精华内容
下载资源
问答
  • CISCO_NAT配置命令

    2014-02-15 15:07:48
    CISCO_NAT配置命令
  • 思科动态nat配置

    2021-12-09 21:14:23
    二、三台pc的配置 四、路由器的配置 Router>en Router#config t Router(config)#int fa0/0 Router(config-if)#ip add 200.1.1.1 255.255.255.0 Router(config-if)#no shut Router(config-if)#exit ...

    动态nat能够自动在配置的地址池里选择内部全局地址,有空闲的内部地址会自动分配利用

    一、拓扑图

    二、三台pc的配置

    四、路由器的配置

    Router>en
    Router#config t 
    Router(config)#int fa0/0
    Router(config-if)#ip add 200.1.1.1 255.255.255.0 
    Router(config-if)#no shut 
    Router(config-if)#exit 
    Router(config)#int fa0/1
    Router(config-if)#ip add 192.168.1.1 255.255.255.0 
    Router(config-if)#no shut 
    Router(config-if)#exit
    Router(config)#int fa0/0
    Router(config-if)#ip nat outside 
                  //配置NAT外部接口
    Router(config-if)#int fa0/1
    Router(config-if)#ip nat inside
                 //配置NAT内部接口 
    Router(config-if)#exit 
    Router(config)#ip nat pool lin 200.1.1.3  200.1.1.4 netmask 255.255.255.0
                 //配置动态NAT地址池
    Router(config)#access-list 1 permit 192.168.1.0   0.0.0.255
                //定义一个标准的ACL,以允许哪些内部地址可以进行动态地址转换
    Router(config)#ip nat inside source list 1 pool lin
                //将ACL指定的内部局部地址与指定的NAT地址池进行关联,完成动态的NAT配置
    Router(config)#end 

    1、开启接口

    2、配置NAT内部与外部接口

    3、配置动态NAT地址池 

                  (pool后面+地址池名字+起始地址+结束地址+netmask +网络掩码)

    4、定义标准的ACL

        (access-list + ACL的标准号(1-99的整数) +permit +源地址+通配符掩码(反向子网掩码))

    5、将ACL指定的内部局部地址与指定的NAT地址池关联

      

    如是在静态nat的基础上做动态nat则需关闭静态nat设置

     如:no ip nat inside source static 192.168.1.2   200.1.1.2

            no ip nat inside source static 192.168.1.2   200.1.1.2

    五、用上面的pc  ping 下面的两台pc

    六、用show ip nat translations 查看

    你的点赞是我最大的动力,

    如有不懂可评论或私信,有问必有答。

    展开全文
  • 思科高级配置(配置动态NAT)

    万次阅读 2019-05-15 20:52:43
    问题 在R1通过动态NAT实现企业内网192.168.0.0/24转换为公网地址201.1.1.2-201.1.1.5,访问200.1...步骤一:动态NAT配置 1)删除静态NAT配置 tarena-R1(config)#no ip nat inside source static 192.168.0.10 201...

    问题
    在R1通过动态NAT实现企业内网192.168.0.0/24转换为公网地址201.1.1.2-201.1.1.5,访问200.1.1.10
    方案
    网络拓扑如图所示:
    在这里插入图片描述

    步骤
    实现此案例需要按照如下步骤进行。

    步骤一:动态NAT配置
    

    1)删除静态NAT配置

    tarena-R1(config)#no ip nat inside source static 192.168.0.10 201.1.1.2
    tarena-R1(config)#no ip nat inside source static 192.168.0.20 201.1.1.3

    2)在R1上配置包括内网所有IP地址的ACL

    tarena-R1(config)#access-list 1 permit 192.168.0.0 0.0.0.255

    3)在R1上配置合法的IP地址池

    地址池是向ISP(Internet服务提供商,如电信、联通)申请得到的,内网主机(上一步ACL中所包含的IP地址)到外网的访问,内网地址将被动态的、随机的转换为这些合法地址。
    tarena-R1(config)#ip nat pool natpool 201.1.1.2 201.1.1.5 netmask 255.255.255.0

    4)关联ACL和合法的IP地址池

    tarena-R1(config)#ip nat inside source list 1 pool natpool

    5)在R1上配置NAT内、外端口

    tarena-R1(config)#interface f0/0
    tarena-R1(config-if)#ip nat inside
    tarena-R1(config-if)#interface f0/1
    tarena-R1(config-if)#ip nat outside

    6)分别在两台PC机上测试到外网主机的通信

    **PC1测试如下所示:
    PC>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2E0:F7FF:FED6:54CC
    IP Address…: 192.168.0.10
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 192.168.0.1
    PC>ping 200.1.1.10
    Pinging 200.1.1.10 with 32 bytes of data:
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Ping statistics for 200.1.1.10:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    PC>
    PC2测试如下所示:
    PC>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2D0:BAFF:FE98:9E29
    IP Address…: 192.168.0.20
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 192.168.0.1
    PC>ping 200.1.1.10
    Pinging 200.1.1.10 with 32 bytes of data:
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Ping statistics for 200.1.1.10:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    PC>

    7)在R1上查看NAT转换表

    转换表中的对应关系是动态的,如192.168.0.10被转换为201.1.1.2,但是下一次对外网的访问很有可能被转换为其他地址。
    tarena-R1#show ip nat translations
    Pro Inside global Inside local Outside local Outside global
    icmp 201.1.1.2:21 192.168.0.10:21 200.1.1.10:21 200.1.1.10:21
    icmp 201.1.1.2:22 192.168.0.10:22 200.1.1.10:22 200.1.1.10:22
    icmp 201.1.1.2:23 192.168.0.10:23 200.1.1.10:23 200.1.1.10:23
    icmp 201.1.1.2:24 192.168.0.10:24 200.1.1.10:24 200.1.1.10:24
    icmp 201.1.1.3:21 192.168.0.20:21 200.1.1.10:21 200.1.1.10:21
    icmp 201.1.1.3:22 192.168.0.20:22 200.1.1.10:22 200.1.1.10:22
    icmp 201.1.1.3:23 192.168.0.20:23 200.1.1.10:23 200.1.1.10:23
    icmp 201.1.1.3:24 192.168.0.20:24 200.1.1.10:24 200.1.1.10:24**

    展开全文
  • cisco中的NAT配置实例

    2008-09-28 13:41:04
    呵呵呵,分享一个nat配置实例,希望对所有学习cisco的朋友有所帮助!!!!!!!! 根据企业的网络环境利用TCP/UDP端口映射的应.......
  • Cisco NAT 配置合集

    2013-09-18 00:49:48
    Cisco NAT 配置合集
  • 思科NAT基础配置

    千次阅读 2020-07-05 16:34:45
    要求配置nat技术server1 ping通server0 server0访问server1布置的web 步骤二: 1)server1配置 IP:192.168.1.8/24 网关:192.168.1.252 2)三层设备ms1配置 ms1(config)#int vlan 1 ms1(config-if)#ip add 192.168...

    步骤一:
    如图拓扑设备,
    要求配置nat技术server1 ping通server0
    server0访问server1布置的web
    在这里插入图片描述
    步骤二:
    1)server1配置
    IP:192.168.1.8/24
    网关:192.168.1.252

    2)三层设备ms1配置
    ms1(config)#int vlan 1
    ms1(config-if)#ip add 192.168.1.252 255.255.255.0
    ms1(config-if)#int f0/5
    ms1(config-if)#no switchport
    ms1(config-if)#ip add 192.168.2.1 255.255.255.0
    ms1(config-if)#no shutdown
    ms1(config-if)#exit
    ms1(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2 //设置静态路由
    ms1(config)#ip routing //开启路由条目

    3)路由器r1配置
    r1(config)#int f0/0
    r1(config-if)#ip add 192.168.2.2 255.255.255.0
    r1(config-if)#no shutdown
    r1(config-if)#int f0/1
    r1(config-if)#ip add 61.159.62.129 255.255.255.248
    r1(config-if)#no shutdown
    r1(config-if)#exit
    r1(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1

    4)server0配置
    IP:61.159.62.134
    掩码:255.255.255.248

    步骤三:
    1)r1 NAT配置 server1 ping通server0
    r1(config)#access-list 1 permit 192.168.1.0 0.0.0.255
    r1(config)#ip nat inside source list 1 interface f0/1 overload
    r1(config)#int f0/1 //对外接口
    r1(config-if)#ip nat outside
    r1(config-if)#int f0/0 //对内接口
    r1(config-if)#ip nat inside

    如图结果
    在这里插入图片描述

    2)r1 IP映射配置 server0访问server1布置的web
    r1(config-if)#ip nat inside source static tcp 192.168.1.8 80 61.159.62.129 80

    如图结果

    在这里插入图片描述

    展开全文
  • 原创,CISCO FTD NAT配置案例,大家共同学习进步。转载请注明楚楚。
  • ip nat pool pool-name start-ip end-ip { netmask network | prefx-length prefix-lengh} 关键字netmask 或prefx-lengh指示哪些地址位于属于网络,哪些位于该地址范围内的主机。 步骤二:配置标准ACL、 范围太宽的...

    步骤一:定义用于转换的地址池

    ip nat pool pool-name start-ip end-ip { netmask network | prefx-length prefix-lengh}
    关键字netmaskprefx-lengh指示哪些地址位于属于网络,哪些位于该地址范围内的主机。

    步骤二:配置标准ACL、

    范围太宽的ACL会导致意料之外的结果。
    每个ACL的结尾都有一条隐式deny all 语句
    可以匹配标准ACL而不是编号ACL
    展开全文
  • 思科模拟器配置文件及其说明,包含三层交换机配置nat的转换、静态路由的配置和acl的相关知识与配置
  • 很实用的实战思科路由器NAT案例配置详解,路由器是利用NAT技术,把内网的多个IP与端口映射 到外网IP(WAN口)的端口进行通讯
  • CISCO NAT配置详解

    2011-09-23 13:29:24
    CISCO路由器NAT功能介绍,具体配置讲解。
  • 思科路由器NAT配置详解s.pdf
  • Cisco NAT 配置指南

    万次阅读 多人点赞 2018-08-05 14:26:20
    NAT的基本知识 NAT(Network Address Translation )技术提供了一种完全将内部网络和Internet网隔离的方法,让内部网络中的计算机通过少数几个甚至一个合法IP地址(已申请的一个公网IP)访问Internet资源,从而节省...
  • Cisco路由器配置NAT的主要命令: 静态NAT: 1、指定NAT内部接口 在内网相应接口的接口配置模式下执行:ip nat inside 2、指定NAT外部接口 在外网相应接口的接口配置模式下执行:ip nat outside 3、在内部...
  • Cisco 静态nat配置

    2020-08-18 16:50:27
    实验拓扑 实验需求 pc8 ping pc9映射的公网地址192.168.1.9 ...对端口进行配置IP 实验步骤 R6 Router(config)#int e0/0 Router (config-if)#ip add 192.168.2.1 255.255.255.0 Router (config-if)#no shut Router
  • 思科路由器NAT配置详解(转)

    万次阅读 2019-08-07 20:23:10
    思科路由器NAT配置详解(转) 网络技术 2010-07-11 17:48:14 阅读104 评论0 字号:大中小订阅 思科路由器NAT配置详解 一、NAT简介: NAT(Network Address Translation)网络地址转换。 最早出现在思科...
  • Cisco静态NAT配置

    千次阅读 2017-11-23 13:29:00
    NAT的含义 NAT英文全称是“Network Address Translation”,中文意思是“网络地址转换”,它是一个IETF(Internet Engineering Task Force, Internet工程任务组)标准,允许一个整体机构以一个公用IP(Internet ...
  • Cisco ASA防火墙配置NAT

    千次阅读 2019-05-28 22:03:30
    在ASA防火墙配置NAT分为4种类型:动态NAT动态PAT、静态NAT、静态PAT。 结合实验拓补来了解如何配置这四种NAT类型: 基本配置已经配置完成动态PAT转换配置方法: ASA(config)# nat (×××ide) 1 10.1.1.0 255....
  • 思科防火墙nat 命令配置

    千次阅读 2019-08-19 19:47:59
    1.ASA一对一的NAT配置 分析现在内网不能PING外网有两方面原因 1:在路由层面(内网的设备没有外网的路由,外网的设备没有内网路由) 2:ASA防火策略层面(当外网的OUTSIDE去访问INSIDE接口时候会拒绝访问。 1...
  • 静态NAT转换 采用如图所示的结构,每个端口配置如下的ip 首先得理解这个结构,r4的s2/0端口和r6和pc8共同组成外网 r4的f0/0和交换机s2以及pc6 pc7组成内网, 因此配完ip后,还得保证r4能ping通pc8 同样pc8也能ping...
  • cisco配置动态NAT实验

    千次阅读 2009-12-01 17:12:52
    今天为大家演示的是动态NAT:首先要定义合法地址池,然后采用动态分配的方法映射到内部网络。动态NAT动态一对一的映射。 动态NAT拓扑: IP地址规划: R1--F0/0=202.96.1.1/24 ---F0/1=192.168.1.254/24...
  • 思科防火墙ASA5520 外观网络拓扑图如下内网 网段 192.168.2.0/24公网IP地址 118.25.235.100公网IP地址网关:118.25.235.1.1防火墙内网IP:192.168.2.1/24配置步骤:1、基本配置配置内外网接口 conf t hostname ASAFW...
  • 公司路由器配置: R1(config)# interface FastEthernet 0/0 R1(config-if)# ip address 10.1.1.1 255.255.255.0 R1(config-if)# no shutdown R1(config-if)# ip nat outside 启用外网NAT 转换 R1(config-if)# ...
  • 思科模拟器CIsco Packet Tracer网络地址转换 NAT 配置

    万次阅读 多人点赞 2018-12-07 11:11:13
    动态 NAT:定义一个地址池,自动映射,也是一对一的。现实中,用得比较少; NAPT:使用不同的端口来映射多个内网 IP 地址到一个指定的外网 IP 地址,多对 一。 2.拓扑图 3.配置PC和服务器IP地址 Server...
  • 思科路由器静态NAT配置

    千次阅读 2019-04-24 16:40:28
    2、R5配置SNAT命令行 #进入config节点 R5#configure terminal Enter configuration commands, one per line. End with CNTL/Z. #配置接口IP R5(config)#interface Ethernet 1/0 R5(config-if)#ip address 11.11....
  • 静态路由和DHCP/NAT配置实例配套视频刘辉:02-静态路由和DHCP/NAT配置实例​zhuanlan.zhihu.com实验描述:1. AR1 为公司总部出口路由器,申请了一个12.1.1.0/27 的公网IP 地址 AR3 为公司分支出口路由器 ,申请...
  • 通过配置过载NAT从而实现企业内网正常访问公网,PC2可以正常ping通server,但是无法访问server的HTTP服务器,PC1正常。 二.实验拓扑图 ​ 三.实验过程 首先给PC1、PC2添加ip、子网、网关、D...
  • 以下内容摘自刚刚上市,史上最全面、最系统的的四本大型(每本平均近900页)网络设备新书之一《H3C路由器配置与管理完全手册》(第二版),其它三本分别是:《Cisco交换机配置与管理完全手册》(第二版)、《Cisco路由器...
  • Cisco ASA 应用NAT配置详解

    千次阅读 2019-04-28 07:10:52
    ASA 防火墙上NAT的基本原理与路由器上一样,只不过只用定义一下内网地址和进行...1、动态NAT(可以说是一对一,但不是静态的,一般不使用动态NAT)的配置步骤如下: 将内网10.0.0.0/8进行NAT转换为170.16.1.100~1...
  • 思科路由器上实现NAT实例(设置企业WEB服务器)

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,177
精华内容 4,470
关键字:

思科动态nat配置