精华内容
下载资源
问答
  • 思科静态路由

    千次阅读 2018-05-02 19:40:58
    #拓扑结构1、CISCO静态路由配置命令Router(config)#ip route destination destination_mask〔IP_address}FastEthernetnumber{Loopback number}Serialnumber]metric]其中destination代表目的网络的网络IP地址...

    #拓扑结构

    1、CISCO静态路由配置命令

    Router(config)#ip route destination destination_mask〔IP_address}FastEthernetnumber{Loopback number}Serialnumber]metric]

    其中destination代表目的网络的网络IP地址或者主机的IP地址,destination mask是目的网络的子网掩码或者目的主机的子网掩码。

    2、华为静态路由配置命令

    在路由器上增加静态路由命令为IP ROUTE.下面,我们将介绍如何用IP ROUTE命令来添加路由,以及IP ROUTE的各项参数。

    IP ROUTE是在系统视图下使用的命令,其完整语法格式如下:

    [Quidway] ip route-static ip-address{mask{masklen}{interface-type interfacce-name}nexthop-address}[preference value][reject | blackhole]

    命令中各参数解释如下:

    目的地址( ip-ddress ):用来标识数据包的目标地址或目标网络,当目的地址和掩码均为0.0.0.0时,配置的缺省路由,即当查找路由表失败后,根据缺省路由进行数据包的转发。

    网络掩码(<mask> | <masklen> ):和目标地址一起来标识目标网络。把目标地址和网络掩码逻辑与,即可得到目标网络。例如:目标地址为129.102.9.10,掩码为255.255.0.0,目标网络为129.102.0.0;由于要求掩码32位中"1”必须是连续的。因此点分十进制格式的掩码可以用掩码长度mask-length来代替,掩码长度为掩码中连续“1”的位数,就是mask-length。

    下一跳地址(nexthop-address):说明数据包所经由的下一跳地址。在一般情况下都会用nexthop-address配置路由,interface-name会自动生成。但如果在某些情况下无法知道下一跳地址,如拨号线路在拨通前是可能不知道对方甚至自己的IP地址的,在此种情况下必须要用Interface配置路由。

    preference关键字用于指定本条静态路由加入路由表的优先级(preference-value)。范围为0-255。在Quidway路由器中,静态路由的缺省优先级是60, RIP的优先级是100, OSPF的优先级是10,接口上直接相连网络的路由优先级最高,总是0。用户可以配置多条到同一目的地但优先级不同的路由。路由器将按照优先级的顺序从中选取唯一的一条加入到路由表中去供转发数据决策用。如配置到达相同目的地的多条路由,如果指定相同优先级,则可实现负载分担;如果指定不同优先级,则可实现路由备份。

    目的地不可达的路由(reject):当到某一目的地的静态路由具有reject属性时,任何去往该目的地的IP报文都将被丢弃,并且通知源主机目的地不可达。

    目的地为黑洞的路由(blackhole ):当到某一目的地的静态路由具有blackhole属性时,任何去往该目的地的IP报文都将被丢弃,也不向数据源发送任何错误消息,象一个黑洞一样。reject和blackhole属性一般用来控制本路由器可达目的地的范围。

    3、缺省路由

    简单地说,缺省路由就是在没有找到匹配的路由表入口项时才使用的路由。即只有当没有合适的路由时,缺省路由才被使用。在路由表中,缺省路由以到网络0.0.0.0/0的路由形式出现。用0.0.0.0作为目标网络号,用0.0.0.0作为子网掩码,所有的网络都会和这条路由记录符合。每个IP地址与0.0.0.0进行二进制“与”操作后的结果都得。,与目标网络号0.0.0.0相等。也就是说用0.0.0.0/0作为目标网络的路由记录符合所有的网络,我们称这种路由记录为缺省路由或默认路由。



    Router>en

    Router#conf t

    Router(config)#int g0/0

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.2.10 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#int g0/1

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.1.11 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.2.11

     

     

     

     

     

    Router>en

    Router#conf t

    Router(config)#int g0/0

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.2.11 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#int g0/1

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.3.10 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#ip route 10.1.1.0 255.255.255.0 10.1.2.10

    Router(config)#ip route 10.1.4.0 255.255.255.0 10.1.3.11

     

     

    Router>en

    Router#conf t

    Router(config)#int g0/0

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.3.11 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#int g0/1

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.4.11 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.3.10



    展开全文
  • 思科静态路由配置

    2014-10-15 14:32:07
    思科静态路由配置
  • 思科静态路由协议

    2019-09-01 16:30:17
    思科静态路由协议 ** 1.规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...

    **

    思科静态路由协议

    **
    1.规划网段(路由是隔离网段的)
    在这里插入图片描述

    1. 配置每个节点IP地址。
      

      R0
      Router(config)#interface f0/0
      Router(config-if)#no shutdown
      Router(config-if)#ip address 192.168.10.1 255.255.255.0
      Router(config-if)#exit
      Router(config)#interface f0/1
      Router(config-if)#ip address 192.168.20.1 255.255.255.0
      Router(config-if)#no shutdown
      R1
      Router(config)#interface f0/0
      Router(config-if)#no shutdown
      Router(config-if)#ip address 192.168.20.2 255.255.255.0
      Router(config-if)#exit
      Router(config)#interface f0/1
      Router(config-if)#no shutdown
      Router(config-if)#ip address 192.168.30.1 255.255.255.0
      Router(config-if)#exit
      R2
      Router(config)#interface f0/0
      Router(config-if)#no shut
      Router(config-if)#ip address 192.168.30.2 255.255.255.0
      Router(config-if)#exit
      Router(config)#interface f0/1
      Router(config-if)#no shutdown
      Router(config-if)#ip address 192.168.40.1 255.255.255.0
      三:我们要搞清楚为什么不通,以及通的条件是什么?
      在这里插入图片描述

    路要修得怎么样(条件)网络才会通。
    每台三层设备都要用所有网段的路由表网络才会全通。
    如何使用路由协议去修路
    Router(config)#ip route 192.168.30.0 255.255.255.0 下一跳地址
    源:你在哪台设备上配置的路由器,这台路由器就作为源。
    目的:你添加的网段就作目的。
    下一跳地址:从源出发到目的遇到的第一个IP地址就作为下一跳地址。
    Ro:
    ip route 192.168.30.0 255.255.255.0 192.168.20.2
    ip route 192.168.40.0 255.255.255.0 192.168.20.2
    R1
    ip route 192.168.10.0 255.255.255.0 192.168.20.1
    ip route 192.168.40.0 255.255.255.0 192.168.30.2
    R2
    ip route 192.168.10.0 255.255.255.0 192.168.30.1
    ip route 192.168.20.0 255.255.255.0 192.168.30.1
    以上这种协议是静态路由协议。
    静态路由协议:
    1. 缺点配置麻烦(我要知识这这个拓扑图有几个网段。
    2. 在下一跳找不准。
    优点:不占用CPU和内存资源。

    展开全文
  • 思科静态路由设置

    2019-10-18 18:38:39
    GNS3实验|静态路由的设置(三台虚拟机通过四台路由器进行互联互通) 首先,我们打开GNS3系统,进入编辑界面: [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-1j2bTLiy-1571395091233)(C:\...

    GNS3实验|静态路由的设置(三台虚拟机通过四台路由器进行互联互通)

    首先,我们打开GNS3系统,进入编辑界面:
    在这里插入图片描述
    1.放上三台虚拟机,分别以HOST;HOST2;HOST3命名。
    在这里插入图片描述
    在这里插入图片描述
    2.放置四台路由器,分别是R1,R2,R3,R4:
    在这里插入图片描述

    3.为了能让设备正常通信,需增加些许内存,个人设置了128MIB,四台以相同步骤操作:
    在这里插入图片描述
    在这里插入图片描述
    4.通过设备连接线将三台虚拟机与四台路由器连接,因为R2路由器需连接三个虚拟机,则需要三个接口,路由器设备初始为两个,所以需添加一个单板:
    在这里插入图片描述
    在这里插入图片描述
    5.先将HOST1与R1连接,HOST1选择VMNet1网卡,R2选择0/0接口:

    在这里插入图片描述

    在这里插入图片描述

    6.以此类推,R1f0/1接R2f0/0,R2f0/1接R3f0/0,R3f0/1接HOST2的VMnet2;R2f1/0接R4f0/0,R4f0/1接Host3的VMet3;接完后点击下图工具即可显示端口名称:

    在这里插入图片描述

    7.这样网络拓扑即搭建完成,接下来点击下图工具给每个端口设计IP地址,设计完后点击开始,绿灯全量即可继续下一步操作,如下图所示:
    在这里插入图片描述

    9.接下来双击R1路由器,弹出CRT远程连接工具,开始进行操作:
    在这里插入图片描述

    10.给R1路由器对着两个接口进行有效的配置;R1的两个端口分别是f0/0;IP:192.168.10.2/24f0/1;IP:192.168.20.3/24 。所以,我们先进入f0/0的接口模式,输入configure先进入全局模式然后输入interface fastEthernet 0/0进入f0/0的接口模式,如下图:
    在这里插入图片描述
    11.进入f0/0的接口模式后,输入ip address 192.168.10.2 255.255.255.0,确认后输入no shut即可录入f0/0接口的ip地址,接着返回全局模式,输入exit;再进入f0/1的接口模式,与进入f0/0的相同步骤输入即可,如下图:
    在这里插入图片描述
    12.这时为了确定ip地址是否生效,我们先输入end进入特权模式,然后输入show ip interface brief即可查看:
    在这里插入图片描述
    13.可以看出接口与ip地址已经生效。同理,用相同的步骤给R2,R3和R4路由器分别进行配置:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    14.这时四台路由器的地址已配置完成,接下来给三台虚拟机进行配置。我们打开VMware Workstation Pro虚拟机,并打开已经安装好并激活成功的三台win10-1,win10-2,win10-3系统:
    在这里插入图片描述
    在这里插入图片描述
    15.首先进行网卡绑定。先打开win10-1系统,点开右下角的设置,选择网络适配器,在自定义上选择VMnet1(仅主机模式);同理,在win10-2与win10-3上进行同样的操作;win10-2选择VMnet2;win10-3选择VMnet3;
    在这里插入图片描述
    在这里插入图片描述
    16.接着配上地址:进入win10-1系统,打开网络,点击网络并点击网络和共享中心,点击更改适配器设置,找到属于这台虚拟机的网络并右击点开属性;选择第四项并点开属性,勾选使用下面的IP地址,即HOST1的地址:192.168.10.1并把子网掩码和默认网关即R1f0/0的地址:192.168.10.1输入进去,点击确定。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    同理,把win10-2和win10-3的配置设置完成。
    在这里插入图片描述
    在这里插入图片描述
    17.此时我们联通完毕,如果不放心,可以测试一下;在win10-1虚拟机中搜索命令提示符并打开;输入 ping 192.168.10.2,如图所示,可以联通。win10-2与win10-3用相同步骤测试。
    在这里插入图片描述
    在这里插入图片描述
    18.为了能够顺利的互联互通,我们选择将虚拟机中的防火墙进行关闭:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    win10-2与win10-3已相同步骤进行关闭。

    18.想要顺利的让三台虚拟机能够互相通信,我们需要可以提供查找目标网络,从而确定转发接口及下一跳网关的路由器,因此我们将对R1,R2,R3,R4这四台路由器进行配置:
    在这里插入图片描述
    19.首先,打开R1路由器CRT界面,给R1路由器设置静态路由,即添加它的非直连网段以及下一跳地址,如图所示:
    在这里插入图片描述
    然后我们可以通过命令:do show ip route来确认;同理,给R2,R3,R4路由器进行配置:
    在这里插入图片描述
    在这里插入图片描述

    在这里插入图片描述
    在这里插入图片描述
    20.设置完毕后,即可让三虚拟机进行正常通信;我们已经ping下三台虚拟机进行验证:
    在这里插入图片描述
    在这里插入图片描述
    可以确认,静态路由设置完成。

    展开全文
  • 思科静态路由和动态路由部署

    千次阅读 2019-03-19 12:24:59
    网络括谱图 静态路由网络部署 Router0配置如下 Router>enable #进入特权模式 Router#configure terminal #进入全局配置模式 Enter confi...

    网络括谱图

     

    2019-03-19_104925.png

     

    静态路由网络部署

    Router0配置如下

    Router>enable                 #进入特权模式                                                              

    Router#configure terminal           #进入全局配置模式

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#interface FastEthernet0/0

    Router(config-if)#ip address 192.168.11.1 255.255.255.0                        #配置对应端口IP

    Router(config-if)#no shutdown   #开启端口

    Router(config-if)#exit

    Router(config)#interface FastEthernet0/1

    Router(config-if)#ip address 192.168.12.1 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#interface FastEthernet0/0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#ip route 192.168.13.0 255.255.255.0 192.168.12.2                           #配置静态路由(即手动指定去某个网段路径)

    Router(config)#ip route 192.168.14.0 255.255.255.0 192.168.12.2

     

    Router1配置如下

    Router>enable

    Router#configure terminal

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#interface FastEthernet0/0

    Router(config-if)#ip address 192.168.12.2 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#interface FastEthernet0/1

    Router(config-if)#ip address 192.168.13.1 255.255.255.0

    Router(config-if)#shutdown

    Router(config-if)#exit

    Router(config)#ip route 192.168.11.0 255.255.255.0 192.168.12.1          #配置静态路由(即手动指定去某个网段路径)

    Router(config)#ip route 192.168.14.0 255.255.255.0 192.168.13.2

     

    Router2配置如下

     

    Router>enable

    Router#configure terminal

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#interface FastEthernet0/0

    Router(config-if)#ip address 192.168.13.2 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#interface FastEthernet0/1

    Router(config-if)#ip address 192.168.14.1 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#ip route 192.168.12.0 255.255.255.0 192.168.13.1                                       #配置静态路由(即手动指定去某个网段路径)

    Router(config)#ip route 192.168.11.0 255.255.255.0 192.168.13.1

    Router(config)#interface FastEthernet0/0

    Router(config-if)#do show ip route

    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

    * - candidate default, U - per-user static route, o - ODR

    P - periodic downloaded static route

     

    Gateway of last resort is not set

     

    S    192.168.11.0/24 [1/0] via 192.168.13.1

    S    192.168.12.0/24 [1/0] via 192.168.13.1

    C    192.168.13.0/24 is directly connected, FastEthernet0/0

    C    192.168.14.0/24 is directly connected, FastEthernet0/1

     

    动态路由网络部署

    Router0

    Router(config)#no ip route 192.168.14.0 255.255.255.0 192.168.12.2                 #关闭静态路由(即指示对应网段的路径)

    Router(config)#no ip route 192.168.13.0 255.255.255.0 192.168.12.2

    Router(config)#router rip

    Router(config-router)#network 192.168.11.0                                           #配置动态路由(即将直连网段宣告出去)

    Router(config-router)#exit

    Router(config)#router rip

    Router(config-router)#network 192.168.12.0

     

    Router1

    Router(config)#no ip route 192.168.14.0 255.255.255.0 192.168.12.2           #关闭静态路由

    Router(config)#no ip route 192.168.13.0 255.255.255.0 192.168.12.2

    Router(config)#router rip

    Router(config-router)#network 192.168.11.0                                        #配置动态路由(即将直连网段宣告出去)

    Router(config-router)#exit

    Router(config)#router rip

    Router(config-router)#network 192.168.12.0

     

    Router2

     

    Router(config)#no ip route 192.168.14.0 255.255.255.0 192.168.12.2           #关闭静态路由

    Router(config)#no ip route 192.168.13.0 255.255.255.0 192.168.12.2

    Router(config)#router rip

    Router(config-router)#network 192.168.11.0                                               #配置动态路由(即将直连网段宣告出去)

    Router(config-router)#exit

    Router(config)#router rip

    Router(config-router)#network 192.168.12.0

     

     

     

    展开全文
  • 静态路由与IP SLA 路由联动实现线路故障自动切换一、组网需求1、 单位需要与外联单位网络互通2、 为了冗余网络,单位向运营商租用两条专线与外联单位互连3、 两条专线线路为主备模式,主R1--R2,当主线路故障自动切换...
  • 组网要求某公司内部网络,如 图 1所示,从Device A到Device B有两条转发路径,下一...假设Device B不支持BFD,要求在Device A上使用静态路由与BFD联动技术,实现当Device B与二层交换机L2 Switch之间的链路出现故障...
  • 思科静态路由配置简单命令

    千次阅读 2020-05-16 22:00:58
    路由器配置IP en 进入用户模式 config interface f+tab键 || interface s+tab键 启用接口模式 紧跟着写上端口号0/0 || 1/0 ip address <子网掩码> 配置IP no shutdown 配置IP route en 进入用户模式 ...
  • NQA还提供了与Track和应用模块联动的功能,实时监控网络状态的变化,及时进行相应的处理,从而避免通信的中断或服务质量的降低 今天 我们主要先关注一下如何使用NQA实现静态路由切换。静态路由中,对于非直连检测是...
  • 思科路由器dhcp 架设实验拓扑图:思科路由器 dhcp 架设3.配置思路 :首先给终端配置pc5配置一个测试的地址,其次再给switch3 ,switch 1,router1 配置 ip 地址,最后使pc5,pc6都可以4. 配置步骤: # 给pc5配置 ip...
  • 思科静态路由生产环境实例

    千次阅读 2015-07-14 17:11:42
    静态路由设置实例解析(图文) 今天公司添加了一台新的打印机但是由于没有多余的网口来给打印机分配IP地址所以自己就找了一个小路由器单独配置了一个基于串联双路由的模式配置实现了不同网段访问共享打印机。接...
  • BFD(Bidirectional Forwarding Detection,双向转发检测)是一个通用的、标准化的...BFD可以为各种上层协议(如路由协议)快速检测两台设备间双向转发路径的故障。上层协议通常采用Hello报文机制检测故障,所需时间为秒...
  • 静态路由静态路由无疑是最简单,也是最基本的。Ip route-static(指定是静态路由) 10.1.2.0 255.255.255.0(目的地和子网掩码,你旅游景点) 10.1.4.2(默认网关,就是你家大门)。默认网关就是无论你去哪里...
  • BFD广泛用于链路故障检测,并能实现与接口、静态路由、动态路由等联动检测。一、BFD检测原理1、BFD会话流程的建立,BFD的会话建立有两种方式:静态和动态。在BFD的会话的建立过程中,会有本地标示...
  • 点击蓝字关注我们思科安全管理器(Cisco Security Manager)是一个企业级安全管理应用程序,可监控和管理思科的安全和网络设备,包括Cisco ASA自适应安全设备、Cisco IPS系列传感器设备、Cisco集成服务路由器(ISR)、...
  • 原标题:【实验篇】如何利用BFD与浮动路由联动实现链路自动切换?...2、了解、掌握BFD配置、BFD如何联动静态路由。1 拓扑图(若看不清,可单击图片,放大查看)2 需求(目的)1、测试浮动路由未联动BFD和联动BFD...
  • 点击蓝字关注我们静态路由故障诊断也许你听过这样的问题,“他知道什么?他什么时候知道的?”这些问题对于网络调查员也同样适用。当排除路由故障时,首要的一步就是检查路由表。路由器知道什么?这些信息在路由表中...
  • 按照官网文档,C7609配置BFD的大概步骤如下:1、在接口下配置bfd和相关参数:interface gx/xbfd interval 400 min_rx 400 multiplier 52、配置静态路由bfd:ip route static bfd gx/x 下一跳地址(静态路由的下一跳...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 431
精华内容 172
关键字:

思科静态路由