精华内容
下载资源
问答
  • 后台运行 实际上要一个应用后台运行,在输入命令的时候加上 “&” 符号就可以了,向下面 helloworld & 开启自启动 开机自启动这好像还是挺多方法的,一个是在 /etc/init.d目录编写文件,一个是在网页上的...

    openwrt 的自启动和 Linux 差不多,下面简单讲讲

    后台运行

    实际上要一个应用后台运行,在输入命令的时候加上 “&” 符号就可以了,向下面

    helloworld &
    

    开启自启动

    开机自启动这好像还是挺多方法的,一个是在 /etc/init.d目录编写文件,一个是在网页上的开机运行脚本上加上上面后台运行的命令。

    编写自启动脚本

    在 openwrt 开发板命令行中输入

    vi /etc/init.d/mystart
    

    里面输入如下内容:

    #!/bin/sh /etc/rc.common
    START=99
    STOP=15
    
    start(){
        echo start helloword
        helloword &
    }
    
    stop(){
        echo stop helloword
    }
    
    restart(){
        echo restart helloword
    }
    
    enable(){
        echo enable helloword
    }
    
    disable(){
        echo disable helloword
    }
    
    

    命令应该很好理解,前面 START 和 STOP 是启动和关闭的优先级。

    下面是另一种自启动脚本的写法,应该是差不多,注释写的也挺清楚了

    #!/bin/sh /etc/rc.common
    
    START=99 # 执行的顺序,按照字符串顺序排序并不是数字排序
    STOP=15
    SERVICE=helloword
    PROG=/bin/helloword
    USE_PROCD=1 # 使用procd启动
    
    # start_service 函数必须要重新定义
    start_service()
    {
        echo service helloword start
        procd_open_instance  # 创建一个实例, 在 procd 看来一个应用程序可以多个实例
        # ubus call service list 可以查看实例
        procd_set_param command $PROG # mycode执行的命令是"/app/mycode", 若后面有参数可以直接在后面加上
        procd_set_param respawn # 定义respawn参数,告知procd当mycode程序退出后尝试进行重启
        # procd_close_instance # 关闭实例
    }
    
    

    编写完文件后还应该记得改一下权限,让脚本能够执行

    cd /etc
    chmod -R 777 init.d/mystart #设置权限,否则无法激活开机启动,提示权限不足
    

    使用的时候按下面输入命令就可以,和普通服务类似

    /etc/init.d/mystart enable #激活开机启动
    /etc/init.d/mystart start #运行start函数启动程序
    
    在网页上配置自启动

    由于这项目是上一家公司的时候开发的了,都快一年了,源码都在之前公司的笔记本电脑里面,自己电脑没源码,就简单讲讲。

    先要打开 openwrt 的网页控制界面,里面找到自启动功能,在里面的文本行中加入下面命令

    helloword &
    

    实际上使用起来,好像在网页上配置的自启动还好一些,用配置文件写的但是还总出错,当时是对4G上网模块有影响,具体记不清了。当时分析出错的原因是,用配置文件写的命令在软件被停止后会尝试重新启动,当然如果你没遇到这些问题,两种方法都是可以的。

    自启动进阶

    网上的博客一般到这里就完了,可是我当时不想做差不多先生,我将自启动脚本写到我们的源码文件中去,在安装的时候就给自动弄好,简单省事,下面看看写法。

    • 先编写配置文件

    这里再源码目录总编写我们的自启动脚本文件,以上一篇的 helloword 为例

    mkdir ~/openwrt/package/hellworld/auto
    cd  ~/openwrt/package/hellworld/auto
    

    这里新起了一个目录来存放我们的配置文件,内容和上面一样,不说了。

    接下来的重点是编写外层的 Makefile 文件,在复制那一段将我们的配置文件复制到 /etc/init.d/ 目录中去

    define Package/helloword /install
    	echo "Here is Package/install"
    	$(INSTALL_DIR) $(1)/bin $(1)/etc/init.d/
    	$(INSTALL_BIN) $(PKG_BUILD_DIR)/helloword $(1)/bin/
    	$(INSTALL_BIN) ./auto/mystart $(1)/etc/init.d/
    endef
    

    注意这里的 $(INSTALL_BIN),复制的是二进制文件,权限问题我忘了,如果启动不了,也还是按上面的方法增加运行权限吧。

    结语

    到这里应该把我脑子里记得的东西讲的差不多了。

    end
    完美撒花

    展开全文
  • OpenWRT运行Sakura Frp

    千次阅读 2020-09-30 12:28:10
    通过Sakura Frp远程访问路由WEB界面 创建隧道安装FrpcOpenWRT上传文件运行Frpc后台运行Frpc开机自动启动Frpc Sakura Frp非常好用,但是如果在OpenWRT上自动运行,作为一个小白还是折腾了许久,因此写下详细过程 创建...

    Sakura Frp非常好用,但是如果在OpenWRT上自动运行,作为一个小白还是折腾了许久,因此写下详细过程

    创建隧道

    首先你要创建一个隧道并映射80端口,这样你才可以访问你的路由界面
    在这里插入图片描述
    建立后将你的隧道配置文件保存为Frpc.ini备用

    安装Frpc

    将路由器系统升级到了最新的OpenWRT之后,非常尴尬的发现,啥也没有了,以前用惯的明月永在系统确实是非常贴心,什么功能都内置好了,但是现在只能从头再来.
    首先搜索了一通,opkg找不到这个软件,然后在github上找到了下载页面,可惜没有已编译好并且能适合我的路由器型号的版本可供下载,尝试用源码编译…好吧,还是放弃了
    换一种思路,既然不能使用安装方法,那么直接运行BIN程序如何?
    查询处理器架构命令:

    root@OpenWrt:~# cat /proc/cpuinfo
    

    根据结果

    cpu model		: MIPS 74Kc V4.12
    isa			: mips1 mips2 mips32r1 mips32r2
    

    下载Sakura Frp已编译好的版本并上传到/usr/sbin/文件夹:
    Sakura Frp软件下载页面
    下载这个版本:Linux (Mips)
    或者下载原版:
    https://github.com/fatedier/frp/releases
    原版已打tar包,需要解压出Frpc执行文件,然后上传到/usr/sbin/文件夹

    OpenWRT上传文件

    作为一个小白,一帆顺是不可能的,如何上传文件呢
    首先下载Xshell,然后打开Xsell
    在这里插入图片描述
    连接成功后输入命令

    root@OpenWrt:~# opkg update
    

    等待执行完毕后安装lrzsz,可以直接拖拽上传文件

    root@OpenWrt:~# opkg install lrzsz
    

    安装完成后进入/usr/sbin/

    root@OpenWrt:~# cd /usr/sbin/ 
    

    直接拖拽上传(Frcp,Frpc.ini)
    在这里插入图片描述

    运行Frpc

    程序已经上传成功,运行一下看效果如何

    root@OpenWrt:/usr/sbin# ./frpc
    

    果然隧道已经在线,通过http://服务器网址:端口号/便可以访问你的路由器了
    但是关闭Xshell,程序便会停止运行,应该如何解决这个问题呢?

    后台运行Frpc

    安装screen支持后台运行

    root@OpenWrt:~# opkg install screen
    

    运行screen,新建名为frpc的会话

    root@OpenWrt:~# screen -S frpc
    

    运行Frpc

    root@OpenWrt:/usr/sbin# ./frpc
    

    运行成功后,离开会话(会话中的程序不会关闭,仍在运行)快捷键Ctrl+a d(即按住Ctrl,依次再按a,d)
    此时关闭Xshee,Frpc不会停止,仍在后台运行

    开机自动启动Frpc

    Frpc已经后台运行了,但是如果路由重启了,并不能自动运行,因此需要将Frpc加入启动项实现开机自启
    首先,创建一个启动脚本

    root@OpenWrt:/etc/init.d# vim /etc/init.d/startFrpc 
    #!/bin/sh /etc/rc.common
    START=99
    STOP=15
    
    start() {
      echo start
      cd /usr/sbin
      frpc
      #commands to launch application, such as above
    }
    
    stop() {
      echo stop
      #commands to kill application
    }
    

    按esc键,输入 :wq 保存退出
    添加可执行权限

    root@OpenWrt:/etc/init.d# chmod +x /etc/init.d/startFrpc
    

    建立启动链接

    root@OpenWrt:/etc/init.d# ln -s /etc/init.d/startFrpc /etc/rc.d/s99startFrpc
    

    查看启动状态

    root@OpenWrt:/etc/init.d# for F in /etc/init.d/* ; 
    do $F enabled && echo $F on || echo $F **disabled**; done
    

    按理说到这里应该结束了,但是小白毕竟是小白,重启以后发现在隧道并没有自动运行,因此有了一下步操作
    OpenWRT系统菜单-启动项-本地启动脚本( /etc/rc.local)加入以下内容

    /etc/init.d/startFrpc start
    

    修改后如下

    # Put your custom commands here that should be executed once
    # the system init finished. By default this file does nothing.
    /etc/init.d/startFrpc start
    exit 0
    

    果断reboot,成功自启

    展开全文
  • 在自己的Openwrt路由器上部署了一个小型的Python服务器。用于提供服务。 我们的需求是开机时自动启动这个服务。实现步骤如下: python 服务器脚本的保存在:/etc/kaihei_server.py为了实现自动后台启动,在/etc/rc....

    在自己的Openwrt路由器上部署了一个小型的Python服务器。用于提供服务。 我们的需求是开机时自动启动这个服务。

    实现步骤如下:
    python 服务器脚本的保存在:

    /etc/kaihei_server.py

    为了实现自动后台启动,在/etc/rc.local中添加代码

    nohup python /etc/kaihei_server.py >/dev/null 2>&1 &

    解释一下,nohup用于实现程序的后台运行,和screen很像。但是screen经过我的实验无法用在启动脚本中。

    - >/dev/null 表示将程序的输出重定向到/dev/null这样一个系统垃圾桶中
    - 2>&1 表示系统错误输出(用2代表)stderr的重定向方式和标准输出(用1代表)stdout的方式一样。 &1表示和1一样
    - 最后一个&表示程序在后台运行。

    nohup程序默认并没有安装在Openwrt中。
    需要运行如下代码:

    opkg update
    opkg install coreutils-nohup

    关于nohup输出重定向的更多信息,请参考:
    http://www.cnblogs.com/taosim/articles/2610170.html

    展开全文
  • 本文主要目的在于让你的路由器能自动连接学校的校园网并且能发出WIFI让所有设备使用。...但是这篇文章稍作迁移可以应用到其它的学校网络,以及其它所有可以安装OpenWRT的路由器,只要你能动一下自己的小头和小手。

    注意:本文所有的最新更正请全部前往http://blog.reetsee.com/archives/227查看。


    本文主要目的在于让你的路由器能自动连接学校的校园网并且能发出WIFI让所有设备使用。要注意的是这篇作者呕心沥血写的超级傻瓜教程是主要针对中山大学东校区使用H3C客户端(例如iNode)连接校园网的同学。但是这篇文章稍作迁移可以应用到其它的学校网络,以及其它所有可以安装OpenWRT的路由器,只要你能动一下自己的小头和小手。

    Step 0 : 为什么要这么做?

    (注:这个教程理论上可以应用到其它能装上OpenWRT系统的路由器。)虽然电脑可以将校园网发WIFI供其它设备使用,但是这样始终不方便,要开机,要输入start hostednetwork等命令比较麻烦,不如一步到位直接买个便宜一点的路由器发WIFI好了,WR703N就是一个比较不错的选择。注意以下安装过程主要针对中山大学东校区使用H3C客户端(iNode)连接校园网的同学。

    Step 1 : 下载OpenWRT针对WR703N的版本

    先到http://wiki.openwrt.org/toh/tp-link/tl-wr703n#flashing官方页面下载squashfs-sysupgrade.bin(这个版本不带LuCi,一个图形界面管理路由器的程序,可以下载另外一个squashfs-factory.bin就是自带了)。下载完成后将其重命名为openwrt.bin(因为长的文件名可能会导致升级出错)

    Step 2 : 为WR703N安装上OpenWRT

    将WR703N接上电源之后,就会发出wifi了,发出的wifi名字应该是TP-LINK-xxxxxx之类的。连接后在浏览器访问“192.168.1.1”,输入默认密码“admin”,然后在左边找到“系统工具”->“软件升级”,点击“浏览”,找到刚才的openwrt.bin,然后确定,问是否确定升级点是就可以了。等待进度条读完。

    Step 3 : 第一次连接到OpenWRT

    这个时候进度条已经读完了,找一根网线连接你的WR703N和你的电脑,然后如果电脑的系统是类Unix系统(包括MAC OS X)在控制台中输入

    telnet 192.168.1.1

    如果是 Windows系统,那么就下载 putty并运行,连接地址(Host Name(or IP address))填“192.168.1.1”,连接类型(Connection type:)是“Telnet”,端口(Port)填“22”,连接后,用户名输入“root”。

    Step 4 : 设置以后连接到WR703N系统的密码

    成功后就进入WR703N的控制台了,输入命令

    passwd root

    来修改WR703N的密码,记住这个密码需要具备一定的复杂性,如果你在修改过程中弹出类似“bad password”之类的字眼,证明修改失败,重新输入passwd root来修改吧。

    Step 5 : 第一次安全连接到WR703N

    修改成功后输入命令exit,对于类Unix系统的用户,这个时候再用“telnet 192.168.1.1”就无法连接上去了,这个时候必须使用ssh登陆。运行这个命令

    ssh root@192.168.1.1

    很多人会忘记“root@”导致登陆失败。输入密码成功登陆显示欢迎界面。注意:以后你可能因为自己的误操作或者其它原因,会提示“Host key verification failed”之类的字眼,如果是使用类unix系统,那么久前往~/.ssh下,打开know_hosts文件,删除开头为192.168.1.1的那行,保存并退出然后重新ssh root@192.168.1.1即可。

    对于Windows系统用户,要连接只需要将连接类型从“Telnet”改为“SSH”就可以了。

    Step 6 : 让WR703N发出WIFI

    成功连接到WR703N后运行以下命令

    cd /etc/config

    ,然后运行命令
    vi wireless

    。这里可能有人不知道vi这个编辑软件怎么用,这里先说最基本的知识,vi有两个常用模式,一个是普通模式(初始默认的模式),另外一个是编辑模式(就是可以像文本编辑器一样输入删除文字的)首先大家按“i”这个键进入输入(input)模式,像使用普通文本编辑器一样使用就可以了。有个地方新手要注意一下,在vi下按退格键虽然内容好像没有删除,实际已经删除了,你继续输入就可以了。将“option disabled 1”这行前面加一个"#"注释掉,然后将config wifi-iface那一栏以下的内容改为如下( 记得“option disabled 1”用“#”注释掉):

    config wifi-iface
                option device     radio0
                option network    lan
                option mode       ap
                option ssid       热点名称,自己写(例如“OWIFI”)
                option encryption psk2
                option key        热点密码,自己写(例如“1234abcd”),这个不是WR703N的密码不要搞错了

    修改完后按下“Esc”键返回到vi的普通模式,然后输入以下内容
    :wq

    就是保存并退出。然后我们让设置生效,输入命令
    reboot && exit

    然后就可以看到 这个设备发出来的WIFI了,连接之。连接好WIFI后, 把电脑和WR703N之间的网线拔掉


    下面加了删除线的内容请直接跳过,有想问我怎么回事的可以直接回复问我。

    接下来我们需要为WR703N安装sysuh3c客户端,有两种方法:第一种是让WR703N先连接到一个WIFI(没错让这个发WIFI的东西去连WIFI哈哈)然后进行文件下载升级等,第二种方法是直接先将sysuh3c客户端下载放在电脑中,然后再通过winscp这个软件将sysuh3c传输到WR703N中。对于新手建议使用第二种方法,比较便捷。

    方法1(失败了,因为这个版本的wget不支持https,而且即使升级也会提示空间不够无法打开升级包):

    打开/etc/config下的wireless文件,然后将config wifi-iface那一栏以下的内容改为如下:

    <del>config wifi-iface 'wlan0'
                option device     radio0
                option network    wan
                option mode       sta
                option ssid       WR703N要连接的WIFI的名称
                option encryption psk2
                option key        连接的WIFI的密码</del>

    保存退出。然后打开/etc/config下的network文件,首先将“config interface 'lan'”以下的"option ipaddr 192.168.1.1"改为"option ipaddr 192.168.10.1",然后在文件的最后加上以下内容:

    <del>config interface 'wan'
               option ifname 'wlan0'
               option proto 'dhcp'</del>

    保存退出。然后运行命令reboot && exit。过一阵后,重新ssh登录,注意命令变为ssh root@192.168.10.1。登录完成后可以测试以下是否可以联网,使用命令ping www.amazon.cn,如果能ping通,那么就OK啦。接下来就升级WR703N的OpenWRT系统并且直接下载sysuh3c客户端吧,命令如下:

    opkg update

    opkg install wget

    cd ~

    wget https://github.com/zonyitoo/sysuh3c/raw/openwrt/sysuh3c_0.2-1_ar71xx.ipk


    Step 7 : 下载在WR703N上能连接校园网的sysuh3c客户端

    接下来,下载编译好的sysuh3c客户端到你的电脑,地址是:https://github.com/zonyitoo/sysuh3c/raw/openwrt/sysuh3c_0.2-1_ar71xx.ipk。下载后重命名为sysuh3c.ipk即可。

    Step 8 : 把下载好的sysuh3c客户端放到WR703N上

    我们要将下载好的sysuh3c.ipk放到WR703N的/tmp目录下,如果是类Unix系统,则直接通过scp命令把下载好的这个文件复制到WR703N的/tmp中,命令是:

    scp ~/Downloads/sysuh3c.ipk root@192.168.1.1:/tmp

    输入密码后就传送成功了。

    如果是Windows系统,先下载WinScp这个软件,运行之(如果是压缩包记得解压缩后运行),文件协议(File protocol)选择“SCP”,主机名(Host name:)填写“192.168.1.1”,端口号(Port number:)填写“22”,用户名"User name:"填写“root”,密码“Password:”填写你们之前设定的WR703N的连接密码就可以了,然后点击“登陆”(Login),中途会弹出一条提示信息点击“否”(No)就可以了,然后如果弹出一条错误信息,点击“好”(OK)忽略之即可。然后你就可以看到左边是你的电脑上的文件,右边是WR703N的文件,在右边先双击第一个文件夹(名字是“..”),然后双击“/tmp”这个文件夹,然后在左边找到你的sysuh3c.ipk文件,把这个文件从左边拖到右边就可以了。然后在右下角找到“F10 Quit”类似字样的图标,点击退出(弹出的提示框点“OK”)就可以了。

    Step 9 : 让WR703N安装sysuh3c客户端

    接下来ssh到WR703N(类Unix系统直接ssh,Windows系统用putty),然后就可以安装sysuh3c.ipk这个文件,命令如下:

    cd /tmp
    opkg install sysuh3c.ipk

    安装完毕,已经成功一大半了。输入命令“sysuh3c --help”就可以看到操作提示了。例如-u后面是指定你的NetID,-p后面是指定你的密码,-d是让其在后台运行,-l是将当前已经登陆的NetID下线等,下面会大致讲怎么使用。

    Step 10 : 为WR703N连上校园网作最后的准备

    这个时候,我们编辑/etc/config下的network,输入命令

    vi /etc/config/network

    将"config interface 'lan'"下的“option ifname 'eth0'”这一行用"#"注释掉

    并且在文件最末尾加上

    config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

    重启路由器

    reboot && exit

    Step 11 : 第一次让WR703N连接校园网,电脑连上WIFI后可以上网啦

    重新ssh到WR703N(类Unix系统直接ssh,Windows系统用putty),将WR703N与校园网接口用网线连接,然后输入以下命令尝试让WR703N连接校园网:

    sysuh3c -u 你的账号 -p 密码
    “你的账号”替换成你的NetID,“密码”替换成你NetID的密码。如果没有error字样, 并且你的电脑连接WR703N发出的WIFI后可以上网,那么就是成功了,如果没有成功可以回复问我,应该是有地方配置错了。

    Step 12 : 让路由器在每次启动时自动连接校园网

    然后我们就要设置路由器启动时自动连接校园网啦,先断开校园网输入命令

    sysuh3c -l

    然后编辑/etc下的rc.local文件
    vi /etc/rc.local

    在“exit 0”前面加上以下内容:
    sysuh3c -u 你的账号 -p 密码 -d

    然后保存并退出(先按“Esc”返回到Vi的普通模式,再输入“:wq”)。然后重启路由器

    reboot && exit

    路由器重新启动并且电脑连接上WIFI后,电脑应该就可以自动联网了。

    Step 13 : 最后一小步,解决电脑连接WIFI后无法观看校园网的IPTV问题

    最后,由于有人发现了无法连接中山大学的网络电视,所以编辑/etc/config下的dhcp文件,将“option rebind_protection 1”中的1改为0就可以了。或者不改也可以,以后要看中大网络电视,就直接在浏览器输入172.20.2.2也可以。

    ————————————教程结束————————————

    至此教程就全部结束了,如果有神马问题欢迎留言问我。另外……如果有人问《APUE代码注记》这篇博文为什么不更新了,是这样的,我发现代码按照文章开头的配置后基本都可以运行,也没有人反映哪一章节的代码有问题,加上最近在做毕业设计,所以就暂时更新得慢点了。


    本文中的资料,部分参考自:

    http://wiki.openwrt.org/doc/start

    http://wiki.xinchejian.com/wiki/Install_OpenWRT_on_TPlink_WR703N

    http://blog.csdn.net/killzero/article/details/8607276

    http://blog.csdn.net/killzero/article/details/9155245


    本文作者:fanfank@CSDN

    本文原文地址参见:http://blog.csdn.net/fanfank/article/details/18707169






    展开全文
  • Linux下使用Docker运行OpenWrt系统

    千次阅读 2021-06-09 11:11:15
    使用Docker运行虚拟的OpenWrt系统,很适合初学者调试系统和学习Luci界面的编辑 1、准备Linux环境 可以是虚拟机,可以是远程云服务器。 本文系统是Centos 7.6 2、安装Docker容器 如何安装和使用请另行学习,本文默认...
  • OpenWRT

    千次阅读 2013-02-23 02:18:58
    OpenWRT  Featured, Phase-Deploy, 路由器配置 ...TP-Link TL-MR3420 v1路由上运行WallProxy v2.1.x 软硬件环境:本例中的路由是老款TP-Link TL-MR3420 v1改16M Flash,64M RAM,固件刷OpenWrt-dre
  • 系统: openWRT v15, CHAOS CALMER 脚本: BASH 步骤: 1. 更新数据源及安装 BASH; #opkg update #opkg install bash 2. 脚本文件, check_process.sh #!/bin/bash while [ 1 ] do flag=$(ps | grep check_...
  • OpenWrt是Linux的一个发行版,是一个独立的操作系统,主要运行在嵌入式设备中,由于嵌入式硬件种类繁多,并且稍微不慎就可能导致板子变砖,这给开发者带来了很大麻烦。 本篇文章以极路由为例,详细记录了OpenWrt系统...
  • socat 内网端口转发 并后台运行

    千次阅读 2017-07-15 09:59:15
    socat TCP4-LISTEN:19122,reuseaddr,fork TCP4:172.29.71.7:19122 & 转发TCP协议 (V4) 转发19122 端口 后台运行 就是最后面加个&
  • 在Docker 中运行 OpenWrt 旁路网关

    千次阅读 2020-03-31 15:37:37
    docker ps -a命令查看当前运行的容器: $ docker ps -a CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES a26cee7cade6 openwrt:latest "/sbin/init" 3 hours ago Up 3 hours openwrt 若容器运行信息STATUS...
  • OpenWRT ubus

    2018-03-11 19:14:00
    使用OpenWRT ubus的 examples 写一个 通信zigbee 的协议 在路由器... ubus启动后会在后台运行ubusd进程,该进程监听一个unix套接字用于与其他应用程序通信。其他应用程序可基于libubox提供的接口(或自己实现)与其...
  • 编译OpenWrt

    千次阅读 2014-09-15 16:37:51
    Openwrt 官方正式的发行版是已编译好了的映像文件(后缀名bin或trx、trx2),此映像文件可从Openwrt官方网站的下载页面中轻松获取到,连接地址为 OpenWrt官方网站。 为了参与测试或参与开发OpenWrt的工作;我们...
  • 网络资料:  最近被mesh路由器项目搞得焦头烂额的,想死的心都有了,当然,...近来搞定了在ubuntu上搭建openwrt的交叉编译环境,另外搞定了openwrt先添加启动项。  说说添加启动项问题吧。在/etc/init.d里添
  • 首先我们需要制作一个脚本。在终端下输入并回车新建脚本文件start.shtouch start.sh chmod 777 start.sh然后向rc.local文件添加启动代码修改rc.local文件,在终端输入并回车:sudo vi /etc/rc.local在打开的文本中...
  • 写入完成后插入SD卡,通电开机,运行成功后你可以在附近的wifi中找到叫"OrangePiZero"的热点(默认wifi密码是:internet)。 OrangePiZero 4. 连接成功后你可以进入192.168.1.1管理后台,后台的默认用户名...
  • 解决方法,在openwrt中安装screen软件,安装方法opkg update,opkg install screen。安装完成后,输入screen回车,在新的界面下,运行tcpdump,然后Ctrl+a,再点击d即可回到主界面下,会显示[detached]字符串。输入...
  • slim版固件只有OpenWrt本体,但内置了“本地软件源”,包含大部分常用插件,不喜欢固件预装繁杂插件的人可以选择这个版本,进入后台软件包选装所需插件 采用ext4文件系统,刷卡之后可自行使用分区工具对sd卡扩容根...
  • 如何编译OpenWrt

    2014-09-17 18:52:46
    分类: openwrt ... Openwrt 官方正式的发行版是已编译好了的映像文件(后缀名bin或trx、trx2),此映像文件可从Openwrt官方网站的下载页面中轻松获取到,连接地址为 OpenWrt官方网站。这些编译好的
  • openwrt添加一条开机自动运行的命令

    万次阅读 2013-11-17 11:39:53
    修改:/etc/rc.local
  • 软路由openwrt新手教程

    万次阅读 2020-03-23 12:09:11
    ssh进入路由器后台运行dmesg查看硬件配置信息CPU、PCIe RC mode等。 刷入固件 按住reset键插上电源,5秒松手,浏览器192.168.1.1进入breed界面 固件升级—选择固件 导入openwrt固件(一般为kernel.bin和sysupgrade....
  • 树莓派3B设置openWrt

    2021-05-05 07:43:29
    开启系统 插入SD卡到树莓派3B 树莓派接通电源,系统会自动执行,不需要连接显示屏 大概等待30s左右,查看无线wifi,如果多出一个openWrt,说明系统已经成功运行 记录IP 打开终端,输入命令 ipconfig 获取当前主路由的网关...
  • [OpenWrt] 如何编译OpenWrt

    千次阅读 2012-11-26 13:15:14
    ...文末,附加人生如戏写的编译OPENWRT的TXT内容,可直接... Openwrt 官方正式的发行版是已编译好了的映像文件(后缀名bin或trx、trx2),此映像文件可从Openwrt官方网站的下载页面中轻松获取到,连接地址为 Ope
  • R2S设置openWrt软路由

    千次阅读 2021-05-05 07:48:49
    固件的默认后台IP为192.168.2.1 默认用户名为root 默认密码为password 本固件为:192.168.22.1 密码:password 固件是基于lean大佬的源码编译 lean大佬源码仓库地址: https://github.com/bigdongdongCLUB/lede ...
  • openwrt系统编译简述

    千次阅读 2020-01-09 20:12:10
    OpenWrt编译要求 以生成安装8M的OpenWrt固件镜像为例: 在你的操作系统上安装OpenWrt的编译系统和一些必要的东西; 确保有3-4 GB的可用空间; 环境变量: 不应该设置SED,如果有在编译之前执行unset SED; GREP_...
  • openwrt-fancontrol-源码

    2021-05-19 00:23:17
    openwrt-fancontrol 根据来自OpenWRT wrt1900ac线程的,对/sbin/fan_ctrl....让它在后台运行,以保持路由器凉爽。 /etc/fancontrol.sh & ####禁用原始风扇控制器。 从/ etc / crontabs / root中删除或注释掉这一行

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 645
精华内容 258
关键字:

openwrt后台运行