精华内容
下载资源
问答
  • openwrtip配置 openwrt有一个默认固定ip的网口,5个或者1个,2种模式,但是都是默认固定ip的; 但是我现在把openwrt作为sta模式,所以需要默认以dhcp模式来分配ip,网上的教程大多数都是以openwrt CC版本为教程的, ...

    openwrt笔记7 ip配置

    openwrtip配置

    openwrt有一个默认固定ip的网口,5个或者1个,2种模式,但是都是默认固定ip的;

    但是我现在把openwrt作为sta模式,所以需要默认以dhcp模式来分配ip,网上的教程大多数都是以openwrt CC版本为教程的,

    但是现在openwrt已经发展到很前端了,好像已经去到18.06以上的版本了,再用网上的教程已经不管用了;

    下面记录我的做法:

    cd openwrt17.01.06/package/base-files/files/lib/functions
    vim uic-defaults.sh
    修改30行的函数,_ucidef_set_interface(){
    ...
    lan) proto="static"---->lan) proto="dhcp"
    wan) proto="dhcp"
    ...
    }
    

    修改完毕,make V=99

    成功!

    展开全文
  • OPENWRT VLAN 配置

    2021-03-16 17:13:46
    OPENWRT VLAN 配置 OPENWRT VLAN 配置 openwrt配置vlan 1.先配置switch使能 config switch option name ‘eth0’ option reset ‘1’ option enable_vlan ‘1’ 2.配置对应的switch config switch_vlan option ...

    OPENWRT VLAN 配置

    OPENWRT VLAN 配置

    openwrt中配置vlan

    1.先配置switch使能
    config switch
    option name ‘eth0’
    option reset ‘1’
    option enable_vlan ‘1’

    2.配置对应的switch
    config switch_vlan
    option device ‘eth0’
    option vlan ‘1’
    option ports ‘1 2 3 4 5t’

    config switch_vlan
    option device ‘eth0’
    option vlan ‘2’
    option ports ‘0 5t’

    3.将对应的端口绑定对应的网络接口
    config interface ‘lan’
    option type ‘bridge’
    option ifname ‘eth0.1’
    option proto ‘static’
    option netmask ‘255.255.255.0’
    option ip6assign ‘60’
    option ipaddr ‘192.168.1.1’

    config interface ‘wan’
    option ifname ‘eth0.2’
    option proto ‘dhcp’

    到此一个完整的vlan配置已经完成
    下图为对应的switch逻辑图,由eth0创建switch虚拟出vlan接口,将port0口绑在 id 为1的vlan上,然后绑定在wan口;将port1、port2、port3、port4绑定到lan口上;port5口连接着vlan1和vlan2所以他是trunk口;

    在这里插入图片描述

    展开全文
  • OpenWRT NAT配置

    万次阅读 2020-02-20 13:43:02
    OpenWRT防火墙工具fw3之NAT篇 NAT的原理 网卡收到数据包,首先进行的是DNAT检查,检查数据包的包头是否符合DNAT的规则,如果符合,将数据包的包头目的地址(包括端口,后文不在赘述)按规则替换。 替换完目的地址后...

    OpenWRT防火墙工具fw3之NAT篇

    NAT的原理

    网卡收到数据包,首先进行的是DNAT检查,检查数据包的包头是否符合DNAT的规则,如果符合,将数据包的包头目的地址(包括端口,后文不在赘述)按规则替换。
    替换完目的地址后,根据新的包头匹配路由表进行路由,确定数据包从哪个端口出去。
    路由完成后再检查是否符合源地址替换规则(SNAT),如果符合源地址替换规则,则按照规则将数据包做SNAT,然后将新的数据包按照路由送出网卡。注意:上述描述的是数据包的目的地址不是本机,而是需要本机转发的报文。

    Created with Raphaël 2.2.0 网卡收包 检查是否符合目的地址转换规则 DNAT 根据包目的地址进行路由 检查是否符合源地址转换规则 SNAT 出网卡 yes no yes no

    OpenWRT下的netfilter管理工具

    Linux下的防火墙和NAT功能是通过netfilter内核模块实现的,iptables是一个用来与内核层的netfilter交互的用户层工具,但是iptables是一个命令行工具,为了方便从配置文件中获取过滤信息,OpenWRT开发了一套与iptables同地位的netfilter管理工具fw3,这个工具侧重于从uci格式的配置文件中获取过滤信息下发到内核的netfilter中去。

    1. fw3配置文件

    阅读本小节需要具备uci配置文件格式知识。
    fw3的配置文件默认为/etc/config/firewall。

    2. 数据包的目的地址转换(DNAT)

    DNAT就是对数据包的目的地址进行转换,目的地址包含目的IP地址、目的端口。即从一个五元组变化为另一个五元组,生成一个新的数据包。五元组里面的5个数据任意组合可以作为过滤条件,即从所以数据包中筛选生效数据包的过滤条件。
    目的IP | 源IP | 目的端口 | 源端口 | 协议类型) --> (新目的IP | 源IP | 新目的端口 | 源端口 | 协议类型)

    举个例子 1:
    config redirect
           option target          DNAT
           option src             wan
           option dest            lan
           option proto           tcp
           option src_dport       2222
           option src_dip         192.168.8.20
           option src_ip          192.168.9.20
           option src_port        3333
           option dest_ip         192.168.10.20
           option dest_port       22
           option enabled         1
    

    上述配置翻译成iptables命令如下:

    iptables -t nat -A zone_wan_prerouting -p tcp -s 192.168.9.20/255.255.255.255 -d 192.168.8.20/255.255.255.255 -m tcp --sport 3333 --dport 2222 -m comment --comment "@redirect[0]" -j DNAT --to-destination 192.168.10.20:22
    

    翻译成白话就是告诉内核:

    如果遇到“源地址192.168.8.20,目的地址192.168.8.20,源端口3333,目的端口2222”的数据包,修改成“源地址192.168.168.8.20,目的地址192.168.10.20,源端口3333,目的端口22”的数据包。
    
    option name含义
    target本条规则的动作[DNAT|SNAT]
    src数据包的来源接口,对应zone节点的定义
    dest数据包的目的接口,对应zone节点的定义
    proto要过滤的数据包的协议, [tcp|udp|tcpudp]
    src_dport在做地址替换之前的数据包目的端口
    src_ip在做地址替换之前的数据包源IP地址
    src_dip在做地址替换之前的数据包目的IP地址
    src_port在做地址替换之前的数据包的源端口
    dest_ip地址替换之后的数据包目的IP地址
    dest_port地址替换之后的数据包目的端口地址
    举个例子 2:
    config redirect
           option target          DNAT
           option src             wan
           option dest            lan
           option proto           tcp
           option src_dport       2222
           option src_dip         192.168.8.20
           option dest_port       22
           option enabled         1
    

    上述配置翻译成iptables命令如下:

    iptables -t nat -A zone_wan_prerouting -p tcp -d 192.168.8.20/255.255.255.255 -m tcp --dport 2222 -m comment --comment "@redirect[0]" -j REDIRECT --to-ports 22
    

    翻译成白话就是告诉内核:

    如果遇到“目的地址192.168.8.20,目的端口2222,协议为tcp”的数据包,修改成“源地址保持,目的地址192.168.10.20,源端口保持,目的端口22,协议为tcp”的数据包。
    

    对比例子1和例子2的区别: 例子2的对数据包的过滤范围要宽,只关心目的地址和目的端口。我们可以任意的放宽检测条件来对数据包进行过滤

    注意:DNAT只做目的地址、目的端口的转换。

    3. 数据包的源地址转换(SNAT)

    举个例子 1
    config redirect
           option target          SNAT
           option src             wan
           option dest            lan
           option proto           tcp
           option src_dport       2222
           option src_dip         192.168.8.20
           option src_ip          192.168.9.20
           option src_port        3333
           option dest_ip         192.168.10.20
           option dest_port       22
           option enabled         1
    

    翻译成iptables命令:

    iptables -t nat -A zone_lan_postrouting -p tcp -s 192.168.9.20/255.255.255.255 -d 192.168.10.20/255.255.255.255 -m tcp --sport 3333 --dport 22 -m comment --comment "@redirect[0]" -j SNAT --to-source 192.168.8.20:2222
    

    翻译成白话:

    当遇到“源地址192.168.9.20,目的地址192.168.10.20,源端口3333,目的端口22,协议为TCP”的数据包时,将其源地址和源端口修改为(192.168.8.20,2222)
    

    (,192.168.9.20,22,3333,tcp) --> (,192.168.8.20,22,2222,tcp)

    注意:在源地址转换里,option参数的意义与在目的地址转换里有些不同,区别如下:

    option选项在DNAT中的含义在SNAT中的含义
    src_dport原数据包的目的端口做源端口替换后的端口号
    src_dip原数据包的目的地址做源地址替换后的目的地址
    dest_ip做目的地址替换后的目的地址原数据包的目的地址
    dest_port做目的地址替换后的目的端口原数据包的目的端口
    展开全文
  • OpenWRT快速配置Samba

    2021-08-07 18:18:28
    OpenWRT快速配置Samba 这两天把迅雷下载宝翻出来又想用用,想着原开发商估计已经跑路了,所以网上找了个OpenWRT的包刷上。 开机后发现Samba竟然要自己配置,研究了一下午,基本把方法学会了,分享给大家。 安装Samba...

    OpenWRT快速配置Samba

    这两天把迅雷下载宝翻出来又想用用,想着原开发商估计已经跑路了,所以网上找了个OpenWRT的包刷上。

    开机后发现Samba竟然要自己配置,研究了一下午,基本把方法学会了,分享给大家。

    安装Samba

    登录Luci,在“系统”选项卡-“软件包”中更新列表,然后点可用软件包,搜索下面三个软件并安装即可。

    • samba36-server
    • luci-app-samba
    • luci-i18n-samba-zh-cn

    第一、二个必装,第三个是语言包,英文好的可以把“zh-cn”改成“en”装英文版的,装啥语言包界面就是啥语言的。

    配置匿名服务

    “系统”选项卡中选择“TTYD终端”,若没有,可以下载putty,然后ssh登录路由器IP。

    注:Samba服务的配置由两个文件组成,一是/etc/config/samba,二是/etc/samba/smb.conf.template,服务启动后会先读取一号文件,然后读取二号文件,生成/etc/samba/smb.conf文件,最后运行服务。

    根据Samba服务读取配置的方法,需要更改上述的一、二号文件。这里直接给出模板配置,将模板直接覆盖原配置即可。操作如下。

    • 在ssh窗口中输入vim /etc/config/samba,编辑一号文件。

    可以发现原配置文件应与要修改的配置文件比较相似,为方便起见,键盘输入:%d并回车,直接清空该文件。再按i,进入编辑模式,复制以下内容,在ssh界面按右键,粘贴。按Esc,再输入:wq,注意这时候wq会显示在ssh窗口最下方,按回车即可保存退出。

    注:下面配置模板中所指的U盘挂载点可以在“系统”选项卡-“挂载点”中查看,找到挂载点中容量对应你插入的U盘的行,然后将该行挂载点列的值复制到上述位置替换原值即可。一般来说若路由器只插了一个U盘,挂载点会在模板中的位置,但可能有不适用的情况,建议还是自己查看并确认一下。

    samba文件配置模板如下:

    config samba
    	option name 'OpenWrt'
    	option workgroup 'WORKGROUP'
    	option description 'OpenWrt'
    	option homes '1'
    
    config sambashare 'FlashDisk'  ## 引号中可改为想要的共享名称,建议不要有中文
    	option name 'FlashDisk'  ## 引号中可改为想要的共享名称,建议不要有中文,与上面相同
    	option path '/mnt/sda1'  ## 引号中改为U盘挂载位置
    	option read_only 'no'
    	option guest_ok 'yes'
    	option create_mask '777'
    	option dir_mask '777'
    
    • 在ssh窗口中输入vim /etc/samba/smb.conf.template,编辑二号文件

    二号文件与一号文件操作步骤相同,但是二号文件没有需要修改的地方,可以直接粘贴后保存。

    键盘输入:%d并回车,直接清空该文件。再按i,进入编辑模式,复制以下内容,在ssh界面按右键,粘贴。按Esc,再输入:wq,回车后保存退出。

    [global]
    	netbios name = |NAME|
    	display charset = |CHARSET|
    	interfaces = |INTERFACES|
    	server string = |DESCRIPTION|
    	unix charset = |CHARSET|
    	workgroup = |WORKGROUP|
    	browseable = yes
    	deadtime = 30
    	domain master = yes
    	encrypt passwords = true
    	enable core files = no
    	guest account = nobody
    	guest ok = yes
    	#invalid users = root
    	local master = yes
    	load printers = no
    	map to guest = Bad User
    	max protocol = SMB2
    	min receivefile size = 8192
    	null passwords = yes
    	obey pam restrictions = yes
    	os level = 20
    	passdb backend = smbpasswd
    	preferred master = yes
    	printable = no
    	security = user
    	smb encrypt = disabled
    	smb passwd file = /etc/samba/smbpasswd
    	socket options = TCP_NODELAY SO_RCVBUF=960000 SO_SNDBUF=960000
    	syslog = 2
    	use sendfile = yes
    	use mmap = yes
    	writeable = yes
    	disable spoolss = yes
    	host msdfs = no
    	strict allocate = No
    

    最后,在ssh窗口输入/etc/init.d/samba restart并回车;或者在“系统”-“启动项”中找到“samba”,点重启,重启Samba服务,即可使配置生效。

    在win10运行窗口输入\\192.168.1.1即可访问路由器上U盘中的内容了。注意,\\必须要有,后面跟着路由器的IP。

    至此,Samba服务的基本配置已经结束了。同时我还发现,Samba服务是可以添加密码的,对于在路由器上部署了内网穿透服务的网友,不添加服务密码是非常容易被黑客窃取U盘中的数据的,所以可以参照以下步骤给Samba服务添加一层密码。

    晋级操作

    Samba服务需要单独配置账号,所以你登录路由器时的账号是没法用的。

    细心的你应该发现了,上述二号文件配置模板中注释了一行#invalid users = root,若取消该行注释,意味着将不能使用root账号添加密码,这样一来还需要为samba服务单独添加账号,对个人用户来说比较麻烦,所以我下面介绍直接使用root账号为samba服务添加密码的方法。

    其实第一步应该是注释掉二号文件中的invalid users = root,这里直接跳过这一步。在ssh窗口中输入smbpasswd -a root,回车后下方会跳出输入密码的提示,在这时输入你的密码然后按回车,再输一遍,即可为root账户设置samba服务的密码。注意,输入密码时不会显示任何字符。

    下面需要取消Samba服务中配置的允许匿名访问的选项,输入vim /etc/config/samba,编辑一号文件,将option guest_ok 'yes'中的yes更改为no,按Esc,再输入:wq,回车后保存退出即可。当然也可以在“网络储存”-“网络共享”中将共享目录中你设置的共享一行的“允许匿名用户”选项取消勾选,点“保存并应用”,达到与vim配置一样的效果。

    最后,重启samba服务。在ssh窗口输入/etc/init.d/samba restart并回车;或者在“系统”-“启动项”中找到“samba”,点重启。

    win10中访问加密Samba服务的方式与匿名方式一致,只是系统会在访问前询问账号密码,账号为root,密码为你自己设置的密码,勾选上保存账号密码,下次访问就可以双击进入啦。

    以上,就是我一下午研究出的Samba服务配置方法,可以帮助一些没有接触过Samba的网友快速完成基础的配置,但是由于本人时间有限,没有进行更加深入的研究,我上述方法中的问题大家可以在评论中指出。

    展开全文
  • OpenWrt网络配置

    2020-07-22 18:07:42
    文件内容 查看vi /etc/config/network lan为固定ip wan链接外网 pc上 在虚拟机中配置
  • openwrt wifi 配置

    千次阅读 2015-08-19 11:31:01
    使用不同的架构配置是因为不同的驱动配置。 The reason for using such architecture, is that it abstracts the driver configuration. 标准的Broadcom无线配置:  Generic Broadcom wireless config: ...
  • OpenWrt系统配置UCI

    千次阅读 2019-11-09 23:26:57
    openWrt也是采用该设计模式,模型层采用统一配置接口UCI,是Unified Configuration Interface的缩写,翻译成中文就是统一配置接口,用途就是为OpenWrt提供一个集中控制的接口。OpenWrt实现的这个工具,能够让你的...
  • openwrt手工配置pptpd

    千次阅读 2019-02-21 21:26:20
    官方wiki:http://wiki.openwrt.org/doc/howto/vpn.server.pptpd#prerequisites 20190220更新:PPTP VPN协议已经被 IOS 10及以后的版本取消了 前提是用opkg安装的pptpd #######/etc/config/pptpd###### config ...
  • VMware装Openwrt配置虚拟机网段IP后 reboot 浏览器无法登录Openwrt管理页面。。 —————— 重启电脑 再打开vmware启动Openwrt OK..
  • OpenWRT18.06配置各项默认参数

    千次阅读 2019-09-05 09:18:29
    OpenWRT配置各项默认参数 1配置默认WiFi参数 /*配置路径*/ package/kernel/mac80211/files/lib/wifi/mac80211.sh 2配置默认NET参数 /*15.05之前版本配置路径*/ package/base-files/files/lib/functions/uci-...
  • OpenWrt安装配置NextCloud

    2021-04-30 22:48:17
    本文记录了如何在Openwrt上安装配置NextCloud的例子。 此例所有操作在ubuntu下进行,用virtualbox的虚机模拟。 openwrt主机IP设置为192.168.100.1。 没有用https,考虑到这个一般是个人做云盘,野证书实在意义...
  • OpenWrt——配置L2TP客户端

    万次阅读 2019-10-03 09:10:11
    基本概念 L2TP:一种工业标准的Internet隧道协议,功能大致和PPTP协议类似,比如同样可以对网络数据流进行加密。不过也有不同之处,比如PPTP要求网络为IP网络,L2TP...官网配置:https://wiki.openwrt.org/doc/uci...
  • openwrt 安装 配置网络

    2021-01-20 22:58:08
    安装openwrt参考网站:: https://www.cnblogs.com/yczz/p/3893102.html https://m0n0.ch/wall/physdiskwrite.php 拓扑图: [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-ttnB1VS4-...
  • 20. 详解 OpenWrt 防火墙配置、NAT配置

    千次阅读 2021-06-11 23:00:46
    OpenWRT开发了一套与iptables同地位的netfilter管理工具fw3,这个工具侧重于从uci格式的配置文件中获取过滤信息下发到内核的netfilter中去。 防火墙文件总会在/etc/init.d/firewall 启动的时候由 UCI 解码并且
  • openwrt无线配置

    千次阅读 2012-04-18 13:44:49
    配置有线 设置lan ip(即访问路由的ip) uci set network.lan.ipaddr=[lan ip] 复制代码 pppoe用户 uci set network.wan.proto=pppoe //设置wan口类型为pppoe uci set network.wan....
  • OpenWrt配置原生IPv6 NAT

    万次阅读 热门讨论 2015-05-01 19:07:10
    OpenWrt配置原生IPv6 NAT,让连接上路由器的设备都能使用IPv6网络.
  • OPENWRT NETWORK配置

    2014-10-02 22:33:00
    2019独角兽企业重金招聘Python工程师标准>>> ...mtd -r write openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin firmware  转载于:https://my.oschina.net/blueprint/blog/323992
  • openwrt network 配置文件

    千次阅读 2016-04-12 16:20:39
    config 'interface' 'loopback' #本地回环地址 option 'ifname' 'lo' ... option 'ipaddr' '127.0.0.1' option 'netmask' '255.0.0.0' config 'interface' 'lan' #LAN口,用于路由器子网设置 opti
  • openwrt默认lan ip地址配置

    万次阅读 2016-11-11 10:45:17
    openwrt 15.05之前的版本,配置/package/base-files/files/lib/functions/uci-default.sh中的lan ip地址即可。但是在15.05版本中这部分的配置做了修改,使用了新的uci-new-default.sh, 已不再包括lan ip配置,...
  • openwrt LAN口配置ip

    千次阅读 2021-02-21 00:51:13
    修改network配置文件 vi /etc/config/network config interface 'lan' option type 'bridge' option proto 'static' option netmask '255.255.255.0' option _orig_ifname 'eth0 eth1 eth2 eth3' option _orig_...
  • OpenWrt配置

    万次阅读 2016-06-03 09:04:57
    OpenWrt配置
  • [OpenWrt] openwrt无线配置

    千次阅读 2012-11-26 10:35:58
    配置有线 设置lan ip(即访问路由的ip) uci set network.lan.ipaddr=[lan ip] 复制代码 pppoe用户 uci set network.wan.proto=pppoe //设置wan口类型为pppoe uci set network.wan....
  • OpenWRT 路由配置技巧

    千次阅读 2015-05-27 00:11:36
    随着最近 Google 在国内已经完全无法访问,使得通过 VPN 访问...Wifi 环境,连接到这个网络的设备不需要任何配置即可安全上网,完全感觉不到任何不便。  chnroutes 路由表 这个路由表集中了所有分配到中国大陆的 I
  • 2、Linux下的防火墙最终都会归iptables进行管理,OpenWrt的防火墙机制同样也是,最上层采用了自己基于UCI标准的配置方法管理防火墙firewall,最终写入到iptables。 3、UCI是OpenWrt统一配置文件的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,941
精华内容 1,576
关键字:

openwrtip配置