精华内容
下载资源
问答
  • openwrt命令行模式命令及其工具 需要学会用ssh登录路由器用linux命令查看。 ps 命令查看当前系统运行的进程信息 free 命令查看内存使用和swap挂载情况 ls 查看目录和文件 cd 进入退出目录 vi 查看编辑配置文件 ...
  • OPENWRT入门之四------openwrt命令行模式命令及其工具 本文转自:http://blog.chinaunix.net/uid-9688646-id-5025317.htm
    原文地址为:
    OPENWRT入门之四------openwrt命令行模式命令及其工具
    

    OPENWRT入门之四------openwrt命令行模式命令及其工具

     

    本文转自:http://blog.chinaunix.net/uid-9688646-id-5025317.html

    需要学会用ssh登录路由器用linux命令查看。
      ps 命令查看当前系统运行的进程信息
      free 命令查看内存使用和swap挂载情况
      ls 查看目录和文件
      cd 进入退出目录
      vi 查看编辑配置文件
      安装命令:
    1. #opkg update
    2. #opkg install nano
    3. + N2 U! x4 e% G. O- k
    4. uci set network.lan.ipaddr=[lan ip]
    复制代码
    使用pppoe设置
      Shell代码
    1. uci set network.wan.proto=pppoe    //设置wan口类型为pppoe
    2. uci set network.wan.username=[上网帐户] 
    3. uci set network.wan.password=[上网密码]    //这两行设置pppoe用户名和密码
    复制代码
    如果要挂在上级路由下面,就需要进行下面的设置
      Shell代码
    1. uci set network.wan.proto=none    //关掉wan 
    2. uci set network.lan.gateway=[上级路由ip]    //网关指向上级路由
    3. uci set network.lan.dns=[上级路由ip]    //dns指向上级路由  :
    4. uci set dhcp.lan.ignore=1    //关掉lan的dhcp
    复制代码
    最后对无线网络进行配置
      Shell代码
    1. uci set wireless.@wifi-device[0].disabled=0    //打开无线  )
    2. uci set wireless.@wifi-device[0].txpower=17    //设置功率为17dbm 太高会烧无线模块
    3. uci set wireless.@wifi-device[0].channel=6    //设置无线信道为6 
    4. uci set wireless.@wifi-iface[0].mode=ap    //设置无线模式为ap 
    5. uci set wireless.@wifi-iface[0].ssid=[自己设置SSID]    //设置无线SSID 
    6. uci set wireless.@wifi-iface[0].network=lan    //无线链接到lan上
    7. uci set wireless.@wifi-iface[0].encryption=psk2    //设置加密为WPA2-PSK
    8. uci set wireless.@wifi-iface[0].key=[密码]    //设置无线密码
    复制代码
    提交应用配置
      Shell代码
    1. uci commit    //应用
    2. /etc/init.d/network restart    //重启网络服务
    复制代码
    安装luci管理界面
      Shell代码
    1. opkg update // 更新软件列表 
    2. opkg list-installed // 查看已安装软件
    3. opkg install luci // 安装LUCI 
    4. opkg install luci-i18n-chinese // 支持中文
    5. luci-app-firewall - 0.10.0-1
    6. luci-i18n-english - 0.10.0-1
    7. luci-lib-core - 0.10.0-1
    8. luci-lib-ipkg - 0.10.0-1
    9. luci-lib-lmo - 0.10.0-1
    10. luci-lib-nixio - 0.10.0-1
    11. luci-lib-sys - 0.10.0-1
    12. luci-lib-web - 0.10.0-1
    13. luci-mod-admin-core - 0.10.0-1
    14. luci-mod-admin-full - 0.10.0-1
    15. luci-proto-core - 0.10.0-1
    16. luci-proto-ppp - 0.10.0-1
    17. luci-sgi-cgi - 0.10.0-1
    18. luci-theme-base - 0.10.0-1
    19. luci-theme-openwrt - 0.10.0-1
    复制代码
    即可完成LUCI的安装。
      输入以下命令开启支持web服务的uhttpd,并设置其为自启动:
      Shell代码
    1. /etc/init.d/uhttpd enable # 开机自启动
    2. /etc/init.d/uhttpd start # 启动uhttpd
    复制代码
    - Wifidog
      你可以尝试执行以下命令安装Wifidog
    1. opkg update # Optional
    复制代码
    --sftp安装
    1. opkg update
    2. opkg install vsftpd openssh-sftp-server
    3. /etc/init.d/vsftpd enable
    4. /etc/init.d/vsftpd start
    复制代码
    小米端口转发命令:
      通过修改 /etc/config/firewall 这个文件来实现开放自己需要的端口到外网
    1. config rule 'httpdwan'
    2.         option src 'wan'
    3.         option dest_port '8088'
    4.         option proto 'tcp'
    5.         option target 'ACCEPT'
    6.         option name ''\''httpd wan accept tcp port 8088'
    复制代码
    保存后,执行 /etc/init.d/firewall restart 重启防火墙。
      SSH工具:
      1.WINSCP WinSCP.rar (7.7 MB, 下载次数: 47)
      2.putty中文版 putty.rar (233.87 KB, 下载次数: 28) 中文的使用的难度相对低一点
      3.熟练一些的用户推荐 SecureCRT
      操作多台设备的时候,十分的方便。这个自行搜索安装吧~
      附VI命令图:
    本文转载自: 小米社区

    转载请注明本文地址: OPENWRT入门之四------openwrt命令行模式命令及其工具
    展开全文
  • 修改路径: /etc/config/firewall 添加如下参数就会把路由80NAT到外网8080,如此类推 config redirect option target 'DNAT' option src 'wan' option dest 'lan' option proto 'tcp udp' ...

    修改路径: /etc/config/firewall

    添加如下参数就会把路由80NAT到外网8080,如此类推

    config redirect                     
            option target 'DNAT'        
            option src 'wan'             
            option dest 'lan'           
            option proto 'tcp udp'      
            option src_dport '8080'     
            option dest_ip '192.168.2.1'
            option dest_port '80' 
            option name 'router'

    展开全文
  • openwrt命令行模式命令及其工具

    万次阅读 2016-12-19 11:15:35
    luci-theme-openwrt - 0.10.0-1 即可完成LUCI的安装。  输入以下命令开启支持web服务的uhttpd,并设置其为自启动:  Shell代码  /etc/init.d/uhttpd enable # 开机自启动  /etc/init.d/uhttpd ...

    出处:http://bbs.xiaomi.cn/thread-9734746-1-1.html

    基础:学会用ssh登录路由器用linux命令查看。

    ps 命令查看当前系统运行的进程信息
    free 命令查看内存使用和swap挂载情况
    ls 查看目录和文件
    cd 进入退出目录
    vi 查看编辑配置文件


    安装命令:
    #opkg update
    #opkg install nano



    uci set network.lan.ipaddr=[lan ip]  

    使用pppoe设置 
    Shell代码  
    uci set network.wan.proto=pppoe    //设置wan口类型为pppoe  
    uci set network.wan.username=[上网帐户]  
    uci set network.wan.password=[上网密码]    //这两行设置pppoe用户名和密码  

    如果要挂在上级路由下面,就需要进行下面的设置 
    Shell代码  
    uci set network.wan.proto=none    //关掉wan  
    uci set network.lan.gateway=[上级路由ip]    //网关指向上级路由  
    uci set network.lan.dns=[上级路由ip]    //dns指向上级路由  
    uci set dhcp.lan.ignore=1    //关掉lan的dhcp  

    最后对无线网络进行配置 
    Shell代码  
    uci set wireless.@wifi-device[0].disabled=0    //打开无线  
    uci set wireless.@wifi-device[0].txpower=17    //设置功率为17dbm 太高会烧无线模块  
    uci set wireless.@wifi-device[0].channel=6    //设置无线信道为6  
    uci set wireless.@wifi-iface[0].mode=ap    //设置无线模式为ap  
    uci set wireless.@wifi-iface[0].ssid=[自己设置SSID]    //设置无线SSID  
    uci set wireless.@wifi-iface[0].network=lan    //无线链接到lan上  
    uci set wireless.@wifi-iface[0].encryption=psk2    //设置加密为WPA2-PSK  
    uci set wireless.@wifi-iface[0].key=[密码]    //设置无线密码  

    提交应用配置 
    Shell代码  
    uci commit    //应用  
    /etc/init.d/network restart    //重启网络服务  


    安装luci管理界面 
    Shell代码  
    opkg update // 更新软件列表  
    opkg list-installed // 查看已安装软件  
    opkg install luci // 安装LUCI  
    opkg install luci-i18n-chinese // 支持中文  

    luci-app-firewall - 0.10.0-1
    luci-i18n-english - 0.10.0-1
    luci-lib-core - 0.10.0-1
    luci-lib-ipkg - 0.10.0-1
    luci-lib-lmo - 0.10.0-1
    luci-lib-nixio - 0.10.0-1
    luci-lib-sys - 0.10.0-1
    luci-lib-web - 0.10.0-1
    luci-mod-admin-core - 0.10.0-1
    luci-mod-admin-full - 0.10.0-1
    luci-proto-core - 0.10.0-1
    luci-proto-ppp - 0.10.0-1
    luci-sgi-cgi - 0.10.0-1
    luci-theme-base - 0.10.0-1
    luci-theme-openwrt - 0.10.0-1

    即可完成LUCI的安装。 
    输入以下命令开启支持web服务的uhttpd,并设置其为自启动: 
    Shell代码  
    /etc/init.d/uhttpd enable # 开机自启动  
    /etc/init.d/uhttpd start # 启动uhttpd  

    - Wifidog
    你可以尝试执行以下命令安装Wifidog:
      opkg update # Optional
      opkg install wifidog

    --sftp安装
    opkg update
    opkg install vsftpd openssh-sftp-server
    /etc/init.d/vsftpd enable
    /etc/init.d/vsftpd start


    小米端口转发命令:


    通过修改 /etc/config/firewall 这个文件来实现开放自己需要的端口到外网。


    config rule 'httpdwan'      
            option src 'wan'     
            option dest_port '8088'
            option proto 'tcp'
            option target 'ACCEPT'
            option name ''\''httpd wan accept tcp port 8088'\'''





    保存后,执行 /etc/init.d/firewall restart 重启防火墙。


    SSH工具:
    1.WINSCP

    下载附件WinSCP_19281.rar( 7.7 MB )


    2.putty中文版

    下载附件putty中文版.rar( 234.57 KB )

    中文的使用的难度相对低一点
    3.熟练一些的用户推荐 SecureCRT
    操作多台设备的时候,十分的方便。这个自行搜索安装吧~


    另附VI命令图:
    展开全文
  • OpenWrt命令行启动WiFi

    万次阅读 2014-01-20 17:50:21
    Using interface wlan0 with hwaddr 00:03:7f:42:03:25 and ssid "OpenWrt" [ 3168.510000] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 3168.520000] br-lan: port 3(wlan0) entered forwarding ...

    # cd /etc/config

    # vim /etc/config/wireless

    config wifi-device  radio0

            ........

            # REMOVE THIS LINE TO ENABLE WIFI:

            #option disabled 1

    # /sbin/wifi up

    Configuration file: /var/run/hostapd-phy0.conf
    [ 3168.440000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 3168.470000] device wlan0 entered promiscuous mode
    [ 3168.490000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    Using interface wlan0 with hwaddr 00:03:7f:42:03:25 and ssid "OpenWrt"
    [ 3168.510000] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 3168.520000] br-lan: port 3(wlan0) entered forwarding state
    [ 3168.520000] br-lan: port 3(wlan0) entered forwarding state
    [ 3170.520000] br-lan: port 3(wlan0) entered forwarding state

    展开全文
  • luci-theme-openwrt - 0.10.0-1 即可完成LUCI的安装。 输入以下命令开启支持web服务的uhttpd,并设置其为自启动: Shell代码  /etc/init.d/uhttpd enable # 开机自启动  /etc/init.d/uhttpd start # 启动...
  • OpenWrt 通过命令行设置IP为DHCP获取 环境 OpenWrt 19.07 针对当前固件修改 在当前设备命令行执行 vi /etc/config/network 将config interface 'lan’下的 static 修改为DHCP即可 重启生效 reboot 源码修改 vi ...
  • OPENWRT使用命令行设置无线和有线网络 OPENWRT使用命令行设置无线和有线网络   在我们将路由器固件刷成开源的基于Linux内核的openwrt系统后,由于openwrt默认未安装WEB管理界面,所以我们需要先通过SSH或者...
  • 下面我们要使用 sysupgrade 更新固件到trunk最新版。...今天我们要尝试的的是命令行刷机升级。命令行的方式更强大。 SSH登录路由器 在Ubuntu里,按Ctrl+Alt+T打开命令行终端,输入: ssh root@192.16
  • OpenWrt sysupgrade 命令行更新固件到最新版 下面我们要使用 sysupgrade 更新固件到trunk最新版。 要注意的是,trunk包含试验的功能,可能不稳定,刷机风险自己承担。 在浏览器里登陆 192.168.1.1 进行固件升级是...
  • 在我们将路由器固件刷成开源的基于Linux内核的openwrt系统后,由于openwrt默认未安装WEB管理界面,所以我们需要先通过SSH或者telnet对路由器进行网络设置,设置完成后可通过openwrt的软件包管理opkg
  • openwrt之ubus命令行工具

    千次阅读 2016-07-22 09:15:39
    root@OpenWrt:~# ubus Usage: ubus [] [arguments...] Options:  -s : Set the unix domain socket to connect to 设置unix的套接字连接到    -t : Set the timeout
  • OPENWRT设置之命令行下简单配置有线和无线 先配置有线 设置lan ip(即访问路由的ip) uci set network.lan.ipaddr=[lan ip] 复制代码 pppoe用户 uci set network.wan.pro
  • 命令行修改OpenWrt的IP地址

    千次阅读 2021-03-01 16:16:22
    OpenWrt安装好之后,默认的IP地址是192.168.1.1,很多时候是不符合实际需求的,所以需要修改。 以下操作是在命令行下输入的: 1、以root的身份登录; 2、修改/etc/config/network文件: vim /etc/config/network ...
  • 初识OPENWRT:uci介绍与命令行运用

    千次阅读 2017-11-21 09:15:10
    作用:UCI是集中式配置信息管理接口(Unified Configuration Interface),是OpenWrt引进的一套配置 参数管理系统。 日前已有大量软件包支持UCI模式管理,但不是所有的软件包,支持的软件包是这样来完成 启动的(以...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,025
精华内容 810
关键字:

openwrt命令行