精华内容
下载资源
问答
  • 西南科技大学网络程序设计综合实验,八说了,开冲 2实验目的 锻炼按照软件工程过程对实际应用进行分析、设计和编程的能力; 综合运用在本课程与相关课程中学过的知识,结合实际工程应用环境,在设计 过程中加深...
  • 网络程序设计综合实验网络程序设计综合实验网络程序设计综合实验网络程序设计综合实验网络程序设计综合实验 包含多个版本的五子棋程序包含多个版本的五子棋程序包含多个版本的五子棋程序包含多个版本的五子棋程序...
  • WeTalk是一款基于Windows网络编程技术和MFC实现的聊天应用,该应用采用了Client/Server结构,可以实现多个客户端与服务器建立连接,用户可以通过客户端进行聊天,用户可以发群聊消息,也可以对指定的用户发消息,...
  • 实验题目二:自选网络通信程序设计(可选)  实验要求 可以自选与网络通信相关的设计题目,要求如下: 1、在确定实验题目、设计内容以及设计功能指标要求后,向实验指导教师提交书面申请,由实验指导教师根据所选...
  • 网络程序设计 实验报告 ... 实验成绩_ 实验七 网络程序设计综合实验 摘要本课程设计包含了文件传输协议的简单设计与实现文件传送协议是一 种最基本的应用层协议按照客户/服务器的模式进行工作提供交互式的访问是INTE
  • 网络程序设计实验设计题目:AOD.Net用户登录认证 完整实验报告另附源代码
  • 基于网络环境的程序设计综合实验 综合实验报告 实验课程目的: 本实验课程的目的是通过对网络软件的学习与分析,提高同学们对网络环境下的程序的认识水平;同时,实践于网络软件的设计与编程实现,从而提高同学们...
      
    

    基于网络环境的程序设计综合实验

    综合实验报告

    实验课程目的:

    本实验课程的目的是通过对网络软件的学习与分析,提高同学们对网络环境下的程序的认识水平;同时,实践于网络软件的设计与编程实现,从而提高同学们对该类软件的程序设计与开发能力。

    下面的基于网络环境的程序简称为网络软件。

    撰写综合实验报名的目的:

    1、叙述清楚自己对网络软件的认识水平,展示自己对网络软件的分析能力;

    2、展示自己对网络软件的设计能力和编程水平;

    3、展示自己的文档组织能力和撰写水平。

    实验内容:

    1、对现有网络软件进行分析并做出文档;

    2、确定技术方向,设计出自己软件的设计文档;

    3、根据设计文档编程实现。

    实验报告结构组成:

    l        封面

    l        标题

    l        学号 姓名 班级

    l        实验环境

    l        实验内容目录

    l        网络软件分析文档

    l        自己软件设计文档

    l        自已软件实现文档

    l        结束语

    l        附件目录

    实验报告结构组成说明:

    1、封面:应含“基于网络环境的程序设计综合实验报告”字样,含标题、学号、姓名和班级;

    2、实验环境可分为分析、设计与开发环境,务求真实与详实;

    3、实验内容目录:报名文档通篇目录,特别是分析文档、设计文档和实验文档的下一级目录应该包含;

    4、分析文档:将作业1最终稿整理拷贝至此;

    5、设计文档:软件设计的各类技术图表和文字,务必包含系统结构图和层次功能图;

    6、实现文档:实现的叙述文档,可只展示程序所有界面以及各界面的关键性程序代码。

    7、结束语:对自己的学习过程进行总结,对自己的学习内容进行总结,对自己的提高(技术、方法等方面)效果总结。

    8:附件目录:实验过程中所有使用的文稿;

       参考:

    (1)    网络软件分析图表(Visio文件,含系统结构图和层次功能图);

    (2)    软件设计图表(Visio文件,含系统结构图、层次功能图、数据流图、系统框架图等);

    (3)    项目和程序源代码及资源文件;

    (4)    数据库包

    (5)    程序部署发布文件包(含部署说明)与数据库实施文档;

    (6)    相关环境软件(大于20MB不提交)。

    实验报告撰写格式:

    题目(20字以内、小二号隶书)

    学号、姓名、班级(小四宋体)

    1、一级标题(以1、2、3、….开头,四号宋体加粗)

    1.1 二级标题(四号宋体)

    1.1.1 三级标题(小四宋体)

    正文XXXXXXXXXXXX(小四宋体,首行缩进2字符)

    正文内容分点采用(1)(2)(3)……,①②③……。

     

    实验课程的评分标准:

    序号

    内容

    分值

    1

    文章封面(好、中、差三个等级)

    5分

    2

    文档的写作文笔与格式规范

    20分

    3

    网络软件的分析

    25分

    4

    自己软件的分析与设计

    25分

    5

    自己软件的编程实现

    15分

    6

    提交材料的完整程度

    10分

     

    展开全文
  • 2、培养学生对网络环境下的程序的分析能力; 3、提高学生对网络环境下的程序的编程水平; 4、使用学生掌握一定的程序评价技术; 5、使用部分基础较好的学生制做出具有一定价值的网络软件。   实验过程与计划:...

    实验目的:

    1、培养学生对网络环境的认识;

    2、培养学生对网络环境下的程序的分析能力;

    3、提高学生对网络环境下的程序的编程水平;

    4、使用学生掌握一定的程序评价技术;

    5、使用部分基础较好的学生制做出具有一定价值的网络软件。

     

    实验过程与计划:

    第一步 学习网络环境与网络软件(1-2周);

    第二步 分析网络软件并确定开发语言(1-2周);

    第三步 设计软件并编程实现(4-8周);

    第四步 网络软件实施与维护(1周);

    第五步 撰写文档,与程序一起提交(2周)。

     

    工作量指标:

    1、对不少于三类网络环境进行了解;

    2、对不少于五个网络软件的进行分析;

    3、设计不少于三个图,软件模块不少于三个;

    4、源程序代码不少于10个文件;

    5、提交文档不少于15页(含图);

    6、程序包含:源码、发布软件、相关资料(如:用户使用说明、实施步骤说明、实施环境相关软件(超过10MB只提供下载路径)等)。

     

    学习用时:

    共9-12周时间,上机实验时间为:一周4学时,平时自由保证学时为:每周15小时。

     

    展开全文
  • 网络工程汇编语言实验报告(两只老虎+综合程序设计).zip
  • windows 网络程序设计 考试资料 西南科技大学 西南科大 实验报告,已写
  • 网络课程设计中,Select模型代码编程 工作于非阻塞模式下
  • 实验网络综合设计实验

    千次阅读 2019-05-30 11:20:17
    网络综合设计实验 一、实验目的 1、 掌握以太网交换机基本概念,完成交换机的基本配置; 2、掌握路由器的构成、工作原理、基本配置; 3、学习常用网络层级结构及网络协议,掌握动态聚合的配置方法,能根据需要...

    网络综合设计实验

    一、实验目的

    1、 掌握以太网交换机基本概念,完成交换机的基本配置;

    2、掌握路由器的构成、工作原理、基本配置;

    3、学习常用网络层级结构及网络协议,掌握动态聚合的配置方法,能根据需要进行简单网络的规划和设计。

     

    二、实验内容

    根据网络环境描述及需求,规划设计办公网络,并按给定需求配置相关网络设备。

    • 网络环境描述

    某公司总部位于青岛市市南区,并在市北设有办公点。总部中心机房设有DNS服务器、IIS服务器等若干台。现因业务需要,需在公司内部架设网络系统,实现各办公地点之间的网络互通,满足日常数据传输需要。

    (二)网络需求(以参考图示为例)

    1. R1、SW1、SW3运行OSPF协议。
    2. R1上开启OSPF,宣告100.1.1.0/24网段和200.1.1.0/24网段进人area 0,开启loopback口,设定IP 1.1.1.1/24,将1.1.1.0/24网段宣告进area 3。
    3. SW1、SW3开启SVI子接口和路由器相连,SW1和SW3通过VLAN10互联。
    4. SW3、SW4的5口和6口进行链路聚合,并归属于VLAN20,在SW3和SW1上 show ip route,要求有全网络的路由,其中包括20.1.1.0/24。

     

    三、实验设备

    计算机、路由器、交换机

     

    四、实验步骤

        1、根据以上要求,设计网络层级结构及设备部署方案;

    2、根据以上要求,规划IP、网段、VLAN等的分配方案,并实施配置;

    3、在客户机上利用ping命令测试终端设备间是否连同,并在交换机、路由器上测试VLAN、链路聚合是否生效。

    图7-1、网络拓扑图

    五、实验注意事项

    1.每登陆一次设备都要登陆一次“超级终端”。

    2交换机3与交换机4的链路聚合尽量先做,防止环路产生大量的ARP包。

    3.物理端口的端口配置信息要和链路聚合组端口的配置信息一一对应。

    4.出现报错信息“^”请检查命令是否输错。

     

    六、实验报告要求

    1.画出实验拓扑图并以表格的方式列出IP及端口规划。

    2. 在路由器上使用“show ip protocol routing”,在交换机1和交换机3上使用“show ip route”查看路由信息,并记录。

    3. 在交换机1上ping实验拓扑中的任意网段可以ping通。

    (1)不同交换机的相同vlan是否通。

    (2)不同交换机的不同vlan是否通。

    如:ping 10.1.1.3; ping 100.1.1.1; ping 200.1.1.3;ping 20.1.1.3。

     

     

    附录:

    表7-1、设备ip及端口规划

    机柜

    路由器1800-2s

    交换机5950-1

    交换机5950-2

    交换机3950-1

    交换机3950-2

    11

    192.168.1.231:10001

    192.168.1.241:10001

    192.168.1.241:10002

    192.168.1.241:10003

    192.168.1.241:10004

    10

    192.168.1.231:10003

    192.168.1.242:10001

    192.168.1.242:10002

    192.168.1.242:10003

    192.168.1.242:10004

    9

    192.168.1.232:10001

    192.168.1.243:10001

    192.168.1.243:10002

    192.168.1.243:10003

    192.168.1.243:10004

    8

    192.168.1.232:10003

    192.168.1.244:10001

    192.168.1.244:10002

    192.168.1.244:10003

    192.168.1.244:10004

    7

    192.168.1.233:10001

    192.168.1.245:10001

    192.168.1.245:10002

    192.168.1.245:10003

    192.168.1.245:10004

    6

    192.168.1.233:10003

    192.168.1.246:10001

    192.168.1.246:10002

    192.168.1.246:10003

    192.168.1.246:10004

     

    (一)、实验室设备超级终端访问方式:

    (注:以机柜10为例)

    1. 点击超级终端启动程序
    2. 随意输入,如R1、sw1、sw2等名称,点击确定。

    1. 输入规划好的ip及端口号,连接时使用设置为“TCP/IP(Winsock)”点击确定。

    1. 进入终端,准备配置。

    • 注意路由器1800-2s是全新款的设备,所以它在进入特权模式的时候需要加权。如:enable 18

    (18为权值)

    只有路由器进入特权模式时需要加权,交换机不需要加权。

    • 所有设备的enable密码都是 zxr10

    实验设备的配置

     

    交换机3950-1 

    SW3:

    ZXR10>enable

    password:zxr10

    ZXR10#conf t

     

    ZXR10(config)#interface fei_1/11

    ZXR10(config-fei_1/11)#switchport mode access

    ZXR10(config-fei_1/11)#switchport  access vlan 10

    ZXR10(config-fei_1/11)#exi

    ZXR10(config)#interface fei_1/2

    ZXR10(config-fei_1/2)#switchport mode access

    ZXR10(config-fei_1/2)#switchport access vlan 200

    ZXR10(configcon-fei_1/2)#exit

     

    ZXR10(config)#interface  vlan 10

    ZXR10(config-if-vlan10)#  ip  address  10.1.1.3  255.255.255.0

    ZXR10(config-if-vlan10)#exi

    ZXR10(config)#vlan 20

    ZXR10(config)#exit

    ZXR10(config)#interface vlan 20

    ZXR10(config-if-vlan20)#ip  address  20.1.1.3  255.255.255.0

    ZXR10(config-if-vlan20)#exi

    ZXR10(config)#interface vlan 200

    ZXR10(config-if-vlan200)#  ip  address  200.1.1.3  255.255.255.0

    ZXR10(config-if-vlan200)#exit

    ZXR10(config)#interface smartgroup1

    ZXR10(config-smartgroup1)#  smartgroup mode 802.3ad

    ZXR10(config-smartgroup1)# switchport  mode access

    ZXR10(config-smartgroup1)#   switchport  acces s vlan 20

    ZXR10(config-smartgroup1)#exi

    ZXR10(config)#interface fei_1/5

    ZXR10(config-fei_1/5)#switchport   mode access

    ZXR10(config-fei_1/5)#switchport access vlan 20

    ZXR10(config-fei_1/5)#smartgroup 1 mode active

    ZXR10(config-fei_1/5)#exi

    ZXR10(config)#interface fei_1/7

    ZXR10(config-fei_1/7)#switchport   mode access

    ZXR10(config-fei_1/7)#switchport access vlan 20

    ZXR10(config-fei_1/7)#smartgroup 1 mode active

    ZXR10(config-fei_1/7)#exi

    ZXR10(config)#router ospf 1

    ZXR10(config-router)# network  10.1.1.0  0.0.0.255  area  1

    ZXR10(config-router)# network  20.1.1.0  0.0.0.255  area  2

    ZXR10(config-router)# network  200.1.1.0  0.0.0.255  area  0

     

    -----------------------------------------------------------

     

    交换机3950-2 

    SW4:

    ZXR10>enable

    password:zxr10

    ZXR10#conf t

    ZXR10(config)#vlan 20

    ZXR10(config-vlan20)#exit

    ZXR10(config)#interface smartgroup1

    ZXR10(config-smartgroup1)#  smartgroup mode 802.3ad

    ZXR10(config-smartgroup1)# switchport   mode access

    ZXR10(config-smartgroup1)#   switchport access vlan 20

    ZXR10(config-smartgroup1)#exi

    ZXR10(config)#interface fei_1/5

    ZXR10(config-fei_1/5)#switchport   mode access

    ZXR10(config-fei_1/5)#switchport access vlan 20

    ZXR10(config-fei_1/5)#smartgroup 1 mode passive

    ZXR10(config-fei_1/5)#exi

    ZXR10(config)#interface fei_1/7

    ZXR10(config-fei_1/7)#switchport  mode  access

    ZXR10(config-fei_1/7)#switchport access vlan 20

    ZXR10(config-fei_1/7)#smartgroup 1 mode passive

    -----------------------------------------------------------

     

    交换机5950-1 

    SW1:

    ZXR10>enable

    password:zxr10

    ZXR10#conf t

    ZXR10(config)#interface gei_1/11

    ZXR10(config-gei_1/11)#switchport mode access

    ZXR10(config-gei_1/11)#switchport access vlan 100

    ZXR10(config-gei_1/11)#exi

    ZXR10(config)#interface gei_1/9

    ZXR10(config-gei_1/9)#switchport mode access

    ZXR10(config-gei_1/9)#switchport access vlan 10

    ZXR10(config-gei_1/9)#exi

    ZXR10(config)#interface vlan 10

    ZXR10(config-if-vlan10)#ip address 10.1.1.1  255.255.255.0

    ZXR10(config-if-vlan10)#exi

    ZXR10(config)# interface vlan 100

    ZXR10(config-if-vlan100)#  ip  address  100.1.1.2  255.255.255.0

    ZXR10(config-if-vlan100)#exi 

    ZXR10(config)#router ospf 1

    ZXR10(config-router)#  network  10.1.1.0  0.0.0.255  area  1

    ZXR10(config-router)#  network  100.1.1.0  0.0.0.255  area  0

     

    -----------------------------------------------------------

     

    交换机5950-2  

    SW2:

    ZXR10>enable

    password:zxr10

    ZXR10#conf t

    ZXR10(config)#interface gei_1/9

    ZXR10(config-gei_1/9)#switchport mode access

    ZXR10(config-gei_1/9)# switchport access vlan 10

    ZXR10(config-gei_1/9)#exi

    ZXR10(config)#interface gei_1/11

    ZXR10(config-gei_1/11)#switchport mode access

    ZXR10(config-gei_1/11)# switchport access vlan 10

     

    -----------------------------------------------------------

     

    路由器1800-2s

    R1:

    ZXR10>en 18

    Password:zxr10

    ZXR10#conf t

    ZXR10(config)#interface gei-2/1

    ZXR10(config-if-gei-2/1)#  ip  address  100.1.1.1  255.255.255.0

    ZXR10(config-if-gei-2/1)#  no shutdown

    ZXR10(config-if-gei-2/1)#exi

    ZXR10(config)#interface gei-2/2

    ZXR10(config-if-gei-2/2)#  ip  address  200.1.1.1  255.255.255.0

    ZXR10(config-if-gei-2/2)#  no shutdown

    ZXR10(config-if-gei-2/2)#exi

    ZXR10(config)#interface loopback1

    ZXR10(config-if-loopback1)#  ip  address  1.1.1.1  255.255.255.0

    ZXR10(config-if-loopback1)# exi

    ZXR10(config)#router ospf 1

    ZXR10(config-ospf-1)# network  1.1.1.0  0.0.0.255  area  3

    ZXR10(config-ospf-1)# network  100.1.1.0  0.0.0.255  area  0

    ZXR10(config-ospf-1)# network  200.1.1.0  0.0.0.255  area  0

     

    -----------------------------------------------------------

     

    查看配置结果:

    1、查看smartgroup 信息:

    ZXR10 (config)#show lacp 1 internal

    2、查看vlan信息:

    ZXR10 (config)#show vlan

    3、查看端口信息:

    (config)#show interface brief

    4、查看是否联通

    ZXR10# ping 10.1.1.3

    (返回!!!!为联通,返回…..为不通)

     

    展开全文
  • 实验报告 2016 / 2017 学年第2学期 课程名称 JAVA程序设计 实验名称 综合图形界面程序设计 实验时间 2017 年 6 月 2 日 指导单位 计算机学院计算机系统与网络教学中心 指导教师 学生姓名 班级学号 学院系 计算机学院...
  • 网络程序设计

    2014-05-21 10:06:56
    网络程序设计SOCKET,java,通信编程
  • 题目关键字 linux shell程序设计实验1 题目录入时间 2013-5-6 10:25:36 题目内容 完成课本实验6的第2题,要有输入错误处理。 题目创建人 题目注释 把程序文件以附件形式提交即可。 题目名称 linux ...
  • 07 数据库系统设计综合实验 实验报告

    万次阅读 多人点赞 2018-07-30 01:23:22
    07 数据库系统设计综合实验 实验报告  广州大学学生实验报告  开课学院及实验室:计算机科学与工程实...

                                         07 数据库系统设计综合实验  实验报告

                                                                                  广州大学学生实验报告

                                     开课学院及实验室:计算机科学与工程实验室418B室         2018年06月 14 日

    学院

    计算机科学与教育软件

    年级、专业、班

    网络***

    姓名

    卟咚君

    学号

    1606100***

    实验课程名称

    数据库原理实验

    成绩

     

    实验项目名称

    数据库系统设计综合实验

    指导老师

    ***

             

    预备知识

    本实验的任务是设计并实现一个数据库系统。数据库设计的一般步骤包括:需求分析、概念结构设计、逻辑结构设计、物理结构设计、数据库实施、数据库运行和维护。

    (1)  概念结构设计

    了解概念结构设计的基本方法,根据需求分析的结果或实验题目给出的要求,能够准确地用实体联系图来描述实体和实体之间的联系。

    (2)  逻辑结构设计

    理解逻辑结构设计的基本方法,根据实体联系图的设计,转换成合理的关系模式,每个关系模式至少应该满足第三范式的要求。

    (3)  物理结构设计

    理解物理结构设计的基本方法,选择合理的索引结构和存储结构,优化数据库的存取。

    (4)  数据库实施

    选择一门熟悉的面向对象程序设计语言,完成应用程序的开发。

    实验目的

    通过实验,使学生掌握数据库系统设计和开发的一般方法,能够设计并实现简单的数据库系统。

    实验要求

    熟悉实验室实验环境,掌握实验预备知识,了解实验中故障排除的基本方法。实验中根据实验要求完成相应的任务,并独立完成实验报告。

    实验环境

    Oracle 10gwindows 2003

    实验内容和步骤

    假设有“教师”、“学生”、“课程”三个实体,教师的基本信息包括:工号、姓名、职称、工资,课程的基本信息包括:课程号、课程名、学分数,学生的基本信息包括:学号、姓名、性别、年龄。系统必须满足以下要求:

    (1)  一门课程只能有一个教师任课,一个教师可以上多门课程;

    (2)  一个学生可以选修多门课程,一门课程可以由多个学生来选修,记录不同学生选修不同课程的成绩;

    (3)  设置一个管理员,用于维护(添加、删除和修改等基本任务)学生基本信息、教师基本信息和教师所授课程等工作,此外,管理员添加学生时,为其设置初始密码;当学生选修了某门课程,课程成绩由管理员录入;

    (4)  学生可以利用学号和密码登录系统,登陆系统后,可以进行选课、修改密码和个人基本信息、查询自己的选课及总学分等操作;

    (5)  能够统计不同职称的教师的数量、不同职称的教师的平均工资,可以统计每门课程的平均成绩、最高分、最低分,统计每个学生选修课程的总学分;

    根据上述描述,解答下列问题:

    1. 设计并画出E-R图,要求标注连通词(即联系类型);

    1. E-R图转化为关系模型,并指出各关系的主码和外码;

    关系模型为:

    teacher(tno,tname,tposition,tsalary,pwd),其中,tnoteacher表的主码

    course(cno,cname,ccredit,tno),其中,cnocourse表的主码

    student(sno,sname,ssex,sage,pwd),其中,snostudent表的主码

    sc(sno,con,grade),其中,(sno,cno)sc表的主码,sno为外码,参照student(sno),cno为外码,参照course(cno)

    1. MySqlSQL ServerOracle中选择一个数据库管理系统,并设计数据库的物理结构;

    创建用户byd003,密码为byd123

    create user byd003 identified by byd123;

    grant connect,resource,unlimited tablespace to byd003;

    grant create view to byd003;

    在用户byd003下创建表sutudentteachercoursesc,视图studentinfocourseinfo

    drop table teacher cascade constraints;

    drop table student cascade constraints;

    drop table course cascade constraints;

    drop table sc cascade constraints;

    create table Student

    (

      sno varchar(10) primary key,/*列级完整性约束条件*/

      sname varchar(20) not null unique,

      ssex char(3) check(ssex in('男','女')),

      sage smallint not null,

      pwd varchar(20) not null

    );

    select *from student;

    create table teacher

    (

      tno varchar(7) primary key,/*列级完整性约束条件*/

      tname varchar(20) not null unique,

      tposition varchar(20) not null,

      tsalary smallint not null,

      pwd varchar(20) not null

      );

    select *from teacher;

    create table course

    (

      cno varchar(4) primary key,

      cname varchar(40) not null unique,

      ccredit smallint not null,

      tno varchar(7) not null,

      foreign key (tno) references teacher(tno)

    );

    select *from course;

    create table sc

    (

      sno varchar(10) not null,

      cno varchar(4) not null,

      grade smallint not null,

      primary key(sno,cno),

      foreign key (sno) references student(sno),

      foreign key (cno) references course(cno) 

    );

    select *from sc;

    insert into student(sname,ssex,sno, sage, pwd) values('李勇','男','201215121',20,'123456');

    insert into student(sname,ssex,sno, sage, pwd) values('刘晨','女','201215122',19,'123456');

    insert into student(sname,ssex,sno, sage, pwd) values('王敏','女','201215123',18,'123456');

    insert into student(sname,ssex,sno, sage, pwd) values('张立','男','201215125',19,'123456');

    insert into student(sname,ssex,sno, sage, pwd) values('卟咚君','男','1606100236',19,'123456');

    select *from student;

    insert into teacher(tno,tname, tposition, tsalary, pwd) values('t001','张三','教授',30000,'123456');

    insert into teacher(tno,tname, tposition, tsalary, pwd) values('t002','李四','副教授',35000,'123456');

    insert into teacher(tno,tname, tposition, tsalary, pwd) values('t003','熊猫','教授',45000,'123456');

    insert into teacher(tno,tname, tposition, tsalary, pwd) values('t004','王小二','副教授',38000,'123456');

    insert into teacher(tno,tname, tposition, tsalary, pwd) values('t005','李小小','副教授',42000,'123456');

    insert into teacher(tno,tname, tposition, tsalary, pwd) values('t006','李小龙','教授',60000,'123456');

    select *from teacher;

    insert into course values('6','数据处理',2,'t001');

    insert into course values('2','数学',2,'t002');

    insert into course values('7','PASCAL语言',4,'t003');

    insert into course values('5','数据结构',4,'t002');

    insert into course values('1','数据库',4,'t003');

    insert into course values('3','信息系统',4,'t004');

    insert into course values('4','操作系统',3,'t005');

    select *from course;

    insert into sc values('201215121','1',92);

    insert into sc values('201215121','2',85);

    insert into sc values('201215121','3',88);

    insert into sc values('201215122','2',90);

    insert into sc values('201215122','3',80);

    select *from sc;

    drop view courseinfo;

    drop view studentinfo;

    create view courseinfo as select course.cno 课程编号,course.cname 课程名称,teacher.tname 任课老师,course.ccredit 课程学分,countnum 选修人数,avg_grade 平均分,max_grade 最高分,min_grade 最低分 from teacher,course left outer join (select cname, count(*) countnum,avg(grade)  avg_grade,max(grade)  max_grade,min(grade) min_grade from sc,course where course.cno=sc.cno group by cname)a1 on (course.cname=a1.cname) where teacher.tno=course.tno;

    select *from courseinfo;

    create view studentinfo as select student.sno 学号,student.sname 姓名,(select sum(grade) from sc where sno=student.sno) 总分 ,(select sum(ccredit) from course where cno in (select cno from sc where sno=student.sno)) 总学分 ,(select max(grade) from sc where sc.sno in (student.sno)) 最高分,(select min(grade) from sc where sc.sno in (student.sno)) 最低分 from student;

    select *from studentinfo;

    create view teacherinfo1 as select tposition 职位,count(tno) 在任人数,avg(tsalary) 平均工资 from teacher group by tposition;

    create view teacherinfo2 as select tno 教师工号,tname 教师名称,(select count(student.sno) from student,sc,course where student.sno=sc.sno and sc.cno=course.cno and course.tno=teacher.tno) 授课学生总人数 from teacher;

    select * from studentinfo where 姓名 like '卟咚君';

    insert into sc values('1606100236','7',80);

    insert into sc values('1606100236','2',80);

    insert into sc values('201215121','2',90);

    insert into sc values('201215122','2',60);

    insert into sc values('201215123','2',80);

    insert into sc values('201215125','2',50);

    commit;

    1. 选择一门熟悉的面向对象程序设计语言,完成系统开发。

    部分C#代码:

    定义的学生类:

    using Oracle.ManagedDataAccess.Client;
    
    using System;
    
    using System.Collections.Generic;
    
    using System.Configuration;
    
    using System.Linq;
    
    using System.Text;
    
    using System.Threading.Tasks;
    
    using System.Windows.Forms;
    
    namespace byd001_app
    
    {
    
        class student
    
        {
    
            public string sno { get; set; }
    
            public string sname { get; set; }
    
            public string ssex { get; set; }
    
            public int sage { get; set; }
    
            public string pwd { get; set; }
    
            public static List<student> Selectstudent(string sname)
    
            {
    
                string sql = "select sno,sname,ssex,sage,pwd from student where sname like :sname";
    
                OracleParameter[] para = new OracleParameter[] { new OracleParameter(":sname", OracleDbType.Char, 20) };
    
                para[0].Value = sname + "%";
    
                //MessageBox.Show(tname+"%");
    
                List<student> list = new List<student>();
    
                //创建链接,打开连接,创建命令对象,执行命令,关闭连接
    
                OracleConnection con = new OracleConnection(ConfigurationManager.ConnectionStrings["strCon"].ConnectionString);
    
                try
    
                {
    
                    con.Open();
    
                    OracleCommand cmd = new OracleCommand(sql, con);
    
                    cmd.Parameters.AddRange(para);
    
                    OracleDataReader odr = cmd.ExecuteReader();
    
                    while (odr.Read())
    
                    {
    
                        student s = new student();
    
                        //c.Cno = odr.GetString(0); //ord["cno'].
    
                        s.sno = odr["sno"].ToString();
    
                        //t.tno = odr.GetString(0);
    
                        s.sname = odr.GetString(1);
    
                        s.ssex= odr.GetString(2);
    
                        s.sage = odr.GetInt32(3);
    
                        if (common.ID == "0")
    
                            s.pwd = odr.GetString(4);
    
                        else
    
                            s.pwd = "******";
    
                        list.Add(s);
    
    
    
                    }
    
                }
    
                catch (Exception ex)
    
                {
    
                    MessageBox.Show(ex.Message);
    
                }
    
                finally
    
                {
    
                    con.Close();
    
                }
    
                return list;
    
            }
    
            public static int Deletestudent(string sno)
    
            {
    
                int result = 0;
    
                string sql = "delete from student where sno=:sno";
    
                OracleParameter[] para = new OracleParameter[] { new OracleParameter(":sno", OracleDbType.Char, 10) };
    
                para[0].Value = sno;
    
                OracleConnection con = new OracleConnection(ConfigurationManager.ConnectionStrings["strCon"].ConnectionString);
    
                try
    
                {
    
                    con.Open();
    
                    OracleCommand cmd = new OracleCommand(sql, con);
    
                    cmd.Parameters.AddRange(para);
    
                    result = cmd.ExecuteNonQuery();
    
                }
    
                catch (Exception ex)
    
                {
    
                    MessageBox.Show(ex.Message);
    
                }
    
                finally
    
                {
    
                    con.Close();
    
                }
    
                return result;
    
            }
    
            public static int Insertstudent(student s)
    
            {
    
                int result = 0;
    
                string sql = "insert into student(sno,sname,ssex,sage,pwd) values(:sno,:sname,:ssex,:sage,:pwd)";
    
                OracleParameter[] para = new OracleParameter[] {new OracleParameter(":sno",OracleDbType.Char,10),
    
                                                              new OracleParameter(":sname",OracleDbType.Char,20),
    
                                                              new OracleParameter(":ssex",OracleDbType.Char,3),
    
                                                              new OracleParameter(":sage",OracleDbType.Int32),
    
                                                              new OracleParameter(":pwd",OracleDbType.Char,20)};
    
                para[0].Value = s.sno;
    
                para[1].Value = s.sname;
    
                para[2].Value = s.ssex;
    
                para[3].Value = s.sage;
    
                para[4].Value = s.pwd;
    
                OracleConnection con = new OracleConnection(ConfigurationManager.ConnectionStrings["strCon"].ConnectionString);
    
                try
    
                {
    
                    con.Open();
    
                    OracleCommand cmd = new OracleCommand(sql, con);
    
                    cmd.Parameters.AddRange(para);
    
                    result = cmd.ExecuteNonQuery();
    
    
    
                }
    
                catch (Exception ex)
    
                {
    
                    MessageBox.Show(ex.Message);
    
                }
    
                finally
    
                {
    
                    con.Close();
    
                }
    
                return result;
    
            }
    
            public static int Updatestudent(student s)
    
            {
    
                int result = 0;
    
                string sql = "update student set sname=:sname,ssex=:ssex,sage=:sage,pwd=:pwd where sno=:sno";
    
                OracleParameter[] para = new OracleParameter[] {new OracleParameter(":sname",OracleDbType.Char,20),
    
                                                                new OracleParameter(":ssex",OracleDbType.Char,20),
    
                                                                new OracleParameter(":sage",OracleDbType.Int32),
    
                                                                new OracleParameter(":pwd",OracleDbType.Char,20),
    
                                                                new OracleParameter(":sno",OracleDbType.Char,10)};
    
                para[0].Value = s.sname;
    
                para[1].Value = s.ssex;
    
                para[2].Value = s.sage;
    
                para[3].Value = s.pwd;
    
                para[4].Value = s.sno;
    
                OracleConnection con = new OracleConnection(ConfigurationManager.ConnectionStrings["strCon"].ConnectionString);
    
                try
    
                {
    
                    con.Open();
    
                    OracleCommand cmd = new OracleCommand(sql, con);
    
                    cmd.Parameters.AddRange(para);
    
                    result = cmd.ExecuteNonQuery();
    
    
    
                }
    
                catch (Exception ex)
    
                {
    
                    MessageBox.Show(ex.Message);
    
                }
    
                finally
    
                {
    
                    con.Close();
    
                }
    
                return result;
    
            }
    
        }
    
    }

    学生查询窗口:

    using System;
    
    using System.Collections.Generic;
    
    using System.ComponentModel;
    
    using System.Data;
    
    using System.Drawing;
    
    using System.Linq;
    
    using System.Text;
    
    using System.Threading.Tasks;
    
    using System.Windows.Forms;
    
    
    
    namespace byd001_app
    
    {
    
        public partial class Form_studentQuery : Form
    
        {
    
            public Form_studentQuery()
    
            {
    
                InitializeComponent();
    
            }
    
    
    
            private void button1_Click(object sender, EventArgs e)
    
            {
    
                this.dataGridView1.DataSource = student.Selectstudent(this.textBox1.Text);
    
            }
    
    
    
            private void Form_studentQuery_Load(object sender, EventArgs e)
    
            {
    
                this.dataGridView1.DataSource = student.Selectstudent(this.textBox1.Text);
    
            }
    
        }
    
    }

    添加学生:

    using System;
    
    using System.Collections.Generic;
    
    using System.ComponentModel;
    
    using System.Data;
    
    using System.Drawing;
    
    using System.Linq;
    
    using System.Text;
    
    using System.Threading.Tasks;
    
    using System.Windows.Forms;
    
    
    
    namespace byd001_app
    
    {
    
        public partial class Form_studentInsert : Form
    
        {
    
            public Form_studentInsert()
    
            {
    
                InitializeComponent();
    
            }
    
    
    
            private void button1_Click(object sender, EventArgs e)
    
            {
    
                student s = new student();
    
                s.sno = tbsno.Text;
    
                s.sname = tbsname.Text;
    
                s.ssex = tbssex.Text;
    
                s.sage= Convert.ToInt32(tbsage.Text);
    
                s.pwd = tbpwd.Text;
    
                //把课程c放入数据库
    
                if (student.Insertstudent(s) == 1)
    
                {
    
                    MessageBox.Show("insert success");
    
                }
    
            }
    
        }
    
    }
    
    

    修改学生1:

    using System;
    
    using System.Collections.Generic;
    
    using System.ComponentModel;
    
    using System.Data;
    
    using System.Drawing;
    
    using System.Linq;
    
    using System.Text;
    
    using System.Threading.Tasks;
    
    using System.Windows.Forms;
    
    
    
    namespace byd001_app
    
    {
    
        public partial class Form_studentUpdate : Form
    
        {
    
            public Form_studentUpdate()
    
            {
    
                InitializeComponent();
    
            }
    
    
    
            private void button1_Click(object sender, EventArgs e)
    
            {
    
                this.dataGridView1.DataSource = student.Selectstudent(this.textBox1.Text);
    
            }
    
    
    
            private void dataGridView1_CellClick(object sender, DataGridViewCellEventArgs e)
    
            {
    
                if (this.dataGridView1.Rows.Count == 0) return;
    
                if (e.RowIndex < 0) return;
    
                DataGridViewRow row = this.dataGridView1.Rows[e.RowIndex];
    
                if (e.ColumnIndex == 5)
    
                {
    
                    //表示用户点击了删除按钮
    
                    string sno = row.Cells[0].Value.ToString();
    
                    if (student.Deletestudent(sno) == 1)
    
                    {
    
                        MessageBox.Show("delete success");
    
                        //this.dataGridView1.Rows.Remove(row);//出问题
    
                    }
    
                    else
    
                        MessageBox.Show("没有找到数据");
    
                }
    
                else
    
                    if (e.ColumnIndex == 6)
    
                    {
    
                        //表示用户点击了修改按钮
    
                        student s = (student)row.DataBoundItem;
    
                        Form_studentUpdate2 frm = new Form_studentUpdate2();
    
                        frm.tbsno.Text = s.sno;
    
                        frm.tbsname.Text = s.sname;
    
                        frm.tbssex.Text = s.ssex;
    
                        frm.tbsage.Text = s.sage.ToString();
    
                        frm.tbpwd.Text = s.pwd;
    
                        frm.ShowDialog();
    
                    }
    
            }
    
    
    
            private void Form_studentUpdate_Load(object sender, EventArgs e)
    
            {
    
                this.dataGridView1.DataSource = student.Selectstudent(this.textBox1.Text);
    
            }
    
        }
    
    }

    修改学生2:

    using System;
    
    using System.Collections.Generic;
    
    using System.ComponentModel;
    
    using System.Data;
    
    using System.Drawing;
    
    using System.Linq;
    
    using System.Text;
    
    using System.Threading.Tasks;
    
    using System.Windows.Forms;
    
    
    
    namespace byd001_app
    
    {
    
        public partial class Form_studentUpdate2 : Form
    
        {
    
            public Form_studentUpdate2()
    
            {
    
                InitializeComponent();
    
            }
    
    
    
            private void button1_Click(object sender, EventArgs e)
    
            {
    
                student s = new student();
    
                s.sno = tbsno.Text;//保持不变的
    
                s.sname = tbsname.Text;
    
                s.ssex = tbssex.Text;
    
                s.sage = Convert.ToInt32(tbsage.Text);
    
                s.pwd = tbpwd.Text;
    
                if (student.Updatestudent(s) == 1)
    
                    MessageBox.Show("update success");
    
                else
    
                    MessageBox.Show("可能没有找到记录");
    
            }
    
        }
    
    }

    关于教师信息统计的类:

    using Oracle.ManagedDataAccess.Client;
    
    using System;
    
    using System.Collections.Generic;
    
    using System.Configuration;
    
    using System.Linq;
    
    using System.Text;
    
    using System.Threading.Tasks;
    
    using System.Windows.Forms;
    
    
    
    namespace byd001_app
    
    {
    
        class teacherinfo
    
        {
    
            public string 职位 { get; set; }
    
            public int 在任人数 { get; set; }
    
            public double 平均工资 { get; set; }
    
            public string 教师工号 { get; set; }
    
            public string 教师姓名 { get; set; }
    
            public int 授课学生总人数 { get; set; }
    
            public static List<teacherinfo> Selectteacherinfo1()
    
            {
    
                string sql = "select *from teacherinfo1 where 职位 like :职位";
    
                OracleParameter[] para = new OracleParameter[] { new OracleParameter(":职位", OracleDbType.Char, 7) };
    
                para[0].Value = "%";
    
                //MessageBox.Show(tname+"%");
    
                List<teacherinfo> list = new List<teacherinfo>();
    
                //创建链接,打开连接,创建命令对象,执行命令,关闭连接
    
                OracleConnection con = new OracleConnection(ConfigurationManager.ConnectionStrings["strCon"].ConnectionString);
    
                try
    
                {
    
                    con.Open();
    
                    OracleCommand cmd = new OracleCommand(sql, con);
    
                    cmd.Parameters.AddRange(para);
    
                    OracleDataReader odr = cmd.ExecuteReader();
    
                    while (odr.Read())
    
                    {
    
                        teacherinfo s_infon = new teacherinfo();
    
                        //c.Cno = odr.GetString(0); //ord["cno'].
    
                        s_infon.职位 = odr["职位"].ToString();
    
                        //t.tno = odr.GetString(0);
    
                        s_infon.在任人数 = odr.GetInt32(1);
    
                        if (odr.IsDBNull(2))
    
                            s_infon.平均工资 = 0;
    
                        else
    
                            s_infon.平均工资 = odr.GetDouble(2);
    
                        list.Add(s_infon);
    
                    }
    
                }
    
                catch (Exception ex)
    
                {
    
                    MessageBox.Show(ex.Message);
    
                }
    
                finally
    
                {
    
                    con.Close();
    
                }
    
                return list;
    
            }
    
            public static List<teacherinfo> Selectteacherinfo2(string tno)
    
            {
    
                string sql = "select *from teacherinfo2 where 教师工号 like :教师工号";
    
                OracleParameter[] para = new OracleParameter[] { new OracleParameter(":教师工号", OracleDbType.Char, 7) };
    
                para[0].Value = tno + "%";
    
                //MessageBox.Show(tname+"%");
    
                List<teacherinfo> list = new List<teacherinfo>();
    
                //创建链接,打开连接,创建命令对象,执行命令,关闭连接
    
                OracleConnection con = new OracleConnection(ConfigurationManager.ConnectionStrings["strCon"].ConnectionString);
    
                try
    
                {
    
                    con.Open();
    
                    OracleCommand cmd = new OracleCommand(sql, con);
    
                    cmd.Parameters.AddRange(para);
    
                    OracleDataReader odr = cmd.ExecuteReader();
    
                    while (odr.Read())
    
                    {
    
                        teacherinfo s_infon = new teacherinfo();
    
                        //c.Cno = odr.GetString(0); //ord["cno'].
    
                        s_infon.教师工号 = odr["教师工号"].ToString();
    
                        //t.tno = odr.GetString(0);
    
                        s_infon.教师姓名 = odr.GetString(1);
    
                        if (odr.IsDBNull(2))
    
                            s_infon.授课学生总人数 = 0;
    
                        else
    
                            s_infon.授课学生总人数 = odr.GetInt32(2);
    
                        list.Add(s_infon);
    
                    }
    
                }
    
                catch (Exception ex)
    
                {
    
                    MessageBox.Show(ex.Message);
    
                }
    
                finally
    
                {
    
                    con.Close();
    
                }
    
                return list;
    
            }
    
        }
    
    }

    教师统计信息:

    using System;
    
    using System.Collections.Generic;
    
    using System.ComponentModel;
    
    using System.Data;
    
    using System.Drawing;
    
    using System.Linq;
    
    using System.Text;
    
    using System.Threading.Tasks;
    
    using System.Windows.Forms;
    
    namespace byd001_app
    
    {
    
        public partial class Form_Statistics_teacher : Form
    
        {
    
            public Form_Statistics_teacher()
    
            {
    
                InitializeComponent();
    
            }
    
    
    
            private void dataGridView2_CellContentClick(object sender, DataGridViewCellEventArgs e)
    
            {
    
    
    
            }
    
    
    
            private void button1_Click(object sender, EventArgs e)
    
            {
    
                this.dataGridView2.DataSource = teacherinfo.Selectteacherinfo2(this.textBox1.Text);
    
            }
    
    
    
            private void Form_Statistics_teacher_Load(object sender, EventArgs e)
    
            {
    
                this.dataGridView1.DataSource = teacherinfo.Selectteacherinfo1();
    
                this.dataGridView2.DataSource = teacherinfo.Selectteacherinfo2(this.textBox1.Text);
    
            }
    
        }
    
    }

    登录界面:

    管理员登录后的界面:

    根据不同的权限屏蔽控件,比如说管理员不需要选课的控件

    管理员具有更新学生的信息的权限:

     

    管理员具有删除老师信息的权限:

     

    管理员具有添加课程的权限:

     

     

    管理员具有更新学生选修课程的信息的权限:

    统计学生成绩信息:

    统计课程信息:

    统计在校教师的职位和教学信息:

    用学生账号登录选课:

    用教师账号查询教师:

    用教师账号登录查看自己的个人信息:

     

    实验总结

    总结实验过程中涉及到的知识点、实验过程中遇到的问题及解决方法。

    在本次实验中,使用了C#语言,运用VS软件进行可视化编程开发一个学生选课信息管理数据库系统,需要先安装VS2013的ODT软件,然后在VS2013的扩展中将oracle的服务添加进来,这样才可以用VS连接数据库。在帮助同学用VS连接数据库的时候,有部分同学用’C##’开头的用户是无法用VS连接数据库的,但是用其他的用户是可以连接数据库,一个比较奇怪的问题。在本次实验中,有4个表,分别定义了teacher,course,student,sc类,方便查询,插入,删除,修改数据。在统计方面,定义了四个视图,分别为studentinfo,teacherinfo1,teacherinfo2,courseinfo,每一个视图也分别定义了相关的类,为了方便查询和统计。在统计的过程中,不定义类,直接将视图的内容输出的时候,会出现转换的列无效的情况,可能是在第一行的数据中有的统计出来是空值,导致列的属性无法正常输出,在将这些视图全部转换成类之后,然后将这些类的对象导入dataView1中,就可以直接输出统计的信息了,当然在从数据库读出的时候,还是需要先判断一下是否为空值。在主程序运行之前,我们可以加入一个登录界面,相同的方法,不是按一下查询键才进行查询,可以在每一个窗口弹出后,在Load事件中添加刷新窗口的功能,使得打开一个新的用户界面时就可以直接看到全部的相应的信息,当然也支持单个的查询。在登录界面中,有两个radios的按钮,一个是学生的,另外一个是老师的,学生账号需要选择学生的按钮,再用学生的账号登录,老师的也一样,这样可以有效的防止学生和老师的账号搞混,在登录的时候只需要查询一个表就可以了。由于在数据库中没有把管理员定义成一个表,所以默认管理员只有一个账号,在登录的时候特判。在登录后,会有一个全局变量common记录登录用户的信息和相应的权限。一开始主程序的所有的控件都是屏蔽的,登录成功后,会对应不同的用户开发不同的控件,另外有一些类似密码的信息对一些权限较低的用户也是用“****”显示的,只有管理员才有最高的权限可以查看所有的信息。在教师信息的统计中界面中,使用了两个dataview1的显示,界面不太好看,不知道该如何把两个信息表的内容统计到一起。另外还增加了一个个人中心的控件,在控件拉下来后,可以选择个人信息修改,可以查询到自己的个人信息以及修改相应的信息。选择重新登录界面后,可以重新进入登录界面,并更新全局变量记录的权限信息。

    通过本次实验,了解概念结构设计的基本方法,理解逻辑结构设计的基本方法,理解物理结构设计的基本方法,对数据库的设计有了初步的认识。在老师教学视频的帮助下,成功的运用在VS2013的编译环境下用C#语言编写了一个学生选课信息管理数据库系统,该系统在查询,添加,修改,删除信息的时候会连接数据库,提高了数据的存储和查询的效率。在完成实验报告的基本要求后,为了管理系统的界面友好,又添加控件管理以及个人中心等功能。在完成本次综合实验的过程中,感谢老师对我们的认真指导和教诲。

    展开全文
  • 数据库系统设计综合实验

    千次阅读 多人点赞 2020-06-19 13:15:34
    数据库系统设计综合实验 实验目的 通过实验,使学生掌握数据库系统设计和开发的一般方法,能够设计并实现简单的数据库系统。 实验要求 熟悉实验室实验环境,掌握实验预备知识,了解实验中故障排除的基本方法。实验中...
  • 网络通信程序设计》课程综合报告的要求与格式 综合报告的目的: 本课程通过讲授、实验和编程练习将学习网络通信编程的基本技术和技巧,为了展示学生对本课程的学习水平,使学生的水平在教师评分时有更好的参考,...
  • 网络通信软件综合实验》课程综合实验报告目的:为考核学生对本课程知识的掌握,考查学生对课程的完成情况,将考查成绩作为课程期末成绩。分值比例:按学时数考查,最高可计24学时,总分最高分为100分。每学时最高...
  • Java程序设计是计算机科学与技术、网络工程、软件工程、物联网工程专业的一门专业基础课程。本课程是一门实用性和综合运用性都很强的课程,实践教学环节是教学过程中必不可少的重要内容。通过实验,让学生熟悉JDK中...
  • 实验一 Java的类和对象实验 实验二 多线程应用 实验三 Socket综合网络编程 实验四 用户登录系统的设计
  • [单选] 计划、组织、()、控制、创新是一切管理活动最基本的职能 [单选] 下列不属于计算机网络的功能(目标)是() [单选] 关于低压电力电缆错误的有()。 [单选] 可编程控制器是不可以进行下列哪一种操作() ...
  • 最新东北大学Python程序设计实验代码(含报告,不含综合作业),项目包括:井字棋、人口数据特征间的关系、 P2P网络贷款数据、插补用户用电量数据缺失值、wine和wine_quality 数据集分类及回归分析。仅供学习交流和...
  • 实验三 数据库系统设计综合实验 1、实验目的 通过实验,使学生掌握数据库系统设计和开发的一般方法,能够设计并实现简单的数据库系统。 2、实验要求 熟悉实验室实验环境,掌握实验预备知识,了解实验中故障排除的...
  • 网络程序设计-WeTalk聊天程序

    千次阅读 2017-07-19 22:34:51
    【摘要】WeTalk是一款基于Windows网络编程技术和MFC实现的聊天应用,该应用采用了Client/Server结构,可以实现多个客户端与服务器建立连接,用户可以通过客户端... 【关键词】Windows网络程序设计,事件选择模型,MF
  • 网络通信软件综合实验》实验教学大纲一、大纲说明课程编号:课程名称(中文):网络通信软件综合实验课程名称(英文):Computer Network Communication Software Experiment适用专业:计算机科学与技术专业、网络...
  • 专业资料 专业资料 综合性设计性实验报告 实验项目名称 数据库...Java程序设计综合实验一一数据库综合应用 实验地点 综 C601 实验日期 2016-6-15 一 实验目的 锻炼学生综合使用所学过的 Java语言程序设计知识运用面向
  • word word范文 word word范文 综合性设计性实验报告 实验项目名称 数据库综合应用 ...实验名称 Java程序设计综合实验一一数据库综合应用 实验地点 综 C601 实验日期 2016-6-15 一 实验目的 锻炼学生综合使用所学过的 Ja
  • 综合实验一嵌入式平台的进程管理模拟实验33 第3章 嵌入式Linux内核、引导系统和文件系统36 3.1 Linux内核定制、裁剪和添加36 3.1.1 概述36 3.1.2 内核目录简介37 3.1.3 配置文件和配置工具37 3.1.4 内核的编译...
  • 综合实验一嵌入式平台的进程管理模拟实验33 第3章 嵌入式Linux内核、引导系统和文件系统36 3.1 Linux内核定制、裁剪和添加36 3.1.1 概述36 3.1.2 内核目录简介37 3.1.3 配置文件和配置工具37 3.1.4 内核的编译...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 26,245
精华内容 10,498
关键字:

网络程序设计综合实验