精华内容
下载资源
问答
  • Cisco VTP配置

    千次阅读 2019-01-08 20:49:41
    详细详解Cisco配置vtp.

    Cisco vtp 配置

    具体的拓补图

    • 三层交换机作为 vtp server
    • 二层交换机作为 vtp client

    在三层交换机中配置:

    vtp mode server
    vtp domian main
    

    此时这个三层就是vtp server, domain 就是 main。


    再将连接二层交换机的端口打开trunk. (此时会遇到打不开Trunk的情况, 则需要将端口封装qot1q)

    switchport trunk encapsulation dot1q
    

    再打开trunk

    switchport mode trunk
    

    再去将两个二层交换机的vtp 设置为client

    vtp mode client
    

    就完成配置了,此时从三层创建vlan , 这两个二层也能学习到三层的vlan。



    编程中我们会遇到多少挫折?表放弃,沙漠尽头必是绿洲。

    展开全文
  • CISCO交换机 VTP配置

    千次阅读 2019-01-23 16:13:06
    VTP配置 VTP协议 VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道协议。它是思科私有协议。作用是十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP ...

    VTP配置

    VTP协议

    VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道协议。它是思科私有协议。作用是十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP Server, 其余交换机配置成VTP Client,这样他们可以自动学习到server 上的VLAN 信息。

    VTP协议用途

    VTP有三种工作模式:VTP Server、VTP Client 和 VTP Transparent。新交换机出厂时的默认配置是预配置为VLAN1,VTP 模式为服务器。 一般,一个VTP域内的整个网络只设一个VTP Server。VTP Server维护该VTP域中所有VLAN 信息列表,VTP Server可以建立、删除或修改VLAN,发送并转发相关的通告信息,同步vlan配置,会把配置保存在NVRAM中。VTP Client虽然也维护所有VLAN信息列表,但其VLAN的配置信息是从VTP Server学到的,VTP Client不能建立、删除或修改VLAN,但可以转发通告,同步vlan配置,不保存配置到NVRAM中。VTP Transparent相当于是一项独立的交换机,它不参与VTP工作,不从VTP Server学习VLAN的配置信息,而只拥有本设备上自己维护的VLAN信息。VTP Transparent可以建立、删除和修改本机上的 VLAN信息,同时会转发通告并把配置保存到NVRAM中。

    VTP配置

    在这里插入图片描述

    配置要求:

    1、sw1与sw2 配置vtp domain域ccie,密码为cisco,模式为server,创建vlan 100 ,200
    2、sw3与sw4配置为client模式

    配置代码

    sw1 与 sw2

    Switch(config)#vtp domain ccie  #建立domain域
    Domain name already set to ccie.
    Switch(config)#vtp password cisco #配置密码
    Setting device VLAN database password to cisco
    Switch(config)#vtp mode server  #设定模式
    Switch(config)#int range f0/3-4
    Switch(config-if-range)#sw tr en do
    Switch(config-if-range)#sw mo tr  #将转发端口设置为trunk模式
    Switch(config)#vlan 100
    Switch(config)#vlan 200	
    

    sw3 与 sw4

    Switch(config)#int range f0/1-2
    Switch(config-if-range)#sw mode tr
    Switch(config)#vtp domain ccie
    Domain name already set to ccie.
    Switch(config)#vtp mode client 
    Setting device to VTP CLIENT mode.
    Switch(config)#vtp password cisco
    

    验证

    Switch#show vtp status
    VTP Version                     : 2
    Configuration Revision          : 2
    Maximum VLANs supported locally : 255
    Number of existing VLANs        : 7
    VTP Operating Mode              : Server
    VTP Domain Name                 : ccie
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x90 0xC6 0x74 0xDB 0xB2 0x7A 0x20 0xD3 
    Configuration last modified by 0.0.0.0 at 3-1-93 00:01:35
    Local updater ID is 0.0.0.0 (no valid interface found)
    

    查看sw3上是否同步 vlan信息
    Switch#show vlan brief

    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                    Fa0/23, Fa0/24, Gig0/1, Gig0/2
    100  VLAN0100                         active    
    200  VLAN0200                         active    
    300  VLAN0300                         active    
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    
    

    现网中建议还是只有一台vtp server即可,本实验只为了验证vtp server之间是否能同步vlan信息。

    展开全文
  • cisco 交换机 VTP 配置

    2017-11-13 01:27:00
    VTP有三种工作模式: 1、VTP Server,可以建立、删除或修改VLAN 2、VTP Client, 不可以建立、删除或修改VLAN 3、VTP Transparent可以建立、删除和修改本机上的VLAN信 息,转发VTP消息 ...一、配置VTP 1...

    VTP有三种工作模式:

    1、VTP Server, 可以建立、删除或修改VLAN
    2、VTP Client, 不可以建立、删除或修改VLAN
    3、VTP Transparent 可以建立、删除和修改本机上的 VLAN信 
                   息, 转发VTP消息
    一个网络内可以有多台server,一般只要一台就可以了。
     
    一、配置VTP
    1、server配置
    2、transparent配置
    3、client配置
    好了,vtp已经配置完了,下面验证是否生效。
    先在server上创建vlan2~vlan4.
    然后去client看下,是否有这几个vlan。
     
    然后再去看transparent的vlan信息。
     
    看以看到client模式可以学到到server模式创建的vlan,而transparent模式是学习不到的。
     
    下面再去client创建vlan看是什么反应。可以看到vtp client模式是不能创建vlan的。
     
     
    再看下transparent模式,它可以创建维护自己的vlan
     
    VTP配置命令
     
    进入Vlan数据库
    Switch#vlan database
    建立VTP域
    Switch(vlan)#vtp domain name
    修改交换机vtp的模式
    Switch(vlan)#vtp{client|server|transparent}
    配置vtp密码
    Switch(vlan)#vtp password ……
    配置VTP修剪
    switch (vlan) # vtp pruning
    查看VTP运行状态
    Switch#show vtp status
    查看交换机收到和发出广告的数目
    Switch#show vtp counters
    配置接口为trunk模式
    Switch(config)#interface  f0/1
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#no shutdown
    配置注意:
    VTP domain 一致
    VTP password  一致
    将交换机互联的的交换机端口改称为trunk模式
    可以不配置VTP password
    默认的模式是server模式
     

    本文转自zhaoyun00 51CTO博客,原文链接:http://blog.51cto.com/zhaoyun/631666

    展开全文
  • Cisco VTP中继协议配置

    2018-04-14 12:07:00
    VLAN中继协议,VTP,VLAN TRUNKING PROTOCOL,是CISCO专用协议,大多数交换机都支持该协议。VTP负责在VTP域内同步VLAN信息, 这样就不必在每个交换上配置相同的VLAN信息。VTP还提供一种映射方案,以便通信流能跨越...

     

     

     

    VTP协议:

     

    VLAN中继协议,VTP,VLAN TRUNKING PROTOCOL,是CISCO专用协议,大多数交换机都支持该协议。VTP负责在VTP域内同步VLAN信息,

    这样就不必在每个交换上配置相同的VLAN信息。VTP还提供一种映射方案,以便通信流能跨越混合介质的骨干。VTP最重要的作用是,将进行

    变动时可能会出现在的配置不一致性降至最低。不过,VTP也有一些缺点,这些缺点通常都与生成树协议有关.

     

    知识点:

    VLAN中继协议(VTP)利用第2层中继帧,在一组交换机之间进行VLAN通信.VTP从一个中心控制点开始,维护整个企业网上VLAN的添加和重命名工作,确保配置的一致性。

     

     

    设计思路:

     

    1、 Cisco C3560配置成为VTP server并设置VTP管理域名称CCTV

    2、 Cisco C3560创建三个VLAN(VLAN10  VLAN20  VLAN 30)并配置每个VLAN动态获取IP

    3、 Cisco C3650 分配三个端口fa 0/1-3 设置为trunk

    4、 三台Cisco C2960配置成为 VTP client

    5、 C2960_01 分配fa 0/1-5给VLAN 10 ,并设置fa0/24端口为trunk

    6、 C2960_02 分配fa 0/1-5给VLAN 20 ,并设置fa0/24端口为trunk

    7、 C2960_03 分配fa 0/1-5给VLAN 30 ,并设置fa0/24端口为trunk

     

    网络拓扑图:

     

     

     

     

     

     

     

    Cisco C3560配置如下:

     

    ##设置VTP 域名名称及VTP Server

    C3560>enable

    C3560#vlan database

    C3560(vlan)#vtp domain CCTV

    C3560(vlan)#vtp server

    ##创建VLAN 10  VLAN 20  VLAN 30

    C3560(vlan)#vlan 10 name VLAN10

    C3560(vlan)#vlan 20 name VLAN20

    C3560(vlan)#vlan 30 name VLAN30

    C3560(vlan)#exit

    ##VLAN配置IP地址

    3560#configure terminal

    C3560(config)#interface vlan 10

    C3560(config-if)#ip address 192.168.10.1 255.255.255.0

    C3560(config-if)#exit

    C3560(config)#interface vlan 20

    C3560(config-if)#ip address 192.168.20.1 255.255.255.0

    C3560(config-if)#exit

    C3560(config)#interface vlan 30

    C3560(config-if)#ip address 192.168.30.1 255.255.255.0

    C3560(config-if)#exit

    ##配置DCHP

    C3560(config)#service dhcp

    C3560(config)#ip dhcp pool vlan10_dhcp

    C3560(dhcp-config)#network 192.168.10.0 255.255.255.0

    C3560(dhcp-config)#default-router 192.168.10.1

    C3560(dhcp-config)#dns-server 114.114.114.114

    C3560(dhcp-config)#exit

    C3560(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10

    C3560(config)#ip dhcp pool vlan20_dhcp

    C3560(dhcp-config)#network 192.168.20.0 255.255.255.0

    C3560(dhcp-config)#default-router 192.168.20.1

    C3560(dhcp-config)#dns-server 114.114.114.114

    C3560(dhcp-config)#exit

    C3560(config)#ip dhcp excluded-address 192.168.20.1 192.168.20.10

    C3560(config)#ip dhcp pool vlan30_dhcp

    C3560(dhcp-config)#network 192.168.30.0 255.255.255.0

    C3560(dhcp-config)#default-router 192.168.30.1

    C3560(dhcp-config)#dns-server 114.114.114.114

    C3560(dhcp-config)#exit

    C3560(config)#ip dhcp excluded-address 192.168.30.1 192.168.30.10

    ##设置三个端口fastEthernet 0/1-3为trunk

    知识点:VLAN的封装类型,目前有ISL和802.1q(dot1q)两种协议,ISL是思科私有的VLAN封装协议,思科部分交换机支持ISL协议,使用该协议能提高VLAN传输性能。

    C3560(config)#interface range fastEthernet 0/1-3

    C3560(config-if-range)#switchport trunk encapsulation ?

    dot1q Interface uses only 802.1q trunking encapsulation when trunking

    C3560(config-if-range)#switchport trunk encapsulation dot1q

    C3560(config-if-range)#switchport mode trunk

    C3560(config-if-range)#exit

    ##开启三层路由功能

    C3560>enable

    C3560#configure terminal

    C3560(config)#ip routing

    ##显示与维护

    C3560#show running-config

    C3560#show vtp status

     

     

     

    Cisco C2960_01配置如下:

     

    ##设置VTP 域名名称及VTP Client

    C2960_01>enable

    C2960_01#vlan database

    C2960_01(vlan)#vtp domain CCTV

    C2960_01(vlan)#vtp client

    C2960_01(vlan)#exit

    ##分配fa0/1-5端口给VLAN 10

    C2960_01#configure terminal

    C2960_01(config)#interface range fastEthernet 0/1-5

    C2960_01(config-if-range)#switchport access vlan 10

    C2960_01(config-if-range)#switchport mode access

    C2960_01(config-if-range)#no shutdown

    C2960_01(config-if-range)#exit

    ##设置fa0/24端口为trunk

    C2960_01(config)#interface fastEthernet 0/24

    C2960_01(config-if)#switchport mode trunk

    C2960_01(config-if)#no shutdown

    C2960_01(config-if)#exit

    ##显示与维护

    C2960_01#show vlan

    C2960_01#show running-config

    C2960_01#show vtp status

     

     

     

    Cisco C2960_02配置如下:

     

    ##设置VTP 域名名称及VTP Client

    C2960_02>enable

    C2960_02#vlan database

    C2960_02(vlan)#vtp domain CCTV

    C2960_02(vlan)#vtp client

    C2960_02(vlan)#exit

    ##分配fa0/1-5端口给VLAN 10

    C2960_02#configure terminal

    C2960_02(config)#interface range fastEthernet 0/1-5

    C2960_02(config-if-range)#switchport access vlan 10

    C2960_02(config-if-range)#switchport mode access

    C2960_02(config-if-range)#no shutdown

    C2960_02(config-if-range)#exit

    ##设置fa0/24端口为trunk

    C2960_02(config)#interface fastEthernet 0/24

    C2960_02(config-if)#switchport mode trunk

    C2960_02(config-if)#no shutdown

    C2960_02(config-if)#exit

    ##显示与维护

    C2960_02#show vlan

    C2960_02#show running-config

    C2960_01#show vtp status

     

     

     

    Cisco C2960_03配置如下:

     

    ##设置VTP 域名名称及VTP Client

    C2960_03>enable

    C2960_03#vlan database

    C2960_03(vlan)#vtp domain CCTV

    C2960_03(vlan)#vtp client

    C2960_03(vlan)#exit

    ##分配fa0/1-5端口给VLAN 10

    C2960_03#configure terminal

    C2960_03(config)#interface range fastEthernet 0/1-5

    C2960_03(config-if-range)#switchport access vlan 10

    C2960_03(config-if-range)#switchport mode access

    C2960_03(config-if-range)#no shutdown

    C2960_03(config-if-range)#exit

    ##设置fa0/24端口为trunk

    C2960_03(config)#interface fastEthernet 0/24

    C2960_03(config-if)#switchport mode trunk

    C2960_03(config-if)#no shutdown

    C2960_03(config-if)#exit

    ##显示与维护

    C2960_03#show vlan

    C2960_03#show running-config

    C2960_03#show vtp status

     

     

     

    展开全文
  • Cisco交换机 vtp 配置

    千次阅读 2018-03-30 13:11:41
    先确定核心 交换机是哪台 ,然后再进行分支设置 基本步骤为: 1、配置Server端主交换机,也就是domain管理域; 2、分别在各分支交换机上配置为client客户端以及domain管理域(注: 管理域和...设置核心交换机 VTP...
  • VTP配置 所属章节 实验目的 使其整个内部网络能够互相学习VTP协议 实验要求: 1. 保证4台交换机能够学习到VTP协议 2. 将SW3交换机设置为透明模式且能够让其他交换机学习到VTP协议 3....
  • 使用Cisco模拟器进行VTP配置

    千次阅读 2018-09-18 09:38:42
    在十几台交换机的企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置VTP Server,其余交换机配置VTP Client,这样Client可以自动学习到Server上的VLAN信息。 VTPVTP域,也称VLAN管理域,由一个...
  • 本实例是中用到的是Cisco 3620的交换机,由于是用模拟器做的实验,所以有的地方可能和真实机有所不同,这个简单的实验只是提供一个... 配置VTP; 查看上述配置项目的相关信息。 2.设备需求 本实验需要以下设备: ...
  • cisco vtp domain

    2014-07-15 13:43:47
    在一台VTP Server 上配置一个新的VLAN时,该VLAN的配置信息将自动传播到本域内的其他所有交换机,这些交换机会自动地接收这些配置信息,使其VLAN的配置VTP Server保持一致,从而减少在多台设备上...
  • VTP理解:在一个拥有多台交换机的交换网络中,通常会在多台交换机上配置相同的VLAN,并且也会对多个接口做相同的配置。 对于需要对多个接口做相同的配置,通过快速接口配置,能够轻松实现,提高工作效率。而对于在多...
  • VTP配置

    2017-11-12 18:09:00
    简单介绍Cisco VTP配置 同样希望对各位友友有所帮助 编于2008年11月 附件:http://down.51cto.com/data/2353644 本文转自 ...
  • Cisco vtp 解析-ielab

    2019-12-26 15:45:12
    作用是十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置VTP Server, 其余交换机配置VTP Client,这样他们可以自动学习到 VTP用途: 通常情况下,我们需要在整个园区网或者企业网中...
  • Cisco Packet Tracer 学习--VTP配置

    千次阅读 2018-05-31 21:41:25
    在每个 VTP 域中,可以将一台或多台交换机配置VTP 服务器。然后可以在 VTP 服务器上创建 VLAN,并将这些 VLAN 传送给域中的其它交换机。常见的 VTP 配置任务是设置工作模式、域和口令。在本实验中,您将把 S1 ...
  • VTP配置实验

    2020-04-12 12:52:27
    1.配置四台交换机的VTP域为cisco,交换机之间相连的接口为trunk。 VTP域名配置命令:Switch(config)#vtp domain cisco 2.按照图中标识配置VTP模式。 VTP模式配置命令: 服务器模式:Switch(config)#vtp mode server ...
  • Cisco VTP protocol 实验笔记 实验目标: 使用vtp(vlan trunk protocol 虚拟局域网中继协议)实现交换机之间相互传递vlan信息。实现vlan的统一配置及管理。实现单个控制点上管理整个网络。 实验拓扑: Vtp ...

空空如也

空空如也

1 2 3 4 5 ... 18
收藏数 349
精华内容 139
关键字:

ciscovtp配置