精华内容
下载资源
问答
  • eNSP单臂路由,跨vlan通信一、实验题目二、实验拓扑图三、实验内容1.配置确定2.主机配置3.配置二层交换机4.配置单臂路由5.测试不同vlan间连通性四、实验总结 一、实验题目 三台二层交换机,一台路由器,四台PC,...


    一、实验题目

    三台二层交换机,一台路由器,四台PC,实现不同vlan间通信。具体实施:通过给单臂路由下的子接口分别对应vlan,进行数据转发,实现不同vlan之间的通信。

    二、实验拓扑图

    本次实验使用的交换机型号均为S5700,路由器我们采用AR2220。
    注释:大家需要知道路由器一个端口造价昂贵,所以我们与单臂路由相连只用一根线,然后进行分逻辑端口。
    在这里插入图片描述

    三、实验内容

    1.配置确定

    VLAN:
    VLAN 10:PC1 PC3
    VLAN 20:PC2 PC4
    网段:
    192.168.10.0/24
    192.168.20.0/24
    

    2.主机配置

    PC1:192.168.10.1 255.255.255.0 192.168.10.254
    PC2:192.168.20.1 255.255.255.0 192.168.20.254
    PC3:192.168.10.2 255.255.255.0 192.168.10.254
    PC4:192.168.20.2 255.255.255.0 192.168.20.254
    

    3.配置二层交换机

    -----------------SW1配置-----------------
    [Huawei]sysname SW1
    [SW1]vlan batch 10 20
    [SW1]int g0/0/1
    [SW1-GigabitEthernet0/0/1]port link-type access 
    [SW1-GigabitEthernet0/0/1]port default vlan 10
    [SW1-GigabitEthernet0/0/1]int g0/0/2
    [SW1-GigabitEthernet0/0/2]port link-type access
    [SW1-GigabitEthernet0/0/2]port default vlan 20
    [SW1-GigabitEthernet0/0/2]int g0/0/3
    [SW1-GigabitEthernet0/0/3]port link-type trunk 
    [SW1-GigabitEthernet0/0/3]port trunk allow-pass vlan 10 20
    -----------------SW2配置-----------------
    与SW1配置相同
    -----------------SW3配置-----------------
    [SW3]vlan batch 10 20
    [SW3]int g0/0/1
    [SW3-GigabitEthernet0/0/1]port link-type trunk 
    [SW3-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20
    [SW3-GigabitEthernet0/0/1]int g0/0/2
    [SW3-GigabitEthernet0/0/2]port link-type trunk
    [SW3-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 20
    [SW3-GigabitEthernet0/0/2]int g0/0/3
    [SW3-GigabitEthernet0/0/3]port link-type trunk
    [SW3-GigabitEthernet0/0/3]port trunk allow-pass vlan 10 20
    

    4.配置单臂路由

    路由器进入逻辑接口(可直接进入)

    [Huawei]int g0/0/0.1
    [Huawei-GigabitEthernet0/0/0.1]dot1q termination vid 10
    [Huawei-GigabitEthernet0/0/0.1]ip address 192.168.10.254 24
    [Huawei-GigabitEthernet0/0/0.1]arp broadcast enable 
    [Huawei-GigabitEthernet0/0/0.1]int g0/0/0.2
    [Huawei-GigabitEthernet0/0/0.2]dot1q termination vid 20
    [Huawei-GigabitEthernet0/0/0.2]ip address 192.168.20.254 24
    [Huawei-GigabitEthernet0/0/0.2]arp broadcast enable
    

    5.测试不同vlan间连通性

    在这里插入图片描述

    四、实验总结

    我们本次实验运用到的知识有:

    1. vlan的配置我们之前就已经学习了,这次在这里再一次重温。
    2. 通过单臂路由实现不同vlan之间的通信(之前使用的是三层交换机)。
    3. 需要掌握一下指令
      int g0/0/0.1				//进入0.1逻辑子接口
      dot1q termination vid 10	//处理VLAN ID为10的报文
      ip address 192.168.10.254 24//VLAN 10的网关地址
      arp broadcast enable 		//接口可以处理ARP广播报文
      
    展开全文
  • eNSPVLAN

    2021-03-27 11:13:02
    跨交换机VLAN的通信 ...跨VLAN通信:三层交换机 1.拓扑图 配置 pc机配置见上图 S2的配置:配置率VLAN,接口 S3的配置: 三层交换机,S1上的VLAN配置如下: S1上还需要配置PC机的网关,在VLAN接口配置

    跨交换机VLAN的通信

    1. 拓扑图
      在这里插入图片描述
    2. 配置步骤
      配置IP地址,如上图,略。
      配置VLAN,以S2交换为例,其他类似
      在这里插入图片描述创建VLAN10
      在这里插入图片描述access接口加入VLAN
      在这里插入图片描述trunk接口的配置
      在这里插入图片描述trunk接口的配置
      此时PING:

      各PC之间无法PING通

    S1,S3上配置完善(类似)
    在这里插入图片描述 在这里插入图片描述
    3. 验证结果
    在这里插入图片描述

    跨VLAN通信:三层交换机

    1.拓扑图

    在这里插入图片描述

    1. 配置
      pc机配置见上图
      S2的配置:配置率VLAN,接口在这里插入图片描述
      S3的配置:
      在这里插入图片描述
      三层交换机,S1上的VLAN配置如下:
      在这里插入图片描述
      S1上还需要配置PC机的网关,在VLAN接口配置:
      在这里插入图片描述
      查看S1的路由表:
      在这里插入图片描述
      为了避免有环路,将S2的e0/0/2端口shutdown掉

    测试:可以PC1 PING PC2了啊

    跨VLAN通信:路由器

    在这里插入图片描述

    1. 配置,PC机地址如图,交换机配置接口和VLAN,最终实现PC1—PC2互通
      S1的配置:
      vlan batch 10
      interface Ethernet0/0/1
      port link-type access
      port default vlan 10

    interface Ethernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094

    S2的配置:
    sysname S2

    vlan batch 20
    interface Ethernet0/0/1
    port link-type access
    port default vlan 20

    interface Ethernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 20

    S3的配置:
    sysname S3

    vlan batch 10 20
    interface Ethernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094

    interface Ethernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094

    interface Ethernet0/0/3
    port link-type trunk
    port trunk allow-pass vlan 10 20
    路由器的配置:

    interface GigabitEthernet0/0/0

    interface GigabitEthernet0/0/0.10
    dot1q termination vid 10
    ip address 10.0.1.1 255.255.255.0
    arp broadcast enable

    interface GigabitEthernet0/0/0.20
    dot1q termination vid 20
    ip address 10.0.2.1 255.255.255.0
    arp broadcast enable

    PC机配置:
    在这里插入图片描述测试:
    在这里插入图片描述

    跨VLAN通信:交换机+路由器

    在这里插入图片描述配置和要求如图:
    PC2,其他类似:注意网关在这里插入图片描述
    S1:

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094

    interface Ethernet0/0/2
    port link-type access

    interface Ethernet0/0/1
    port link-type access
    port default vlan 2

    S3的配置:
    在这里插入图片描述
    ]ip route-static 192.168.100.0 24 192.168.6.10 静态路由
    在这里插入图片描述
    s3的路由表为:
    在这里插入图片描述

    路由器配置:配置默认路由
    在这里插入图片描述

    1. 测试:所有pc都可以互通
      2在这里插入图片描述
      在这里插入图片描述
    展开全文
  • 如何使用eNSP配置VLAN与Trunk

    千次阅读 2020-03-27 18:04:00
    参照如下网络拓扑实现交换机的相同vlan通信。 使用eNSP搭建实验环境,如图-2所示。 1)配置第1台交换机 [SW1]vlan 5 [SW1]vlan 10 [SW1]interface Ethernet0/0/1 [SW1-Ethernet0/0/1]port link-type access [SW...

    参照如下网络拓扑实现跨交换机的相同vlan的通信。

    使用eNSP搭建实验环境,如图在这里插入图片描述所示。

    1)配置第1台交换机

    [SW1]vlan 5
    [SW1]vlan 10
    [SW1]interface Ethernet0/0/1
    [SW1-Ethernet0/0/1]port link-type access 
    [SW1-Ethernet0/0/1]port default vlan 5
    [SW1]interface Ethernet0/0/2
    [SW1-Ethernet0/0/2]port link-type access 
    [SW1-Ethernet0/0/2]port default vlan 10
    [SW1]interface Ethernet0/0/24
    [SW1-Ethernet0/0/24]port link-type trunk 
    [SW1-Ethernet0/0/24]port trunk allow-pass vlan 5 10
    

    2)配置第2台交换机

    [SW2]vlan 5
    [SW2]vlan 10
    [SW2]interface Ethernet0/0/3
    [SW2-Ethernet0/0/3]port link-type access 
    [SW2-Ethernet0/0/3]port default vlan 5
    [SW2]interface Ethernet0/0/4
    [SW2-Ethernet0/0/4]port link-type access 
    [SW2-Ethernet0/0/4]port default vlan 10
    [SW2]interface Ethernet0/0/24
    [SW2-Ethernet0/0/24]port link-type trunk 
    [SW2-Ethernet0/0/24]port trunk allow-pass vlan 5 10
    

    3)测试

    VLAN 5的2台主机能够互通,VLAN 10的2台主机能够互通。

    VLAN 5与VLAN 10的2台主机不能够互通。

    展开全文
  • eNSPVLAN与Trunk配置

    2019-05-04 12:07:44
    参照如下网络拓扑图实现交换机的相同Vlan通信 步骤 如图所示,配置pc1~pc4(从左至右的顺序)的IP地址和子网掩码 2.交换机SW1下的接口为0/0/1和0/0/2,交换机SW2下的接口为0/0/3和0/0/4,交换机之间的接口为0/0...

    参照如下网络拓扑图实现跨交换机的相同Vlan通信

    eNSP中VLAN与Trunk配置

    步骤

    1. 如图所示,配置pc1~pc4(从左至右的顺序)的IP地址和子网掩码

    2.交换机SW1下的接口为0/0/1和0/0/2,交换机SW2下的接口为0/0/3和0/0/4,交换机之间的接口为0/0/24

    1. 进入交换机SW1进行配置

    [SW1]vlan 5 //创建一个端口为5的vlan
    [SW1]vlan 10 //创建一个端口为10的vlan
    [SW1]interface Ethernet0/0/1 //进入SW1下0/0/1接口
    [SW1-Ethernet0/0/1]port link-type access //设置接口模式为access
    [SW1-Ethernet0/0/1port default vlan 5 //把端口0/0/1加入vlan5
    [SW1]interface Ethernet0/0/2 //进去SW1下0/0/2接口
    [SW1-Ethernet0/0/2]port link-type access //设置接口模式为access
    [SW1-Ethernet0/0/2port default vlan 10 //把端口0/0/2加入vlan10
    [SW1]interface Ethernet0/0/24 //进入交换机接口
    [SW1-interface Ethernet0/0/24]port link-type trunk //设置接口模式为trunk
    [SW1-interface Ethernet0/0/24]port trunk allow-pass vlan 5 10 //允许vlan5 10的数据通过

    4.配置交换机SW2

    [SW2]vlan 5 //创建一个端口为5的vlan
    [SW2]vlan 10 //创建一个端口为10的vlan
    [SW2]interface Ethernet0/0/3 //进入SW1下0/0/3接口
    [SW2-Ethernet0/0/3]port link-type access //设置接口模式为access
    [SW2-Ethernet0/0/3port default vlan 5 //把端口0/0/3加入vlan5
    [SW2]interface Ethernet0/0/4 //进去SW1下0/0/4接口
    [SW2-Ethernet0/0/4]port link-type access //设置接口模式为access
    [SW2-Ethernet0/0/4port default vlan 10 //把端口0/0/4加入vlan10
    [SW2]interface Ethernet0/0/24 //进入交换机接口
    [SW2-interface Ethernet0/0/24]port link-type trunk //设置接口模式为trunk
    [SW2-interface Ethernet0/0/24]port trunk allow-pass vlan 5 10 //允许vlan5 10的数据通过
    5.测试

    VLAN 5的两台主机(pc1,pc3)之间能够ping通,VLAN 10的两台主机(pc2,pc4)能够ping通
    VLAN5 和 VLAN10的主机不能ping通

    转载于:https://blog.51cto.com/14310343/2388752

    展开全文
  • 实验环境:华为ENSP模拟器 实验原理: 1)华为的VLAN规则: ①所有数据帧在一个交换机内部转发时,必须存在标签 ②在每一个交换机的接口上均存在转发允许列表,只有被允许的流量才能通过该接口进或出 ③流量从一个...
  • eNSP中VLAN与Trunk配置参照如下网络拓扑图实现交换机的相同Vlan通信步骤1. 如图所示,配置pc1~pc4(从左至右的顺序)的IP地址和子网掩码2.交换机SW1下的接口为0/0/1和0/0/2,交换机SW2下的接口为0/0/3和0/0/4,...
  • eNSP模拟器中VLAN与Trunk配置

    千次阅读 2019-04-30 00:01:33
    参照如下网络拓扑图实现交换机的相同Vlan通信 步骤 1. 如图所示,配置pc1~pc4(从左至右的顺序)的IP地址和子网掩码 2.交换机SW1下的接口为0/0/1和0/0/2,交换机SW2下的接口为0/0/3和0/0/4,交换机之间的接口为0/...
  • 一、实验目的 通过混合端口实现VLAN间的通信实验,...(1)基于混合端口控制VLAN通信交换机的混合端口通信继续配置,配置LSW1 (2)PC1(vlan20) ping PC5(vlan10)通过Ethernet0/0/6抓包得到untagged的帧,且
  • 实验案例:在华为ensp软件上模拟三层交换机利用路由功能实现全网互通 实验环境 如图所示,在win10下使用华为ensp软件...设置三层交换机的vlanif网关,使得不同vlan间的pc可以正常通信 具体如下:这里的ip地址以及vl
  • 实验使用ensp 1.2.0版,A为3700v200R001C00,B为5700,pc1-5『配置环境参数』1.PC1、PC2和PC3分别连接到二层交换机SwitchA的端口E0/1、E0/2和E0/3,端口分属于VLAN10、20和30;PC4和PC5分别连接到二层交换机SwitchB...
  • 实验拓补图: 问题分析:由于此拓扑为三层的设备。接入交换机(sw2、sw3)为转发设备。可以将vlan 10 这一个整体看成一个pc,同理vlan 20也是一个...可以跨vlan通信的原因就是汇聚交换机可以将数据包报文转发到另一个
  • 在现实网络中,经常会遇到需要跨VLAN相互访问的情况,工程师通常会选择一些方法来实现不同VLAN间主机的相互访问,例如单臂路由。但是单臂路由技术中由于存在一些局限性,比如带宽,转发效率等,使得这项技术应用较少...
  • 我们在实际生活中经常要跨vlan进行通信,我们的解决办法有单臂路由,但是单臂路由存在很大的局限性,带宽,转发效率等,所以单臂路由用的就有点少,所以就有了本章节三层交换机在原有的二层交换机的基础上,增加了...
  • 在现实网络中,经常会遇到需要跨VLAN 相互访问的情况, 工程师通常会选择一些方法来实现不同VLAN 间主机的相互访问,例如单臂路由。但是单臂路由技术中由于存在一些局限性,比如带宽、转发效率等,使得这项技术应用...
  • 在现实网络中,经常会遇到需要跨VLAN相互访问的情况,工程师通常会选择一些方法来实现不同VLAN间主机的相互访问,例如单臂路由。但是单臂路由技术中由于存在一些局限性,比如带宽、转发效率等,使得这项技术应用较少...
  • 在现实网络中,经常会遇到需耍跨VLAN相互访问的情况,工程师通常会选择一些方法来实现不同VLAN间主机的相互访问,例如单臂路由,但是单臂路由技术中由于存在一些局限性,比如带宽、转发效率等, 使得这项技术应用较...
  • (抓包)三层交换机网段通信

    千次阅读 2020-05-15 17:10:27
    三层交换机通信-全网互通 实验拓扑图 实验环境 win10 、ensp 实验描述 二层交换之间同网段实现通信,三层交换机网段通信。 最终实现全网通。 实验步骤 步骤一:根据实验拓扑图,设置PC1、PC2、PC3、PC4的手配...
  • 问题:参照如下网络拓扑实现交换机的相同vlan通信。 1.使用eNSP搭建实验环境2.搭建好以后,分配为每台PC机配置IP地址及子网掩码如上图所示,分别把PC1的IP地址配置为:192.168.1.1,子网掩码为255.255.255.0PC2...
  • 实验拓扑图: 实验说明: 1.测试6台PC能否通信?(YES) ...6.续完成 hybrid 端口相应配置,使得3个VLAN内部能够完成通信(不考虑跨VLAN通信)。 实验配置及过程: 测试连通性 显然6台PC全互通 配置1
  • 具体实施:通过给交换机配置进行Vlan分配,给路由器配置静态路由实现通信。 二、实验拓扑图 本次实验采用的路由器型号为:AR2220,交换机型号为:S5700。 三、实验内容 1.配置确定 VLAN: VLAN 10:PC1 VLAN 20:...
  • VLAN与Trunk配置

    2020-06-25 18:35:10
    参照如下网络拓扑实现交换机的相同vlan通信。 2.2 方案 使用eNSP搭建实验环境,如图-2所示。 图-2 2.3 步骤 实现此案例需要按照如下步骤进行。 1)配置第1台交换机 [SW1]vlan5 [SW1]vlan10 [SW1]interface ...
  • Vlan与trunk配置

    2019-05-04 18:32:00
    参照如下网络拓扑实现交换机的相同vlan通信。使用eNSP搭建实验环境,如图-2所示。实现此案例需要按照如下步骤进行。1)配置第1台交换机01.[SW1]vlan 502.[SW1]vlan 1003.[SW1]interface Ethernet0/0/104.[SW1-...
  • 2、交换机使用VLAN来隔离或连接终端之间的通信 lsw1配置 lsw2配置 验证 3、配置交换机管理IP地址测试PC与交换机间的逻辑联通 在实验2的基础上进行实验,拓扑图相同,交换机配置大体相同 lsw1相较于实验2增加的...

空空如也

空空如也

1 2
收藏数 33
精华内容 13
关键字:

ensp跨vlan通信