精华内容
下载资源
问答
  • 华为静态路由配置

    千次阅读 多人点赞 2019-11-12 09:11:59
    静态路由是由管理员手动配置和管理的路由,静态路由配置简单,因此,被广泛应用于结构简单网络中,静态路由还可以实现负载均衡与路由备份。 拓扑 PC1位于192.168.1.0网段,它的IP是192.168.1.2,网关是192.168....

    静态路由

    静态路由(Static Router)是由管理员通过手动配置的方式创建的路由,可以让路由器便捷的获知到达目的网络的路由。在静态路由基础上也可使用负载均衡、路由备份等技术。

    本文分别对静态路由、负载均衡、路由备份进行实验配置及配置完之后如何验证。

    网络拓扑图
    在这里插入图片描述
    给PC1与PC2分配IP、网关、掩码

    PC1位于192.168.1.0网段,它的IP192.168.1.2,网关192.168.1.1,掩码255.255.255.0。
    PC2位于192.168.2.0网段,它的IP192.168.2.2,网关192.168.2.1,掩码255.255.255.0。
    在这里插入图片描述

    在一个192.168.1.xxx这个网段中,共有256个地址,可用地址是254个,其中网络地址与广播地址是保留的,网络地址:192.168.1.0、广播地址:192.168.1.255。

    路由器AR1:
    GE 0/0/2接口192.168.1.1(网关地址),右边出接口与下一跳。
    路由器AR2:
    GE 0/0/2接口192.168.2.1(网关地址)。

    配置命令

    路由器AR1

    <Huawei>system-view
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname AR1
    [AR1]interface GigabitEthernet 0/0/2
    [AR1-GigabitEthernet0/0/2]ip address 192.168.1.1 24
    [AR1-GigabitEthernet0/0/2]quit
    [AR1]interface GigabitEthernet 0/0/0
    [AR1-GigabitEthernet0/0/0]ip address 10.0.0.1 24
    [AR1-GigabitEthernet0/0/0]quit
    [AR1]interface GigabitEthernet 0/0/1
    [AR1-GigabitEthernet0/0/1]ip address 20.0.0.1 24
    [AR1-GigabitEthernet0/0/1]quit
    [AR1]ip route-static 192.168.1.0 24 10.0.0.2
    

    路由器AR2

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname AR2
    [AR2]interface GigabitEthernet 0/0/2
    [AR2-GigabitEthernet0/0/2]ip address 192.168.2.1 24
    [AR2-GigabitEthernet0/0/2]quit
    [AR2]interface GigabitEthernet 0/0/0
    [AR2-GigabitEthernet0/0/0]ip address 10.0.0.2 24
    [AR2-GigabitEthernet0/0/0]quit
    [AR2]interface GigabitEthernet 0/0/1
    [AR2-GigabitEthernet0/0/1]ip address 20.0.0.2 24
    [AR2-GigabitEthernet0/0/1]quit
    [AR2]ip route-static 192.168.1.0 24 10.0.0.1  //静态路由配置,解释:将去往192.168.1.0网段的数据都交给10.0.0.1这条路由。
    
    配置完成,不妨使用ping,测试一下吧。

    PC>ping 192.168.2.2
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: bytes=32 seq=1 ttl=126 time=16 ms
    From 192.168.2.2: bytes=32 seq=2 ttl=126 time=16 ms
    From 192.168.2.2: bytes=32 seq=3 ttl=126 time=31 ms
    From 192.168.2.2: bytes=32 seq=4 ttl=126 time=31 ms
    From 192.168.2.2: bytes=32 seq=5 ttl=126 time=16 ms

    [AR1]display ip routing-table  //查看路由表信息
    

    在这里插入图片描述
    通过display ip routing-table 命令,可以查看路由表信息,在图中,在接口0/0/0/中,Protocol 协议下 static 代表是 静态路由,192.168.2.0/24代表“目标网段”/“掩码”,Pre是优先级,设备默认优先级是60,它的下一跳是 10.0.0.2。

    负载均衡

    其实,静态路由的配置只需要使用到一条链路即可实现,使用G0/0/0接口的配置分别连接在AR1与AR2两个路由器上
    在这里插入图片描述
    负载均衡是配置在G0/0/1接口上,负载均衡也叫负载分担,同样的它也是一条等价路由,优先级相同的路由称之为等价路由。

    在配置完静态路由的基础上,添加以下一条命令即可实现负载均衡

    在路由器AR1配置:

    [AR1]ip route-static 192.168.2.0 24 20.0.0.2  
    

    在路由器AR2配置:

    [AR2]ip route-static 192.168.1.0 24 20.0.0.1
    

    负载均衡配置完,再通过display ip routing-table查看路由信息
    在这里插入图片描述
    从表中可知,代表静态路由条目的static路由有两条,且优先级都为60。

    路由备份

    路由备份配置也极为简单,一条命令就可以了,它与负载均衡一样,也是使用G0/0/1接口上, 如果配置了负载均衡,需要先取消负载均衡,再做路由备份。

    其实,负载均衡/路由备份都是在静态路由的基础之上,再进行实验配置的。

    取消路由AR1的负载均衡配置

    [AR1]undo ip router-static 192.168.2.0 24 20.0.0.2 
    

    取消路由器AR2的负载均衡

    [AR1]undo ip router-static 192.168.1.0 24 20.0.0.1 
    

    AR1路由备份配置:

    [AR1]ip router-staic 192.168.2.0 24 20.0.0.2 Preference 70 
    

    AR2路由备份配置

    [AR1]ip router-staic 192.168.1.0 24 10.0.0.2 Preference 70 
    

    很简单吧,路由备份也配置完了,但是它的验证可能与前两个实验有些不同,无法直接通过display ip-routing table查看路由表判断出是否配置成功,如图disp路由信息可以看到,并没有看到我们配置的路由备份条目,再直观点就是看Preference 70的条目有没有在列表中, Preference 70 代表的是优先级为70,如果不做设置,设备默认优先级是60,值越小,优先级越优,因此,pre为60路由会先启用,而70不启用,则作为备份。
    在这里插入图片描述

    路由备份验证

    假设G0/0/0链路断开了,看路由备份会否启用。

    需要手动配置命令关闭接口G0/0/0

    [AR1-GigabitEthernet0/0/0]shutdown  //关闭接口G0/0/0
    

    关闭之后,display ip routing-table查询AR1路由表
    在这里插入图片描述
    从图静态路由信息可知,G0/0/1接口已启用,且其优先级是70的静态路由。

    路由备份的机制是通过配置路由的优先级来决定谁优先启用,默认值60,值越小,路由便越优。

    如果要取消刚才所关闭的接口,回到路由器AR1 G0/0/0接口下,使用此命令

    undo shutdown 
    

    缺省路由

    缺省路由也叫默认路由,在路由器配置中可用0.0.0.0/0表示默认路由,作用是帮助路由器发送路由表中无法查询的包。如果设置了全零网络的路由,路由表中无法查询的包都将送到全零网络的路由中去。

    [AR1]ip router-static 0.0.0.0 0 10.0.0.2  //默认路由0.0.0.0 
    
    展开全文
  • 华为静态路由配置 拓扑图如下: 1、先给R1路由器各接口配置IP 2、给R2路由器各接口配置IP 3、给R3路由器各接口配置IP 4、配置R1路由器的静态路由 5、配置R2路由器的静态路由 6、配置R3路由器的静态路由 7、...

    华为静态路由的配置
    拓扑图如下:
    在这里插入图片描述
    1、先给R1路由器各接口配置IP
    在这里插入图片描述
    2、给R2路由器各接口配置IP
    在这里插入图片描述
    3、给R3路由器各接口配置IP
    在这里插入图片描述
    4、配置R1路由器的静态路由
    在这里插入图片描述
    5、配置R2路由器的静态路由
    在这里插入图片描述
    6、配置R3路由器的静态路由
    在这里插入图片描述
    7、测试网络是否全网互通
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    由此可得,全网互通

    展开全文
  • 如果要使源节点域目标网络进行双向通信,必须同时配置回程静态路由2、接力性 如果某条静态路由中间经过的跳数大于1(路由要经过3个或以上路由节点),则必须在除最后一个路由器外的其他路由器上依次配置到达相同目的...

    本试验主要实验静态路由的三个主要特性

    1、单向性

    仅为数据提供沿着下一跳的方向进行路由,不提供反向路由。如果要使源节点域目标网络进行双向通信,必须同时配置回程静态路由

    2、接力性

    如果某条静态路由中间经过的跳数大于1(路由要经过3个或以上路由节点),则必须在除最后一个路由器外的其他路由器上依次配置到达相同目的节点或目的网络的静态路由。(路由器各端口上直连的各个网络都是直连互通的,因此之间默认是直连路由,因而无需另外配置路由。)

    3、迭代性

    理论上来说,静态路由的下一跳可以是路径中其他路由器中的任意一个接口,只要能保证路由到达下一跳就行了。

    2fbc73394f62fab936f885c68a6d74de.png

    具体配置:

    dis cu

    [V200R003C00]

    #

    sysname r6

    #

    interface GigabitEthernet0/0/1

    ip address 10.1.3.254 255.255.255.0

    #

    ip route-static 10.1.1.0 255.255.255.0 10.1.2.254

    ip route-static 10.1.2.0 255.255.255.0 10.1.3.1

    ip route-static 172.16.1.0 255.255.255.0 10.1.3.1

    ip route-static 172.16.2.0 255.255.255.0 10.1.3.1

    ip route-static 192.168.0.0 255.255.0.0 10.1.2.254 #此处聚合性静态路由 以及迭代性示例

    #

    return

    ------------------

    dis cu

    [V200R003C00]

    #

    sysname r4

    #

    interface GigabitEthernet0/0/0

    ip address 172.16.1.254 255.255.255.0

    #

    interface GigabitEthernet0/0/1

    ip address 10.1.3.1 255.255.255.0

    #

    interface GigabitEthernet0/0/2

    ip address 10.1.2.254 255.255.255.0

    #

    ip route-static 10.1.1.0 255.255.255.0 10.1.2.1

    ip route-static 172.16.2.0 255.255.255.0 172.16.1.1

    ip route-static 172.16.10.0 255.255.255.0 172.16.1.1

    ip route-static 192.168.0.0 255.

    #

    return

    ------------------

    dis cu

    #

    sysname s1

    #

    vlan batch 2 10 100

    #

    interface Vlanif2

    ip address 172.16.2.254 255.255.255.0

    #

    interface Vlanif10

    ip address 172.16.10.254 255.255.255.0

    #

    interface Vlanif100

    ip address 172.16.1.1 255.255.255.0

    #

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 2

    #

    interface GigabitEthernet0/0/23

    port link-type access

    port default vlan 10

    #

    interface GigabitEthernet0/0/24

    port link-type trunk

    port trunk pvid vlan 100

    port trunk allow-pass vlan 2 to 4094

    #

    ip route-static 0.0.0.0 0.0.0.0 172.16.1.254

    ip route-static 10.1.2.0 255.255.255.0 172.16.1.254

    ip route-static 10.1.3.0 255.255.255.0 172.16.1.254

    #

    return

    --------------------------

    dis cu

    [V200R003C00]

    #

    sysname r5

    #

    interface GigabitEthernet0/0/1

    ip address 10.1.1.254 255.255.255.0

    #

    interface GigabitEthernet0/0/2

    ip address 10.1.2.1 255.255.255.0

    #

    ip route-static 10.1.3.0 255.255.255.0 10.1.2.254

    ip route-static 172.16.0.0 255.255.0.0 10.1.2.254

    ip route-static 192.168.0.0 255.255.0.0 10.1.1.1

    #

    return

    ------------------

    dis cu

    [V200R003C00]

    #

    sysname r3

    #

    interface GigabitEthernet0/0/0

    ip address 192.168.1.254 255.255.255.0

    #

    interface GigabitEthernet0/0/1

    ip address 10.1.1.1 255.255.255.0

    #

    ip route-static 10.1.2.0 255.255.255.0 10.1.1.254

    ip route-static 10.1.3.0 255.255.255.0 10.1.1.254

    ip route-static 172.16.2.0 255.255.255.0 10.1.1.254

    ip route-static 172.16.10.0 255.255.255.0 10.1.1.254

    ip route-static 192.168.2.0 255.255.255.0 192.168.1.1

    #

    return

    --------------------

    dis cu

    #

    sysname s3

    #

    vlan batch 20 100

    #

    interface Vlanif20

    ip address 192.168.2.254 255.255.255.0

    #

    interface Vlanif100

    ip address 192.168.1.1 255.255.255.0

    #

    interface GigabitEthernet0/0/24

    port link-type trunk

    port trunk pvid vlan 100

    port trunk allow-pass vlan 2 to 4094

    #

    ip route-static 0.0.0.0 0.0.0.0 192.168.1.254

    ip route-static 10.1.1.0 255.255.255.0 192.168.1.254

    ip route-static 172.16.0.0 255.255.0.0 10.1.1.1

    #

    展开全文
  • 华为静态路由配置 什么是静态路由 网络的端到端之间的传递,靠的就是路由,静态路由简单来说就是手工给路由器或者交换机指定一条去往其他网络的路径信息。 静态路由需要包含哪些东西 一条完整的静态路由需要包含...

    华为静态路由配置及讲解

    什么是静态路由

    网络的端到端之间的传递,靠的就是路由,静态路由简单来说就是手工给路由器或者交换机指定一条去往其他网络的路径信息。

    路由可以解决什么问题?

    路由就是用来解决非直连网络之间的通信问题

    什么是非直连网络

    假设此时我们有一个网络环境
    AR1----AR2----X
    AR1连接到AR2,AR2身后有一个X网络,AR1到X网络就属于非直连网络

    静态路由需要包含哪些东西

    一条完整的静态路由需要包含,目的地址,目的掩码,出接口,及下一跳地址,如果只包含下一跳,不包含出接口,则会造成路由或交换等设备一次查表不能准确的转发数据,而导致二次查表,或者多次查表。这种行为称为递归表查询

    华为路由器静态路由的配置

    拓扑图

    在这里插入图片描述
    lo: 环回口
    ge:千兆以太网接口
    这里以环回口当做路由器身后的网络

    配置要求

    AR1的环回口地址lo:1.1.1.1能ping通AR2的环回口地址2.2.2.2

    配置命令

    首先我们配置接口地址

    AR1

    配置环回口地址
    interface LoopBack0
    ip address 1.1.1.1 255.255.255.255

    配置接口地址
    interface GigabitEthernet0/0/0
    ip address 12.1.1.1 255.255.255.0

    AR2

    配置环回口地址
    interface LoopBack0
    ip address 2.2.2.2 255.255.255.255

    配置接口地址
    interface GigabitEthernet0/0/0
    ip address 12.1.1.2 255.255.255.0

    配置完接口IP后,我们首先要ping一下直连接口,确保直连链路没有问题

    AR1

    AR1的直连接口是AR2的GE0/0/0口,对方的IP地址是12.1.1.2
    在这里插入图片描述
    从此图可以看到AR1到AR2的通信是没有问题的,反过来我们再从AR2 ping AR1

    AR2

    在这里插入图片描述
    也没有问题

    此时我们如果想让AR1的环回口地址能与AR2的环回口地址相互通信,那么我们就要通过写静态的方式来让这两个网段互通

    AR1

    华为的静态路由配置方式如下:
    ip route-static 目的地址 目的掩码 出接口 下一跳地址
    ip route-static 2.2.2.0 24 GigabitEthernet 0/0/0 12.1.1.2

    AR2

    由于通信是双向的,所以AR2也要有去往AR1的路由
    ip route-static 1.1.1.0 24 GigabitEthernet 0/0/0 12.1.1.1

    此时我们可以通过display ip routing-table,这条命令来查看路由的信息

    在这里插入图片描述
    这条路由就是我们刚刚在AR1上写的静态路由。

    ping检测

    AR1

    在这里插入图片描述

    此时,AR1的环回口就可以跟AR2的环回口进行通信了

    展开全文
  • 2 PC配置 3 路由器配置 AR1 system-view 进入系统视图 [AR1]interface GigabitEthernet 0/0/2进入接口视图 [AR1-GigabitEthernet0/0/2]ip address 10.0.0.254 8 配置接口IP [AR1-GigabitEthernet0/0/2]quit [AR1]...
  • 华为静态路由配置实例

    万次阅读 2018-10-08 23:35:04
    拓扑图如上,实验的目的是让三个主机相互进行通信。 大概思路如下: 对于路由器的配置如下:
  • 华为ensp静态路由配置一、拓扑图的搭建二、命令配置1.配置两台pc机2.配置三台路由器的IP地址总结三、1.命令配置:2.查看静态路由表 提示:文章写完后,目录可以自动生成,如何生成可参考右边的帮助文档 以下是本篇...
  • 1234 R2:R3:R4:R5路由配置基本一致 R3:[r3]dhcp enable r3]ip pool [r3]ip pool 1 Info: It’s successful to create an IP address pool. [r3-ip-pool-1]network 192.168.1.96 mask 255.255.255.240 [r3-ip-pool-1]...
  • 华为静态路由配置1

    2015-07-01 19:52:29
    3,给PC配置IP地址; 4,配置路由器; 5,选一台PC去ping另一台PC,若通则成功,不通的话可通过路由表排错。 转载于:https://blog.51cto.com/10080392/1669868...
  • 关注我,你的眼睛会怀孕一、静态路由功能介绍静态路由就是手工配置的路由,使得数据包能够按照预定的路径传送到指定的目标网络。当不能通过动态路由协议学到一些目标网络的路由时,配置静态路由就会显得十分重要。二...
  • 华为静态路由动态路由配置

    千次阅读 2018-10-18 17:33:11
    一、配置设备名称与 IP 地址:R1: <Huawei>system-view Enter system view, return user view with Ctrl+Z. [Huawei]sysname R1 [R1]interface g0/0/1 [R1-GigabitEthernet0/0/1]ip address 202.100.1.1 255....
  • 华为ensp静态路由配置

    2019-11-09 10:44:26
    01配置静态路由 02静态路由负载均衡和备用路由 .
  • 华为静态路由及默认路由的配置

    千次阅读 2020-05-18 21:41:33
    一、 静态路由及默认路由配置: 原理概述: 实验目的: 掌握配置静态路由(指定接口)的方法。 掌握配置静态路由(指定下一跳ip地址)的方法 掌握测试静态路由的连通性的方法。 掌握配置默认路由的方法 掌握测试...
  • 静态路由配置

    2020-12-27 16:59:51
    华为静态路由配置 实验:华为静态路由配置 1.1实验目的 掌握华为静态路由配置 1.2实验拓展 1.3实验要求 1.R1——R4每台设备均有两个环回 2.实验中所有的IP地址均由192.168.1.0/24 划分所得 3.R5的环回为5.5.5.0/24...
  • 浮动静态路由主要应用在设备与设备之间有多条物理链路互联时,比如常见的两条,客户希望一条作为主链路承载一些关键业务,另外一条作为备份链路(平时不用),当主链路故障不通的时候(比如接口down掉),数据流...
  • 静态路由是单向的,也就是说如果希望实现双方的通信,必须在通信双方配置双向的静态路由。 默认路由是一种特殊的静态路由,是当路由表中没有与数据包的目的地址相匹配的表项时路由器能够做出的选择。如果没有默认...
  • 编辑 | 排版 | 制图 | 测试 | ©瑞哥此文用时0小时20分钟,原创不易,坚持更不易,希望我的每一份劳动成果都可以得到大家的一个【好看】静态路由配置1.1 拓扑去包路由:PC1--->PC2 (目标网段始终是:172.16.1.0/...
  • 华为eNSP静态路由配置实验

    千次阅读 2020-05-25 00:28:22
    学习静态路由配置 实验任务 实现网络中设备互通 实验环境 实验拓扑如图所示: 实验配置 路由器R3配置 Ip地址配置 sys [Huawei]sysname R3 [R3]int g0/0/0 [R3-g0/0/0]ip address 20.0.0.1 24 [R3-g0/0/0]dis this ...
  • 华为模拟器静态路由配置所需命令有 1.system-view2.Return(用来从除用户视图外的其它视图退回到用户视图。)3.interfacegigabitethernet?/?/?4.quit(用来从当前视图退回到较低级别视图,如果是用户视图,则退出系统。...
  • 华为eNSP静态路由配置

    2020-12-22 11:16:32
    拓扑图如下: 前提:为各PC配置IP地址、子网掩码等。 配置接口IP R1 R2: R3 配置静态IP R1 R2 R3 查看路由表 此处以R2为例,R1和R3类似不再赘述: 到此结束~
  • IPv4静态路由配置示例组网需求如图1所示,属于不同网段的主机通过几台Switch相连,要求不配置动态路由协议,使不同网段的任意两台主机之间能够互通。图1 配置IP静态路由组网图配置思路采用如下的思路配置IPv4静态...
  • 在SW1上0接口配IP192.168.1.254;在1接口配置IP地址192.168.2.1;在SW2上0接口配IP192.168.3.254;...SW1上配置静态路由去往192.168.3.0网段,下一跳192.168.2.2SW2上也做相同操作 转载于:https://blog....
  • 华为交换之间静态路由配置实例

    千次阅读 2018-11-17 14:17:43
    华为交换之间静态路由配置实例
  • 华为静态路由实验

    2020-11-29 21:39:01
    华为静态路由实验 一、实验要求 二、划分地址,配置IP 三、配置静态路由 1、静态路由 2、路径备份(浮动静态路由) 3)空接口防环 四、单臂路由 SW1 ...
  • 关于出现多个###的问题:将包含eNSP的程序项全部允许防火墙通过,同时“公用”下对应的选择框也需要√;重新启动eNSP后,再打开路由器的CLI界面后恢复正常。2、华为路由基础命令进入系统视图命令:sys...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 661
精华内容 264
关键字:

华为静态路由配置