精华内容
下载资源
问答
  • ospf多区域配置实验
    千次阅读
    2021-09-16 19:19:35

    实验目的:配置OSPF多区域,使得不同网段的PC互相ping通。
    网络拓扑如下:
    在这里插入图片描述
    R0的配置
    Router>en
    Router#conf t
    Router(config)#int g0/1
    Router(config-if)#ip add 192.168.1.1 255.255.255.0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#int g0/0
    Router(config-if)#ip add 192.168.2.1 255.255.255.0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#router ospf 100
    Router(config-router)#router-id 1.1.1.1
    Router(config-router)#net 192.168.1.0 0.0.0.255 area 1
    Router(config-router)#net 192.168.2.0 0.0.0.255 area 0
    Router(config)#exit
    Router#show ip ospf neighbor
    Neighbor ID Pri State Dead Time Address Interface
    2.2.2.2 1

    更多相关内容
  • OSPF多区域配置实验

    千次阅读 2021-05-04 15:15:45
    OSPF多区域配置实验一、实验目的二、实验内容三、实验过程1、实验任务说明2、业务配置流程图3、实验配置过程四、查看和验证五、实验思考与总结 一、实验目的 1、掌握路由器中OSPF动态路由区域的基本配置方法和结果...

    一、实验目的

    1、掌握路由器中OSPF动态路由多区域的基本配置方法和结果验证。

    二、实验内容

    1、完成中兴1800路由器ospf动态路由多区域的基本配置和结果验证。

    三、实验过程

    1、实验任务说明

    1、完成中兴1800路由器ospf动态路由多区域的基本配置和结果验证。
    在这里插入图片描述

    2、业务配置流程图

    在这里插入图片描述

    3、实验配置过程

    1.路由器的基本配置
    步骤1:路由器R1的配置

    ZXR10(config)#conf t
    ZXR10(config)#ip routing
    ZXR10(config)#interface gei_2/2
    ZXR10(config-if)#ip address 192.168.2.1 255.255.255.0
    ZXR10(config)#no shutdown
    ZXR10(config-if)#exit
    ZXR10(config)#interface gei_2/1
    ZXR10(config-if)#ip address 192.168.1.1 255.255.255.0
    ZXR10(config)#no shutdown
    ZXR10(config-if)#exit
    ZXR10(config)#router ospf 1
    ZXR10(config)#area 23
    ZXR10(config-router)#network 192.168.2.0 0.0.0.255
    ZXR10(config-router)#end
    ZXR10#show ip forwarding route
    

    步骤1:路由器R2的配置

    ZXR10(config)#conf t
    ZXR10(config)#ip routing
    ZXR10(config)#interface gei_2/1
    ZXR10(config-if)#ip address 192.168.1.2 255.255.255.0
    ZXR10(config)#no shutdown
    ZXR10(config-if)#exit
    ZXR10(config)#interface gei_2/2
    ZXR10(config-if)#ip address 192.168.3.1 255.255.255.0
    ZXR10(config)#no shutdown
    ZXR10(config-if)#exit
    ZXR10(config)#router ospf 1
    ZXR10(config)#area 24
    ZXR10(config-router)#network 192.168.3.0 0.0.0.255
    ZXR10(config)#area 0
    ZXR10(config-router)#network 192.168.1.0 0.0.0.255
    ZXR10(config-router)#end
    ZXR10#show ip forwarding route
    

    2.路由器配置过程
    在这里插入图片描述

    图1-3路由器R1配置结果图

    在这里插入图片描述

    图1-4路由器R2配置结果图

    四、查看和验证

    步骤1:查看两个路由器的路由表
    路由器R1的输出结果如图1-5所示。

    ZXR10(config)#show ip fouwarding route
    

    在这里插入图片描述

    图1-5 ospf多区域配置R1的路由表

    路由器R2的输出结果如图1-6所示。
    在这里插入图片描述

    图1-6 ospf多区域配置R2的路由表

    步骤2:在各个路由器查看OSPF的运行信息

    ZXR10(config)#show ip ospf
    

    在这里插入图片描述

    图1-7 ospf多区域配置R1的路由表

    步骤3:在各个路由器查看OSPF邻居路由器的信息

    ZXR10(config)#show ip ospf neighbor
    

    在这里插入图片描述

    图1-8 ospf多区域配置R1的路由表

    在这里插入图片描述

    图1-9 ospf多区域配置R3的路由表

    在这里插入图片描述

    图1-10 路由器R1 ping通结果图

    五、实验思考与总结

    1、在OSPF单区域中,每台路由器都要收集其他所有路由器的链路状态信息,如果网路规模不断扩大,链路状态信息也会随之不断的增多,这将使得单台路由器上链路状态数据库非常庞大,导致路由器负担加重,也不便于维护管理。为了解决上述问题,OSPF协议可以将整个自治系统划分为不同的区域(Area),就像一个国家的国土面积很大时,会把整个国家划分为不同的省份来管理一样。
    2、在配置过程中一定要注意命令的书写,真机上的命令和GNS3上的命令是不同的,但是思路是一样的。比如说声名不同的区域,GNS3上是在ip地址和反掩码的后面加上区域,而在真机是先声明区域再宣告网络。

    展开全文
  • ensp的ospf多区域配置实验

    千次阅读 2022-04-15 16:21:43
    实验拓扑如下 路由器配置如下 sys Enter system view, return user view with Ctrl+Z. [Huawei]sysn AR1 [AR1]int g0/0/0 [AR1-GigabitEthernet0/0/0]ip add 192.168.1.1 24 [AR1-GigabitEthernet0/0/0]int lo0 [AR...

    实验拓扑如下

    在这里插入图片描述

    路由器配置如下

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysn AR1
    [AR1]int g0/0/0
    [AR1-GigabitEthernet0/0/0]ip add 192.168.1.1 24
    [AR1-GigabitEthernet0/0/0]int lo0
    [AR1-LoopBack0]ip add 1.1.1.1 24
    [AR1-LoopBack0]q
    [AR1]
    [AR1]ospf 1 router-id 1.1.1.1
    [AR1-ospf-1]area 0
    [AR1-ospf-1-area-0.0.0.0]network 1.1.1.0 0.0.0.255
    [AR1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
    [AR1-ospf-1-area-0.0.0.0]q
    [AR1-ospf-1]q
    [AR1]q
    save


    [Huawei]sysn AR4
    [AR4]int g0/0/0
    [AR4-GigabitEthernet0/0/0]ip add 192.168.1.86 24
    [AR4-GigabitEthernet0/0/0]int s1/0/0
    [AR4-Serial1/0/0]ip add 192.168.2.86 24
    [AR4-Serial1/0/0]int lo0
    [AR4-LoopBack0]ip add 2.2.2.2 24
    [AR4-LoopBack0]ospf 1 router 2.2.2.2
    [AR4-ospf-1]area 0
    [AR4-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
    [AR4-ospf-1-area-0.0.0.0]network 2.2.2.0 0.0.0.255
    [AR4-ospf-1-area-0.0.0.0]q
    [AR4-ospf-1]area 2
    [AR4-ospf-1-area-0.0.0.2]network 192.168.2.0 0.0.0.255
    [AR4-ospf-1-area-0.0.0.2]q
    [AR4-ospf-1]q


    [Huawei]sysn AR3
    [AR3]int s1/0/0
    [AR3-Serial1/0/0]ip add 192.168.2.1 24
    [AR3-Serial1/0/0]
    [AR3-Serial1/0/0]int lo 0
    [AR3-LoopBack0]ip add 3.3.3.3 24
    [AR3-LoopBack0]ospf 1 router 3.3.3.3
    [AR3-ospf-1]area 2
    [AR3-ospf-1-area-0.0.0.2]network 192.168.2.0 0.0.0.255
    [AR3-ospf-1-area-0.0.0.2]network 3.3.3.3 0.0.0.255
    [AR3-ospf-1-area-0.0.0.2]q
    [AR3-ospf-1]q
    [AR3]


    查看ospf 路由

    在这里插入图片描述

    查看R1 R3 ospf链路状态数据库

    在这里插入图片描述

    R3的链路状态数据库

    在这里插入图片描述

    查看R4邻居

    在这里插入图片描述
    当然本次实验比较简单只是让大家了解一下基本配置

    展开全文
  • 摘要消息。③ 个主机都能捕捉到 OSPF 报文:可以看到,图 9-6 为 PC2 捕捉到的报文,两台主机都能捕捉到 OSPF 报文。计算机网络实验报告(3)使用
  • 实验报告里有详细的华为和思科关于ospf多区域配置,还有抓包分析,有需要的话可以私信作者发源码
  • 华为实验17-ospf多区域配置

    千次阅读 2021-08-24 16:24:25
    OSPF区域中,随着网络规模的不断扩大,链路状态信息也很,导致路由的负担加重,为了解决上述问题,OSPF可以将整个自治系统划分为不同的区域链路状态信息只在区域内部泛洪,区域之间传递的只有路由条目而非链路...
    实验原理

    OSPF单区域中,随着网络规模的不断扩大,链路状态信息也很多,导致路由的负担加重,为了解决上述问题,OSPF可以将整个自治系统划分为不同的区域链路状态信息只在区域内部泛洪,区域之间传递的只有路由条目而非链路状态信息,因此减小了路由器的负担,当一台路由器的接口属于不同的区域时候,称为区域边界路由器,负责传递区域间的路由信息,区域间的路由信息传递类似距离矢量算法,为了防止区域间产生环路,所有非骨干区域的路由信息必须经过骨干区域,也就是说非骨干区域必须和骨干区域相连,且非骨干区域之间不能直接进行路由信息交换。

    实验目的

    了解ospf的多区域使用场景
    掌握配置OSPF的多区域方法
    理解OSPF区域边界路由器的工作特点

    实验拓扑

    在这里插入图片描述

    实验步骤

    1,基本配置,测试各链路是否可以ping通,这里已经测试,直连链路都可以正常ping通
    2,配置骨干区域路由器,并在骨干区域0视图下,通告各网段

    [R1]ospf 1
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.0]network 10.0.13.0 0.0.0.255
    
    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255
    
    [R3]ospf 1
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 10.0.13.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 10.0.34.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 10.0.3.0 0.0.0.255
    
    [R4]ospf 1
    [R4-ospf-1]area 0 
    [R4-ospf-1-area-0.0.0.0]network 10.0.34.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.0]network 10.0.4.0 0.0.0.255
    
    

    测试骨干区域内的两台pc是否可以ping通:
    在这里插入图片描述

    配置非骨干区域路由器

    [R5]ospf 1
    [R5-ospf-1]area 1
    [R5-ospf-1-area-0.0.0.1]network 10.0.15.0 0.0.0.255
    [R5-ospf-1-area-0.0.0.1]network 10.0.35.0 0.0.0.255
    [R5-ospf-1-area-0.0.0.1]network 10.0.1.0 0.0.0.255
    
    [R1]ospf 1
    [R1-ospf-1]area 1
    [R1-ospf-1-area-0.0.0.1]network 10.0.15.0 0.0.0.255
    
    [R3]ospf 1
    [R3-ospf-1]area 1
    [R3-ospf-1-area-0.0.0.1]network 10.0.35.0 0.0.0.255
    
    

    查看ospf的邻居状态

    [R5]dis ospf peer
         OSPF Process 1 with Router ID 10.0.15.5
             Neighbors 
    
    
     Area 0.0.0.1 interface 10.0.15.5(GigabitEthernet0/0/0)'s neighbors
     Router ID: 10.0.12.1        Address: 10.0.15.1       
       State: Full  Mode:Nbr is  Slave  Priority: 1
       DR: 10.0.15.5  BDR: 10.0.15.1  MTU: 0    
       Dead timer due in 36  sec 
       Retrans timer interval: 5 
       Neighbor is up for 00:06:25     
       Authentication Sequence: [ 0 ] 
        
             Neighbors 
    
    
     Area 0.0.0.1 interface 10.0.35.5(GigabitEthernet0/0/1)'s neighbors
     Router ID: 10.0.34.3        Address: 10.0.35.3       
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 10.0.35.5  BDR: 10.0.35.3  MTU: 0    
       Dead timer due in 32  sec 
       Retrans timer interval: 5 
       Neighbor is up for 00:05:05     
       Authentication Sequence: [ 0 ]
    
    

    可以看出R5和R1和R3的ospf邻居关系建立正常,都为full状态。
    查看一下路由条目在这里插入图片描述
    查看R5的ospf链路状态数据库信息
    在这里插入图片描述
    可以看到其他区域的路由条目通过sum-net这类LSA获得,而这类LSA不参与本区域的SFP算法匀速那
    对于另外一分部B的路由器R6 ,做相应的配置

    [R6]ospf 1
    [R6-ospf-1]area 2
    [R6-ospf-1-area-0.0.0.1]network 10.0.46.0 0.0.0.255
    [R6-ospf-1-area-0.0.0.1]network 10.0.26.0 0.0.0.255
    [R6-ospf-1-area-0.0.0.1]network 10.0.2.0 0.0.0.255
    
    [R2]ospf 1
    [R2-ospf-1]area 2
    [R2-ospf-1-area-0.0.0.1]network 10.0.26.0 0.0.0.255
    
    [R4]ospf 1
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.1]network 10.0.46.0 0.0.0.255
    
    

    查看R6的路由条目
    在这里插入图片描述

    测试pc1和pc2的连通信

    在这里插入图片描述
    多区域的配置完成,不确定自己有没有配置好ospf,可以使用命令:display current-configuration
    下面看一下R6.
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 华为ensp 模拟器进行OSPF多区域配置 ...实验目的1:实现ospf多区域配置实现pc1与pc2的通信 实验目的2:ospf与rip注入路由实现pc1、pc2与192.168.30.30 通信 最终成功实现,但相应命令是缩写形式完成的
  • OSPF 多区域实验报告

    千次阅读 2021-12-04 16:44:12
    一、实验内容 1.1、背景 科技公司网络准备使用ospf协议来进行路由信息的传递,为了应对网络规模日益增大的问题,决定使用ospf...掌握配置多区域ospf基本的命令。 掌握ospf认证配置命令。 掌握ospf进程下路由引.
  • OSPF多区域实验

    2018-05-31 10:18:24
    用三层交换机和路由器实现多区域OSPF配置详细过程,可以用锐捷、思科的设备,也可用模拟器实现
  • OSPF多区域配置与心得理解

    万次阅读 2019-07-16 10:43:19
    文章目录ospf 多区域实验背景实验需求1.配置ip地址2.配置OSPF3查看R1,R4的邻居表4.强制发布一跳默认路由查看R1有没有收到默认路由5.在R3上使用静默接口测试PC ping外网6.6.6.66.查看路由 实验背景 实验需求 1.配置...
  • 【计算机网络实验】多区域OSPF配置实验
  • 导语: OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous ...2.配置骨干区域路由器: [R1]ospf [R1-ospf-1]area 0 [R
  • OSPF多区域配置实验(思科配置脚本)一、实验目的二、实验内容三、实验流程四、查看和验证 一、实验目的 掌握路由器中ospf动态路由区域划分的基本配置方法和验证结果; 进一步理解网络配置的基本原理; 二、实验...
  • OSPF 多区域配置实验

    2019-07-16 10:55:00
    按照图示分区域配置 OSPF ,实现全网互通 为了路由结构稳定,要求路由器使用环回口作为 Router-id 在AR3上配置静默接口 在OSPF里发布默认路由 PC1 PING通公网地址 实验步骤 按照图示配置 IP 地址和loopback 接口 AR...
  • 计算机网络 OSPF区域DHCP配置实验
  • 配置 OSPF 多区域基本实验

    千次阅读 2020-05-01 17:21:38
    OSPF 多区域基本配置 实验目的 多区域 OSPF 配置技术 背景描述 你是某集成商的高级技术支持工程师,现在让你为某企业设计一个网络,你选择了使用 ospf 路由协议来构建,整个 OSPF 网络设计区域。 实现功能 构建 ...
  • 熟悉ospf多区域配置以及查询LSA的详细信息,有具体的拓扑实验,步骤详细。
  • ospf多区域配置(思科和中兴)

    千次阅读 2019-10-13 19:39:30
    掌握了OPSF动态路由协议的工作原理,以及OSPF区域划分的作用和原理,了解路由器中OSPF动态路由区域划分的基本配置方法和结果验证。 二、实验内容 完成中兴路由器OSPF动态路由区域划分的基本配置和结果验证 三、...
  • OSPF区域配置实验

    2021-04-20 15:51:16
    OSPF区域配置实验 一、实验目的   1、掌握OSPF动态路由单区域的基本配置方法和结果验证。 二、实验内容   1、完成中兴1800路由器OSPF动态路由单区域的基本配置和结果验证。 三、实验过程 1、实验任务说明   ...
  • //R1 conf t interface Loopback0 ip address 1.1.1.1 255.255.255.0 no shut interface FastEthernet0/0 ip address 11.1.1.1 255.255.255.0 no shut ...router ospf 1 network 11.1.1.0 0.0.0.2...
  • OSPF多区域配置实验(中兴配置脚本)一、实验目的二、实验内容三、实验流程四、查看和验证 一、实验目的 掌握路由器中ospf动态路由区域划分的基本配置方法和验证结果; 进一步理解网络配置的基本原理; 二、实验...
  • OSPF多区域实验

    2021-07-10 18:37:45
    所有ip配置完之后 全部通告在ospf中注意,a0区域ospf1,a1区为ospf2。a2,二区为ospf3,这一步是为了重发布时进入的区域正确 ,重发布后可达到全网可达,TelnetR3公有ip,登录到R6,只需要将R3的右边接口 用nat做一...
  • OSPF多区域配置实验报告 用GNS3实现区域的OSPF配置 这是被湖北银河信息技术学院的老师拿来当教材的哦
  • 实验6 OSPF区域配置

    2022-05-24 19:59:47
    掌握OSPF配置方法 掌握通过display命令查看OSPF运行状态的方法 实验环境 Windows 10 eNSP 实验内容(步骤、方法、算法、程序) 【实验拓扑】 ...
  • ENSP ospf 多区域配置

    千次阅读 2022-04-27 15:31:10
    多区域OSPF配置示例 虚链路的连接;totally stub区域配置;hello报文,DD报文,LSR报文,LSU报文和LSAck报文的抓取。
  • OSPF多区域原理与配置

    2021-03-24 15:30:19
    OSPF多区原理一、OSPF多区域概念1、通信量分类(1)域内通信量(2)域间通信量(3)外部通信量2、路由器类型(1)内部路由器(2)区域边界...状态数据库三、OSPF多区域配置四、末梢区域和完全末梢区域相关配置...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,078
精华内容 2,831
关键字:

ospf多区域配置实验