精华内容
下载资源
问答
  • H3C MSR系列路由器典型配置举例(V7)-6W101-H3C MSR系列路由器以太网链路聚合典型配置举例(V7)
  • SOLARIS配置IPV4路由器服务_链路聚合
  • 链路聚合配置命令

    万次阅读 2018-04-09 21:18:49
    1.1 概述1.1.1 链路聚合简介在路由器上使用多链路进行互连时,可以把多条物理链路进行捆绑,对外呈现一条逻辑链路,并屏蔽实际的物理链路。这种方式称之为链路聚合(Aggregate,简称AG),且把实际的物理链路称之...

    1.1    概述

    1.1.1    链路聚合简介

    在路由器上使用多链路进行互连时,可以把多条物理链路进行捆绑,对外呈现一条逻辑链路,并屏蔽实际的物理链路。这种方式称之为链路聚合(Aggregate,简称AG),且把实际的物理链路称之为AG的成员链路。锐捷设备所提供的AG功能符合IEEE802.3ad标准,它可以用于扩展链路带宽,提供更高的连接可靠性。

    AG功能支持流量平衡,可以把流量均匀地分配给各成员链路。AG功能还实现了链路备份,当AG中的一条成员链路断开时,系统会将该成员链路的流量自动地分配到AG中的其它有效成员链路上去。AG中一条成员链路收到的广播或者多播报文,将不会被转发到其它成员链路上。

    图 1‑1 典型拓扑场景

    路由器上每个AG口最多包含的成员口数量都为8个。

    1.1.2    流量均衡简介

    AG可以根据报文的源IP地址,目的IP地址,源IP地址+目的IP及源IP和目的端口号等特征值把流量平均地分配到AG的成员链路中。可以在接口模式下用route-aggregateportload-balance设定流量分配方式。

    “源IP流量平衡”是根据报文的源IP把报文分配到AG的各个成员链路中。不同源IP的报文根据源IP在各成员链路间平衡分配,相同源IP的报文,固定从同一个成员链路转发。该方式为三层AG默认的流量平衡方式。

    “目的IP流量平衡”是根据报文的目的IP把报文分配到AG的各个成员链路中。相同目的IP的报文,固定从同一个成员链路转发,不同目的IP的报文,根据目的IP在各成员链路间平衡分配。

    “源IP地址+目的IP流量平衡”是根据报文的源IP地址+目的IP把报文分配到AP的各个成员链路中。具有不同的源IP地址+目的IP的报文根据源IP地址+目的IP在各成员链路间平衡分配,而具有相同的源IP地址+目的IP的报文则固定分配给同一个成员链路。

    “源IP和目的端口号流量平衡”是根据源IP和目的端口号进行流量分配。不同源IP和目的端口号的报文根据源IP和目的端口号在各成员链路间平衡分配,相同源IP和目的端口号的报文则固定通过相同的成员链路转发。

    当前在路由器上的流量均衡主要由:源IP、目的IP、源端口号、目的端口号为元素的组合进行流量平衡。在路由器RSR77系列上除了支持上述的流量平衡模式外,还支持其他的流量均衡模式,如:基于源和目的端口、基于源IP和目的端口号、基于目的IP和源端口号等,具体配置命令详见下面配置例子

    我们应根据不同的网络环境设置合适的流量分配方式,以便能把流量较均匀地分配到各个链路上,充分利用网络的带宽。


    相关的协议规范或参见的标准:

      802.1AX-2014 - IEEE Standard for Local and metropolitan areanetworks -- Link Aggregation

      RFC7130, Bidirectional Forwarding Detection (BFD) on LinkAggregation Group (LAG) Interfaces


    配置步骤

    步骤

    配置任务

    说明

    1

    创建AG接口

    必选

    2

    将以太口加入AG接口

    必选

    3

    配置AG接口

    可选

    配置举例

    组网需求

    为了提高带宽和链路可靠性,RouterA与RouterB之间通过不同的运营商链路进行互连


    配置要点

    l   RouterARouterB上分别创建AG口,分别将gi 0/0gi 0/1加入AG口;

    l   RouterARouterBAG口配置IP地址及BFD会话。

    配置步骤

    1)    RouterA上创建AG1,并将gi 0/0gi 0/1加入AG口:

    RouterA#configure terminal

    RouterA(config)#interfaceroute-aggregateport 1

    RouterA(config-if-Route-aggregateport1)#exit

    RouterA(config)#

    RouterA(config)#interfacegigabitEthernet 0/0

    RouterA(config-if-GigabitEthernet0/0)#route-port-group 1

    RouterA(config-if-GigabitEthernet0/0)#exit

    RouterA(config)#

    RouterA(config)#interfacegigabitEthernet 0/1

    RouterA(config-if-GigabitEthernet0/1)#route-port-group 1

    RouterA(config-if-GigabitEthernet0/1)#exit

    2)    RouterA上的AG口配置IP地址及BFD会话。

    RouterA(config)#

    RouterA(config)#interfaceroute-aggregateport 1

    RouterA(config-if-Route-aggregateport1)#ip address 124.115.8.1 255.255.255.0

    RouterA(config-if-Route-aggregateport1)#bfd interval 50 min_rx 50 multiplier 3

    RouterA(config-if-Route-aggregateport1)#member interface GigabitEthernet 0/0 bind bfd peer-ip 124.115.8.2

    RouterA(config-if-Route-aggregateport1)#member interface GigabitEthernet 0/1 bind bfd peer-ip 124.115.8.2

    3)    RouterB上创建AG1,并将gi 0/0gi 0/1加入AG口:

    RouterB#configure terminal

    RouterB(config)#interfaceroute-aggregateport 1

    RouterB(config-if-Route-aggregateport1)#exit

    RouterB(config)#

    RouterB(config)#interfacegigabitEthernet 0/0

    RouterB(config-if-GigabitEthernet0/0)#route-port-group 1

    RouterB(config-if-GigabitEthernet0/0)#exit

    RouterB(config)#

    RouterB(config)#interfacegigabitEthernet 0/1

    RouterB(config-if-GigabitEthernet0/1)#route-port-group 1

    RouterB(config-if-GigabitEthernet0/1)#exit

    4)    RouterB上的AG口配置IP地址及BFD会话。

    RouterB(config)#

    RouterB(config)#interfaceroute-aggregateport 1

    RouterB(config-if-Route-aggregateport1)#ip address 124.115.8.2 255.255.255.0

    RouterB(config-if-Route-aggregateport1)#bfd interval 50 min_rx 50 multiplier 3

    RouterB(config-if-Route-aggregateport1)#member interface GigabitEthernet 0/0 bind bfd peer-ip 124.115.8.1

    RouterB(config-if-Route-aggregateport1)#member interface GigabitEthernet 0/1 bind bfd peer-ip 124.115.8.1

    显示验证

    1)查看RouterA上的AG口的接口统计:

    RouterA#show interfaceroute-aggregateport 1

    Index(dec):35 (hex):23

    Route-aggregateport 1 is UP  , line protocol is UP   

    Hardware is  Route-aggregateport, address is001a.a93e.dd31 (bia 001a.a93e.dd31)

    Interface address is: 124.115.8.1/24

    后面省略。。。。

    展开全文
  • 核心交换机CORE和路由器A以及路由器B做链路聚合后成员是unselect 核心交换机CORE的配置 <CORE>display current-configuration # sysname CORE # vlan batch 10 20 100 # cluster enable ntdp enable ndp ...
  • 华为路由器vlan ospf rip static 单臂 多臂 三层 链路聚合 dhcp ppp pppoe的配置
  • 链路聚合和vrrp概述与配置链路聚合链路聚合配置交换机1 配置交换机2 配置VRRPvrrp(虚拟路由器冗余协议)vrrp术语VRRP路由器VRRP组虚拟路由器虚拟IP地址、 MAC地址Master路由器Backup路由器VRRP配置master路由Backup...

    链路聚合

    以太网链路聚合----Eth- trunk多链路汇聚,将多条物理链路变为一条E-trunk的逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效的提高链路的可靠性。即使某条线路短掉,仍能进行数据传输。

    链路聚合分为手工模式和LACP模式。手工模式大多被淘汰。

    LACP模式需要有链路集合控制协议LACP的参与。当需要在两个直连设备间提供一个较大的链路带宽而设备支持LACP时,建议使用LACP模式。

    链路聚合配置

    在这里插入图片描述

    LSW1:

    [LSW1]lacp priority 1000   #配置系统LACP优先级
    [LSW1]int Eth-Trunk 1   #进入Eth-Trunk视图
    [LSW1-Eth-Trunk1]bpdu enable  #开启DPDU功能,起防环作用
    [LSW1-Eth-Trunk1]mode lacp-static  #配置Eth-Trunk为静态LACP模式
    [LSW1-Eth-Trunk1]trunkport Ethernet 0/0/2 to 0/0/4  #批量添加接口
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [LSW1-Eth-Trunk1]p l t   #必须先添加接口到Eth-Trunk后,再设置接口模式
    [LSW1-Eth-Trunk1]p t a v a 
    [LSW1-Eth-Trunk1]max active-linknumber 2 #配置接口上限阈值,表示同时有俩接口是活动状态
    [LSW1-Eth-Trunk1]q                  #接上:剩余接口处于备份状态(忽略的话默认设为8)

    LSW2:

    #LSW1设过优先级后,LSW2可不设
    [LSW2]int Eth-Trunk 1                #配置和LSW1一样,上限阈值设过了 这里也不用设了
    [LSW2-Eth-Trunk1]bpdu enable         
    [LSW2-Eth-Trunk1]mode lacp-static 
    [LSW2-Eth-Trunk1]trunkport Ethernet 0/0/2 to 0/0/4
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [LSW2-Eth-Trunk1]p l t 
    [LSW2-Eth-Trunk1]p t a v a 
    [LSW2-Eth-Trunk1]q

    现在我们来看两个交换机的链路负载情况

    LSW1

    [LSW1]dis trunkmembership eth-trunk 1  #查看链路负载情况
    Trunk ID: 1 
    Used status: VALID 
    TYPE: ethernet 
    Working Mode : Static 
    Number Of Ports in Trunk = 3    #共有3条线路
    Number Of Up Ports in Trunk = 2  #有两条处于活跃状态
    Operate status: up 
      
    Interface Ethernet0/0/2, valid, operate up, weight=1
    Interface Ethernet0/0/3, valid, operate up, weight=1
    Interface Ethernet0/0/4, valid, operate down, weight=1
    [LSW1]         #2、3口 up 活跃状态
    [LSW1]         #4口 down 备份状态

    LSW2

    [LSW2]dis trunkmembership eth-trunk 1
    Trunk ID: 1 
    Used status: VALID 
    TYPE: ethernet 
    Working Mode : Static 
    Number Of Ports in Trunk = 3
    Number Of Up Ports in Trunk = 2
    Operate status: up 
      
    Interface Ethernet0/0/2, valid, operate up, weight=1
    Interface Ethernet0/0/3, valid, operate up, weight=1
    Interface Ethernet0/0/4, valid, operate down, weight=1
    [LSW2]                   #理应和LSW1一样

    在这里插入图片描述
    通信正常

    现在我们来断开活跃口
    在这里插入图片描述

    继续查看链路负载情况

    LSW1

    [LSW1]dis trunkmembership eth-trunk 1
    Trunk ID: 1 
    Used status: VALID 
    TYPE: ethernet 
    Working Mode : Static 
    Number Of Ports in Trunk = 3
    Number Of Up Ports in Trunk = 1
    Operate status: up 
      
    Interface Ethernet0/0/2, valid, operate down, weight=1
    Interface Ethernet0/0/3, valid, operate down, weight=1
    Interface Ethernet0/0/4, valid, operate up, weight=1

    原先备份的4接口被打开

    再次pingPC2
    在这里插入图片描述

    仍能传输,链路聚合备份作用生效!

    vrrp(虚拟路由器冗余协议)

    vrrp作用提供了局域网上的设备备份机制。

    VRRP是一种容错协议,它保证当主机的下–跳路由器坏掉时,可以及时由另一台路由器来代替,从而保证通讯的连续性和可靠性。

    VRRP工作时会在网络中加入一个含有虚拟IP和虚拟MAC地址的虚拟路由器,该路由器充当网络用户的网关,使得网络上的主机与虚拟路由器通信无需了解这个网络上物理路由器的任何信息。

    Master报文的发送:当Master正常工作时,它会每隔一段时间(缺省为1秒)向组内Backup设备发送vrrp通告报文,通告自己工作正常。 (只有Master发送VRRP报文)

    VRRP通告报文被封装在IP报文里,通过组播地址224.0.0.18发送,TTL为255, 协议号为112

    vrrp术语

    VRRP路由器

    运行VRRP的路由器。一台VRRP路由器(的接口)可以同时参与到多个VRRP组中,在不同的组中,一台VRRP路由器可以充当不同的角色。

    VRRP组

    一个VRRP组由多个VRRP路由器组成,使用相同的VRID ( Virtual Router ID ,虚拟路由器ID )进行标识,属于同一VRRP组的VRRP路由器互相交换信息,每一个VRRP组中只能有一个Master。

    虚拟路由器

    对于每一个VRRP组,抽象出来的一个逻辑路由器,该路由器充当网络用户的网关,该路由器并非真实存在,事实上对于用户而言,只需知道虚拟路由器的IP ,至于具体的虚拟路由器的角色由谁来承担、数据转发任务由谁来承担、Master故障后谁来接替,这是VRRP的工作。

    虚拟IP地址、 MAC地址

    虚拟IP地址就是虚拟路由器的IP地址,该地址实际上就是用户的网关地址。

    虚拟MAC地址是虚拟路由器根据VRID生成的MAC地址。一个虚拟路由器拥有一一个虚拟MAC地址,格式为: 00-00-5E-00-01-{VRID}。

    Master路由器

    定时发送VRRP通告报文,以便向Backup路由器告知自己的存活情况。

    以虚拟MAC地址响应其他设备对虚拟IP地址的ARP请求。

    转发目的MAC地址为虚拟MAC地址的IP报文。如果它是这个虚拟IP地址的拥有者(接口实际IP地址为虚拟IP地址) ,则接收目的IP地址为这个虚拟IP地址的IP报文。否则,丢弃这个IP报文。

    如果收到比自己优先级大的报文,立即成为Backup。

    如果收到与自己优先级相等的VRRP报文且本地接口IP地址小于对端接口IP ,立即成为Backup.

    Backup路由器

    接收Master设备发送的VRRP通告报文,判断Master设备的状态是否正常。

    对虚拟IP地址的ARP请求,不做响应。

    丢弃目的IP地址为虚拟IP地址的IP报文。

    如果收到优先级和自己相同或者比自己大的报文,则重置Master_ Down__Interval定时器 ,不进一步比较IP地址。

    如果收到比自己优先级小的报文且该报文优先级是0时,定时器时间设置为Skew_time (偏移时间) , 如果该报文优先级不是0 ,丢弃报文,立刻成为Master。

    VRRP配置

    在这里插入图片描述
    这里默认路由器IP地址都已配好
    现在我们让AR1为master路由器,AR2为backup路由器

    vrrp配置如下

    master路由

    [AR1]int g0/0/0 #进入路由器下行接口(靠近客户端的接口)(若是三层交换机,则进入vlan接口配置)
    [AR1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 10.0.0.1
    Error: The virtual IP address is not within a subnet on this interface.
    # 这里设置虚拟IP出错了, 要设置与客户端相同网段的IP地址
    [AR1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 1.0.0.100
                              #设置虚拟路由器标识 及 虚拟IP地址
    [AR1-GigabitEthernet0/0/0]vrrp vrid 1 priority 120
                              #设置优先级为120(默认为100),数值越大越优先
    [AR1-GigabitEthernet0/0/0]vrrp vrid 1 preempt-mode timer delay 6
                              #配置抢占时延为6秒,防止频繁的进行状态切换造成的线路故障
    [AR1-GigabitEthernet0/0/0]vrrp vrid 1 track interface g0/0/1 reduced 30
                              #跟踪上行接口,若是该接口断开,则优先级降低30(默认为10)
    

    backup路由

    [AR2]int g0/0/0
    [AR2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 1.0.0.100
                             #标识与IP地址要与主路由一致
    #这里配置就完成了 优先级默认100 比主路由低,确保了主路由上行接口出故障后,优先级高于主路由
                     

    现在我们来查看两个路由的vrrp情况

    AR1
    在这里插入图片描述

    AR2
    在这里插入图片描述
    主备路由器已完成

    当我们断开主路由上行接口,再看vrrp,看看发生什么变化

    断开上行接口
    在这里插入图片描述
    AR1
    在这里插入图片描述
    AR2
    在这里插入图片描述

    我们发现,AR2成了主路由,AR1变成了备份路由

    VRRP设备备份作用生效!

    展开全文
  • 路由器路由器)(交换机与服务器之间)------------链路聚合技术 (链路捆绑) 因为当我们在交换机与交换机增加线路时会出现环路,默认情况下CISCO启用了STP技术(会把环路给我们断点)。会把我们增加的线路给...

    **

    链路聚合技术 (链路捆绑)

    **

    链路聚合技术背景
    交换机与交换机之间如果流量很大的时候会出现带宽不足的问题。(路由器与路由器)(交换机与服务器之间)------------链路聚合技术 (链路捆绑)
    在这里插入图片描述

    因为当我们在交换机与交换机增加线路时会出现环路,默认情况下CISCO启用了STP技术(会把环路给我们断点)。会把我们增加的线路给假DOWN。无论交换机与交换机之间增加多少线路默认情况由STP只启一根线路。
    

    链路聚合原理
    将多个物理线路绑捆成一根逻辑线路(port-channel 1),从而增加线路带宽(稳定)。线路的冗余备份(可靠性),线路负责均衡(流量均衡),实现线路的稳定性。
    Switch#show ip inter b
    Interface IP-Address OK? Method Status Protocol
    Port-channel 1 unassigned YES manual up up
    逻辑线路(port-channel 1)作用:你在逻辑接口下做的配置会自动下发链路聚合物理接口下面。

    链路聚合作用
    1:带宽
    2:冗余备份
    3:负载均衡
    链路聚合配置
    在这里插入图片描述

    Switch(config)#interface range f0/3-4
    Switch(config-if-range)#channel-group 1 mode on
    Switch(config)#interface range f0/1,f0/4
    Switch(config-if-range)#channel-group 1 mode on

    链路聚合协议分类

    链路聚合(PAGP,cisco专有协议)
    链路聚合(LACP,IEEE802.3AD 公有协议)

    Switch(config)#interface range f0/1-2
    Switch(config-if-range)#channel-group 1 mode ?
    active Enable LACP unconditionally
    auto Enable PAgP only if a PAgP device is detected
    desirable Enable PAgP unconditionally
    on Enable Etherchannel only
    passive Enable LACP only if a LACP device is detected

    etherchannel的模式作用

    下表为配置etherchannel的模式总结:

    在这里插入图片描述
    Etherchannel负载均衡配置
    在这里插入图片描述

    Etherchannel的负载均衡和线路备份

    Switch(config)#port-channel d-balance ?
    dst-ip Dst IP Addr
    dst-mac Dst Mac Addr
    src-dst-ip Src XOR Dst IP Addr
    src-dst-mac Src XOR Dst Mac Addr
    src-ip Src IP Addr
    src-mac Src Mac Addr
    Switch#show
    etherchannel load-balance
    EtherChannel Load-Balancing Operational State (src-mac):
    Non-IP: Source MAC address
    IPv4: Source MAC address
    IPv6: Source MAC address

    三层链路聚合配置

    链路聚合工作层次划分
    二层链路聚合:以上的聚合都是二层链路聚合。
    三层链路聚合:如下是三层链路聚合配置:
    在这里插入图片描述

    Switch(config)#interface range f0/1-2
    Switch(config-if-range)#no
    switchport(将二层交换机的接口配置成三层接口)
    Switch(config-if-range)#channel-group 1 mode on
    Switch(config-if-range)#exit
    Switch(config)#interface port-channel 1
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config)#interface range f0/1-2
    Switch(config-if-range)#no switchport
    Switch(config-if-range)#channel-group 1 mode on
    Switch(config-if-range)#exit
    Switch(config)#interface port-channel 1
    Switch(config-if)#ip address 192.168.1.2 255.255.255.0
    Etherchannel注意事项(工作中常用)

    为使port channel正常工作,portchannel的成员端口必须具备以下相同属性

    Switch(config)#interface range f0/1,f0/4

    1:端口均为全双工模式
    Switch(config)#interface f0/1
    Switch(config-if)#duplex ?
    auto Enable AUTO
    duplex configuration(自动学习)
    full Force full duplex operation Full(这个端口可以同时接收数据和发送数据)
    half Force half-duplex operation Half(这个端口可以同时接收数据或发送数据)
    2:端口速率相同
    Switch(config)#interface f0/1
    Switch(config-if)#speed 100
    3:端口的类型必须一样,比如同为以太口或同为光纤口;
    Ethernet fastethernet gibitethernet
    4:端口同为access端口并且属于同一个VLAN或同为TRUNK端口
    总:做链路聚合的所有物理接口下面的配置要一样。
    5:如果端口为TRUNK端口,则其allowed vlan 和native vlan属性也应该相同
    总:做链路聚合的所有物理接口下面的配置要一样。
    6:交换机最多可配置48个etherchannel
    7:pagp模式的etherchannel最多可以配置8个相同类型的端口,即每个设备4个端口
    8:lacp模式的etherchannel最多可以配置16个相同类型的端口,即每个设备8个端口

    展开全文
  • 链路聚合与VRRP一.链路聚合1.概念2.配置 一.链路聚合 1.概念 Eth-trunk多链路汇聚,将多跳物理链路变为一条E-trunk的逻辑链路,从而实现增加链路带宽的目的。 链路聚合分为手工模式和LACP模式。 LACP模式需要有链路...

    一.链路聚合

    1.概念

    Eth-trunk多链路汇聚,将多跳物理链路变为一条E-trunk的逻辑链路,从而实现增加链路带宽的目的。
    链路聚合分为手工模式和LACP模式。
    LACP模式需要有链路集合控制协议LACP的参与。当需要在两个直连设备间提供一个较大的链路带宽而设备支持LACP时,建议使用LACP模式。LACP模式不仅可以实现增加带宽,提高可靠性,负载分担的目的,而且可以提供Eth-trunk的容错性,提供备份功能。
    LACP模式下,部分链路是活动链路,所有活动链路均参与数据转发。如果某条活动链路故障,链路聚合组自动在非活动链路中选择一条链路作为活动链路,使得参与数据转发的链路数目不变。

    2.配置

    在这里插入图片描述
    交换机1配置
    [SW1] lacp priority 1000 配置系统LACP优先级
    [SW1] int Eth-Trunk 1 进入Eth-Trunk视图
    [SW1-Eth-Trunk 1] bpdu enable 配置接口上发送到BPDU报文到CPU处理,起到防环作用
    [SW1-Eth-Trunk 1] mode lacp-static 配置Eth-Trunk为静态LACP模式
    在这里插入图片描述
    [SW1] int e0/0/2 接口在加入Eth-trunk前必须要保持为默认hybrid模式类型,可在加入Eth-trunk后再配trunk
    [SW1-e0/0/2] eth-trunk 1 将当前接口加入Eth-Trunk

    [SW1] int e0/0/3
    [Huawei-int e0/0/3] eth-trunk 1

    [SW1] int e0/0/4
    [SW1-int e0/0/4] eth-trunk 1

    [SW1] int e0/0/5
    [SW1-int e0/0/5] eth-trunk 1
    在这里插入图片描述
    [SW1] dis eth-trunk 1 下面有三个成员 此时三个口是跑流量的 负载冗余

    [SW1] int eth-trunk 1
    [SW1-eth-trunk 1] max active-linknumber 2 配置链路聚合活动接口数上限阈值。剩余的成员的接口处于备份状态,未配置上限阈值则Eth-Trunk最多允许8个接口同时处于活动状态
    [SW1-eth-trunk 1]dis this
    在这里插入图片描述
    交换机2配置
    [SW2] int Eth-Trunk 1
    [SW2-Eth-Trunk 1] bpdu enable
    [SW2-Eth-Trunk 1] mode lacp-static

    [SW2] int e0/0/10
    SW2-e0/0/10] eth-trunk 1

    [SW2] int e0/0/11
    [SW2-int e0/0/11] eth-trunk 1

    [SW2] int e0/0/12
    [SW2-int e0/0/12] eth-trunk 1
    在这里插入图片描述

    [SW2] interface eth-trunk 1
    [SW2-Eth-Trunk1] trunkport ethernet 0/0/10 to 0/0/12 向Eth-Trunk批量增加成员接口

    [SW1]dis eth-trunk 1
    [SW1]dis trunkmembership eth-trunk 1 查看链路负载情况
    在这里插入图片描述

    二.VRRP(虚拟路由器冗余协议)

    1.VRRP概述

    1.Virtual Router Redundancy Protocol,也即虚拟路由器冗余协议。
    2.利用VRRP,一组路由器(同一个LAN中的接口)协同工作,但只有一个处于Master状态,处于该状态的路由器(的接口)承担实际的数据流量转发任务。在一个VRRP组内的多个路由器接口共用一个虚拟IP地址,该地址被作为局域网内所有主机的缺省网关地址。
    3.VRRP决定哪个路由器是Master,Master路由器负责接收发送至用户网关的数据包并进行转发,以及相应PC对于其网关IP地址的请求。
    4.Backup路由器侦听Master路由器的状态,并在Master路由器发生故障时,接替其工作,从而保证业务流量的平滑切换。

    2.VRRP术语

    1.VRRP路由器:
    运行VRRP的路由器。一台VRRP路由器(的接口)可以同时参与到多个VRRP组中,在不同的组中,一台VRRP路由器可以充当不同的角色。
    2.VRRP组:
    一个VRRP组由多个VRRP路由器组成,使用相同的VRID(Virtual Router ID,虚拟路由器ID)进行标识,属于同一VRRP组的VRRP路由器互相交换信息,每一个VRRP组中只能有一个Master。
    3.模拟路由器:
    对于每一个VRRP组,抽象出来的一个逻辑路由器,使该路由器充当网络用户的网关,该路由器并非真实存在,事实上对于用户而言,只需知道虚拟路由器的IP,至于具体的虚拟路由器的角色由谁来承担,数据装发任务有谁来承担,Master故障后谁来接替,这是VRRP的工作。

    3.VRRP的作用

    提供了局域网上的设备备份机制。VRRP是一种容错协议,它保证当主机的下一跳路由器坏掉时,可以及时由另一台路由器来代替,从而保证通讯的连续性和可靠性。
    VRRP工作时会在网络中加入一个含有虚拟ID和虚拟MAC地址的虚拟路由器,该路由器充当网络用户的网关,使得网络上的主机与虚拟路由器通信无需了解这个网络上物理路由器的任何信息。

    4.VRRP状态机

    VRRP协议的状态共有三种,分别是lnitialize,Master,Backup,初始状态都是lnitialize,通过比较优先级产生Master和Backup,在规定时间内,Backup若没有收到Master发来的心跳报文,将切换为Master。
    在这里插入图片描述

    5.Master/Backup路由器

    1.Master路由器:
    ◉定时发送VRRP通告报文,以便向Backup路由器告知自己的存活情况。
    ◉以虚拟MAC地址响应其他设备对虚拟IP地址的ARP请求。
    ◉转发目的MAC地址为虚拟MAC地址的IP报文。
    如果它是这个虚拟IP地址的拥有者(接口实际IP地址为虚拟IP地址),则接收目的为这个虚拟IP地址的IP报文。否则,丢弃这个IP报文。
    ◉如果收到比自己优先级大的报文,立即成为Backup。
    ◉如果收到与自己优先级相等的VRRP报文且本地接口IP地址小于对端接口IP,立即成为Backup。
    2.Backup路由器:
    ◉接收Master设备发送的VRRP通告报文,判断Master设备的状态是否正常。
    ◉对虚拟IP地址的ARP请求,不做响应。
    ◉丢弃目的IP地址为虚拟IP地址的IP报文。
    ◉如果收到优先级和自己想同或者比自己大的报文,则重置Master_Down_Interval定时器,不进一步比较IP地址。
    ◉如果收到比自己优先级小的报文且该报文优先级是0时,定时器时间设置为Skew_time(便宜时间),如果该报文优先级不是0,丢弃报文,立刻成为Master。

    6.配置

    在这里插入图片描述

    R1的配置:
    [R1]int g/0/0/0 网关接口(三层交换为VLAN接口,路由器为下行接口)
    [R1-GigabitEthernet0/0/0]ip address 192.168.10.11 24

    [R1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.1 创建VRRP虚拟路由器的标识vrid为1,并配置vrid 1的虚拟IP地址
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 priority 120 设置设备A的优先级为120(缺省值为100),数值越大越优先
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 preempt-mode timer delay 6 配置Master设备的抢占时延为6秒(缺省值为0,立即抢占),以防频繁地进行状态切换
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 track interface GigabitEthernet0/0/1 reduce 30 跟踪上行接口G0/0/0的状态,如端口故障则Master优先级降低30(缺省值为10)
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 track interface g0/0/0 跟踪下行接口
    在这里插入图片描述
    R2配置:
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 192.168.10.44 24
    [R2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.1
    [R2-GigabitEthernet0/0/0]vrrp vrid 1 priority 115
    [R2]dis vrrp 显示VRRP状态
    在这里插入图片描述

    选配项:
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 preempt-mode timer delay 6
    建议backup设备设置为立即抢占,master设备设置为延时抢占,指定一定的延迟时间,这样配置的目的是为了在网络环境不稳定时,为上下行链路的状态恢复一致性等待一定时间,以免出现双master设备或由于主备双方频繁抢占导致用户设备学习到错误的master设备MAC地址。

    [Huawei-GigabitEthernet0/0/2]vrrp vrid 1 timer advertise 3
    master设备会以advertisement_interval通告时间定时器(缺省值为1)向组内backup设备发送vrrp通告报文,通告自己工作正常。如果backup设备在通告时间定时器(约为通告时间的3倍+偏移时间((256–Priority)/256)超时后仍未收到vrrp通告报文,则重新选举Master。

    展开全文
  • 链路聚合的介绍以及配置

    千次阅读 2019-08-17 20:38:15
    1、链路聚合技术的背景: 交换机与交换机之间如果流量很大的时候会出现带宽不足的问题。(路由器路由器)、(交换机与服务器之间) 因为当我们在交换机与交换机增加线路时会出现环路,默认情况下CISCO启用了...
  • 现在网络中两台核心设备之间如果流量太大就会出现带宽不足的现象,一般都是怎么解决呢,今天就向大家...配置链路聚合的设备不仅可以是两台交换机,还可以是两台路由器或者一太交换机一台路由器。2.链路聚合方式图...
  • 现在网络中两台核心设备之间如果流量太大就会出现带宽不足的现象,一般都是怎么解决呢,今天就向大家...配置链路聚合的设备不仅可以是两台交换机,还可以是两台路由器或者一太交换机一台路由器。2.链路聚合方式图...
  • 现在网络中两台核心设备之间如果流量太大就会出现带宽不足的现象,一般都是怎么解决呢,今天就向大家介绍一下链路...配置链路聚合的设备不仅可以是两台交换机,还可以是两台路由器或者一太交换机一台路由器。2.链路...
  • 以太网链路聚合、VRRP简单介绍一、以太网链路聚合1、Eth-trunk2、LACP模式3、链路聚合配置二、VRRP1、虚拟路由器冗余协议2、VRRP相关介绍3、虚拟MAC地址4、VRRP状态机三、Master/Backup路由器1、Master路由器2、...
  • 目录 1.交换机的相关知识 交换机网络中的链路类型:接入...二层交换机之间做lacp链路聚合 r1到r4有一条链路做浮动路由 拓补图: PC1到PC7里面的IP地址,子网网关自己配好 交换机的配置,我这里是从LSW2开始配的 LSW
  • 一、配置之前有几点坑需要点一下 1.通过cat /proc/net/bonding/bond0来... 2.链路聚合测试的时候,必须得插在交换机上,如果直接插在路由器上的话是没有效果的,亲测深坑。 二、创建聚合网络: 1.创建ifcfg-bond0...
  • 1、使两台核心交换机之间形成一根聚合了两条物理链路的TRUNK聚合虚拟链路; 2、交换机S2可以管理除交换机S1之外所有交换机的VLAN,别的交换机不能修改和新建VLAN信息,交换机S1只能自己管理自己和传递S2的VLAN维护...
  • 目录单臂路由、三层交换机和链路聚合一、单臂路由1)单臂路作用:2)链路类型:二、三层交换三、链路聚合1)以太网链路聚合2)配置命令 一、单臂路由 1)单臂路作用: 实现不同VLAN之间的通信 2)链路类型: 交换机...
  • Trunk概念2.2 Eth-Trunk链路聚合模式2.2.1 手工负载分担模式2.2.2 LACP模式2.2.2.1 LACP模式活动链路的选取2.2.2.2 LACP模式的抢占机制2.3 Eth-Trunk接口负载分担三、Eth-Trunk配置实例3.1 手工配置路由器 ...
  • 三层交换机技术链路聚合1.链路聚合概述2.链路聚合的工作模式实验实验一 三层交换机 1.三层交换机技术 交换机使用三层交换机技术实现vlan间的通信,三层交换=二层交换+三层转发。 在三层交换机上,第三层引擎处理数据...
  • 文章目录手工配置静态lacp三层链路聚合 手工配置 这里只有200M,即使SW5有2G,但是实际只能转发200M。 静态lacp SW5同理 lacp有差错校验的效果。 三条链路1:1:1,最大活跃是8。 将其中一条链路作为...
  • 二、链路聚合的概述 1、链路聚合的产生 2、聚合链路的原理和好处 三、链路聚合的模 1、手动负载均衡模式 2、LACP(链路聚合控制协议)模式 3、两者的区别 四、数据流控制 五、Eth-Trunk端口 六、配置Eth-Trunk端口 ...
  • 单臂路由、三层交换、链路聚合 目录 单臂路由、三层交换、链路聚合 单臂路由: 三层交换: 链路聚合 单臂路由: 当只有二层交换机又要实现不同VLAN之间的通信时,需要用到单臂路由。 链路类型: 交换机连接...
  • 思科--链路聚合拓扑图地址分配表在本练习中,两个路由器配置为可相互通信。您负责配置子接口以便与交换机通信。您将用 PVST 配置 VLAN、中继和 EtherChannel。所有互联网设备已预先配置。R1路由器配置R2路由器配置S1...
  • 单臂路由三层交换技术和链路聚合一、单臂路由1、链路类型2、子接口3、路由实现不同VLAN间通信4、华为配置命令二、三层交换技术1.概念2、MLS条目3、华为配置命令三、链路聚合1、概念2、华为配置命令 一、单臂路由 1、...
  • 一、单臂路由 1.实现VLAN之间的路由 方法一:采用路由器的多个物理接口 方法二:采用单臂路由的方式(子接口的方式) 2.单臂路由概述 单臂路由实现不同VLAN间通信 链路类型: ...
  • 链路聚合实现冗余功能实验(2) 文章目录1.实验环境2.配置LSW1 LACP3. 配置LSW24.配置R15.配置R26.主机配置注意网关地址一定要填7.互通性测试 1.实验环境 2.配置LSW1 LACP 3 配置LSW2 4.配置R1 5配置R2 6.主机配置注意...
  • 文章目录单臂路由技术三层交换技术链路聚合技术LSW交换机的链路聚合CE交换机的链路聚合 单臂路由技术 二层交换机+路由器 当只有二层交换机时,又要实现不同vlan间通信时,需要用到单臂路由技术 交换机命令: 路由器...
  • 文章目录VRRP的概述VRRP的作用虚拟路由器Master报文的发送VRRP状态机VRRP华为命令配置链路聚合命令 VRRP的概述 1.利用VRRP,一组路由器(同一个LAN中的接口),协同工作,但是只有一个处于Master状态,处于该状态的...
  • 单臂路由、三层交换和链路聚合的...三层交换机VLAN间通信的转发过程链路聚合配置命令 单臂路由 单臂路由实现不同vlan间通信 1、链路类型 (1)交换机连接主机的端口为access链路 (2)交换机连接路由器的端口为Trunk链

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 158
精华内容 63
关键字:

路由器链路聚合配置