精华内容
下载资源
问答
  • 包含超级终端的登录教程和静态路由与缺省路由的配置代码,以H3C为例
  • 《计算机网络实验报告——静态路由与缺省路由的使用》由会员分享,可在线阅读,更多相关《计算机网络实验报告——静态路由与缺省路由的使用(8页珍藏版)》请在人人文库网上搜索。1、实验三 静态路由与缺省路由的使用...

    《计算机网络实验报告——静态路由与缺省路由的使用》由会员分享,可在线阅读,更多相关《计算机网络实验报告——静态路由与缺省路由的使用(8页珍藏版)》请在人人文库网上搜索。

    1、实验三 静态路由与缺省路由的使用一、实验环境:Windows7操作系统的计算机;Boson Netsim for CCNA v6.0805交换机2、 实验步骤;rt1接到pc1,rt2接到pc2,rt1到rt2选择点到点类型,rt2的serial0作为DCE端。配置如下:(1)Router1配置:Routerenable Router#config tEnter configuration commands, one per line. End with CNTL/Z.Router(config)#hostname router1router1(config)#ena se c1router1。

    2、(config)#vty 0 4% Invalid input detected at marker.router1(config)#line vty 0 4router1(config-line)#login router1(config-line)#pass c2router1(config-line)#int eth 0router1(config-if)#ip address 192.168.1.1 255.255.255.0router1(config-if)#no shut%LINK-3-UPDOWN: Interface Ethernet0, changed state to u。

    3、prouter1(config-if)#int se 0router1(config-if)#ip address 10.0.0.1 255.0.0.0router1(config-if)#clock rate 64000router1(config-if)#no shut%LINK-3-UPDOWN: Interface Serial0, changed state to up%LINK-3-UPDOWN: Interface Serial0, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface Seria。

    4、l0, changed state to downrouter1(config-if)#endrouter1#copy run startDestination filename startup-config?Building configuration.OK(2)Router2配置:RouterenableRouter#config tEnter configuration commands, one per line. End with CNTL/Z.Router(config)#host router2router2(config)#ena se c1router2(config)#li。

    5、ne vty 0 4router2(config-line)#loginrouter2(config-line)#pass c2router2(config-line)#int eth 0router2(config-if)#ip address 192.168.2.1 255.255.255.0router2(config-if)#no shut%LINK-3-UPDOWN: Interface Ethernet0, changed state to uprouter2(config-if)#int se 0router2(config-if)#ip add 10.0.0.2 255.0.0。

    6、.0router2(config-if)#no shut%LINK-3-UPDOWN: Interface Serial0, changed state to up%LINK-3-UPDOWN: Interface Serial0, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to downrouter2(config-if)#endrouter2#copy run startDestination filename startup-config?Buil。

    7、ding configuration.OK(3) PC配置:PC1 192.168.1.2 255.255.255.0 192.168.1.1PC2 192.168.2.2 255.255.255.0 192.168.1.1(4) 配置,测试静态路由在Rputer1中配置:router1#ip route 192.168.2.0 255.255.255.0 10.0.0.2% Invalid input detected at marker.router1# ip router 192.168.2.0 255.255.255.0 10.0.0.2% Invalid input detected。

    8、 at marker.router1#config tEnter configuration commands, one per line. End with CNTL/Z.router1(config)# ip route 192.168.2.0 255.255.255.0 10.0.0.2router1(config)#endrouter1#copy run startDestination filename startup-config?Building configuration.OKrouter1#router1#show ip rpute% Invalid input detect。

    9、ed at marker.router1#show ip routeCodes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaE1 - OSPF external type 1, E2 - OSPF external type 2, E - EGPi - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate defaul。

    10、tU - per-user static routeGateway of last resort is not setC 192.168.1.0 is directly connected, Ethernet0S 192.168.2.0 1/0 via 10.0.0.2在Router2中配置:router2#router2#router2#config tEnter configuration commands, one per line. End with CNTL/Z.router2(config)#ip route 192.168.1,0 255.255.255.0 10.0.0.1% 。

    11、Invalid input detected at marker.router2(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1router2(config)#endrouter2#copy run startDestination filename startup-config?Building configuration.OKrouter2#show ip rpute% Invalid input detected at marker.router2#show ip routeCodes: C - connected, S - sta。

    12、tic, I - IGRP, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaE1 - OSPF external type 1, E2 - OSPF external type 2, E - EGPi - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate defaultU - per-user static routeGateway of last resort is not setC 19。

    13、2.168.2.0 is directly connected, Ethernet0S 192.168.1.0 1/0 via 10.0.0.1再分别选择R1,R2测试静态路由,命令如下:router1#show ip rpute% Invalid input detected at marker.router1#show ip routeCodes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter。

    14、 areaE1 - OSPF external type 1, E2 - OSPF external type 2, E - EGPi - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate defaultU - per-user static routeGateway of last resort is not setC 192.168.1.0 is directly connected, Ethernet0S 192.168.2.0 1/0 via 10.0.0.2router2#show ip routeCodes: 。

    15、C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaE1 - OSPF external type 1, E2 - OSPF external type 2, E - EGPi - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate defaultU - per-user static routeGateway of last。

    16、 resort is not setC 192.168.2.0 is directly connected, Ethernet0S 192.168.1.0 1/0 via 10.0.0.1(5) 配置,测试缺省路由:router2#config tEnter configuration commands, one per line. End with CNTL/Z.router2(config)#no ip route 192.168.1.0 255.255.255.0 10.0.0.1router2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1route。

    17、r2(config)#endrouter2#copy run startDestination filename startup-config?Building configuration.OK3、 最终配置列表:Router1Router2PC1PC2Ethernet ip192.168.1.0192.168.2.0192.168.1.2 192.168.2.2Serial ip10.0.0.210.0.0.1子网掩码255.255.255.0 255.255.255.0 默认网关192.168.1.0192.168.2.0四、结果分析:配置完PC后,先测试一下:在PC1 ping Rout。

    18、er1C:ping 192.168.1.1Pinging 192.168.1.1 with 32 bytes of data:Reply from 192.168.1.1: bytes=32 time=60ms TTL=241Reply from 192.168.1.1: bytes=32 time=60ms TTL=241Reply from 192.168.1.1: bytes=32 time=60ms TTL=241Reply from 192.168.1.1: bytes=32 time=60ms TTL=241Reply from 192.168.1.1: bytes=32 time。

    19、=60ms TTL=241Ping statistics for 192.168.1.1: Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),Approximate round trip times in milli-seconds:Minimum = 50ms, Maximum = 60ms, Average = 55ms在PC2 ping Router2C:ping 192.168.2.1Pinging 192.168.2.1 with 32 bytes of data:Reply from 192.168.2.1: bytes=32 。

    20、time=60ms TTL=241Reply from 192.168.2.1: bytes=32 time=60ms TTL=241Reply from 192.168.2.1: bytes=32 time=60ms TTL=241Reply from 192.168.2.1: bytes=32 time=60ms TTL=241Reply from 192.168.2.1: bytes=32 time=60ms TTL=241Ping statistics for 192.168.2.1: Packets: Sent = 5, Received = 5, Lost = 0 (0% loss。

    21、),Approximate round trip times in milli-seconds:Minimum = 50ms, Maximum = 60ms, Average = 55msC:ping 192.168.2.2Pinging 192.168.2.2 with 32 bytes of data:Reply from 192.168.2.2: bytes=32 time=60ms TTL=241Reply from 192.168.2.2: bytes=32 time=60ms TTL=241Reply from 192.168.2.2: bytes=32 time=60ms TTL。

    22、=241Reply from 192.168.2.2: bytes=32 time=60ms TTL=241Reply from 192.168.2.2: bytes=32 time=60ms TTL=241Ping statistics for 192.168.2.2: Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),Approximate round trip times in milli-seconds:Minimum = 50ms, Maximum = 60ms, Average = 55ms配置缺省路由后:C:ping 172.。

    23、16.1.1Pinging 172.16.1.1with 32 bytes of data:Reply from 172.16.1.1: bytes=32 time=60ms TTL=241Reply from 172.16.1.1: bytes=32 time=60ms TTL=241Reply from 172.16.1.1: bytes=32 time=60ms TTL=241Reply from 172.16.1.1: bytes=32 time=60ms TTL=241Reply from 172.16.1.1: bytes=32 time=60ms TTL=241Ping statistics for 172.16.1.1: Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),Approximate round trip times in milli-seconds:Minimum = 50ms, Maximum = 60ms, Average = 55ms5、 实验拓扑截图:6、 心得体会:通过本次实验掌握了静态路由与缺省路由的配置方法,但是对于实验中的许多命令还是不熟练,今后要多加练习。

    展开全文
  • 静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。静态路由一般适用于比较简单的网络环境,在这样的环境中,网络管理员易于清楚地了解网络的拓扑...

    静态路由介绍:

    静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。静态路由一般适用于比较简单的网络环境,在这样的环境中,网络管理员易于清楚地了解网络的拓扑结构,便于设置正确的路由信息。

    格式:ip route 目标网段 子网掩码 下一跳地址

     

    缺省路由介绍:

    缺省路由又称为默认路由,是一种特殊的静态路由,目的地址与掩码配置为全零(0.0.0.0 0.0.0.0)。当路由表中的所有路由都选择失败的时候,为使得报文有最终的一个发送地,将使用缺省路由。

    缺省路由通常用相同的处理方式把报文指向另一个路由器。如果有其他路由匹配,则按照该路由规则转发相应的报文,否则该报文将被转发到该路由器的缺省路由。这个过程不断重复,直到一个数据包被传递到目的地。设备的缺省路由通常被也称为默认网关,它经常提供如数据包过滤,防火墙或代理服务器等功能。

    格式:ip route  0.0.0.0  0.0.0.0  下一跳地址

     

    操作

    添加三台路由器和四台主机

    本实验的路由器使用了Serial(串口),因此需要在路由器中添加模块NM-4A/S,添加模块前

    先关闭路由器电源,添加好后再开启电源。

     

    为Router0添加模块NM-4A/S

    找到 “Physical”

    默认电源为开

    单击电源关闭电源

    拖入模块NM-4A/S

    单击电源打开电源

    为Router1和Router2完成同样的操作

     

     

    PC0的IP为192.168.10.1,网关为192.168.10.254,与Router1的fa0/0接口连接

    PC1的IP为192.168.20.1,网关为192.168.20.254,与Router1的fa0/1接口连接

    PC2的IP为192.168.30.1,网关为192.168.30.254,与Router2的fa0/0接口连接

    PC3的IP为192.168.40.1,网关为192.168.40.254,与Router1的fa0/1接口连接

     

    Router1的s1/0端口与Router的s1/0端口连接

    Router1的s1/1端口与Router的s1/1端口连接

     

    Router2的s1/0端口与Router的s1/0端口连接

    Router2的s1/1端口与Router的s1/1端口连接

     

    分配IP

    PC0

    PC1

    PC2

    PC3

     

    配置Router1

    Router>enable

    Router#configure terminal

    Router(config)#hostname SA

    SA(config)#interface fa0/0

    SA(config-if)#ip address 192.168.10.254 255.255.255.0

    SA(config-if)#shutdown

    SA(config-if)#no shutdown

    SA(config-if)#exit

    SA(config)#interface fa0/1

    SA(config-if)#ip address 192.168.20.254 255.255.255.0

    SA(config-if)#shutdown

    SA(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#interface s1/0

    Router(config-if)#ip address 192.168.1.1 255.255.255.0

    Router(config-if)#clock rate 38400     (设置时钟频率)

    Router(config-if)#shutdown

    Router(config-if)#no shutdown

    Router(config-if)#exit

     

    测试:

    SA(config-if)#^Z    (Ctrl+Z组合键)

    SA#show running-config

     

    保存设置

    Router#write

     

     

    配置Router2

    Router>enable

    Router#configure terminal

    SB(config)#hostname SB

    SB(config)#int fa0/0

    SB(config-if)#ip address 192.168.30.254 255.255.255.0

    SB(config-if)#shutdown

    SB(config-if)#no shutdown

    SB(config-if)#exit

    SB(config)#int fa0/1

    SB(config-if)#ip address 192.168.40.254 255.255.255.0

    SB(config-if)#shutdown

    SB(config-if)#no shutdown

    SB(config-if)#exit

    SB(config)#interface s1/1

    SB(config-if)#ip address 192.168.2.2 255.255.255.0

    SB(config-if)#shutdown

    SB(config-if)#no shutdown

     

    测试

    SB(config-if)#^Z

    SB#show running-config

     

    保存设置:

    SB#write

     

     

    配置Router0

    Router>enable

    Router#configure terminal

    Router(config)#hostname SC

    SC(config)#interface s1/0

    SC(config-if)#ip address 192.168.1.2 255.255.255.0

    SC(config-if)#shutdown

    SC(config-if)#no shutdown

    SC(config-if)#exit

    SC(config)#interface s1/1

    SC(config-if)#ip address 192.168.2.1 255.255.255.0

    SC(config-if)#clock rate 38400

    SC(config-if)#shutdown

    SC(config-if)#no shutdown

     

    测试:

    SC(config)#^Z

    SC#show running-config

     

    保存设置:

    SC#write

     

    配置静态路由

    Router1

    SA>enable

    SA#configure terminal

    SA(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.2

    SA(config)#ip route 192.168.30.0 255.255.255.0 192.168.1.2

    SA(config)#ip route 192.168.40.0 255.255.255.0 192.168.1.2

     

    测试:

    SA(config)#^Z

    SA#show running-config

     

    保存设置:

    SA#write

     

     

    Router2

    SB>enable

    SB#configure terminal

    SB(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1

    SB(config)#ip route 192.168.10.0 255.255.255.0 192.168.2.1

    SB(config)#ip route 192.168.20.0 255.255.255.0 192.168.2.1

     

    测试:

    SB(config)#^Z

    SB#show running-config

     

    保存设置:

    SB#write

     

     

    Router2

    SC>enable

    SC#configure terminal

    SC(config)#ip route 192.168.10.0 255.255.255.0 192.168.1.1

    SC(config)#ip route 192.168.20.0 255.255.255.0 192.168.1.1

    SC(config)#ip route 192.168.30.0 255.255.255.0 192.168.2.2

    SC(config)#ip route 192.168.40.0 255.255.255.0 192.168.2.2

     

    测试:

    SC(config)#^Z

    SC#show running-config

     

    保存设置:

    SC#write

     

    连通性测试

    PC0 Ping PC1

     

    PC0 Ping PC2

    PC0 Ping PC3

    实验成功

     

     

     

    缺省路由(默认路由)

    删除之前配置的静态路由

    Router1

    SA>enable

    SA#configure terminal

    SA(config)#no ip route 192.168.2.0 255.255.255.0 192.168.1.2

    SA(config)#no ip route 192.168.30.0 255.255.255.0 192.168.1.2

    SA(config)#no ip route 192.168.40.0 255.255.255.0 192.168.1.2

     

    测试:

    SA(config)#^Z

    SA#show running-config

     (之前设置的静态路由表已经没有了)

     

    配置静态路由

    SA#enable

    SA#configure terminal   

    SA(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2

     

    测试:

    SA(config)#^Z

    SA#show running-config

     (缺省路由已添加)

     

    保存设置:

    SA#write

     

    Router2

    删除之前配置的静态路由

    SB>enable

    SB#configure terminal

    SB(config)#no ip route 192.168.1.0 255.255.255.0 192.168.2.1

    SB(config)#no ip route 192.168.10.0 255.255.255.0 192.168.2.1

    SB(config)#no ip route 192.168.20.0 255.255.255.0 192.168.2.1

     

    测试:

    SB(config)#^Z

    SB#show running-config

      (之前设置的静态路由表已经没有了)

     

    配置静态路由

    SB#enable

    SB#configure terminal

    SB(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.1

     

    测试:

    SB(config)#^Z

    SB#show running-config

    (缺省路由已添加)

     

    保存设置:

    SB#write

     

    连通性测试:

    PC0 Ping PC1

    PC0 Ping PC2

    PC0 Ping PC3

    实验成功

     

     

    注意:1、主机和路由器间用反转线连接。

          2、路由器设置完后要保存设置,以防断电后丢失做好的设置。

    3、Router0中不能采用默认路由的方式配置路由信息,如在Router0中配置了两条静态路由,当PING信息包到达Router0时,Router0会依次将数据包转发到192.168.1.2和192.168.2.1两个下一跳,所以出现数据包转发超时丢包的情况就难以避免;若只保留其中的任何一条默认路由也会导致Router0与左半部分或右半部分的网络不能通信。

    展开全文
  • 实验10 静态路由和静态缺省路由配置 1 实验内容实验目的 实验内容: 1. 给路由器的网络接口配置IP地址 2. 配置静态路由和静态缺省路由,观察静态缺省路由产生的路由环 3. 使用路由表查看指令
  • 静态路由缺省路由的配置

    千次阅读 2020-01-12 17:08:17
    静态路由缺省路由的配置 0X00前言  静态路由静态路由是一种路由的方式,路由项由手动配置,而非动态决定。静态路由是固定的,不会改变,即使网络状况已经改变或是重新被组态。一般来说,静态路由是由网络管理员...

    静态路由和缺省路由的配置

    0X00前言

     静态路由:静态路由是一种路由的方式,路由项由手动配置,而非动态决定。静态路由是固定的,不会改变,即使网络状况已经改变或是重新被组态。一般来说,静态路由是由网络管理员逐项加入路由表中的。
     缺省路由:在通信网络中,缺省路由是当网络主机上没有特定路由时而设置的数据包转发规则,可以给出一个默认的下一跳地址,路由表中没有匹配项的所有数据包都通过缺省路由进行转发。

    0X01拓扑图

    0X02基础配置

    一、配置路由器R1

    system-view    //进入系统视图,注意后面代码中,<>代表用户视图,[]代表系统视图
    sysname R1    //将路由器改名为R1
    [R1]interface GigabitEthernet 0/0/0   //进入G0/0/0端口
    [R1-GigabitEthernet0/0/0]ip address 10.0.13.1 24    //设置ip
    [R1-GigabitEthernet0/0/0]quit   //退出系统视图
    [R1]interface GigabitEthernet 0/0/1    //进入G0/0/1端口
    [R1-GigabitEthernet0/0/1]ip address 10.0.12.1 24    //设置ip地址
    [R1-GigabitEthernet0/0/1]quit    //退出系统视图
    [R1]interface LoopBack 0    //进入LoopBack端口
    [R1-LoopBack0]ip address 10.0.1.1 24    //设置ip
    

    二、查看R1配置情况

    <R1>display ip interface brief    //在用户视图下输入这行命令
    

    lWKptg.png

    三、配置路由器R2

    system-view
    sysname R2
    [R2]interface GigabitEthernet 0/0/1
    [R2-GigabitEthernet0/0/1]ip address 10.0.12.2 24
    [R2-GigabitEthernet0/0/1]quit
    [R2]interface GigabitEthernet 0/0/2
    [R2-GigabitEthernet0/0/2]ip address 10.0.23.2 24
    [R2-GigabitEthernet0/0/2]quit
    [R2]interface LoopBack0
    [R2-LoopBack0]ip address 10.0.2.2 24
    

    四、查看R2配置情况

    <R2>display ip interface brief
    

    lohUbT.png

    五、配置路由器R3

    system-view
    sysname R3
    [R3]interface GigabitEthernet 0/0/0
    [R3-GigabitEthernet0/0/0]ip address 10.0.13.3 24
    [R3-GigabitEthernet0/0/0]quit
    [R3]interface GigabitEthernet0/0/2
    [R3-GigabitEthernet0/0/2]ip address 10.0.23.3 24
    [R3-GigabitEthernet0/0/2]quit
    [R3]interface LoopBack 0
    [R3-LoopBack0]ip address 10.0.3.3 24
    

    六、查看R3配置情况

    <R3>display ip interface brief
    

    lWMYMn.png

    七、ping

    执行ping命令,检查R1、R2与其他设备间的连通性,发现可以ping通。

    <R1>ping 10.0.12.2
    <R1>ping 10.0.13.3
    <R2>ping 10.0.23.3
    

    0X03测试连通性

    测试R2到10.0.13.0/24、10.0.3.0/24的连通性。

    一、ping

    <R2>ping 10.0.13.3
    <R2>ping 10.0.3.3
    

    ping完后发现网络之间是ping不通的。

    二、查看路由表

    <R2>display ip routing-table 
    

    lWM5Je.png
     查看R2的路由表发现,路由表中没有去往这两个网段路由的信息。R2如果要与10.0.3.0/24网络通信,需要R2上有去往该网段的路由信息,并且R3上也需要有到R2相应接口所在IP网段的路由信息。

    0X04在R2上配置静态路由

    一、

     配置目的地址为10.0.13.0/24和10.0.3.0/24的静态路由,路由的下一跳配置为R3的G0/0/0接口,IP地址10.0.23.3。默认静态路由优先级为60.

    [R2]ip route-static 10.0.13.0 24 10.0.23.3  //24代表子网掩码长度
    [R2]ip route-static 10.0.3.0 24 10.0.23.3  //24也可写255.255.255.0
    

    二、查看路由表

    lWMxJg.png

    0X05配置备份静态路由

     R2与网络10.0.13.3和10.0.3.3之间交互的数据通过R2与R3间的链路传输。根据拓扑图可以看出,当R2和R3间的链路发生故障时,R2将不能与网络10.0.13.3和10.0.3.3通信。 但是R2可以通过R1与R3通信。所以可以通过配置一条备份静态路由实现路由的冗余备份。
     注意在正常情况下,备份静态路由是不生效的。当R2和R3间的链路发生故障时,才使用备份静态路由传输数据。 所以在配置备份静态路由时,需要修改备份静态路由的优先级,确保只有主链路故障时才使用备份路由。本实验将备份静态路由的优先级修改为80。

    [R1]ip route-static 10.0.3.0 24 10.0.13.3
    [R2]ip route-static 10.0.13.0 255.255.255.0 10.0.12.1 preference 80
    [R2]ip route-static 10.0.3.0 24 10.0.12.1 preference 80
    [R3]ip route-static 10.0.12.0 24 10.0.13.1
    

    0X06验证静态路由

    一、

    <R2>display ip routing-table
    

    二、

     当R2和R3之间链路正常时,R2与网络10.0.13.3和10.0.3.3之间交互的数据通过R2与R3间的链路传输。执行tracert命令,查看数据的传输路径。

    <R2>tracert 10.0.13.3
    <R2>tracert 10.0.3.3
    

    lofxjx.png

    0X07验证备份静态路由

    一、关闭R2上的G0/0/2接口,模拟R2与R3间链路发生故障。

    [R2]interface GigabitEthernet 0/0/2
    [R2-GigabitEthernet0/0/2]shutdown
    [R2-GigabitEthernet0/0/2]quit
    

    二、查看路由表

    <R2>display ip routing-table
    

    lWlgUK.png

    三、检测R2到目的地址10.0.13.3。10.0.3.3的连通性,发现可以ping通。

    <R2>ping 10.0.3.3
    <R2>ping 10.0.3.3
    

    四、执行tracert命令

    用tracert命令查看数据包的转发路径,命令的回显信息表明,R2发送的数据经过R1抵达R3设备。
    lof7HU.png

    0X08 配置缺省路由实现网络互通

    一、打开R2中关闭的接口

    [R2]interface GigabitEthernet 0/0/2
    [R2-GigabitEthernet0/0/2]undo shutdown
    

    二、验证R1到10.0.23.3的连通性,发现ping不通。

    [R1]ping 10.0.23.3
    

    三、在R1上配置一条下一跳为10.0.13.3的缺省路由来实现网络的连通。

    [R1]ip route-static 0.0.0.0 0.0.0.0 10.0.13.3
    

    四、再次ping10.0.23.3,发现可以ping通。

    <R1>ping 10.0.23.3
    

    0X09配置备份缺省路由

     当R1与R3间的链路发生故障时,R1可以使用备份缺省路由通过R2实现与10.0.23.3和10.0.3.3网络间通信。 所以配置两条备份路由,确保数据来回的双向都有路由。

    [R1]ip route-static 0.0.0.0 0.0.0.0 10.0.12.2 preference 80
    [R3]ip route-static 10.0.12.0 24 10.0.23.2 preference 80 
    

    0X10验证备份缺省路由

    一、查看链路正常时R1上的路由条目。

    <R1>display ip routing-table 
    

    lW1DJS.png

    二、关闭R1与R3上的G0/0/0接口模拟链路故障,然后查看R1的路由表。

    [R1]interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/0]shutdown
    [R1-GigabitEthernet0/0/0]quit
    [R3]interface GigabitEthernet 0/0/0
    [R3-GigabitEthernet0/0/0]shutdown
    [R3-GigabitEthernet0/0/0]quit
    <R1>display ip routing-table 
    

    lW1Le1.png
    对比发现上述路由表中,缺省路由0.0.0.0的Preference值为80,表明备用的缺省路由已生效。

    三、再次ping10.0.23.3,可以ping通

    <R1>ping 10.0.23.3
    

    四、执行tracert命令

    <R1>tracert 10.0.23.3
    

    lW3kwt.png
    发现当R1与R3之间的链路断了的时候,报文通过R2(10.0.12.2)到达R3(10.0.23.3)

    0x11总结

     小编在这里主要简单介绍了静态路由,备份静态路由,缺省路由,备份缺省路由的配置。因为搭建的拓扑比较简单,只是简单介绍一下基础的原理。可能有些过程比较绕,表达不太清楚,但对着拓扑图稍稍研究下便可以理解。

    本文作者:Sundry-Z
    原文链接:https://sundry-z.github.io/
    版权声明: 转载请注明来自Sundry-Z!

    展开全文
  • 配置静态路由缺省路由

    千次阅读 2019-06-23 10:23:38
    配置静态路由缺省路由 静态路由的配置步骤: 为网络中的每个数据链路确定子网或网络地址。 为每台路由器标识所有非直连的数据链路。 为每台路由器写出关于每个非直连数据链路的路由语句。 作业要求 4. 使用eNSP...
                  配置静态路由和缺省路由
    

    静态路由的配置步骤:

    1. 为网络中的每个数据链路确定子网或网络地址。
    2. 为每台路由器标识所有非直连的数据链路。
    3. 为每台路由器写出关于每个非直连数据链路的路由语句。

    作业要求
    4. 使用eNSP搭建以下拓扑图。
    在这里插入图片描述

    1. 给设备分配IP地址,然后查看直连路由表项

    2. 使用display ip routing-table命令查看路由表
      路由信息中的各字段含义下表所示。

    表6-2 display ip routing-table命令显示信息描述表
    字段 描述
    Destinations 目的地址个数
    Routes 路由条数
    Destination/Mask 目的地址/掩码长度
    Proto 发现该路由的路由协议
    Pre 路由的优先级
    Cost 路由的度量值
    Nexthop 此路由的下一跳地址

    1. 配置静态路由
      R1: 192.168.3.0/24 192.168.4.0/24
      R2: 192.168.1.0/24 192.168.2.0/24
      [R1]ip route-static 192.168.3.0 24 12.0.0.2
      [R1]ip route-static 192.168.4.0 24 12.0.0.2
      [R2]ip route-static 192.168.1.0 24 12.0.0.1
      [R2]ip route-static 192.168.2.0 255.255.255.0 12.0.0.1
      测试:
      PC1> tracert 192.168.4.14

    2. 缺省路由(默认路由)配置与路由环路分析
      1)R2添加3个环回接口用来模拟外网
      [R2]int LoopBack 0
      [R2-LoopBack0]ip add 1.1.1.1 24
      2)在R1上配置缺省路由
      [R1]ip route-static 0.0.0.0 0 12.0.0.2

    3. 配置路由环路 (路由配置错误就会出现路由环路)

    分析环路的时候可以用tracert命令

    一、路由表及其来源
    路由器是通过匹配路由表里的路由项来实现数据包的转发。每个路由器中都保存着一张路由表,表中每条路由项都指明数据到某个网段应通过路由器的哪个物理接口发送,然后就可以到达该路径的下一跳路由器,或者不再经过别的路由器而传送到直接相连的网络中的目的主机。
    路由表的来源主要有如下3种。
    11. 直连路由
    直连路由不需要配置,当接口配置了IP地址并且状态正常时,由路由进程自动生成。它的特点是开销小,配置简单,无须人工维护,但只能发现本路由器接口所属网段的路由。
    12. 手工配置的静态路由
    由管理员手动配置的路由称为静态路由。通过静态路由的配置可建立一个互通的网络,但这种配置的问题在于:当一个网络发生故障后,静态路由不会自动修正,必须有管理员修改配置。静态路由无开销,配置简单,适合简单拓扑结构的网络。
    13. 动态路由协议发现的路由
    当网络拓扑结构十分复杂时,手动配置静态路由的工作量大而且容易出现错误,这时就可以用动态路由协议(如RIP、OSPF等),让其自动发现和修改路由,避免人工维护。但动态路由协议开销大,配置复杂。

    二、路由环路
    路由环路会使数据转发形成死循环,不能到达目的地。
    在这里插入图片描述

    路由环路的主要生成原因是配置了错误的静态路由或网络规划错误。另外,某些动态路由协议在特定环境下或者配置不当,也可能产生环路。

    展开全文
  • 静态路由:手动一条一条写上去的 动态路由:路由器之间动态学习(自动方式) 静态路由配置: ip route <目的ip地址> <目的ip地址掩码> <下一跳地址/接口> 静态路由: 用“下一跳”的方式...
  • 静态路由缺省路由的作用

    千次阅读 2019-05-24 11:42:00
    静态路由作用:减少路由选择...缺省路由作用:是静态路由的一种,也是网络管理员设置的,在没有找到目的网络的路由表项时,路由器将按照缺省路由表发送信息,同时可以极大减少路由表条目。 转载于:https://www.cn...
  • 等价静态路由、浮动静态路由缺省静态路由的配置 等价静态路由 等价静态路由:只有下一跳地址不一样的N条路由。 等价静态路由在路由表中查看时,只显示一条路由但有N个不同下一跳。 等价路由的配置实验:  ...
  • 静态路由缺省路由的基础原理

    千次阅读 2020-01-13 17:19:10
    静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。静态路由一般适用于比较简单的网络环境,在这样的环境中,网络管理员易于清楚地了解网络的拓扑...
  • 将192.168.1.0/24进行合理的IP地址划分,并且尽量减少每台路由器的路由条目数量 减少路由条目数量的方法是子网汇总 二、给每台路由器配置接口IP,并给每台路由器配置两个环回接口 例如: [r2]interface ...
  • 缺省路由是一种特殊的静态路由; 在通信网络中,缺省路由(Default Route)是当 网络主机上 没有特定路由时 而设置的数据包转发规则,可以给出一个默认的下一跳地址,路由表中没有匹配项的所有数据包都通过缺省路由...
  • 配置 静态路由使不同网络的计算机、路由器、交换机之间能相互通信。下面有个网络图: 网络布局R1 fa1/0:12.1.1.1 fa0/0:192.168.100.254 PC1 192.168.100.1R2 fa1/0:12.1.1.2 23.1.1.2 fa0/0:192.168.150.254 fa4/0:...
  • 实验三 静态路由配置和缺省路由配置 一、实验目的 1、掌握静态路由缺省路由配制方法。 二、实验内容 1、配置两台路由器上的静态路由缺省路由、实现网络的互通。 三、实验设备 PC终端一台,cisco packet tracer ...
  • 静态路由 [Huawei]sy R1 修改默认设备名 [R1]dis ip interface brief 查看接口摘要 [R1]int g0/0/0 [R1-GigabitEthernet0/0/0]display this 查看当前所在位置具体配置:比如当下在g0/0/0接口中,...
  • 首先要学习一些ensp模拟器的词语 环回接口的配置 [r4]...静态路由的写法 [r1]ip route-static 缺省路由的配置 [r2]ip route-static 0.0.0.0 0 192.168.3.2 空接口路由的配置 [r2]ip route-static 1.1.0.0 22 ...
  • eNSP:静态路由中的缺省路由

    千次阅读 2020-11-05 21:10:21
    方法: ip route-static 0.0.0.0(目标地址) 0.0.0.0(目标子网掩码) 下一跳IP 用 0.0.0.0 代表目标地址,0.0.0.0 代表子网掩码,缺省路由的优先级比静态路由的优先级低,在访问其他主机时,会先在路由表中寻找目的...
  • 1. 首先对其进行子网划分 如下图 2. 构建好模型,标上相应的角标,如下图 ...然后配置缺省路由:也是ip route-static 0.0.0.0 0 ............ 如下图(由于没有黑洞路由,因此第六步空接口路由不需要) ...
  • 路由(routing)的定义是指分组从源到目的地时,决定端到端路径的网络范围的进程。在OSI七层模型下,路由主要进行在第三次网络层:通过寻址来建立两个节点之间的连接,为源端的运输层送来... 静态路由:管理员手工定义
  • 静态路由缺省路由的配置 这里我们用的模拟器是GNS3(一款功能十分强大的模拟器),用Cisco Packet Tracer模拟器也是可以的 目的:使各路由器之间相互连通 绘制拓扑图 配置好直连路由,给路由器各个端口...
  • #静态路由配置命令:ip route命令 # r(config)#ip route dest_net_id dest_net_mask next_hop_ip #缺省路由配置命令:目的网络id和掩码均为0.0.0.0 # r(config)#ip route 0.0.0.0 0.0.0.0 next_hop...
  • 1. 掌握静态路由协议的作用和使用范围 2. 掌握配置静态路由协议的过程实验内容及原理 3. 掌握静态路由协议的作用和使用范围 4. 掌握配置静态路由协议的过程
  • 了解如何配置静态路由: 静态路由器扩展配置: 1、负载均衡 --- 当路由器到达同一个目标,具有多条开销相似路径时,可以让设备将流量拆分后延多条路径同时传输; 2、环回接口 PC的环回网卡 --- 127.0.0.1 pc...
  • 本文将详细介绍RIP缺省静态路由的重发布,需要了解更多的朋友可以参考下
  • 文章目录软件说明静态路由基础实验2个设备直连三个设备直连静态缺省路由实验生产环境的缺省地址配置静态路由备份实验 软件说明 这个需要使用EVE软件来做实验,我博客的“网络“分类中已经发布了EVE的安装方法...
  • 在Packet Tracer 思科模拟器中,进行默认路由器和静态路由的相关配置,在三层路由实现不同vlan间的通信的基础之上,测试多台pc机的连通性。
  • 怎么设置单臂路由静态路由和优先路线
  • 3、R1-R4上不能直接编写到达5.5.5.0/24的静态路由,但依然可以访问。 4、全网可达,尽量减少每台路由器,路由表条目数量,避免环路岀现。 5、R4R5间,正常1000M链路通信,故障时自动改为100M。 ​​ 解题步骤: 1、数...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 17,671
精华内容 7,068
关键字:

静态路由与缺省路由