精华内容
下载资源
问答
  • bgp的基本配置实验,基于华为模拟器ensp进行的ibgp和ebgp的综合实验,以及对于bgp的路由选路进行分析,抓包看bgp的四种报文类型。
  • BGP实验详解

    2017-09-26 15:07:33
    BGP实验操作,适用于cisco平台;包括BGP(IBGP/EBGP)邻居建立,同步,通告原则,属性等原理与配置。BGP实验操作,适用于cisco平台;包括BGP(IBGP/EBGP)邻居建立,同步,通告原则,属性等原理与配置。
  • BGP实验(1)- eBGP

    2018-03-09 16:39:53
    (1)分别按照实验拓扑的标识配置好各个路由器及其对应的BGP AS R4(config)#router bgp 65004 1、启用不自动汇总功能。 R4(config-router)#no auto-summary 2、分别把Loopback接口按实验拓扑的标识通告到各自的AS内...
  • CCNP 课件 BGP实验.pdf

    2019-07-18 17:34:30
    CCNP 课件 BGP实验.pdf
  • BGP实验

    2020-12-31 23:22:53
    --------------------本文华为模拟BGP实验,仅供学习参考------------------------- 解题思路:IP规划 > 启动OSPF、BGP建邻 > MPLS 一、IP规划 172.15.0.0/16 172.16.0.0/16 172.17.0.0/24 172.18.0.0...

    --------------------本文华为模拟BGP实验, 仅供学习参考-------------------------

    解题思路:IP规划 > 启动OSPF、BGP建邻 > MPLS

    一、IP规划

    172.15.0.0/16

    172.16.0.0/16

    172.17.0.0/24

    172.18.0.0/24

     

    [r1]int loopback 0

    [r1-LoopBack0]ip add 172.15.1.1 24

    [r1-LoopBack0]int g0/0/0

    [r1-GigabitEthernet0/0/0]ip add 172.15.0.6 30

    [r1-GigabitEthernet0/0/0]int g0/0/1

    [r1-GigabitEthernet0/0/1]ip add 172.15.0.1 30

    [r1]ospf 1 router-id 1.1.1.1

    [r1-ospf-1]area 0

    [r1-ospf-1-area-0.0.0.0]network 172.15.0.0 0.0.255.255

     

    [r2]ospf 1 router-id 2.2.2.2

    [r2-ospf-1]area 0

    [r2-ospf-1-area-0.0.0.0]network 172.15.0.0 0.0.255.255

     

    [r3]ospf 1 router-id 3.3.3.3

    [r3-ospf-1]area 0

    [r3-ospf-1-area-0.0.0.0]network 172.15.0.0 0.0.255.255

     

    [r4]ospf 1 router-id 4.4.4.4

    [r4-ospf-1]area 0

    [r4-ospf-1-area-0.0.0.0]network 172.16.0.0 0.0.255.255

    [r4]int g0/0/0

    [r4-GigabitEthernet0/0/0]ip add 24.1.1.2 30

    [r4-GigabitEthernet0/0/0]int g0/0/1

    [r4-GigabitEthernet0/0/1]ip add 172.16.0.1 30

    [r4]int g0/0/2

    [r4-GigabitEthernet0/0/2]ip add 172.16.0.5 30

    [r4]int loopback 0

    [r4-LoopBack0]ip add 172.16.4.1 24

     

    [r5]ospf 1 router-id 5.5.5.5

    [r5-ospf-1]area 0

    [r5-ospf-1-area-0.0.0.0]network 172.16.0.0 0.0.255.255

    [r5]int g0/0/1

    [r5-GigabitEthernet0/0/1]ip add 172.16.0.9 30

    [r5-GigabitEthernet0/0/1]int g0/0/0

    [r5-GigabitEthernet0/0/0]ip add 35.1.1.2 30

    [r5-GigabitEthernet0/0/0]int g0/0/2

    [r5-GigabitEthernet0/0/2]ip add 172.16.0.6 30

     

    [r6]ospf 1 router-id 6.6.6.6

    [r6-ospf-1]area 0

    [r6-ospf-1-area-0.0.0.0]network 172.16.0.2 0.0.0.0

    [r6-ospf-1-area-0.0.0.0]network 172.16.6.1 0.0.0.0

    [r6-ospf-1-area-0.0.0.0]area 1

    [r6-ospf-1-area-0.0.0.1]network 172.16.12.1 0.0.0.0

    [r6-ospf-1-area-0.0.0.1]int loopback 0

    [r6-LoopBack0]ip add 172.16.6.1 24

    [r6-LoopBack0]int g0/0/0

    [r6-GigabitEthernet0/0/0]ip add 172.16.0.2 30

    [r6-GigabitEthernet0/0/0]int g0/0/1

    [r6-GigabitEthernet0/0/1]ip add 172.16.12.1 30

    [r6]int g0/0/2

    [r6-GigabitEthernet0/0/2]ip add 172.16.12.21 30

     

    [r7]ospf 1 router-id 7.7.7.7

    [r7-ospf-1]area 0

    [r7-ospf-1-area-0.0.0.0]network 172.16.0.10 0.0.0.0

    [r7-ospf-1-area-0.0.0.0]network 172.16.7.1 0.0.0.0

    [r7-ospf-1-area-0.0.0.0]area 1

    [r7-ospf-1-area-0.0.0.1]network 172.16.12.9 0.0.0.0

    [r7-ospf-1-area-0.0.0.1]int loopback 0

    [r7-LoopBack0]ip add 172.16.7.1 24

    [r7-LoopBack0]int g0/0/1

    [r7-GigabitEthernet0/0/1]ip add 172.16.0.10 30

    [r7-GigabitEthernet0/0/1]int g0/0/0

    [r7-GigabitEthernet0/0/0]ip add 172.16.12.9 30

    [r7-GigabitEthernet0/0/0]int g0/0/2

    [r7-GigabitEthernet0/0/2]ip add 172.16.12.22 30

     

    [r8]ospf 1 router-id 8.8.8.8

    [r8-ospf-1]area 1

    [r8-ospf-1-area-0.0.0.1]network 172.16.0.0 0.0.255.255

    [r8]int g0/0/0

    [r8-GigabitEthernet0/0/0]ip add 172.16.12.2 30

    [r8-GigabitEthernet0/0/0]int g0/0/1

    [r8-GigabitEthernet0/0/1]ip add 172.16.12.5 30

     

    [r9]ospf 1 router-id 9.9.9.9

    [r9-ospf-1]area 1

    [r9-ospf-1-area-0.0.0.1]network 172.16.0.0 0.0.255.255

    [r9]int g0/0/1

    [r9-GigabitEthernet0/0/1]ip add 172.16.12.10 30

    [r9]int g0/0/0

    [r9-GigabitEthernet0/0/0]ip add 172.16.12.13 30

     

    [r10]ospf 1 router-id 10.10.10.10

    [r10-ospf-1]area 1

    [r10-ospf-1-area-0.0.0.1]network 172.16.10.1 0.0.0.0

    [r10-ospf-1-area-0.0.0.1]network 172.16.12.6 0.0.0.0

    [r10]ospf 2

    [r10-ospf-2]area 2

    [r10-ospf-2-area-0.0.0.2]network 172.16.16.1 0.0.0.0

    [r10-ospf-1-area-0.0.0.2]int loopback 0

    [r10-LoopBack0]ip add 172.16.10.1 24

    [r10-LoopBack0]int g0/0/0

    [r10-GigabitEthernet0/0/0]ip add 172.16.12.6 30

    [r10-GigabitEthernet0/0/0]int g0/0/1

    [r10-GigabitEthernet0/0/1]ip add 172.16.16.1 30

     

    [r11]int g0/0/0

    [r11-GigabitEthernet0/0/0]ip add 172.16.12.14 30

    [r11-GigabitEthernet0/0/0]int loopback 0

    [r11-LoopBack0]ip add 172.16.11.1 24

    [r11-LoopBack0]int g0/0/1

    [r11-GigabitEthernet0/0/1]ip add 172.16.16.9 30

    [r11]ospf 1 router-id 11.11.11.11

    [r11-ospf-1]area 1

    [r11-ospf-1-area-0.0.0.1]network 172.16.11.1 0.0.0.0

    [r11-ospf-1-area-0.0.0.1]network 172.16.12.14 0.0.0.0

    [r11-ospf-1-area-0.0.0.1]q

    [r11-ospf-1]q

    [r11]ospf 2

    [r11-ospf-2]area 2

    [r11-ospf-2-area-0.0.0.2]network 172.16.16.9 0.0.0.0

     

    [r12]ospf 1 router-id 12.12.12.12

    [r12-ospf-1]area 2

    [r12-ospf-1-area-0.0.0.2]network 172.16.0.0 0.0.255.255

    [r12]int g0/0/0

    [r12-GigabitEthernet0/0/0]ip add 172.16.16.2 30

    [r12-GigabitEthernet0/0/0]int g0/0/2

    [r12-GigabitEthernet0/0/2]ip add 124.1.1.1 24

    [r12]int loopback 0

    [r12-LoopBack0]ip add 172.16.17.1 30

    [r12]int g0/0/1

    [r12-GigabitEthernet0/0/1]ip add 172.16.16.5 30

     

    [r13]ospf 1 router-id 13.13.13.13

    [r13-ospf-1]area 2

    [r13-ospf-1-area-0.0.0.2]network 172.16.0.0 0.0.255.255

    [r13]int g0/0/0

    [r13-GigabitEthernet0/0/0]ip add 172.16.16.10 30

    [r13]int g0/0/2

    [r13-GigabitEthernet0/0/2]ip add 134.1.1.1 30

    [r13]int g0/0/1

    [r13-GigabitEthernet0/0/1]ip add 172.16.16.6 30

     

    [r14]int g0/0/1

    [r14-GigabitEthernet0/0/1]ip add 134.1.1.2 30

    # 查看邻居关系,和多个进程

     

     

     

     

    #dis ospf routing r12的路由表

    ----------------------------------------------------------------

    #R10\R11上做双向重发布

    [r10]ospf 1

    [r10-ospf-1]import-route ospf 2

    [r10-ospf-1]ospf 2

    [r10-ospf-2]import-route ospf 1

     

    [r11]ospf 1

    [r11-ospf-1]import-route ospf 2

    [r11-ospf-1]ospf 2

    [r11-ospf-2]import-route ospf 1

    #查看R12 R13的环回是否收到,在R4上看(dis ospf routing)

    [r4]ping 172.16.18.1 可以访问

     

    #dis ospf routing r12学习到了3条

     

    以下是R13

     

    以下是R4 R5 路由表是一样的

     

     

     

    #r10上把区域0、1的T各汇总一条路由一条给区域2,把R12

    #三个区域都是一条一条互传的

    #进入到R6,把区域0给区域1,把区域1给区域0

    #维汇总维做空口

    [r6]ip route-static 172.16.0.0 21 null

    [r6]ip route-static 172.16.8.0 21 null

    [r7]ip route-static 172.16.0.0 21 null

    [r7]ip route-static 172.16.8.0 21 null

    [r10]ip route-static 172.16.8.0 21 null

    [r10]ip route-static 172.16.16.0 255.255.248.0 null 0 #域外的

    [r11]ip route-static 172.16.8.0 255.255.248.0 null 0

    [r11]ip route-static 172.16.16.0 255.255.248.0 null 0

    #r8 查看是否有R9的一类

    #dis ospf lsdb

    #r8 ping 172.168.9.1 是访问不了的

    [r6]ospf 1

    [r6-ospf-1]network 172.16.12.21 0.0.0.0

    [r7-ospf-1-area-0.0.0.1]network 172.16.12.22 0.0.0.0

    #在R10上查看,7 9 10都来了

    启BGP,必面MPLS,否则无法钻出黑洞。

    [r1]bgp 1

    [r1-bgp]route-select

    [r1-bgp]router-id 1.1.1.1

    [r1-bgp]peer 172.15.2.1 as-number 1

    [r1-bgp]peer 172.15.2.1 connect-interface loopback 0

    [r1-bgp]peer 172.15.3.1 as-number 1

    [r1-bgp]peer 172.15.3.1 connect-interface loopback 0

     

    [r2]bgp 1

    [r2-bgp]route-select

    [r2-bgp]router-id 2.2.2.2

    [r2-bgp]peer 172.15.1.1 as-number 1

    [r2-bgp]peer 172.15.1.1 connect-interface loopback 0

    [r2-bgp] peer 172.15.3.1 as-number 1

    [r2-bgp]peer 172.15.3.1 connect-interface loopback 0

    [r2-bgp] peer 24.1.1.2 as-number 2

     

    [r3]bgp 1

    [r3-bgp]route-select

    [r3-bgp]router-id 3.3.3.3

    [r3-bgp]peer 172.15.1.1 as-number 1

    [r3-bgp]peer 172.15.1.1 connect-interface loopback 0

    [r3-bgp] peer 172.15.2.1 as-number 1

    [r3-bgp]peer 172.15.2.1 connect-interface loopback 0

    [r3-bgp] peer 35.1.1.2 as-number 2

    #dis bgp peer 查看R1 R2 R3邻居关系 正常

     

    [R4]bgp 2

    [r4-bgp]route-select

    [r4-bgp]router-id 4.4.4.4

    [r4-bgp]peer 24.1.1.1 as-number 1

    [r4-bgp]peer 172.16.5.1 as-number 2

    [r4-bgp]peer 172.16.5.1 connect-interface loopback 0

    [r4-bgp]peer 172.16.9.1 as-number 2

    [r4-bgp]peer 172.16.9.1 connect-interface loopback 0

    [r4-bgp]peer 172.16.17.1 as-number 2

    [r4-bgp]peer 172.16.17.1 connect-interface loopback 0

     

    [R5]bgp 2

    [r5-bgp]route-select

    [r5-bgp]router-id 5.5.5.5

    [r5-bgp]peer 35.1.1.1 as-number 1

    [r5-bgp]peer 172.16.4.1 as-number 2

    [r5-bgp]peer 172.16.4.1 connect-interface loopback 0

    [r5-bgp]peer 172.16.9.1 as-number 2

    [r5-bgp]peer 172.16.9.1 connect-interface loopback 0

     

    [R9]bgp 2

    [r9-bgp]route-select

    [r9-bgp]router-id 4.4.4.4

    [r9-bgp]peer 172.16.4.1 as-number 2

    [r9-bgp]peer 172.16.4.1 connect-interface loopback 0

    [r9-bgp]peer 172.16.5.1 as-number 2

    [r9-bgp]peer 172.16.5.1 connect-interface loopback 0

    [r9-bgp]peer 172.16.17.1 as-number 2

    [r9-bgp]peer 172.16.17.1 connect-interface loopback 0

    [r9-bgp]peer 172.16.18.1 as-number 2

    [r9-bgp]peer 172.16.18.1 connect-interface loopback 0

    [r9-bgp]peer 95.1.1.2 as-number 4

     

    [r12]bgp 2

    [r12-bgp]route-select

    [r12-bgp]router-id 12.12.12.12

    [r12-bgp]peer 172.16.4.1 as-number 2

    [r12-bgp]peer 172.16.4.1 connect-interface loopback 0

    [r12-bgp]peer 172.16.9.1 as-number 2

    [r12-bgp]peer 172.16.9.1 connect-interface loopback 0

    [r12-bgp]peer 172.16.18.1 as-number 2

    [r12-bgp]peer 172.16.18.1 connect-interface loopback 0

    [r12-bgp]peer 124.1.1.2 as-number 3

     

    [r13-bgp]route-select

    [r13-bgp]router-id 13.13.13.13

    [r13-bgp]peer 172.16.17.1 as-number 2

    [r13-bgp]peer 172.16.17.1 connect-interface loopback 0

    [r13-bgp]peer 172.16.9.1 as-number 2

    [r13-bgp]peer 172.16.9.1 connect-interface loopback 0

    [r13-bgp]peer 134.1.1.2 as-number 3

     

    [r14]bgp 3

    [r14-bgp]route-select

    [r14-bgp]router-id 14.14.14.14

    [r14-bgp]peer 124.1.1.1 as-number 2

    [r14-bgp]peer 134.1.1.2 as-number 3

    [r14-bgp]network 172.17.0.0 24

     

    [r15]bgp 4

    [r15-bgp]route-select

    [r15-bgp]router-id 15.15.15.15

    [r15-bgp]peer 95.1.1.1 as-number 2

    [r15-bgp]network 172.18.0.0 24

    #查看AS2 中的邻接关系

    #dis bgp peer

     

     

     

     

     

    验证成功

    --------------------------------------

    所有设备互访

    在R3上把所有S1汇成一条发过去

    [R3]ip route-static 172.15.0.0 22 null 0

    [r3]bgp 1

    [r3-bgp]network 172.15.0.0 22

     

    [R2]ip route-static 172.15.0.0 22 null 0

    [r2]bgp 1

    [r2-bgp]network 172.15.0.0 22

    #验证测试 上面走上面那条路,下面走下面那条路

     

    #R2 R3到R9的路不优,因此改下一跳

    [r2]bgp 1

    [r2] peer 172.15.1.1 next-hop-invariable

    [r2] peer 172.15.1.1 next-hop-local

     

    [r3]bgp 1

    [r3] peer 172.15.1.1 next-hop-invariable

    [r3] peer 172.15.1.1 next-hop-local

     

    [r4]bgp 2

    [r4] peer 172.16.9.1 next-hop-invariable

    [r4] peer 172.16.9.1 next-hop-local

    [r4] peer 172.16.5.1 next-hop-invariable

    [r4] peer 172.16.5.1 next-hop-local

    [r4] peer 172.16.17.1 next-hop-invariable

    [r4] peer 172.16.17.1 next-hop-local

     

    [r5]bgp 2

    [r5] peer 172.16.9.1 next-hop-invariable

    [r5] peer 172.16.9.1 next-hop-local

    [r5] peer 172.16.4.1 next-hop-invariable

    [r5] peer 172.16.4.1 next-hop-local

     

    [r9] peer 172.16.4.1 next-hop-invariable

    [r9] peer 172.16.4.1 next-hop-local

    [r9] peer 172.16.5.1 next-hop-invariable

    [r9] peer 172.16.5.1 next-hop-local

    [r9] peer 172.16.17.1 next-hop-invariable

    [r9] peer 172.16.17.1 next-hop-local

    [r9] peer 172.16.18.1 next-hop-invariable

    [r9] peer 172.16.18.1 next-hop-local

    #r9把路由反射给R12 R13

    [r9]bgp 2

    [r9-bgp] peer 172.16.4.1 reflect-client

    [r9-bgp] peer 172.16.5.1 reflect-client

    [r9-bgp] peer 172.16.17.1 reflect-client

     

    把R9表上的第二条优先级改101,优R5到R9优。

    [r9] ip ip-prefix a permit 172.15.0.0 22

    [r9]route-policy a permit node 10

    #un route-policy a

    [r9-route-policy]if-match ip-prefix a

    #[r9-route-match]apply local-preference 101

    [r9-route-policy]apply preferred-value 1 #修改全重值,全重不传播

    [r9-route-policy]q

    [r9]route-policy a permit node 20

    [r9]bgp 2

    [r9-bgp] peer 172.16.5.1 route-policy a import #入方向

    #dis bgp routing-table

    [r12]bgp 2

    [r12-bgp] peer 172.16.9.1 next-hop-invariable

    [r12-bgp] peer 172.16.9.1 next-hop-local

    [r12-bgp] peer 172.16.4.1 next-hop-invariable

    [r12-bgp] peer 172.16.4.1 next-hop-local

     

    [r13]bgp 2

    [r13-bgp] peer 172.16.9.1 next-hop-invariable

    [r13-bgp] peer 172.16.9.1 next-hop-local

     

    [r9] ip ip-prefix b permit 172.17.0.0 24

    [r9]route-policy b permit node 10

    [r9-route-policy]if-match ip-prefix b

    [r9-route-policy]apply preferred-value 1

    [r9-route-policy]q

    [r9]route-policy-change

    [r9]route-policy b permit node 20

    [r9-route-policy]bgp 2

    [r9-bgp] peer 172.16.18.1 route-policy b import

     

     

     

     

    三、启mpls

    [r4]mpls lsr-id 172.16.4.1

    [r4]mpls

    [r4]mpls ldp

    [r4-mpls-ldp]int g0/0/1

    [r4-gigabitethernet0/0/1]mpls

    [r4-gigabitethernet0/0/1]mpls ldp

    [r4-gigabitethernet0/0/1]int g0/0/2

    [r4-gigabitethernet0/0/2]mpls

    [r4-gigabitethernet0/0/2]mpls ldp

    [r4]mpls

    [r4-mpls]lsp-trigger all

     

    [r5]mpls lsr-id 172.16.5.1

    [r5]mpls

    [r5]mpls ldp

    [r5-mpls-ldp]int g0/0/0

    [r5-gigabitethernet0/0/0]mpls

    [r5-gigabitethernet0/0/0]mpls ldp

    [r5-gigabitethernet0/0/0]int g0/0/2

    [r5-gigabitethernet0/0/2]mpls

    [r5-gigabitethernet0/0/2]mpls ldp

    [r5]mpls

    [r5-mpls]lsp-trigger all

     

    [r6]mpls lsr-id 172.16.6.1

    [r6]mpls

    [r6]mpls ldp

    [r6-mpls-ldp]int g0/0/0

    [r6-gigabitethernet0/0/0]mpls

    [r6-gigabitethernet0/0/0]mpls ldp

    [r6-gigabitethernet0/0/0]int g0/0/1

    [r6-gigabitethernet0/0/1]mpls

    [r6-gigabitethernet0/0/1]mpls ldp

    [r6-gigabitethernet0/0/1]int g0/0/2

    [r6-gigabitethernet0/0/2]mpls

    [r6-gigabitethernet0/0/2]mpls ldp

    [r6]mpls

    [r6-mpls]lsp-trigger all

     

    [r7]mpls lsr-id 172.16.7.1

    [r7]mpls

    [r7]mpls ldp

    [r7-mpls-ldp]int g0/0/0

    [r7-gigabitethernet0/0/0]mpls

    [r7-gigabitethernet0/0/0]mpls ldp

    [r7-gigabitethernet0/0/0]int g0/0/1

    [r7-gigabitethernet0/0/1]mpls

    [r7-gigabitethernet0/0/1]mpls ldp

    [r7-gigabitethernet0/0/1]int g0/0/2

    [r7-gigabitethernet0/0/2]mpls

    [r7-gigabitethernet0/0/2]mpls ldp

    [r7]mpls

    [r7-mpls]lsp-trigger all

     

    [r8]mpls lsr-id 172.16.8.1

    [r8]mpls

    [r8]mpls ldp

    [r8-mpls-ldp]int g0/0/0

    [r8-gigabitethernet0/0/0]mpls

    [r8-gigabitethernet0/0/0]mpls ldp

    [r8-gigabitethernet0/0/0]int g0/0/1

    [r8-gigabitethernet0/0/1]mpls

    [r8-gigabitethernet0/0/1]mpls ldp

    [r8]mpls

    [r8-mpls]lsp-trigger all

     

    [r9]mpls lsr-id 172.16.9.1

    [r9]mpls

    [r9]mpls ldp

    [r9-mpls-ldp]int g0/0/0

    [r9-gigabitethernet0/0/0]mpls

    [r9-gigabitethernet0/0/0]mpls ldp

    [r9-gigabitethernet0/0/0]int g0/0/1

    [r9-gigabitethernet0/0/1]mpls

    [r9-gigabitethernet0/0/1]mpls ldp

    [r9]mpls

    [r9-mpls]lsp-trigger all

     

    [r10]mpls lsr-id 172.16.10.1

    [r10]mpls

    [r10]mpls ldp

    [r10-mpls-ldp]int g0/0/0

    [r10-gigabitethernet0/0/0]mpls

    [r10-gigabitethernet0/0/0]mpls ldp

    [r10-gigabitethernet0/0/0]int g0/0/1

    [r10-gigabitethernet0/0/1]mpls

    [r10-gigabitethernet0/0/1]mpls ldp

    [r10]mpls

    [r10-mpls]lsp-trigger all

     

    [r11]mpls lsr-id 172.16.11.1

    [r11]mpls

    [r11]mpls ldp

    [r11-mpls-ldp]int g0/0/0

    [r11-gigabitethernet0/0/0]mpls

    [r11-gigabitethernet0/0/0]mpls ldp

    [r11-gigabitethernet0/0/0]int g0/0/1

    [r11-gigabitethernet0/0/1]mpls

    [r11-gigabitethernet0/0/1]mpls ldp

    [r11]mpls

    [r11-mpls]lsp-trigger all

     

    [r12]mpls lsr-id 172.16.17.1

    [r12]mpls

    [r12]mpls ldp

    [r12-mpls-ldp]int g0/0/0

    [r12-gigabitethernet0/0/0]mpls

    [r12-gigabitethernet0/0/0]mpls ldp

    [r12-gigabitethernet0/0/0]int g0/0/2

    [r12-gigabitethernet0/0/2]mpls

    [r12-gigabitethernet0/0/2]mpls ldp

    [r12]mpls

    [r12-mpls]lsp-trigger all

     

    [r13]mpls lsr-id 172.16.18.1

    [r13]mpls

    [r13]mpls ldp

    [r13-mpls-ldp]int g0/0/1

    [r13-gigabitethernet0/0/1]mpls

    [r13-gigabitethernet0/0/1]mpls ldp

    [r13-gigabitethernet0/0/1]int g0/0/2

    [r13-gigabitethernet0/0/2]mpls

    [r13-gigabitethernet0/0/2]mpls ldp

    [r13]mpls

    [r13-mpls]lsp-trigger all

    #查看邻居关系

     

    [r4]route recursive-lookup tunnel

    [r5]route recursive-lookup tunnel

    [r12]route recursive-lookup tunnel

    [r13]route recursive-lookup tunnel

    [r9]route recursive-lookup tunnel

    #dis mpls ldb

    R14到R15的路由选路有2条,经过R12 R13,想办法让经过R13,让12参数加1

    [r12] ip ip-prefix w permit 172.18.0.0 24

    [r12]route-policy w permit node 10

    [r12-route-policy]if-match ip-prefix w

    [r12-route-policy]apply cost 1 #修改权重属性,加1

    [r12-route-policy]q

    [r12]route-policy w permit node 20 #空表

    [r12-route-policy]q

    [r12] bpg 2

    [r12-bgp] peer 124.1.1.2 route-policy w export

    [r12] dis ip ip-prefix

    同理,R1 R2 R3之间的选路

    IBGP选路

    [r3] ip ip-prefix w permit 172.18.0.0 24

    [r3]route-policy w permit node 10

    [r3-route-policy]if-match ip-prefix w

    [r3-route-policy]apply local-preference 101 #默认100

    [r3-route-policy]q

    [r3]route-policy w permit node 20 #空表

    [r3-route-policy]q

    [r3] bpg 1

    [r3-bgp] peer 172.15.1.1 route-policy w export

    s1 s3 s4选路好了

    s1 s3 s4学习到s2里面的路由

    [r9]ip route-static 172.16.0.0 19 null 0

    [r9]ip route-static 172.16.0.0 20 null 0

    [r9]bgp 2

    [r9-bgp]network 172.16.0.0 19 #做汇总

    [r12]ip route-static 172.16.0.0 20 null 0

    [r12]ip route-static 172.16.0.0 19 null 0

    [r13]ip route-static 172.16.0.0 20 null 0

    [r13]ip route-static 172.16.0.0 19 null 0

    [r13]bgp 2

    [r13-bgp]network 172.16.5.1 32

    [r13-bgp]network 172.16.7.1 32

    [r13-bgp]network 172.16.9.1 32

    [r13-bgp]network 172.16.11.1 32

    [r13-bgp]network 172.16.18.1 32

    [r13-bgp]network 172.16.18.1 24

     

    #谁宣告,不走谁,路径走的是R13

     

    [r12]bgp 2

    [r12-bgp]network 172.16.5.1 32

    [r12-bgp]network 172.16.7.1 32

    [r12-bgp]network 172.16.9.1 32

    [r12-bgp]network 172.16.11.1 32

    [r12-bgp]network 172.16.18.1 255.255.255.255

     

    [r4]bgp 2

    [r4-bgp]network 172.16.5.1 32

    [r4-bgp]network 172.16.7.1 32

    [r4-bgp]network 172.16.9.1 32

    [r4-bgp]network 172.16.11.1 32

    [r4-bgp]network 172.16.18.1 255.255.255.255

    [r4]ip route-static 172.16.0.0 20 null 0

    [r4]ip route-static 172.16.0.0 19 null 0

     

    [r5]ip route-static 172.16.0.0 20 null 0

    #S2中间没运行BGP的路由不能访问域外路由,但域外路由可以访问它们。如何实现互访?

    [r5-ospf-1]default-route-advertise always #强制

    [r13-ospf-1]default-route-advertise always #强制

    [r4-ospf-1]default-route-advertise always #强制

    [r12-ospf-1]default-route-advertise always #强制

     

    展开全文
  • BGP实验配置实例

    2021-03-29 10:48:18
    BGP实验一、基本配置命令二、题目需求三、配置R1R2R3R4R5结果 一、基本配置命令 二、题目需求 按照拓扑图要求完成实验,在AS200内运行OSPF协议,要求实现1.1.1.1可以访问5.5.5.5 三、配置 R1 R2 R3 R4 R5 结果 ...

    一、基本配置命令

    二、题目需求

    在这里插入图片描述
    按照拓扑图要求完成实验,在AS200内运行OSPF协议,要求实现1.1.1.1可以访问5.5.5.5

    三、配置

    R1

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sys R1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 12.1.1.1 24
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 13.1.1.1 24
    [R1-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R1-GigabitEthernet0/0/1]int loo 0
    [R1-LoopBack0]ip add 1.1.1.1 32
    [R1-LoopBack0]q 
    [R1]ip route-static 2.2.2.2 32 12.1.1.2 
    [R1]ip route-static 3.3.3.3 32 13.1.1.3
    [R1]

    配置BGP

    [R1]bgp 100 
    [R1-bgp]router-id 1.1.1.1 
    [R1-bgp]peer 2.2.2.2 as-number 200 
    [R1-bgp]peer 3.3.3.3 as-number 200 
    [R1-bgp]peer 2.2.2.2 connect-interface LoopBack 0 
    [R1-bgp]peer 3.3.3.3 connect-interface LoopBack 0 
    [R1-bgp]peer 2.2.2.2 ebgp-max-hop 2 
    [R1-bgp]peer 3.3.3.3 ebgp-max-hop 2
    [R1-bgp]net 1.1.1.1 255.255.255.255
    [R1-bgp]net 2.2.2.2 255.255.255.255
    [R1-bgp]net 3.3.3.3 255.255.255.255
    [R1-bgp]

    R2

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sys R2
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.1.1.2 24
    [R2-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 24.1.1.2 24
    [R2-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R2-GigabitEthernet0/0/1]int loo 0
    [R2-LoopBack0]ip add 2.2.2.2 32
    [R2-LoopBack0]q 
    [R2]ip route-static 1.1.1.1 32 12.1.1.1
    [R2]ospf
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]net 2.2.2.2 0.0.0.0
    [R2-ospf-1-area-0.0.0.0]net 24.1.1.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]

    配置BGP

    [R2]bgp 200 
    [R2-bgp]router-id 2.2.2.2 
    [R2-bgp]peer 1.1.1.1 as-number 100 
    [R2-bgp]peer 1.1.1.1 connect-interface LoopBack 0 
    [R2-bgp]peer 1.1.1.1 ebgp-max-hop 2 
    [R2-bgp]peer 3.3.3.3 as-number 200 
    [R2-bgp]peer 4.4.4.4 as-number 200 
    [R2-bgp]peer 3.3.3.3 connect-interface LoopBack 0 
    [R2-bgp]peer 4.4.4.4 connect-interface LoopBack 0 
    [R2-bgp]peer 3.3.3.3 next-hop-local  
    [R2-bgp]peer 4.4.4.4 next-hop-local 
    [R2-bgp]net 1.1.1.1 255.255.255.255
    [R2-bgp]net 2.2.2.2 255.255.255.255
    [R2-bgp]net 3.3.3.3 255.255.255.255
    [R2-bgp]net 4.4.4.4 255.255.255.255
    [R2-bgp]

    R3

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sys R3
    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip add 34.1.1.3 24
    [R3-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R3-GigabitEthernet0/0/0]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 13.1.1.3 24
    [R3-GigabitEthernet0/0/1]un sh 
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R3-GigabitEthernet0/0/1]int loo 0
    [R3-LoopBack0]ip add 3.3.3.3 32
    [R3-LoopBack0]q 
    [R3]ip route-static 1.1.1.1 32 13.1.1.1
    [R3]
    [R3]ospf
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]net 3.3.3.3 0.0.0.0
    [R3-ospf-1-area-0.0.0.0]net 34.1.1.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]

    配置BGP

    [R3]bgp 200 
    [R3-bgp]router-id 3.3.3.3 
    [R3-bgp]peer 1.1.1.1 as-number 100 
    [R3-bgp]peer 1.1.1.1 connect-interface LoopBack 0 
    [R3-bgp]peer 1.1.1.1 ebgp-max-hop 2 
    [R3-bgp]peer 4.4.4.4 as-number 200 
    [R3-bgp]peer 2.2.2.2 as-number 200 
    [R3-bgp]peer 4.4.4.4 connect-interface LoopBack 0 
    [R3-bgp]peer 2.2.2.2 connect-interface LoopBack 0 
    [R3-bgp]peer 4.4.4.4 next-hop-local  
    [R3-bgp]peer 2.2.2.2 next-hop-local 
    [R3-bgp]net 1.1.1.1 255.255.255.255
    [R3-bgp]net 2.2.2.2 255.255.255.255
    [R3-bgp]net 3.3.3.3 255.255.255.255
    [R3-bgp]net 4.4.4.4 255.255.255.255
    [R3-bgp]

    R4

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en 
    Info: Information center is disabled.
    [Huawei]sys R4
    [R4]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip add 34.1.1.4 24
    [R4-GigabitEthernet0/0/0]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip add 24.1.1.4 24
    [R4-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R4-GigabitEthernet0/0/1]int g0/0/2
    [R4-GigabitEthernet0/0/2]ip add 45.1.1.4 24
    [R4-GigabitEthernet0/0/2]int loo 0
    [R4-LoopBack0]ip add 4.4.4.4 32
    [R4-LoopBack0]q 
    [R4]ip route-static 5.5.5.5 32 45.1.1.5
    [R4]
    [R4]ospf
    [R4-ospf-1]area 0
    [R4-ospf-1-area-0.0.0.0]net 4.4.4.4 0.0.0.0
    [R4-ospf-1-area-0.0.0.0]net 24.1.1.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.0]net 34.1.1.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.0]

    配置BGP

    [R4]bgp 200 
    [R4-bgp]router-id 4.4.4.4 
    [R4-bgp]peer 5.5.5.5 as-number 300 
    [R4-bgp]peer 5.5.5.5 connect-interface LoopBack 0 
    [R4-bgp]peer 5.5.5.5 ebgp-max-hop 2 
    [R4-bgp]peer 3.3.3.3 as-number 200 
    [R4-bgp]peer 2.2.2.2 as-number 200 
    [R4-bgp]peer 3.3.3.3 connect-interface LoopBack 0 
    [R4-bgp]peer 2.2.2.2 connect-interface LoopBack 0 
    [R4-bgp]peer 3.3.3.3 next-hop-local  
    [R4-bgp]peer 2.2.2.2 next-hop-local
    [R4-bgp]net 2.2.2.2 255.255.255.255
    [R4-bgp]net 3.3.3.3 255.255.255.255
    [R4-bgp]net 4.4.4.4 255.255.255.255
    [R4-bgp]net 5.5.5.5 255.255.255.255
    [R4-bgp]
    

    R5

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sys R5
    [R5]int g0/0/0
    [R5-GigabitEthernet0/0/0]ip add 45.1.1.5 24
    [R5-GigabitEthernet0/0/0]int loo 0
    [R5-LoopBack0]ip add 5.5.5.5 32
    [R5-LoopBack0]q
    [R5]ip route-static 4.4.4.4 32 45.1.1.4
    [R5]

    配置BGP

    [R5]bgp 300
    [R5-bgp]router 
    [R5-bgp]router-id 5.5.5.5 
    [R5-bgp]peer 4.4.4.4 as-number 200 
    [R5-bgp]peer 4.4.4.4 connect-interface LoopBack 0 
    [R5-bgp]peer 4.4.4.4 ebgp-max-hop 2
    [R5-bgp]q

    结果

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • CCNP实验:简单的BGP实验

    千次阅读 2019-06-24 14:08:11
    CCNP实验:简单的BGP实验: 对于该实验有不懂得可以查看我这篇博客: CCNP7:BGP的 [特点、数据包、工作过程、路由黑洞、放环机制、配置、MA网络中下一跳问题 ] 这个实验如下所示:所有的IP地址已经标明,然后...

    CCNP实验:简单的BGP实验:

    对于该实验有不懂得可以查看我这篇博客:
    CCNP7:BGP的 [特点、数据包、工作过程、路由黑洞、放环机制、配置、MA网络中下一跳问题 ]
    这个实验如下所示:所有的IP地址已经标明,然后所有的设备均运行BGP,且AS2中的3台路由器运行的IGP协议是OSPF,R4-R5之间存在两条链路。现在要求:R1-R5之间它们的环回可以互相访问
    在这里插入图片描述
    由于拓扑、IP均已经规划好了,因此我们直接进入路由环节。

    路由:

    1、AS2中运行OSPF:

    关于OSPF怎么宣告的配置这里不再演示,需要注意的是与BGP相连的接口不宣告在OSPF区域内。

    2、BGP建邻:

    它们之间的邻居关系如下,IBGP水平分割规定:从一个IBGP邻居学到的路由,不能给另一个IBGP邻居。

    目前解决这个问题,这里使用比较差的方案就是:在R2和R4之间建立一个BGP邻居关系。
    在这里插入图片描述
    如果在配置时:出现类似下面的报错情况,第一反应应该是AS号配置的问题。
    (Peer in wrong AS) 2 bytes 0002
    (1)R1、R2之间建立直连的BGP邻居:

    R1(config)#router bgp 1
    R1(config-router)#bgp router-id 1.1.1.1
    R1(config-router)#neighbor 12.1.1.2 remote-as 2
    
    R2(config)#router bgp 2
    R2(config-router)#bgp router-id 2.2.2.2 
    R2(config-router)#neighbor 12.1.1.1 remote-as 1
    

    (2)IBGP邻居关系建立:
    由于环回可以起到链路备份的作用,保证邻居关系的不断开。因此IBGP中的邻居最好使用环回来建邻。

    R2(config-router)#neighbor 3.3.3.3 remote-as 2
    R2(config-router)#neighbor 3.3.3.3 update-source loopback 0
    R2(config-router)#neighbor 4.4.4.4 remote-as 2
    R2(config-router)#neighbor 4.4.4.4 update-source loopback 0
    
    R3(config)#router bgp 2
    R3(config-router)#bgp router-id 3.3.3.3
    R3(config-router)#neighbor 2.2.2.2 remote-as 2
    R3(config-router)#neighbor 2.2.2.2 update-source loopback 0
    R3(config-router)#neighbor 4.4.4.4 remote-as 2
    R3(config-router)#neighbor 4.4.4.4 update-source loopback 0
    
    
    R4(config)#router bgp 2
    R4(config-router)#bgp router-id 4.4.4.4
    R4(config-router)#neighbor 3.3.3.3 remote-as 2
    R4(config-router)#neighbor 3.3.3.3 update-source loopback 0
    R4(config-router)#neighbor 2.2.2.2 remote-as 2
    R4(config-router)#neighbor 2.2.2.2 update-source loopback 0
    

    (3)R4、R5两条链路之间建立BGP邻居关系
    为了使R4-R5之间的两条链路全部用上,因此R4需要写到R5环回的静态路由。

    R4(config)#ip route 5.5.5.0 255.255.255.0 45.1.1.2
    R4(config)#ip route 5.5.5.0 255.255.255.0 54.1.1.2
    R5(config)#ip route 4.4.4.0 255.255.255.0 45.1.1.1
    R5(config)#ip route 4.4.4.0 255.255.255.0 54.1.1.1
    

    建邻:

    R4(config)#router bgp 2
    R4(config-router)#neighbor 5.5.5.5 remote-as 3
    R4(config-router)#neighbor 5.5.5.5 update-source loopback 0
    R4(config-router)#neighbor 5.5.5.5 ebgp-multihop
    
    
    R5(config)#router bgp 3
    R5(config-router)#bgp router-id 5.5.5.5
    R5(config-router)#neighbor 4.4.4.4 remote-as 2
    R5(config-router)#neighbor 4.4.4.4 update-source loopback 0
    R5(config-router)#neighbor 4.4.4.4 ebgp-multihop
    

    3、BGP宣告:

    (1)R1的环回访问R5的环回:
    为了能将学习到的路由给该AS内部的其它IBPG邻居,因此需要修改下一跳为本地。

    R2(config-router)#neighbor 3.3.3.3 next-hop-self 
    R2(config-router)#neighbor 4.4.4.4 next-hop-self
    
    R3(config-router)#neighbor 2.2.2.2 next-hop-self 
    R3(config-router)#neighbor 4.4.4.4 next-hop-self
    
    R4(config-router)#neighbor 2.2.2.2 next-hop-self
    R4(config-router)#neighbor 3.3.3.3 next-hop-self 
    

    接着我们宣告R1、R5的环回:

    R1(config)#router bgp 1
    R1(config-router)#network 1.1.1.0 mask 255.255.255.0
    
    R5(config)#router bgp 3
    R5(config-router)#network 5.5.5.0 mask 255.255.255.0
    

    之后,R1的环回就可以ping通R5的环回了:
    在这里插入图片描述
    (2)所有环回之间互访:

    由于R1、R5它们没有到R2-R4中环回的路由,因此我们需要宣告R2-R4环回。
    宣告这里省略,之后就可以实现全环回互访了。

    但当我们进入bgp协议,宣告R2的环回的后,就会出现一个问题:R3会学习到两条R2环回的路由,一条是2.2.2.2/32OSPF的,另一条是R1发来的2.2.2.0/24BGP学习到的路由。
    在这里插入图片描述
    因此,我们还需要在环回中修改环回在OSPF的工作方式为点到点:

    这样OSPF的环回网段的掩码就是24位,OSPF的管理距离【110】比BGP的管理距离【200】小,这样路由表就只会加载一条OSPF的路由。
    在这里插入图片描述
    这样我们就可以看到BGP表中的路由,显示没有被装载,已被更好的路由所替代。到这里实验就完了,

    还有一种方法是:由于R2拥有R3、R4环回的路由,因此我们可以让R2直接宣告R3、R4的环回,不让R3、R4在bgp中宣告它们的环回,也可以实现环回间互访。
    在这里插入图片描述
    上面是两种宣告方式所呈现的路由表的截选,上面的是第一种宣告方式,而下面的路由表是第二种宣告方式。我们知道BGP是靠属性选路,但是这里却出现了度量值。

    BGP协议在宣告路由时,将携带本地路由表中到达目标的度量值及下一跳。
    第一种方式之所以度量都是零,是因为它们都运行的是BGP协议,且宣告的网段都和自己直连,因此都是0。
    第二种方式是因为其它设备没有运行BGP,到达那些网段并不是直连,而是通过 OSPF,因此需要加度量。

    展开全文
  • BGP实验(OSPF+环回全通) 实验要求 配置思路 先配置所有接口和环回地址 启动OSPF协议 IBGP建邻 EBGP建邻 EBGP邻居间存在多条物理链路时,也建议使用环回接口地址来建立——R5 正常环回作为源、目ip地址...

    HCIP


    前言

    BGP实验(OSPF+环回全通)


    实验要求

    在这里插入图片描述

    配置思路

    • 先配置所有接口和环回地址

    • 启动OSPF协议

    • IBGP建邻

    • EBGP建邻

      EBGP邻居间存在多条物理链路时,也建议使用环回接口地址来建立——R5

      正常环回作为源、目ip地址建立邻居关系

      IP可达,写静态路由——建立TCP会话

      默认IBGP邻居间数据包的TTL值为255,EBGP邻居间TTL为1;故一旦使用环回建立ebgp邻居关系,必须修改TTL值,否则无法建立

    • 路由宣告

    配置

    启动OSPF协议

    [r2]ospf 1 router-id 2.2.2.2
    [r2-ospf-1]area 0
    [r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
    [r2-ospf-1-area-0.0.0.0]network 12.1.1.2 0.0.0.0
    [r2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0
    
    [r3]ospf 1 router-id 3.3.3.3
    [r3-ospf-1]area 0
    [r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
    [r3-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0
    [r3-ospf-1-area-0.0.0.0]network 34.1.1.1 0.0.0.0
    
    [r4]ospf 1 router-id 4.4.4.4 
    [r4-ospf-1]area 0
    [r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
    [r4-ospf-1-area-0.0.0.0]network 34.1.1.2 0.0.0.0
    [r4-ospf-1-area-0.0.0.0]network 45.1.1.1 0.0.0.0
    [r4-ospf-1-area-0.0.0.0]network 54.1.1.1 0.0.0.0
    

    IBGP建邻

    [r2-bgp]peer 3.3.3.3 as-number 2
    [r2-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    
    [r3]bgp 2
    [r3-bgp]router-id 3.3.3.3
    [r3-bgp]peer 2.2.2.2 as-number 2 
    [r3-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    [r3-bgp]peer 4.4.4.4 as-number 2
    [r3-bgp]peer 4.4.4.4 connect-interface LoopBack 0
    
    [r4-bgp]peer 3.3.3.3 as-number 2
    [r4-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    

    EBGP建邻

    [r1]bgp 1
    [r1-bgp]router-id 1.1.1.1
    [r1-bgp]peer 12.1.1.2 as-number 2
    
    [r2]bgp 2
    [r2-bgp]router-id 2.2.2.2
    [r2-bgp]peer 12.1.1.1 as-number 1
    
    
    
    [r4-bgp]peer 5.5.5.5 as-number 3
    [r4-bgp]peer 5.5.5.5 connect-interface LoopBack 0
    
    [r5]bgp 3
    [r5-bgp]peer 4.4.4.4 as-number 2
    [r5-bgp]peer 4.4.4.4 connect-interface LoopBack  0
    
    [r4]ip route-static 5.5.5.0 24 45.1.1.2
    [r4]ip route-static 5.5.5.0 24 54.1.1.2
    [r5]ip route-static 4.4.4.0 24 45.1.1.1 
    [r5]ip route-static 4.4.4.0 24 54.1.1.1
    
    改 TTL
    [r4-bgp]peer 5.5.5.5 ebgp-max-hop 2
    [r5-bgp]peer 4.4.4.4 ebgp-max-hop 2
    

    在这里插入图片描述

    路由宣告

    由于IBGP水平分割——本地路由器从一个IBGP邻居处学习到的路由,不得传递给本地的下一台IBGP邻居

    需要给R2和R4建立IBGP邻居

    [r2]bgp 2
    [r2-bgp]peer 4.4.4.4 as-number 2
    [r2-bgp]peer 4.4.4.4 connect-interface LoopBack 0
    
    
    [r4-bgp]peer 2.2.2.2 as-number 2
    [r4-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    
    当路由条目传递给本地的EBGP邻居时,属性将自动发生变化,包括下一跳地址;
    [r1-bgp]network 1.1.1.0 24
    

    在这里插入图片描述

    基于AS-BY-AS规则,条目在一个AS内部传递时将不修改条目属性;导致通过IBGP邻居学习到的BGP路由可能出现下一跳不可达;导致条目不优;

    
    [r2-bgp]network 2.2.2.0 24
    
    将BGP路由传递给本地的邻居3.3.3.3时修改下一跳地址为本地与3.3.3.3建立邻居关系的源ip地址
    
    [r2-bgp]peer 3.3.3.3 next-hop-local 
    [r2-bgp]peer 4.4.4.4 next-hop-local 
    

    在这里插入图片描述

    [r3-bgp]network 3.3.3.0 24
    

    在这里插入图片描述

    由于逻辑悖论——R4要宣告路由(4.4.4.0 24),但之前R4为了与R5建邻写了一条静态路由(4.4.4.0 24),R5要学习的路由与建邻使用的路由相同。无法最优。

    所以,将之前的4.4.4.0 24静态路由删除。要将建邻用的静态路由和宣告用的静态路由写成不同的。——(4.4.4.4 32)

    [r4]undo ip route-static 5.5.5.0 24 45.1.1.2
    [r4]undo ip route-static 5.5.5.0 24 54.1.1.2
    
    [r4]ip route-static 5.5.5.5 32 45.1.1.2
    [r4]ip route-static 5.5.5.5 32 54.1.1.2
    
    [r4-bgp]network 4.4.4.0 24
    
    [r4-bgp]peer 3.3.3.3 next-hop-local 
    [r4-bgp]peer 2.2.2.2 next-hop-local
    

    在这里插入图片描述

    
    [r5]undo ip route-static 4.4.4.0 24 45.1.1.1 
    [r5]undo ip route-static 4.4.4.0 24 54.1.1.1
    
    [r5]ip route-static 4.4.4.4 32 45.1.1.1 
    [r5]ip route-static 4.4.4.4 32 54.1.1.1
    [r5-bgp]network 5.5.5.0 24
    

    在这里插入图片描述

    • 实际工程中,BGP建邻用的实际的环回,都是24位,但OSPF用的是32位,就要修改类型
    [r2-LoopBack0]ospf network-type broadcast
    [r3-LoopBack0]ospf network-type broadcast
    [r4-LoopBack0]ospf network-type broadcast
    
    但是这样又会产生逻辑悖论
    
     解决方法是
    
    把R2R3R4宣告的路由先去掉
    
    重新建立新的环回(loopBack 1)——重新启动协议——宣告。然后再把这个宣告环回的类型修改——此时BGP宣告的就是建邻使用的掩码为24位的环回地址。(第十一天)
    
     把(LoopBack0——用来建邻的)的ospf network-type broadcast类型删掉。
    
    • 本实验中,不用修改broadcast也是可以的,因为建邻用的24位,OSPF宣告的是32位

    测试

    在这里插入图片描述
    在这里插入图片描述

    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • bgp实验

    2020-07-12 15:44:42
    接下来配置bgp 由于R1与R2使用环回建邻,需要环回可达,于是在R1,R2上写到达对方环回的静态路由 由于在EBGP之间bgp数据包传递的TTL值为1,所以EBGP之间使用环回建邻时必须更改TTL值 在AS2内部使用联邦 在R3和...
  • 华三BGP实验

    2020-10-24 14:21:01
    R1的配置 [H3C]int g0/0 [H3C-GigabitEthernet0/0]ip add 1.1.1.1 24 [H3C-GigabitEthernet0/0]int g0/1 [H3C-GigabitEthernet0/1]ip add 1.1.2.1 24 ...[H3C-bgp-default]peer 1.1.2.3 as-number 20.
  • BGP实验一分析(hcip)

    2021-01-20 13:11:54
    目录  拓扑设计  拓扑搭建  配置 ...[r3-bgp]peer 2.2.2.2 connect-interface LoopBack 1 //IBG内部采用环回建立邻居关系,因为IBGP内部存在备份和负载,如果有动荡,不影响BGP.  [r3-bgp
  • 基于ensp的BGP实验

    千次阅读 2020-05-18 20:59:14
    BGP实验 BGP协议:边界网关协议,是一种提供域间路由选择系统的路由协议,确保自治系统AS之间能够无环路的交换路由选择信息。BGP是一种基于策略的路由选择协议,BGP确定最佳路径时考虑的不是速度,而是让AS能够根据...
  • 简单易懂的BGP实验

    2020-07-06 17:07:18
    BGP原理及运用1. BGP的概述1.1 自治系统1.2 动态路由的分类1.2.1 按自治系统分类1.3 BGP的概念1.4 BGP的特征1.5BGP的工作原理 1. BGP的概述 1.1 自治系统 1、自治系统(AS)是由一个技术管理机构管理,使用统一选路...
  • BGP实验1

    2021-02-06 19:01:38
    R1与R2建立EBGP邻居 (拿直连接口IP进行建立) ,R2\3\4相互建立IBGP关系,并且BGP可以跨路由器建立邻居,所以再将R2与R4建立IBGP邻居关系,R4与R5建立EBGP邻居关系(拿环回IP接口建立)因为R4\5之间有俩条线,如果...
  • 华为模拟器eNSP中BGP实验

    千次阅读 2020-08-01 19:19:30
    BGP实验实验拓扑图实验要求实验配置测试 实验拓扑图 实验要求 1.如图连接网络,合理规格IP地址,AS200内IGP协议为OSPF 2.R1属于AS 100 ; R2-R3-R4小AS 234 R5-R6-R7小AS 567,同时声明大AS 200,R8属于AS300 3.R2-...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,369
精华内容 3,347
关键字:

bgp实验