精华内容
下载资源
问答
  • RIP动态路由配置
    万次阅读
    2019-05-01 16:55:23

    RIP动态路由配置

    问题

    在相对较小而且结构不变的网络中,静态路由是很好的解决方案,它配置简单而且不过多消耗设备资源(动态路由协议在运行时要消耗路由器内部资源,在与其他路由器更新信息时又会消耗网络资源)。
    然而在大型网络中,网络非常多,而且很有可能因为某些因素的影响,网络拓扑会有轻微变化。这时如果仍然采用静态路由就非常不方便了。
    1)通过RIP实现路由间通信

    方案

    动态路由协议配置灵活,路由器会发送自身的路由信息给其他路由器,同时也会接收其他路由器发来的路由信息建立自己的路由表。这样在路由器上就不必像静态路由那样为每个目标地址都配置路由,因为路由器可以通过协议学习这些路由。网络拓扑改变,路由信息也会自动更新,无需管理员干预。
    网络拓扑如图所示:
    在这里插入图片描述

    步骤

    实现此案例需要按照如下步骤进行。

    步骤一:VLAN以及端口配置与上面3三层交换配置路由完全一致,不再赘述配置

    步骤二:将上面【1.3在三层交换机上配置路由】中的静态、默认路由删除

    tarenasw-3L(config)#no ip route 0.0.0.0 0.0.0.0 192.168.10.1
    tarena-rouer(config)#no ip route 192.168.1.0 255.255.255.0 192.168.10.2
    tarena-rouer(config)#no ip route 192.168.2.0 255.255.255.0 192.168.10.2
    tarena-rouer(config)#no ip route 192.168.3.0 255.255.255.0 192.168.10.2
    

    步骤三:分别在三层交换机和路由器上配置RIP路由协议

    RIP路由协议在配置network时,只需要配置该路由器所直连的主类网络,不与该路由器直连的网络不需要包含在network中。
    RIP默认工作在第一版本下,但是RIP-V1是有类路由协议,而且通过广播的方式进行路由更新,无论是功能上还是效率上都有一些缺陷,这些缺陷RIP-V2可以弥补。在使用时建议采用RIP-V2而不是RIP-V1。

    tarenasw-3L(config)#router rip
    tarenasw-3L(config-router)#version 2
    tarenasw-3L(config-router)#no auto-summary 
    tarenasw-3L(config-router)#network 192.168.1.0
    tarenasw-3L(config-router)#network 192.168.2.0
    tarenasw-3L(config-router)#network 192.168.3.0
    tarenasw-3L(config-router)#network 192.168.10.0
    tarena-rouer(config)#router rip
    tarena-rouer(config-router)#version 2
    tarena-rouer(config-router)#network 192.168.10.0
    tarena-rouer(config-router)#network 200.1.1.0
    

    步骤四:分别在三层交换机和路由器上查看路由表

    注意以R开头的路由,这些路由表示通过RIP协议从其他运行RIP的路由器学习过来的路由。每条路由都写明了目标网络、下一跳IP地址以及从自己哪个端口发出去。

    tarenasw-3L#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is not set
    C    192.168.1.0/24 is directly connected, Vlan1
    C    192.168.2.0/24 is directly connected, Vlan2
    C    192.168.3.0/24 is directly connected, Vlan3
    C    192.168.10.0/24 is directly connected, FastEthernet0/23
    R    200.1.1.0/24 [120/1] via 192.168.10.1, 00:00:07, FastEthernet0/23
    tarena-rouer#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is not set
    R    192.168.1.0/24 [120/1] via 192.168.10.2, 00:00:10, FastEthernet0/0
    R    192.168.2.0/24 [120/1] via 192.168.10.2, 00:00:10, FastEthernet0/0
    R    192.168.3.0/24 [120/1] via 192.168.10.2, 00:00:10, FastEthernet0/0
    C    192.168.10.0/24 is directly connected, FastEthernet0/0
    C    200.1.1.0/24 is directly connected, FastEthernet0/1
    

    步骤五:在Server上测试到三个VLAN中主机的通信

    SERVER>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address.........: FE80::2E0:8FFF:FE14:BB43
    IP Address......................: 200.1.1.10
    Subnet Mask.....................: 255.255.255.0
    Default Gateway.................: 200.1.1.1
    SERVER>ping 192.168.1.10
    Pinging 192.168.1.10 with 32 bytes of data:
    Reply from 192.168.1.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.1.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.1.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.1.10: bytes=32 time=1ms TTL=126
    Ping statistics for 192.168.1.10:
        Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms
    SERVER>ping 192.168.2.10
    Pinging 192.168.2.10 with 32 bytes of data:
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Ping statistics for 192.168.2.10:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms
    SERVER>ping 192.168.3.10
    Pinging 192.168.3.10 with 32 bytes of data:
    Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Ping statistics for 192.168.3.10:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms
    SERVER>
      31% /misc/nfsdir
    
    更多相关内容
  • RIP动态路由实验.docx

    2020-07-02 23:29:25
    RIP动态路由实验:V1版本、V2版本(对有类路由进行汇总) ripV1:以每30秒一次的频率拷贝自己的路由表副本作为路由更新发送给其直连邻居,更新方式为直播,即以255.255.255.255为目的地址发送报文 ripV2:更新方式为...
  • 掌握查看通过动态路由协议RIP学习产生的路由; 熟悉广域网线缆的链接方式; 实验背景 假设校园网通过一台三层交换机连到校园网出口路由器上,路由器再和校园外的另一台路由器连接。现要做适当配置,实现校园网...
  • 路由器RIP动态路由配置 路由器OSPF动态路由配置(选做) 假设校园网通过一台三层交换机连到校园网出口路由器上,路由器再和校园外的另一台路由器连接。现要做适当配置,实现校园网内部主机与校园网外部主机之间的...
  • RIP动态路由协议原理与配置PPT学习教案.pptx
  • rip动态路由实验.pkt

    2020-07-02 23:28:05
    rip路由信息协议: 1.以跳数作为度量值,经过一个路由器,跳数增加1 2.rip路由协议认为跳数越少,路径的路由越佳,并将其加入路由表 3.跳数相等的路径,尽管带宽不同,rip也会认为它们是等价路由 4.rip默认支持4条...
  • 路由器RIP动态路由配置

    借鉴网址:(28条消息) Packet Tracer 思科模拟器入门教程 之十二 路由器RIP动态路由配置_柚子君.的博客-CSDN博客_思科模拟器动态路由配置

    姓 名

    彭彭头

    实验日期

    2022.05.07

    学 号

    实验序号

    13

    实验名称

    路由器RIP动态路由配置

    一、实验目的及要求

    掌握RIP协议的配置方法,掌握查看通过动态路由协议RIP学习产生的路由,熟悉广域网线缆的链接方式

    二、实验环境

    Cisco软件、1台三层交换机、2台路由器、2台主机、直连线、交叉线、DCE串口线

    三、实验内容

    1.建立拓扑图

    2.配置主机:IP地址、子网掩码、网关

    3.配置三层交换机:创建vlan端口并绑定物理端口、设置vlan端口IP和子网掩码并启动

    4.配置路由器:设置物理端口的IP和子网掩码并开启、配置时钟速率、查看路由表、配置RIP协议并添加IP

    5. 测试2台PC能否互相ping通

    四、实验步骤

    (一)拓扑图

     

    (二)配置ip、子网掩码、网关

    1.配置PC0

    2.配置PC1

    • 配置三层交换机3560
    1. 更改主机名,划分vlan,设置物理端口,显示路由表信息
    2. 检查路由的配置情况

    • 配置路由器Router0
    1. 更改主机名,设置端口的IP和子网掩码、配置时钟速率
    2. 配置RIP协议并添加IP地址

    • 配置路由器Router1
    1. 更改主机名,设置端口的IP和子网掩码、配置时钟速率
    2. 配置RIP协议并添加IP地址

    • 实验结果
    1. PC0 ping PC1,可以ping通

    五、实验总结

    今天的实验是掌握如何为路由器和三层交换机配置RIP协议,从中我学习到了:

    1. RIP(Routing Information Protocols,路由信息协议)是应用较早、使用较普遍的IGP内部网管协议,使用于小型同类网络,是距离矢量协议
    2. 主机和交换机通过直连线,主机与路由器通过交叉线连接
    3. RIP协议跳数作为衡量路径开销,RIP协议里规定最大跳数为15
    4. 有类路由协议不携带网络掩码,无类路由协议携带网络掩码
    5. RIP协议有两个版本:RIPv1和RIPv2。RIPv1属于有类路由协议,不支持VLSM,以广播形式进行路由信息的更新;RIPv2属于无类路由协议,支持VLSM,以组播形式进行路由更新。

    展开全文
  • 1. 配置动态路由 配置路由器 R1 R1(config)#router rip //启动 RIP 进程 R1(config-router)#version 1 //配置 RIP 版本 1 R1(config-router)#network 1.0.0.0 //通告网络 R1(config-router)#network 192.168.12.0 /...

    1. 配置动态路由

    在这里插入图片描述
    配置路由器 R1
    R1(config)#router rip //启动 RIP 进程
    R1(config-router)#version 1 //配置 RIP 版本 1
    R1(config-router)#network 1.0.0.0 //通告网络
    R1(config-router)#network 192.168.12.0
    //宣告网络是直连网段

    2. 查看路由表

    R1#show ip route

    R 4.0.0.0/8 [120/3] via 192.168.12.2, 00:00:03, Serial0/0/0
    R 192.168.23.0/24 [120/1] via 192.168.12.2, 00:00:03, Serial0/0/0
    R 192.168.34.0/24 [120/2] via 192.168.12.2, 00:00:03, Serial0/0/0
    以上输出表明路由器 R1 学到了 3 条 RIP 路由,其中路由条目“R 4.0.0.0/8 [120/3]
    via 192.168.12.2, 00:00:03, Serial0/0/0”的含义如下:
    ① R:路由条目是通过 RIP 路由协议学习来的;
    ② 4.0.0.0/8:目的网络;
    ③ 120:RIP 路由协议的默认管理距离;
    ④ 3: 度量值,从路由器 R1 到达网络 4.0.0.0/8 的度量值为 3 跳;
    ⑤ 192.168.12.2:下一跳地址;
    ⑥ 00:00:03:距离下一次更新还有 27(30-3)秒;
    ⑦ Serial0/0/0:接收该路由条目的本路由器的接口。
    同时通过该路由条目的掩码长度可以看到,RIPv1 确实不传递子网信息。

    3. 查看 IP 路由协议配置和统计信息

    R1#show ip protocols

    4. 查看 RIP 路由协议的动态更新过程

    R1#clear ip route *
    R1#debug ip rip

    5. 配置被动接口

    R1(config)#router rip
    R1(config-router)#version 1
    R1(config-router)#passive-interface GigabitEthernet0/0
    R1(config-router)#passive-interface GigabitEthernet0/1

    6. 单播更新

    R1(config)#router rip
    R1(config-router)#passive-interface GigabitEthernet0/0
    R1(config-router)#neighbor 172.16.1.3

    7. 配置默认路由

    R1(config)#router rip
    R1(config-router)#default-information originate

    8.RIPV2手工汇总

    在这里插入图片描述
    R4(config)#router rip
    R4(config-router)#version 2
    R4(config-router)#no auto-summary
    R4(config-router)#network 192.168.34.0
    R4(config-router)#network 4.0.0.0
    R4(config)#interface s0/0/0
    R4(config-if)#ip summary-address rip 4.4.0.0 255.255.252.0//RIP 手工路由汇总

    展开全文
  • RIP 动态路由协议

    2021-03-19 11:22:55
    动态路由协议思维导图一、回顾引入1.1 路由概念1.2 路由协议分类二、距离矢量路由协议2.1 概念2.2 距离矢量路由选择协议2.2.1路由器初始启动2.2.2 初次路由信息交换2.2.3 路由收敛完成三、RIP基本原理3.1 RIP协议3.2...

    思维导图

    在这里插入图片描述

    一、回顾引入

    1.1 路由概念

    在这里插入图片描述

    1.2 路由协议分类

    在这里插入图片描述
    在这里插入图片描述

    二、距离矢量路由协议

    2.1 概念

    在这里插入图片描述

    2.2 距离矢量路由选择协议

    2.2.1路由器初始启动

    在这里插入图片描述

    2.2.2 初次路由信息交换

    在这里插入图片描述

    2.2.3 路由收敛完成

    在这里插入图片描述

    三、RIP基本原理

    3.1 RIP协议

    • Routing Information Protocol
    • RIP是Routing Information Protocol(路由信息协议)的简称
    • RIP是一种基于距离矢量(Distance-Vector)算法的路由协议
    • RIP协议适用于中小型网络,分为RIPv1和RIPv2
    • RIP支持水平分割、毒性逆转和触发更新等工作机制防止路由环路
    • RIP协议基于UDP传输,端口号520

    3.2 RIP路由的度量值

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    3.3 Route Preference

    在这里插入图片描述
    在这里插入图片描述

    3.4 工作过程

    第一阶段 初始化
    RIP工作第一阶段:会从每个参与工作的接口上发送请求数据包。该请求数据包会向所有的RIP路由器请求一份完整的路由表。
    广播链路为广播形式请求, P2P 链路为下一跳地址形式请求。
    RIPv1发送数据包为广播形式: 255.255.255.255
    RIPv2发送数据包为组播形式: 224.0.0.9
    在这里插入图片描述
    第二阶段 接受请求
    RIP有两种类型的消息,响应和接收消息。请求数据包中的每个路由条目都会被处理,从而为路由建立度量以及路径。
    第三阶段 接受到响应
    路由器接收并处理响应,它会通过对路由表项进行添加,删除或者修改作出更新。
    第四阶段 常规路由更新和定时
    路由器以30秒一次地将整个路由表以应答消息地形式发送到邻居路由器
    第五阶段 触发路由更新
    当某个路由条目度量发生改变时,路由器只发送与改变有关的路由,并不发送完整的路由表

    3.5 RIP的四个计时器

    1、更新计时器(Updata Timer):
    RIP协议平均每隔30s(默认值)从每个启动RIP协议的接口不断地发送出响应消息。这个周期性的更新由更新计时器进行初始化,并且包含一个随机变化量用来防止表的同步。

    2、无效计时器(Invalidation Timer)/ 超时计时器(Timeout Timer):
    无效计时器用来限制停留在路由选择表中的路由未被更新的时间。无论什么时候,当有一条新的路由建立成功后,超时计时器就会被初始化为180s(默认值), 而每当接收到这条路由的更新报文时,超时计时器又将被重置成计时器的初始化值。如果一条路由的更新在180s(6个更新周期)内还没有收到,那么这条路由 的跳数将变成16,也就是标记为不可达路由。

    3、垃圾收集(Garbage Collection)/ 刷新计时器(Flush Timer):
    这个计时器所设置的时间长度一般比无效计时器/限时计时器的时间长240~60s。如果垃圾收集计时器也超时了,则该路由将被通告为一条度量值为不可到达的路由,同时从路由选择表中删除该路由。

    4、抑制计时器(Holddown Timer):
    用于抑制更新机制。如果一条路由更新的跳数大于路由选择表已记录的该路由的跳数,那么将会引起该路由进入长达180s(即6个路由更新周期)的抑制状态阶段。

    四、RIP的防环机制

    • 水平分割
      定义及优势:
      RIP从某个接口学到的路由,不会从该接口再发回给邻居路由器。减少了带宽消耗,防止路由环路。
      按照网络类型的处理方式:
      广播网、P2P和P2MP网络中是按照接口进行水平分割的
      NBMA网络是按照邻居进行水平分割的
      某一接口的对端邻居处学习到路由,不会再通过该接口发送回去。
    • 毒性逆转
      定义:
      RIP从某个接口学到路由后,从原接口发回邻居路由器,并将该路由的开销设置为16
    • 触发更新
      定义:
      触发更新是指当路由信息发生变化时,立即向邻居设备发送触发更新报文,而不用等待更新定时器超时,从而避免产生路由环路。
      过程:
      如果路由器增加了一个 RIP 接口,会直接触发路由器发送 response 报文,
      该报文中路由为增量路由。如果删除某个接口,则向其他路由器触发发送一条跳
      数置为 16 跳的毒性路由,告知对方清除该路由,用以删除无效路由。
    • 最大跳数
      一条路由的跳数最大为 15 跳,如果超过 15 跳,则认为不可达。

    五、RIP版本区别和配置

    RIPv1报文格式
    在这里插入图片描述
    RIPv2报文格式
    在这里插入图片描述
    RIPv2相比v1的改进

    • 支持外部路由标记(Route Tag),可以在路由策略中根据Tag对路由进行灵活的控制。
    • 报文中携带掩码信息,支持路由聚合和CIDR(Classless Inter-Domain Routing)。
    • 支持指定下一跳,在广播网上可以选择到目的网段最优下一跳地址。
    • 支持以组播方式发送更新报文,只有支持RIP-2的设备才能接收协议报文,减少资源消耗。
    • 支持对协议报文进行验证,增强安全性。

    RIP基础命令
    启动RIP进程,并进入RIP配置视图:
    [Router] rip 1
    在指定网段使能RIP(RIP只支持classful网络宣告):
    [Router-rip-1] network 192.168.12.0
    指定RIP的版本(默认为版本1):
    [Router-rip-1] version 2

    展开全文
  • 华三静态路由、单臂路由以及动态路由RIP)配置实验报告,给出了详细的网络拓扑图,实验过程就截图、实验结果和实验分析心得。
  • RIP动态路由协议原理与配置PPT教案.pptx
  • 第10章 路由器RIP动态路第10章 路由器RIP动态路由配置由配置
  • eNSP | RIP动态路由配置

    2021-06-23 19:54:23
    目录 一、搭建拓扑图 二、配置IP地址 三、配置RIP动态路由 四、查看和测试 (一)查看路由表 (二)测试连通性 一、搭建拓扑图 二、配置IP地址 R1 [R1]interface GigabitEthernet 0/0/0 //进入接口 0/0/0 [R1-...
  • 路由器RIP动态路由配置实验报告
  • RIP动态路由配置.docx

    2019-09-19 17:34:57
    计算机网络rip动态路由配置实验报告,选择两台中兴1800路由器,两台PC完成网络的连接和设置,通过配置RIP动态路由实现173.35.1.0/24和173.35.2.0/24两个网络之间的相互通信
  • 本文写了:RIP的配置方法,工作原理,认证
  • 神舟数码路由器怎么配置RIP动态路由?神舟数码路由器组成的小型网络中想要牌值rip动态路由,该怎么配置呢?下面我们就来看看详细的教程,需要的朋友可以参考下
  • 16、rip动态路由

    千次阅读 2021-12-12 08:20:09
    文章目录**rip动态路由****协议概述**度量值是什么动态路由、静态路由区别**动态路由协议分配****rip的含义** **常用rip 2****30秒一更新****最大15跳、UDP520 端口****路由环路****水平分割**RIP 实例 rip动态路由 ...
  • RIP动态路由实验

    2019-09-16 10:24:45
    动态路由简述: 1、动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整 2、当网络中节点或节点间的...
  • RIP动态路由实验配置

    千次阅读 2019-09-19 10:10:50
    二、实验内容 根据实验要求,按照拓扑结构和路由协议进行子网内划分,设置三个网段,分别为173.35.1.0/24、173.35.4.4/30、173.35.2.0/24,设置各个接口IP地址,PC-1和PC-2的IP...完成RIP动态路由的配置和结果查看...
  • 动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整。当网络中节点或节点间的链路发生故障,或存在其它...
  • 路由器RIP动态路由配置 二、实验目的 路由器RIP动态路由配置: 1.掌握RIP协议的配置方法; 2.掌握查看通过动态路由协议RIP学习产生的路由; 3.熟悉广域网线缆的链接方式。 三、实验内容和要求 假设校园...
  • 路由器RIP动态路由的配置,通过使用交换机(3560)和路由器,使得两台PC机之间可以相互通信。注意:设置路由器端口时要设置时钟频率。
  • 学 生 实 训 报 告实训课名称________ 计 算 机 网 络_______实训内容 RIP 动态路由协议的配置学 院 数信学院 年级 050711专 业 数学与应用数学学 生 姓 名___ 杨义_ 学 号__ 13 _开 课 时 间_ 2007__ 至 _ 200...
  • RIP动态路由协议

    2019-09-07 16:18:12
    动态路由协议 动态路由协议概述 路由器之间用来交换信息的语言 度量值 跳数、带宽、负载、时延、可靠性、成本 收敛 使所有路由表都达到一致状态的过程 ...RIP路由协议 矢量路由选择协议 RIP基本概念: 定期更新...
  • RIP动态路由协议一、动态路由协议简介二、动态路由的协议三、RIP路由协议V1与V2区别四、动态路由的优劣点 一、动态路由协议简介 路由协议是路由器之间交互信息的一种语言。 路由协议共享网络状态和网络可达性的一些...
  • 远离的配置指定网段的IP 如: R1中e0/0/0接口,配置192.168.30.1的IP,e0/0/1接口,配置10.0.1.1的IP,子网掩码均为24位 第五步:路由器配置rip R1:rip 1 version 2 undo summary network 10.0.0.0 network 172.16....
  • 交换机的RIP动态路由配置 实验目的: 要实现当前网络的所有计算机能相互通信,就要在两个交换机中分别各自规划3个Vlan,分别为Vlan10、Vlan20、Vlan100和Vlan30、Vlan40、Vlan100,每个Vlan设置对应网段的IP地址,...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 44,619
精华内容 17,847
关键字:

rip动态路由

友情链接: DSP_code.zip