精华内容
下载资源
问答
  • Cisco Packet Tracer 实验

    2020-12-26 10:00:39
    Cisco Packet Tracer 实验

    相关概念简介

    完成以下实验需要请大家先了解 VLSM、CIDR、RIP、OSPF、VLAN、STP、NAT 及 DHCP 等概念,以能够进行网络规划和配置。

    VLSM其实就是相对于类的IP地址来说的。A类的第一段是网络号(前八位),B类地址的前两段是网络号(前十六位),C类的前三段是网络号(前二十四位)。而VLSM的作用就是在类的IP地址的基础上,从它们的主机号部分借出相应的位数来做网络号,也就是增加网络号的位数。各类网络可以用来再划分子网的位数为:A类有二十四位可以借,B类有十六位可以借,C类有八位可以借(可以再划分的位数就是主机号的位数。实际上不可以都借出来,因为IP地址中必须要有主机号的部分,而且主机号部分剩下一位是没有意义的,所以在实际中可以借的位数是在上面那些数字中再减去2,借的位作为子网部分)。VSLM

    CIDR:无类别域间路由是基于可变长子网掩码(VLSM)来进行任意长度的前缀的分配的。在RFC 950(1985)中有关于可变长子网掩码的说明。CIDR包括:指定任意长度的前缀的可变长子网掩码技术。遵从CIDR规则的地址有一个后缀说明前缀的位数,例如 192.168.0.0/16。这使得对日益缺乏的IPv4地址的使用更加有效。将多个连续的前缀聚合成超网,以及,在互联网中,只要有可能,就显示为一个聚合的网络,因此在总体上可以减少路由表的表项数目。聚合使得互联网的路由表不用分为多级,又用VLSM reverses the process of “subnetting a subnet” 。 根据机构的实际需要和短期预期需要而不是分类网络中所限定的过大或过小的地址块来管理IP地址的分配的过程。 因为在IPv6中也使用了IPv4的用后缀指示前缀长度的CIDR,所以IPv4中的分类在IPv6中已不再使用 。CIDR

    RIP(Routing Information Protocol,路由信息协议)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。这种协议的路由器只关心自己周围的世界,只与自己相邻的路由器交换信息,范围限制在15跳(15度)之内,再远,它就不关心了。RIP应用于OSI网络七层模型的应用层。各厂家定义的管理距离(AD,即优先级)如下:华为定义的优先级是100,思科定义的优先级是120。RIP

    OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。著名的迪克斯彻(Dijkstra)算法被用来计算最短路径树。OSPF支持负载均衡和基于服务类型的选路,也支持多种路由形式,如特定主机路由和子网路由等。OSPF

    **虚拟局域网(VLAN)**是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点: 网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。VLAN

    STP(Spanning Tree Protocol)是生成树协议的英文缩写,可应用于计算机网络中树形拓扑结构建立,主要作用是防止网桥网络中的冗余链路形成环路工作。但某些特定因素会导致STP失败,要排除故障可能非常困难,这取决于网络设计 。生成树协议适合所有厂商的网络设备,在配置上和体现功能强度上有所差别,但是在原理和应用效果是一致的。STP

    NAT(Network Address Translation,网络地址转换)是1994年提出的。当在专用网内部的一些主机本来已经分配到了本地IP地址(即仅在本专用网内使用的专用地址),但现在又想和因特网上的主机通信(并不需要加密)时,可使用NAT方法。
    这种方法需要在专用网(私网IP)连接到因特网(公网IP)的路由器上安装NAT软件。装有NAT软件的路由器叫做NAT路由器,它至少有一个有效的外部全球IP地址(公网IP地址)。这样,所有使用本地地址(私网IP地址)的主机在和外界通信时,都要在NAT路由器上将其本地地址转换成全球IP地址,才能和因特网连接。
    另外,这种通过使用少量的公有IP 地址(私网地址)代表较多的私有IP 地址的方式,将有助于减缓可用的IP地址空间的枯竭。在RFC 2663中有对NAT的说明。NAT

    DHCP(动态主机配置协议)是一个局域网的网络协议。指的是由服务器控制一段IP地址范围,客户机登录服务器时就可以自动获得服务器分配的IP地址和子网掩码。默认情况下,DHCP作为Windows Server的一个服务组件不会被系统自动安装,还需要管理员手动安装并进行必要的配置。DHCP

    CPT 软件使用简介

    Cisco Packet Tracer 是由Cisco公司发布的一个辅助学习工具,为学习思科网络课程的初学者去设计、配置、排除网络故障提供了网络模拟环境。用户可以在软件的图形用户界面上直接使用拖曳方法建立网络拓扑,并可提供数据包在网络中行进的详细处理过程,观察网络实时运行情况。可以学习IOS的配置、锻炼故障排查能力。 [1]
    Packet Tracer是一个功能强大的网络仿真程序,允许学生实验与网络行为,问“如果”的问题。随着网络技术学院的全面的学习经验的一个组成部分,包示踪提供的仿真,可视化,编辑,评估,和协作能力,有利于教学和复杂的技术概念的学习。
    Packet Tracer补充物理设备在课堂上允许学生用的设备,一个几乎无限数量的创建网络鼓励实践,发现,和故障排除。基于仿真的学习环境,帮助学生发展如决策第二十一世纪技能,创造性和批判性思维,解决问题。Packet Tracer补充的网络学院的课程,使教师易教,表现出复杂的技术概念和网络系统的设计。

    Packet Tracer软件是免费提供的唯一的网络学院的教师,学生,校友,和管理人员,注册学校连接的用户。Cisco Packet Tracer-百度百科

    学习资料:
    计算机网络第01讲-Packet Tracer的简单使用
    Cisco Packet Tracer 实验教程

    直接连接两台 PC 构建 LAN

    将两台 PC 直接连接构成一个网络。注意:直接连接需使用交叉线。

    进行两台 PC 的基本网络配置,只需要配置 IP 地址即可,然后相互ping通即成功。

    在这里插入图片描述

    直接连接两台 PC 构建 LAN

    构建如下拓扑结构的局域网:
    在这里插入图片描述

    各PC的基本网络配置如下表:

    机器名IP子网掩码
    PC0192.168.1.1255.255.255.0
    PC1192.168.1.2255.255.255.0
    PC2192.168.2.1255.255.255.0
    PC3192.168.2.2255.255.255.0

    ✎ 问题
    PC0 能否 ping 通 PC1、PC2、PC3 ?

    在这里插入图片描述
    在这里插入图片描述

    PC0能够ping通PC1,不能ping通PC2和PC3

    PC3 能否 ping 通 PC0、PC1、PC2 ?为什么?

    在这里插入图片描述

    PC3能够ping通PC2,不能ping通PC0和PC1

    将 4 台 PC 的掩码都改为 255.255.0.0 ,它们相互能 ping 通吗?为什么?

    在这里插入图片描述

    这四台PC之间都能相互ping通;因为子网掩码为255.255.255.0时,PC0、PC1与PC2、PC3处于两个不同的子网下面,而改成255.255.0.0后这四台PC处于同一子网下,因而能够互相ping通。

    使用二层交换机连接的网络需要配置网关吗?为什么?
    使用二层交换机连接的网路不需要配置网关,二层交换机配置好后可在2个网络间建立传输连接,也可以进行点到点的连接

    ✎ 试一试
    集线器 Hub 是工作在物理层的多接口设备,它与交换机的区别是什么?请在 CPT 软件中用 Hub 构建网络进行实际验证。
    集线器 Hub对所有收的数据帧进行广播
    在这里插入图片描述

    交换机接口地址列表

    二层交换机是一种即插即用的多接口设备,它对于收到的帧有 3 种处理方式:广播、转发和丢弃(请弄清楚何时进行何种操作)。那么,要转发成功,则交换机中必须要有接口地址列表即 MAC 表,该表是交换机通过学习自动得到的!

    仍然构建上图的拓扑结构,并配置各计算机的 IP 在同一个一个子网,使用工具栏中的放大镜点击某交换机如左边的 Switch3,选择 MAC Table,可以看到最初交换机的 MAC 表是空的,也即它不知道该怎样转发帧(那么它将如何处理?),用 PC0 访问(ping)PC1 后,再查看该交换机的 MAC 表,现在有相应的记录,请思考如何得来。随着网络通信的增加,各交换机都将生成自己完整的 MAC 表,此时交换机的交换速度就是最快的!

    在这里插入图片描述

    首先最初交换机的 MAC 表是空的,即它不知道该怎样转发帧,那么它将把接收到的帧进行广播;若收到某一端口发回的回复即可知道该帧的MAC地址并存到其MAC表中。
    用 PC0 访问(ping)PC1 后,再查看该交换机的 MAC 表,现在有相应的记录,这是通过ARP(地址解析协议)得来的MAC地址。

    生成树协议(Spanning Tree Protocol)

    交换机在目的地址未知或接收到广播帧时是要进行广播的。如果交换机之间存在回路/环路,那么就会产生广播循环风暴,从而严重影响网络性能。

    而交换机中运行的 STP 协议能避免交换机之间发生广播循环风暴。

    只使用交换机,构建如下拓扑:

    在这里插入图片描述

    这是初始时的状态。我们可以看到交换机之间有回路,这会造成广播帧循环传送即形成广播风暴,严重影响网络性能。

    随后,交换机将自动通过生成树协议(STP)对多余的线路进行自动阻塞(Blocking),以形成一棵以 Switch4 为根(具体哪个是根交换机有相关的策略)的具有唯一路径树即生成树!

    经过一段时间,随着 STP 协议成功构建了生成树后,Switch5 的两个接口当前物理上是连接的,但逻辑上是不通的,处于Blocking状态(桔色)如下图所示:

    在这里插入图片描述

    在网络运行期间,假设某个时候 Switch4 与 Switch5 之间的物理连接出现问题(将 Switch4 与 Switch5 的连线剪掉),则该生成树将自动发生变化。Switch5 上方先前 Blocking 的那个接口现在活动了(绿色),但下方那个接口仍处于 Blocking 状态(桔色)。如下图所示:

    在这里插入图片描述

    🗣 注意
    交换机的 STP 协议即生成树协议始终自动保证交换机之间不会出现回路,从而形成广播风暴。

    路由器配置

    我们模拟重庆交通大学和重庆大学两个学校的连接,构建如下拓扑:

    在这里插入图片描述

    说明一
    交通大学与重庆大学显然是两个不同的子网。在不同子网间通信需通过路由器。

    路由器的每个接口下至少是一个子网,图中我们简单的规划了 3 个子网:

    1. 左边路由器是交通大学的,其下使用交换机连接交通大学的网络,分配网络号
      192.168.1.0/24,该路由器接口也是交通大学网络的网关,分配 IP 为 192.168.1.1
    2. 右边路由器是重庆大学的,其下使用交换机连接重庆大学的网络,分配网络号
      192.168.3.0/24,该路由器接口也是重庆大学网络的网关,分配 IP 为 192.168.3.1
    3. 两个路由器之间使用广域网接口相连,也是一个子网,分配网络号 192.168.2.0/24

    说明二
    现实中,交通大学和重庆大学的连接是远程的。该连接要么通过路由器的光纤接口,要么通过广域网接口即所谓的serial 口(如拓扑图所示)进行,一般不会通过双绞线连接(为什么?)。

    下面我们以通过路由器的广域网口连接为例来进行相关配置。请注意:我们选用的路由器默认没有广域网模块(名称为 WIC-1T 等),需要关闭路由器后添加,然后再开机启动。

    说明三
    在模拟的广域网连接中需注意 DCE 和 DTE 端(连线时线路上有提示,带一个时钟标志的是 DCE 端。有关 DCE 和 DTE 的概念请查阅相关资料。),在 DCE 端需配置时钟频率 64000

    说明四
    路由器有多种命令行配置模式,每种模式对应不同的提示符及相应的权限。

    请留意在正确的模式下输入配置相关的命令。

    User mode:用户模式
    Privileged mode:特权模式
    Global configuration mode:全局配置模式
    Interface mode:接口配置模式
    Subinterface mode:子接口配置模式
    说明五
    在现实中,对新的路由器,显然不能远程进行配置,我们必须在现场通过笔记本的串口与路由器的 console 接口连接并进行初次的配置(注意设置比特率为9600)后,才能通过网络远程进行配置。这也是上图左上画出笔记本连接的用意。

    说明六
    在路由器的CLI界面中,可看到路由器刚启动成功后,因为无任何配置,将会提示是否进行对话配置(Would you like to enter the initial configuration dialog?),因其步骤繁多,请选择 NO

    比如交通大学路由器的初步配置可以如下:

    🗣 注意
    在我们的实验中可不进行如下的配置,但在现实中为了安全,以下的登录及特权密码等配置是必须的,否则每个人都可操作你的路由器或交换机!

    Router>en // 从普通模式进入特权模式
    Router#conf t // 进入全局配置模式
    Router(config)#interface FastEthernet0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#line vty 0 4 //可支持0-4共5个终端同时登录
    Router(config-line)#password dswybs // 远程登录密码
    Router(config-line)#login
    Router(config-line)#exit
    Router(config)#enable password dswybs // 特权模式密码
    Router(config)#^Z // 退出
    拓扑图中路由器各接口配置数据如下:

    在这里插入图片描述

    交通大学路由器基本配置如下:
    以太网口:

    Router>enable // 从普通模式进入特权模式
    Router#configure terminal // 进入全局配置模式
    Router(config)#interface f0/0 // 进入配置以太网口模式
    Router(config-if)#ip address 192.168.1.1 255.255.255.0 // 配置该接口的 IP
    Router(config-if)#no shutdown // 激活接口
    Router(config-if)#^z // 直接退到特权模式
    Router#
    广域网口:

    Router>en // 从普通模式进入特权模式
    Router#conf t // 进入全局配置模式
    Router(config)#int s0/0 // 进入配置广域网口模式
    Router(config-if)#ip address 192.168.2.1 255.255.255.0 //配置该接口的 IP
    Router(config-if)#clock rate 64000 // 其为 DCE 端,配置时钟频率
    Router(config-if)#no shutdown // 激活接口
    Router(config-if)#^z // 直接退到特权模式
    Router#
    重庆大学路由器基本配置如下:
    以太网口:

    Router>en // 从普通模式进入特权模式
    Router#conf t // 进入全局配置模式
    Router(config)#int f0/0 // 进入配置以太网口模式
    Router(config-if)#ip address 192.168.3.1 255.255.255.0 // 配置该接口的 IP
    Router(config-if)#no shutdown // 激活接口
    Router(config-if)#^z // 直接退到特权模式
    Router#

    广域网口:
    Router>en // 从普通模式进入特权模式
    Router#conf t // 进入全局配置模式
    Router(config)#int s0/0 // 进入配置广域网口模式
    Router(config-if)#ip address 192.168.2.1 255.255.255.0 //配置该接口的 IP
    Router(config-if)#clock rate 64000 // 其为 DCE 端,配置时钟频率
    Router(config-if)#no shutdown // 激活接口
    Router(config-if)#^z // 直接退到特权模式
    Router#

    至此,路由器基本的配置完成。请按照上面 PC 配置表继续配置各个 PC 。

    在这里插入图片描述

    ✎ 问题
    现在交通大学内的各 PC 及网关相互能 ping 通,重庆大学也类似。但不能从交大的 PC ping 通重大的 PC,反之亦然,也即不能跨子网。为什么?
    因为路由器2和路由器3之间跨了一个子网,在进行数据包与路由进行与操作是没有所对应的子网地址,广播也广播不到,所以无法进行通信。

    展开全文
  • 自行观看这个视频讲解:Cisco Packet Tracer 系列视频 一、直接连接两台 PC 构建 LAN 将两台 PC 直接连接构成一个网络。注意:直接连接需使用交叉线。 进行两台 PC 的基本网络配置,只需要配置 IP 地址即可,然后...


    CPT 软件使用简介

    自行观看这个视频讲解:Cisco Packet Tracer 系列视频

    一、直接连接两台 PC 构建 LAN

    将两台 PC 直接连接构成一个网络。注意:直接连接需使用交叉线。
    进行两台 PC 的基本网络配置,只需要配置 IP 地址即可,然后相互 ping 通即成功。

    二、用交换机构建 LAN


    问题

    1、PC0 能否 ping 通 PC1、PC2、PC3 ?
    答:能ping通PC1,不能ping通PC2、PC3。
    2、PC3 能否 ping 通 PC0、PC1、PC2 ?为什么? 将 4 台 PC
    答:能ping通PC2,不能ping通PC0、PC1。PC0和PC1的IP地址与子网掩码相与得到的结果是192.168.1.0,PC2和PC3的IP与子网掩码相与得到的是192.168.2.0,分别表示PC0和PC1处于同一子网下,PC2和PC3处于同一子网下,所以PC3不能ping通PC0和PC1。
    3、的掩码都改为 255.255.0.0 ,它们相互能 ping 通吗?为什么?
    答:能,因为ip地址与子网掩码相与后的结果都是192.168.0.0,表示都处于同一子网192.168.0.0下。
    4、使用二层交换机连接的网络需要配置网关吗?为什么?
    答:集线器Hub是工作在物理层,而交换机则是工作在物理层和数据链路层。两种工作的区域不同。

    三、交换机接口地址列表

    二层交换机是一种即插即用的多接口设备,它对于收到的帧有 3 种处理方式:广播、转发和丢弃(请弄清楚何时进行何种操作)。那么,要转发成功,则交换机中必须要有接口地址列表即 MAC 表,该表是交换机通过学习自动得到的!

    仍然构建上图的拓扑结构,并配置各计算机的 IP 在同一个一个子网,使用工具栏中的放大镜点击某交换机如左边的 Switch3,选择 MAC Table,可以看到最初交换机的 MAC 表是空的,也即它不知道该怎样转发帧(那么它将如何处理?),用 PC0 访问(ping)PC1 后,再查看该交换机的 MAC 表,现在有相应的记录,请思考如何得来。随着网络通信的增加,各交换机都将生成自己完整的 MAC 表,此时交换机的交换速度就是最快的!

    展开全文
  • Cisco Packet Tracer实验

    2020-12-19 10:59:55
    本文通过Cisco Packet Tracer实验,熟悉网络的一些协议与算法。通过构建网络拓扑结构,以及对网络的配置,得到了一些个人的思考与理解 文章目录摘要::sun_with_face: CPT软件简单使用:sun_with_face: 用交换机构建...

    摘要:

    本文通过Cisco Packet Tracer实验,熟悉网络的一些协议与算法。通过构建网络拓扑结构,以及对网络的配置,得到了一些个人的思考与理解

    🌞 CPT软件简单使用

    加入主机和集线器:

    配置网络:

    拖动发消息:

    先是简单的试下,接下来就是正式实验了。


    🌞 用交换机构建 LAN

    构建拓扑结构如下的局域网:

    配置信息

    机器名IP子网掩码
    主机0192.168.1.1255.255.255.0
    主机1192.168.1.2255.255.255.0
    主机2192.168.2.1255.255.255.0
    主机3192.168.2.2255.255.255.0

    主机0 ping 主机1

    可以看到ping通

    再由主机1 ping 主机3

    可以看到没有ping通;

    同样的操作实验,得到

    主机0可以ping通主机1,ping不同主机2、3

    主机2可以ping通主机3,ping不同主机0、1

    ✍️ 原因就是主机0,1是在一子网下,主机2,3是在另一个子网下。在同一子网下的主机可以相互ping同而在不同子网下的主机就无法ping通。

    如果改子网掩码都为255.255.0.0,那么这些主机都会位于同一子网下,再次实验:

    依次操作,可以返现可以ping通了。证明上面的想法是对的。

    集线器 Hub 是工作在物理层的多接口设备,它与交换机的区别是什么?请在 CPT 软件中用 Hub 构建网络进行实际验证。

    验证方式:通过simulation

    个人理解,集线器Hub相当于就是把端口连接起来的设备,并没有任何别的功能。当接收到了帧之后就广播出去;

    但是交换机就不同,它可以看成多端口的网桥,网桥具有转发帧,过滤帧,转换帧格式等功能。端口接收到帧后,查询地址列表,如果同端口就丢弃,不同端口就转发,找不到就广播

    如下,对三台主机分别配置网址和掩码和网关,分别在集线器连接和交换机连接尝试。得到,集线器在任何时候都会广播出去,而交换机则可以实现找到端口发送。在第一次交换机还没有构建地址表时和集线器一样都是采用广播方式

    🌞 交换机地址列表

    初始时,看到交换机MAC表为空

    但是,当PC0ping完PC1时查看MAC Table发现存的有东西了

    ✍️ 当同一子网下的主机间要进行通信的时候,该主机会地址解析协议(ARP)发一个广播,来获取IP对应的MAC地址,并存在自己的缓冲区内


    🌞 生成树协议

    交换机在目的地址未知或接收到广播帧时是要进行广播的。如果交换机之间存在回路/环路,那么就会产生广播循环风暴,从而严重影响网络性能。

    构建如下拓扑:

    这是初始时的状态。我们可以看到交换机之间有回路,这会造成广播帧循环传送即形成广播风暴,严重影响网络性能。

    随后,交换机将自动通过生成树协议(STP)对多余的线路进行自动阻塞(Blocking),以形成一棵以 Switch4 为根(具体哪个是根交换机有相关的策略)的具有唯一路径树即生成树!

    通过Simulation模拟看清整个过程

    总结生成树的过程

    首先先确认根假设为B1,然后跟广播出去,交换机比如B2,B3,B4。依次确定与根的距离,然后再广播出自己的距离,这时B2,3,4之间相互屏蔽,比如都广播至B5那里,B5判断最短路径,依次这样构建生成树。

    🌞 路由配置初步

    构建两所大学的连接

    配置好相应的网络。

    ✍️ 注意:

    • 两所大学所在不同的子网,分配左边大学为192.168.1.0/24,网关为192.168.1.1,右边大学的网络号为c,网关为192.168.3.1,两个路由器之间也是使用广域网接口相连,也是一个子网,分配网号为192.168.2.0/24
    • 两学校间相连通过路由器的广域网serial接口需要,我们需要做出如下配置
    • 在模拟的广域网连接中需注意 DCE 和 DTE 端(连线时线路上有提示,带一个时钟标志的是 DCE 端。有关 DCE 和 DTE 的概念请查阅相关资料。),在 DCE 端需配置时钟频率 64000

    然后我们对左边大学的路由器初步配置

    配置完后发现

    可以ping通该学校下的其他主机

    可以ping通网关

    ping不通另一个学校的其它主机

    大学内部各PC可以互相ping,也可以ping通网关,但是大学间就是ping不通

    ✍️ 原因:路由表尚未构建,路走不通。


    🌞 静态路由

    静态路由是非自适应性路由协议,是由网络管理人员手动配置的,不能够根据网络拓扑的变化而改变。 因此,静态路由简单高效,适用于结构非常简单的网络。我们可以使用静态路由,直接告诉路由器该怎么走

    然后进行静态路由配置:

    配置第一所大学

    框选即为告诉路由器该怎么走

    查看路由配置,S即为静态路由表

    同样的操作对另一所大学

    最终都可以互相ping通了

    下面是左边大学的主机0ping 右边大学主机2

    ✍️ 需要注意,我们的网络数量特别多时就需要配置一条缺省路由Router(config)#ip route 0.0.0.0 0.0.0.0 *.*.*.*//这样缺省就可以全部转发给这个IP了


    🌞 动态路由RIP

    动态路由协议采用自适应路由算法,能够根据网络拓扑的变化而重新计算机最佳路由。

    RIP 的全称是 Routing Information Protocol,是距离矢量路由的代表(目前虽然淘汰,但可作为我们学习的对象)。使用 RIP 协议只需要告诉路由器直接相连有哪些网络即可,然后 RIP 根据算法自动构建出路由表。

    因为我们模拟的网络非常简单,因此不能同时使用静态和动态路由,否则看不出效果,所以我们需要把刚才配置的静态路由先清除掉。

    首先清除静态路由

    no
    

    配置动态路由RIP

    配置右边大学

    配置左边大学

    查看

    看到R的一条路由,表示RIP

    此时可以ping通

    ✍️ 可以用debug ip rip开启RIP诊断,判断网络状态是否发生变化从而更新路由表no debug ip rip关闭诊断

    🌞 动态路由OSPF

    OSPF(Open Shortest Path First 开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称 IGP), 用于在单一自治系统(Autonomous System,AS)内决策路由。OSPF 性能优于 RIP,是当前域内路由广泛使用的路由协议。

    清除 RIP 路由配置:

    no router rip清除RIP路由

    然后配置OSPF路由

    配左边大学

    配右边大学

    O的一条路由,O就是OSPF

    主机之间相互ping通

    总结 RIPOSPF找不同

    • RIP:数跳数;OSPF:计算链路的度量值
    • RIP:仅和相邻路由器交换信息;OSPF:向本自治系统所有路由器发送消息,由于路由器发送的链路状态信息只能单向传送,OSPF不存在“坏消息传播得慢”的问题,更新过程的收敛性得到保证。
    • 为了使 OSPF 能够用于规模很大的网络,OSPF 将一个自治系统再划分为若干个更小的范围,叫作区域。利用洪泛法交换链路状态信息的范围局限于每一个区域而不是整个的自治系统,减少了整个网络上的通信量,减轻路由器的负担。
    • RIP:按固定的时间间隔交换路由信息(当网络拓扑发生变化时,路由器也及时向相邻路由器通告拓扑变化后的路由信息)
    • RIP协议使用运输层的用户数据包UDP来进行传送;
    • OSPF的位置在网络层,直接用IP数据报传送(其IP数据报首部的协议字段值为89)。由于OSPF构成的数据报很短,不仅减少了路由信息的通信量,而且在传送中不必分片,不会出现一片丢失而重传整个数据报的现象。

    🌞 基于端口的网络地址翻译 PAT

    首先配置主机网络

    节点名IP子网掩码网关
    交通大学PC0192.168.1.2255.255.255.0192.168.1.1
    交通大学PC1192.168.1.3255.255.255.0192.168.1.1
    重庆大学PC28.8.8.2255.255.255.08.8.8.1
    重庆大学 PC38.8.8.3255.255.255.08.8.8.1

    配置路由器接口:

    接口名IP子网掩码
    交通大学 Router2 以太网口192.168.1.1255.255.255.0
    交通大学 Router2 广域网口202.202.240.1255.255.255.0
    重庆大学 Router3 以太网口8.8.8.1255.255.255.0
    重庆大学 Router3 广域网口202.202.240.2255.255.255.0

    重庆大学的PC网络配置模拟外部/公网IP地址,重庆大学和交大的广域网口配置变化

    然后进行OSPF路由配置

    交大:

    重大:

    Router>en   // 从普通模式进入特权模式
    Router#conf t   // 进入全局配置模式
    Router(config)#router ospf 1   // 启用 OSPF 路由协议,进程号为1
    Router(config-router)#network 202.202.240.0 0.0.0.255 area 0   // 自治域0中的属于202.202.240.0/24网络的所有主机(反向掩码)参与 OSPF
    Router(config-router)#network 8.8.8.0 0.0.0.255 area 0   // 自治域0中的属于8.8.8.0/24网络的所有主机(反向掩码)参与 OSPF
    

    PC0pingPC2可以ping通:

    重大丢包配置:

    Router>en   // 从普通模式进入特权模式
    Router#conf t   // 进入全局配置模式
    Router(config)#access-list 1 deny 192.168.1.0 0.0.0.255  // 创建 ACL 1,丢弃/不转发来自 192.168.1.0/24 网络的所有包
    Router(config)#access-list 1 permit any  // 添加 ACL 1 的规则,转发其它所有网络的包
    Router(config)#int s0/0   // 配置广域网口
    Router(config-if)#ip access-group 1 in  // 在广域网口上对进来的包实施 ACL 1 中的规则,实际就是广域网口如果收到来自 192.168.1.0/24 IP的包即丢弃
    

    同上测试网络发现ping不通 提示Destination host unreachable信息

    Simulation模拟

    配置 NAT

    配置好后再次测试网络:

    可以看到网络已经通了,我们用show ip nat translations看翻译过程

    ✍️ 可以看到内部地址已经被翻译成了外部地址,这就是NAT网络地址转换的作用,完美解决了IP地址不足的问题,还能隐藏保护网络内部的计算机。


    🌞 虚拟局域网VLAN

    VLAN(Virtual Local Area Network)即虚拟局域网。通过划分 VLAN,我们可以把一个物理网络划分为多个逻辑网段即多个子网。

    划分 VLAN 后可以杜绝网络广播风暴,增强网络的安全性,便于进行统一管理等

    构建拓扑网

    Cisco 2960 交换机是支持 VLAN 的交换机,共有 24 个 100M 和 2 个 1000M 以太网口。默认所有的接口都在 VLAN 1 中,故此时连接上来的计算机都处于同一 VLAN,可以进行通信。

    配置VLAN

    Switch>en
    Switch#conf t
    Switch(config)#vlan 10    // 创建 id 为 10 的 VLAN(缺省的,交换机所有接口都属于VLAN 1,不能使用)
    Switch(config-vlan)#name computer    // 设置 VLAN 的别名
    Switch(config-vlan)#exit
    Switch(config)#int vlan 10    // 该 VLAN 为一个子网,设置其 IP,作为该子网网关
    Switch(config-if)#ip address 192.168.0.1 255.255.255.0
    Switch(config-if)#exit
    Switch(config)#vlan 20    // 创建 id 为 20 的 VLAN
    Switch(config-vlan)#name communication    //设置别名
    Switch(config-vlan)#exit
    Switch(config)#int vlan 20
    Switch(config-if)#ip addr 192.168.1.1 255.255.255.0
    Switch(config-if)#exit
    Switch(config)#vlan 30    // 创建 id 为 20 的 VLAN
    Switch(config-vlan)#name electronic    // 设置别名
    Switch(config-vlan)#exit
    Switch(config)#int vlan 30
    Switch(config-if)#ip add 192.168.2.1 255.255.255.0
    Switch(config-if)#exit
    Switch(config)#int range f0/1-8    // 成组配置接口(1-8)
    Switch(config-if-range)#switchport mode access    // 设置为存取模式
    Switch(config-if-range)#switchport access vlan 10    // 划归到 VLAN 10 中
    Switch(config-if-range)#exit
    Switch(config)#int range f0/9-16
    Switch(config-if-range)#switchport mode access
    Switch(config-if-range)#switchport access vlan 20
    Switch(config-if-range)#exit
    Switch(config)#int range f0/17-24
    Switch(config-if-range)#switchport mode access
    Switch(config-if-range)#switchport access vlan 30
    Switch(config-if-range)#^Z
    Switch#show vlan // 查看 VLAN 的划分情况
    

    查看配好的VLAN

    7

    网络配置如下

    机器名连接的接口所属VLANIP子网掩码网关
    PC0F0/1VLAN 10192.168.0.2255.255.255.0192.168.0.1
    PC1F0/2VLAN 10192.168.0.3255.255.255.0192.168.0.1
    PC2F0/17VLAN 30192.168.2.2255.255.255.0192.168.2.1
    PC3F0/9VLAN 20192.168.1.2255.255.255.0192.168.1.1
    PC4F0/10VLAN 20192.168.1.3255.255.255.0192.168.1.1
    PC5F0/18VLAN 30192.168.2.3255.255.255.0192.168.2.1
    PC6F0/19VLAN 30192.168.2.4255.255.255.0192.168.2.1

    网络测试,ping同一VLAN下可以ping通

    ping不同VLAN下ping不通

    分析一下当前为何不同 VLAN 中的 PC 不能通信?网关在此起什么作用?我们的网关又在何处?如何发起广播测试?

    答:

    1. VLAN具有分割网络的作用,因此不能通信
    2. VLAN只是链路层协议,划分广播域,而不需要考虑IP;网关是用来进行协议转换的。不同的网段之间需要通信一定需要网关。
    3. 若是要发起广播测试,那么就要引入三层设备。

    🌞 虚拟局域网管理VTP

    VTP协议(VLAN Trunk Protocol),可以使VLAN的划分得到统一的规划和管理。也叫VLAN中继协议。VTP 通过 ISL 帧Cisco 私有 DTP 帧(可查阅相关资料了解)保持 VLAN 配置统一性,也被称为虚拟局域网干道协议,它是思科私有协议。 VTP 统一管理、增加、删除、调整VLAN,自动地将信息向网络中其它的交换机广播。

    构建如下拓扑结构:

    作为干线,两个 2960 交换机和核心的 3560 交换机应该使用 Gbit 口相连。这虽然不是必须,但现实中这样连接性能最好。

    3560 交换机是网络中的核心交换机,我们将其作为 VTP Server,VTP 域及 VLAN 将在其上创建和管理。

    两个 2960 交换机是是局域网中的汇聚层/接入层交换机,将作为 VTP Client,可决定加入的 VTP 域和 VLAN。

    目前该网络都属于 VLAN 1,也即这些 PC 是可以相互通信的。前面说过,无论对于性能、管理还是安全等而言,现实中我们必须进行 VLAN 划分。

    进行网络配置

    现在我们的要求是:新建两个 VLAN,然后让 PC0 和 PC1 属于 VLAN 2,PC1 和 PC3 属于 VLAN 3

    我们将在核心交换机 3560上进行如下工作:

    1. 设置为 server 模式,VTP 域为 cqjtu
    2. 新建 VLAN 2,网络号 192.168.1.0/24,网关 192.168.1.1
    3. 新建 VLAN 3,网络号 192.168.2.0/24,网关 192.168.2.1

    配置好如下:

    2960A(左边)VTP Client配置

    2960A(右边边)VTP Client同样配置

    划分结果

    主机配置

    机器名连接的交换机和接口所属VLANIP子网掩码网关
    PC02960A-F0/1VLAN 2192.168.1.2255.255.255.0192.168.1.1
    PC12960A-F0/2VLAN 3192.168.2.2255.255.255.0192.168.2.1
    PC22960B-F0/1VLAN 2192.168.1.3255.255.255.0192.168.1.1
    PC32960B-F0/2VLAN 3192.168.2.3255.255.255.0192.168.2.1

    可以发现PC0可以ping通PC2,但是PC0却ping不通PC1,这就是在不同的VLAN下,即使在同一交换机下也不能实现通信

    VLAN间的通信

    因为默认的,VLAN 间是不允许进行通信,此时我们需要所谓的独臂路由器在 VLAN 间为其进行转发!我们使用的核心交换机 3560 是个 3 层交换机,可工作在网络层,也称路由交换机,即具有路由功能,能进行这种转发操作。

    进行如下配置

    3560>en
    3560#conf t
    3560(config)#int g0/1    // 配置连接左边 2960A 交换机的接口
    3560(config-if)#switchport trunk encapsulation dot1q    // 封装 VLAN 协议
    3560(config-if)#switchport mode trunk     // 设置为中继模式
    3560(config-if)#switchport trunk allowed vlan all     // 在所有 VLAN 间转发
    3560(config-if)#exit
    3560(config)#int g0/2    // 配置连接右边 2960B 交换机的接口
    3560(config-if)#switchport trunk encapsulation dot1q    //封装 VLAN 协议
    3560(config-if)#switchport mode trunk     // 设置为中继模式
    3560(config-if)#switchport trunk allowed vlan all     // 在所有 VLAN 间转发
    3560(config-if)#exit
    3560(config)#ip routing    // 启用路由转发功能
    

    然后再测试网络

    发现各VLAN都通信正常了。

    上述过程中难免会遇到一些问题,比较严重的就是一个路由器可能形成瓶颈

    🌞 DHCP、DNS及Web服务器简单配置

    首先,构建如图所示的拓扑结构:

    然后进行配置,Server-PT同时作为DNS、DHCP及Web服务器,各客户机无需配置。通过自动获取网络地址,然后设置server-PT的IP为19.89.6.4/24,然后进行如下相关配置:

    机器名配置项目说明
    ServerHTTP开启即可
    ServerDNS19.89.6.4:www.google.com、www.baidu.com
    ServerDHCP地址池开始地址:19.89.6.10/24,并返回DNS地址
    PC网络配置自动获取

    具体操作如下

    服务器:

    1、网路配置

    2、HTTP开

    3、DHCP设置如下

    4、DNS添加记录

    最后对PC进行动态获取IP配置

    然后打开浏览器,网站输入wwww.google.com即可进入网页

    做了稍微的改动:

    🌞 总结

    通过实验,我对计算机网络有了更深入的认识,从数据链路层的生成树协议、VLAN划分到网络层路由的一些路由算法,再到DHCP、DNS、HTTP协议的认识。都有个更好的了解。通过对路由器的配置我也学习到了一些基本路由配置的语法。感觉收获很大。计算机网络就是考虑如何实现主机之间的连通与共享。在这次实操中,与网络测试语句,让我理解了一个建网的过程。收获颇丰。

    参考:

    https://qige.io/network/netlab/index.html#3

    展开全文
  • Cisco Packet Tracer 实验教程

    万次阅读 多人点赞 2017-04-20 11:02:54
    Cisco Packet Tracer 实验教程 本笔记的实验来源是上学校计算机网路课程时的实验资料,我稍微整理了一些,在实现后的命令行添加了一些注释,实现不是唯一的,我的实现也不一定是最优的,如果有错谬,敬请指正...

    Cisco  Packet Tracer 实验教程


    本笔记的实验来源是上学校计算机网路课程时的实验资料,我稍微整理了一些,在实现后的命令行添加了一些注释,实现不是唯一的,我的实现也不一定是最优的,如果有错谬,敬请指正;

    以下条目直接链接到我的为知笔记的外链,方便及时修改错误;


    01. 开篇:组建小型局域网 

    02.  交换机的基本配置和管理

    03. 交换机的Telnet远程登陆配置

    04. 交换机的端口聚合配置

    05. 交换机划分Vlan配置

    06. 三层交换机实现VLAN间路由

    07. 快速生成树协议

    08. 路由器的基本配置和Talent配置

    09. 路由器单臂路由配置

    10. 路由器静态路由配置

    11. 路由器RIP动态路由配置

    12. 路由器OSPF动态路由配置

    13. 路由器综合路由配置

    14. 标准IP访问控制列表配置

    15. 扩展IP访问控制列表配置

    16. 网络地址转换NAT配置

    17. 网络端口地址转换NAPT配置


    展开全文
  • 思科Cisco Packet Tracer实验 标准 IP 访问控制 备注:本实验在 Cisco Packet Tracer 7.2.1 中完成,其它版本尚未测试。 实验目的: (1) 理解标准 IP 访问控制列表的原理及功能 (2) 能够配置 IP 访问控制 实验...
  • Cisco Packet Tracer实验案例及源文件,内容比较全面,而且实用。
  • 文章目录Cisco Packet Tracer 实验一、直接连接两台 PC 构建 LAN二、 Cisco Packet Tracer 实验 本部分实验共有 15 个,需使用 Cisco Packet Tracer 软件完成。 一、直接连接两台 PC 构建 LAN 将两台 PC 直接连接...
  • 计算机网络基础实验Cisco Packet Tracer 实验)-附件资源
  • Cisco Packet Tracer实验及实训

    万次阅读 多人点赞 2019-10-24 18:00:01
    Cisco Packet Tracer实验及实训,主要参照于路由和交换技术实验实训完成。本文中实现RSPAN配置实验、VTP配置实验、交换式以太网实验、交换机VLAN远程配置实验、交换机远程配置实验、单交换机VLAN配置实验、容错实验...
  • Cisco Packet Tracer 实验指导、、 【共5讲】 Cisco交换机、、路由配置等网络技术
  • 计算机网络—Cisco Packet Tracer 实验

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,338
精华内容 2,135
关键字:

ciscopackettracer实验