精华内容
下载资源
问答
  • 1. 基于端口的VLAN 基于端口的VLAN的划分是最简单、最有效的VLAN划分方法。该方法只需网络管理员针对于网络设备的交换端口进行重新分配组合在不同的逻辑网段中即可。而不用考虑该端口所连接的设备是什么。 2. 基于...
  • 华为hcie示例,已通过。 使用ensp打开即可。 有修改均已在示例中注明。
  • 详细解答华为S5700交换机, VLAN划分 和 ACL配置命令,非常适合新手
  • vlan划分

    千次阅读 2019-09-02 18:03:24
    1.为什么要进行VLAN划分 过大的广播域,造成带宽的浪费; mac地址表过大,造成转发效率低; 不够安全; 一个VLAN=一个网段=一个广播域 2.VLAN如何来进行划分? (1)静态划分:基于端口 (2)动态划分:基于mac地址 ...

    1.为什么要进行VLAN划分
    过大的广播域,造成带宽的浪费;
    mac地址表过大,造成转发效率低;
    不够安全;
    一个VLAN=一个网段=一个广播域
    2.VLAN如何来进行划分?
    (1)静态划分:基于端口
    (2)动态划分:基于mac地址
    3.VLAN的范围:0——4095
    其中0和4095是保留vlan。
    交换机的默认所有端口都属于vlan1,vlan1不能被修改或者删除。
    常用的vlan:2——1001(扩展vlan 1025——4094)
    4.VLAN的划分命令
    (1)第一步:创建vlan
    SW1(config)#vlan 10 //创建vlan10
    SW1(config-vlan)#name xiaoshou //命名为xiaoshou
    SW1(config-vlan)#exit
    SW1(config)#vlan 20
    SW1(config-vlan)#name caiwubu
    SW1(config-vlan)#exit
    (2)第二步:把接口加入到vlan中
    SW1(config)#int range f0/3 - 4 //进入接口,多个接口同时操作可以用range
    SW1(config-if-range)#switchport mode access //接口模式为access
    SW1(config-if-range)#switchport access vlan 20 //把接口加入到相应的vlan20中
    (3)第三步:检查vlan的命令
    SW1#show vlan brief
    5.Trunk链路(中继链路):在一条物理链路上,可以承载多个vlan。
    应用:设备之间(交换机之间;交换机和路由器之间)
    (1)trunk的原理:把原始的数据帧加入了新的标签,破坏了原来的“帧格式”。——在trunk链路上传输的不是原始的数据帧。
    (2)trunk链路标记vlan的方式:ISL(Cisco的私有协议,在帧的外边插入了30Byte);
    IEEE 802.1 q(在数据帧的内部插入了4Byte;工业标准)。
    (3)配置:
    SW1(config)#int f0/5
    SW1(config-if)#switchport mode trunk #把接口加入到trunk
    SW1(config-if)#switchport trunk allowed vlan all #允许所有vlan通过
    (4)查询命令:
    SW4#show interfaces trunk #查看trunk链路
    (5)对vlan进行过滤的命令:
    SW1(config)#int f0/5
    SW1(config-if)#switchport trunk allowed vlan ?
    WORD VLAN IDs of the allowed VLANs when this port is in trunking mode
    all all VLANs //允许所有vlan通过(白名单)
    remove remove VLANs from the current list //从当前列表中移除某个vlan
    except all VLANs except the following //从允许的列表中排除某个vlan(不允许通过)
    none no VLANs //拒绝所有vlan通过(黑名单)
    add add VLANs to the current list //这个列表的vlan允许通过
    6.Native Vlan(本征vlan):在交换机中默认就是vlan1.
    (1)交换机收到一个来自Native vlan的数据,会不打标签发送(原始数据帧);
    (2)如果交换机收到一个原始数据帧,会把数据帧广播到Native vlan 的端口;
    7.DTP协议(Dynamic Trunk Protocol):动态trunk协议,用来协商链路是否要成为trunk。
    DTP协议的配置;
    SW1(config-if)#switchport mode dynamic ?
    auto Set trunking mode dynamic negotiation parameter to AUTO //自动协商
    desirable Set trunking mode dynamic negotiation parameter to DESIRABLE //期望成为trunk
    在协商过程中,trunk可以和trunk/desirable/auto
    desirable和desirable/auto
    access和任何一种也不能协商为trunk链路;两个auto也不能协商为trunk。
    8.EtherChannel (以太通道):解决交换机之间链路的冗余问题,可以提高网络的高可用性;还可以增加带宽。
      interface  range  FastEthernet0/4  - 5
      channel-group 1 mode on        //把多个链路进行捆绑,编号为1
      switchport mode trunk           //设置为trunk链路
      SW2#do show etherchannel summary     //检查以太通道的命令,SU标准二层以太通道链路正常。

    展开全文
  • VLAN划分

    千次阅读 2020-06-14 15:08:21
    Vlan划分步骤及命令详解 步骤一:了解基础命令 交换机的基本配置模式: 用户模式:switch> 特权模式:Switch# 进入方法:在默认的用户模式下输入:enable 进入。 退出方法:输:exit 退回到用户模式。 注意用户...

    Vlan划分步骤及命令详解

    步骤一:了解基础命令

    交换机的基本配置模式:

    用户模式:switch>

    特权模式:Switch#

    进入方法:在默认的用户模式下输入:enable 进入。

    退出方法:输:exit 退回到用户模式。

    注意用户模式和特权模式的前面代码的区别:一个是switch>;一个是Switch#。

    VLAN模式:Switch(vlan)#

    进入方法:从#模式输入 vlan database 进入

    全局配置模式:

    Switch(config)#

    进入方法:从#模式输入 config terminal 进入,也可以使用简写conf t 进入

    接口配置模式:

    Switch(config-if)#

    进入方法:从(config)#模式输入 interface+接口号进入 //同时分配多个接口要加一个range

    要记住这些交换机的配置模式,要知道如何进入和退出,也有能看懂当前处于哪个模式下,在所有模式中,输入exit返回上级,输入end或ctrl+z退出。

    VLAN的常用配置命令:

    交换机没有被划分VLAN的时候,交换机默认只有VLAN1,所有的端口都在VLAN1里面,所以我们是不能创建也不能删除VLAN1的。

    创建VLAN

    Switch#vlan database (进入VLAN数据库)

    Switch(vlan)# vlan 1 name vlan10

    switch(vlan)# vlan 2 name vlan20

    第一条命令:进入VLAN数据库

    第二条命令:创建一个名称为VLAN10 的 VLAN 1
    第三条命令:创建一个名称为VLAN20 的 VLAN 2

    这里Name属性最好定义一下,如果不定义会和默认VLAN名称冲突,这样一一对应比较好。

    端口划入VLAN

    Switch(config)#interface fa0/1

    Switch(config-if)#switchport access vlan 10

    第一条命令的意思是:进入接口fa0/1,这里的0表示第1个插槽,1表示第2个端口。(设备第一个端口通常为0,第二个端口通常为1)。

    第二条命令:把fa0/1这个端口划分给VLAN 10 这样配置之后,接在这个端口的所有设备就属于VLAN 10 了。

    查看VLAN信息

    Switch#show vlan 查看所有VLAN信息

    Switch#show vlan id 10 查看vlan 10的信息

    删除VLAN

    switch#vlan database

    Switch(vlan)#no vlan 10

    删除VLAN 10后,所有分配给VLAN10的端口都变回非活动状态,直到下次再次分配给别的VALN为止。

    一个VLAN可以有多个端口,如果要将某个端口从VLAN中删除

    Switch(config)# interface f0/2

    Switch(config-if)#no switchport access vlan 10

    开始步骤

    一个简单的VLAN划分,将终端0-2和9-11划分为 vanl 1 ,其余的划分为vlan 2
    一个简单的VLAN划分,将终端0-2和9-11划分为 vanl 1 ,其余的划分为vlan 2
    首先我们需要进行创建VLAN,我们需要创建一个vlan 1 和一个vlan 2 ,并且命名
    Switch>en
    Switch>enable
    Switch#vlan d
    Switch#vlan database
    Switch(vlan)#
    Switch(vlan)#vl
    Switch(vlan)#vlan 1 name vlan1
    A default VLAN may not have its name changed.
    Switch(vlan)#vl
    Switch(vlan)#vlan 2 name vlan2
    VLAN 2 added:
    Name: vlan2
    Switch(vlan)#exit

    创建好vlan后我们需要将计算机终端分配给各自的vlan
    在这里插入图片描述
    Switch#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#in
    Switch(config)#interface r
    Switch(config)#interface range f0/2-4
    Switch(config-if-range)#sw
    Switch(config-if-range)#switchport a
    Switch(config-if-range)#switchport access v
    Switch(config-if-range)#switchport access vlan 2
    Switch(config-if-range)#exit
    Switch(config)#int
    Switch(config)#interface r
    Switch(config)#interface range f0/5-7
    Switch(config-if-range)#sw
    Switch(config-if-range)#switchport a
    Switch(config-if-range)#switchport access v
    Switch(config-if-range)#switchport access vlan 1
    Switch(config-if-range)#exit
    Switch(config)#

    如此便将6太计算机分配成功
    但是我们还需要将f0/1划分为串口,让它可以让不同的vlan通过

    Switch(config)#interface f0/1
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#switchport trunk allowed v
    Switch(config-if)#switchport trunk allowed vlan
    如此配置好一个交换机了
    我们同理配置另外一台交换机就完成vlan的划分了

    展开全文
  • VLAN划分与互联.ppt

    2019-09-08 19:20:07
    VLAN划分方法 基于端口划分的VLAN 基于MAC地址划分VLAN 基于网络层协议划分VLAN 根据IP组播划分VLAN
  • VLan划分命令、详细的VLAN划分方法
  • VLAN划分及配置注意事项

    千次阅读 2021-03-13 11:05:54
    VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。VLAN内的主机间可以直接通信,...一、基于接口的VLAN划分 1、按端口划分VLAN 许多VLAN厂商都利用交换机的端

    VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。VLAN内的主机间可以直接通信,而VLAN间不能直接通信,从而将广播报文限制在一个VLAN内。VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点:网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。

    一、基于接口的VLAN划分

    1、按端口划分VLAN

    许多VLAN厂商都利用交换机的端口来划分VLAN成员。被设定的端口都在同一个广播域中。例如,一个交换机的1,2,3,4,5端口被定义为虚拟网AAA,同一交换机的6,7,8端口组成虚拟网BBB。这样做允许各端口之间的通讯,并允许共享型网络的升级。但是,这种划分模式将虚拟网限制在了一台交换机上。第二代端口VLAN技术允许跨越多个交换机的多个不同端口划分VLAN,不同交换机上的若干个端口可以组成同一个虚拟网。以交换机端口来划分网络成员,其配置过程简单明了。因此,从目前来看,这种根据端口来划分VLAN的方式仍然是最常用的一种方式。

    2、按MAC地址划分VLAN

    这种划分VLAN的方法是根据每个主机的MAC地址来划分,即对每个MAC地址的主机都配置它属于哪个组。这种划分VLAN方法的最大优点就是当用户物理位置移动时,即从一个交换机换到其他的交换机时,VLAN不用重新配置,所以,可以认为这种根据MAC地址的划分方法是基于用户的VLAN,这种方法的缺点是初始化时,所有的用户都必须进行配置,如果有几百个甚至上千个用户的话,配置是非常累的。而且这种划分的方法也导致了交换机执行效率的降低,因为在每一个交换机的端口都可能存在很多个VLAN组的成员,这样就无法限制广播包了。另外,对于使用笔记本电脑的用户来说,他们的网卡可能经常更换,这样,VLAN就必须不停地配置。

    3、按网络层划分

    这种划分VLAN的方法是根据每个主机的网络层地址或协议类型(如果支持多协议)划分的,虽然这种划分方法是根据网络地址,比如IP地址,但它不是路由,与网络层的路由毫无关系。这种方法的优点是用户的物理位置改变了,不需要重新配置所属的VLAN,而且可以根据协议类型来划分VLAN,这对网络管理者来说很重要,还有,这种方法不需要附加的帧标签来识别VLAN,这样可以减少网络的通信量。这种方法的缺点是效率低,因为检查每一个数据包的网络层地址是需要消耗处理时间的(相对于前面两种方法),一般的交换机芯片都可以自动检查网络上数据包的以太网帧头,但要让芯片能检查IP帧头,需要更高的技术,同时也更费时。当然,这与各个厂商的实现方法有关。

    4、按IP组播划分

    IP组播实际上也是一种VLAN的定义,即认为一个组播组就是一个VLAN,这种划分的方法将VLAN扩大到了广域网,因此这种方法具有更大的灵活性,而且也很容易通过路由器进行扩展,当然这种方法不适合局域网,主要是效率不高。

    5、基于规则的VLAN

    也称为基于策略的VLAN。这是最灵活的VLAN划分方法,具有自动配置的能力,能够把相关的用户连成一体,在逻辑划分上称为“关系网络”。网络管理员只需在网管软件中确定划分VLAN的规则(或属性),那么当一个站点加入网络中时,将会被“感知”,并被自动地包含进正确的VLAN中。同时,对站点的移动和改变也可自动识别和跟踪。采用这种方法,整个网络可以非常方便地通过路由器扩展网络规模。有的产品还支持一个端口上的主机分别属于不同的VLAN,这在交换机与共享式Hub共存的环境中显得尤为重要。自动配置VLAN时,交换机中软件自动检查进入交换机端口的广播信息的IP源地址,然后软件自动将这个端口分配给一个由IP子网映射成的VLAN。

    6、按用户定义、非用户授权划分

    基于用户定义、非用户授权来划分VLAN,是指为了适应特别的VLAN网络,根据具体的网络用户的特别要求来定义和设计VLAN,而且可以让非VLAN群体用户访问VLAN,但是需要提供用户密码,在得到VLAN管理的认证后才可以加入一个VLAN。[4]

    以上划分VLAN的方式中,基于端口的VLAN端口方式建立在物理层上;MAC方式建立在数据链路层上;网络层和IP广播方式建立在第三层上。

    图5-17 基于接口的VLAN划分组网图

    图片

     

    某数据中心的交换机Switch,根据不同用户对接口的需求,将每个用户所拥有的接口划分到不同的VLAN,实现数据中心中不同用户业务的完全隔离。可以认为每个用户拥有独立的"虚拟交换机",每个VLAN就是一个"虚拟工作组"。

    基于MAC的VLAN划分

    图5-18 基于MAC的VLAN划分组网图

    图片

     

    如所示,某数据中心中,UserA初始与SwitchA相连。由于用户地点调整,需要将UserA调整接入交换机的另一个接口。为了保证UserA在改变地点后,仍然能够与UserC继续通信。可在交换机SwitchA上配置基于MAC地址划分VLAN。只要UserA的MAC地址不变,UserA改变接入接口时,并不影响VLAN的划分,不需要更改配置。

    二、 VLAN间通信

    VLAN间互通有两种方式,以下分别介绍。

    多个VLAN属于同一个设备

    图5-19 多个VLAN属于同一个设备互通组网图

    图片

     

    如所示,如果VLAN2、VLAN3和VLAN4仅属于SwitchA,即VLAN2、VLAN3和VLAN4不是跨交换机的VLAN,可在SwitchA上为每个VLAN配置一个虚拟路由接口,实现VLAN2、VLAN3和VLAN4间的路由。

    多个VLAN跨越设备

    图5-20 多个VLAN跨越设备互通组网图

    图片

     

    如所示,VLAN2、VLAN3和VLAN4是跨交换机的VLAN,可在SwitchA和SwitchB上为每个VLAN配置一个虚拟路由接口。除此以外,还需要在SwitchA和SwitchB之间配置静态路由或运行路由协议。

    三、 VLAN Aggregation

    图5-21 VLAN Aggregation应用组网图

    图片

     

    如所示,共有4个VLAN,如果VLAN间需要互通,在Switch上要为每个VLAN配置一个IP地址。

    将VLAN21和VLAN22聚合到Super VLAN 2中;将VLAN31和VLAN32聚合到Super VLAN 3中。这样只需在Switch上为Super VLAN分配IP地址,节约了IP地址资源。

    在Switch上配置VLAN间的Proxy ARP,使同一Super VLAN下的不同Sub VLAN间的用户可以互通。

    四、 配置任务概览

    介绍VLAN的配置任务。

    VLAN的配置任务如表5-7所示。

    表5-7 VLAN配置任务概览

    五、 配置注意事项

    介绍VLAN的配置注意事项。

    涉及网元

    无需其他网元配合。

    License支持

    VLAN特性是交换机的基本特性,无需获得License许可即可应用此功能。

    版本支持

    表5-8 支持本特性的最低软件版本

    特性依赖和限制

    · 建议独立规划业务VLAN和管理VLAN,以便业务VLAN上发生的任何广播风暴不会影响到交换机的管理。

    · 实际运用中,Trunk接口需要透传哪些VLAN就透传哪些VLAN,不建议使用port trunk allow-pass vlan all命令透传所有VLAN。

    · VLAN 1是系统自带的VLAN,不需要创建,也不可以删除,不能配置为管理VLAN或Super-VLAN。在骨干网设备上,建议取消接口加入VLAN 1,从而避免广播风暴。

    · 对于CE6870EI,基于MAC地址划分VLAN功能与端口安全功能、MAC地址学习限制规则冲突。

    · 除CE6870EI和CE6880EI外的其他设备,基于MAC地址划分的VLAN不支持基于VLAN的镜像。

    · 对于CE6870EI,基于MAC地址划分VLAN功能时配置mac-vlan enable或undo mac-vlan enable命令后会有少量报文丢弃,请谨慎操作。

    · 对于CE6870EI,基于子网划分的VLAN做三层转发时,需要配置接口的PVID与关联子网的VLAN ID相同。

    · 当接口配置了PVID,并且通过执行命令encapsulation untag配置二层子接口接收不带VLAN Tag的报文,如果二层子接口状态为Up,则untag的报文通过二层子接口接入VXLAN进行转发;如果二层子接口状态为Down,则通过PVID进行转发。

    · QinQ二层子接口上封装的外层VLAN不能和对应二层主接口配置的缺省VLAN以及允许通过的VLAN相同。

    · VLAN、VXLAN、Carrier VLAN、主接口以及单板互通模式为增强模式时的Eth-Trunk接口共享系统资源,系统资源不足可能会导致这些特性的配置失败。

    · 保留VLAN

    · 保留VLAN与普通VLAN相冲突,配置的保留VLAN不能作为普通VLAN使用。

    · 创建的保留VLAN只有在设备重启后才会生效,正在使用的VLAN不能配置为保留VLAN。

    · 对于CE6855HI、CE7855EI的三层主接口专用保留VLAN:

    · 不用重启即可生效。可以为三层主接口配置多个保留VLAN范围段,最多支持8段,且不同的主接口专用的保留VLAN范围不允许有重叠。

    · 执行命令undo vlan reserved for main-interface startvlanid to endvlanid取消保留VLAN范围时,不支持取消部分保留VLAN,必须整段范围取消,且如果有主接口加入了其中一个保留VLAN,则不能执行undo vlan reserved for main-interface命令。

    · 主接口专用的保留VLAN不能和通过执行命令vlan reserved配置的二层保留VLAN范围重叠。

    · 如果通过GVRP学习到的动态VLAN属于主接口专用的保留VLAN范围内,则学习不到该动态VLAN。

    · 在SVF系统中,通过执行命令encapsulation dot1q vid vid配置二层子接口的VID不能是该主接口专用的保留VLAN范围段中的VLAN ID。

    · VLAN聚合

    · 配置某VLAN为Super-VLAN后,该VLAN类型改变为super,不允许任何物理接口加入该VLAN。

    · 一个VLAN不能同时加入多个不同的Super-VLAN中。

    · Super-VLAN与Sub-VLAN必须为不同的VLAN。

    · Super-VLAN对应的VLANIF接口配置IP地址后,Proxy ARP才能生效。

    · MUX VLAN

    · 使能MUX VLAN功能的接口不能加入同一个MUX VLAN组中的其他VLAN。

    · MUX VLAN组中的所有成员VLAN必须在同一个STP实例中,否则会导致流量不通或者有成环风险。对于QinQ和VLAN Mapping的成员VLAN,也是如此。

    · Access类型接口只能加入一个MUX VLAN组,Trunk、Hybrid类型接口可以加入多个MUX VLAN组,最多可以加入32个MUX VLAN组。

    · 如果指定VLAN已经用于Principal VLAN,那么该VLAN不能再在VLAN Mapping、VLAN Stacking、Super-VLAN、Sub-VLAN的配置中使用。

    · 如果指定VLAN已经用于Group VLAN或Separate VLAN,那么该VLAN不能再用于创建VLANIF接口,或者在VLAN Mapping、VLAN Stacking、Super-VLAN、Sub-VLAN的配置中使用。

    · 禁止接口MAC地址学习功能或限制接口MAC地址学习数量会影响MUX VLAN功能的正常使用。

    · MUX VLAN功能与接口安全功能、基于VLAN ID的灵活QinQ功能、VBST功能均互斥,不能同时配置。

    · 对于同一个VLAN,不支持同时配置CE VLAN和MUX VLAN。

    · 对于除CE6810LI外的其他设备,MUX VLAN级联场景中,Principal VLAN(主VLAN)支持创建VLANIF接口,但该VLANIF接口不能对Sub VLAN(从VLAN)上送的流量进行三层转发。

    · 对于CE6810LI,Principal VLAN(主VLAN)和Sub VLAN(从VLAN)均不支持创建VLANIF接口。

    · VLAN流量统计

    · 对于CE6870EI,针对MUX VLAN的流量统计功能无效。

    · 流量统计信息是累增的,系统不会自动清除。如需清空VLAN的流量,可执行reset vlan statistics命令清除指定VLAN的统计信息。

    · 流量统计功能需要占用系统资源,系统资源不足可能会导致配置失败,请在不需要流量统计时及时关闭此功能。

    · 对于V100R006C00之前的版本,对于所有款型设备,由于VLAN流量统计->MQC流量统计->VLANIF接口流量统计(这三个流量统计功能存在优先级顺序,优先级高低顺序从左至右),同时配置时只有优先级高的流量统计功能生效。从V100R006C00版本开始,对于CE6850HI、CE6850U-HI、CE6851HI、CE6855HI、CE6860EI、CE6870EI、CE7850EI、CE7855EI、CE8850、CE8860EI,VLAN的流量统计与这二者不互斥,对于CE6880EI,VLAN流量统计功能优先级高于VLANIF流量统计。

    · 对于CE6870EI,出方向的流量统计不包括三层转发的报文。

    · 对于CE6870EI设备上绑定了EVN实例的VLAN,其流量统计出方向计数不准确。

    · 对于CE6880EI交换机,当转发报文的模式配置为直通(Cut Through)模式时,设备不支持VLAN流量统计功能。如果需要使用该功能,建议执行命令assign forward mode store-and-forward将转发报文模式修改为存储转发模式。

    · VLANIF流量统计

    使用undo statistics enable命令关闭VLANIF的流量统计功能后,将终止对VLANIF流量的统计,以前统计的流量信息会被清空。

    使用VLANIF接口的流量统计可能对转发性能产生影响(如在满端口线速转发时可能会导致部分端口不能线速转发),请在必要的场景下合理使用。

    对于CE6880EI交换机:

    · 若VLANIF接口对应的VLAN下使能了流量统计功能,VLANIF接口统计三层流量,VLAN统计二层流量。

    · 不支持区分单播和组播报文分别统计,不支持区分IPv4和IPv6报文类型统计。

    · 不支持统计错误报文和设备本身产生发送出的报文(如ping报文)。

    对于CE6870EI交换机:

    · VLANIF接口的流量统计功能需要占用系统ACL资源,由于系统ACL资源有限,打开过多的流量统计将会导致其它功能申请不到ACL资源。最多支持对100个VLANIF接口进行流量统计。

    · 不支持统计错误报文、MPLS报文和携带VXLAN封装的报文,不支持区分单播和组播报文分别统计。

    · 仅支持对IPv4单播报文的统计,其中不包括带有IPv4封装头的GRE报文、IPv6 over IPv4报文和EVN特性封装使用的VXLAN报文。

    · 不支持统计设备本身产生发送出的报文(如ping报文)。

    · 由于M-LAG单向隔离机制>MQC(流量监管、流量统计、报文过滤)>查询指定五元组信息以及源MAC地址、目的MAC地址的报文的出接口>本地VLAN镜像>sFlow>NetStream>VLANIF接口统计(此类业务存在优先级顺序,优先级高低顺序从左至右),在接口出方向上配置时只有优先级高的生效。例如,在VLANIF接口上同时配置报文过滤以及VLANIF接口统计,优先生效的是报文过滤。

    · 在MPLS TE隧道接口和使能MPLS TE的VLANIF接口上同时使能流量统计时,对于接收到的下一跳是TE隧道接口的报文,只会统计为MPLS TE隧道接口流量而不会统计为VLANIF接口流量。

    · 在配置VXLAN的解封装设备上,VLANIF入方向流量统计不支持统计携带VXLAN封装的报文。在配置VXLAN的封装设备上,如果设备上没有配置VXLAN流量统计功能且配置NVO3网关的增强模式为非环回模式时,VLANIF出方向流量统计支持统计携带VXLAN封装的报文,否则VLANIF出方向无法统计。

    对于除CE6870EI和CE6880EI以外的交换机:

    · VLANIF接口的流量统计功能需要占用系统ACL资源,由于系统ACL资源有限,打开过多的流量统计将会导致其它功能申请不到ACL资源。最多支持对100个VLANIF接口进行流量统计。

    · Super-VLAN和MUX VLAN对应的VLANIF接口不支持流量统计。

    · 不支持统计错误报文、MPLS报文和携带VXLAN封装的报文。

    · 不支持区分单播和组播报文分别统计。

    · 不支持统计设备本身产生发送出的报文(如ping报文)。

    展开全文
  • 交换机VLAN划分实验

    千次阅读 2018-04-10 21:37:53
    交换机VLAN划分实验一、 实验目的1、 了解VLAN原理;2、 熟练掌握二层交换机VLAN的划分方法;3、 了解如何验证VLAN的划分。二、 应用环境学校实验楼中有两个实验室位于同一楼层,一个是计算机软件实验室,一个...

    交换机VLAN划分实验

    一、       实验目的

    1、  了解VLAN原理;

    2、  熟练掌握二层交换机VLAN的划分方法;

    3、  了解如何验证VLAN的划分。

    二、       应用环境

    学校实验楼中有两个实验室位于同一楼层,一个是计算机软件实验室,一个是多媒体实验室,两个实验室的信息端口都连接在一台交换机上。学校已经为实验楼分配了固定的IP地址段,为了保证两个实验室的相对独立,就需要划分对应的VLAN,使交换机某些端口属于软件实验室,某些端口属于多媒体实验室,这样就能保证它们之间的数据互不干扰,也不影响各自的通信效率。

    三、       实验设备

    1  DCS-3926S交换机1台

    2  PC机2台

    3  Console线1根

    4  直通网线2根

    四、       实验拓扑

     

    使用一台交换机和两台PC机,还将其中PC1作为控制台终端,使用Console口配置方式;使用两根网线分别将PC1和PC2连接到交换机的RJ-45接口上。

    五、       实验要求

    在交换机上划分两个基于端口的VLAN:VLAN100,VLAN200。

    VLAN 

    端口成员 

    100

    1~8

    200

    9~16

    使得VLAN100的成员能够互相访问,VLAN200的成员能够互相访问;VLAN100和VLAN200成员之间不能互相访问。

    PC1和PC2的网络设置为:

    设备

    IP地址

    Mask

    交换机A 

    192.168.1.11 

    255.255.255.0 

    PC1 

    192.168.1.101 

    255.255.255.0 

    PC2 

    192.168.1.102 

    255.255.255.0 

    PC1、PC2接在VLAN100的成员端口1~8上,两台PC互相可以ping通;PC1、PC2接在VLAN的成员端口9~16上,两台PC互相可以ping通;PC1接在VLAN100的成员端口1~8上,PC2接在VLAN200的成员端口9~16上,则互相ping不通。

    若实验结果和理论相符,则本实验完成。

     

    六、       实验步骤

    第一步:交换机恢复出厂设置

    switch#set default

    switch#write 

    switch#reload 

    第二步:给交换机设置IP地址即管理IP。

    switch#config  

    switch(Config)#interface vlan 1        

    switch(Config-If-Vlan1)#ip address 192.168.1.11 255.255.255.0                                                                 

    switch(Config-If-Vlan1)#no shutdown    

    switch(Config-If-Vlan1)#exit      

    switch(Config)#exit               

    第三步:创建vlan100和vlan200。

    switch(Config)#

    switch(Config)#vlan 100

    switch(Config-Vlan100)#exit

    switch(Config)#vlan 200

    switch(Config-Vlan200)#exit

    switch(Config)#

    验证配置:

    switch#show vlan

    VLAN Name         Type       Media     Ports

    ---- ------------ ---------- --------- ----------------------------------------

    1    default      Static     ENET      Ethernet0/0/1       Ethernet0/0/2

                                           Ethernet0/0/3       Ethernet0/0/4

                                           Ethernet0/0/5       Ethernet0/0/6

                                           Ethernet0/0/7       Ethernet0/0/8

                                           Ethernet0/0/9       Ethernet0/0/10

                                           Ethernet0/0/11      Ethernet0/0/12

                                           Ethernet0/0/13      Ethernet0/0/14

                                           Ethernet0/0/15      Ethernet0/0/16

                                           Ethernet0/0/17      Ethernet0/0/18

                                           Ethernet0/0/19      Ethernet0/0/20

                                           Ethernet0/0/21      Ethernet0/0/22

                                           Ethernet0/0/23      Ethernet0/0/24

    100  VLAN0100     Static     ENET   !已经创建了vlan100,vlan100中没有端口;

    200  VLAN0200     Static     ENET   !已经创建了vlan200,vlan200中没有端口;

     

    第四步:给vlan100和vlan200添加端口。

    switch(Config)#vlan 100             !进入vlan 100

    switch(Config-Vlan100)#switchport interface ethernet 0/0/1-8

    !给vlan100加入端口1-8

    Set the port Ethernet0/0/1 access vlan 100 successfully

    Set the port Ethernet0/0/2 access vlan 100 successfully

    Set the port Ethernet0/0/3 access vlan 100 successfully

    Set the port Ethernet0/0/4 access vlan 100 successfully

    Set the port Ethernet0/0/5 access vlan 100 successfully

    Set the port Ethernet0/0/6 access vlan 100 successfully

    Set the port Ethernet0/0/7 access vlan 100 successfully

    Set the port Ethernet0/0/8 access vlan 100 successfully

    switch(Config-Vlan100)#exit

    switch(Config)#vlan 200              !进入vlan 200

    switch(Config-Vlan200)#switchport interface ethernet 0/0/9-16

    !给vlan200加入端口9-16

    Set the port Ethernet0/0/9 access vlan 200 successfully

    Set the port Ethernet0/0/10 access vlan 200 successfully

    Set the port Ethernet0/0/11 access vlan 200 successfully

    Set the port Ethernet0/0/12 access vlan 200 successfully

    Set the port Ethernet0/0/13 access vlan 200 successfully

    Set the port Ethernet0/0/14 access vlan 200 successfully

    Set the port Ethernet0/0/15 access vlan 200 successfully

    Set the port Ethernet0/0/16 access vlan 200 successfully

    switch(Config-Vlan200)#exit

    验证配置:

    switch#show vlan

    VLAN Name         Type       Media     Ports

    ---- ------------ ---------- --------- ----------------------------------------

    1    default      Static     ENET      Ethernet0/0/17      Ethernet0/0/18

                                           Ethernet0/0/19      Ethernet0/0/20

                                           Ethernet0/0/21      Ethernet0/0/22

                                           Ethernet0/0/23      Ethernet0/0/24

    100  VLAN0100     Static     ENET      Ethernet0/0/1       Ethernet0/0/2

                                           Ethernet0/0/3       Ethernet0/0/4

                                           Ethernet0/0/5       Ethernet0/0/6

                                           Ethernet0/0/7       Ethernet0/0/8

    200  VLAN0200     Static     ENET      Ethernet0/0/9       Ethernet0/0/10

                                           Ethernet0/0/11      Ethernet0/0/12

                                           Ethernet0/0/13      Ethernet0/0/14

                                           Ethernet0/0/15      Ethernet0/0/16

     

    第五步:验证实验。

       

    PC1位置

    PC2位置

    动作

    结果

    1-8端口

     

    PC1 ping 192.168.1.11

    不通

    9-16端口

     

    PC1 ping 192.168.1.11

    不通

    17-24端口

     

    PC1 ping 192.168.1.11

    1-8端口

    1-8端口

    PC1 ping PC2

    1-8端口

    9-16端口

    PC1 ping PC2

    不通

    1-8端口

    17-24端口

    PC1 ping PC2

    不通

     

    七、       注意事项和排错

    1、  默认情况下,交换机所有端口都属于vlan1,因此我们通常把vlan1作为交换机的管理vlan,因此vlan1接口的IP地址就是交换机的管理地址。

    2、  在DCS-3926S中,一个普通端口只属于一个vlan。

    八、       配置序列

    Switch#Show run

    Current configuration:

    !

       hostname switch

    !

    !

    Vlan 1

       vlan 1

    !

    Vlan 100

       vlan 100

    !

    Vlan 200

       vlan 200

    !

    !

    Interface Ethernet0/0/1

       switchport access vlan 100

    !

    Interface Ethernet0/0/2

       switchport access vlan 100

    !

    Interface Ethernet0/0/3

       switchport access vlan 100

    !

    Interface Ethernet0/0/4

       switchport access vlan 100

    !

    Interface Ethernet0/0/5

       switchport access vlan 100

    !

    Interface Ethernet0/0/6

       switchport access vlan 100

    !

    Interface Ethernet0/0/7

       switchport access vlan 100

    !

    Interface Ethernet0/0/8

       switchport access vlan 100

    !

    Interface Ethernet0/0/9

       switchport access vlan 200

    !

    Interface Ethernet0/0/10

       switchport access vlan 200

    !

    Interface Ethernet0/0/11

       switchport access vlan 200

    !

    Interface Ethernet0/0/12

       switchport access vlan 200

    !

    Interface Ethernet0/0/13

       switchport access vlan 200

    !

    Interface Ethernet0/0/14

       switchport access vlan 200

    !

    Interface Ethernet0/0/15

       switchport access vlan 200

    !

    Interface Ethernet0/0/16

       switchport access vlan 200

    !

    Interface Ethernet0/0/17

    !

    Interface Ethernet0/0/18

    !

    Interface Ethernet0/0/19

    !

    Interface Ethernet0/0/20

    !

    Interface Ethernet0/0/21

    !

    Interface Ethernet0/0/22

    !

    Interface Ethernet0/0/23

    !

    Interface Ethernet0/0/24

    !

    switch#

    九、       共同思考

    1、  怎样取消一个vlan。

    2、  怎样取消一个vlan中的某些端口。

    十、       课后练习

    1、  请给交换机划分三个vlan,验证vlan实验

    VLAN 

    端口成员 

    10

    1~6

    20

    7~12

    30

    13~16

    十一、   相关配置命令详解

    vlan

    命令:vlan <vlan-id>

             no vlan <vlan-id>

    功能:创建VLAN并且进入VLAN配置模式,在VLAN模式中,用户可以配置VLAN名称和为该VLAN分配交换机端口;本命令的no操作为删除指定的VLAN。

    参数:<vlan-id>为要创建/删除的VLAN的VID,取值范围为1~4094。

    命令模式:全局配置模式

    缺省情况:交换机缺省只有VLAN1。

    使用指南:VLAN1为交换机的缺省VLAN,用户不能配置和删除VLAN1。允许配置VLAN的总共数量为255个。另需要提醒的是不能使用本命令删除通过GVRP学习到的动态VLAN。

    举例:创建VLAN100,并且进入VLAN100的配置模式。

    Switch(Config)#vlan 100

    Switch(Config-Vlan100)#

     

    name

    命令:name <vlan-name>

             no name

    功能:为VLAN指定名称,VLAN的名称是对该VLAN一个描述性字符串;本命令的no操作为删除VLAN的名称。

    参数:<vlan-name>为指定的vlan名称字符串。

    命令模式:VLAN配置模式

    缺省情况:VLAN缺省VLAN名称为vlanXXX,其中XXX为VID。

    使用指南:交换机提供为不同的VLAN指定名称的功能,有助于用户记忆VLAN,方便管理。

    举例:为VLAN100指定名称为TestVlan。

    Switch(Config-Vlan100)#name TestVlan

     

    switchport interface

    命令:switchport interface <interface-list>

    no switchport interface <interface-list>

    功能:给VLAN分配以太网端口的命令;本命令的no操作为删除指定VLAN内的一个或一组端口。

    参数:<interface-list> 要添加或者删除的端口的列表,支持”;” ”-” ,如:ethernet 0/0/1;2;5 或ethernet 0/0/1-6;8。

    命令模式:VLAN配置模式

    缺省情况:新建立的VLAN缺省不包含任何端口。

    使用指南:Access端口为普通端口,可以加入VLAN,但同时只允许加入一个VLAN。

    举例:为VLAN100分配百兆以太网端口1,3,4-7,8。

    Switch(Config-Vlan100)#switchport interface ethernet 0/0/1;3;4-7;8

    switchport mode

    命令:switchport mode {trunk|access}

    功能:设置交换机的端口为access模式或者trunk模式。

    参数:trunk表示端口允许通过多个VLAN的流量;access为端口只能属于一个VLAN。

    命令模式:端口配置模式

    缺省情况:端口缺省为Access模式。

    使用指南:工作在trunk mode下的端口称为Trunk端口,Trunk端口可以通过多个VLAN的流量,通过Trunk端口之间的互联,可以实现不同交换机上的相同VLAN的互通;工作在access mode下的端口称为Access端口,Access端口可以分配给一个VLAN,并且同时只能分配给一个VLAN。

    注意在Trunk端口不允许802.1X认证。

    举例:将端口5设置为trunk模式,端口8设置为access模式。

    Switch(Config)#interface ethernet 0/0/5

    Switch(Config-ethernet0/0/5)#switchport mode trunk

    Switch(Config-ethernet0/0/5)#exit

    Switch(Config)#interface ethernet 0/0/8

    Switch(Config-ethernet0/0/8)#switchport mode access

    Switch(Config-ethernet0/0/8)#exit

    展开全文
  • VLAN 划分——基于交换机端口划分VLAN

    万次阅读 多人点赞 2018-05-12 16:23:20
    交换机作用是什么?我这里度娘一下:交换机(Switch)意为“开关”是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点...刚才提到了vlanvlan又是什么呢?同样度娘一下:VLAN(Virtual...
  • 划分虚拟网的实验报告,有截图,有子网号,Ip,子网掩码等,步骤齐全。有需要其他类似的私密。
  • Cisco思科交换机Vlan划分

    千次阅读 2021-04-28 11:07:52
    vlan技术是通过交换机上的端口进行划分不同的局域网,使得连接在同一个交换机的计算机实现计算机与计算机之间的隔离(不在同一个vlan中无法ping通),也可以使多个交换机进行网络划分。 1、试验目的 **实现同颜色...
  • vlan划分实验.pkt

    2021-07-29 17:47:24
    使用仿真器PACKET TRACER,在六节点星型网络、树型网络、总线型网络里构造Vlan并测试。(下面例子以六节点星型网络为例,全部的仿真链接在文章末尾总结处) 其中仿真要求:(主机ip地址的命名规则:192.168.学号后两...
  • VLAN划分实验

    2020-11-21 08:16:06
    VLAN划分实验 如下图四台PC的网段均为192.168.1.0/24.,在末划分vlan前都可以相互平通,在这里我就不测试了,读者可以自行测试。 任务:把vlan10划分到PC1和PC4,vlan20划分到PC2和PC3 命名交换机为S1,S2 测试PC1和...
  • vlan划分和子网划分的区别

    千次阅读 2020-11-17 14:55:19
    (2)虚拟局域网(VLAN)是一组逻辑上的设备和用户,设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样。 2、组建不同 (1)子网划分是...
  • 交换机vlan划分实验

    2020-12-20 21:59:20
    利用cisco packet tracker 熟悉交换机的vlan配置 实验工具 cisco packet tracker 拖入组件,绘制网络拓扑图 本实验中网络的最终的拓扑结构如下所示: 其中,计算机使用的是cisco packet tacker 提供的PC。 交换机...
  • VLAN是一种将局域网设备从逻辑上划分(注意,不是从物理上划分)成一个个网段,从而实现虚拟工作组的新兴数据交换技术。这一新兴技术主要应用于交换机和路由器中,但主流应用还是在交换机之中。但又不是所有交换机都...
  • 首先,分析了设计的IaaS资源池结构,对VLAN划分进行分析,提出VLAN的结构、划分方式、VLAN的配置策略,并且设计IP池管理的方案。最后,对VLAN划分与IP池管理进行测试。通过测试结果表示满足实际需求,能够使资源池...
  • 本文将详细介绍思科2950交换机VLAN划分,需要的朋友可以参考下
  • 运用Ensp进行VLAN划分

    千次阅读 2020-03-11 20:17:32
    实验一 VLAN划分及GVRP实验 (一) VLAN划分配置(2学时) 一、预备知识 交换机的Vlan划分可以分为Access、Trunk和Hybrid三种类型。Access端口是交换上用来直接连接用户终端的端口,它只允许属于该端口的缺省Vlan的...
  • 单交换机的vlan划分

    2019-09-18 15:17:55
    (1)给一台单交换机划分vlan划分vlan10,vlan20 (2)给连接的几台主机设置同一网段内的IP地址 (3)用ping命令验证同一vlan与不同vlan内主机的通讯情况 2、业务配置流程图 3、实验配置过程 (1)现有一台...
  • 传统VLAN划分
  • VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的新兴数据交换技术。那么如何实现同一路由器不同vlan之间的通信?下面就详情来看看vlan配置方式了解下
  • 计算机网络思科交换机的vlan划分的配置,适合小白
  • 交换机VLAN划分 单个交换机VLAN划分 跨交换机相同VLAN间通讯 交换机端口与MAC绑定
  • openWrt下的vlan划分

    千次阅读 2021-02-19 09:58:49
    openWrt下的vlan划分 VLAN是虚拟局域网的缩写,它是OSI层上物理网络交换机的虚拟分区。 它是一种保持网络客户端彼此分离的方法,即使它们使用相同的共享物理网络,而不设置整个子网和路由器。 它通过在网络流量上...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 24,139
精华内容 9,655
关键字:

vlan的划分