精华内容
下载资源
问答
  • vlan绑定mac-add、ip-add实现只有绑定的用户才能上网,否则与网关不通,本网段通的效果。 配置模板 LSW1:[Huawei]dis cu sysname Huawei vlan batch 2 cluster enablentdp enablendp enable drop illegal-mac alar ...

    vlan绑定mac-add、ip-add实现只有绑定的用户才能上网,否则与网关不通,本网段通的效果。

    huawei_vlan绑定mac-add、ip-add

    配置模板

    LSW1:
    [Huawei]dis cu

    sysname Huawei

    vlan batch 2

    cluster enable
    ntdp enable
    ndp enable

    drop illegal-mac alar

    user-bind static ip-address 192.168.1.1 mac-address 5489-9891-49fd vlan 1 //绑定ip、mac
    user-bind static ip-address 192.168.2.1 mac-address 5489-98a2-570a vlan 2

    diffserv domain default

    drop-profile default

    vlan 1 //开启检查功能
    arp anti-attack check user-bind enable
    vlan 2
    arp anti-attack check user-bind enable

    aaa
    authentication-scheme default
    authorization-scheme default
    accounting-scheme default
    domain default
    domain default_admin
    local-user admin password simple admin
    local-user admin service-type http

    interface Vlanif1
    ip address 192.168.1.254 255.255.255.0

    interface Vlanif2
    ip address 192.168.2.254 255.255.255.0

    interface MEth0/0/1

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094

    interface GigabitEthernet0/0/2

    huawei_vlan绑定mac-add、ip-add

    转载于:https://blog.51cto.com/9616635/2090779

    展开全文
  • 使用二层设备实现如下图所示,两个交换机之间使用端口绑定的方式以trunk连接,下联2台同网段的pc,但不属于同一个vlan,大部分的案例都是不同的vlan属于不同网段通过子接口进行通信,本示例则以纯二...

    关注我,你的眼睛会怀孕

    1c2d9d3df02fb1f15127975020696b2a.png

    一、背景介绍

    交换是疏通领域另一个知识块,与路由一样有着举足轻重的地方,本片就通过不同vlan间通信的三个实现方式来讲解交换的通信过程。

    二、不同vlan间通信实现方法

    1.使用二层设备实现

    如下图所示,两个交换机之间使用端口绑定的方式以trunk连接,下联2台同网段的pc,但不属于同一个vlan,大部分的案例都是不同的vlan属于不同网段通过子接口进行通信,本示例则以纯二层网络设备进行通信,顺便说明通信的过程。0c612e23b8f22911f180758c0d6d1426.png 
    (1)创建vlan2,并将连接pc的端口加入vlan2
    [SW1]vlan 2  [SW1-vlan2]q  
    [SW1]int e0/0/1  [SW1-Ethernet0/0/1]port link-type access  
    [SW1-Ethernet0/0/1]port default vlan 2  
    (2)创建eth-trunk接口,并将10/11接口加入eth-trunk
    [SW1]int Eth-Trunk 1  [SW1-Eth-Trunk1]int e0/0/10  [SW1-Ethernet0/0/10]eth-trunk 1  [SW1-Ethernet0/0/10]int e0/0/11  [SW1-Ethernet0/0/11]eth-trunk 1  
    (3)将eth-trunk口类型设置为trunk,并将SW1上eth-trunk口pvid改为2
    [SW1]int Eth-Trunk 1  
    [SW1-Eth-Trunk1]port link-type trunk   [SW1-Eth-Trunk1]port trunk pvid vlan 2  
    (4)通过display interface brief命令查看端口都已激活 99f5371176f76285e1e5708dfd03b5c6.png(5)再通过display port vlan查看每个端口的vlan信息,此时可以看到eth-trunk1的pvid虽然已经为2,但是默认放通vlan仍为1,1为默认放通的管理vlan,所有端口默认pvid也为1 d370c9bbd85ed81e488519763e904e0a.png 
    此时ping操作发现pc1与pc2之间无法正常通信,原因就在于尽管sw1的eth-trunk口pvid是2,但是他并没有放通vlan 
    2,sw2也是没有放通vlan 3,只有当使用命令
    [SW1]int Eth-Trunk 1  
    [SW1-Eth-Trunk1]undo port trunk allow-pass vlan 1  #取消默认放通的vlan 1,可省略[SW1-Eth-Trunk1]port trunk allow-pass vlan 2  
    再查看sw1确认vlan2已经放通,两个pc间才能正查光通信,sw2上的配置类似,不再赘述。 d1fa006bf1f7bbbd49454eb6cfb10641.png 
    通过本实例可以总结出数据通信的过程为: 
    (1)pc1发出报文从sw1的e0/0/1口进入,再通过e0/0/1口时被打上该端口的default vlan 
    (2)报文再通过eth-trunk 1口发出前先判断是否允许通过,如果没有放通,即使tag等于该端口的pvid也会丢弃,本例中pvid与tag相同,所以从eth-trunk 1口出来时剥离tag变为纯以太网帧 
    (3)报文进入sw2的eth-trunk 1口时打上该端口的pvid 
    (4)从sw2的e0/0/1流出时,因为tag等于该端口的pvid所以脱掉tag变为纯以太网帧发送给pc2。tag是由交换机添加的信息,pc并不能识别,pc只能识别纯以太网帧 
    这样,尽管没有借用三层设备但最终pc1和oc2实现了通信。

    2.借助路由器子接口

    拓扑如下图所示,此时交换机上联路由器,属于不同vlan的pc1和pc2将通过路由器子接口的方式进行通信。 5458ad4e49528173547344b9c0c1d9e2.png (1) SW1上的配置 
    创建vlan10,20
    [SW1]vlan batch 10 20  
    将e0/0/1口加入vlan 10
    [SW1]int e0/0/1  [SW1-Ethernet0/0/1]port link-type access  
    [SW1-Ethernet0/0/1]port default vlan 10  
    将e0/0/1口加入vlan 20
    [SW1-Ethernet0/0/1]int e0/0/2  [SW1-Ethernet0/0/2]port link-type access  
    [SW1-Ethernet0/0/2]port default vlan 20  
    将g0/0/1口配置成trunk模式,并放通vlan 10/20
    [SW1]int g0/0/1  [SW1-GigabitEthernet0/0/1]port link-type trunk  
    [SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20  [SW1-GigabitEthernet0/0/1]undo port trunk allow-pass vlan 1  
    检查配置,至此SW上配置完成 48e9b979c0d3883b37fced4fd2102a83.png (2) 路由器上配置 
    首先能看到,在交换机上并没有三层口,g0/0/1属于二层端口 
    c3f41c3f0651e8a998ade460b46a45b3.png而在路由器上g0/0/1是三层端口,此时是用交换机的二层口连接路由器的三层口,且tag是二层标签,三层口无法直接识别,所以要先进行dot1q封装 17126c235bf73e6284229725182277db.png路由器上创建子接口,用dot1q封装用于终结vlan标签,并将网关地址配置在该端口上
    [R1]interface g0/0/1.10  
    [R1-GigabitEthernet0/0/1.10]dot1q termination vid 10  
    [R1-GigabitEthernet0/0/1.10]ip add 192.168.10.254 24  
    [R1-GigabitEthernet0/0/1.10]arp broadcast enable   [R1]interface g0/0/1.20  
    [R1-GigabitEthernet0/0/1.20]dot1q termination vid 10  
    [R1-GigabitEthernet0/0/1.20]ip add 192.168.20.254 24  
    [R1-GigabitEthernet0/0/1.20]arp broadcast enable
    至此,R1的配置完成,此时pc1与pc2就能正常通信了,需要注意的是:当开启子接口后,物理接口的功能就将小时此时的物理接口只是接收数据,子接口默认情况下不启用arp广播,所以需要手动开启。

    3.使用vlanif子接口实现

    方法2的方法固然能实现不同vlan间通信,但实际生产环境中很少会用到,原因是:单臂路由引入了单点故障,尽管可以通过eth-trunk的方式将多跟链路绑定做冗余,但vlan的1次间通信会在该链路上一进一出,该链路的负载较大,所以常见的方式是使用三层交换机完成,如下图所示: 70fac3392312e24248db26d7dd413177.png 
    创建vlan10/20,并加入对应vlan
    SW1]vlan batch 10 20  [SW1]int e0/0/1  [SW1-Ethernet0/0/1]port link-type access  
    [SW1-Ethernet0/0/1]port default vlan 10  [SW1-Ethernet0/0/1]int e0/0/2  [SW1-Ethernet0/0/2]port link-type access  
    [SW1-Ethernet0/0/2]port default vlan 20  
    创建vlanif子接口,并将网关配置到该接口上
    [SW1]interface Vlanif 10  
    [SW1-Vlanif10]ip address 192.168.10.254 24  
    [SW1-Vlanif10]int vlanif 20  
    [SW1-Vlanif20]ip add 192.168.20.254 24  
    至此,SW1配置完成pc1与pc2之间能够正常通信,此时有几个需要注意的地方: 
    (1)vlanif的子接口必须要跟vlan号保持一致 
    (2)vlanif是一个三层逻辑端口,使用三层交换机进行多vlan间通信时,不需要进行dot1q封装,因为二层的tag信息在交换机的物理口就已经被剥离
    1

    end

    作者:兔样兔森破来源:https://blog.51cto.com/arkling年度热文5336ad802579266e3e6a350578655c54.png【收藏】运维必备的问题定位工具及案例分析【收藏】超全Redis面试题,开发、运维必备!【技术】摸鱼也要有技巧,这3个命令让你看起来很忙【干货】Telnet的命令使用方法及常见问题【收藏】快速排查无线AP故障的十种方法【干货】超全!华为交换机端口vlan详解~【收藏】最常见的10个网络故障,你一定遇到过  新网工为什么要学虚拟化?【工具】6款免费网络延迟测试工具,放心大胆用!【必看】你离IT大佬还差11个认证【收藏】华为5700系列交换机常用配置示例【科普】为什么ip地址通常以192.168开头?【干货】图文并茂磁盘阵列RAID详解【教程】手把手zabbix安装教程

    f7d82005f6a6b9a215a3834cc4b85390.png

    系统集成/认证培训

    买设备,找我们

    IT维保,找我们

    IT培训,找我们

    展开全文
  • 所有交换机上创建 Vlan10,Vlan20,Vlan30 和 Vlan40解答:标配创建VLANvlan batch 10 20 30 402.所有交换机之间的端口配置为 Trunk,并放行相关 VLAN解答:标配配置Trunk:[S1-GigabitEthernet0/0/2]port link-t...

    一、拓扑

    b7e2dc1d2b06aa11fc9f57e1d55d5196.png

    很多同学的课设,作业需要用到分享给需要的同学,要求1小时内完成。

    二、 需求及配置

    1.所有交换机上创建 Vlan10,Vlan20,Vlan30 和 Vlan40

    解答:标配创建VLAN: vlan batch 10 20 30 40

    2.所有交换机之间的端口配置为 Trunk,并放行相关 VLAN

    解答:标配配置Trunk:

    [S1-GigabitEthernet0/0/2]port link-type trunk

    [S1-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 20 30 40

    3.按照图示分区域配置 MSTP,并配置主备根网桥

    解答:配置主备根网桥

    stp instance 1 root primary //配置为主

    stp instance 2 root secondary //配置为备

    4.S1、s2 上配置 MST 域,域名为 demo1,修订级别为 1,创建 Instance1 映射 Vlan10 和 Vlan20,创建 Instance2 映射 Vlan30 和 Vlan40

    解答:配置MSTP实例stp region-configuration //进入MSTP视图

    region-name demo1 //配置域名

    revision-level 1 //配置级别

    instance 1 vlan 10 20 //配置实例1绑定VLAN10 20

    instance 2 vlan 30 40 //配置实例2绑定VLAN30 40

    active region-configuration //激活MST域的配置

    5.S3、s4 上配置 MST 域,域名为 demo2,修订级别为 2,创建 Instance1 映射 Vlan10,创建 Instance2 映射 Vlan30

    解答:配置MSTP实例stp region-configuration //进入MSTP视图

    region-name demo2 //配置域名

    revision-level 2 //配置级别

    instance 1 vlan 10 //配置实例1绑定VLAN10

    instance 2 vlan 30 //配置实例2绑定VLAN30

    active region-configuration //激活MST域的配置

    6.S5、s6 上配置 MST 域,域名为 demo3,修订级别为 3,创建 Instance1 映射 Vlan20,创建 Instance2 映射 Vlan40

    解答:配置MSTP实例stp region-configuration //进入MSTP视图

    region-name demo3//配置域名

    revision-level 3 //配置级别

    instance 1 vlan 20 //配置实例1绑定VLAN 20

    instance 2 vlan 40 //配置实例2绑定VLAN 40

    active region-configuration //激活MST域的配置

    7.s5 的 G0/0/3 端口加入vlan 10,并配置为边缘端口,开启边缘端口保护功能。

    解答配置:

    interface GigabitEthernet0/0/3

    port link-type access

    port default vlan 10

    stp bpdu-filter enable //开启BPDU过滤

    stp edged-port enable //配置边缘端口

    8.s6 的 G0/0/3 端口加入vlan 30,并配置为边缘端口,开启边缘端口保护功能。

    解答配置:

    interface GigabitEthernet0/0/3

    port link-type access

    port default vlan 30

    stp bpdu-filter enable

    stp edged-port enable

    stp bpdu-protection

    欢迎【零基础】学网络的小伙伴们加入网工训练营,资料每天限量10份先来先得。单独私信小编领取哦!【私信小编备注:资料】

    2e34c3c5af5b1bda4fd0819e8e63a1b4.png
    展开全文
  • 提到vlan,大家都比较熟悉,说的就是虚拟局域网,就是在同一个vlan...思科下vlan创建:创建vlan 3002vlan 接口可以设置ip地址设置vlan 接口ip地址华为下创建vlanvlan接口设置ip地址:vlan的划分有如下几种方式,...

    提到vlan,大家都比较熟悉,说的就是虚拟局域网,就是在同一个vlan里面的形成一个局域网,这是将在物理上一个小的区域内的网络再次进行了逻辑上的划分,对网络的分组非常简单有效。

    vlan 的创建比较简单,仅以思科和华为为例说明。

    思科下vlan创建:

    4a8e284926145d23f183dd56153520fe.png

    创建vlan 3002

    vlan 接口可以设置ip地址

    4a9b507f887d6c8bc718d6cb1a92188d.png

    设置vlan 接口ip地址

    华为下创建vlan:

    153c945c282c43304cf74eaff7225ee9.png

    vlan接口设置ip地址:

    4e1c315b55ad1a8395ffc249696c9eca.png

    vlan的划分有如下几种方式,下面统一以华为交换机为例:

    基于端口划分:

    551763388c5c768848cd4ae41e45c1fb.png

    基于mac地址划分vlan,可以实现对mac绑定,未绑定mac地址将不能使用网络

    149a6545ca936188766b36c5a11891fb.png

    创建基于mac的vlan

    c95c7a6dceb17d81d205163ff67fab6d.png

    启用mac vlan

    如此设置后,20端口只有绑定的mac地址能接入网络,其它mac无法接入;

    基于ip子网的划分,

    9f3d73fd895d526f85fe16130c642b4b.png

    创建vlan

    7475766ecf74398258e43941e2acc1ec.png

    启用基于子网vlan

    如此就将192.168.3.1/24划入vlan 3004 ;

    基于协议划分vlan

    4702de8de99a50a0ebac5447a8129339.png

    创建基于协议的vlan

    729b7f11f39b21a77287072242968b83.png

    将协议vlan应用到接口


    通过不同的方式建立vlan,可实现不同的功能,在企业局域网可以灵活应用。

    展开全文
  • 在文章《5分钟让你熟悉VLAN并掌握基本的配置,新手入门必备》,介绍过VLAN的划分的几种方法和配置,我非常好奇VLAN是一个怎样的工作过程呢?它是如何做到隔离的功能,带着这些疑问,今天一起来看看吧VLAN基本通信...
  • 基于MAC的VLAN是根据报文的源MAC地址来划分VLAN。设备维护的MAC VLAN表记录了MAC地址和VLAN的对应关系。这种划分方法的最大优点就是当用户物理位置发生变化,例如从一台设备换到其他设备时,VLAN不用重新配置。所以...
  • [Router] interface GigabitEthernet 0/0/0.10 (2)绑定VLANid; [Router-GigabitEthernet0/0/0.10] dot1q termination vid 10 (3)配置IP地址作为网关; [Router-GigabitEthernet0/0/0.10] ip address 192.168.10....
  • 拓扑图和VLAN规划如下:如上图所示,企业中有两个部门:部门1和部门2,部门1规划VLAN 10,部门2规划VLAN 20,现在公司的需求是:部门1 VLAN 10的流量平时通过核心交换机-1来转发流量,核心交换-2作为备份;部门2 VLAN...
  • 一、MSTP1、IEEE 802.1s 中定义了多生成树协议 MSTP(Multiple Spanning Tree Protocol),MSTP兼容 STP 和 RSTP,既可以快速收敛,又提供了数据转发的多个冗余路径,在数据转发过程中实现 VLAN 数据的负载均衡。...
  • 场景介绍:交换机 Secblade防火墙插卡实现主备跨VLAN二层转发的应用。SecBlade 配置二层转发模式,并配置跨VLAN转发类型的Bridge组,实现流量在数据链路层完成不同VLAN间通信。 网络拓扑:配置流程:①假使交换机和...
  • 将多个VLAN绑定到同一SSID的方案

    千次阅读 2014-04-24 08:58:48
    只有一个SSID并绑定了一个VLAN用于办公网络。 随着Windows XP升级到Windows 7,公司更换了大批笔记本电脑,几乎所有用户都是有线和无线网络同时连接,三四百台笔记本,只有一个C网,虽然将DHCP的租用时间更改为1小时...
  • VLAN 网卡 绑定

    2014-09-01 21:20:18
    原创作品,允许转载,转载时请务必...http://xiaoli110.blog.51cto.com/1724/940971 服务器网卡多网卡绑定vlan支持版本:1.1 2012-07-26 增加如何查看linux系统中的bond状态版本: 1.0原理: 利用802.3ad协...
  • H3C交换机删除VLAN与其绑定端口配置

    千次阅读 2019-09-23 19:56:32
    在系统视图下,执行 undo int vlan 2 undo vlan 2 可以删除vlan2的配置信息。 执行 undo vlan all 可以删除所有的vlan信息。...可以解除GE3/1/1和VLAN2的绑定。 在系统视图下,输入: dis int v b 可以查看当前的...
  • IP,MAC,PORT,VLAN地址绑定

    2012-12-31 13:30:49
    比较详细的介绍了IP,MAC,PORT,VLAN这几个属性的绑定
  • 首先,我是在vlanif下启用dhcp的。 [2#-1F-Core1-Vlanif2]display this # interface Vlanif2 ip address 172.16.15.1 255.255.254.0 dhcp select interface dhcp server excluded-ip-address 172.16...
  • system[h3c]vlan 100(添加并进入vlan100)[h3c]int vlan 100(进入vlan100接口)[h3c]ip addess 192.168.10.1 255.255.255.0(设置vlan 100的IP地址为192.168.10.1/24)将端口加入vlan:<h...
  • 1、组网需求图1 配置基于MAC地址的VLAN划分组网图如上图1所示,某个公司的网络中,网络管理者将同一部门的员工划分到同一VLAN。...可以配置基于MAC地址划分VLAN,将本部门员工PC的MAC地址与VLAN绑定,...
  • 服务器网卡多网卡绑定vlan支持 版本: 1.2 2014-12-04 增加一个排错案例 版本: 1.1 2012-07-26 增加如何查看linux系统中的bond状态版本: 1.0原理: 利用802.3ad协议,实现多网卡的绑定。利用802.31p协议,...
  • 20网段的ip地址与mac地址绑定,从而实现下面的电脑更改ip地址或者不明来源的电脑不能连接到交换机。 1.system-view 进入系统试图模式 2.dis cu 查看当前配置情况 3.vlan 20 创建vlan20 4.interface g0/0/1 进入...
  • 一、客户需求①有线部分:KTV内前台、财务等有线电脑需接入内部点单系统,包房内机顶盒等设备需要接入内网...路由器使用M80实现路由功能、AC管理功能、VLAN划分,核心交换机使用G3224P进行VLAN划分。三、网络拓扑网...
  • 如果没有,使用以下命令将模组载入内核: # /sbin/modprobe -a 8021q 2、删除team0 中的IP配置 #vi /etc/sysconfig/network-scripts/ifcfg-team0 删除IP 和DNS 配置,并保存配置 3、创建VLAN 网卡配置文件。...
  • 由于公司所有的地方都已经有了内网的无线信号覆盖,而且我们使用的无线AP是Cisco 12系列的,那能不能在其上面新建另外的ssid,并加入到一个新的vlan当中去,接外网adsl的自动拨号路由器接入这个vlan,这样就能实现这...
  • #nmcli connection add type vlan con-name bond0.100  ifname bond0.100  id 100 dev  bond0 修改bond0配置,取消ipv4和ipv6的配置 #nmcli connecton modify bond0 ipv4.method disabled #nmcli ...
  • 基于MAC地址划分VLAN实验 ...可以配置基于MAC地址划分VLAN,将本部门员工PC的MAC地址与VLAN绑定,从而实现该需求; 创建VLAN10: [sw1]vlan batch 10 接口配置VLAN: [sw1]int g0/0/1 [sw1-Giga...
  • 交换机恢复出厂设置及其基本配置 1 使用telnet方式管理交换机 7 交换机文件备份 15 ...交换机端口与MAC绑定 38 交换机链路聚合 46 多层交换机VLAN的划分和VLAN间路由 55 多层交换机静态路由实验 63
  • 1.cpu主控:rk3399; 2.交换机芯片marvell mv88e6390(8个电口+2光口);...通过tag based vlan将marvell mv88e6390划分为vlan1(wan)+vlan2(lan); 用vconfig实现 vlan网桥; 通过iptables 实现wan/lan数据转发 使
  • 如果没有,使用以下命令将模组载入内核: # /sbin/modprobe -a 8021q 2、删除team0 中的IP配置 #vi /etc/sysconfig/network-scripts/ifcfg-team0 删除IP 和DNS 配置,并保存配置 3、创建VLAN 网卡配置文件。...
  • 四、配置Vlan绑定IP  #vim /etc/network/interfaces 添加以下内容:  auto vlan314 iface vlan314 inet static vlan_raw_device bond1 address 10.172.1.226 netmask 255.255.255.224 #添加路由 ...
  • 在思科交换机中为了防止ip被盗用或员工乱改ip,可以做以下措施,既ip与mac地址的绑定,和ip与交换机端口的绑定。一、通过IP查端口 先查MAC地址,再根据MAC地址查端口: bangonglou3#show arp | include 208.41...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 492
精华内容 196
关键字:

vlan绑定