精华内容
下载资源
问答
  • H3C命令大全

    2011-06-23 13:20:23
    H3C命令大全H3C命令大全H3C命令大全H3C命令大全H3C命令大全H3C命令大全
  • h3c命令大全

    2018-02-04 23:33:05
    h3c 配置命令
  • H3C 命令大全

    2015-12-25 20:27:08
    进入系统视图system-view配置设备名sysname RouterA查看FLASH目录下内容dir指定下次启动配置文件startup saved-configuration main.cfg保存配置save重启reboot#置CONSOLE用户登陆的口令认证system-view[H3C]user-...

    进入系统视图

    system-view


    配置设备名

    sysname RouterA



    查看FLASH目录下内容

    dir


    指定下次启动配置文件

    startup saved-configuration main.cfg


    保存配置

    save


    重启

    reboot


    #置CONSOLE用户登陆的口令认证

    system-view


    [H3C]user-interface aux 0


    [H3C-ui-aux0]authentication-mode password


    [H3C-ui-aux0]set authenticaton password simple 123456

    [H3C-ui-aux0]user privilege level 3



    用户的命令控制级别设置


    [H3C-ui-aux0]user privilege level 0


    [H3C]super password level 1 simple 123456


    [H3C]super password level 2 simple 123456


    [H3C]super password level 3 simple 123456


    # 设置super(明文)密码 当低权限向高权限切换时使用!

    [RouterA]super password simple quidway


    # 设置super(密文)密码

    [RouterA]super password cipher quidway


    # 启用telnet 管理功能

    [RouterA]user-interface vty 0 4

    [RouterA-ui-vty0-4]authentication-mode password

    [RouterA-ui-vty0-4]set authentication password simple quidway

    [RouterA-ui-vty0-4]user privilege level 3

    [RouterA-ui-vty0-4]quit

    [RouterA]telnet server enable


    # 配置端口IP 地址

    [RouterA]int e 0

    [RouterA-Ethernet0]ip add 192.168.1.1 24


    # 启动端口

    [RouterA-Ethernet0]undo shutdown

    [RouterA-Ethernet0]quit


    # 保存,在任何视图下

    save


    # 查看当前设备配置信息

    [RouterA]display current-configuration


    # 查看Flash 中的配置(相当于CISCO start-config)

    [RouterA]display saved-configuration


    # 删除FLASH 中的配置信息(重置设备配置)

    [RouterA]reset saved-configuration


    # 重新启动设备

    reboot


    # 显示系统软件版本

    [RouterA]display version


    # 访问TFTP 服务器

    tftp 服务器IP {put|get} 源文件名目的文件名

    tftp 192.168.1.2 put startup.cfg startup.cfg //上传

    tftp 192.168.1.2 get test.txt test.txt //下载


    # 交换机IP 地址

    [H3C]int vlan 1

    [H3C-Vlan-interface1]ip add 192.168.1.1 24

    [H3C-Vlan-interface1]undo ip add 192.168.1.1 24


    # 创建VLAN

    [H3C]vlan 10

    [H3C]undo vlan 10


    # 向VLAN 添加一个、多个端口

    [H3C-vlan10]port e 1/0/1

    [H3C-vlan10]port e 1/0/5 to e 1/0/7

    [H3C-vlan10]port e 1/0/8 to e 1/0/9 e 1/0/11 to e 1/0/12


    # 显示VLAN 信息

    [H3C]dis vlan


    # 设置以太网端口的链路类型为TRUNK

    [H3C-Ethernet1/0/1]port link-type trunk

    [H3C-Ethernet1/0/1]port trunk permit vlan all

    [H3C-Ethernet1/0/1]port trunk pvid vlan 1


    # 设置以太网端口的链路类型为ACCESS

    [H3C-Ethernet1/0/1]port link-type access

    [H3C-Ethernet1/0/1]port access vlan 10

    [H3C-Ethernet1/0/1]undo port access vlan


    # 配置Loopback 环回接口

    [H3C]int loopback 0

    [H3C-Lookback0]ip add 10.1.1.1 24


    # 静态路由

    [H3C]ip route 192.168.3.0 255.255.255.0 s 1/0

    [H3C]undo ip route 192.168.3.0 255.255.255.0 s 1/0


    # 默认路由

    [H3C]ip route 0.0.0.0



    显示当前配置

    dis cu


    dis命令集(汉化)


    acl ACL状态和配置信息

    arp 显示ARP信息 

    aspf ASPF状态和配置信息

    atm ATM状态和配置信息 

    bgp BGP 协议信息

    boot-loader 显示启动文件

    bootp 自举协议 

    bridge 桥的信息 

    brief 接口状态和配置简要信息

    channel 信息通道状态和配置信息

    clipboard 剪贴板的状态和配置信息

    clock 时钟状态和配置信息 

    configure-user 具有配置权限的用户

    connection 显示连接信息

    connection-limit 连接统计模块的状态和配置信息

    controller 指定controller接口 

    cpu-usage CPU占用率统计信息

    current-configuration 系统当前配置

    dar DAR状态和配置信息

    debugging 显示当前调试开关设置情况

    device 显示设备信息

    dhcp DHCP命令 

    diagnostic-information 显示系统诊断信息

    dialer DCC状态和配置信息

    dns DNS 状态和配置信息

    domain 显示域配置方案

    dot1x 802.1X配置信息 

    dsl DSL状态和配置信息

    environment 显示环境信息

    fan 显示风扇状态

    fe1 接口FE1状态和配置信息 

    fib FIB状态和配置信息

    firewall 防火墙的配置信息

    firewall-statistics 防火墙的状态和配置信息

    fr 帧中继状态和配置信息 

    ft1 接口FT1状态和配置信息 

    ftp FTP客户端状态和配置信息

    ftp-server FTP服务器状态和配置信息

    ftp-user FTP用户状态和配置信息 

    history-command 历史命令配置信息

    hotkey 快捷键的状态和配置信息

    hwtacacs HWTACACS服务器的相关信息

    icmp ICMP信息 

    igmp 状态和配置信息 

    info-center 显示信息中心配置及内容

    interface 接口状态和配置信息 

    ip IP 协议

    ipv6 IPv6状态和配置信息 

    isdn ISDN 状态和配置信息

    l2tp L2TP状态和配置信息

    local-proxy-arp 显示本地ARP代理信息 

    local-server 本地服务器信息

    local-user 显示本地用户信息

    logbuffer 日志缓冲区状态和配置信息

    logfile 显示日志文件信息

    loopback-detection 检测端口是否存在自环

    mac-address MAC地址信息

    memory 显示内存信息

    mfr 显示MFR状态和配置信息 

    mirroring-group 设置镜像组

    mld MLD状态和配置信息 

    msdp MSDP状态和配置信息

    multicast 多播配置

    nat 地址转换状态和配置信息

    nqa 显示NQA信息

    ntp-service NTP网络时间服务

    oap 开放应用平台的操作

    ospf OSPF路由协议

    pim PIM状态和配置信息

    pki PKI信息

    policy-based-route 策略路由的状态和配置信息

    port 显示端口信息

    port-isolate 隔离组信息

    portal Portal 协议

    power 显示电源状态

    ppp PPP状态和配置信息

    pppoe-client PPPoE Client状态和配置信息

    pppoe-server PPPoE服务器端状态和配置信息

    proxy-arp 显示ARP代理信息 

    qos 服务质量状态和配置信息

    radius 显示RADIUS配置信息

    reboot-type 显示启动类型

    rip RIP状态和配置信息

    rmon RMON信息

    route-policy 显示路由策略配置

    router 配置路由器信息

    routing 显示路由信息

    rps 显示冗余电源状态

    rsa 显示RSA模块的状态和配置信息

    saved-configuration 显示保存的系统配置信息

    schedule 设定系统任务

    sftp 显示设置的源

    snmp-agent 显示SNMP状态和配置信息

    ssh SSH 状态和配置信息

    standby 备份接口状态和配置信息 

    startup 显示系统启动配置

    stop-accounting-buffer 查询备份在本地的无响应的停止计费报文

    stp 生成树协议 

    tcp TCP状态和配置信息 

    telnet TELNET状态和配置信息

    tftp TFTP客户端状态和配置信息

    this 当前视图的运行配置

    time-range 时间段状态和配置信息

    traffic 数据流的状态和配置信息 

    transceiver

    trapbuffer 告警缓冲区状态和配置信息

    udp UDP状态和配置信息 

    udp-helper UDP HELPER模块

    user-interface 用户接口的状态和配置信息 

    userlog 用户日志特性

    users 用户接口状态及配置信息

    version 系统的硬件和软件版本信息 

    virtual-access Virtual-access 接口状态和配置信息 

    vlan VLAN配置信息

    voice Voice VLAN


    ==========================================================================================

    reset save ;清除所有配置

    [Quidway]super password ;修改特权用户密码

    [Quidway]sysname ;交换机命名

    [Quidway]interface ethernet 0/1 ;进入接口视图

    [Quidway]interface vlan x ;进入接口视图

    [Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0 ;配置VLAN的IP地址

    [Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 ;静态路由=网关



    [Quidway]user-interface vty 0 4 ;进入虚拟终端

    [S3026-ui-vty0-4]authentication-mode password ;设置口令模式

    [S3026-ui-vty0-4]set authentication password simple 222 ;设置口令

    [S3026-ui-vty0-4]user privilege level 3 ;用户级别



    [Quidway-Ethernet0/1]duplex {half|full|auto} ;配置端口工作状态

    [Quidway-Ethernet0/1]speed {10|100|auto} ;配置端口工作速率

    [Quidway-Ethernet0/1]flow-control ;配置端口流控

    [Quidway-Ethernet0/1]mdi {across|auto|normal} ;配置端口平接扭接

    [Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} ;设置端口工作模式

    [Quidway-Ethernet0/1]undo shutdown ;激活端口

    [Quidway-Ethernet0/2]quit ;退出系统视图



    [Quidway]vlan 3       ;创建VLAN

    [Quidway-vlan3]port ethernet 0/1 to ethernet 0/4      ;在VLAN中增加端口

    [Quidway-Ethernet0/2]port access vlan 3      ;当前端口加入到VLAN

    [Quidway-Ethernet0/2]port trunk permit vlan {ID|All}   ;设trunk允许的VLAN

    [Quidway-Ethernet0/2]port trunk pvid vlan 3      ;设置trunk端口的PVID



    [Quidway]monitor-port  ;指定镜像端口

    [Quidway]port mirror   ;指定被镜像端口

    [Quidway]port mirror int_list observing-port int_type int_num ;指定镜像和被镜像



    [Quidway]description string      ;指定VLAN描述字符

    [Quidway]description         ;删除VLAN描述字符

    [Quidway]display vlan [vlan_id] ;查看VLAN设置



    [Quidway]stp {enable|disable} ;设置生成树,默认关闭

    [Quidway]stp priority 4096      ;设置交换机的优先级

    [Quidway]stp root {primary|secondary}      ;设置为根或根的备份

    [Quidway-Ethernet0/1]stp cost 200      ;设置交换机端口的花费



    [SwitchA-vlanx]isolate-user-vlan enable      ;设置主vlan

    [SwitchA]Isolate-user-vlan secondary      ;设置主vlan包括的子vlan

    [Quidway-Ethernet0/2]port hybrid pvid vlan      ;设置vlan的pvid

    [Quidway-Ethernet0/2]port hybrid pvid      ;删除vlan的pvid

    [Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged  ;设置无标识的vlan

    如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。

    所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged.

    ----------------------------------------

    路由器命令


    [Quidway]display version       ;显示版本信息

    [Quidway]display current-configuration       ;显示当前配置

    [Quidway]display interfaces       ;显示接口信息

    [Quidway]display ip route       ;显示路由信息



    [Quidway]sysname aabbcc       ;更改主机名

    [Quidway]super passwrod 123456       ;设置口令

    [Quidway]interface serial0       ;进入接口

    [Quidway-serial0]ip address       ;配置端口IP地址

    [Quidway-serial0]undo shutdown       ;激活端口

    [Quidway]link-protocol hdlc       ;绑定hdlc协议

    [Quidway]user-interface vty 0 4

    [Quidway-ui-vty0-4]authentication-mode password

    [Quidway-ui-vty0-4]set authentication-mode password simple 222

    [Quidway-ui-vty0-4]user privilege level 3

    [Quidway-ui-vty0-4]quit



    [Quidway]debugging hdlc all serial0       ;显示所有信息

    [Quidway]debugging hdlc event serial0       ;调试事件信息

    [Quidway]debugging hdlc packet serial0       ;显示包的信息



    静态路由:

    [Quidway]ip route-static {interface number|nexthop}[value][reject|blackhole]

    例如:

    [Quidway]ip route-static 129.1.0.0 16 10.0.0.2

    [Quidway]ip route-static 129.1.0.0 255.255.0.0 10.0.0.2

    [Quidway]ip route-static 129.1.0.0 16 Serial 2

    [Quidway]ip route-static 0.0.0.0 0.0.0.0 10.0.0.2



    动态路由:

    [Quidway]rip ;设置动态路由

    [Quidway]rip work ;设置工作允许

    [Quidway]rip input ;设置入口允许

    [Quidway]rip output ;设置出口允许

    [Quidway-rip]network 1.0.0.0       ;设置交换路由网络

    [Quidway-rip]network all ;设置与所有网络交换

    [Quidway-rip]peer ip-address ;

    [Quidway-rip]summary ;路由聚合

    [Quidway]rip version 1 ;设置工作在版本1

    [Quidway]rip version 2 multicast ;设置工作在版本2,多播方式

    [Quidway-Ethernet0]rip split-horizon ;水平分隔



    [Quidway]router id A.B.C.D ;配置路由器的ID

    [Quidway]ospf enable ;启动OSPF协议

    [Quidway-ospf]import-route direct ;引入直联路由

    [Quidway-Serial0]ospf enable area ;配置OSPF区域



    标准访问列表命令格式如下:

    acl [match-order config|auto] ;默认前者顺序匹配。

    rule [normal|special]{permit|deny} [source source-addr source-wildcard|any]

    例:

    [Quidway]acl 10

    [Quidway-acl-10]rule normal permit source 10.0.0.0 0.0.0.255

    [Quidway-acl-10]rule normal deny source any



    扩展访问控制列表配置命令

    配置TCP/UDP协议的扩展访问列表:

    rule {normal|special}{permit|deny}{tcp|udp}source {|any}destination |any}

    [operate]



    配置ICMP协议的扩展访问列表:

    rule {normal|special}{permit|deny}icmp source {|any]destination {|any]

    [icmp-code] [logging]



    扩展访问控制列表操作符的含义

    equal portnumber ;等于

    greater-than portnumber ;大于

    less-than portnumber ;小于

    not-equal portnumber ;不等

    range portnumber1 portnumber2 ;区间



    扩展访问控制列表举例

    [Quidway]acl 101

    [Quidway-acl-101]rule deny souce any destination any

    [Quidway-acl-101]rule permit icmp source any destination any icmp-type echo

    [Quidway-acl-101]rule permit icmp source any destination any icmp-type echo-reply



    [Quidway]acl 102

    [Quidway-acl-102]rule permit ip source 10.0.0.1 0.0.0.0 destination 202.0.0.1 0.0.0.0

    [Quidway-acl-102]rule deny ip source any destination any



    [Quidway]acl 103

    [Quidway-acl-103]rule permit tcp source any destination 10.0.0.1 0.0.0.0 destination-port equal ftp

    [Quidway-acl-103]rule permit tcp source any destination 10.0.0.2 0.0.0.0 destination-port equal www


    [Quidway]firewall enable

    [Quidway]firewall default permit|deny

    [Quidway]int e0

    [Quidway-Ethernet0]firewall packet-filter 101 inbound|outbound


    地址转换配置举例

    [Quidway]firewall enable

    [Quidway]firewall default permit

    [Quidway]acl 101

    [Quidway-acl-101]rule deny ip source any destination any

    [Quidway-acl-101]rule permit ip source 129.38.1.4 0 destination any

    [Quidway-acl-101]rule permit ip source 129.38.1.1 0 destination any

    [Quidway-acl-101]rule permit ip source 129.38.1.2 0 destination any

    [Quidway-acl-101]rule permit ip source 129.38.1.3 0 destination any

    [Quidway]acl 102

    [Quidway-acl-102]rule permit tcp source 202.39.2.3 0 destination 202.38.160.1 0

    [Quidway-acl-102]rule permit tcp source any destination 202.38.160.1 0 destination-port great-than

    1024



    [Quidway-Ethernet0]firewall packet-filter 101 inbound

    [Quidway-Serial0]firewall packet-filter 102 inbound



    [Quidway]nat address-group 202.38.160.101 202.38.160.103 pool1

    [Quidway]acl 1

    [Quidway-acl-1]rule permit source 10.110.10.0 0.0.0.255

    [Quidway-acl-1]rule deny source any

    [Quidway-acl-1]int serial 0

    [Quidway-Serial0]nat outbound 1 address-group pool1



    [Quidway-Serial0]nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp

    [Quidway-Serial0]nat server global 202.38.160.102 inside 10.110.10.2 www tcp

    [Quidway-Serial0]nat server global 202.38.160.102 8080 inside 10.110.10.3 www tcp

    [Quidway-Serial0]nat server global 202.38.160.103 inside 10.110.10.4 smtp udp


    PPP验证:

    主验方:pap|chap

    [Quidway]local-user u2 password {simple|cipher} aaa

    [Quidway]interface serial 0

    [Quidway-serial0]ppp authentication-mode {pap|chap}

    [Quidway-serial0]ppp chap user u1 //pap时,不用此句



    pap被验方:

    [Quidway]interface serial 0

    [Quidway-serial0]ppp pap local-user u2 password {simple|cipher} aaa



    chap被验方:

    [Quidway]interface serial 0

    [Quidway-serial0]ppp chap user u1

    [Quidway-serial0]local-user u2 password {simple|cipher} aaa


    转载于:https://blog.51cto.com/sbujjiqpl/1728400

    展开全文
  • h3c配置命令大全

    2016-01-07 12:45:29
    大全H3C命令大全
  • H3C命令完整大全

    2018-03-22 16:45:39
    H3C命令完整大全system-view 进入系统视图模式 2、sysname 为设备命名 3、display current-configuration 当前配置情况 4、language-mode Chinese|English 中英文切换 5、interface Ethernet 1/0/1 进入以太网...
  • H3C 路由器命令大全

    2011-12-13 01:07:18
    H3C 路由器命令大全
  • H3C交换机命令大全

    2015-01-16 09:28:47
    H3C交换机路由器命令大全,网络管理必备。
  • H3C交换机配置命令大全
  • H3C路由器命令大全.doc

    2011-10-31 16:50:16
    H3C 路由器 命令 大全 doc H3C 路由器 命令 大全 doc H3C 路由器 命令 大全 doc
  • H3C交换机配置命令大全
  • H3C 配置命令大全

    2017-10-18 11:26:30
    H3C交换节配置命令 。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。
  • H3C设备配置命令大全

    2015-02-05 15:00:08
    H3C设备配置命令大全。包含H3C路由器、交换机以及防火墙设备。
  • H3C华为交换机配置命令大全
  • H3C交换机常用配置命令大全
  • H3C基本命令大全

    2015-08-14 09:21:52
    H3C交换机配置命令大全H3C交换机1、system-view进入系统视图模式2、sysname为设备命名3、displaycurrent-configuration当前配置情况4、language-modeChinese|English中英文切换5、interfaceEthernet1/0/1进入以太网...

    H3C交换机配置命令大全H3C交换机  

    1system-view   进入系统视图模式   

    2sysname   为设备命名   

    3display current-configuration 当前配置情况   

    4、 language-mode Chinese|English 中英文切换   

    5interface Ethernet 1/0/1 进入以太网端口视图  

    6、 port link-type Access|Trunk|Hybrid      设置端口访问模式 7、 undo shutdown   打开以太网端口   

    8、 shutdown   关闭以太网端口   

    9、 quit     退出当前视图模式   

    10、 vlan 10    创建VLAN 10并进入VLAN 10的视图模式   

    11、 port access vlan 10   在端口模式下将当前端口加入到vlan 10中   

    12port E1/0/2 to E1/0/5    VLAN模式下将指定端口加入到当前vlan中   

    13port trunk permit vlan all    允许所有的vlan通过

     

     

     

    H3C路由器

    1system-view   进入系统视图模式   

    2sysname R1   为设备命名为R1   

    3display ip routing-table 显示当前路由表  

    4、 language-mode Chinese|English 中英文切换   

    5interface Ethernet 0/0 进入以太网端口视图

    6、 ip address 192.168.1.1 255.255.255.0   配置IP地址和子网掩码   

    7、 undo shutdown   打开以太网端口   

    8、 shutdown   关闭以太网端口   

    9、 quit     退出当前视图模式   

    10、 ip route-static 192.168.2.0 255.255.255.0 192.168.12.2 description To.R2 配置静态路由   

    11、 ip route-static 0.0.0.0 0.0.0.0 192.168.12.2 description To.R2 配置默认的路由

     

     

     

     

     

    H3C S3100 Switch   H3C S3600 Switch  H3C MSR 20-20 Router 

    1、调整超级终端的显示字号;   

    2、捕获超级终端操作命令行,以备日后查对;   

    3、 language-mode Chinese|English 中英文切换;   

    4、复制命令到超级终端命令行, 粘贴到主机;   

    5、交换机清除配置 :<H3C>reset save <H3C>reboot ;   

    6、路由器、交换机配置时不能掉电,连通测试前一定要   检查网络的连通性,不要犯最低级的错误。   

    7192.168.1.1/24    等同   192.168.1.1 255.255.255.0;在配置交换机和路由器时, 192.168.1.1 255.255.255.0 可以写成:   192.168.1.1 24   

    8、设备命名规则:地名-设备名-系列号例:PingGu-R-S3600

     

     

     

    H3C华为交换机端口绑定基本配置

    1.端口 MAC   

    a)AM命令   

    使用特殊的AM User-bind命令,来完成MAC地址与端口之间的绑定。例如:   

    [SwitchA]am user-bind mac-address 00e0-fc22-f8d3 interface Ethernet 0/1   

    配置说明:由于使用了端口参数,则会以端口为参照物,即此时端口E0/1只允许PC1上网,而使用其他未绑定的MAC地址的PC机则无法上网。但是PC1使用该MAC地址可以在其他端口上网。   

    b)mac-address命令   

    使用mac-address static命令,来完成MAC地址与端口之间的绑定。例如:   

    [SwitchA]mac-address static 00e0-fc22-f8d3 interface Ethernet 0/1 vlan 1   

    [SwitchA]mac-address max-mac-count 0   

    配置说明:由于使用了端口学习功能,故静态绑定mac后,需再设置该端口mac学习数为0,使其他PC接入此端口后其mac地址无法被学习。   

     

    2.IP MAC   

    a)AM命令   

    使用特殊的AM User-bind命令,来完成IP地址与MAC地址之间的绑定。例如:   

    [SwitchA]am user-bind ip-address 10.1.1.2 mac-address 00e0-fc22-f8d3   

    配置说明:以上配置完成对PC机的IP地址和MAC地址的全局绑定,即与绑定的IP地址或者MAC地址不同的PC机,在任何端口都无法上网。

    支持型号:S3026E/EF/C/G/TS3026C-PWRE026/E026TS3050CE050S3526E/C/EFS5012T/GS5024G   

    b)arp命令

    使用特殊的arp static命令,来完成IP地址与MAC地址之间的绑定。例如:   

    [SwitchA]arp static 10.1.1.2 00e0-fc22-f8d3   

    配置说明:以上配置完成对PC机的IP地址和MAC地址的全局绑定。   

     

    3.端口 IP MAC   

    使用特殊的AM User-bind命令,来完成IPMAC地址与端口之间的绑定。例如:   

    [SwitchA]am user-bind ip-address 10.1.1.2 mac-address 00e0-fc22-f8d3 interface Ethernet 0/1   

    配置说明:可以完成将PC1IP地址、MAC地址与端口E0/1之间的绑定功能。由于使用了端口参数,则会以端口为参照物,即此时端口E0/1只允许 PC1上网,而使用其他未绑定的IP地址、MAC地址的PC机则无法上网。但是PC1使用该IP地址和MAC地址可以在其他端口上网。

     

     

     

     

     

     

    [S2016-E1-Ethernet0/1]mac-address max-mac-count 0;   

    进入到端口,用命令mac max-mac-count 0(端口mac学习数设为0)

    [S2016-E1]mac static 0000-9999-8888 int e0/1 vlan 10; 

    0000-9999-8888绑定到e0/1端口上,此时只有绑定macpc可以通过此口上网,同时E0/1属于vlan 10

    就这样,ok了,不过上面两个命令顺序不能弄反,除非端口下没有接pc   

     

     

    dis vlan 显示vlan   

    name text 指定当前vlan的名称   

    undo name 取消   

    [h3c] vlan 2

    [h3c-vlan2]name test vlan   

    dis users 显示用户   

    dis startup 显示启动配置文件的信息   

    dis user-interface 显示用户界面的相关信息   

    dis web users 显示web用户的相关信息。  

    header login 配置登陆验证是显示信息   

    header shell   

    undo header   

    lock 锁住当前用户界面   

    acl 访问控制列表 acl number inbound/outbound

    [h3c]user-interface vty 0 4   

    [h3c-vty0-4] acl 2000 inbound   

    shutdown:关闭vlan接口   

    undo shutdown 打开vlan接口   

    关闭vlan1 接口   

    [h3c] interface vlan-interface 1   

    [h3c-vlan-interface] shutdown  

     vlan vlan-id 定义vlan   

    undo valn vlan-id   

    display ip routing-table   

    display ip routing-table protocol static   

    display ip routing-table statistics

    display ip routing-table verbose 查看路由表的全部详细信息

    interface vlan-interface vlan-id 进入valn   

    management-vlan vlan-id 定义管理vlan号   

    reset ip routing-table statistics protocol all 清除所有路由协议的路由信息.   

    display garp statistics interface GigabitEthernet 1/0/1 显示以太网端口上的garp统计信息   

    display voice vlan status 查看语音vlan状态   

    [h3c-GigabitEthernet1/0/1] broadcast-suppression 20 允许接受的最大广播流量为该端口传输能力的20%.超出部分丢弃.   

    [h3c-GigabitEthernet1/0/1] broadcast-suppression pps 1000 每秒允许接受的最大广播数据包为1000传输能力的20%.超出部分丢弃.

    display interface GigabitEthernet1/0/1 查看端口信息 

    display brief interface GigabitEthernet1/0/1 查看端口简要配置信息   

    display loopback-detection 用来测试环路测试是否开启  

    display transceiver-information interface GigabitEthernet1/0/50 显示光口相关信息

    duplex auto/full/half   

    [h3c]interface GigabitEthernet1/0/1   

    [h3c-GigabitEthernet1/0/1]duplux auto 设置端口双工属性为自协商   

    port link-type access/hybrid/trunk 默认为access   

    port trunk permit vlan all trunk扣加入所有vlan中   

    reset counters interface GigabitEthernet1/0/1 清楚端口的统计信息   

    speed auto 10/100/1000   

    display port-security 查看端口安全配置信息

    am   user-bind   mac-addr 00e0-fc00-5101 ip-addr 10.153.1.2 interface GigabitEthernet1/0/1 端口ip绑定

    display arp 显示arp 

    display am user-bind 显示端口绑定的配置信息 

    display mac-address 显示交换机学习到的mac地址   

    display stp 显示生成树状态与统计信息   

    [h3c-GigabitEthernet1/0/1]stp instance 0 cost 200 设置生成树实例0上路径开销为200 

    stp cost 设置当前端口在指定生成树实例上路径开销。instance-id 0-16 0cist 取值范围1-200000

    <h3c> display system-guard ip-record 显示防***记录信息

    system-guard enable 启用系统防***功能 

    display icmp statistics icmp流量统计 

    display ip socket 

    display ip statistics 

    display acl all 

    acl number acl-number match-order auto/config 

    acl-number (2000-2999 是基本acl 3000-3999是高级acl为管理员预留的编号

    rule deny/permit protocal 

    访问控制   [h3c] acl number 3000 

    [h3c-acl-adv-3000]rule permit tcp source 129.9.0.0 0.0.255.255 destination 202.38.160.0 0.0.255.255 destination-port eq 80 (定义高级acl 3000,允许129.0.0/16网段的主机向202.38.160/24网段主机访问端口80)

     

      rule permit source 211.100.255.0 0.255.255.255 

    rule deny cos 3 souce 00de-bbef-adse ffff-ffff-fff dest 0011-4301-9912 ffff-ffff-ffff 

    (禁止mac地址00de-bbef-adse发送到mac地址0011-4301-9912802.1p优先级为3的报文通过)

    display qos-interface GigabitEthernet1/0/1 traffic-limit 查看端口上流量

    端口速率限制 

    line-rate inbound/outbound target-rate 

    inbound:对端口接收报文进行速率限制

    outbound: 对端口发送报文进行速率限制

    target-rate 对报文限制速率,单位kbps 千兆口 inbound范围1-1000000 outbound范围20-1000000

     

    undo line-rate取消限速.

    [h3c]interface GigabitEthernet1/0/1 

    [h3c-GigabitEthernet1/0/1]line-rate outbound 128 限制出去速率为128kbps

    display arp | include 77

    display arp count 计算arp表的记录数

    display ndp 显示交换机端口的详细配置信息。

    display ntdp device-list verbose 收集设备详细信息

    display lock

    display users

    display cpu

    display memory

    display fan 

    display device

    display power

    转载于:https://blog.51cto.com/1215046331/1684525

    展开全文
  • h3c的交换机命令大全,适合网管参考使用.
  • H3C通用命令大全分享

    2019-05-27 19:55:00
    H3C>" 进入系统模式"[H3C]" <H3C>system-view 查看路由器IP的命令 [H3C] display ip routing-table 查看VLAN命令 [H3C]display vlan brief system-view进入系统视图模式 2、sysname为设备命名 3、...

    由用户模式 "<H3C>" 进入系统模式"[H3C]"

    <H3C>system-view

    查看路由器IP的命令

    [H3C] display ip routing-table


    查看VLAN命令

    [H3C]display vlan brief


    system-view  进入系统视图模式

    2、sysname  为设备命名

    3、displaycurrent-configuration 当前配置情况

    4、language-mode Chinese|English 中英文切换

    5、interfaceEthernet 1/0/1 进入以太网端口视图

    6、port link-type Access|Trunk|Hybrid 设置端口访问模式

    7、undo shutdown 打开以太网端口

    8、shutdown 关闭以太网端口

    9、quit 退出当前视图模式

    10、vlan 10 创建VLAN 10并进入VLAN 10的视图模式

    11、port access vlan 10 在端口模式下将当前端口加入到vlan 10中

    12、portE1/0/2 to E1/0/5 在VLAN模式下将指定端口加入到当前vlan中

    13、porttrunk permit vlan all 允许所有的vlan通过

    14、 ipaddress 192.168.1.1 255.255.255.0 配置IP地址和子网掩码

    15、undo shutdown 打开以太网端口

    16、shutdown 关闭以太网端口

    17、quit 退出当前视图模式

    18、 iproute-static 192.168.2.0 255.255.255.0 192.168.12.2 description To.R2 配置静态路由

    19、 iproute-static 0.0.0.0 0.0.0.0 192.168.12.2 description To.R2 配置默认的路由

    转载于:https://www.cnblogs.com/andy123/p/10932743.html

    展开全文
  • H3C路由器交换机配置命令大全1H3C路由器交换机配置命令大全1
  • H3C交换机常用命令大全

    万次阅读 多人点赞 2019-05-15 09:55:25
    一.用户配置: system-view [H3C]super password H3C 设置用户分级密码 [H3C]undo super password 删除用户分级密码 [H3C]localuser bigheap 123456 1 Web网管用户设置,1(缺省...[H3C]undo localuser bigheap 删...

    一.用户配置:

    system-view
    [H3C]super password H3C 设置用户分级密码
    [H3C]undo super password 删除用户分级密码
    [H3C]localuser bigheap 123456 1 Web网管用户设置,1(缺省)为管理级用户,缺省admin,admin
    [H3C]undo localuser bigheap 删除Web网管用户
    [H3C]user-interface aux 0 只支持0
    [H3C-Aux]idle-timeout 2 50 设置超时为2分50秒,若为0则表示不超时,默认为5分钟
    [H3C-Aux]undo idle-timeout 恢复默认值
    [H3C]user-interface vty 0 只支持0和1
    [H3C-vty]idle-timeout 2 50 设置超时为2分50秒,若为0则表示不超时,默认为5分钟
    [H3C-vty]undo idle-timeout 恢复默认值
    [H3C-vty]set authentication password 123456 设置telnet密码,必须设置
    [H3C-vty]undo set authentication password 取消密码
    [H3C]display users 显示用户
    [H3C]display user-interface 显示用户界面状态

    二.系统IP配置:

    [H3C]vlan 20
    [H3C]management-vlan 20
    [H3C]interface vlan-interface 20 创建并进入管理VLAN
    [H3C]undo interface vlan-interface 20 删除管理VLAN接口
    [H3C-Vlan-interface20]ip address 192.168.1.2 255.255.255.0 配置管理VLAN接口静态IP地址(缺省为192.168.0.234)
    [H3C-Vlan-interface20]undo ip address 删除IP地址
    [H3C-Vlan-interface20]ip gateway 192.168.1.1 指定缺省网关(默认无网关地址)
    [H3C-Vlan-interface20]undo ip gateway
    [H3C-Vlan-interface20]shutdown 关闭接口
    [H3C-Vlan-interface20]undo shutdown 开启
    [H3C]display ip 显示管理VLAN接口IP的相关信息
    [H3C]display interface vlan-interface 20 查看管理VLAN的接口信息
    debugging ip 开启IP调试功能
    undo debugging ip

    三.DHCP客户端配置:

    [H3C-Vlan-interface20]ip address dhcp-alloc 管理VLAN接口通过DHCP方式获取IP地址
    [H3C-Vlan-interface20]undo ip address dhcp-alloc 取消
    [H3C]display dhcp 显示DHCP客户信息
    debugging dhcp-alloc 开启DHCP调试功能
    undo debugging dhcp-alloc

    四.端口配置:

    [H3C]interface Ethernet0/3
    [H3C-Ethernet0/3]shutdown
    [H3C-Ethernet0/3]speed 100 速率,可为10,100,1000和auto(缺省)
    [H3C-Ethernet0/3]duplex full 双工,可为half,full和auto(缺省) 光口和汇聚后不能配置
    [H3C-Ethernet0/3]flow-control 开启流控,默认为关闭
    [H3C-Ethernet0/3]broadcast-suppression 20 设置抑制广播百分比为20%,可取5,10,20,100,缺省为100,同时组播和未知单播也受此影响
    [H3C-Ethernet0/3]loopback internal 内环测试
    [H3C-Ethernet0/3]loopback external 外环测试,需插接自环头,必须为全双工或者自协商模式
    [H3C-Ethernet0/3]port link-type trunk 设置链路的类型为trunk,可为access(缺省),trunk
    [H3C-Ethernet0/3]port trunk pvid vlan 20 设置20为该trunk的缺省VLAN,默认为1
    (trunk线路两端的PVID必须一致)
    [H3C-Ethernet0/3]port access vlan 20 将当前access端口加入指定的VLAN
    [H3C-Ethernet0/3]port trunk permit vlan all 允许所有的VLAN通过当前的trunk端口,可多次使用该命令
    [H3C-Ethernet0/3]mdi auto 设置以太端口为自动监测,normal(缺省)为直通线,across为交叉线
    [H3C]link-aggregation Ethernet 0/1 to Ethernet 0/4 将1-4口加入汇聚组,1为主端口,两端需要同时配置,设置了端口镜像以及端口隔离的端口无法汇聚
    [H3C]undo link-aggregation Ethernet 0/1 删除该汇聚组
    [H3C]link-aggregation mode egress 配置端口汇聚模式为根据目的MAC地址进行负荷分担,可选为 ingress,egress和both,缺省为both
    [H3C]monitor-port Ethernet 0/2 将该端口设置为镜像端口,必须先设置镜像端口,删除时必须先删除被镜像端口,而且它们不能同在一个端口,该端口不能在汇聚组中,设置新镜像端口时,新取代旧,被镜像不变
    [H3C]mirroring-port Ethernet 0/3 to Ethernet 0/4 both 将端口3和4设置为被镜像端口,both为同时监控接收和发送的报文,inbound表示仅监控接收的报文,outbound表示仅监控发送的报文
    [H3C]display mirror
    [H3C]display interface Ethernet 0/3
    reset counters 清除所有端口的统计信息
    [H3C]display link-aggregation Ethernet 0/3 显示端口汇聚信息
    [H3C-Ethernet0/3]virtual-cable-test 诊断该端口的电路状况

    五.VLAN配置:

    [H3C]vlan 2
    [H3C]undo vlan all 删除除缺省VLAN外的所有VLAN,缺省VLAN不能被删除
    [H3C-vlan2]port Ethernet 0/4 to Ethernet 0/7 将4到7号端口加入到VLAN2中,此命令只能用来加access端口,不能用来增加trunk或者hybrid端口
    [H3C-vlan2]port-isolate enable 打开VLAN内端口隔离特性,不能二层转发,默认不启用该功能
    [H3C-Ethernet0/4]port-isolate uplink-port vlan 2 设置4为VLAN2的隔离上行端口,用于转发二层数据,只能配置一个上行端口,若为trunk,则建议允许所有VLAN通过,隔离不能与汇聚同时配置
    [H3C]display vlan all 显示所有VLAN的详细信息
    S1550E支持基于端口的VLAN,通过创建不同的user-group来实现,一个端口可以属于多个user-group,不属于同一个user-group的端口不能互相通信,最多支持50个user-group
    [H3C]user-group 20 创建user-group 20,默认只存在user-group 1
    [H3C-UserGroup20]port Ethernet 0/4 to Ethernet 0/7 将4到7号端口加入到VLAN20中,初始时都属于user-group 1中
    [H3C]display user-group 20 显示user-group 20的相关信息

    六.集群配置:

    S2100只能作为成员交换机加入集群中,加入后系统名改为"集群名_成员编号.原系统名"的格式.
    即插即用功能通过两个功能实现: 集群管理协议MAC组播地址协商和管理VLAN协商
    [H3C]cluster enable 启用群集功能,缺省为启用
    [H3C]cluster 进入群集视图
    [H3C-cluster]administrator-address H-H-H name switch H-H-H为命令交换机的MAC,加入switch集群
    [switch_1.H3C-cluster]undo administrator-address 退出集群
    [H3C]display cluster 显示集群信息
    [H3C]management-vlan 2 集群报文只能在管理VLAN中转发,同一集群需在同一个管理VLAN中,需在建立集群之前指定管理VLAN
    debugging cluster

    七.QoS配置:

    QoS配置步骤:设置端口的优先级,设置交换机信任报文的优先级方式,队列调度,端口限速
    [H3C-Ethernet0/3]priority 7 设置端口优先级为7,默认为0
    [H3C]priority-trust cos 设置交换机信任报文的优先级方式为cos(802.1p优先级,缺省值),还可以设为dscp方式(dscp优先级方式)
    [H3C]queue-scheduler hq-wrr 2 4 6 8 设置队列调度算法为HQ-WRR(默认为WRR),权重为2,4,6,8
    [H3C-Ethernet0/3]line-rate inbound 29 将端口进口速率限制为2Mbps,取1-28时,速率为rate81024/125,即64,128,192…1.792M;29-127时,速率为(rate-27)*1024,即2M,3M,4M…100M,千兆时可继续往下取,128-240时,速率为(rate-115)81024,即104M,112M,120M…1000M
    [H3C]display queue-scheduler 显示队列调度模式及参数
    [H3C]display priority-trust 显示优先级信任模式

    八.系统管理:

    [H3C]mac-address blackhole H-H-H vlan 1 在VLAN1中添加黑洞MAC
    [H3C]mac-address static H-H-H interface Ethernet 0/1 vlan 1 在VLAN1中添加端口一的一个mac
    [H3C]mac-address timer aging 500 设置MAC地址表的老化时间为500s
    [H3C]display mac-address
    [H3C]display arp
    [H3C]mac-address port-binding H-H-H interface Ethernet 0/1 vlan 1 配置端口邦定
    [H3C]display mac-address port-binding
    [H3C]display saved-configuration
    [H3C]display current-configuration
    save
    [H3C]restore default 恢复交换机出厂默认配置,恢复后需重启才能生效
    [H3C]display version
    reboot
    [H3C]display device
    [H3C]sysname bigheap
    [H3C]info-center enable 启用系统日志功能,缺省情况下启用
    [H3C]info-center loghost ip 192.168.0.3 向指定日志主机(只能为UNIX或LINUX,不能为Windows)输出信息,需先开启日志功能,缺省关闭
    [H3C]info-center loghost level 8 设置系统日志级别为8,默认为5.级别说明:1.emergencies 2.alerts 3.critical 4.errors 5.warnings 6.notifications 7.informational 8.debugging
    terminal debugging 启用控制台对调试信息的显示,缺省控制台为禁用
    terminal logging 启用控制台对日志信息的显示,缺省控制台为启用
    terminal trapping 启用控制台对告警信息的显示,缺省控制台为启用
    [H3C]display info-center 显示系统日志的配置和缓冲区记录的信息
    [H3C]display logbuffer 显示日志缓冲区最近记录的指定数目的日志信息
    [H3C]display trapbuffer 显示告警缓冲区最近记录的指定数目的日志信息
    reset logbuffer 清除日志缓冲区的信息
    reset trapbuffer 清除告警缓冲区的信息

    九.网络协议配置:

    NDP即是邻居发现协议,S1550E只能开启或关闭NDP,无法配置,默认有效保留时间为180s,NDP报文发送的间隔60s
    [H3C]ndp enable 缺省情况下是开启的
    [H3C-Ethernet0/3]ndp enable 缺省情况下开启
    [H3C]display ndp 显示NDP配置信息
    [H3C]display ndp interface Ethernet 0/1 显示指定端口NDP发现的邻居信息
    debugging ndp interface Ethernet 0/1
    HABP协议即Huawei Authentication Bypass Protocol,华为鉴权旁路协议,是用来解决当交换机上同时配置了802.1x和HGMPv1/v2时,未经授权和认证的端口上将过滤HGMP报文,从而使管理设备无法管理下挂的交换机的问题。交换机启动HABP后,将忽略802.1x认证。
    HABP包括服务器和客户端,由服务器定期发送请求,客户端进行应答,并向下进行转发,服务器一般启动在管理设备上,客户机在下挂设备上启动,1550E只支持客户端。
    [H3C]habp enable 启动HABP特性,缺省即启动,启动后即缺省为客户机模式
    debugging habp 启动HABP调试功能
    NTDP即邻居拓扑发现协议,用来收集网络拓扑信息的协议,与NDP协议一起工作,用于集群管理,S1550E的配置主要包括开启与关闭功能能,开启与关闭调试功能
    [H3C]ntdp enable 缺省情况下为开启的
    [H3C-Ethernet0/3]ntdp enable 缺省情况下为使能
    debugging ntdp

    十.SNMP配置:

    S1550E支持SNMPv1,SNMPv2c,主要配置包括:设置团体名,设置系统信息,设置Trap目标主机的地址,允许或禁止发送Trap,禁止SNMP Agent的运行
    [H3C]snmp-agent community read bigheap 设置bigheap团体,且为只读访问
    [H3C]snmp-agent max-size 1600 设置Agent能接受/发送的SNMP消息包最大为1600字节,缺省1500
    [H3C]snmp-agent sys-info contact #27345 location Diqiu version v2c 设置系统信息,版本为v2c,缺省情况下联系信息为"R&D Hangzhou, H3C Technologies co.,Ltd.",位置为"Hangzhou China",v2c版本
    [H3C]undo snmp-agent 禁止SNMP Agent的运行,若配置任何SNMP命令将重新启动SNMP Agent
    [H3C]display snmp-agent community read
    [H3C]display snmp-agent sys-info contact
    [H3C]display snmp-agent sys-info location
    [H3C]display snmp-agent sys-info version
    debugging snmp-agent packet|process

    十一.IGMP Snooping配置:

    IGMP Snooping是运行在二层交换机上的组播约束机制,用于管理和控制组播组.主要负责建立和维护二层MAC地址表,同时根据建立的组播地址表来转发路由器下发的组播报文,如果不运行IGMP Snooping,则组播报文将在二层网络中广播
    IGMP Snooping配置包括:启动和关闭IGMP Snooping,配置路由器端口老化时间,配置最大响应查询时间,配置组播组成员端口老化时间,配置端口快速离开,调试功能
    [H3C]igmp-snooping 启用IGMP Snooping功能,默认为关闭
    [H3C]igmp-snooping router-aging-time 500 配置路由器端口老化时间为500s,默认为105s
    [H3C]igmp-snooping max-response-time 15 配置最大响应查询时间为15s,默认为10s
    [H3C]igmp-snooping host-aging-time 300 配置组播组成员端口老化时间为300s,默认为260s
    [H3C-Ethernet0/3]igmp-snooping fast-leave 配置快速离开,若收到离开报文,则立即删除端口,不询问
    [H3C]display igmp-snooping configuration 显示配置信息
    [H3C]display igmp-snooping statistics 显示包统计信息
    [H3C]display igmp-snooping group vlan 2 显示VLAN2中IP组播组和MAC组播组的信息
    reset igmp-snooping statistics 清楚统计信息
    debugging igmp-snooping

    十二.系统调试:

    debugging all 开启所有调试开关,此命令为协议调试开关
    terminal debugging 终端调试开关,打开开关,默认为关闭
    debugging drv 主要显示报文的实际内容,默认为关闭
    [H3C]display debugging 显示调试开关状态

    十三.802.1x配置:

    [H3C-Ethernet0/3]dot1x 开启802.1x特性,也可在系统视图下使用,使用后全局开启,也可用 interface参数开启指定端口的802.1x特性,缺省全关闭,要启用802.1x,全局和端口的都需开启
    [H3C-Ethernet0/3]dot1x port-control unauthorized-force 设置工作模式为强制非授权模式,使用 模式与dot1x命令相同,默认为auto,即通过了认证才可以访问,还有authorized-force,为强制授权 模式,允许用户访问
    [H3C-Ethernet0/3]dot1x port-method portbased 设置接入控制方式为基于端口的,使用模式与 dot1x命令相同,默认为macbase,基于MAC地址的
    [H3C-Ethernet0/3]dot1x max-user 10 设置端口接入用户的数量最大为10个,使用模式与dot1x命令 相同,默认为128,取值范围为1-128
    [H3C]dot1x authentication-method eap 设置802.1x的用户认证方法为EAP,即EAP中继,直接用EAP报 文发送到服务器,需服务器支持
    [H3C-Ethernet0/3]dot1x re-authenticate 开启802.1x重认证功能使交换机以一定时间间隔周期性 的进行认证,使用模式同dot1x命令,缺省情况下所有端口该特性都关闭
    [H3C]dot1x timer handshake-period 20 reauth-period 7200 quiet-period 30 tx-period 20 supp- timeout 20 server-timeout 200 设置802.1x认证的定时器,handshake-period为认证成功后, 系统以此间隔为周期发送握手请求报文(相当于keepalive消息发送间隔),1-1024s,默认15s.
    reauth-period为重认证超时定时器,1-86400s,默认3600s.
    quiet-period为用户认证失败后,Autheticator的静默定时器,静默后再处理认证,10-120s,默认60s.
    tx-period为传送超时定时器,Supplicant未成功发送认证应答报文,则重发认证请求,10-120s,默认 为30s.
    supp-timeout为认证超时定时器,Supplicant未成功响应,则重发认证请求,10-120s,默认30s.
    server-timeout为服务器未成功响应的超时定时器,100-300s,默认100s.
    reset dot1x statistics 清除802.1x统计信息
    [H3C]display dot1x statistics 显示802.1x的配置,运行情况和统计信息
    debugging dot1x 打开802.1x的相关模块的调试信息

    十四.RADIUS配置:

    [H3C]radius scheme system 进入system方案,其各项值为缺省值,1550E只支持默认方案
    [H3C-radius-system]primary authentication 10.110.1.1 1812 设置RADIUS服务器地址和UDP端口 号,默认情况下,system方案中服务器IP地址为空,UDP端口号为1812
    [H3C-radius-system]key authentication 123 指示RADIUS加密共享密钥为123,默认无共享密钥
    [H3C-radius-system]timer 10 设置RADIUS服务器响应超时定时器,1-10s,默认为5s
    [H3C-radius-system]retry 10 设置RADIUS服务器最大响应重试次数为10,1-20次,默认为5次
    [H3C]display radius 显示radius方案信息
    debugging radius packet 打开radius报文调试开关

    展开全文

空空如也

空空如也

1 2 3 4 5 ... 11
收藏数 208
精华内容 83
关键字:

h3c命令大全