精华内容
下载资源
问答
  • 很多时候我们使用路由器,都会划分多个网段,然后依据自己和访客不同网段去做不同限速规则或者行为管控,那么如何实现不同网段的互访呢,具体要取决于的所用路由品牌多网口互通两个情况第一种:多网卡桥接,所有网...

    53530f036df871ba4ad135a3c9d64219.png

    很多时候我们使用路由器,都会划分多个网段,然后依据自己和访客不同网段去做不同限速规则或者行为管控,那么如何实现不同网段的互访呢,具体要取决于的所用路由品牌

    多网口互通分两个情况

    第一种:多网卡桥接,所有网口相当于交换机接出来的,此时所有数据二层交换,必须要同一个网段才能互访,此情况下无法隔离多个网段,所以我们看下一种方法。

    第二种:多网卡分别设置不同lan,多个广播域互相隔离,由路由器进行三层转发。此时不同路由器可能会有不同的表现,如刷爱快路由器默认就是所有lan、vlan可以互相访问

    如下拓扑:

    2a4c7dc48d32b9fd72fc1cff40ea5193.png

    (1)当a电脑访问b电脑的时候,a:「我是1.2,我要发给2.2,我发给1.254就能送过去)

    (2)爱快路由器收到后,分析接口掩码,lan1 lan2的掩码都是/24,匹配到lan2接口,于是直接发送给了b电脑。

    (3)b电脑收到后再回复给a电脑,b:「我是2.2,我要发给1.2,我发给2.254就能送过去)

    (4)爱快路由器收到后,分析接口掩码,匹配到lan1接口,于是直接发送给了a电脑。

    到此,数据访问交互完成。

    默认状态下路由转发,需要a.b设备正确设置网关才可以,如果你的设备不支持网关设置。

    因为b电脑收到的数据,来自1.2,b电脑2.x网段/24掩码 且没有网关,也就没去往1.2的路径,b直接将数据丢弃,a就收不到了

    此时可以在nat转发里加一条规则,源地址1.2,目的地址2.2,动作转发

    a发给b的数据,路由器将数据在lan2发出去的时候,对数据修改,本来是1.2发过来的会修改成2.254发出来的

    经过nat转发动作后,b电脑收到的是数据来自2.254.匹配的到自身掩码。于是将数据发给lan2,爱快路由器再根据nat映射关系,将收到的数据包修改回1.2位置并对应转发,交互完成,互访成功

    如果不希望a,b两台电脑互访,可以在路由器上定义acl规则,阻断转发即可,如原源地址1.2,目的地址2.2,那么路由器在(1)接收到a发过来的数据后,直接匹配规则进行丢弃,数据就不会再发给b电脑了。

    如果其他路由器默认禁止互访,可以通过acl规则定义允许转发即可。

    展开全文
  • 在实际项目有可能会遇到,也有不少的朋友在问起,之前发布的内容中我们有一大概的介绍,本期我们来详细总结下具体如何实现录像机添加不同网段ip的摄像头?常用的有种方法。方法一、使用双网口录像机添加不同...

    录像主机怎样添加不同网段ip的摄像头?这个在实际项目有可能会遇到,也有不少的朋友在问起,之前发布的内容中我们有一个大概的介绍,本期我们来详细总结下具体如何实现录像机添加不同网段ip的摄像头?常用的有两种方法。

    方法一、使用双网口录像机添加不同网段的摄像头

    我们可以使用双网口的录像主机,就能实现添加不同网段的摄像头,通常双网口录像机的有两种工作模式, 网络容错、多址设定。

    而添加不同网段的摄像头,一般选用的就是多址设定模式,假设录像主机是192.168.1.x网段,而摄像头是192.168.0.x网段,这样添加摄像头。

    步骤一、在录像机主菜单-【系统配置】-【网络配置】-【基本配置】将工作模式改成多址设定,网卡选择LAN1,设置录像主机IP为192.168.1.100,因为LAN1是连接路由器,外网访问的,因此默认选择LAN1。

    a9b9af2d05d40be250ef6b39a9c1abea.png

    步骤二、连接摄像头
    像头的交换机接到录像主机的LAN2口,网卡选择LAN2,设置录像主机LAN2的IP地址为192.168.0.100。

    cded2144cbde8d948e5255e712f29046.png

    录像主机有两个IP,LAN1是用来连接外网,远程访问;LAN2是用来添加同网段的摄像头,然后再通道管理-IP通道管理里面添加摄像头,这样就能实现添加不同网段的摄像头。

    方法二、修改子网掩码

    你可能会问弱电行业网,有没有更简单的方法,其实是有的,对于一般两个不同的ip地址,更简单的方法是可以通过修改子网掩码来完成的,然后直接添加,不用过多设置。

    举例:

    例如两个网段的ip地址:

    ip地址一、192.168.1.x

    ip地址二:192.168.0.x

    如果不想设置,一般我们可以把子网掩码从255.255.255.0改成255.255.252.0,当然也有的朋友会直接改成255.255.0.0,不过还是建议子网掩码越精准越好。

    原理其实就是把不同的网段,变成相同的网段,这里也说明了一点,子网掩码的作用是获取网络IP地址分割网络。

    展开全文
  • 关注我,你的眼睛会怀孕拓扑图规格适用于所有版本、所有形态的AR路由器。组网需求RouterA和RouterC属于相同的子网,通过在RouterB上启用代理ARP功能来实现RouterA和RouterC的通信。操作步骤1.RouterA上的配置 # ...

    关注我,你的眼睛会怀孕

    768778288f2b7bf1c0b50376531b627b.png

    6e043798bc456b58f6448db9e41c4c2a.gif

    拓扑图

    7f5508b74f3b16fe41ba18bb4764140a.png

    6e043798bc456b58f6448db9e41c4c2a.gif

    规格

    适用于所有版本、所有形态的AR路由器。

    6e043798bc456b58f6448db9e41c4c2a.gif

    组网需求

    RouterA和RouterC属于相同的子网,通过在RouterB上启用代理ARP功能来实现RouterA和RouterC的通信。

    6e043798bc456b58f6448db9e41c4c2a.gif

    操作步骤

    1.RouterA上的配置 #                                                                              interface GigabitEthernet0/0/0                                                   ip address 10.1.1.2 255.255.0.0                                                                                                   #2.RouterB上的配置 #                                                                              interface GigabitEthernet0/0/0                                                   ip address 10.1.1.1 255.255.255.0 arp-proxy enable                                                                                                   #                                                                              interface GigabitEthernet0/0/1                                                   ip address 10.1.2.2 255.255.255.0   arp-proxy enable                                                                                                  #3.RouterC上的配置 #                                                                         interface GigabitEthernet0/0/1                                                   ip address 10.1.2.1 255.255.0.0                                                                                                   #

    6e043798bc456b58f6448db9e41c4c2a.gif

    验证配置结果

    # 在RouterB上使能代理ARP功能后,在RouterA上ping 10.1.2.1,发现可以ping通。在RouterB上执行display arp,查看其ARP表项如下:

    50e0e9c94ca500ec9c242abc2d7de9fe.png

    1

    end

    年度热文

    65d34b1ab66babef53ce3df29397bea0.png

    30岁还能入行干网络工程师吗?

    人手必备的网络故障排除工具

    【干货】救火必备:线上故障排查套路大全

    【干货】为什么我的Redis总比别人的慢?

    【干货】面试官:网络排错会不会?

    【教程】瘦AP升级为胖AP的终极大法

    【扎心】到底是谁把路由规划冲突了!

    【基础】面试官:你解释一下什么是TCP的固定窗口和滑动窗口

    【收藏】用户私自搭建伪服务器怎么办?禁它

    【工具】这几款免费的内网监控软件真的绝了,附下载链接

    【超详细】模拟器EVE的安装与使用,附下载链接

    【干货】一文汇总网络基础知识大全

    【必看】2020年最全运维岗位技能风向标!


    15bcf2ccd8a18718edecbb7de3d5f557.png

    系统集成/认证培训

    买设备,找我们

    IT维保,找我们

    IT培训,找我们

    展开全文
  • 静态路由的配置很简单,可有些细节还是需要注意,主要包括两个方面。1. 静态路由所指定的下一跳路由器,必须是可达的。否则,这样的路由即使能在路由表里产生,也无法生效。2. 针对以太网这种特殊用途:通过指定出...

    静态路由

    静态路由作为开销小、配置简单的一种产生路由信息的方式,在实际中有着广泛的用途。特别是对于一些简单网络或某些网络的出口,通过配置静态路由的方式能很容易地解决寻路的问题。

    664df611650f8c3bbb026363126bb744.png

    静态路由的配置很简单,可有些细节还是需要注意,主要包括两个方面。

    1. 静态路由所指定的下一跳路由器,必须是可达的。否则,这样的路由即使能在路由表里产生,也无法生效。

    2. 针对以太网这种特殊用途:通过指定出接口的方式并不能产生静态路由。

    静态路由实现网络互通

    42e488de4326c2b5bcfa496bf3d8049b.png

    1. 实验拓扑如图所示

    2. PCA、PCB分别模拟一个局域网

    3. 两局域网通过路由器连接在一起

    4. 要实现的目标是PCA、PCB能互相访问

    PC机配置:(略)

    路由器的相关配置:

    RouterA的配置:

    [H3C]sysname RouterA 设备命名

    [RouterA]interface Ethernet 0/0 进入接口配置界面

    [RouterA-Ethernet0/0]ip address 192.168.1.1 24 配置地址,作为PCA网关

    [RouterA-Ethernet0/0]quit 从接口界面退出

    [RouterA]interface Ethernet 0/1 进入接口配置界面

    [RouterA-Ethernet0/1]ip address 1.1.1.1 24 配置地址,路由器间直连的地址

    [RouterA-Ethernet0/1]quit 从接口界面退出

    [RouterA]ip route-static 192.168.2.0 255.255.255.0 1.1.1.2 配置去往PCB的路由

    c619cbcd7bbcc4f78fc3cf116016aebc.png

    RouterB的配置:

    [H3C]sysname RouterB 设备命名

    [RouterB]interface Ethernet 0/0 进入接口配置界面

    [RouterB-Ethernet0/0]ip address 192.168.2.1 24 配置地址,作为PCB网关

    [RouterB-Ethernet0/0]quit 从接口界面退出

    [RouterB]interface Ethernet 0/1 进入接口配置界面

    [RouterB-Ethernet0/1]ip address 1.1.1.2 24 配置地址,路由器间直连的地址

    [RouterB-Ethernet0/1]quit 从接口界面退出

    [RouterA]ip route-static 192.168.1.0 255.255.255.0 1.1.1.1 配置去往PCA的路由

    9b235a6640559d3d0bc3e1874ada2c6f.png

    测试的方法有两种:

    1. 通过查看命令

    [RouterA]display ip routing-table

    Routing Tables: Public

    Destinations : 7 Routes : 7

    Destination/Mask Proto Pre Cost NextHop Interface

    1.1.1.0/24 Direct 0 0 1.1.1.1 E0/1

    1.1.1.1/32 Direct 0 0 127.0.0.1 InLoop0

    127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0

    127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0

    192.168.1.0/24 Direct 0 0 192.168.1.1 E0/0

    192.168.1.1/32 Direct 0 0 127.0.0.1 InLoop0

    192.168.2.0/24 Static 60 0 1.1.1.2 E0/1 静态路由

    查看另一路由器结果也一样。

    2. 通过ping命令检测

    [RouterA]ping –a 192.168.1.1 192.168.2.2 以192.168.1.1为源地址ping192.168.2.2

    PING 192.168.2.2: 56 data bytes, press CTRL_C to break

    Reply from 192.168.2.2: bytes=56 Sequence=1 ttl=255 time=1 ms

    Reply from 192.168.2.2: bytes=56 Sequence=2 ttl=255 time=1 ms

    Reply from 192.168.2.2: bytes=56 Sequence=3 ttl=255 time=1 ms

    Reply from 192.168.2.2: bytes=56 Sequence=4 ttl=255 time=1 ms

    Reply from 192.168.2.2: bytes=56 Sequence=5 ttl=255 time=1 ms

    --- 192.168.2.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 1/1/1 ms


    4eca48cb98c5e530a7e622325d7dd980.png

    说明:

    1. 配置静态路由时必须注意要想全网互通,则从任意一台路由器上必须有去往所有网段的路由信息。

    2. 对于以太网来说,下一跳必须是对端IP地址。

    3. 对于路由器来说,它有各种不同的接口,实验时要根据实际情况选择正确的接口类型和编号。

    缺省路由

    0b2526d863aa155f96da8c24c891bab2.png

    1. 在这里我们用RouterB模拟公网

    2. 在RouterB上配置一些LOOPBACK接口,模拟公网上的一些网段

    3. 通过合理使用具体的静态路由和缺省的静态路由使全网互通

    PC机配置:(略)

    RouterA的相关配置:

    [H3C]sysname RouterA 设备命名

    [RouterA]interface Ethernet 0/0 进入接口配置界面

    [RouterA-Ethernet0/0]ip address 192.168.1.1 24 配置地址,作为PCA网关

    [RouterA-Ethernet0/0]quit 从接口界面退出

    [RouterA]interface Ethernet 0/1 进入接口配置界面

    [RouterA-Ethernet0/1]ip address 1.1.1.1 30 配置地址,路由器间直连的地址

    [RouterA-Ethernet0/1]quit 从接口界面退出

    [RouterA]ip route-static 0.0.0.0 0.0.0.0 1.1.1.2 配置去往任意目的的缺省路由

    76844b9601f22bf396fc72c04fdb591c.png

    RouterB的相关配置:

    [H3C]sysname RouterB 设备命名

    [RouterB]interface Ethernet 0/0 进入接口配置界面

    [RouterB-Ethernet0/0]ip address 1.1.1.1 30 配置地址,作为与RouterA的直连地址

    [RouterB-Ethernet0/0]quit 从接口界面退出

    [RouterB]interface Ethernet 0/1 进入接口配置界面

    [RouterB-Ethernet0/1]ip address 2.2.2.1 30 配置地址,作为与RouterC的直连地址

    [RouterB-Ethernet0/1]quit 从接口界面退出

    [RouterB]interface LoopBack 0 创建一个loopback接口

    [RouterB-LoopBack0]ip address 3.3.3.1 32 给此接口配上IP地址,默认掩码32位

    [RouterB-LoopBack0]quit

    [RouterB]interface LoopBack 1 这样的虚接口可以配置许多个

    [RouterB-LoopBack1]ip address 4.4.4.1 32 每个类似于一个物理接口,配置不同IP

    [RouterB-LoopBack1]quit

    [RouterB]ip route-static 192.168.1.0 255.255.255.0 1.1.1.1 配置去往PCA的路由

    [RouterB]ip route-static 192.168.2.0 255.255.255.0 2.2.2.2 配置去往PCB的路由

    7688fe3b2a87f5ea23f7a153b91c40fa.png

    RouterC的相关配置:

    [H3C]sysname RouterC 设备命名

    [RouterC]interface Ethernet 0/0 进入接口配置界面

    [RouterC-Ethernet0/0]ip address 192.168.2.1 24 配置地址,作为PCB的网关

    [RouterC-Ethernet0/0]quit 从接口界面退出

    [RouterC]interface Ethernet 0/1 进入接口配置界面

    [RouterC-Ethernet0/1]ip address 2.2.2.2 30 配置地址,路由器间直连的地址

    [RouterC-Ethernet0/1]quit 从接口界面退出

    [RouterC]ip route-static 0.0.0.0 0.0.0.0 2.2.2.1 配置去往任意目的的缺省路由

    测试

    通过ping的命令,分别在PCA、PCB上ping其他地址,能ping通说明配置无误。


    d98f7610f01a1ef5daffc76d6ef06d52.png

    说明:

    1. 对于缺省路由来说,其用途是非常广泛的,根据具体情况灵活使用。

    2. 通过配置缺省路由和具体的静态路由可实现多出口的负载分担。

    展开全文
  • 对于监控项目来说,很多故障的原因都是跟ip地址设置不当有关,如ip冲突,或者有几路监控图像没有显示等,都是跟ip有一定...第一、如果超过254点位不划分网段的话,让系统自动分配ip地址的话,容易产生ip冲突。第二...
  • 今天我们来讲一下策略路由,如果有2条外线,如何实现数据分流,该怎么办呢,话不多说上拓扑图:web设置法# 在路由器接口面板找到LAN接口,用网线将电脑和设备的任意一LAN接口连在一起,电脑可以自动获取IP地址。...
  • 首先查下拓扑结构通过查询A、B两段的路由情况,绘制出如下拓扑:需求很明确:两个网段不可以互通。可以通过哪些方式去解决?该文章发散性问题,大家一起开动大脑来提出解决方法。我先提出解决方式1:若Shengw-PE下面...
  • 现要求通过配置基于端口的VLAN和VLAN接口实现下面应用需求: 1、同一VLAN内的主机能够二层互通,不同VLAN内的主机不能二层互通,能够三层互通。 2、通过配置使Device A作为部门A中用户的网关,Device B作为部门B中...
  • 日常工作中,我们有时会遇到不同网段的两个路由器如何互通?这个就需要配置静态路由了。 路由器的桥接功能一般应用在家用中...一台路由器连接另外一台路由器,这两台路由器分别连接不同的网段,那么如果要这两个网段...
  • 路由器的桥接功能一般应用在家用中较多,而静态路由的...一台路由器连接另外一台路由器,这两台路由器分别连接不同的网段,那么如果要这两个网段互通,则必须配置路由,这个就是静态路由。例如:A路由wan口192.168...
  • 不同网段的两个路由器如何互通?这个就需要配置静态路由了。路由器的桥接功能一般应用在家用...一台路由器连接另外一台路由器,这两台路由器分别连接不同的网段,那么如果要这两个网段互通,则必须配置路由,这个就...
  • 划分VLAN让两个网段互通
  • 的两种方法,有弱电VIP群里的朋友就接着问到了我们,不同网段两个路由器如何互通?这个就需要配置静态路由了。路由器的桥接功能一般应用在家用中较多,而静态路由的配置确是在项目中经常会应用,主要可以解决两个...
  • 一文了解清楚,有弱电VIP群里的朋友就接着问到了我们,不同网段两个路由器如何互通?这个就需要配置静态路由了。路由器的桥接功能一般应用在家用中较多,而静态路由的配置确是在项目中经常会应用,主要可以解决...
  • 前段时间弱电君分享了关于...一、同一个vlan中,不同网段的主机如何互通同一个vlan,不同网段的主机如何互通,这个在小型网络中用的比较多,我们一起来看案例。1、拓扑图要求:实现拓扑图中,两个主机之间互访,他们...
  • 增加了一个路由器,分了两个网段,A子网和B子网处于不同网段,当网络中存在多个路由器时,要求不同路由器下属的子网可以互相通讯,同时又可以通过宽带路由器上网,这如何实现?案例情景1企业通过一台路由器R1上网,...
  • 如果台计算机在一相同网段,不需要辅助设备(网关)的帮助,可以直接通信。如果台计算机在不同网段,一定需要辅助设备(网关)的接力帮助,实现间接通信。上文一下子出现很多陌生名词,需要解释:相同网段计算机A...
  • 为了保证无线的覆盖,估计很多人家里都有好几个路由器,但是如果要让每个路由器下的设备可以互联互通,那么就必须保证每个路由器都在同一个网段下面,简单说就是同一个局域网,或者用静态路由表转发的方式让不同网段...
  • 在我们弱电VIP群里就有朋友项目中遇到相关的问题了,不同网段两个路由器如何互通?这个就需要配置静态路由了。路由器的桥接功能一般应用在家用中较多,而静态路由的配置确是在项目中经常会应用,主要可以解决两个...
  • 企业随着员工或部门的增多,增加了一个路由器,分了两个网段,A子网和B子网处于不同网段,当网络中存在多个路由器时,要求不同路由器下属的子网可以互相通讯,同时又可以通过宽带路由器上网,这如何实现?...
  • 如果台计算机在一相同网段,不需要辅助设备(网关)的帮助,可以直接通信。如果台计算机在不同网段,一定需要辅助设备(网关)的接力帮助,实现间接通信。上文一下子出现很多陌生名词,需要解释:相同网段计算机A...
  • 但是有好多人对IP这概念还是不太清楚,尤其是子网掩码,IP网段之类的有些疑问,还有就是划分vlan和用子网掩码有什么不太,那么今天我们一起来解下这方面的内容。一、什么是子网掩码?在了解ip地址的网段之前,我们...
  • 网络拓扑注解:上面两台主机是我们欲做路由器且装有多个网卡和LInux操作系统的PC机,其中Route1装有两个网卡,其中一个网卡(设备名eth1)的IP地址为192.168.1.250,另一个网卡(设备名eth0)的IP地址为192.168.2....
  • 不同网段的两个路由器如何互通?这个就需要配置静态路由了。路由器的桥接功能一般应用在家用...一台路由器连接另外一台路由器,这两台路由器分别连接不同的网段,那么如果要这两个网段互通,则必须配置路由,这个就...
  • 增加了一个路由器,分了两个网段,A子网和B子网处于不同网段,当网络中存在多个路由器时,要求不同路由器下属的子网可以互相通讯,同时又可以通过宽带路由器上网,这如何实现?本期我们通过路由器的操作,来实现三种...
  • 的两种方法,有弱电VIP群里的朋友就接着问到了我们,不同网段两个路由器如何互通?这个就需要配置静态路由了。路由器的桥接功能一般应用在家用中较多,而静态路由的配置确是在项目中经常会应用,主要可以解决两个...
  • 直连路由、静态路由:直连路由:接口配置正确的IP地址和掩码,物理UP和协议UP静态路由:由管理员手动配置和维护的路由。静态路由配置简单,并且无需像动态路由那样占用路由器的CPU资源来计算和分析路由更新,度量值...
  • 路由器的桥接功能一般应用在家用中较多,而静态路由的...一台路由器连接另外一台路由器,这两台路由器分别连接不同的网段,那么如果要这两个网段互通,则必须配置路由,这个就是静态路由。例如:A路由wan口192.168...
  • 的两种方法,有朋友就接着问到了我们,不同网段两个路由器如何互通?这个就需要配置静态路由了。路由器的桥接功能一般应用在家用中较多,而静态路由的配置确实在项目中经常会应用,主要可以解决两个不同网段路由器...

空空如也

空空如也

1 2 3 4 5
收藏数 88
精华内容 35
关键字:

两个网段如何互通