精华内容
下载资源
问答
  • 华为 BGP/MPLS VP#实验

    千次阅读 多人点赞 2021-01-12 11:18:12
    哈喽,大家好!...ip address 10.1.47.4 24 [AR4]bgp 100 [AR4-bgp]ipv4-family vp#-instance ybd666 [AR4-bgp-ybd666]peer 10.1.47.7 as 64523 华为设备当将BGP路由引入到IGP时,只将EBGP路由引入。 AR7 ...

    哈喽,大家好!我是艺博东 ,是一个思科出身、专注于华为的网工;好了,话不多说,我们直接进入正题。

    由于特殊原因,所以把“N”字母替换为“#”符号。

    一、拓扑

    在这里插入图片描述

    二、基础配置与分析

    1、将骨干网络打通IGP
    2、配置公网的LSP隧道,PE,P设备的loopack的主机路由建立LSP
    3、PE之间配置MP-IBGP邻居关系(可以通过RR简化MP-IBGP全互联邻居关系)
    4、VP#业务接入配置,在PE上创建VPN实例,接入用户私网路由

    IS-IS

    AR2

    [Huawei]sysname AR2
    [AR2]int l0
    [AR2-LoopBack0]ip address  2.2.2.2 32
    [AR2-LoopBack0]int g0/0/0
    [AR2-GigabitEthernet0/0/0]ip address  10.1.23.2 24
    [AR2-GigabitEthernet0/0/0]q
    [AR2]isis 
    [AR2-isis-1]network-entity 12.0001.0000.0000.0002.00
    [AR2-isis-1]is-level level-2
    [AR2-isis-1]int g0/0/0
    [AR2-GigabitEthernet0/0/0]isis enable 
    [AR2-GigabitEthernet0/0/0]int l0
    [AR2-LoopBack0]isis enable 
    [AR2-LoopBack0]q
    [AR2]int g0/0/1
    [AR2-GigabitEthernet0/0/1]ip address  10.1.12.2 24
    

    AR3

    [Huawei]sysname AR3
    [AR3]int l0
    [AR3-LoopBack0]ip address  3.3.3.3 32
    [AR3-LoopBack0]int g0/0/0
    [AR3-GigabitEthernet0/0/0]ip address  10.1.34.3 24
    [AR3-GigabitEthernet0/0/0]int g0/0/1
    [AR3-GigabitEthernet0/0/1]ip address 10.1.23.3 24
    [AR3-GigabitEthernet0/0/1]q
    [AR3]isis 
    [AR3-isis-1]network-entity 12.0001.0000.0000.0003.00
    [AR3-isis-1]is-level level-2
    [AR3-isis-1]int l0
    [AR3-LoopBack0]isis enable 
    [AR3-LoopBack0]int g0/0/0
    [AR3-GigabitEthernet0/0/0]isis enable 
    [AR3-GigabitEthernet0/0/0]int g0/0/1
    [AR3-GigabitEthernet0/0/1]isis enable 
    [AR3-GigabitEthernet0/0/1]q
    

    AR4

    [Huawei]sysname AR4
    [AR4]int l0
    [AR4-LoopBack0]ip address  4.4.4.4 32
    [AR4-LoopBack0]int g0/0/1
    [AR4-GigabitEthernet0/0/1]ip address  10.1.34.4 24
    [AR4-GigabitEthernet0/0/1]q
    [AR4]isis 
    [AR4-isis-1]network-entity 12.0001.0000.0000.0004.00
    [AR4-isis-1]is-level level-2
    [AR4-isis-1]int l0
    [AR4-LoopBack0]isis enable 
    [AR4-LoopBack0]q
    [AR4]int g0/0/1
    [AR4-GigabitEthernet0/0/1]isis enable 
    [AR4-GigabitEthernet0/0/1]int g0/0/0
    [AR4-GigabitEthernet0/0/1q
    [AR4]int g0/0/0
    [AR4-GigabitEthernet0/0/0]ip address  10.1.45.4 24
    

    [AR3]dis isis peer

    在这里插入图片描述

    MPLS

    AR2

    [AR2]mpls lsr-id 2.2.2.2
    [AR2]mpls
    [AR2-mpls]mpls ldp
    [AR2-mpls-ldp]int g0/0/0
    [AR2-GigabitEthernet0/0/0]mpls
    [AR2-GigabitEthernet0/0/0]mpls ldp
    

    AR3、AR4配置类似

    [AR3]dis mpls ldp session
    在这里插入图片描述

    [AR3]dis mpls lsp
    在这里插入图片描述
    BGP

    AR3

    [AR3]bgp 100
    [AR3-bgp]peer 2.2.2.2 as-number 100
    [AR3-bgp]peer 2.2.2.2 connect-interface  LoopBack 0
    [AR3-bgp]peer 2.2.2.2 next-hop-local
    [AR3-bgp]peer 4.4.4.4 as-number 100
    [AR3-bgp]peer 4.4.4.4 connect-interface  LoopBack 0
    [AR3-bgp]peer 4.4.4.4 next-hop-local
    [AR3-bgp]peer 2.2.2.2 reflect-client 
    [AR3-bgp]peer 4.4.4.4 reflect-client 
    [AR3-bgp]ipv4-family vp#v4
    [AR3-bgp-af-vp#v4]peer 2.2.2.2 enable 
    [AR3-bgp-af-vp#v4]peer 2.2.2.2 reflect-client 
    [AR3-bgp-af-vp#v4]peer 4.4.4.4 enable 
    [AR3-bgp-af-vp#v4]peer 4.4.4.4 reflect-client 
    

    AR2

    [AR2]bgp 100	
    [AR2-bgp]peer 3.3.3.3 as-number 100
    [AR2-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    [AR2-bgp]peer 3.3.3.3 next-hop-local
    [AR2-bgp]ipv4-family vp#v4
    [AR2-bgp-af-vp#v4]peer 3.3.3.3 enable 
    

    AR4

    [AR4]bgp 100
    [AR4-bgp]peer 3.3.3.3 as-number 100
    [AR4-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    [AR4-bgp]peer 3.3.3.3 next-hop-local
    [AR4-bgp]ipv4-family vp#v4
    [AR4-bgp-af-vp#v4]peer 3.3.3.3 enable 
    

    [AR3]dis bgp peer verbose
    在这里插入图片描述

    VP#v4

    AR2

    [AR2]bgp 100
    [AR2-bgp]ipv4-family unicast 
    [AR2-bgp-af-ipv4]undo peer 3.3.3.3 enable
    

    AR3

    [AR3]bgp 100
    [AR3-bgp]ipv4-family unicast 
    [AR3-bgp-af-ipv4]undo peer 2.2.2.2 enable 
    [AR3-bgp-af-ipv4]undo peer 4.4.4.4 enable 
    

    AR4

    [AR4]bgp 100
    [AR4-bgp]ipv4-family unicast 
    [AR4-bgp-af-ipv4]undo peer 3.3.3.3 enable 
    

    查看vpnv4地址族的BGP邻居关系
    [AR3]dis bgp vp#v4 all peer dis bgp

    在这里插入图片描述
    [AR3]dis bgp vp#v4 all peer verbose
    在这里插入图片描述
    VP#业务接入配置
    在这里插入图片描述

    AR2

    [AR2]ip vpn-instance ybd
    [AR2-vpn-instance-ybd]route-distinguisher 10:1
    [AR2-vpn-instance-ybd-af-ipv4]vp#-target 100:1 both 
    [AR2]int g0/0/1
    [AR2-GigabitEthernet0/0/1]ip binding vp#-instance ybd
    [AR2-GigabitEthernet0/0/1]ip address  10.1.12.2 24
    

    [AR2]dis ip routing-table vp#-instance ybd
    在这里插入图片描述
    [AR2]ping -vp#-instance ybd 10.1.12.1
    在这里插入图片描述
    OSPF

    AR1

    [AR1]ospf 1 router-id 1.1.1.1
    [AR1-ospf-1]a 0
    [AR1-ospf-1-area-0.0.0.0]network 192.168.1.1 0.0.0.0
    [AR1-ospf-1-area-0.0.0.0]network 10.1.12.1 0.0.0.0
    

    AR2

    [AR2]ospf 1 vp#-instance ybd
    [AR2-ospf-1]a 0
    [AR2-ospf-1-area-0.0.0.0]network 10.1.12.2 0.0.0.0
    

    [AR2]dis ospf peer brief
    在这里插入图片描述
    [AR2]dis ip routing-table vp#-instance ybd
    在这里插入图片描述

    AR1、AR2
    
    [AR1]int l10
    [AR1-LoopBack10]ip address 192.168.10.1 32
    
    [AR2]ip route-static vp#-instance ybd 192.168.10.0 24 10.1.12.1
    

    [AR2]dis ip routing-table vp#-instance ybd
    在这里插入图片描述
    RIP

    AR4

    [AR4]ip vp#-instance ybd6
    [AR4-vp#-instance-ybd6]route-distinguisher 10:2
    [AR4-vp#-instance-ybd6-af-ipv4]vp#-target 100:1 both 
    [AR4-vp#-instance-ybd6-af-ipv4]q
    [AR4-vp#-instance-ybd6]q
    [AR4]int g0/0/0
    [AR4-GigabitEthernet0/0/0]ip binding vp#-instance ybd6
    [AR4-GigabitEthernet0/0/0]ip address 10.1.45.4 24
    [AR4-GigabitEthernet0/0/0]q
    [AR4]rip 1 vp#-instance ybd6
    [AR4-rip-1]version 2
    [AR4-rip-1]network 10.0.0.0
    

    AR5

    [AR5]rip 1 
    [AR5-rip-1]version 2
    [AR5-rip-1]network 10.0.0.0
    [AR5-rip-1]network 192.168.2.0
    

    [AR4]dis ip routing-table vp#-instance ybd6
    在这里插入图片描述
    VP#业务接入配置

    vp#-instacen ybd 路由 —> vp#-instance vp#v4 路由 —> vp#-insance Ai vp#v4 BGP路由

    AR2

    [AR2]bgp 100
    [AR2-bgp]ipv4-family vp#-instance ybd
    [AR2-bgp-ybd]import-route ospf 1
    [AR2-bgp-ybd]import-route static 
    

    [AR2]display bgp vp#v4 all routing-table
    在这里插入图片描述
    在AR2的G0/0/0接口进行抓包

    在这里插入图片描述
    policy vp#target 开启基于RT属性VP#v4路由的过滤

    1、如果本路由器没有VP#实例业务接入,则丢弃所有vp#v4路由
    2、如果本路由器存在VP#实例业务接口,则对ert和本端所有VP#实例的irt做匹配,如果ert没有和任何一个本端vp#实例的irt匹配,则丢弃。

    [AR3-bgp]dis bgp vp#v4 all routing-table
    在这里插入图片描述
    没bgp vp#v4路由

    RR上

    [AR3-bgp]ipv4-family vp#v4
    [AR3-bgp-af-vp#v4]undo policy vp#-target 
    

    [AR3-bgp-af-vp#v4]dis bgp vp#v4 all routing-table
    在这里插入图片描述
    [AR4]dis bgp vp#v4 all routing-table
    在这里插入图片描述
    AR4已接收相应的路由。

    [AR4]dis ip routing-table vp#-instance ybd6 protocol bgp
    在这里插入图片描述
    最有路由。

    AR4

    [AR4]bgp 100
    [AR4-bgp]ipv4-family vp#-instance ybd6
    [AR4-bgp-ybd6]import-route rip 1
    
    [AR4-rip-1]import-route bgp
    

    [AR5]dis ip routing-table protocol rip
    在这里插入图片描述
    [AR4]dis ip routing-table vp#-instance ybd6

    在这里插入图片描述AR2

    [AR2]ospf 
    [AR2-ospf-1]import-route bgp
    

    [AR2]dis ip routing-table vp#-instance ybd
    在这里插入图片描述
    [AR1]dis ip routing-table 192.168.2.5
    在这里插入图片描述

    下面说一下AR5的192.168.2.5是怎么访问AR1的192.168.1.1的路由。

    AR5查找路由表192.168.1.1,发现下一跳是10.1.45.4
    然后在这里插入图片描述
    然后根据AR4的接口下绑定的ybd6路由表,去查相关路由。

    在这里插入图片描述
    [AR4]dis bgp vpnv4 vp#-instance ybd6 routing-table 192.168.1.1
    在这里插入图片描述
    在这里插入图片描述
    数据封装成在这里插入图片描述

    在这里插入图片描述
    出去的标签是1024

    在这里插入图片描述

    然后数据封装成这样了在这里插入图片描述

    压入标签为2个。

    然后AR4根据G0/0/1接口发出去,

    在这里插入图片描述
    RR 查找标签

    在这里插入图片描述
    2.2.2.2的进标签1024,出标签是3,然后进行弹出顶部标签,从G0/0/1接口发送出去。

    在这里插入图片描述
    AR2收到后,查看lsp

    在这里插入图片描述

    通过BGP协议得到的标签,收到的标签如果是1027的话,就属于ybd路由表进行转发的。

    弹出标签
    在这里插入图片描述
    192.168.1.1属于ybd本地的报文

    在这里插入图片描述

    从接口g0/0/1发出,下一跳是10.1.12.1。

    反过来也是一样的。

    创建一个telnet

    AR5

    [AR5]user-interface vty 0 4
    [AR5-ui-vty0-4]set authentication password cipher ybd666666
    [AR5-ui-vty0-4]user privilege level 15
    

    telnet -a 192.168.1.1 192.168.2.5

    在这里插入图片描述

    模拟内网冲突的场景,路由冲突的时候怎么区分?

    拓扑
    在这里插入图片描述

    本地路由一样是可以通过VP#实例来进行区分的。

    RD:区分实例,标记路由,只在本地有效,区分不同站点的相同路由;
    RT:对路由进行控制,控制路由的导入与导出。

    注意:可以是相同的DR的

    AR2

    [AR2]int g0/0/2
    [AR2-GigabitEthernet0/0/2]ip address 10.1.26.2 24
    [AR2]ip vp#-instance ybd99
    [AR2-vpn-instance-ybd99]route-distinguisher 20:3
    [AR2-vpn-instance-ybd99]vp#-target 200:1 both 
    [AR2]int g0/0/2	
    [AR2-GigabitEthernet0/0/2]ip binding vp#-instance ybd99
    [AR2-GigabitEthernet0/0/2]ip address 10.1.26.2 24
    
    [AR2]isis 10 vp#-instance ybd99
    [AR2-isis-10]is-level level-2
    [AR2-isis-10]network-entity 12.0099.0000.0000.0002.00
    [AR2-isis-10]int g0/0/2
    [AR2-GigabitEthernet0/0/2]isis enable 10
    

    AR6

    [Huawei]sysname AR6
    [AR6]int g0/0/0
    [AR6-GigabitEthernet0/0/0]ip address 10.1.26.6 24
    [AR6-LoopBack0]ip address 192.168.1.1 32
    
    [AR6]isis
    [AR6-isis-1]network-entity 12.0099.0000.0000.0006.00
    [AR6-isis-1]is-level level-2
    [AR6-isis-1]int g0/0/0
    [AR6-GigabitEthernet0/0/0]isis enable 
    [AR6-GigabitEthernet0/0/0]int l0
    [AR6-LoopBack0]isis enable 
    
    [AR2]bgp 100
    [AR2-bgp]ipv4-family vp#-instance ybd99
    [AR2-bgp-ybd99]import-route isis 10
    

    [AR6]dis isis peer
    在这里插入图片描述
    [AR2]dis isis peer vp#-instance ybd99
    在这里插入图片描述

    AR4

    [AR4]ip vp#-instance ybd666
    [AR4-vp#-instance-ybd666]route-distinguisher 20:3
    [AR4-vp#-instance-ybd666-af-ipv4]vp#-target 200:1 both 
    [AR4-vp#-instance-ybd666-af-ipv4]int g0/0/2
    [AR4-GigabitEthernet0/0/2]ip binding vp#-instance ybd666
    [AR4-GigabitEthernet0/0/2]ip address  10.1.47.4 24
    
    [AR4]bgp 100
    [AR4-bgp]ipv4-family vp#-instance ybd666
    [AR4-bgp-ybd666]peer 10.1.47.7 as 64523
    

    华为设备当将BGP路由引入到IGP时,只将EBGP路由引入。

    AR7

    [Huawei]sysname AR7
    [AR7]int l0
    [AR7-LoopBack0]ip address 192.168.10.1 32
    [AR7-LoopBack0]int g0/0/0
    [AR7-GigabitEthernet0/0/0]ip address 10.1.47.7 24
    
    [AR7]bgp 64523
    [AR7-bgp]peer 10.1.47.4 as 100
    [AR7-bgp]network 192.168.10.1 32
    

    [AR4]dis bgp vp#v4 all peer
    在这里插入图片描述

    [AR2]isis 10
    [AR2-isis-10]import-route  bgp
    

    [AR4]dis bgp vpnv4 all routing-table在这里插入图片描述

    RD、RT不一样。

    [AR2]dis mpls lsp
    在这里插入图片描述

    192.168.10.1 PING测 192.168.1.1
    在这里插入图片描述
    在这里插入图片描述
    已学到192.168.1.1/32的路由,下一跳是10.1.47.4;

    在这里插入图片描述
    然后根据AR4的接口下绑定的ybd666路由表,去查找相关的路由。

    在这里插入图片描述

    由以上输出结果可知,下一跳是2.2.2.2。

    [AR4]dis bgp vpnv4 vp#-instance ybd666 routing-table 192.168.1.1

    在这里插入图片描述

    在这里插入图片描述

    压入公网标签1024
    在这里插入图片描述

    在这里插入图片描述
    弹出标签

    在这里插入图片描述

    在这里插入图片描述

    通过BGP协议得到的标签,收到的标签如果是1037的话,就属于ybd99路由表进行转发的。

    192.168.1.1属于ybd99本地的报文

    在这里插入图片描述
    有以上输出结果可知,下一跳是10.1.26.6。

    在这里插入图片描述

    温故而知新,可以为师矣。


    欢迎访问我的易百纳技术社区文章《华为 BGP/MPLS VP#》
    https://www.ebaina.com/articles/140000005374


    在这里插入图片描述

    好了这期就到这里了,如果你喜欢这篇文章的话,请点赞评论分享收藏,如果你还能点击关注,那真的是对我最大的鼓励。谢谢大家,下期见!

    展开全文
  • 华为 BGP路由聚合

    千次阅读 多人点赞 2020-07-01 11:03:17
    文章目录BGP路由聚合的作用和聚合的方式拓扑基础配置策略与观察TS排错 BGP的聚合相对其他协议的聚合差异较大,且重要性较高,关于手动聚合的属性及策略运用要熟练掌握。 BGP路由聚合的作用和聚合的方式 1、减少...

    业精于勤,荒于嬉;行成于思,毁于随。

    BGP的聚合相对其他协议的聚合差异较大,且重要性较高,关于手动聚合的属性及策略运用要熟练掌握。

    一、BGP聚合

    在中型或大型BGP网络中,BGP路由表会变得十分庞大,存储路由表占用大量的交换机内存资源,传输和处理路由信息需要占用大量的网络资源。使用路由聚合(Routes Aggregation)可以大大减小路由表的规模;另外通过对路由进行聚合,隐藏一些具体的路由,可以减少路由震荡对网络带来的影响。

    BGP路由聚合结合灵活的路由策略,使BGP更有效的传递和控制路由。

    1、减少路由表项网络设备的硬件资源的占用
    2、提高网络的稳定性

    BGP支持两种聚合方式:自动聚合和手动聚合。自动聚合的路由优先级低于手动聚合的路由优先级(宣告聚合路由–配合静态来实现)。

    1.1 BGP路由聚合的作用

    (1)减少路由表的明细路由(减少空间占用和维护每条明细路由带来压力)
    (2)减少因为某些明细路由的频繁更新导致网络波动

    1.2 BGP路由聚合的方式

    (1)summary automatic 自动聚合
    (2)Aggregation 手动聚合
    (3)静态宣告 宣告时宣告手动汇总后的路由(需要再ip路由表静态部署一条指向null 0的手动聚合后的路由)

    二、拓扑

    在这里插入图片描述

    三、基础配置

    1、AS-200运行OSPF协议属于区域0

    2、如图构建BGP邻居,全部建立EBGP邻居(AR-4不运行BGP),开启团体属性通告功能

    3、在AR-4将静态路由及Loopback 1直连路由引入进OSPF,引入后的路由开销为150,类型值为2

    [AR-4]acl 2000                                           //创建基本acl 2000 来匹配192.168.1.4/32的主机路由
    [AR-4-acl-basic-2000]rule permit source 192.168.1.4 0 
    [AR-4-acl-basic-2000]quit 
    [AR-4]route-policy ospf_cost permit node 10              //创建名称为ospf_cost的路由策略节点10	
    [AR-4-route-policy]if-match acl 2000                     //此节点匹配acl 2000抓取的路由
    [AR-4-route-policy]apply cost 150                        //此节点匹配到路由修改开销为150
    [AR-4-route-policy]quit 
    
    [AR-4]ospf 1                                             //进入OSPF进程
    [AR-4-ospf-1]import-route direct route-policy ospf_cost  //引入直连路由时挂接名称为ospf_cost的路由策略进行路由过滤与开销修改
    [AR-4-ospf-1]import-route static cost 150                //引入此设备的静态路由并修改开销为150
    [AR-4-ospf-1]quit 
    

    3.1 自动聚合

    (1)只对引入的BGP路由会自动聚合,network宣告进BGP的路由无法执行自动聚合。
    (2)只对始发与本地的BGP路由聚合会生效,对于通过其他BGP设备传递而来的外部路由聚合不会生效。
    (3)只将聚合后的路由发布出去
    (4)聚合后自动在本地生成一条指向聚合的Null路由来防止可能出现的环路
    (5)默认情况BGP设备的自动聚合是关闭的

    1、在AR-3将Loopback 1接口地址引入进BGP协议并开启自动聚合

    [AR-3]bgp 300	
    [AR-3-bgp]net 192.168.1.3 32 
    [AR-3-bgp]ipv4-family unicast 
    [AR-3-bgp-af-ipv4]summary automatic  //开启本BGP设备的自动汇总,自动汇总只对引入(重分发)进本BGP的路由有效,会将路由汇总为主类路由
    

    四、策略与观察

    1、查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-patch值判断AR-2对于此路由的最优来源选择

    dis bgp routing-table
    在这里插入图片描述
    MED值为0;AS-patch值为300;
    主要是该路由到达目的地的路由是唯一的,所以直接优选。

    2、在AR-2将OSPF路由引入进BGP协议,查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-path值判断AR-2对于此路由的最优来源选择

    [AR-2]bgp 200
    [AR-2-bgp]import-route ospf 
    

    dis bgp routing-table
    在这里插入图片描述
    MED值为150,AS-path值为空(本地产生);为本地始发
    Origin i>e>?
    主要是该路由到达目的地的路由是唯一的,所以直接优选,对到达同一目的地的路由不存在多条。

    3、在AR-2开启自动聚合,查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-path值判断AR-2对于此路由的最优来源选择

    [AR-2]bgp 200
    [AR-2-bgp]summary automatic 
    

    dis bgp routing-table
    在这里插入图片描述
    4、在AR-2通过手动聚合产生192.168.1.0/24的BGP路由,查看AR-2 BGP路由表针对192.168.1.0/24路由的MED值,AS-patch值判断AR-2对于此路由的最优来源选择
    (通告查看192.168.1.0的bgp详细路由信息来区分路由是自动聚合或是手动聚合产生)

    起源属性为“?”是自动聚合产生;
    起源属性为“i”可能是自动聚合产生,也可能是动聚合产生。

    [AR-2-bgp]aggregate 192.168.1.0 24
    

    dis bgp routing-table
    在这里插入图片描述

    [AR-2-bgp]undo summary automatic 
    

    dis bgp routing-table
    在这里插入图片描述
    5、当完成上述内容后,在AR-2的BGP路由表存在几条192.168.1.0/24的路由,同时存在这些路由时优选哪个起源属性的路由,并得出BGP本地起源属性的规则

    BGP本地起源属性:

    BGP的第四条选路原则只有当BGP设备针对同一条路由有多个获取源时,使用第四条选路原则
    手动聚合>自动聚合>IGP>BGP的规则来原则最佳路由

    五、TS排错

    1、现要求AS-100的路由器可以正常接收聚合路由192.168.2.0/24

    [AR-2-bgp]aggregate 192.168.2.0 255.255.255.0 detail-suppressed
    

    dis bgp routing-table
    在这里插入图片描述
    2、此路由需要最好的放环属性

    [AR-2-acl-basic-2000]acl 2020
    [AR-2-acl-basic-2020]rule 20 permit source 192.168.2.0 0.0.0.255
    [AR-2-acl-basic-2020]quit
    [AR-2]route-policy no-ad permit node 10
    [AR-2-route-policy]if-match acl 2020
    [AR-2-route-policy]apply community no-advertise
    [AR-2-route-policy]quit
    [AR-2]route-policy no-ad  permit node 20
    [AR-2-route-policy]quit
    [AR-2]bgp 200
    [AR-2-bgp]peer 12.1.1.1 route-policy no-ad  export 
    

    3、同时只接收192.168.2.0/24内的明细路由192.168.2.3/32

    请在AR-2进行故障排查,修改缺失或者错误配置及策略,满足以上题目需求
    (注意:可做修改与增加配置,不要删除任何配置)

    我这里用的是“反向操作”!!但是最好所有的问题和需求都在聚合策略下完成

    [AR-2]acl 2030
    [AR-2-acl-basic-2030]rule 30 permit source 192.168.2.2 0
    [AR-2-acl-basic-2030]rule 40 permit source 192.168.2.4 0
    [AR-2-acl-basic-2030]quit
    [AR-2]route-policy aa permit node 10
    [AR-2-route-policy]if-match acl 2030
    [AR-2-bgp]undo  peer 12.1.1.1 route-policy no-ad export
    [AR-2-bgp]aggregate 192.168.2.0 255.255.255.0 as-set suppress-policy aa 
    

    dis bgp routing-table
    在这里插入图片描述

    5.1 手动聚合

    1、聚合后明细和聚合路由都发布出去

    (1)对宣告;引入;始发;以及通过BGP学到的路由都会生效
    (2)汇总后将明细和汇总路由都传递出去
    (3)汇总后的路由不再携带明细路由的AS号,只携带汇总设备的AS号,此路由以汇总设备作为始发。
    (4)聚合后自动在本地生成一条指向聚合的Null路由来防止可能出现的环路

      [AR-2-bgp]aggregate 192.168.2.0 24 ?
              as-set              //发出聚合路由时携带明细路由的AS号
              attribute-policy    //为聚合路由添加属性值
              detail-suppressed   //抑制所有的明细路由,只发出聚合路由
              origin-policy       //只有命中指定路由后才会产生此聚合路由(被route-policy命中的的明细)
              suppress-policy     //选择性抑制明细路由(被suppress-policy命中的路由会被抑制)
    

    2、聚合后的路由携带明细AS发布出去

    (1)默认情况下聚合后的路由不再携带原明细路由的AS号,只有本聚合设备的AS然后开始传递,这样聚合路由回传存在环路的风险
    (2)对聚合路由赋予as-set属性,此聚合路由将保留原明细路由的AS属性

    [AR-2-bgp]aggregate 192.168.0.0 22 as-set                  //手动聚合的这条路由将携带明细路由的AS-Path属性发布出去。
    
    [AR-2-bgp]aggregate 40.1.0.0 22 detail-suppressed as-set   //只将聚合后的路由发送给邻居,并携带明细路由的AS-Path属性。
    

    3、只将聚合后的路由发布出去

    (1)对宣告;引入;始发;以及通过BGP学到的路由都会生效
    (2)汇总后只将汇总路由传递出去 ,参与汇总的明细路由将在本地BGP路由表打上“S”被抑制
    (3)汇总后的路由不再携带明细路由的AS号,只携带汇总设备的AS号,此路由以汇总设备作为始发。

     [AR-2-bgp]aggregate 192.168.2.0 24 detail-suppressed        //手动聚合后只将聚合路由传递下去
    
     [AR-2-bgp]aggregate 192.168.2.0 24 suppress-policy aa      //手动聚合后的路由和经过路由策略AAA过滤完的明细路由传递下去
    

    六、策略

    suppress-policy 抑制策略

    作用:抑制BGP对的路由(被抑制的路由不会被邻居通告)
    匹配:Route-policy

    attribute-policy 聚合路由路径属性策略

    作用:修改聚合路由属性
    匹配:Route- policy

    origin- policy 起源策略

    作用:限制聚合路由的条件(只有被origin- policy命中的路由才可以产生聚合路由)
    匹配:route policy

    route policy 路由策略

    作用:过滤路由修改路由属性,匹配路由(抓取路由–基于cost路由匹配)
    匹配:ACL,匹配所以路由

    在这里插入图片描述

    本人所有文章都受版权保护,著作权归艺博东所有!未经授权,转载必究或附上其原创链接。

    展开全文
  • 华为 BGP协议基础配置与总结

    千次阅读 多人点赞 2020-03-03 17:40:54
    BGP的邻居建立很关键,涉及环回口地址建立bgp邻居就需要指定更新源,单一的直连物理接口建立bgp邻居时不需要指定更新源的。 BGP的防环属性是影响路由更新传的重要因素,一定要牢记BGP的防环策略。IBGP防环是从IBGP...

    良药苦口利于病,忠言逆耳利于行。

    BGP的邻居建立很关键,涉及环回口地址建立bgp邻居就需要指定更新源,单一的直连物理接口建立bgp邻居时不需要指定更新源的。
    BGP的防环属性是影响路由更新传的重要因素,一定要牢记BGP的防环策略。
    IBGP防环是从IBGP邻居学到的路由不再传递给其他的IBGP邻居注意这里是IBGP邻居,EBGP邻居不受影响。
    IBGP之间路由传递时要更改下一跳属性,使得从EBGP邻居学到的路由可以顺利在IBGP邻居之间传递。

    一、BGP概述

    1、简介:

    BGP-Border Gateway Protocol边界网关协议,是一种在自治系统AS(Autononmous System)之间传递并选择最佳路由的高级矢量路由协议。

    路由协议通常分为内部网关协议(IGP)和外部网关协议(EGP)两大类。

    BGP虽然是一种动态路由协议,但它实际上本身并不产生路由、不发现路由、不计算路由,其主要功能是完成最佳路由的选择并在BGP邻居之间进行最佳路由的传递。BGP选择了TCP作为其传输协议,端口号是179。

    BGP的邻居关系分为IBGP和EBGP两种:两台BGP路由器位于同一AS时,它们的邻居关系为IBGP邻居关系;两台BGP路由器位于不同的AS时,它们的邻居关系为EBGP邻居关系。BGP没有自动建立邻居关系的能力,邻居关系必须通过手动配置来建立。

    2、版本:

    (1)BGP-1(RFC1105);
    (2)BGP-2(RFC1163);
    (3)BGP-3(RFC1267);
    (4)BGP-4(RFC1771,1994年开始使用);
    (5)BGP-4(RFC4271,2006年后单播IPv4网络使用),这个版本是当前的BGP版本;
    (6)MP-BGP(RFC4760)供其他网络使用;
    (7)BGP-4+提供对IPv6单播网络的支持;

    注意:

    华为路由器运行的BGP特性同时支持BGP-4,BGP-4+和MP-BGP。即在BGP下的配置同时对这三个版本生效。默认情况在BGP IPv4单播地址族视图下的配置可以在BGP视图配置,但只对BGP-4生效。

    3、特性:

    (1)BGP拥有丰富的选路参考属性,灵活组合可以实现路由的优选和避免路由环路,能够高效率的传递路由和维护大量的路由信息;
    (2)BGP提供了丰富的路由策略,能够灵活的进行路由选路,并且能指导邻居按策略发布路由;
    (3)BGP提供了路由聚合和路由衰减功能,用于防止路由振荡,有效提高网络的稳定性;
    (4)BGP是一种距离矢量协议,将AS作为一个节点来计算;IGP协议以一个路由器为节点;
    (5)BGP使用TCP(端口号179)作为底层传输协议,与每个BGP对等体形成独特的基于单播的连接 并支持BGP于BFD联动,提高了网络的可靠性。

    4、AS

    (1)BGP的AS是指在一个组织机构管辖下拥有相同选路策略的IP网络,BGP网络中的每个AS都被分配了一个唯一的AS号,用于区域不同的AS。
    (2)BGP的AS号分为2字节和4字节的AS号,
    2字节AS号范围1----65535的整数,
    4字节AS号范围2----4 294 967 295的整数(可以有不同的表示格式)
    RFC 5389规定在2字节的AS号中;1–64511是公网AS,64512—65534为私网AS,65535保留用于特殊用途。

    二、拓扑

    在这里插入图片描述

    三、基础配置

    AR-1:
    
    <Huawei>system-view 
    [Huawei]sysname AR-1
    [AR-1]int g0/0/0
    [AR-1-GigabitEthernet0/0/0]ip add 12.1.1.1 24
    [AR-1-GigabitEthernet0/0/0]quit
    [AR-1]int LoopBack 0
    [AR-1-LoopBack0]ip add 1.1.1.1 32
    [AR-1-LoopBack0]quit
    [AR-1]ospf 1 router-id 1.1.1.1
    [AR-1-ospf-1]area 0
    [AR-1-ospf-1-area-0.0.0.0]network 12.1.1.1 0.0.0.0
    [AR-1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0
    
    **AR-2;AR-3同上!**
    **AR-1与AR-3通过环回口建立IBGP的邻居;**
    
    **AR-1基础配置:**
    
    [AR-1]bgp 100                                       //本设备创建BGP AS,所属AS 100
    [AR-1-bgp]router-id 1.1.1.1                         //设置本设备的BGP的R-ID为1.1.1.1
    [AR-1-bgp]peer 3.3.3.3 as-number 100                //手动指定与对等体的接口地址3.3.3.3建立IBGP邻居
    [AR-1-bgp]peer 3.3.3.3 connect-interface LoopBack 0 //指定与3.3.3.3建立邻居时更新源地址为本设备的环回口0
    [AR-1-bgp]peer 3.3.3.3 next-hop-local               //指定发往邻居12.1.1.1的条目下一跳地址为本设备自身
    
    **AR-3基础配置:**
    
    [AR-3]bgp 100
    [AR-3-bgp]router-id 3.3.3.3
    [AR-3-bgp]peer 1.1.1.1 as-number 100
    [AR-3-bgp]peer 1.1.1.1 connect-interface LoopBack 0
    [AR-3-bgp]peer 1.1.1.1 next-hop-local
    

    在这里插入图片描述
    AR-3与AR-4通过直连地址建立EBGP邻居;

    **AR-3设备配置:**
    
    [AR-3]bgp 100
    [AR-3-bgp]peer 34.1.1.2 as-number 200
    
    **AR-4设备配置:**
    
    [AR-4]bgp 200
    [AR-4-bgp]router-id 4.4.4.4
    [AR-4-bgp]peer 34.1.1.1 as-number 100
    [AR-4-bgp]network 4.4.4.4 255.255.255.255
    

    AR-4: dis bgp peer
    在这里插入图片描述
    AR-3: dis bgp peer
    在这里插入图片描述

    AR-2设备:
    
    [AR-2]bgp 100
    [AR-2-bgp]router-id 2.2.2.2
    [AR-2-bgp]peer 1.1.1.1 as-number 100
    [AR-2-bgp]peer 1.1.1.1 connect-interface  LoopBack 0
    [AR-2-bgp]peer 3.3.3.3 as-number 100
    [AR-2-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    
    AR-1设备:
    
    [AR-1]bgp 100
    [AR-1-bgp]peer 2.2.2.2 as-number 100
    [AR-1-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    [AR-1-bgp]peer 2.2.2.2 next-hop-local
    

    AR-3配置类似

    在AR-1的BGP路由表查看4.4.4.4/32路由前面带“下一跳可达”
    在这里插入图片描述
    AR-1的BGP路由表信息
    在这里插入图片描述
    AR-1和AR-3 BGP配置内容(dis cu se bgp)
    在这里插入图片描述
    在这里插入图片描述
    在设备AR-3、4配置ospf协议时
    AR-1的BGP路由表信息:

    AR-1:dis bgp routing-table
    在这里插入图片描述
    AR-1: ping -c 3 -a 1.1.1.1 4.4.4.4
    在这里插入图片描述
    IBGP不用配置多跳,可以用loopback建立邻居。EBGP不是直连接口建立邻居,需要指多跳。

    四、BGP与IGP比较

    IGP协议特点:

    (1)在AS之内使用的协议,主要用于发现和计算路由;
    (2)IGP的路由收敛都相对迅速。工作在直连邻居间;
    (3)单一的度量值,列如OSPF和IS-IS当然链路开销cost,RIP的跳数;
    (4)适用于中小型网络。

    BGP协议特点:

    (1)BGP作为外部网关协议,着眼于控制路由的传播和选择最佳路由;
    (2)BGP可以工作在非直连邻居之间,使用TCP作为其传输层协议(端口号179);
    (3)BGP支持五类别域间路由,路由更新时只发送更新的路由,大大减少了BGP传播路由所占用的带宽, 适用在Internet上传播大量的路由信息;
    (4)BGP提供了丰富的路由策略,能够实现路由的过滤和选择;
    (5)BGP易于扩展,能够适应网络新技术的发展。适用于大型,超大型运营商网络。

    五、BGP的数据包

    BGP数据包都由2部分组成,BGP报文头部+类型报文本体

    1、BGP报文头部:

    Marker 16字节:用于检测BGP对等体之间同步丢失情况;在支持消息验证功能的情况下进行消息验证;
    五验证时字段全为1(16 进制显示全FFFF)
    Length 2字节:长度,表示此BGP报文的总长度(包含头部,总长度在19–4096字节之间)
    Type 1字节:类型值,标识本BGP报文的类型(open 1;update 2;Notification 3;keepalive 4;route-refresh 5)。

    2、Open报文(类型1)

    (1)作用:

    TCP 会话建立起来自以后,两个邻居都要发送一个 Open 报文,每个邻居都使用该报文标识自己, 并且规定自己的 BGP 运行参数。如果 open 消息被接受,则回送一条 keepalive 消息进行确认, 确认后就能发送 update 。

    (2)内容:

    Version 8bit :BGP版本号,BGP对等体的使用的版本,默认为BGP-4,如果邻居运行版本低于本设备,会拒绝V-4信息, 本设备将发送低版本信息直至协商成功。
    My AS 号 16bit :本地 AS 号(决定双方建立什么样的BGP邻居;通AS建立IBGP;不同AS建立EBGP)
    Hold Time 16bit: 对等体相互协商及保存邻居最大时间,默认为Keepalive时间的3倍-180S
    (如果两端hold time时间不一致,将会采用较短时间作为保存时间;最小可以为0,这种情况BGP连接被认为永远是UP的,不再发送Keepalive报文来检测邻居是否失效)
    BGP Identifer 32bit:用来标识发送此Open报文设备的Router-ID(ROUTER-ID 和 OSPF 选取 routerID 的方式一致)
    Optional Parameters Length 8bit:标识下面的可选参数的总长度(如果为0,那么本报文中没有包含可选参数字段)
    Optional Parameters 可变长大小:用于BGP邻居会话协商过程中所使用的可选列表;每一个参数为一个
    (参数类型参数长度,参数值)三元组,用于公布一些可选功能的支持,如多协议扩展,路由刷新能力, 四字节AS号等能力。

    3、KEEPALIVE 消息(类型4)

    (1)作用:

    如果路由器接受了邻居在 OPEN 消息中的参数,就会应答一个 keeplive 消息,并且在此后 1/3 的 holdtime(但不小于 1S)为周期发送该消息,华为设备默认 60S一发,保持时间默认180S。如果协商后保持时间为 0,标识此邻居永远UP,则不发送 keepalive 保活消息。

    (2)内容:

    只包含BGP的消息头部?
    Marker 16字节:用于检测BGP对等体之间同步丢失情况;在支持消息验证功能的情况下进行消息验证;
    五验证时字段全为1(16 进制显示全FFFF)
    Length 2字节:长度,表示此BGP报文的总长度(包含头部,总长度在19–4096字节之间)
    Type 1字节:类型值,标识本BGP报文的类型(open 1;update 2;Notification 3;keepalive 4;route-refresh 5)。

    (3)其他:

    KEEPALIVE 消息实际上弥补了 TCP 无法确认对端存活情况的缺陷;
    KEEPALIVE 消息仅包含 19bytes 的 BGP 头部,除此之外不包含任何其他数据。

    4、Update报文(类型2)

    (1)作用:

    当BGP对等体之间成功建立会话后利用Update报文进行路由信息的交换;Update报文既用来通告可用路由信息,也可以通告不可达需要撤销的路由信息。每条update 消息只描述一类具有相同路径属性的可达路由;可达路由信息放在NLRI字段中同时Update报文可以携带多条不可达路由信息;不可达路由信息放在Withdrawn Router字段中。

    (2)内容:

    Withdrawn Routes Length 2字节:撤销路由长度,标识不可达路由的的长度,为0表示此字段 没有任何数据,本报文不存在需要撤销的路由;
    Withdrawn Routes :撤销路由,与NLRI格式相同,同样是前缀长度+前缀组合;
    Total Path Attribute Length 2字节:路径属性字段长度。如果为0表示没有下面的Path attributes,本报文没有通告可用路由信息;
    Path attributes 可变长:路径属性,每个路径属性都由可变长的三元组(属性类型;属性长度;属性值),为BGP提供最短路径,检查路由环路以及决定路由策略的信息;
    Network Layer Reachability Information (NLRI) 可变长度:标识网络层可达信息,包含要向对等体通告的每条可达路由的前缀(IPv4的地址前缀),和前缀长度(IPv4的掩码)。

    5、Notification 报文(类型3)

    (1)作用:

    当BGP检测到错误状态时,就会向对等体发出Notification通知报文,之后BGP连接会立即中断;例如对等体之间的AS号非法,认证失败,邻居地址不可达等。

    (2)内容:

    Error code 1字节:错误码;描述错误类型,每个错误都使用唯一的错误码来表示;
    Errsubcode 1字节:错误子码;描述错误类型的详细信息;
    Data 可变长字段:包含了与错误有关的数据,用来诊断错误原因,比如非法的AS号,认证失败等。

    6、Route-refresh报文(类型5)

    (1)作用:

    路由刷新报文用来要求对等体重新发送指定地址族的路由信息;

    (2)内容:

    AFI Address Family Identifier 2字节:地址族标识,用来标识所采用的地址族类型;
    Res 1字节:保留
    SAFI:Subsequent Address Family Identifier 1字节:子地址族标识,用于标识地址族的类型。

    六、BGP的邻居状态机

    1、Idle状态

    (1)BGP空闲状态,在Idle状态下BGP拒绝邻居发送的连接请求,此时等待由BGP系统发出的Start事件;
    (2)Start(管理员配置邻居)事件发生后,BGP会对自己的资源进行初始化,重置连接计时器(Connect Retry 默认32S)发起TCP 连接请求,并开始侦听远端对等体发起的连接端口,并转至Connect状态。

    1.1. 停留在此状态的原因:

    (1)本BGP设备没有去往对等体的路由;
    (2)收到来自邻居的Notification报文触发Notification报文条件(再一个重置计时器后重新建立BGP的TCP连接,即重新发送用于BGP的TCP连接报文)
    a. AS号错误;
    b0 R-ID重复;
    c. 认证失败;
    d. hold time连接超时(中间设备或者目标设备策略限制)
    e. 其他错误原因。

    2、Connect状态

    在Connect状态下,BGP启动连接重传定时器,等待TCP完成连接!
    (1)如果TCP连接成功,那么BGP会向对等体发送Open报文,并转至OpenSent状态;
    (2)如果TCP连接失败,那么BGP转至Active状态;
    (3)如果连接重传定时器超时,BGP任没有收到BGP对等体的响应,那么BGP继续尝试TCP连接,停留在Connect状态。

    2.1. 停留在Connect状态的原因:

    (1)与BGP对等体TCP连接超时!
    a. 中间设备没有本设备去往对等体的路由;
    b. 中间设备拒绝了本BGP设备发出的BGP相关数据(过滤了本设备IP流量或者TCP流量或者TCP-179端口数据)
    c. 对等体设备未开启BGP(TCP-179端口处于关闭状态)

    3、Active

    在Active状态下,BGP总是试图建立TCP连接!
    (1)如果TCP连接成功,那么BGP向对等体发送Open报文,关闭连接重传定时器,并转至OpenSent;
    (2)如果TCP连接失败,停留在Active状态;
    (3)如果连接重传定时器超时,任没有收到BGP对等体的响应,那么BGP转至Connect状态。

    3.1. 停留在Active状态的原因:

    (1)与BGP对等体TCP失败;
    (2)本BGP设备配置错误的对等体地址。

    4、OpenSent

    在OpenSent状态,BGP等对等体的Open报文,并对收到的Open报文中的AS号,版本号,认证信息等进行检查!
    (1)如果收到的Open报文正确,那么BGP发送Keepalive报文,且重置Keepalive定时器,并转至OpenConfirm状态;
    (2)如果发现收到的Open报文有错误,那么BGP发送Notification报文给对等体。并转至Idle状态。

    4.1. 停留在OpenSent状态的原因:

    (1)对等体发送的Open报文中的AS号与本BGP设备配置不一致(本端BGP配置时邻居的AS号配置错误)

    5、OpenConfirm

    在OpenConfirm状态下,BGP等待Keepalive或Notification报文;
    (1)如果收到Keepalive报文,则转至Established状态(BGP邻居的最终状态)
    (2)如果收到Notification报文,则转至Idle状态。

    5.1. 停留在OpenConfirm状态的原因:

    (1)BGP的TCP建立成功,对等体未发送Keepalive报文(邻居设备BGP配置对本BGP的AS号错误配置)

    6、Established状态

    在Established状态下,BGP对等体之间交互Update,Keepalive,Route-refresh报文和Notification报文!
    (1)如果收到正确的Update或Keepalive报文,那么BGP就人为对端处于正常运行状态,保持BGP连接;
    (2)如果收到错误的就发送Notification报文告知对端,并转至Idle状态;
    (3)Route-reFresh报文不会改变BGP状态;
    (4)如果收到Notification报文,那么BGP转至Idle状态;
    (5)如果收到TCP拆除链接通知,那么BGP将断开连接,转至Idle状态。

    七、BGP计时器

    1、Connect Retry重置连接计时器,默认32S;
    2、Keepalive保持时间,默认60S;
    3、Hold time 默认为Keeplive时间的三倍(180S),保持时间可以改大,但是不能小于Keepalive的三倍。如果两端 Holdtime 不一致,双方接受较小的的时间;
    4、timer keepalive 0 hold 0 ,当检测时间和保持时间都为0时表示本BGP设备认为邻居永远UP;
    5、BGP 不会周期性更新路由,仅在需要的时候更新,由于公网的路由可能的动荡的,因此触发更新也会有一定的等待时间,IBGP peer 为 5S;EBGP peer 为 30S,而在这段时间内,BGP 仍可以进行路由信息的搜集,所以 BGP收敛会比慢。

    八、BGP的更新源

    1、BGP 无法像 IGP 那样自动发现邻居,而需手工指定,邻居的 IP 由本地的 peer 命令指定,而该 BGP 连接的源 IP(更新源)默认情况下为流量的出接口 IP。注意只有当本地配置的邻居 IP 与邻居用于 BGP 连接建立的源 IP 相同时,BGP 连接才能被正常建立;
    2、IBGP 邻居之间建立邻居,为了保证邻居关系的稳定,一般使用 loopback 接口建立,这是因为如果使用物理接口,那么物理接口故障,邻居关系就 DOWN 了,并且在 AS 内部,路径可能是冗余的,邻居之间的 LOOPBACK 路由可通过IGP获取并提供一定的路由冗余性(当物理线路也存在冗余的情况下)注意: 在使用loopback接口建立BGP邻居关系时,务必注意还需要指定更新源 IP;
    3、如果是建立 EBGP 邻居关系,因为 EBGP 邻居关系的建立会检查直连路由,并且默认 TTL=1, 而这个时候实际上loopback 口到 对方loopback 口至少 2 跳 ,那么这个时候 还需要两者配置 peer x.x.x.x ebgp-max-hop 。

    九、BGP的路由生成

    1、通过手动宣告,只能将本BGP设备路由表存在的路由条目通告出去;
    2、通过路由引入,将IGP或者静态,直连路由的重分发进来。

    十、BGP的路由通告

    1、当存在多条路径时,BGP Router 只选取最优的路由(BEST)来使用(没有负载均衡的情况下);
    2、BGP 只把自己使用的路由,也就是自己认为 Best 的路由传递给 BGP peer;
    3、BGP Speaker 从 EBGP 获得的路由会向它所有 BGP 相邻体通告(包括 EBGP 和 IBGP);
    4、BGP Speaker 从 IBGP 获得的路由不向它的 IBGP 相邻体通告。(避免环路,水平分割;存在路由 RR 的情况除外)

    本人所有文章都受版权保护,著作权归艺博东所有!未经授权,转载必究或附上其原创链接。

    展开全文
  • 华为 BGP原理概述 实验基础配置命令

    千次阅读 多人点赞 2020-04-05 17:59:21
    不怕千万人阻挡,只怕自己投降。...[AR-6]bgp 100 //本设备创建BGP AS,所属AS 100 IBGP邻居关系 [AR-6-bgp]router-id 6.6.6.6 //设置本设备的BGP的R-ID为6.6.6.6 [AR-6-bgp]peer 67.1.1.7 as-number 100

    不怕千万人阻挡,只怕自己投降。

    拓扑
    在这里插入图片描述

    一、BGP 基础配置

    [AR-6]bgp 100                           //本设备创建BGP AS,所属AS 100
    

    IBGP 邻居关系

    [AR-6-bgp]router-id 6.6.6.6             //设置本设备的BGP的R-ID为6.6.6.6
    [AR-6-bgp]peer 67.1.1.7 as-number 100   //手动指定与对等体的接口地址67.1.1.7建立IBGP邻居
    

    EBGP 邻居关系

    [AR-8]bgp 200
    [AR-8-bgp]router-id 8.8.8.8
    [AR-8-bgp]peer 78.1.1.7 as-number 100   //手动指定与对等体的接口地址78.1.1.7建立EBGP邻居
    

    到达对方 Loopback 0 接口的静态路由

    [AR-6]ip  route-static 7.7.7.7 32 67.1.1.7
    

    基础基于单一密钥的 BGP 认证功能

    [AR-6-bgp]peer 67.1.1.7 password cipher Huawei  //与邻居67.1.1.7 建立认证密钥
    
    [AR-6-bgp]undo peer 67.1.1.7 password           //执行删除动作
    

    配置基于 keychain的BGP 认证

    [AR-6]keychain key mode periodic daily                     //生效时间模式为周期形式生效
    [AR-6-keychain]key-id 1                                    //创建一个新的key-id 1
    [AR-6-keychain-keyid-1]algorithm md5                       //配置key采用的认证算法为md5
    [AR-6-keychain-keyid-1]key-string  huawei                  //key的密钥huawei
    [AR-6-keychain-keyid-1]send-time daily  08:00 to 20:00     //key的发送时间每天8:00 to 20:00
    [AR-6-keychain-keyid-1]receive-time daily 08:00 to 20:00   //key的接收时间每天 08:00 to 20:00
    [AR-6-keychain-keyid-1]bgp 100 
    [AR-6-bgp]peer 67.1.1.7 keychain key  
    

    接收容忍时间

    [AR-6-keychain]receive-tolerance infinite 
    

    BGP 自动路由聚合

    [AR-6-bgp]ipv4-family unicast            //建立普通的BGP对等体关系
    [AR-6-bgp-af-ipv4]summary automatic      //开启自动路由聚合功能
    [AR-6-bgp-af-ipv4]network 6.6.6.6 32     //将AR-6的loopback 0 接口所在网段宣告进入bgp进程
    [AR-6-bgp-af-ipv4]import-route direct    //引入自连的路由
    

    二、BGP 手动路由聚合

    手动路由聚合具有更高的灵活性和可控性;使用 aggregate 命令进行聚合

    [AR-6-bgp]aggregate 67.1.1.0 24                      //发布所有聚合路由和被聚合的路由
    
    [AR-6]ip ip-prefix no-adver permit 7.7.7.7 32        //指定地址前缀列表名为no-adver,配置模式为允许模式
    [AR-6]route-policy no-adver permit node 10 
    Info: New Sequence of this List.
    [AR-6-route-policy]if-match ip-prefix no-adver       //匹配IPv4的路由信息
    [AR-6-route-policy]apply community no-advertise      //调整的策略为不公告给邻居
    [AR-6-route-policy]route-policy no-adver permit node 20
    Info: New Sequence of this List.
    [AR-6-route-policy]bgp 100
    [AR-6-bgp]peer 67.1.1.7 route-policy no-adver  export     //针对邻居来应用route-policy,而不是network时调用
    [AR-6-bgp]peer 67.1.1.7 advertise-community               //团体属性传递给邻居67.1.1.7对等体
    
    [AR-6-bgp]aggregate 67.1.1.0 24 detail-suppressed         //实现对明细路由的抑制,只将集合后的路由发送出去
    
    [AR-6-bgp]aggregate 67.1.1.0 21 suppress-policy no-adver  //控制路由聚合 只发布聚合路由和通过router-policy被聚合的子路由
    
    [AR-6-bgp]aggregate 67.1.1.0 21 ?
      as-set             Generate the route with AS-SET path-attribute
      //创建拥有AS-SET属性的聚合路由,用于环路检测
      attribute-policy   Set aggregation attributes
      //通过route-policy指定聚合路由的属性,后面是router-policy的编号*
      detail-suppressed  Filter more detail route from updates
      //实现对明细路由的抑制,只将集合后的路由发送出去
      origin-policy      Filter the originate routes of the aggregate
      //只将router-policy中指定路由策略的路由进行聚合,后面是router-policy的编号
      suppress-policy    Filter more detail route from updates through a Routing    policy
      //只发布聚合路由和通过router-policy策略被聚合的子路由
      <cr>               Please press ENTER to execute command 
    

    三、BGP 路径选择-Preferred Value

    路由信息的首选值 Preferred Value 的取值范围是 0~65535,取值越大,优先级越高。
    缺省情况下,Preferred Value 取值为0。

    修改referred Value

    [AR-6]ip ip-prefix 1 index 10 permit 7.7.7.7 32  //指定本匹配项在地址前缀列表中的序号为10
    [AR-6]route-policy 1 permit node 10
    Info: New Sequence of this List.
    [AR-6-route-policy]if-match ip-prefix 1
    [AR-6-route-policy]apply preferred-value 100     //路由策略中配置改变BGP路由的首选值为100
    [AR-6-route-policy]quit
    [AR-6]bgp 100
    [AR-6-bgp]peer 7.7.7.7 route-policy 1 import     //调用路由策略
    

    四、BGP 路径选择-Local Pregerence

    如果 Preferred Value 相同,就会比较本地优先级 Local Pregerence 属性。
    Local Pregerence 只在 IBGP 对等体之间进行通告,EBGP 对等体之间传递路由时,不携带 Local Pregerence 属性。

    [AR-6-route-policy]apply local-preference 500  //在路由策略中配置改变BGP路由信息的本地优先级为500
    

    五、BGP 路径选择-Next Hop

    Next Hop 属性对 BGP 路由协议选路的影响;通信双方的往返选用不同路径的现象称为不对称路由。

    [AR-6-GigabitEthernet0/0/0]ospf cost 200      //修改接口g0/0/0d 开销值为200;越小越优先
    

    六、BGP 路径选择-AS_Path

    当一台 BGP 路由器中存在多条去往同一目标网络的 BGP 路由时,BGP 协议会对这些BGP 路由的属性进比较,以确定去往该目标网络的最优 BGP 路由。首先要比较的是属性是 Preferred Value,然后是 Local preference ,再次是路由生成方式,如果在比较了这几个属性之后还是无法确定出最优路由,则将进行 AS_Path 属性的比较。BGP 在比较了AS_Path 属性之后,会优先选 AS_Path 长度最短的那条路有。

    [AR-6]ip ip-prefix as_path permit 7.7.7.7 32
    [AR-6]route-policy as_path permit node 10   
    [AR-6-route-policy]if-match ip-prefix as_path               //匹配前缀列表名称as_path扑捉理由
    [AR-6-route-policy]apply as-path 500 500 additive           //在原有的路径前面添加as号
    [AR-6-route-policy]route-policy as_path permit node 20      //创建名称为as_path,执行允许动作,节点为20
    [AR-6-route-policy]bgp 100
    [AR-6-bgp]peer 67.1.1.7 route-policy as_path import         //调用路由策略
    
    [AR-6-route-policy]apply as-path 300 400 500 100 overwrite  //意味着将用300 400 500 100 覆盖路由信息原有的AS_Path属性
    

    在这里插入图片描述

    七、BGP 路径选择-MED

    当一台 BGP 路由器中存在多条去往同一目标网络的 BGP 路由时,BGP 协议会对这些BGP 路由的属性进比较,以确定去往该目标网络的最优 BGP 路由。BGP 路由属性的比较顺序为,Preferred Value 属性,Loacl preference 属性,路由生成方式,AS_Path 属性,Origin 属性,MED 属性,BGP 对等体类型等。

    EMD 的数值越小,表明相应的路由优先级越高,因此 MED 也常被称为 Cost。

    [AR-8]ip ip-prefix 1 permit 7.7.7.0 24    
    [AR-8-route-policy]if-match ip-prefix 1
    [AR-8-route-policy]apply cost 100                //MED配置为1000
    [AR-8-bgp]peer 78.1.1.7 route-policy 1 export    //在传递路由给AR-7调用route-policy
    
    [AR-8-bgp]compare-different-as-med	             //让AR-8强制比较来自不同AS且去玩同一目标网络的路由的MED属性值
    

    2.拓扑
    在这里插入图片描述

    八、BGP 路径选择-Community

    BGP 路由的团体属性 Community 主要作用是简化路由策略的实现过程。

    FRC1997 中定义了几个特殊的团体,也被称为 Well-known 团体,它们是 Internet、No-Export、No-Advertise、No-Export-Subconfed。路由器接收到属于这些团体的路由时,将会直接执行相应的动作。

    Internet 团体属性没有一个特定的值,所有路由都默认为属于该团体,路由器可以向任何 BGP 对等体发布所收到的属于 Internet 团体的路由。

    No-Export 团体属性的值为 4294967041,路由器接收到一条携带 No-Export 团体属性的路由后,不会将它发布给 EBGP 对等体,但可以发布给联盟 EBGP对 等体。

    No-Advertise 团体属性的值为 4294967042,路由器接收到一条携带 No-Advertise 团体属性的路由后,不会将它发布给任何 BGP 对等体。

    No-Export-Subconfed 团体属性的值为4294967043,路由器接收到一条携带 No-Export-Subconfed 团体属性的路由后,不会将它发布给 EBGP 对等体,也不会将它发布给联盟EBGP对等体。

    [AR-9]bgp 3002
    [AR-9-bgp]router-id 9.9.9.9
    [AR-9-bgp]confederation id 300                  //联盟AS 300的成员AS 3002
    [AR-9-bgp]peer 79.1.1.7 as-number 3003
    [AR-9-bgp]peer 79.1.1.7 next-hop-local
    
    [AR-6]bgp 100
    [AR-6-bgp]peer 67.1.1.7 route-policy 1 export   //AR-6上调用route-policy
    

    No_Export 团体属性控制路由信息传递

    [AR-6]ip ip-prefix 10 permit 67.1.1.7 32
    [AR-6]route-policy 1 permit node 10
    [AR-6-route-policy]if-match ip-prefix 1
    [AR-6-route-policy]apply community no-export   //收到具有此属性的路由后,不能发布到本地AS之外
    [AR-6-route-policy]route-policy 15 permit node 20
    
    [AR-6-bgp]peer 67.1.1.7 advertise-community    //AR-6在向AR-7传递BGP路由信息时携带团体属性
    

    no-export-subconfed 团体属性控制路由信息传递

    [AR-6]ip ip-prefix 1 permit 7.7.7.7 32
    [AR-6]route-policy 1 permit node 10
    [AR-6-route-policy]if-match ip-prefix 1
    [AR-6-route-policy]apply community no-export-subconfed  //收到具有此属性的路由后,不能发布给任何其他的子自治系统
    

    No-Advertise 团体属性控制路由信息传递

    [AR-6-route-policy]apply community no-advertise         //收到具有此属性的路由后,不能发布给任何其他的BGP对等体
    

    自定义团体属性控制路由信息传递

    [AR-6-route-policy]apply community 100:9                //前两个字节是AA为AS号,后两个是NN为团体编号
    
    [AR-6]ip community-filter 1 permit 100:9
    [AR-6]route-policy 1 deny node 10
    [AR-6-route-policy]if-match community-filter 1
    [AR-6-route-policy]route-policy 1 permit node 20
    

    本人所有文章都受版权保护,著作权归艺博东所有!未经授权,转载必究或附上其原创链接。

    展开全文
  • 华为 BGP认证功能

    千次阅读 多人点赞 2020-03-21 12:00:43
    BGP是一种运行在AS之间的动态路由协议,具备强大的路径限制能力,这也是使得BGP协议能够管理超大大型网络。 simple与cipher可一起使用,但是显示的类型不一样。 Cipher 密钥加密;simple明文。加密需要密钥一致。
  • 华为 BGP原理概述以及实验基础配置命令 一、拓扑 [AR-6]bgp 100 //本设备创建BGP AS,所属AS 100 IBGP邻居关系 [AR-6-bgp]router-id 6.6.6.6 //设置本设备的BGP的R-ID为6.6.6.6 [AR-6-bgp]peer 67.1.1.7 as-number ...
  • - BGP是一种运行在AS与AS之间的动态路由协议,主要作用是在AS之间自动交换无环路由信息 - 以此来构建AS的拓扑图,从而消除路由环路并实施用户配置的路由策略。 - 目前公网网络条目众多,IGP协议无法承载,而BGP可以...
  • 华为BGP路由的基本配置示例

    万次阅读 2019-02-19 07:57:09
    华为BGP路由的基本配置示例 1、组网需求 图1 BGP基本组网示例图 如上图1所示,需要在所有Switch间运行BGP协议,SwitchA、SwitchB之间建立EBGP连接,SwitchB、SwitchC和SwitchD之间建立IBGP全连接。 2、...
  • 华为BGP实验案例

    2020-11-18 09:52:25
    [R3-route-policy]apply local-preference 222 [R3-route-policy]bgp 200 [R3-bgp]peer 34.1.1.4 route-policy pi export 本文标题:华为BGP实验案例 本文作者:黑刺丶楚阳 本文来自:黑刺计算机科技/CSDN博客 知识...
  • 华为BGP选路原则.txt

    2020-03-05 14:42:26
    1.如果此路由的下一跳不可达,忽略此路由 2.Preferred-Value值数值高的优先 3.Local-Preference值最高的路由优先 4.聚合路由优先于非聚合路由 5.本地手动聚合路由的优先级高于本地自动聚合的路由 ...
  • 华为BGP路由的基本配置示例1、组网需求图1 BGP基本组网示例图如上图1所示,需要在所有Switch间运行BGP协议,SwitchA、SwitchB之间建立EBGP连接,SwitchB、SwitchC和SwitchD之间建立IBGP全连接。2、配置思路2.1、在...
  • 华为 BGP选路规则

    2019-08-24 21:13:47
    [R1]ip route-static 2.2.2.0 24 12.1.1.2 配置静态路由 [R1]bgp 100 开启BGP,AS为100 [R1-bgp]router-id 1.1.1.1 配置BGP的ID为1.1.1.1 [R1-bgp]peer 2.2.2.2 connect-interface LoopBack 0 改变更新源...
  • 华为BGP动态路由协议

    2020-02-07 11:42:50
    文章目录一:BGP概述1.1 自治系统(AS)12 动态路由的分类2.2.1 按自治系统分为1.2.2 按协议类型分类1.3 BGP的概念1.4 BGP的特征二:BGP工作原理2.1.BGP报文2.1.1 Open报文2.1.2UPdate报文2.1.3 Notification报文...
  • 6、BGP路由反射器配置6.1、将本机...[Huawei]bgp 1[Huawei-bgp]ipv4-family unicast[Huawei-bgp-af-ipv4]peer 1.1.1.1reflect-client6.2、设置路由反射器的集群ID[Huawei-bgp-af-ipv4]reflector cluster-id ?INTEGE...
  • 一、BGP简介边界网关协议BGP(BorderGateway Protocol)是一种...早期发布的三个版本分别是BGP-1(RFC1105)、BGP-2(RFC1163)和BGP-3(RFC1267),1994年开始使用BGP-4(RFC1771),2006年之后单播IPv4网络使用的版本是BGP...
  • display bgp routing-table peer ipv4-address advertised-routes //查看bgp对等体发布(通告)的路由display bgp routing-table peer ipv4-address received-routes //查看bgp对等体收到的路由信息display bgp paths ...
  • 文章目录一、拓扑二、基础配置三、BGP的数据包四、BGP的邻居状态机BGP是一种运行在AS之间的动态路由协议,具备强大的路径限制能力,这也是使得BGP协议能够管理超大大型网络。simple与cipher可一起使用,但是显示的...
  • 华为BGP选路原则

    千次阅读 2018-10-11 18:14:34
    Preferred-Valnue值数值越高越优先,华为私有属性,仅本地有意义 Local-Preference值最高的路由优先 聚合路由优先于非聚合路由 本地手动聚合路由的优先级高于本地自动聚合的路由 本地通过Network命令引入的...
  • 实验:华为BGP配置

    千次阅读 2019-06-20 16:40:23
    R1的BGP配置 [R1]dis current-configuration configuration bgp [V200R003C00] # bgp 100 router-id 1.1.1.1 peer 2.2.2.2 as-number 200 peer 2.2.2.2 ebgp-max-hop 2 peer 2.2.2.2 connect-i...
  • 文章目录华为BGP动态路由协议理论BGP的特征BGP报文BGP状态机自治系统ASBGP 数据库BGP对等体设置直连建邻居要注意的用环回口建邻居要注意的关于为什么要用环回口建邻居BGP属性BGP选路规则 华为BGP动态路由协议理论 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 703
精华内容 281
关键字:

华为bgp