精华内容
下载资源
问答
  • 华为DHCP

    2019-02-25 21:07:00
    DHCP 一、DHCP基础 DHCP客户端、服务器、中继器 1、 报文种类 ...DHCP报文格式(华为路由器学习指南354页) 二、基于全局的HCP地址池配置 1、基本配置 System-view IP pool name Net...

    DHCP

    一、DHCP基础

    DHCP客户端、服务器、中继器

    1、  报文种类

    共8种(主要是前面7种类型),discover、offer、request、ACK、NAK、release、decline、inform。

     

    DHCP报文格式(华为路由器学习指南354页)

     

    二、基于全局的HCP地址池配置

    1、基本配置

    System-view

    IP pool name

    Network ip-address~mask   // 网络号与掩码

    Lease {day hour minute }  unlimited   // 指定客户端可以无限期使用该地址

    Excluded-ip-address (起始IP) (结束IP)

    Gateway-list IP-address & <1---8>  // 指定网关地址,同网段的,以空格分隔,最多8个

    Static-bind ip-address IP mac-address MAC  // 静态绑定客户端)

    Next-server IP      // 获取地址完成后,下一步提供配置信息的服务器地址

    Vpn-instance name   // 配置地址池下的VPN实例)

    Lock     // 锁定客户端正在使用的IP地址,当进行网关设备切换时使用

     

    2、  将接口与全局地址池绑定

    Dhcp enable

    Interface e0/0/0

    IP address IP mask

    Dhcp select global                           

     

    3、  配置DNS服务和NetBIOS服务

    Ip pool name

    Import all     // 动态配置DHCP客户端使用的DNS配置信息学和NetBIOS配置信息

                    静态配置优先于动态配置

    Domain-name www.baidu.com

    Dns-list  IP-ADD   // 最多配置8个

    Nbns-list IP-ADD    // 最多配置8个

    Netbios-type { b-node | h-node | m-node | p-node }    多选一配置

     

    4、  配置防止IP地址重复分配功能

    Dhcp enable

    Dhcp server ping packet 10 timeout 100    // 报文最大次数为10次,每次最长等待时间为100ms)

    5、  配置DHCP数据保存功能

    Dhcp server database enable         // 使能DHCP数据保存到flash存储设备

    Dhcp server database write-delay interval  // 默认300S保存一次

    Dhcp server database recover    //使系统重启时,将从flash存储设备的文件中回复dhcp数据)

     

    6、  配置DHCP服务器信息Option82选项

    Dhcp server trust option82     //默认开启

     

    7、  配置DHCP为BOOTP客户端分配IP地址

    Dhcp server bootp

    Dhcp server bootp automatic

     

    三、配置基于接口地址池的DHCP服务器

    Dhcp enable

    Interface e0/0/0

    Ip address IP-ADD

    Dhcp select interface

    Dhcp server lease { day hour minute }

    Dhcp server static-bind ip-address IP-ADD mac-address MAC

    Dhcp server next-server IP-ADD

    Dhcp server import all

    Dhcp server domain-name name

    Dhcp server dns-list IP-ADD & <1---8>

    Dhcp server nbns-list IP-ADD&<1---8>

    Dhcp server netbios-type { b-node | h-node | m-node | p-node }

    四、配置DHCP中继

    1、基本配置

    Dhcp enable

    Ip relay address cycle   // 配置DHCP中继的轮训功能

    Interface e0/0/0    // 三层接口(子接口)、三层Eth-trunk口、VLANIF接口

    Ip address IP-ADD   // 为中继口配置IP地址

    Dhcp select relay   // 在三层接口上配置中继功能

    Dhcp relay trust option82   //视图模式下

     

    2、配置中继转发的目的DHCP服务器组

    Dhcp server group name  // 创建DHCP服务器组

    Dhcp-server IP-ADD     // 向创建的组中添加DHCP中继IP地址,最多有8个

    Gateway IP-ADD        // 配置网关IP

    Vpn-instance name      // 将服务器组与VPN实例绑定

     

    3、绑定中继接口与DHCP服务器或服务器组

    Dhcp relay server-select group-name    // 指定接口要绑定的DHCP服务器组

    Dhcp relay server-ip ip-address     // 配置DHCP中继所绑定的单个DHCP服务器地址

     

    4、不同网段内DHCP服务器和DHCP中继的配置示例

       P387-418

     

    五、配置DHCP/BOOTP客户端属性

    1、  dhcp enable

    interface e0/0/0

    dhcp client class-id  CLASS-ID  // 配置客户端请求报文中的Option60字段(用来设置厂商分类信息选项,表示客户端的类型和配置)

    dhcp client hostname name    // 配置客户端的主机名  

    dhcp client client-id Huawei_client  // 配置客户端的标识 

    dhcp client gateway-detect period period retransmit retransmit timeout timeout

     // 配置网关探测功能

    Dhcp client expected-lease time   // 配置客户端期望的租期时间

        

    2、  DHCP服务器路由下发属性的配置步骤

    Ip route IP-ADD MASK e0/0/0 dhcp preference-value   //  下发路由的优先级

    Interface e0/0/0

    Dhcp client defaulet-route preference preference-value  //  配置服务器下发给以上接口的客户端的路由表默认优先级

     

    3、  使能客户端功能

    Ip address dhcp-alloc 或 ip address bootp-alloc

     

    六、DHCP报文限速配置

    1、  dhcp enable

    dhcp check dhcp-rate enable vlan 2 to vlan 10     //  指定报文限速的vlan范围

    dhcp check dhcp-rate rate vlan 2 to vlan 10   // 指定上送到DHCP协议栈的检查速率

        

    2、  在vlan视图下配置DHCP报文限速

    Vlan 10

    Dhcp check dhcp-rate enable

    Dhcp check dhcp-rate rate

    Interface E0/0/0

    Dhcp check dhcp-rate rate 

    Dhcp alarm dhcp-rate enable   

    Dhcp alarm dhcp-rate threshold threshold   // 配置速率检测告警阈值

     

    七、DHCP服务管理和典型故障排除

    Display ip pool ***   // 查看全局地址池信息

    Display ip pool interface ****  // 查看接口地址池信息

    Display dhcp server database  // 查看数据库的存放信息

    Display dhcp relay all   // 查看中继接口配置的服务器(组)信息

    Display ip pool import all  //  查看服务器自动分配给客户端的DNS等信息

    Display dhcp server group name  // 查看服务器组的配置信息

    Display dhcp client   // 查看开启client接口的客户端状态信息

    Display dhcp statistic   //  查看DHCP报文统计信息

    Display dhcp client statistics interface ***  // 查看指定接口下链接的货这全部的DHCP客户端统计信息

    Display dhcp relay statistic server-group **  // 查看DHCP服务器或中级的统计信息

    Display dhcp server statistics    // 查看DHCP服务器的统计信息

    Reset ip pool { interface *** | name *** } 重置已经配置的符合指定条件的地址池

    Reset ip pool import { all | dns | domain-name  | nbns }  // 清楚DHCP地址池动态获取的指定的配置参数信息

    Reset dhcp server statistics  // 清楚所有DHCP服务器的统计信息

    Reset dhcp statistics   // 清楚dhcp报文统计信息

    Reset dhcp client statistics [ interface *** ]   // 清楚dhcp客户端的统计信息

    Reset dhcp relay statistics [ server-group  ***  ]  // 清楚服务器组的DHCP中级统计信息

     

    转载于:https://www.cnblogs.com/laixufie2046/p/10433452.html

    展开全文
  • 华为dhcp

    千次阅读 2016-08-14 09:00:18
    [Huawei]dhcp enable [Huawei]int e0/0/0 [Huawei-Ethernet0/0/0]ip add 10.0.0.1 24 [Huawei-Ethernet0/0/0]dhcp select interface --将此接口配置为dhcp接口 [Huawei-Ethernet0/0/0]dhcp server dns-li
    1、在路由器某一网关接口使用dhcp
    [Huawei]dhcp enable
    [Huawei]int e0/0/0
    [Huawei-Ethernet0/0/0]ip add 10.0.0.1 24
    [Huawei-Ethernet0/0/0]dhcp select interface  --将此接口配置为dhcp接口
    [Huawei-Ethernet0/0/0]dhcp server dns-list 8.8.8.8 9.9.9.9  --配置主备dns地址
    

    展开全文
  • 华为DHCP实验配置

    2021-05-14 10:00:56
    华为DHCP实验配置 目录 华为DHCP实验配置 网络结构 实验拓扑 基础配置 网络初步测试 DHCP配置 网络测试 DHCP常用查看命令 网络结构 终端 --- 接入设备 --- 核心设备 实验拓扑 S1为VLAN10的网关同时...

    华为DHCP实验配置

    目录

    华为DHCP实验配置

    网络结构

    实验拓扑

    基础配置

    网络初步测试

    DHCP配置

    网络测试

    DHCP常用查看命令


    网络结构

    终端 --- 接入设备 --- 核心设备

     

    实验拓扑

    S1为VLAN10的网关同时配置DHCP服务

    基础配置

    S2

    [S2]vlan 10    // 创建vlan10
    [S2-vlan10]qu
    [S2]int e0/0/1
    [S2-Ethernet0/0/1]port link-type access           // 连入终端接口配置为 access
    [S2-Ethernet0/0/1]port default vlan 10            // 将该接口PVID改为10
    [S2-Ethernet0/0/1]int e0/0/2
    [S2-Ethernet0/0/2]port link-type trunk            // 上连入交换机接口配置为 trunk
    [S2-Ethernet0/0/2]port trunk allow-pass vlan 10   // 配置VLAN放行列表
    [S2-Ethernet0/0/2]qu
    [S2]dis port vlan                                 // 检测接口配置
    
    Port                    Link Type    PVID  Trunk VLAN List
    -------------------------------------------------------------------------------
    Ethernet0/0/1           access       10    -                                   
    Ethernet0/0/2           trunk        1     1 10
    
    

    S1

    [S1]vl 10         // 创建VLAN10
    [S1-vlan10]q
    [S1]int g0/0/1
    [S1-GigabitEthernet0/0/1]port link-type trunk             // 将下联交换机的接口配置为trunk
    [S1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10    // 配置VLAN放行列表
    [S1-GigabitEthernet0/0/1]qu
    [S1]int vl 10                                             // 创建VLANIF接口
    [S1-Vlanif10]ip add 192.168.10.254 24
    [S1-Vlanif10]qu
    [S1]dis port vlan                                         // 检查VLAN配置
    Port                    Link Type    PVID  Trunk VLAN List
    -------------------------------------------------------------------------------
    GigabitEthernet0/0/1    trunk        1     1 10
                                 
    [S1]dis ip int bri                                        // 检查VLANIF接口配置
    
    Interface                         IP Address/Mask      Physical   Protocol     
    Vlanif1                           unassigned           up         down      
    Vlanif10                          192.168.10.254/24    up         up   

    网络初步测试

    给PC1手动配置VLAN10 192.168.10.0/24的地址,访问网关,测试网络连通性 

    (此步骤是为了测试网络连通性,如果手动配置IP地址无法访问网关,之后配置的DHCP也将无法获取地址,排错会更加困难)

    测试完成后将PC IPV4配置模式更改为DHCP

    DHCP配置

    [S1]dhcp enable           // 开启DHCP功能
    [S1]ip pool vlan_10       // 创建DHCP地址池
    Info:It's successful to create an IP address pool.
    [S1-ip-pool-vlan_10]network 192.168.10.0 mask 24    // DHCP地址池的网段及掩码(必填)
    [S1-ip-pool-vlan_10]gateway-list 192.168.10.254     // DHCP地址池的网关(必填)
    [S1-ip-pool-vlan_10]excluded-ip-address 192.168.10.201 192.168.10.253    // 排除地址(选填)
    [S1-ip-pool-vlan_10]dns-list 114.114.114.114        // DHCP地址池下放DNS地址 (根据情况选择)
    [S1-ip-pool-vlan_10]lease 0 6 0                     // DHCP地址租期 (选填)
    [S1-ip-pool-vlan_10]dis th
    #
    ip pool vlan_10
     gateway-list 192.168.10.254
     network 192.168.10.0 mask 255.255.255.0
     excluded-ip-address 192.168.10.201 192.168.10.253
     lease day 0 hour 6 minute 0
     dns-list 114.114.114.114
    
    [S1]int vl 10
    [S1-Vlanif10]dhcp select global         // 将创建的DHCP地址池应用到之前创建的VLANIF接口上
    

    网络测试

    查看终端是否获取地址,测试网络连通性

    DHCP常用查看命令

    [S1]dis ip pool name vlan_10 
      Pool-name      : vlan_10                        // 地址池名称
      Pool-No        : 0
      Lease          : 0 Days 6 Hours 0 Minutes       // 租期
      Domain-name    : -                              // 域名
      DNS-server0    : 114.114.114.114                // DNS
      NBNS-server0   : -               
      Netbios-type   : -               
      Position       : Local           Status           : Unlocked
      Gateway-0      : 192.168.10.254                  // 网关
      Mask           : 255.255.255.0                   // 掩码
      VPN instance   : --
     -----------------------------------------------------------------------------
             Start           End     Total  Used  Idle(Expired)  Conflict  Disable
     -----------------------------------------------------------------------------
        192.168.10.1  192.168.10.254   253     1        199(0)         0       53
     -----------------------------------------------------------------------------
            起始地址      结束地址   总计地址  已使用地址  剩余可用地址     不可用地址总数

     

    展开全文
  • 华为DHCP实验

    2018-08-15 00:01:17
    华为DHCP实验,三种DHCP,附有配置。 接口下+本地地址池+中继+DHCP Snooping
  • 华为DHCP服务器配置

    2020-07-29 14:01:11
    华为dhcp服务默认关闭,在系统视图中使能dhcp服务功能 [Huawei]dhcp enable 1.接口地址池 interface GigabitEthernet0/0/0 ip address 10.39.2.254 255.255.255.0 dhcp select interface #定义为接口地址池 dhcp...

    在这里插入图片描述
    DHCP服务配置:
    华为dhcp服务默认关闭,在系统视图中使能dhcp服务功能
    [Huawei]dhcp enable

    1.接口地址池
    interface GigabitEthernet0/0/0
     ip address 10.39.2.254 255.255.255.0 
     dhcp select interface   #定义为接口地址池
     dhcp server excluded-ip-address 10.39.2.2  #排除不分配的地址
     dhcp server dns-list 8.8.8.8  # DNS设置
    
    2.全局地址池配置

    在系统视图下定义地址池:

    ip pool 501      #定义地址池
    	 gateway-list 10.39.2.1     #网关地址
    	 network 10.39.2.0 mask 255.255.255.0   #网络号
    	 dns-list 8.8.8.8   #DNS
    

    在接口下使用

    interface GigabitEthernet0/0/0
        ip address 10.39.2.254 255.255.255.0 
        dhcp select global   #定义全局地址池
    

    在终端命令行中输入ipconfig 查看获取的IP地址(此图为接口地址池配置)
    在这里插入图片描述

    展开全文
  • 华为 DHCPDHCP中继、DHCP snooping

    千次阅读 多人点赞 2021-02-15 22:02:28
    DHCP客户端获取地址的过程,分为四个阶段:发现阶段,提供阶段,选择阶段,确认阶段。
  • 华为dhcp和e1t1资料

    2012-01-05 12:13:52
    华为dhcp和e1t1资料
  • 华为 dhcp及中继配置: 思路:1、配置 DHCP 客户端 确保每个 PC 为 自动获取IP地址的方式;2、配置 SW1 # 创建 VLAN 10 , 20 # 将相关的端口,放入到对应的 VLAN ; # 配置交换机之间的互联链路 - Trunk ;3、配置 ...
  • 华为DHCP技术白皮书

    2009-04-09 00:34:49
    华为 dhcp技术白皮书 全面而详细的介绍了DHCP的概念、原理、应用,是希望详细深入了解DHCP技术的人员的很好的选择;
  • 华为DHCP中继实验配置

    2020-05-25 16:51:50
    华为DHCP中继实验配置实验目的配置SW1交换机配置AR1路由器配置AR2路由器配置AR3路由器 实验目的 运用DHCP中继使数据存在AR3中实现全网互通,分担AR1路由器的压力 配置SW1交换机 [SW1]vlan batch 10 20 ...
  • 华为DHCP中继

    2019-12-12 08:27:26
    通常在DHCP分配网段过多的情况下,网关路由器上配置DHCP服务,压力过大, 一般我们用第二路由器,或则第二台DHCP服务器来分担业务 实验环境 准备五台没有IP地址主机我们利用DHCP服务来分配地址 拓扑图如下 实验...
  • 华为DHCP中继配置

    千次阅读 2019-06-02 12:01:48
    DHCP 在实际应用中比较广泛,最近刚好重温DHCP就顺便把以前学习遇到的相关问题写下来。 DHCP工作流程: 1、客户端发送DHCP广播请求(UDP报文源68目的67) 2、DHCP服务器回复OFFER报文,客户端一般首选第一个接收到的...
  • DHCP 动态主机配置协议 基于UDP协议 bootpc—端口号68 bootps—端口号67 DHCP 角色: 1.DHCP client: 请求获取ip地址 2.DHCP server:为DHCP client分配的地址,地址租借,续租,释放 3.DHCP relay :中继代理(由于...
  • 如果DHCP客户端和DHCP服务器不在同一网段内,需要DHCP中继负责DHCP服务器与DHCP客户端之间的DHCP报文转发,这样可以避免在每个网段部署DHCP服务器,节约成本,方便管理。 DHCP服务器和DHCP客户端之间的DHCP报文中继...
  • 华为DHCP服务

    2019-09-01 14:52:00
    DHCP服务 思路: 1 全网互通 2 三层设备上配置DHCP服务器 R1 sys [Huawei]interface e0/0/0 [Huawei-Ethernet0/0/0]ip address 192.168.1.254 255.255.255.0 [Huawei-Ethernet0/0/0]undo shutdown [Huawei-Ethernet...
  • 华为DHCP配置

    万次阅读 2019-05-27 10:13:01
    为了方便 吧二层交换机都以24口连接核心... 开启DHCP 服务 <coreSW>system-view [coreSW]dhcp enable 增加地址池 [coreSw]ip pool 10 新增地址池名称为 10 [coreSw-ip-pool-10]network 192.168.1...
  • 华为DHCP中继实战

    2019-11-05 11:10:25
    DHCP中继 eNSP中拓扑图: SW1: <Huawei>sys [Huawei]sysname SW1 [SW1]vlan bat 10 20 Info: This operation may take a few seconds. Please wait for a moment...done. [SW1]int e0/0/1 [SW1-Ethernet0/0/...
  • 思科华为DHCP实验

    2020-07-14 17:02:28
    DHCP 动态主机分配协议,在任何网络种都少不了DHCP的存在,它的主要用途主要有两个: 1.给内部网络或网络服务供应商自动分配IP地址2.给用户或者内部网络管理员作为对所有计算机作中央管理的手段 DHCP的过程原理: 1...
  • DHCP客户端只使用DHCP协议栈接收DHCP报文,不使用DHCP协议栈发送DHCP报文。因此在定位DHCP相关业务的故障时,都需要查看DHCP协议栈的统计信息。不需要DHCP服务器、DHCP中继、DHCP Snooping和DHCP客户端处理的DHCP...
  • 华为DHCP综合实验

    2021-06-28 15:35:40
    第二种方法在R2创建dhcp服务器组 R2: dhcp server group 1020 dhcp-server 23.1.1.1 0 interface GigabitEthernet0/0/0 ip address 23.1.1.2 255.255.255.0 interface GigabitEthernet0/0/1 ip address 20.1.1.1 ...
  • DHCP实验 一、基本概念 (1)DHCP服务器 负责从地址池中分配地址给HDCP客户端,可以为DHCP客户端提供其他网络参数(dns...负责转发DHCP服务器和DHCP客户端之间的DHCP报文,协助DHCP服务器向DHCP客户端动态分配网络参数
  • 华为DHCP interface

    2017-11-12 19:03:00
    SW1关键配置如下: dhcp enable interface Vlanif10 ip address 192.168.10.1 255.255.255.0 dhcp select interface # interface Vlanif20 ip address 192.168.20.1 255.255.255.0 dhcp select ...
  • 华为DHCP relay配置过程/管理口配置

    万次阅读 2016-06-22 16:36:14
    ## 华为DHCP中继配置过程—示例篇 # DHCP relay/5700/5352C/云维护 需求概述: DHCP客户端所在的网段为20.20.20.0/24,而DHCP服务器所在的网段为100.10.10.0/24。需要通过带DHCP Relay功能的Switch中继DHCP...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,368
精华内容 2,147
关键字:

华为dhcp