精华内容
下载资源
问答
  • 华为ensp模拟器RIP

    2021-04-06 09:37:34
    利用RIP实现下图中的全网可达 1.先配置各接口ip地址。 2.在各个路由器上起RIP协议并选择版本号 RIP v2的配置 注:需要关闭自动汇总(undo summary),宣告的为主内网络 RIP v1的配置 3.在R6上做RIP2对RIP1的接收...

    利用RIP实现下图中的全网可达

    在这里插入图片描述
    1.先配置各接口ip地址。
    2.在各个路由器上起RIP协议并选择版本号
    RIP v2的配置
    这里插入图片描述
    注:需要关闭自动汇总(undo summary),宣告的为主内网络
    RIP v1的配置
    在这里插入图片描述
    3.在R6上做RIP2对RIP1的接收实现全网可达
    先进接口G0/0/2,再将RIP1的导入RIP2中
    在这里插入图片描述
    最终即可实现用RIP实现全网可达

    展开全文
  • 华为模拟器里使用RIP协议跨越主类网络边界的实验现象 实验1:使用RIPv1协议跨越主类网络边界 Step1:输入必打命令 <Huawei>undo terminal monitor(关闭自动弹窗) <Huawei>system-view (进入系统...

    华为模拟器里使用RIP协议跨越主类网络边界

    实验1:使用RIPv1协议跨越主类网络边界

     

    Step1:输入必打命令

    <Huawei>undo terminal monitor(关闭自动弹窗) 
    <Huawei>system-view (进入系统视图)
    [Huawei]sysname R1(命名路由器为R1)
    [R1]user-interface console 0
    [R1-ui-console0]idle-timeout 0 0(设置永不超时)
    [R1-ui-console0]quit

    R2、R3、R4同理

    Step2:设置路由器的IP,如图所示。并开始ping左右路由器。

    R2、R3、R4同理

    Step3:设置协议为RIP

    [R1]rip
    [R1-rip-1]network 10.0.0.0 (network后跟着主类IP地址)
    [R1-rip-1]quit

    R2、R3、R4同理

    Step4:观察现象

    [R1]display ip routing-table 

    Destination/Mask Proto Pre Cost Flags NextHop Interface

    10.1.1.0/24 Direct 0 0 D 10.1.1.1 GigabitEthernet
    0/0/0
    10.1.1.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
    0/0/0
    12.0.0.0/8 RIP 100 2 D 10.1.1.2 GigabitEthernet
    0/0/0
    127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
    127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
    172.16.0.0/16 RIP 100 1 D 10.1.1.2 GigabitEthernet
    0/0/0

    跨越主类网络边界的路由器会自动把路由汇总成主类显示,子网掩码变为主类网络默认,如R1中的,12.0.0.0/8,如果没有跨越则不会汇总。

    实验2:使用RIPv1协议不跨越主类网络边界

    Step1:输入必打命令

    <Huawei>undo terminal monitor(关闭自动弹窗) 
    <Huawei>system-view (进入系统视图)
    [Huawei]sysname R1(命名路由器为R1)
    [R1]user-interface console 0
    [R1-ui-console0]idle-timeout 0 0(设置永不超时)
    [R1-ui-console0]quit

    R2、R3、R4同理

    Step2:设置路由器的IP,如图所示。并开始ping左右路由器。

    R2、R3、R4同理

    Step3:设置协议为RIP

    [R1]rip
    [R1-rip-1]network 10.0.0.0 (network后跟着主类IP地址)
    [R1-rip-1]quit

    R2、R3、R4同理

    Step4:观察现象

    Destination/Mask Proto Pre Cost Flags NextHop Interface

    10.1.1.0/24 Direct 0 0 D 10.1.1.5 GigabitEthernet
    0/0/0
    10.1.1.5/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
    0/0/0
    10.1.2.0/24 RIP 100 1 D 10.1.1.6 GigabitEthernet
    0/0/0
    10.1.3.0/24 RIP 100 2 D 10.1.1.6 GigabitEthernet
    0/0/0
    127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
    127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

    不跨越主类网络边界,则不会自动汇总,如10.1.3.0/24。

    实验3:设置为RIPv2协议跨越主类网络边界

    步骤同1,增加变更RIP协议的步骤。

    Step5:变更RIP协议为RIPv2

    [R1]rip
    [R1-rip-1]version 2(修改为版本2,默认为1)
    [R1-rip-1]undo summary(关闭自动汇总)

    Step6:观察现象

    [R1]display ip routing-table

    Destination/Mask Proto Pre Cost Flags NextHop Interface

    10.1.1.0/24 Direct 0 0 D 10.1.1.1 GigabitEthernet
    0/0/0
    10.1.1.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
    0/0/0
    12.1.1.0/24 RIP 100 2 D 10.1.1.2 GigabitEthernet
    0/0/0
    127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
    127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
    172.16.1.0/24 RIP 100 1 D 10.1.1.2 GigabitEthernet
    0/0/0

    可以看出IP地址未被自动汇总,是12.1.1.0/24

    展开全文
  • 动态路由信息协议RIP;配置RIP命令;测试路由器之间联通情况;Wireshark抓包分析e/0/0/0。

    一、动态路由信息协议RIP

    动态路由信息协议RIP(Routing Information Protocol):它是一种基于距离矢量
    (Distance-Vector)算法的协议,使用跳数作为度量来衡量达到目的网络的距离。RIP主要用于规模较小的网络中,收敛速度很慢。
    工作原理:路由器运行RIP 后,首先会发送路由更新请求,收到请求的路由会发送自己的RIP路由进行响应。网络稳定后,路由器会周期性(30秒)发送路由更新信息,目标地址是224.0.0.9的组播地址,报文存放的的是路由信息。RIP的默认优先级Pre是100,RIP只看路由远近,距离以跳数(经过路由器的个数)来衡量,最大跳数不能超过15跳,经过16跳的路由器不可达。
    抑制接口:又称静默接口,配置接口为抑制状态,发送但不接收RIP路由更新报文,抑制接口通常用于接PC端路由器,如R1的Ethernet0/0/1接口,其优先级大于RIP Input和RIP Output。
    [R1]rip
    [R1-rip-1]silent-interface e0/0/1
    华为路由器拓扑图

    二、配置RIP命令

    如上图所示,在配置好R1、R2和R3路由器各个接口IP地址后再配置RIP协议。

    (一)配置路由器RI的RIP路由

    [R1]rip 1 #RIP进程号
    [R1-rip-1]version 2 #使用RIP 2版本
    [R1-rip-1]network 192.168.1.0 # 宣告直连类网路
    [R1-rip-1]network 12.0.0.0 # 宣告直连类网路
    [R1-rip-1]undo summary #关闭路由自动汇总
    [R1-rip-1]display this

    rip 1
    undo summary
    version 2
    network 192.168.1.0
    network 12.0.0.0

    return

    (二)配置路由器R2的RIP路由

    [R2]rip 1
    [R2-rip-1]version 2
    [R2-rip-1]undo summary
    [R2-rip-1]network 12.0.0.0
    [R2-rip-1]network 23.0.0.0
    [R2-rip-1]network 172.16.0.0
    [R2-rip-1]display this

    rip 1
    undo summary
    version 2
    network 12.0.0.0
    network 23.0.0.0
    network 172.16.0.0

    (三)配置路由器R3的RIP路由

    [R3]rip 1
    [R3-rip-1]version 2
    [R3-rip-1]undo summary
    [R3-rip-1]network 23.0.0.0
    [R3-rip-1]network 10.0.0.0
    [R3-rip-1]display this

    rip 1
    undo summary
    version 2
    network 23.0.0.0
    network 10.0.0.0

    (四)抑制路由器R1接口E0/0/1

    RIP Input和RIP Output。
    [R1]rip
    [R1-rip-1]silent-interface e0/0/1

    三、测试路由器之间联通情况

    PC1终端ping路由器R3

    四、Wireshark抓包分析e/0/0/0

    抓包分析e/0/0/0
    Wireshark抓包路由器接口

    展开全文
  • 目录一、RIP路由1.1 RIP路由基础1.2 根据距离向量确定路由1.3 RIP的优缺点1.4 RIP路由配置1.5 RIP配置实验干货分享精彩链接最后 一、RIP路由 1.1 RIP路由基础 路由信息协议(RIP)是内部网关协议中使用较为广泛的...

    有理想,有抱负,相信在不久的将来你会成功的!

    打开微信搜索【孩子上学后】,关注这个不一样的程序员。

    一、RIP路由

    1.1 RIP路由基础

    路由信息协议(RIP)是内部网关协议中使用较为广泛的协议,它是一种分布式、基于距离向量的路由选择协议。

    RIP将路由控制信息(30秒1次)向全网广播。如果没有收到路由控制信息,连接就会断开。不过,这可能是丢包导致的,因此规定RIP等待5次。如果等了6次(180秒)仍未收到路由信息,才会真正关闭连接。

    1.2 根据距离向量确定路由

    RIP基于距离向量算法决定路径。距离的单位为“跳数。跳数是指所经过路由的个数。RIP希望尽可能少的通过路由器将数据包转发到目标IP地址。

    1.3 RIP的优缺点

    在默认情况下,RIP不考虑不考虑带宽、时延等因素,只考虑距离,距离就是通往目的站点所经过的链路数,也称为跳数,跳数越小路径越佳。RIP最小路径称为最佳路径。RIP的跳数取值为1~15,数值16表示无穷大。

    • 优点

      简单,没有复杂的配置选项

    • 缺点

      有最大跳数限制,因此只适合小型互联网络,不适合大型网络;路由更新收敛速度慢,不适合变化剧烈的互联网络。

    1.4 RIP路由配置

    RIP动态东路协议的配置主要包括基本配置和高级配置,配置命令格式如下:

    (1)router rip

    启动RIP协议,并开启RIP进程。

    (2)version1或2

    RIP有两个版本:RIP1和RIP2,RIP1不支持可变长掩码,因此交换路由信息时,不在更新报文中携带子网掩码。RIP2支持可变长掩码、多点广播路由更新和路由更新认证功能。

    (3)network网络地址

    设置RIP协议的网络地址,在设置RIP路由时要注意,network后面的网络地址是指与本路由器直接连接的网络地址,与静态路由完全不同,在静态路由中,路由器的目标网络是与路由器不直接连接的网络,两者正好相反。

    1.5 RIP配置实验

    配置思路

    • 由于要在小型网络中实现设备的网络互联,所以推荐配置RIP路由协议
    • 配置各个连接口的IP地址,使网络可达。
    • 在各个路由器上使用RIP,基本实现网络互联。
    • 在各个路由器上配置RIP2版本,提升RIP路由拓展性能。

    拓扑

    搭建好了拓扑之后,可以配置每个路由端口和PC机的IP地址

    PC1配置

    pc1

    PC2配置

    PC2

    R1配置

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info	
    [Huawei]undo info-center en	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.1.254 24
    [Huawei-GigabitEthernet0/0/1]inter g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.2.1 24
    [Huawei-GigabitEthernet0/0/0]
    

    R2配置

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo in	
    [Huawei]undo info-center en	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.2.2 24
    [Huawei-GigabitEthernet0/0/0]inter g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.3.1 24
    [Huawei-GigabitEthernet0/0/1]
    

    R3配置

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo in	
    [Huawei]undo info-center en	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.3.2 24
    [Huawei-GigabitEthernet0/0/1]inter g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.4.254 24
    [Huawei-GigabitEthernet0/0/0]
    

    接下来就是在各个路由器上配置RIP

    R1配置RIP

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]rip 1
    [Huawei-rip-1]version 2
    [Huawei-rip-1]netwo	
    [Huawei-rip-1]network 192.168.1.0
    [Huawei-rip-1]network 192.168.2.0
    

    R2配置RIP

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]rip 1
    [Huawei-rip-1]version 2
    [Huawei-rip-1]network 192.168.3.0
    [Huawei-rip-1]network 192.168.2.0
    

    R3配置RIP

    [Huawei]rip 1
    [Huawei-rip-1]version 2
    [Huawei-rip-1]networ	
    [Huawei-rip-1]network 192.168.3.0
    [Huawei-rip-1]network 192.168.4.0
    [Huawei-rip-1]
    

    测试

    测试

    从上图可以看到,由PC1到PC2可以ping通,说明本次的RIP协议配置成功!

    干货分享

    打开微信搜索【孩子上学后】

    回复【ensp命令参考手册】,即可获取华为模拟器ensp命令参考手册!

    回复【RIP路由协议】,即可获取配置文件!

    精彩链接

    教你使用华为Ensp模拟器配置静态路由

    最后

    从本次配置上来看,RIP协议相对于静态路由来说是简单很多的,只需要配置与路由相邻的网段即可。

    这次的笔记分享到这里就结束了,更多精彩内容我们下期再见!

    路漫漫其修远兮,吾将上下而求索!

    我是啃书君,一个专注于学习的人,你懂得越多,你不懂的越多。

    更多精彩内容,我们下期再见!

    展开全文
  • RIP路由协议 概念:RIP(Routing Information Protocol,路由信息协议)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法...
  • 大家好! 我叫风清云淡,有句话说“相识是缘”,我也希望多多认识一些志同道和的朋友。作为一名互联网行业的小萌新,写博客一方面是为了记录自己的学习过程,另一方面是总结自己所犯的错误...实验十六 连接RIP 与OSPF网
  • 大家好! 我叫风清云淡,有句话说“相识是缘”,我也希望多多认识一些志同道和的朋友。作为一名互联网行业的小萌新,写博客一方面是为了...文章目录实验十四 RIP实验内容实验步骤实验十五 配置RIPV2 认证实验内容实验步骤
  • ospf与rip的重分发,在之前的基础上,添加了使用RIPv2协议的R6 Step1:如图所示,敲必打命令与设置IP地址。 R1: <Huawei>undo terminal monitor <Huawei>system-view [...
  • 1.1 RIP路由基础1.2 根据距离向量确定路由1.3 RIP的优缺点1.4 RIP路由配置1.5 RIP配置实验一、RIP路由1.1 RIP路由基础路由信息协议(RIP)是内部网关协议中使用较为广泛的协议,它是一种分布式、基于距离向量的路由...
  • eNSP 华为模拟器 acl配置实验

    千次阅读 2020-05-08 16:42:58
    ACL基础配置实验 ACL:访问控制列表 ACL可分为基础ACL和扩展ACL 基础ACL是对源ip地址进行过滤 ...华为(eNSP) RIP实验实验配置过程 在全网可以ping通的情况下我们开始配置acl 基础ACL配置:(在A...
  • eNsp华为模拟器 ospf配置实验

    千次阅读 2020-05-02 00:10:33
    ②network宣布地网段是自己的直连网段(与rip相同),但是需要加上反掩码 一、实验拓扑图搭建 二、配置过程 1、配置pc1、pc2的IP地址和网关。 PC1: PC2: 2、配置各个端口的ip地址 [R1]int g0/0/2 [R1-Giga...
  • 使用华为ENSP模拟器验证OSPF导入RIP路由,附上幕布笔记链接 https://share.mubu.com/doc/5HCTFQztRen
  • 【eNSP 华为模拟器】配置 NAT Easy - IP 与 RIPv2 一、拓扑图和实验结果 二、路由器配置 三、抓包分析 一、拓扑图和实验结果 从pc1 ping 到pc2 二、路由器配置 路由器AR1配置: [R1]int g0/0/0 [R1-...
  • 要求 1.按照拓扑所示,搭建网络环境,进行设备重命名 2.根据pc机给定地址信息,完成各自ip地址、网关地址计算及配置 3.采用RIP协议+静态路由实现pc1、2、3互通
  • 使用华为ENSP模拟器验证Multi VPN Instance CE,VPN路由为RIP协议通告。附上幕布笔记链接 https://mubu.com/doc/-4Ug1ueix7
  • 华为 eNSP 模拟器练习3

    2020-06-04 23:40:15
    在AR3路由器:RIP路由中导入默认路由,实现与公网pc1通信 大概的配置,如下图: AR2 PC1 AR3 LSW1 AR 测试失败 经过检查,LSW1处,出现错误 由上图可知,vlan 20 并没有处于up状态,重复此前对接口g0/0/24...
  • [Quidway-Ethernet0]rip split-horizon ;水平分隔 [Quidway]router id A.B.C.D 配置路由器的ID [Quidway]ospf enable 启动OSPF协议 [Quidway-ospf]import-route direct 引入直联路由 [Quidway-Serial0]ospf ...
  • 1.1 OSPF区域化结构1.2 OSPF报文类型1.3 多区域OSPF网络前言与RIP协议一样,OSPF也是一种IGP。通常,我们把一个以OSPF协议作为其IGP的自治系统称为OSPF网络。然而,OSPF协议的复杂程度要远远大于RIP协议。曾经我花了...
  • 1.1 OSPF区域化结构1.2 OSPF报文类型1.3 多区域OSPF网络前言与RIP协议一样,OSPF也是一种IGP。通常,我们把一个以OSPF协议作为其IGP的自治系统称为OSPF网络。然而,OSPF协议的复杂程度要远远大于RIP协议。曾经我花了...
  • 华为 eNSP 配置 RIP OSPF

    2014-11-29 11:53:48
    RIPOSPF1.实验拓扑:使用ENSP模拟器(版本V100R002C001.2.00.350)2.实验需求1:所有路由器都...实验配置先配IPRIPR1[Huawei]intg0/0/0[Huawei-GigabitEthernet0/0/0]ipadd12.0.0.124[Huawei-GigabitEthernet0/0/0...
  • RIP协议一样,OSPF也是一种IGP。通常,我们把一个以OSPF协议作为其IGP的自治系统称为OSPF网络。 然而,OSPF协议的复杂程度要远远大于RIP协议。曾经我花了2个小时左右的时间就学会了RIP协议,但是现在我花了两周...
  • 华为综合实验 实验拓扑图 模拟器拓扑图 实验步骤 一、配置单臂路由 二、配置RIPv2,RIP路由汇总,开启身份验证 三、配置多区域OSPf,开启身份验证 四、配置路由重分发 五、将R6 的Telnet发布到外网,...
  • 华为OSPF和RIP协议配置

    2017-11-15 15:09:00
    用的是ENSP的模拟器 各网段的IP地址如下: AR1的E0/0/1的地址是192.168.12.1 /24 AR1的E0/0/0的地址是192.168.15.1/24 AR2的E0/0/1的地址是192.168.12.2/24 AR2的E0/0/0的地址是192.168.23.2/24 AR3的E0/0/0的...
  • 华为模拟器–动态路由器+RIP路由协议配置及验证 文章目录华为模拟器--动态路由器+RIP路由协议配置及验证前言一、动态路由1.1动态路由协议基础1.1.1动态路由1.1.2动态路由特点1.2动态路由协议概述1.2.1度量值1.2.2...
  • 1.1 OSPF区域化结构1.2 OSPF报文类型1.3 多区域OSPF网络前言与RIP协议一样,OSPF也是一种IGP。通常,我们把一个以OSPF协议作为其IGP的自治系统称为OSPF网络。然而,OSPF协议的复杂程度要远远大于RIP协议。曾经我花了...
  • 1.1 OSPF区域化结构1.2 OSPF报文类型1.3 多区域OSPF网络前言与RIP协议一样,OSPF也是一种IGP。通常,我们把一个以OSPF协议作为其IGP的自治系统称为OSPF网络。然而,OSPF协议的复杂程度要远远大于RIP协议。曾经我花了...
  • 实验前准备1、电脑上安装华为ENSP模拟器2、添加三台路由器配置命令上一章已经介绍过,这里就不在赘述总结:1.什么是自动汇总?当子网路由传递到主类网段边界的时候,路由器会将子网路由汇总为主类网段再发送出去。2....
  • 实验前准备1、电脑上安装华为ENSP模拟器2、添加三台路由器命令介绍AR1配置1.配置接口IP2.配置RIP协议:[R1]rip 100[R1-rip-100]network 12.0.0.0 [R1-rip-100]quit3.查看RIP路由器:[R1]display ip routing-tableAR2...
  • 使用华为的HW-RouteSim路由模拟器配置的RIP计算机网络实验,教会你配置RIP动态路由!

空空如也

空空如也

1 2 3
收藏数 58
精华内容 23
关键字:

华为模拟器rip