精华内容
下载资源
问答
  • 思科静态路由配置

    千次阅读 2020-10-11 17:15:10
    1.常用命令 名称 作用 en 进入特权模式 conf t 进入配置模式 ...配置ip ...配置静态ip路由 hostname R1 修改路由器名字为R1 2.网络布局 3.网络拓步图 4.实现PC0能够ping通PC1 p

    1.常用命令

    名称作用
    en进入特权模式
    conf t进入配置模式
    no shutdown启用
    interface g0/0进入接口模式
    ip address +参数配置ip
    show ip route查看路由表
    show ip interface brie只显示ip信息
    ip route +参数配置静态ip路由
    hostname R1修改路由器名字为R1

    2.网络布局

    在这里插入图片描述

    3.网络拓步图

    在这里插入图片描述

    4.实现PC0能够ping通PC1

    pc0
    255.255.255.0192.168.1.1192.168.1.254
    pc1
    255.255.255.0192.168.4.1192.168.4.254

    思路:

    要实现PC0到到PC1需要通过路由器进行配置,路由器的作用就是实现咋不同局域网之间进行通信。

    配置acl访问列表:

    接口配置:

    4.1 R1路由配置接口

    配置g0/0为1.0网段的网关

    配置g0/1为2.1

    R1>en  命令提示符   #>代表用户模式提示符 基本上什么都干不了,只能做一些简单的查看操作
    R1#conf t   #输入en后进入 特权模式  可以做一些稍微复杂的操作   可以进行系统配置查看
    R1(config)#    interface g0/0     #输入conf t进入 配置模式提示符  可以对主机做一些配置
    R1(config-if)#     #输入intface g0/0 接口模式
    R1(config-if)#ip address 192.168.1.254 255.255.255.0   配置ip
    R1(config-if)#no shutdown   #激活
    R1(config)#   interface g0/1     #输入conf t进入 配置模式提示符  可以对主机做一些配置
    R1(config-if)#     #输入intface g0/0 接口模式
    R1(config-if)#ip address 192.168.2.1 255.255.255.0   配置ip
    R1(config-if)#no shutdown   #激活
    
    #在特权模式下查看路由表
    R1#show ip interface brief 
    Interface              IP-Address      OK? Method Status                Protocol 
    GigabitEthernet0/0     192.168.1.254   YES manual up                    up 
    GigabitEthernet0/1     192.168.2.1     YES manual up                    down 
    
    

    ps:
    #ctrl +z 快速回到配置

    #show interface g0/0 查看接口g0/0的ip

    #show ip interface brief 只显示接口ip地址信息

    4.2 R2路由配置接口

    配置g0/0为2.2

    配置g0/1为3.1

    R2>en  命令提示符   #>代表用户模式提示符 基本上什么都干不了,只能做一些简单的查看操作
    R2#conf t   #输入en后进入 特权模式  可以做一些稍微复杂的操作   可以进行系统配置查看
    R2(config)#    interface g0/0     #输入conf t进入 配置模式提示符  可以对主机做一些配置
    R2(config-if)#     #输入intface g0/0 接口模式
    R2(config-if)#ip address 192.168.2.2 255.255.255.0   配置ip
    R2(config-if)#no shutdown   #激活
    R2(config)#    interface g0/1     #输入conf t进入 配置模式提示符  可以对主机做一些配置
    R2(config-if)#     #输入intface g0/1 接口模式
    R2r(config-if)#ip address 192.168.3.1 255.255.255.0   配置ip
    R2r(config-if)#no shutdown   #激活
    
    
    
    R2#show ip route 
    C       192.168.2.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.2.2/32 is directly connected, GigabitEthernet0/0
    ​     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.3.0/24 is directly connected, GigabitEthernet0/1
    L       192.168.3.1/32 is directly connected, GigabitEthernet0/1
    

    4.3 R3路由配置

    配置G0/0为3.2

    配置G0/1为4.254

    R3>en  命令提示符   #>代表用户模式提示符 基本上什么都干不了,只能做一些简单的查看操作
    R3#conf t   #输入en后进入 特权模式  可以做一些稍微复杂的操作   可以进行系统配置查看
    R3(config)#    interface g0/0     #输入conf t进入 配置模式提示符  可以对主机做一些配置
    R3(config-if)#     #输入intface g0/0 接口模式
    R3(config-if)#ip address 192.168.3.2 255.255.255.0   配置ip
    R3(config-if)#no shutdown   #激活
    R3(config)#    interface g0/1     #输入conf t进入 配置模式提示符  可以对主机做一些配置
    R3(config-if)#     #输入intface g0/1 接口模式
    R3(config-if)#ip address 192.168.4.254 255.255.255.0   配置ip
    R3(config-if)#no shutdown   #激活
    
    R3#show ip route
    C       192.168.3.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.3.2/32 is directly connected, GigabitEthernet0/0
    ​     192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.4.0/24 is directly connected, GigabitEthernet0/1
    L       192.168.4.254/32 is directly connected, GigabitEthernet0/1
    

    配置完接口以后 我们还是ping不通 ,因为R1路由器上没有去4网段的信息

    在这里插入图片描述

    5.配置下一跳信息

    5.1 R1路由配置去4.0

    
    ip route 路由配置  去往网段信息 网络掩码 去往目标的下一跳接口地址
    
    R1(config)# ip route 192.168.4.0 255.255.255.0  192.168.2.2 
    R1#show ip route
    ​     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.1.254/32 is directly connected, GigabitEthernet0/0
    ​     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.2.0/24 is directly connected, GigabitEthernet0/1
    L       192.168.2.1/32 is directly connected, GigabitEthernet0/1
    S    192.168.4.0/24 [1/0] via 192.168.2.2
    

    5.2 R2配置路由配置去4.0

    R2(config)# ip route 192.168.4.0 255.255.255.0 192.168.3.2
    R2#show ip route 
    C       192.168.2.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.2.2/32 is directly connected, GigabitEthernet0/0
    ​     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.3.0/24 is directly connected, GigabitEthernet0/1
    L       192.168.3.1/32 is directly connected, GigabitEthernet0/1
    S    192.168.4.0/24 [1/0] via 192.168.3.2
    

    现在去ping 还是不行 有来有回才可以ping通 接下来配置4.0网段到1.0网段的路由配置
    在这里插入图片描述

    查看r3路由表没有去往1.0网段的路由 所以导致不能通信

    在这里插入图片描述

    5.3 R2路由配置去1.0

    R2(config)# ip route 192.168.1.0 255.255.255.0 192.168.2.1
    R2#show ip route 
    S    192.168.1.0/24 [1/0] via 192.168.2.1
    ​     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.2.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.2.2/32 is directly connected, GigabitEthernet0/0
    ​     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.3.0/24 is directly connected, GigabitEthernet0/1
    L       192.168.3.1/32 is directly connected, GigabitEthernet0/1
    S    192.168.4.0/24 [1/0] via 192.168.3.2
    

    5.4 R3路由配置去1.0

    R3(config)# ip route 192.168.1.0 255.255.255.0 192.168.3.1
    R3#show ip route 
    S   192.168.1.0/24 [1/0] via 192.168.3.1
    ​     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.3.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.3.2/32 is directly connected, GigabitEthernet0/0
    ​     192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.4.0/24 is directly connected, GigabitEthernet0/1
    L       192.168.4.254/32 is directly connected, GigabitEthernet0/1
    

    在这里插入图片描述

    这样就可以ping 通了
    网关:一个主机想访问其他网关的必经之路

    路由器的接口:网关接口

    展开全文
  • Cisco路由器中的静态路由配置

    千次阅读 多人点赞 2019-10-17 15:03:52
    静态路由配置实验网路拓扑图 一 实验环境:GNS3,Windows10操作系统,SecureCRT8.0 二 实验目的:实现不同网段中主机的通信 三 实验过程: 1 对R1路由器的配置: 配置接口ip: conf t int f 0/1 ip...

    在日常生生活中,我们互相通信时,大家并不在同一网段。主要就是靠路由器的转发数据的功能。这次将在Cisco路由器上面,通过配置静态路由来实现不同网段的通信。
    在这里插入图片描述
    静态路由配置实验网路拓扑图

    一 实验环境:GNS3,Windows10操作系统,SecureCRT8.0

    二 实验目的:实现不同网段中主机的通信

    三 实验过程:

    1 对R1路由器的配置:
    配置接口ip:
    conf t
    int f 0/1
    ip add 192.168.2.1 255.255.255.0
    no shu
    int f 0/0
    ip add 192.168.1.1 255.255.255.0
    no shu
    end
    查看接口信息:
    sh ip int b
    在这里插入图片描述
    2 对R2路由器的配置:
    配置接口ip:
    conf t
    int f 0/1
    ip add 192.168.2.2 255.255.255.0
    no shu
    int f 0/0
    ip add 192.168.3.1 255.255.255.0
    no shu
    end
    查看接口信息:
    sh ip int b
    在这里插入图片描述

    3 配置两台VPC上面的ip
    PC1:ip 192.168.1.100 192.168.1.1(为该主机的默认网关)
    PC2:ip 192.168.3.100 192.168.3.1(为该主机的默认网关)

    4 配置R1,R2的路由信息:
    Tips:如果不配置静态路由信息,两网段的是无法ping通的,两端如果都配置了默认路由之后会造成路由环路,一端配置默认路由 0.0.0.0 0.0.0.0,也可以ping通。
    R1的静态路由配置:
    conf t
    ip route 192.168.3.0 255.255.255.0 192.168.2.2

    R2的静态路由配置:
    conf t
    ip route 192.168.1.0 255.255.255.0 192.168.2.1

    5 查看R1,R2路由表
    R1:sh ip route
    R2:sh ip route
    在这里插入图片描述
    在这里插入图片描述
    四 实验结果:
    在PC1机上面pingPC2:
    在这里插入图片描述
    在PC2机上面pingPC2:
    在这里插入图片描述
    结论: PC1与PC2均可以ping通。

    Tips:第一次PC1pingPC2时会发生少量丢包事件是正常事件,因为第一次数据在路由器转发过程中会丢包。

    展开全文
  • 本人计算机网络课程的实验,兴许对大家有帮助,内含实验报告一份,还有Cisco的工程文件,静态路由和动态路由都以配置好。
  • 当所有的Router都连接在一起的时候,其中同一网段内是可以实现互相访问的,但是我们如何才能够让不同网段之间的路由也可以互相...那就是静态路由配置,可能有的朋友会问怎么不用动态路由协议呢?下面我们一起来看一下
  • 思科静态路由设置

    千次阅读 2019-10-18 18:38:39
    GNS3实验|静态路由设置(三台虚拟机通过四台路由器进行互联互通) 首先,我们打开GNS3系统,进入编辑界面: [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-1j2bTLiy-1571395091233)(C:\...

    GNS3实验|静态路由的设置(三台虚拟机通过四台路由器进行互联互通)

    首先,我们打开GNS3系统,进入编辑界面:
    在这里插入图片描述
    1.放上三台虚拟机,分别以HOST;HOST2;HOST3命名。
    在这里插入图片描述
    在这里插入图片描述
    2.放置四台路由器,分别是R1,R2,R3,R4:
    在这里插入图片描述

    3.为了能让设备正常通信,需增加些许内存,个人设置了128MIB,四台以相同步骤操作:
    在这里插入图片描述
    在这里插入图片描述
    4.通过设备连接线将三台虚拟机与四台路由器连接,因为R2路由器需连接三个虚拟机,则需要三个接口,路由器设备初始为两个,所以需添加一个单板:
    在这里插入图片描述
    在这里插入图片描述
    5.先将HOST1与R1连接,HOST1选择VMNet1网卡,R2选择0/0接口:

    在这里插入图片描述

    在这里插入图片描述

    6.以此类推,R1f0/1接R2f0/0,R2f0/1接R3f0/0,R3f0/1接HOST2的VMnet2;R2f1/0接R4f0/0,R4f0/1接Host3的VMet3;接完后点击下图工具即可显示端口名称:

    在这里插入图片描述

    7.这样网络拓扑即搭建完成,接下来点击下图工具给每个端口设计IP地址,设计完后点击开始,绿灯全量即可继续下一步操作,如下图所示:
    在这里插入图片描述

    9.接下来双击R1路由器,弹出CRT远程连接工具,开始进行操作:
    在这里插入图片描述

    10.给R1路由器对着两个接口进行有效的配置;R1的两个端口分别是f0/0;IP:192.168.10.2/24f0/1;IP:192.168.20.3/24 。所以,我们先进入f0/0的接口模式,输入configure先进入全局模式然后输入interface fastEthernet 0/0进入f0/0的接口模式,如下图:
    在这里插入图片描述
    11.进入f0/0的接口模式后,输入ip address 192.168.10.2 255.255.255.0,确认后输入no shut即可录入f0/0接口的ip地址,接着返回全局模式,输入exit;再进入f0/1的接口模式,与进入f0/0的相同步骤输入即可,如下图:
    在这里插入图片描述
    12.这时为了确定ip地址是否生效,我们先输入end进入特权模式,然后输入show ip interface brief即可查看:
    在这里插入图片描述
    13.可以看出接口与ip地址已经生效。同理,用相同的步骤给R2,R3和R4路由器分别进行配置:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    14.这时四台路由器的地址已配置完成,接下来给三台虚拟机进行配置。我们打开VMware Workstation Pro虚拟机,并打开已经安装好并激活成功的三台win10-1,win10-2,win10-3系统:
    在这里插入图片描述
    在这里插入图片描述
    15.首先进行网卡绑定。先打开win10-1系统,点开右下角的设置,选择网络适配器,在自定义上选择VMnet1(仅主机模式);同理,在win10-2与win10-3上进行同样的操作;win10-2选择VMnet2;win10-3选择VMnet3;
    在这里插入图片描述
    在这里插入图片描述
    16.接着配上地址:进入win10-1系统,打开网络,点击网络并点击网络和共享中心,点击更改适配器设置,找到属于这台虚拟机的网络并右击点开属性;选择第四项并点开属性,勾选使用下面的IP地址,即HOST1的地址:192.168.10.1并把子网掩码和默认网关即R1f0/0的地址:192.168.10.1输入进去,点击确定。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    同理,把win10-2和win10-3的配置设置完成。
    在这里插入图片描述
    在这里插入图片描述
    17.此时我们联通完毕,如果不放心,可以测试一下;在win10-1虚拟机中搜索命令提示符并打开;输入 ping 192.168.10.2,如图所示,可以联通。win10-2与win10-3用相同步骤测试。
    在这里插入图片描述
    在这里插入图片描述
    18.为了能够顺利的互联互通,我们选择将虚拟机中的防火墙进行关闭:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    win10-2与win10-3已相同步骤进行关闭。

    18.想要顺利的让三台虚拟机能够互相通信,我们需要可以提供查找目标网络,从而确定转发接口及下一跳网关的路由器,因此我们将对R1,R2,R3,R4这四台路由器进行配置:
    在这里插入图片描述
    19.首先,打开R1路由器CRT界面,给R1路由器设置静态路由,即添加它的非直连网段以及下一跳地址,如图所示:
    在这里插入图片描述
    然后我们可以通过命令:do show ip route来确认;同理,给R2,R3,R4路由器进行配置:
    在这里插入图片描述
    在这里插入图片描述

    在这里插入图片描述
    在这里插入图片描述
    20.设置完毕后,即可让三虚拟机进行正常通信;我们已经ping下三台虚拟机进行验证:
    在这里插入图片描述
    在这里插入图片描述
    可以确认,静态路由设置完成。

    展开全文
  • CISCO静态路由配置实验 一、建立网络拓扑图,建立有四台计算机,两台二级交换机,两台三层交换机,两台路由器组成的网络拓扑图。并根据实验需要,进行ip的配置,网段的划分。 一、设置二层交换机 1、 创建对应的...

    CISCO静态路由配置实验

    一、建立网络拓扑图,建立有四台计算机,两台二级交换机,两台三层交换机,两台路由器组成的网络拓扑图。并根据实验需要,进行ip的配置,网段的划分。
    在这里插入图片描述

    一、设置二层交换机
    1、 创建对应的vlan,
    2、再设置接口的模式,进行接口vlan划分,其中与pc端相连,设置为access模式,与三层交换机链接的接口,设置为trunk模式
    在这里插入图片描述
    在这里插入图片描述
    三、设置三层交换机
    1、在三层交换机上创建二层交换机上对应的vlan,并根据pc的网关,设置vlan的IP地址;
    在这里插入图片描述
    2、将三层交换机上与二层交换机相连的接口,进行trunk封装,设置为trunk模式
    在这里插入图片描述
    3、与路由器的接口,设置虚拟ip地址。(注意需要先进行no
    switchport)
    在这里插入图片描述
    4、开启交换机的路由功能
    在这里插入图片描述

    四、设置路由器
    1、接口no shutdown
    在这里插入图片描述
    2、进入与三级交换机相连的接口,设置ip地址,地址与交换机上对应接口同一网段;路由器与路由器连接的接口,设置ip地址,ip地址与另一路由器相连的接口的ip地址在同一网段
    在这里插入图片描述
    五、配置交换机与路由器的静态路由
    在这里插入图片描述
    六、配置完成进行测试
    在这里插入图片描述

    展开全文
  • 思科静态路由配置简单命令

    千次阅读 2020-05-16 22:00:58
    路由器配置IP en 进入用户模式 config interface f+tab键 || interface s+tab键 启用接口模式 紧跟着写上端口号0/0 || 1/0 ip address <子网掩码> 配置IP no shutdown 配置IP route en 进入用户模式 config ip...
  • Cisco静态路由配置过程

    千次阅读 2018-11-10 15:43:16
    1,配置ip地址,并且一定要测试直连连通性 R1: En Conf t Int f0/0 Ip add 12.12.12.1 255.255.255.0 No sh R2 En Conf t Int f0/0 Ip add 12.12.12.2 255.255.255.0 No sh Int f0/1 Ip add 23.23.23.2 255.2...
  • 2、熟练掌握浮动静态路由配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器,并最终验证网络的连通性。 三、实验过程 1、实验任务说明 1、配置浮动静态路由,使两个不同网段的PC...
  • 静态路由配置实现不同网段通信——实验一 实验拓扑 PC1经过R1和R2两个路由访问PC2,两台PC处于不同网段,进行通信互访,这里我们使用静态路由的方式进行模拟配置实验 1.配置R1和R2接口ip地址 R1>enable R1#...
  • 静态路由配置.pkt

    2020-05-20 14:21:32
    学生作业.
  • 思科路由器静态路由配置

    千次阅读 2019-11-03 00:46:08
    目的二:掌握静态路由的默认路由配置 目的三:掌握路由诊断方法,会使用ping和trace等命令进行路由测试 实验设备与条件 (1)2811路由器两台,2960交换机两台,计算机若干,同异步串口连接线,网线。 (2)Cisco ...
  • 在Packet Tracer 思科模拟器中,进行默认路由器和静态路由的相关配置,在三层路由实现不同vlan间的通信的基础之上,测试多台pc机的连通性。
  • 2、熟练掌握静态路由配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器,并最终验证网络的连通性。 三、实验过程 1、实验任务说明 1、配置静态路由,使两个不同网段的PC可以互通...
  • Cisco设备——静态路由配置案例

    千次阅读 2019-11-26 14:44:29
    Router0配置 Router>enable Router#configure terminal Router(config)#interface gigabitEthernet 0/0 Router(config-if)#ip address 192.168.1.254 255.255.255.0 Router(config-if)#no shutdown Router...
  • Cisco静态路由配置录像,有题目有操作过程
  • 计算器网络实验静态路由设置,使用软件 Packet Tracer 绘制,静态路由表等已经配置完成,打开可直接运行。
  • cisco静态路由的详细配置

    万次阅读 2017-12-21 23:42:30
    cisco静态路由的详细配置
  • 云南大学信息学院 实 训 报 告 实训项目名称 静态路由配置实验 所属课程名称 计算机网络技术实验 班 级 学 号 姓 名 指导教师 徐永跃 日 期 _ 云南大学 信息学院 项目名称 静态路由配置实验 一实训概述 目的及要求 1...
  • 使用思科模拟器配置静态路由

    万次阅读 多人点赞 2019-12-08 12:38:45
    在总结步骤之前,我想先讲下静态路由和rip动态路由的区别,专业解释是:静态路由是非自适应性路由计算协议,是由管理人员手动配置的,不能够根据网络拓扑的变化而改变。而动态路由是能够根据网络拓扑的变化而自动...
  • 静态路由是指由网络管理员手工配置的路由信息,默认路由是一种特殊的静态路由,本文下面就带来了使用Cisco模拟器进行静态路由和默认路由的配置的教程,希望对大家有所帮助
  • 静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。...
  • 静态路由实验 静态路由(英语:Static routing),一种路由的方式,路由项(routing entry)由手动配置,而非动态决定。与动态路由不同,静态路由是固定的,不会改变,即使网络状况已经改变或是重新被组态。一般来说...
  • 介绍如何配置静态路由以及静态路由配置实例。
  • 静态路由配置是基于相对简单的的网络使用的,如果网络较复杂,则使用起来会很复杂,此时应选择动态路由配置 【实验名称】静态路由配置。 【实验目的】理解静态路由的工作原理,掌握如何配置静态路由。 【背景描述...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 13,826
精华内容 5,530
关键字:

思科静态路由配置