精华内容
下载资源
问答
  • H3C IPv6隧道技术配置,详细描述了配置基于IPv6的NAT地址转换方式
  • Nat地址转换 ACL访问控制 DHCP 三、实验拓扑 四、实验分析 五、实验详细配置 1. LSW1的配置 1.1 划分vlan 将G0/0/1接口划入vlan201,G0/0/2接口划入vlan202 sys Enter system view, return user view with Ctrl+Z
  • NAT地址转换

    2020-05-17 09:42:13
    NAT转换设备(实现NAT功能的网络设备)维护着地址转换表,所有经过NAT转换设备并且需要进行地址转换的报文,都会通过该表做相应转换。 NAT转换设备处于内部网络和外部网络的连接处,常见的有路由器、防火墙等。 私有IP...

    NAT是将IP数据报文报头中的IP地址转换为另-一个IP地址的过程,主要用于实现内部网络(私有IP地址)访问外部网络(公有IP地址)的功能。
    NAT有3种类型:静态NAT、动态地址NAT以及网络地址端口转换NAPT.
    NAT转换设备(实现NAT功能的网络设备)维护着地址转换表,所有经过NAT转换设备并且需要进行地址转换的报文,都会通过该表做相应转换。
    NAT转换设备处于内部网络和外部网络的连接处,常见的有路由器、防火墙等。
    私有IP:
    A:10.0.0.0-10.255.255.255.255
    B:172.16.0.0-172.32.255.255
    C:192.168.0.0-192.168.255.255
    本实验模拟企业网络场景。
    R1是公司的出口网关路由器,公司内员工和服务器都通过交换机S1或S2连接到R1上,R2模拟外网设备与R1直连。由于公司内网都使用私网IP地址,为了实现公司内部分员工可以访问外网,服务器可以供外网用户访问,网络管理员需要在路由器R1上配置NAT:使用静态NAT和NAT Outbound技术使部分员工可以访问外网,使用NAT Server 技术使服务器可以供外网用户访问。

    一.搭建拓扑
    在这里插入图片描述
    二.配置
    A.第一类:一对一的转换
    (1)配置路由器端口IP
    @网关路由器与内网相连的端口配置为私有IP,与外网相连的端口设置成公有IP
    在这里插入图片描述
    @外网路由器配置的是公网IP
    在这里插入图片描述
    (2)为网关路由器配置访问外网默认路由
    ip route-static 0.0.0.0 0 下一跳(外网Ip)
    在这里插入图片描述
    (3)在网关路由器的连接外网的端口上配置一对一的NAT转换
    nat static gloal 外网IP inside 内网IP
    (如将172.16.1.1转换成202.169.10.5)
    在这里插入图片描述
    (4)在172.16.1.1的pc段ping测试与202.169.10.0网段的联通性
    在这里插入图片描述
    B.第二类:多对多的转换
    为私网IP地址172.17.0.0/16网段,用公网地址池202.169.10.50~202.169.10.60为市场部员工做NAT转换。
    @配置NAT outbound
    (nat address-group ID IP IP)
    在这里插入图片描述
    @将NAT结合ACL控制可以换的内网IP
    在这里插入图片描述
    @在于外网相连的端口上配置NAT outbound
    在这里插入图片描述@在172.17.0.0的网段中的任何一台主机测试连通性
    在这里插入图片描述
    C.第三类:多对一
    Easy-IP是NAPT的一种方式,直接借用路由器出接口IP地作为公网地址,将不同的内部地址映射到同一公有地址的不同端口号上,实现多对一地址转换。网络管理员配置网关路由器的GE 0/0/1接口为Easy-IP接口。在网关路由器的GE 0/0/1接口上删除NAT Outbound配置,并使用nat outbound命令配置Easy-IP特性,直接使用接口IP地址作为NAT转换后的地址。
    @在网关路由器的GE 0/0/1接口上删除NAT Outbound配置,并使用nat outbound命令配置Easy-IP特性,直接使用接口IP地址作为NAT转换后的地址。
    在这里插入图片描述
    在172.17.0.0网段的pc上使用UDP发包工具发送UDP数据包到公网地址202. 169.20.1,配置好目的IP和UDP源、目的端口号后,输入字符串数据后单击“发送”按钮
    在这里插入图片描述在网关路由器的用户视图下使用命令
    dis nat session protocol udp verbose查看

    可以观察到,源地址为172.17.1.1 的UDP数据包被新源地址202. 169.10.1和新源端口号10241替换,
    源地址为172.17.1.2的UDP数据包被新源地址202.169.10.1和新源端口号10242替换.
    网关路由器借用自身GE0/0/1接口的公网IP地址为所有私网地址做NAT转换,使用不同的端口号区分不同私网数据。此方式不需要创建地址池,大大节省了地址空间。
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • NAT地址转换实验

    2020-07-31 17:40:22
    由于IP地址有限,又分为私网和公网地址,为了节省IP地址,私网地址可与公网地址重复,但不能出现在公网当中,当需要与公网数据通信时,则出现了一种地址转换技术,即NAT地址转换,通过在路由器上的配置实现。...

    NAT地址转换

    由于IP地址有限,又分为私网和公网地址,为了节省IP地址,私网地址可与公网地址重复,但不能出现在公网当中,当需要与公网数据通信时,则出现了一种地址转换技术,即NAT地址转换,通过在路由器上的配置实现。数据出路由器转换的是源IP地址,数据进路由器转换的是目标IP地址。在这里插入图片描述

    NAT类型

    • 静态NAT:一个私网IP地址对应一个公网IP地址,并未节省IP地址
    • 动态NAT:多个私网IP地址对应多个公网IP地址,并不节省IP地址
    • EasyIP:多个私网IP地址对应外网口公网IP地址,最节省IP地址
    • NAT Server(映射)如下图:
      在这里插入图片描述

    实验拓扑在这里插入图片描述

    PC1采用静态NAT地址转换,在R1上配置,进入外网端口,配置如下:

    [R1-GigabitEthernet0/0/0]nat static global 8.8.8.8 inside 192.168.10.10

    PC2和PC4采用动态NAT地址转换,建立地址池1,在池中获取公网IP,配置如下:

    [R1]nat address-group 1 212.0.0.100 212.0.0.200
    [R1]acl 2000
    [R1-acl-basic-2000]rule permit source 192.168.20.0 0.0.0.255
    [R1-acl-basic-2000]rule permit source 11.0.0.0 0.0.0.255
    [R1-acl-basic-2000]q
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]nat outbound 2000 address-group 1 no-pat

    PC3采用EasyIP,配置如下:

    [R1]acl 3000
    [R1-acl-adv-3000]rule permit ip source 192.168.30.0 0.0.0.255
    [R1-acl-adv-3000]q
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]nat outbound 3000

    服务器上用NAT sever

    [R1-GigabitEthernet0/0/0]nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www

    所有配置如下图所示:

    R1
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 11.0.0.1 24
    [R1-GigabitEthernet0/0/1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 12.0.0.1 24
    [R1-GigabitEthernet0/0/0]q
    [R1]ip route-static 192.168.10.0 24 11.0.0.2
    [R1]ip route-static 192.168.20.0 24 11.0.0.2
    [R1]ip route-static 192.168.30.0 24 11.0.0.2
    [R1]ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
    [R1]int g0/0/0 
    [R1-GigabitEthernet0/0/0]nat st [R1-GigabitEthernet0/0/0]nat static global 8.8.8.8 inside 192.168.10.10
    [R1-GigabitEthernet0/0/0]q
    [R1]nat address-group 1 212.0.0.100 212.0.0.200
    [R1]acl 2000
    [R1-acl-basic-2000]rule p 
    [R1-acl-basic-2000]rule permit s 
    [R1-acl-basic-2000]rule permit source 192.168.20.0 0.0.0.255
    [R1-acl-basic-2000]rule permit source 11.0.0.0 0.0.0.255
    [R1-acl-basic-2000]q
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]nat outbound 2000 address-group 1 no-pat
    [R1-GigabitEthernet0/0/0]q
    [R1]acl 3000
    [R1-acl-adv-3000]rule permit ip source 192.168.30.0 0.0.0.255
    [R1-acl-adv-3000]q
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]nat outbound 3000
    [R1-GigabitEthernet0/0/0]nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www
    
    R2
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.2 24
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 13.0.0.1 24
    [R2-GigabitEthernet0/0/1]q
    [R2]int loop 0
    [R2-LoopBack0]ip add 114.114.114.114 32
    [R2]ip route-static 11.0.0.0 24 12.0.0.1
    [R2]ip route-static 192.168.10.0 24 12.0.0.1
    [R2]ip route-static 192.168.20.0 24 12.0.0.1
    [R2]ip route-static 192.168.30.0 24 12.0.0.1
    [R2]ip route-static 8.8.8.8 32 12.0.0.1
    [R2]ip route-static 9.9.9.9 32 12.0.0.1
    [R2]ip route-static 212.0.0.0 24 12.0.0.1
    
    SW1
    [SW1]int g0/0/1
    [SW1-GigabitEthernet0/0/1]p l a
    [SW1-GigabitEthernet0/0/1]p d v 40
    [SW1-GigabitEthernet0/0/1]int g0/0/2
    [SW1-GigabitEthernet0/0/2]p l a
    [SW1-GigabitEthernet0/0/2]p d v 10
    [SW1-GigabitEthernet0/0/2]int g0/0/3
    [SW1-GigabitEthernet0/0/3]p l a
    [SW1-GigabitEthernet0/0/3]p d v 20
    [SW1-GigabitEthernet0/0/3]int g0/0/4
    [SW1-GigabitEthernet0/0/4]p l a
    [SW1-GigabitEthernet0/0/4]p d v 30
    [SW1-GigabitEthernet0/0/4]int g0/0/5
    [SW1-GigabitEthernet0/0/5]p l a
    [SW1-GigabitEthernet0/0/5]p d v 20
    [SW1-GigabitEthernet0/0/5]int g0/0/6
    [SW1-GigabitEthernet0/0/6]p l a 
    [SW1-GigabitEthernet0/0/6]p de v 10
    [SW1-GigabitEthernet0/0/6]q
    [SW1]int vlanif 10
    [SW1-Vlanif10]ip add 192.168.10.1 24
    [SW1-Vlanif10]int vlanif 20
    [SW1-Vlanif20]ip add 192.168.20.1 24
    [SW1-Vlanif20]int vlanif 30
    [SW1-Vlanif30]ip add 192.168.30.1 24
    [SW1]ip route-static 0.0.0.0 0.0.0.0 11.0.0.1
    [SW1]int vlanif 40
    [SW1-Vlanif40]ip add 11.0.0.2 24
    
    展开全文
  • 理论+实操 :华为NAT地址转换

    千次阅读 2019-12-12 18:24:04
    nat地址转换可以让私有地址转换成公网地址,解决上网问题 华为的三层交换机内不可以配ip地址,需要配vlanif 在企业当中,数据流量业务比较多时,用好一点的路由器 多个私网地址对应外网口ip地址 需要设置acl规则,只...

    前言:
    nat地址转换可以让私有地址转换成公网地址,解决上网问题
    华为的三层交换机内不可以配ip地址,需要配vlanif

    在企业当中,数据流量业务比较多时,用好一点的路由器
    多个私网地址对应外网口ip地址
    需要设置acl规则,只允许某个网段通行,后面跟子网反掩码
    接着到外网口宣告一下,acl的编号即可

    网路地址转换

    一: NAT概述

    1.1 NAT的概念与实现方式

    • 地址转换出现的背景
    • NAT的工作原理
    • network address translation,网路地址转换
    • NAT实现方式
    • 静态转换(static translation)
    • 动态转换(Dynamic translation)
    • 端口多路复用(port address translation, PAT) easyip
      nat地址转换,识别的依据是端口的不同,不然数据返回不知道给谁

    1.2 NAT的术语与转换表

    在这里插入图片描述
    NAT的转换条目
    扩展转换条目

    1.3 NAT实现方法的工作过程

    • 静态转换和动态转换
      在这里插入图片描述

    1.4 NAT的特性

    1.4.1 NAT的优点

    • 节省公有合法IP地址
    • 处理地址重叠
    • 增强灵活性
    • 安全性

    1.4.2 NAT的缺点

    • 延迟增大
    • 配置和维护的复杂性
    • 不支持某些应用,可以通过静态NAT映射来避免

    二:实操:

    在这里插入图片描述

    2.1 基本配置

    LSW1

    The device is running!
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sysname LSW1
    [LSW1]vlan bat 10 20 30 40
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [LSW1]int g 0/0/1
    [LSW1-GigabitEthernet0/0/1]p l a
    [LSW1-GigabitEthernet0/0/1]p d v 10
    [LSW1-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [LSW1-GigabitEthernet0/0/1]int g 0/0/2 
    [LSW1-GigabitEthernet0/0/2]p l a
    [LSW1-GigabitEthernet0/0/2]p d v 20
    [LSW1-GigabitEthernet0/0/2]un sh
    Info: Interface GigabitEthernet0/0/2 is not shutdown.
    [LSW1-GigabitEthernet0/0/2]int g 0/0/3
    [LSW1-GigabitEthernet0/0/3]p l a
    [LSW1-GigabitEthernet0/0/3]p d v 30
    [LSW1-GigabitEthernet0/0/3]un sh
    Info: Interface GigabitEthernet0/0/3 is not shutdown.
    [LSW1-GigabitEthernet0/0/3]int g 0/0/4
    [LSW1-GigabitEthernet0/0/4]p l a
    [LSW1-GigabitEthernet0/0/4]p d v 30
    [LSW1-GigabitEthernet0/0/4]un sh
    Info: Interface GigabitEthernet0/0/4 is not shutdown.
    [LSW1-GigabitEthernet0/0/4]int g 0/0/6
    [LSW1-GigabitEthernet0/0/6]p l a
    [LSW1-GigabitEthernet0/0/6]p d v 10
    [LSW1-GigabitEthernet0/0/6]un sh
    Info: Interface GigabitEthernet0/0/6 is not shutdown.
    [LSW1-GigabitEthernet0/0/6]int g 0/0/5
    [LSW1-GigabitEthernet0/0/5]p l a
    [LSW1-GigabitEthernet0/0/5]p d v 40
    [LSW1-GigabitEthernet0/0/5]un sh
    Info: Interface GigabitEthernet0/0/5 is not shutdown.
    [LSW1-GigabitEthernet0/0/5]q
    [LSW1]dis vlan                                                        
    --------------------------------------------------------------------------------
    1    common  UT:GE0/0/7(D)      GE0/0/8(D)      GE0/0/9(D)      GE0/0/10(D)     
                    GE0/0/11(D)     GE0/0/12(D)     GE0/0/13(D)     GE0/0/14(D)     
                    GE0/0/15(D)     GE0/0/16(D)     GE0/0/17(D)     GE0/0/18(D)     
                    GE0/0/19(D)     GE0/0/20(D)     GE0/0/21(D)     GE0/0/22(D)     
                    GE0/0/23(D)     GE0/0/24(D)                                     
    
    10   common  UT:GE0/0/1(U)      GE0/0/6(U)                                      
    
    20   common  UT:GE0/0/2(U)                                            
    
    30   common  UT:GE0/0/3(U)     GE0/0/4(U)                                                 
    
    40   common  UT:GE0/0/5(U)                                                      
    [LSW1]int vlanif 10
    [LSW1-Vlanif10]ip add 192.168.10.1 24
    [LSW1-Vlanif10]dis this
    #
    interface Vlanif10
     ip address 192.168.10.1 255.255.255.0
    #
    return
    [LSW1-Vlanif10]un sh
    Info: Interface Vlanif10 is not shutdown.
    [LSW1-Vlanif10]int vlanif 20
    [LSW1-Vlanif20]ip add 192.168.20.1 24
    [LSW1-Vlanif20]un sh
    Info: Interface Vlanif20 is not shutdown.
    [LSW1-Vlanif20]int vlanif 30
    [LSW1-Vlanif30]ip add 192.168.30.1 24
    [LSW1-Vlanif30]un sh
    Info: Interface Vlanif30 is not shutdown.
    [LSW1-Vlanif30]int vlanif 40
    [LSW1-Vlanif40]ip add 11.0.0.2 24
    [LSW1-Vlanif40]un sh
    Info: Interface Vlanif40 is not shutdown.
    [LSW1-Vlanif40]q
    [LSW1]dis interface b
    Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
    GigabitEthernet0/0/1        up    up          0%     0%          0          0
    GigabitEthernet0/0/2        up    up          0%     0%          0          0
    GigabitEthernet0/0/3        up    up          0%     0%          0          0
    GigabitEthernet0/0/4        up    up          0%     0%          0          0
    GigabitEthernet0/0/5        up    up          0%     0%          0          0
    GigabitEthernet0/0/6        up    up          0%     0%          0          0
    Vlanif10                    up    up          --     --          0          0
    Vlanif20                    up    up          --     --          0          0
    Vlanif30                    up    up          --     --          0          0
    Vlanif40                    up    up          --     --          0          0
    [LSW1]dis ip routing-table 
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           11.0.0.0/24  Direct  0    0           D   11.0.0.2        Vlanif40
           11.0.0.2/32  Direct  0    0           D   127.0.0.1       Vlanif40
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
       192.168.10.0/24  Direct  0    0           D   192.168.10.1    Vlanif10
       192.168.10.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
       192.168.20.0/24  Direct  0    0           D   192.168.20.1    Vlanif20
       192.168.20.1/32  Direct  0    0           D   127.0.0.1       Vlanif20
       192.168.30.0/24  Direct  0    0           D   192.168.30.1    Vlanif30
       192.168.30.1/32  Direct  0    0           D   127.0.0.1       Vlanif30	
    [LSW1]ip route-static 0.0.0.0 0.0.0.0 11.0.0.1
    

    R2配置

    The device is running!
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sysname R2
    [R2]int g 0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.2 24
    [R2-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R2-GigabitEthernet0/0/0]int g 0/0/1
    [R2-GigabitEthernet0/0/1]ip add 13.0.0.1 24
    [R2-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R2-GigabitEthernet0/0/1]q
    [R2]int LoopBack 0
    [R2-LoopBack0]ip add 114.114.114.114 32
    [R2-LoopBack0]q
    [R2]dis ip routing-table 
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           12.0.0.0/24  Direct  0    0           D   12.0.0.2        GigabitEthernet
    0/0/0
           12.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
         12.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           13.0.0.0/24  Direct  0    0           D   13.0.0.1        GigabitEthernet
    0/0/1
           13.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
         13.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
    114.114.114.114/32  Direct  0    0           D   127.0.0.1       LoopBack0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    [R2]ip route-static 8.8.8.8 32 12.0.0.1
    
    

    2.2 NAT router 配置,先配置第一种的静态nat转换,全局模式下配置,接口开启功能

    The device is running!
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sysname NAT router
    [NAT router]int g 0/0/0 
    [NAT router-GigabitEthernet0/0/0]ip add 11.0.0.1 24
    [NAT router-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [NAT router-GigabitEthernet0/0/0]int g 0/0/1 
    [NAT router-GigabitEthernet0/0/1]ip add 12.0.0.1 24
    [NAT router-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [NAT router-GigabitEthernet0/0/1]q	
    [NAT router]nat static global 8.8.8.8 inside 192.168.10.10
    [NAT router]ip route-static 192.168.0.0 16 11.0.0.2
    [NAT router]int g 0/0/1
    [NAT router-GigabitEthernet0/0/1]nat static enable 
    [NAT router-GigabitEthernet0/0/1]q
    [NAT router]ip route-static 114.114.114.114 32 12.0.0.2
    
    

    测试192.168.10.10 去ping lo 0 114.114.114.114 ,在R2的g0/0/0处抓包
    在这里插入图片描述

    2.3 配置静态NAT的第二种配法,在接口内配置

    [NAT router]nat static global 9.9.9.9 inside 192.168.20.10
    [NAT router]int g 0/0/1
    [NAT router-GigabitEthernet0/0/1]nat static global 9.9.9.9 inside 192.168.20.10
      Info: The NAT in the network has existed.
      Already existing configuration will be covered with current configure. [Y/N]: 
    y
    [NAT router-GigabitEthernet0/0/1]
    

    R2配置回程路由

    [R2]ip route-static 9.9.9.9 32 12.0.0.1
    

    192.168.20.10 去ping 114.114.114.114
    在这里插入图片描述

    2.4 设置动态nat地址转换,即多对多的模式,

    在全局模式下把两个网段(公网和私网)宣告,
    私网是acl ,
    公网是address-group ,
    然后在公网接口 处宣告两者之间的关系

    [NAT router]dis ip routing-table 
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            8.8.8.8/32  Unr     64   0           D   127.0.0.1       InLoopBack0
            9.9.9.9/32  Unr     64   0           D   127.0.0.1       InLoopBack0
           11.0.0.0/24  Direct  0    0           D   11.0.0.1        GigabitEthernet
    0/0/0
           11.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
         11.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           12.0.0.0/24  Direct  0    0           D   12.0.0.1        GigabitEthernet
    0/0/1
           12.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
         12.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
    114.114.114.114/32  Static  60   0          RD   12.0.0.2        GigabitEthernet
    0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.0.0/16  Static  60   0          RD   11.0.0.2        GigabitEthernet
    0/0/0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    [NAT router]ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
    <NAT router>system-view 
    Enter system view, return user view with Ctrl+Z.
    [NAT router]nat address-group 1 212.0.0.100 212.0.0.200
    [NAT router]acl 2000
    [NAT router-acl-basic-2000]rule permit source 192.168.30.0 0.0.0.255
    [NAT router-acl-basic-2000]q
    [NAT router]int g 0/0/1
    [NAT router-GigabitEthernet0/0/1]nat outbound 2000 address-group 1 no-pat
    [NAT router-GigabitEthernet0/0/1]
    

    与此对应的,增加R2的回程路由

    [R2]ip route-static 212.0.0.0 24 12.0.0.1
    

    从抓包数据可以观察到,源ip一直在变
    在这里插入图片描述

    2.5 配置nat模式中多个私网地址对应一个公网地址

    思路跟动态nat思路大致相同,
    全局模式下宣告私网地址网段,acl,要注意的是这种nat命令跟动态nat命令的不同之处在有一个ip 字符
    然后在公网接口处指定关系,因为没有指定的公网网段,不填
    因为环境中pc没有富裕的,需要把之前的部分配置删掉,以免冲突

    <NAT router>system-view 
    Enter system view, return user view with Ctrl+Z.
    [NAT router]acl 3000 
    [NAT router-acl-adv-3000]rule permit ip source 192.168.30.0 0.0.0.255
    [NAT router-acl-adv-3000]q
    [NAT router]int g 0/0/1
    [NAT router-GigabitEthernet0/0/1]nat outbound 3000
    [NAT router-GigabitEthernet0/0/1]dis this
    [V200R003C00]
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.0 
     nat static global 9.9.9.9 inside 192.168.20.10 netmask 255.255.255.255
     nat outbound 2000 address-group 1 no-pat
     nat outbound 3000
     nat static enable
    #
    return
    [NAT router-GigabitEthernet0/0/1]undo  nat outbound 2000 address-group 1 no-pat
    [NAT router-GigabitEthernet0/0/1]undo nat static global 9.9.9.9 inside 192.168.2
    0.10 netmask 255.255.255.255
    [NAT router-GigabitEthernet0/0/1]q
    [NAT router]
    

    在这里插入图片描述

    展开全文
  • 华为——NAT地址转换

    千次阅读 2019-12-12 19:25:44
    NAT的术语与转换NAT包含4类地址 NAT转换条目 简单转换条目 扩展转换条目 静态转换和动态转换 ...下面我们来操作以下NAT地址转换的实验,拓扑如下: SW1配置: ######划分vlan [SW1]vla...

    NAT的术语与转换表

    • NAT包含4类地址

    在这里插入图片描述

    NAT的转换条目

    • 简单转换条目
    • 扩展转换条目

    静态转换和动态转换

    在这里插入图片描述

    NAT的特性

    优点:

    • 节省公有合法IP地址
    • 处理地址重叠
    • 增强灵活性
    • 安全性

    缺点:

    • 延迟增大
    • 配置和维护的复杂性
    • 不支持某些应用,可以通过静态NAT映射来避免

    下面我们来操作以下NAT地址转换的实验,拓扑如下:
    在这里插入图片描述

    SW1配置:

    ######划分vlan
    [SW1]vlan bat 10 20 30 40                 //创建vlan
    [SW1]int g0/0/1
    [SW1-GigabitEthernet0/0/1]port link-type access
    [SW1-GigabitEthernet0/0/1]port default vlan 10
    [SW1-GigabitEthernet0/0/1]un sh
    [SW1-GigabitEthernet0/0/1]int g0/0/2
    [SW1-GigabitEthernet0/0/2]port link-type access
    [SW1-GigabitEthernet0/0/2]port default vlan 20
    [SW1-GigabitEthernet0/0/2]un sh
    [SW1-GigabitEthernet0/0/2]int g0/0/3
    [SW1-GigabitEthernet0/0/3]port link-type access
    [SW1-GigabitEthernet0/0/3]port default vlan 30
    [SW1-GigabitEthernet0/0/3]un sh
    [SW1-GigabitEthernet0/0/3]int g0/0/4
    [SW1-GigabitEthernet0/0/4]port link-type access
    [SW1-GigabitEthernet0/0/4]port default vlan 20
    [SW1-GigabitEthernet0/0/4]un sh
    [SW1-GigabitEthernet0/0/4]int g0/0/5
    [SW1-GigabitEthernet0/0/5]port link-type access
    [SW1-GigabitEthernet0/0/5]port default vlan 40
    [SW1-GigabitEthernet0/0/5]un sh
    
    ######配置vlanif,网关
    [SW1-GigabitEthernet0/0/6]int vlanif 10	
    [SW1-Vlanif10]ip add 192.168.10.1 24
    [SW1-Vlanif10]int vlanif 20
    [SW1-Vlanif20]ip add 192.168.20.1 24
    [SW1-Vlanif20]int vlanif 30
    [SW1-Vlanif30]ip add 192.168.30.1 24
    [SW1-Vlanif30]int vlanif 40
    [SW1-Vlanif40]ip add 11.0.0.2 24
    
    ######配置默认路由出去
    [SW1]ip route-static 0.0.0.0 0.0.0.0 11.0.0.1
    

    R1配置:

    ######配置端口地址
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 11.0.0.1 24 
    [R1-GigabitEthernet0/0/0]un sh
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 12.0.0.1 24
    [R1-GigabitEthernet0/0/1]un sh
    [R1-GigabitEthernet0/0/1]q
    
    ######配置静态路由回程
    [R1]ip route-static 192.168.10.0 255.255.255.0 11.0.0.2
    [R1]ip route-static 192.168.20.0 255.255.255.0 11.0.0.2
    [R1]ip route-static 192.168.30.0 255.255.255.0 11.0.0.2
    
    ######静态NAT:一个私网IP地址对应一个公网IP地址
    [R1]nat static global 8.8.8.8 inside 192.168.10.10      //全局模式下
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]nat static enable    //在外网接口上启动nat static功能
    
    ######配置默认路由出去
    [R1]ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
    
    ######配置回环接口的静态路由
    ip route-static 114.114.114.114 255.255.255.255 12.0.0.2
    
    #######动态NAT:多个私网IP地址对应多个公网IP地址   
    [R1]nat address-group 1 212.0.0.100 212.0.0.200          //新建为1的nat地址池
    [R1]acl 2000                                            // ac1编号
    [R1-acl-basic-2000]rule permit source 192.168.20.0 0.0.0.255    //建立规则,20网段,反掩码
    [R1-acl-basic-2000]int g0/0/1                                //进入外网接口
    [R1-GigabitEthernet0/0/1]nat outbound 2000 address-group 1 no-pat 
    
    ######EasyIp:多个私网IP地址对应外网口公网IP地址(12.0.0.1)
    [R1]acl 3000	
    [R1-acl-adv-3000]rule permit ip source 192.168.30.0 0.0.0.255
    [R1-acl-basic-2000]int g0/0/1                                //进入外网接口
    [R1-GigabitEthernet0/0/1]nat outbound 3000
    
    

    R2配置

    ######配置端口地址
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.2 24
    [R2-GigabitEthernet0/0/0]un sh
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 13.0.0.1 24
    [R2-GigabitEthernet0/0/1]un sh
    [R2]int lo	
    [R2]int LoopBack 0
    [R2-LoopBack0]ip add 114.114.114.114 32
    [R2-LoopBack0]q
    
    ######配置静态路由回程
    [R2]ip route-static 8.8.8.8 255.255.255.255 12.0.0.1
    [R2]ip route-static 212.0.0.0 255.255.255.255 12.0.0.1
    

    实验验证Nat转换:
    在这里插入图片描述
    在这里插入图片描述

    在这里插入图片描述

    展开全文
  • 破解版-sygate NAT地址转换工具.rar 破解版-sygate NAT地址转换工具.rar
  • NAT地址转换配置

    千次阅读 2019-03-06 22:25:18
    1、静态NAT地址转换 举例: 实验: 不通 下面部署动态路由协议 gw和msn的接线的两个接口的ip地址的掩码不一致,导致ospf邻居关系起不来 发现邻居关系起来了 ...
  • 1、静态NAT地址转换 eNSP中拓扑: sw1配置 <Huawei>sys [Huawei]sysname SW1 [SW1]vlan batch 10 20 30 40 Info: This operation may take a few seconds. Please wait for a moment...done. [SW1]int v...
  • NAT 地址转换

    千次阅读 2017-10-10 21:53:15
    NAT功能 NAT不仅能解决了lP地址不足的问题,而且还能够有效地避免来自网络外部的攻击,隐藏并保护网络内部的计算机。1.宽带分享:这是 NAT 主机的最大功能。解决IP4地址短缺的问题。2.安全防护:NAT 之内的 PC 联机...
  • 静态NAT地址转换示例

    2019-10-17 11:38:58
    1.路由器(R2):给对应端口配对应IP地址,并配置默认路由 2.路由器(R1):给对应端口配对应IP地址,并配置默认路由 3.交换机(sw):配双工和速率 4.给各个PC机配对应IP地址 (1)PC1 PC1> ip 192....
  • NAT地址转换的配置
  • VPN是隐藏IP去访问其他的网络 NAT地址转换 NAT是基于网络层的应用 **NAT地址转换:**是把私网IP映射到公网IP上,每个内网地址占用一个端口。 网络地址转换,就是将一个或多个ip地址转换为另一个ip地址或多个ip地址。...
  • NAT的工作原理 Network Address Translation 网络地址转换 NAT实现方式 静态转换(Static Translation) 动态转换(Dynamic Translation) 端口多路复用(Port Address Translation,PAT) NAT的优点 节省...
  • NAT地址转换常用命令详解

    万次阅读 2017-11-22 11:55:13
    说明:静态NAT主要用于那些对需要对外部用户开放的服务,如Web服务器等,它可以把本地地址映射为指定的全局地址。 第一种格式实现的是一对一的NAT映射。第二种格式可实现一对多的映射,即一个全局地址可映射多个...
  • 华为Router 动态NAT地址转换配置

    万次阅读 多人点赞 2018-06-19 11:01:13
    一、组网需求:某公司A部门和B部门的私网用户和...A部门允许使用公网IP地址比较多(202.169.10.100~202.169.10.200),所以使用no-pat转换方式(只转换数据包的IP地址,并不使用端口号)的NAT方式替换A部门内部的主...
  • 动态NAT地址转换配置实验(中兴)

    千次阅读 2020-06-12 23:24:57
    动态NAT地址转换配置实验一、实验目的二、实验内容三、实验流程四、查看和验证五、实验总结 一、实验目的 1.掌握中兴动态NAT技术的基本原理和作用,及其数据的转发过程; 2.掌握动态NAT技术的基本原理和作用; 二、...
  • Demo1:静态NAT地址转换 eNSP中拓扑: SW1: <Huawei>sys [Huawei]sysname SW1 [SW1]vlan batch 10 20 30 40 Info: This operation may take a few seconds. Please wait for a moment...done. [SW1]int ...
  • 2.通过配置NAT转换(EASY IP)使办公网client2与公网client1进行通信,抓包观察现象。 3.现公司内部申请多了一个公网地址1.1.1.10,通过配置NAT Server使得公网client1能与生产服务器建立ftp服务,抓包观察现象。 ...
  • NAT地址转换的配置.pdf

    2021-10-01 20:24:06
    NAT地址转换的配置.pdf
  • NAT:网络地址转换 (cisco篇) 在一台路由器上对进或出流量进行ip地址的修改;常用规则为从内部去往外部时修改源ip地址;从外部进入内部时修改目标ip地址; 静态nat地址间的映射关系为固定; 动态nat,临时地址...
  • Cisco 静态NAT地址转换

    千次阅读 2018-12-06 11:01:13
    实验环境:用10.0.0.0/8用作内网网段,运营商地址为61.159.62.129,R2为运营商路由 实验目的:互联网可以以192....在R1上设置静态地址转换,分别在外网口设置outside和在内网口设置inside R2为互联网路由,测试pi...
  • nat地址转换[参照].pdf

    2021-10-11 04:57:36
    nat地址转换[参照].pdf
  • NAT 地址转换进阶.rar

    2019-07-09 08:43:10
    处理............ 12 3.4 NAT转换可能无法应用于加密的IP报文................1.3 NAT转换地址类型................... 4 1.2 NAT转换的类型.................... . 2 1.1 NAT转换的应用需求................... 1
  • 静态NAT地址转换配置实验一、实验目的二、实验内容三、实验流程四、查看和验证五、实验总结 一、实验目的 1.掌握中兴1800路由器的静态NAT技术的配置方法和结果查看; 2.掌握静态NAT技术的基本原理和作用; 二、实验...
  • NAT(地址转换技术) 将私有地址转换成公有地址 私有地址满足企业用户在Intranet上使用的需求 私有地址不能在Internet上使用 私有地址包括3组 10.0.0.0~10.255.255.255 172.16.0.0~172.31.255.255 192....

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 63,300
精华内容 25,320
关键字:

nat地址转换