精华内容
下载资源
问答
  • 这是三层交换机跨Vlan通信实验的Cisco Packet Tracer文件。实验包括有两个vlan,两个二层交换机,一个三层交换机。
  • 三层交换机S1的配置: 二层交换机S2的配置: 二层交换机S3的配置: “ip routing”配置命令开启三层交换机的IP路由; VLAN能将不同网段的广播隔离开; 二层交换机无法实现不同VLAN间的路由功能; 三层交换机的...

    目录

    三层交换机S1的配置:

    二层交换机S2的配置:

    二层交换机S3的配置:


    1. “ip routing”配置命令开启三层交换机的IP路由;
    2. VLAN能将不同网段的广播隔离开;
    3. 二层交换机无法实现不同VLAN间的路由功能;
    4. 三层交换机的功能 = 二层交换机的功能 + 路由器的功能;
    5. 在VLAN端口配置IP,将GW指向相应VLAN的SVI地址可实现不同VLAN间的通信。
    6. 交换虚拟端口(SVI, Switch Virtual Interface):虚拟的路由器与每个VLAN进行连接的端口。 

    三层交换机S1的配置:

    //配置三层接口之前,首先创建VLAN及端口分配
    S1(config)#VLAN 2 //创建vlan2
    S1(config-vlan)#exit
    
    S1(config)#interface fa0/1 //进入端口配置模式
    S1(config-if)#switchport trunk encapsulation dot1q //配置Trunk封装为802.1q协议
    S1(config-if)#switchport mode trunk //设置为主干道trunk模式
    
    S1(config)#interface fa0/2
    S1(config-if)#switchport trunk encapsulation dot1q //配置Trunk封装为802.1q协议
    S1(config-if)#switchport mode trunk //设置为主干道trunk模式
    
    S1(config)#interface vlan 1 
    S1(config-if)#ip address 192.168.1.1 255.255.255.0 //在VLAN端口配置网关IP地址
    S1(config-if)#no shutdown //开启端口 
    
    S1(config)#interface vlan 2
    S1(config-if)#ip address 192.168.2.1 255.255.255.0 //在VLAN端口配置网关IP地址
    S1(config-if)#no shutdown //开启端口
    S1(config-if)#exit
    
    S1(config)#ip routing //开启三层交换机的IP路由功能

    二层交换机S2的配置:

    S2(config)#vlan 2 //在全局配置模式下创建VLAN
    S2(config-vlan)#exit
    
    S2(config)#interface fa0/1 //进入端口配置模式
    S2(config-if)#switchport mode trunk //端口配置为Trunk模式用来进行交换机互联,可允许多个VLAN通信
    
    S2(config-if)#interface fa0/2 //进入端口配置模式
    S2(config-if)#switchport access vlan 1 //将端口分配到vlan 1
    
    S2(config-if)#interface fa0/3
    S2(config-if)#switchport access vlan 2 //将交换机端口分配到vlan2

    二层交换机S3的配置:

    S3(config)#vlan 2
    S3(config-vlan)#exit
    
    S3(config)#interface fa0/1
    S3(config-if)#switchport mode trunk
    
    S3(config-if)#interface fa0/2
    S3(config-if)#switchport access vlan 2
    
    S3(config-if)#interface fa0/3
    S3(config-if)#switchport access vlan 1

     

    展开全文
  • 关于vlan间的通信,如何实现不同vlan通信互访?案例要求:若企业中有2个部门:销售部和技术部(2个...在本实验中,我们将PC1和PC3分别连接到SwitchA(三层交换机)的F0/5端口和SwitchB的F0/5端口并划入VLAN 10,将PC2...

    关于vlan间的通信,如何实现不同vlan的通信互访?

    案例要求:

    若企业中有2个部门:销售部和技术部(2个部门PC机IP地址在不同网段),其中销售部的PC机分散连接在2台交换机上,配置交换机使得销售部PC能够实现相互通信,而且销售部和技术部之间也能相互通信。

    在本实验中,我们将PC1和PC3分别连接到SwitchA(三层交换机)的F0/5端口和SwitchB的F0/5端口并划入VLAN 10,将PC2连接到SwitchA(三层交换机)的F0/15端口并划入VLAN 20,SwitchA和SwitchB之间通过各自的F0/24端口连接。配置三层交换机使在不同VLAN组中的PC1、PC2、PC3能相互通信。

    拓扑图

    S3550-24(三层交换机)1台、S2126交换机1台、PC机3台。

    9666b01534d2bbf0abc846e796faf127.png

    VLAN间通信实验拓扑结构图

    配置步骤

    1.按实验拓扑连接设备,并按图中所示配置PC机的IP地址,PC1、PC3网段相同可以通信,但是PC1、PC3和PC2是不同网段的,所以PC2(技术部)不能和另外2台PC机(销售部)通信。

    2.在交换机SwitchA上创建VLAN 10,并将0/5端口划入VLAN 10中。

    SwitchA(config)#vlan 10 !创建VLAN 10

    SwitchA (config-vlan)#name sales !将VLAN 10命名为sales

    SwitchA (config)#interface f0/5 !进入F0/5接口配置模式

    SwitchA (config-if)#switchport access vlan10 !将F0/5端口划入VLAN 10

    SwitchA #show vlan id 10 !验证已创建了VLAN 10并已将F0/5端口划入VLAN 10中。

    代码小结:

    创建vlan为10将vlan10命名为sales(销售部)划分的端口为F0/5

    3.在交换机SwitchA上创建VLAN 20,并将F0/15口划分到VLAN 20中。

    SwitchA(config)#vlan20 !创建VLAN 20

    SwitchA(config-vlan)#name technical !将VLAN 20命名为technical

    SwitchA(config)#interface f0/15 !进入F0/15接口配置模式

    SwitchA(config-if)#switchport access vlan 20 !将F0/15端口划入VLAN 20

    SwitchA #showvlan id 20 !验证已创建了VLAN 20并已将F0/15端口划入VLAN 20中。

    代码小结:

    创建vlan为20将vlan10命名为technical(技术部)划分的端口为F0/15

    4.在交换机SwitchA上与SwitchB相连的端口(此处为F0/24端口)定义为tag vlan 模式。

    SwitchA (config)#interface f0/24 !进入接口配置模式

    SwitchA (config-if)#switchport mode trunk !将F0/24口设置为tag vlan模式

    SwitchA (config)#show interfaces f0/24 switch !验证F0/24口已被设置为tag vlan模式

    5.在交换机SwitchB上创建VLAN 10,并将F0/5端口划入VLAN 10中。

    SwitchB(config)#vlan 10 !创建VLAN 10

    SwitchB (config-vlan)#name sales ! 将VLAN 10 命名为sales

    SwitchB (config)#interface f0/5 !进入F0/5接口配置模式

    SwitchB (config-if)#switchport access vlan10 !将F0/5端口划入VLAN 10

    SwitchB #show vlan id 10 !验证已创建了VLAN 10并已将F0/5端口划入VLAN 10中

    6.在交换机SwitchB上与SwitchA相连的端口(此处为F0/24端口)定义为tag vlan 模式。

    SwitchB (config)#interface f0/24 !进入接口配置模式

    SwitchB (config-if)#switchport mode trunk !将F0/24口设置为tag vlan模式

    SwitchB (config)#show interfaces f0/24 switch !验证F0/24口已被设置为tag vlan模式。

    7.设置三层交换机VLAN 间通讯

    开启三层交换机的路由功能

    SwitchA>enable

    SwitchA#configure terminal

    SwitchA(config)#ip routing !开启三层交换机的路由功能

    SwitchA(config) #interface vlan 10 ! 创建虚拟接口vlan10

    SwitchA(config-if) #ip address 192.168.10.254 255.255.255.0 ! 配置vlan10的虚拟接口ip地址

    SwitchA(config) #interface vlan 20 !创建虚拟接口vlan20! 配置vlan20的虚拟接口ip地址

    SwitchA(config-if) #ip address 192.168.20.254 255.255.255.0 ! 配置vlan20的虚拟接口ip地址

    8.将PC1和PC3的默认网关设置为192.168.10.254,将PC2的默认网关设置为192.168.20.254

    9.验证PC1、PC2与PC3能相互ping通。

    C: >ping 192.168.20.1 !从PC1上ping PC2

    C: >ping 192.168.20.1 !从PC3上ping PC2

    C:>ping 192.168.10.2 !从PC2上ping PC3

    附:三层交换机基本配置:

    1.开启三层交换机的路由功能

    SwitchA>enable

    SwitchA#configure terminal

    SwitchA(config)#ip routing !开启三层交换机的路由功能

    2.配置三层交换机端口的路由功能

    SwitchA(config)# interface fastethernet0/5

    SwitchA(config-if)#noswitchport !开启端口的三层路由功能

    SwitchA(config-if)#ip address 192.168.1.5255.255.255.0 !给端口配置ip地址

    SwitchA(config-if)#no shutdown

    SwitchA(config-if)#end

    3.验证,测试配置

    SwitchA#show ip interface !查看接口状态信息

    (Operstatus 状态是up)

    SwitchA#show interface f0/5 !查看接口状态信息(Adminstatus状态是up)

    展开全文
  • 三层交换机实现VLAN通信

    千次阅读 2019-03-28 11:40:48
    原理简述: 交换机实现VLAN通信的方式:(1)单臂路由;(2)三层交换机。 (1)然而利用单臂路由实现VLAN间主机的访问,存在一些局限:如带宽、转发效率这些问题...通过VLANIF接口,三层交换机可以实现路由转...

    原理简述:

    跨交换机实现VLAN间通信的方式:(1)单臂路由;(2)三层交换机。

    (1)然而利用单臂路由实现VLAN间主机的访问,存在一些局限:如带宽、转发效率这些问题。

    (2)三层交换机在原有二层交换机的基础上增加了路由功能,而且数据也没有想单臂路由那样进过物理线路进行路由。

    (3)VLANIF接口:基于网络层的接口,可以进行IP地址的配置。通过VLANIF接口,三层交换机可以实现路由转发功能。

    实验内容:

    通过配置三层交换机实现所有的主机之间都能互相访问。

    实验目的:

    (1)掌握配置VLANIF接口的方法;

    (2)理解数据包跨VLAN路由的原理;

    (3)掌握测试多层交换机网络连通性的方法。

    实验拓扑:

    实验步骤:

    1.基础配置:根据实验要求,完成PC机上相应的配置,如:IP地址的配置。测试一下PC-1与PC-2和PC-3的连通性。

    PC>ping 192.168.1.2
    
    Ping 192.168.1.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.1.2: bytes=32 seq=1 ttl=128 time=47 ms
    From 192.168.1.2: bytes=32 seq=2 ttl=128 time=47 ms
    From 192.168.1.2: bytes=32 seq=3 ttl=128 time=47 ms
    From 192.168.1.2: bytes=32 seq=4 ttl=128 time=47 ms
    From 192.168.1.2: bytes=32 seq=5 ttl=128 time=47 ms
    
    --- 192.168.1.2 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 47/47/47 ms
    
    PC>ping 192.168.2.1     //PC-1与PC-3之间不能通信    原因:未在交换机上做任何的配置,故没有设备应答PC-1发出的ARP请求数据包,无法正常封装和转发。
    
    Ping 192.168.2.1: 32 data bytes, Press Ctrl_C to break
    From 192.168.1.1: Destination host unreachable
    From 192.168.1.1: Destination host unreachable
    From 192.168.1.1: Destination host unreachable
    From 192.168.1.1: Destination host unreachable
    From 192.168.1.1: Destination host unreachable
    
    --- 192.168.1.254 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    数据包转发过程:

    主机发出数据包之前,将查看数据包中的目的IP地址,如果目的IP地址和本机的IP地址在同一网段上,主机会直接发出一个ARP请求数据包来请求对方主机的MAC地址,然后封装数据包,继而发送这个数据包。如果目的IP地址与本机的IP地址不在同一个网段上,主机会发送一个ARP请求数据包来请求网关的MAC地址,在收到网关的MAC地址恢复后,才封装数据包发送出去。

    2.三层交换机的配置:通过在交换机上配置不同的VLAN实现主机间的相互隔离。

    使用interface VLANif命令创建VLANIF接口,并指定接口对应的VLAN ID。在该接口的视图下,可配置其IP地址。

    [S1]int Vlanif 10
    [S1-Vlanif10]ip ad 192.168.1.254 24
    [S1]int Vlanif 20
    [S1-Vlanif20]ip ad 192.168.2.254 24

    配置完后,查看接口状态。

    [S1]dis ip int brief 
    *down: administratively down
    ^down: standby
    (l): loopback
    (s): spoofing
    The number of interface that is UP in Physical is 3
    The number of interface that is DOWN in Physical is 2
    The number of interface that is UP in Protocol is 3
    The number of interface that is DOWN in Protocol is 2
    
    Interface                         IP Address/Mask      Physical   Protocol  
    MEth0/0/1                         unassigned           down       down      
    NULL0                             unassigned           up         up(s)     
    Vlanif1                           unassigned           down       down      
    Vlanif10                          192.168.1.254/24     up         up        
    Vlanif20                          192.168.2.254/24     up         up        
    

    观察:两个VLANif接口已经生成并生效。

    测试PC-1与PC-3间的连通性。

    PC>ping 192.168.2.1
    
    Ping 192.168.2.1: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.1: bytes=32 seq=1 ttl=127 time=78 ms
    From 192.168.2.1: bytes=32 seq=2 ttl=127 time=31 ms
    From 192.168.2.1: bytes=32 seq=3 ttl=127 time=47 ms
    From 192.168.2.1: bytes=32 seq=4 ttl=127 time=31 ms
    From 192.168.2.1: bytes=32 seq=5 ttl=127 time=47 ms
    
    --- 192.168.2.1 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 31/46/78 ms
    

    可在PC-1上查看ARP的信息。使用arp -a命令。

    PC>arp -a
    
    Internet Address    Physical Address    Type
    192.168.1.254       4C-1F-CC-3C-27-81   dynamic
    
    //只有交换机VLANif 10的地址,没有对端的地址。即先发送给网关(VLANif),由VLANif接口发送至对端。
    

     

    展开全文
  • 三层交换机的配置 Switch>en Switch#conf t Switch(config)#VLAN 2 Switch(config-vlan)#exit Switch(config)#int f0/2 Switch(config-if)#switchport trunk encapsulation dot1q //配置Trunk封装为802.1q...
    1. 三层交换机的配置
      Switch>en
      Switch#conf t
      
      Switch(config)#VLAN 2
      Switch(config-vlan)#exit
      
      Switch(config)#int f0/2
      Switch(config-if)#switchport trunk encapsulation dot1q //配置Trunk封装为802.1q协议
      Switch(config-if)#switchport mode trunk //设置为主干道trunk模式
      Switch(config-if)#exit
      
      Switch(config)#int vlan 2
      Switch(config-if)#ip address 192.168.1.1 255.255.255.0在VLAN //端口配置网关IP地址
      Switch(config-if)#no shutdown //开启端口
      
      Switch(config-if)#VLAN 3
      Switch(config-vlan)#exit
      
      Switch(config)#int vlan 3
      Switch(config-if)#ip address 192.168.2.1 255.255.255.0
      Switch(config-if)#no shutdown
      Switch(config-if)#exit
      
      Switch(config)#VLAN 4
      Switch(config-vlan)#exit
      
      Switch(config)#int vlan 4
      Switch(config-if)#ip address 192.168.3.1 255.255.255.0
      Switch(config-if)#exit
      Switch(config)#int vlan 4
      Switch(config-if)#no shutdown
      Switch(config-if)#exit
      
      Switch(config)#ip routing //开启三层交换机的路由功能

       

    2. 二层交换机的配置
      S2(config)#vlan 2 //在全局配置模式下创建VLAN
      S2(config-vlan)#exit
      
      S2(config)#interface fa0/1 //进入端口配置模式
      S2(config-if)#switchport mode trunk //端口配置为Trunk模式用来进行交换机互联,可允许多个VLAN通信
      
      S2(config-if)#interface fa0/2 //进入端口配置模式
      S2(config-if)#switchport access vlan 2 //将端口分配到vlan 1
      

       

    展开全文
  • server0和server1配置为vlan40,给各自vlan设置网关,实现三层交换机交换机vlan通信,为求方便,我们先用到vtp,设置vtp域为qqq 首先给各个pc机和服务器设置好IP地址 先配置三层交换机sw...
  • (抓包)三层交换机跨网段通信

    千次阅读 2020-05-15 17:10:27
    三层交换机跨通信-全网互通 实验拓扑图 实验环境 win10 、ensp 实验描述 二层交换之间同网段实现通信三层交换机跨网段通信。 最终实现全网通。 实验步骤 步骤一:根据实验拓扑图,设置PC1、PC2、PC3、PC4的手配...
  • 实现功能 使在同一VLAN里的计算机系统能跨交换机进行相互通信,而在不同VLAN里的计算机系统也能相互通信。 实验设备 锐捷S3550交换机2台(或锐捷S3550交换机1台和锐捷S2126交换机1台),网线4根。
  • 计算机网络实验报告:包含拓扑图的详细配置,以及实现原理分析。 计算机网络实验报告:包含拓扑图的详细配置,以及实现原理分析。
  • 利用三层交换机实现VLAN 间路由 原理概述 VLAN 将一个物理的LAN 在逻辑上划分成多个广播域。VLAN 内的主机间可以直接通信,而VLAN 间不能直接互通。 在现实网络中,经常会遇到需要跨VLAN 相互访问的情况, 工程师...
  • (1)同一交换机,不同网段,不同vlan三层交换机) (2)同一交换机,不同网段,不同vlan(单臂路由) (3)两台交换机,不同网段,不同vlan三层交换机) (4)两台交换机,不同网段,不同vlan(单臂路由) ...
  • 因此可以简化为一个三层交换机和两个pc连接。再简化就可以看作一个路由器和两个pc。 实验目标: 网络可以跨越不同的vlan进行通信。即pc7ping到pc10.又可以在同一个vlan下进行通信。而在同一个vlan下。可以不用通过...
  • 实验涉及命令以及知识补充(涉及Vlan通过的以太网口需要设置为Trunk口) 单臂路由 父接口 no ip address ;删除实现单臂路由接口的IP no shutdown 虚拟子接口 R2(config)#int f0/0.10 ; 进入虚拟子接口 R2(config...
  • 原理概述 ...三层交换机在原有二层交换机基础上增加了路由功能,同时由于数据没有像单臂路由那样经过物理线路进行路由,很好地解决了带宽瓶颈的问题,为网络设计提供了一个灵活的方案。 VLANIF接口
  • 通过三层交换机实现不同VLAN间互相通信 功能描述:为了隔离广播域而划分了VLAN,但不同的VLAN之间需要通信,即同一VLAN里的计算机能交换机通信,不同VLAN里的计算机系统也能互相通信。 技术原理:在交换网络中,...
  • 一 组网需求: 1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访; 2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口1...
  • 原理概述: VLAN将一个物理的LAN在...三层交换机在原有二层交换机的基础之上增加了路由功能,同时曲丁数据没有像单臂路由那样经过物理线路进行路由,很好地解决了带宽瓶颈的问题,为网络设计提供了一个灵活的解决方.
  • 我们在实际生活中经常要跨vlan进行通信,我们的解决办法有单臂路由,但是单臂路由存在很大的局限性,带宽,转发效率等,所以单臂路由用的就有点少,所以就有了本章节三层交换机在原有的二层交换机的基础上,增加了...
  • 利用三层交换机实现不同vlan通信

    千次阅读 2014-07-31 19:28:15
    利用三层交换机实现不同vlan通信 使在同一VLAN里的计算机系统能交换机进行通信,而在不同VLAN里的计算机系统也能进行相互通信。 【实现步骤】 步骤1.在交换机SwitchA上创建vlan 10 ,并将0/5端口划分到...
  • 网络Cisco实验-跨交换机相同VLAN通信

    千次阅读 2017-12-10 17:34:47
    2.在二层交换机switch0中创建vlan 10,并且将pc1添加进去,在三层交换机Multilayer switch0中也创建vlan 10,将pc0添加进去,两个vlan 10是同一个 3.三层交换机Multilayer switch0默认为auto,不用手动设置trunk ...
  • 1、实验原理:VLAN将一个物理的LAN在逻辑上划分成多个广播域。VLAN内的主机间可以直接通信,而VLAN间不能直接互通。在现实网络中,经常会...三层交换机在原有二层交换机的基础之上增加了路由功能,同时由于数据没...
  • 通过配置三层交换机或路由器实现VLAN间的通信,通过路由器实现vlan通信(单臂路由)在路由器与交换机的端口上配置子接口,每个子接口的IP地址是每个VLAN的网关地址(也可以理解为下一跳地址),并在子接口上封装802....
  • VLAN三层交换机配置

    2021-03-13 16:00:20
    文章目录VNAN三层交换机配置VLAN概述与优势分割广播域vlan的种类VLAN表VLAN的范围华为系统中配置VLAN的相关命令Trunk的作用如何实现交换机之间的VLAN通信交换网络中的链路类型VLAN交换机通信过程VLAN的标识在...
  • 思科模拟器之跨VLAN通信VLAN(虚拟局域网)是对连接到的第二层交换机端口的网络用户的逻辑分段,不受网络用户的物理位置限制而根据用户需求进行网络分段。一个VLAN可以在一个交换机或者跨交换机实现。VLAN可以根据网络...
  • 其中使用的两台交换机型号为H3C S5120-28P-SI,路由器的型号为H3C MSR 36-40,其中交换机为三层交换机,支持路由功能,并且交换机和路由器都支持IPv6的功能。 要求如下: (1) IPv4: 10.1.2.0 / 24网段 与 172....
  • 实验案例:在华为ensp软件上模拟三层交换机利用路由功能实现全网互通 实验环境 如图所示,在win10下使用华为ensp软件...设置三层交换机vlanif网关,使得不同vlan间的pc可以正常通信 具体如下:这里的ip地址以及vl
  • 实验目的 掌握日和在交换机上划分基于端口的VLAN、给VLAN...然后使在同一个VLAN里的计算机系统能交换机进行相互通信,而在不同VLAN里的计算机系统不能进行相互通信实验设备 三层交换机1台 二层交换机1台预备知识 ...
  • 跨交换机VLANVLAN之间通信

    千次阅读 2013-11-17 15:09:22
    2.掌握三层交换机实现不同VLAN之间互通的方法 【基本原理】 实现交换机的VLAN需要采用IEEE802.1q协议的标准,在交换机之间的trunk链路中传输的数据帧内被添加了4个字节的802.1q标签信息,用于标识该数据帧属于...
  • 跨交换机实现vlan通信

    千次阅读 2013-07-14 16:00:43
    1、三层二层交换机配置冗余链路聚合 conf int range f 0/1-2 port-group 1 ...三层交换机 int aggregateport 1 将ap配置成TAG vlan模式 sw mode trunk exit 二层交换机 int aggregatepor

空空如也

空空如也

1 2 3 4 5 6
收藏数 107
精华内容 42
关键字:

三层交换机跨vlan通信