精华内容
下载资源
问答
  • 计算机网络课程设计

    2020-01-04 10:57:49
    @[TOC]计算机网络课程设计 A Try 想要写一篇原创文章,不知道写什么,大概就是这样子随便写写吧! 新的改变 课程设计报告 ( 2019–2020年度第1学期) 名 称: 计算机网络课程设计 题 目: 基础、设计、抓包分析 院 系...

    @[TOC]计算机网络课程设计

    A Try

    想要写一篇原创文章,不知道写什么,大概就是这样子随便写写吧!

    新的改变

    课程设计报告
    ( 2019–2020年度第1学期)

    名 称: 计算机网络课程设计
    题 目: 基础、设计、抓包分析
    院 系: 控制与计算机工程学院计算机系
    班 级: 计算机科学与技术1701、1701、实1701班
    组 号: 第二大组01小组
    指导教师: 邸剑
    设计周数: 一

    序号 姓名 学号 成绩
    1 习梦圆
    2
    3
    4

    日期:2019年12月

    《计算机网络》课程设计
    任 务 书

    一、 目的与要求
    1.目的
    将网络基本原理及基本概念用于实际,将书本上抽象的概念与具体的实现技术结合起来,使学习深化,培养学生对基本原理的应用能力以及实际动手能力。
    2.要求
    独立完成课程设计题目以及课程设计报告。报告应包括设计思路、网络拓扑图、数据包文件、开发中遇到的问题以及解决方法。
    二、 主要内容
    1.网络设备认知及基本配置操作
    (1)了解路由器、交换机等网络设备结构。
    (2)完成以下实验,掌握路由器、交换机等的配置方法,理解相关网络协议。
    ①交换机的基本配置;
    ②路由器的基本操作;
    ③OSPF基本配置;
    ④RIP v2配置;
    ⑤静态路由配置;
    ⑥跨交换机实现VLAN;
    ⑦利用单臂路由实现VLAN间路由;
    ⑧广域网协议的封装。
    ⑨IPv6 任选一个
    2.互联网的模拟
    (1)结合实验环境,提出模拟网络互联需求,设计并完成组网,要求尽最大可能利用实验资源。
    ①网络物理拓扑结构设计及IP地址分配;
    ②网络逻辑拓扑结构设计;
    (2)网络设备配置实现
    按步骤(1)所设计的网络拓扑进行设备连接并配置。配置内容包括路由选择协议OSPF配置,VLAN划分等,并进行测试。

    3.基于模拟互联网的网络协议分析。
    在上面设计并实现的网络环境下,利用arp、ping、tracert等命令、浏览器和IIS、
    wireshark等截获所配置环境下的C/S端数据包,分类保存相关数据包文件,完成如下协
    议分析:
    ①以太网数据链路层帧格式分析;
    ②网络层分片;ICMP协议分析;
    ③ARP地址解析协议分析;
    ④TCP传输控制协议分析;(三次握手、数据传输、四次挥手)
    ⑤FTP协议分析;HTTP协议分析。
    4. 选做:网络编程或LINUX操作系统网络部分的源代码分析。
    三、 进度计划
    序号 设计内容 完成时间 备注
    1 网络设备认知及配置操作 第一天
    2 模拟环境设计及网络设备配置 第二、三天
    3 基于模拟互联网的网络协议分析 第四天
    4 验收、撰写课程设计报告 第五天
    四、 设计成果要求
    1.网络配置拓扑图准确,配置结果测试成功;
    2.网络协议分析准确;
    3. 课程设计报告格式规范,内容详实。
    五、 考核方式
    考勤、验收和课程设计报告。

    学生姓名:
    指导教师: 邸剑
    2019年12月23日

    实验一:网络设备认知及基本配置操作
    交换机的基本配置
    一、课程设计(综合实验)的目的与要求
    1.实验目的
    掌握交换机命令行各种操作模式的区别,能够使用各种帮助信息,以及用命令进行基本的配置。
    2.实验要求
    需要在交换机上熟悉各种不同的配置模式以及如何在配置模式间切换,使用命令进行基本的配置,并熟悉命令行界面的操作技巧。
    二、设计(实验)正文
    1.实验拓扑

    2.实验原理
    交换机的管理方式基本分为两种:带内管理和带外管理。通过交换机的Console口管理交换机属于带外管理,不占用交换机的网络接口,其特点是需要使用配置线缆,近距离配置。第一次配置交换机时必须利用Console端口进行配置。
    交换机的命令行操作模式,主要包括:用户模式、特权模式、全局配置模式、端口模式等几种。
    3.实验步骤
    第一步:交换机各个操作模式直接的切换。
    第二步:交换机命令行界面基本功能。
    第三步:配置交换机的名称和每日提示信息。
    第四步:配置接口状态。
    第五步:查看交换机的系统和配置信息。
    第六步:保存配置。
    4.实验结果
    此实验过程中小组成员练习了交换机的基本配置,熟悉了各个操作。
    路由器的基本配置
    一、课程设计(综合实验)的目的与要求
    1.实验目的
    理解路由器的工作原理,掌握路由器的基本操作。
    2.实验要求
    将计算机的Com口和路由器的Console口通过Console线缆连接起来,使用Windows 提供的超级终端工具进行连接,登录路由器的命令行界面进行配置。
    二、设计(实验)正文

    1. 实验拓扑

    2.实验原理
    路由器的管理方式基本分为两种:带内管理和带外管理。通过路由器的Console口管理路由器属于带外管理,不占用路由器的网络接口,但特点是线缆特殊,需要近距离配置。第一次配置路由器时必须利用Console进行配置,使其支持telnet远程管理。
    路由器的命令行操作模式,主要包括:用户模式、特权模式、全局配置模式、端口模式等几种。
    3.实验步骤
    第一步:路由器命令行的基本功能
    第二步:配置路由器的名称和每日提示信息
    Welcome to RouterA, if you are admin, you can config it. If you are not admin, please EXIT.
    第三步:配置路由器的接口并查看接口配置第四步:配置接口状态。
    第四步:查看路由器的配置。
    4.实验结果
    此实验过程中小组成员练习了路由器的基本配置,熟悉了各个操作。

    OSPF 单区域基本配置
    一、课程设计(综合实验)的目的与要求
    1.实验目的
    掌握在路由器上配置 OSPF 单区域。
    2.实验要求
    需要在路由器和交换机上配置 OSPF 路 由协议,使全网互通,从而实现信息的共享和
    传递
    二、设计(实验)正文

    1. 实验拓扑

    2.实验原理
    OSPF(Open Shortest Path First,开放式最短路径优先)协议,是目前网络中应用最
    广泛的路由协议之一。属于内部网关路由协议,能够适应各种规模的网络环境,是典型的链
    路状态(link-state)协议。
    OSPF 路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一
    个具有全网链路状态的数据库(LSDB),然后路由器采用 SPF 算法,以自己为根,计算到
    达其他网络的最短路径,最终形成全网路由信息。
    OSPF 属于无类路由协议,支持 VLSM(变长子网掩码)。OSPF 是以组播的形式进行
    链路状态的通告的。
    在大模型的网络环境中,OSPF 支持区域的划分,将网络进行合理规划。划分区域时必
    须存在 area0(骨干区域)。其他区域和骨干区域直接相连,或通过虚链路的方式连接。
    5.实验步骤
    第一步:在路由器和三层交换机配置 IP 地址
    三层交换机
    Ruijie(config)#hostname S3750
    S3750(config)#vlan 10
    S3750(config-vlan)#exit
    S3750(config)#vlan 50
    S3750(config-vlan)#exit
    S3750(config)#interface fastEthernet 0/1
    S3750(config-if-FastEthernet 0/1)#switchport access vlan 10
    S3750(config-if-FastEthernet 0/1)#exit
    S3750(config)#interface fastEthernet 0/2
    S3750(config-if-FastEthernet 0/2)#switchport access vlan 50
    S3750(config-if-FastEthernet 0/2)#exit
    S3750(config)#interface vlan 10
    S3750(config-if-VLAN 10)#*Dec 24 17:54:04: %LINEPROTO-5-UPDOWN: Line protocol on Interface VLAN 10, changed state to up.

    S3750(config-if-VLAN 10)#ip address 172.16.1.2 255.255.255.0
    S3750(config-if-VLAN 10)#no shutdown
    S3750(config-if-VLAN 10)#exit
    S3750(config)#interface vlan 50
    S3750(config-if-VLAN 50)#ip address 172.16.5.1 255.255.255.0
    S3750(config-if-VLAN 50)#no shutdown
    S3750(config-if-VLAN 50)#exit
    路由器RA
    Ruijie(config)#interface gi0/1
    Ruijie(config-if-GigabitEthernet 0/1)#ip address 172.116.1.1 255.255.255.0
    Ruijie(config-if-GigabitEthernet 0/1)#no shutdown
    Ruijie(config-if-GigabitEthernet 0/1)#exit
    Ruijie(config)#interface gi0/0
    Ruijie(config-if-GigabitEthernet 0/0)#ip address*Dec 24 17:00:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial
    3/0, changed state to down.

    % Incomplete command.

    Ruijie(config-if-GigabitEthernet 0/0)#ip address 172.116.2.1
    % Incomplete command.

    Ruijie(config-if-GigabitEthernet 0/0)#ip address 172.116.2.1 255.255.255.0
    Ruijie(config-if-GigabitEthernet 0/0)#no shutdown
    Ruijie(config-if-GigabitEthernet 0/0)#exit
    Ruijie(config)#*Dec 24 17:01:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial 3/0, changed state to up.
    路由器RB
    Ruijie(config)#interface gi0/0
    Ruijie(config-if-GigabitEthernet 0/0)#ip address 172.116.2.2 255.255.255.0
    Ruijie(config-if-GigabitEthernet 0/0)#no shutdown
    Ruijie(config-if-GigabitEthernet 0/0)#exit
    Ruijie(config)#interface gi0/1
    Ruijie(config-if-GigabitEthernet 0/1)#ip address 172.116.3.1 255.255.255.0
    Ruijie(config-if-GigabitEthernet 0/1)#no shutdown
    Ruijie(config-if-GigabitEthernet 0/1)#exit
    第二步:配置 OSPF 路由协议
    三层交换机:
    S3750(config)#router ospf
    S3750(config-router)#network 172.16.5.0 0.0.0.255 area 0
    S3750(config-router)#network 172.16.1.0 0.0.0.255 area 0
    S3750(config-router)#end
    路由器RA:

    第三步:验证测试
    三层交换机:
    S3750#show vlan
    VLAN Name Status Ports


    1 VLAN0001 STATIC Fa0/3, Fa0/4, Fa0/5, Fa0/6
    Fa0/7, Fa0/8, Fa0/9, Fa0/10
    Fa0/11, Fa0/12, Fa0/13, Fa0/14
    Fa0/15, Fa0/16, Fa0/17, Fa0/18
    Fa0/19, Fa0/20, Fa0/21, Fa0/22
    Fa0/23, Fa0/24, Gi0/25, Gi0/26
    10 VLAN0010 STATIC Fa0/1
    50 VLAN0050 STATIC Fa0/2
    S3750#show ip int
    S3750#show ip interface brief
    Interface IP-Address(Pri) IP-Address(Sec) Status Protocol
    VLAN 10 172.16.1.2/24 no address up up
    VLAN 50 172.16.5.1/24 no address up down
    S3750#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    C 172.16.1.0/24 is directly connected, VLAN 10
    C 172.16.1.2/32 is local host.
    S3750#
    路由器RA:
    Codes: C - connected, S - static, R - RIP B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

      • candidate default
        Gateway of last resort is no set
        C 172.16.1.0/24 is directly connected, GigabitEthernet 0/1
        C 172.16.1.1/32 is local host.
        C 172.16.2.0/24 is directly connected, GigabitEthernet 0/0
        C 172.16.2.1/32 is local host.
        O 172.16.3.0/24 [110/2] via 172.16.2.2, 00:05:21, GigabitEthernet 0/0
        O 172.16.5.0/24 [110/2] via 172.16.1.2, 00:14:51, GigabitEthernet 0/1
        路由器B
        RB#show ip route
        Codes: C - connected, S - static, R - RIP B - BGP
        O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
      • candidate default
        Gateway of last resort is no set
        O 172.16.1.0/24 [110/2] via 172.16.2.1, 00:05:58, GigabitEtherne 0/0
        C 172.16.2.0/24 is directly connected, GigabitEtherne 0/0
        C 172.16.2.2/32 is local host.
        C 172.16.3.0/24 is directly connected, GigabitEtherne 0/1
        C 172.16.3.1/32 is local host.
        O 172.16.5.0/24 [110/3] via 172.16.2.1, 00:15:22, GigabitEtherne 0/1

    RIP v2配置
    一、课程设计(综合实验)的目的与要求
    1.实验目的
    理解 RIP 两个版本之间的区别,掌握如何配置 RIPv2。
    2.实验要求
    两台路由器通过快速以太网端口连接在一起,每个路由器上设置 2 个 Loopback 端口模
    拟子网,在所有端口运行 RIP 路由协议,实现所有子网间的互通。
    二、设计(实验)正文

    1. 实验拓扑

    2.实验原理
    RIP 协议有两个版本 RIPv1 和 RIPv2。
    RIPv1 属于有类路由协议,不支持 VLSM(变长子网掩码),RIPv1 是以广播的形式进
    行路由信息的更新的;更新周期为 30 秒。
    RIPv2 属于无类路由协议,支持 VLSM(变长子网掩码),RIPv2 是以组播的形式进行
    路由信息的更新的,组播地址是 224.0.0.9。RIPv2 还支持基于端口的认证,提高网络的安全
    性。
    3.实验步骤
    第一步:配置两台路由器的主机名、接口 IP 地址
    第二步:在两台路由器上启用 RIPv2,但不关闭自动汇总
    第三步:查看路由表
    路由器RA
    RouterA(config)#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    R 10.0.0.0/8 [120/1] via 191.168.1.2, 00:00:09, GigabitEthernet 0/0
    C 172.16.1.0/24 is directly connected, Loopback 0
    C 172.16.1.1/32 is local host.
    C 172.16.2.0/24 is directly connected, Loopback 1
    C 172.16.2.1/32 is local host.
    C 191.168.1.0/24 is directly connected, GigabitEthernet 0/0
    C 191.168.1.1/32 is local host.
    路由器RB
    RouterB(config)#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    C 10.1.1.0/24 is directly connected, Loopback 0
    C 10.1.1.1/32 is local host.
    C 10.2.2.0/24 is directly connected, Loopback 1
    C 10.2.2.1/32 is local host.
    R 172.16.0.0/16 [120/1] via 191.168.1.1, 00:00:46, GigabitEthernet 0/1
    C 191.168.1.0/24 is directly connected, GigabitEthernet 0/1
    C 191.168.1.2/32 is local host.
    第四步:关闭自动路由汇总。
    第五步:查看 RIP 配置信息。
    路由表RA:
    RouterA#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    R 10.0.0.0/8 [120/1] via 191.168.1.2, 00:02:07, GigabitEthernet 0/0
    R 10.1.1.0/24 [120/1] via 191.168.1.2, 00:00:07, GigabitEthernet 0/0
    R 10.2.2.0/24 [120/1] via 191.168.1.2, 00:00:07, GigabitEthernet 0/0
    C 172.16.1.0/24 is directly connected, Loopback 0
    C 172.16.1.1/32 is local host.
    C 172.16.2.0/24 is directly connected, Loopback 1
    C 172.16.2.1/32 is local host.
    C 191.168.1.0/24 is directly connected, GigabitEthernet 0/0
    C 191.168.1.1/32 is local host.

    RouterA#show ip rip database
    10.0.0.0/8 auto-summary
    10.0.0.0/8
    [1] via 191.168.1.2 GigabitEthernet 0/0 02:03
    10.1.1.0/24
    [1] via 191.168.1.2 GigabitEthernet 0/0 00:03
    10.2.2.0/24
    [1] via 191.168.1.2 GigabitEthernet 0/0 00:03
    172.16.0.0/16 auto-summary
    172.16.1.0/24
    [1] directly connected, Loopback 0
    172.16.2.0/24
    [1] directly connected, Loopback 1
    191.168.0.0/16 auto-summary
    191.168.1.0/24
    [1] directly connected, GigabitEthernet 0/0
    路由表RB:
    RouterB#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    C 10.1.1.0/24 is directly connected, Loopback 0
    C 10.1.1.1/32 is local host.
    C 10.2.2.0/24 is directly connected, Loopback 1
    C 10.2.2.1/32 is local host.
    R 172.16.1.0/24 [120/1] via 191.168.1.1, 00:03:01, GigabitEthernet 0/1
    R 172.16.2.0/24 [120/1] via 191.168.1.1, 00:03:01, GigabitEthernet 0/1
    C 191.168.1.0/24 is directly connected, GigabitEthernet 0/1
    C 191.168.1.2/32 is local host.

    RouterB#show ip rip
    Routing Protocol is “rip”
    Sending updates every 30 seconds
    Invalid after 180 seconds, flushed after 120 seconds
    Outgoing update filter list for all interface is: not set
    Incoming update filter list for all interface is: not set
    Redistribution default metric is 1
    Redistributing:
    Default version control: send version 2, receive version 2
    Interface Send Recv
    GigabitEthernet 0/1 2 2
    Loopback 0 2 2
    Loopback 1 2 2
    Routing for Networks:
    10.0.0.0 255.0.0.0
    191.168.0.0 255.255.0.0
    Distance: (default is 120)
    Graceful-restart disabled

    RouterB#show ip rip dat
    RouterB#show ip rip database
    10.0.0.0/8 auto-summary
    10.1.1.0/24
    [1] directly connected, Loopback 0
    10.2.2.0/24
    [1] directly connected, Loopback 1
    172.16.0.0/16 auto-summary
    172.16.0.0/16
    [16] via 191.168.1.1 GigabitEthernet 0/1 04:31 is possibly down
    172.16.1.0/24
    [1] via 191.168.1.1 GigabitEthernet 0/1 00:01
    172.16.2.0/24
    [1] via 191.168.1.1 GigabitEthernet 0/1 00:01
    191.168.0.0/16 auto-summary
    191.168.1.0/24
    [1]directly connected, GigabitEthernet 0/1
    第六步:测试网络连通性
    路由器RA
    RouterA#ping 10.1.1.1
    Sending 5, 100-byte ICMP Echoes to 10.1.1.1, timeout is 2 seconds:
    < press Ctrl+C to break >
    !!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/10 ms
    RouterA#ping 10.2.2.1
    Sending 5, 100-byte ICMP Echoes to 10.2.2.1, timeout is 2 seconds:
    < press Ctrl+C to break >
    !!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/10 ms
    路由器RB
    RouterB#ping 172.16.1.1
    Sending 5, 100-byte ICMP Echoes to 172.16.1.1, timeout is 2 seconds:
    < press Ctrl+C to break >
    !!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/8/10 ms
    RouterB#ping 172.16.2.1
    Sending 5, 100-byte ICMP Echoes to 172.16.2.1, timeout is 2 seconds:
    < press Ctrl+C to break >
    !!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/8/10 ms

    实验二 互联网的模拟
    一、课程设计(综合实验)的目的与要求

    1. 实验目的
      将网络基本原理及基本概念用于实际,将书本上抽象的概念与具体的实现技术结合起来,使学习深化,培养学生对基本原理的应用能力以及实际动手能力。
      1.实验要求
      (1)结合实验环境,提出模拟网络互联需求,设计并完成组网,要求尽最大可能利用实验资源。
      ①网络物理拓扑结构设计及IP地址分配;
      ②网络逻辑拓扑结构设计;
      (2)网络设备配置实现
      按步骤(1)所设计的网络拓扑进行设备连接并配置。配置内容包括路由选择协议OSPF配置,VLAN划分等,并进行测试。
      二、设计(实验)正文
    2. 实验拓扑
    3. 配置信息:
      交换机的

    路由表RSB201-1的配置信息:
    R1(config)#show running-config

    !
    version RGOS 10.4(3b12) Release(151012)(Fri Dec 28 19:23:27 CST 2012 -ngcf67)
    hostname R1
    !
    interface Serial 2/0
    encapsulation HDLC
    !
    interface Serial 3/0
    encapsulation HDLC
    ip address 172.10.4.2 255.255.255.0
    !
    interface GigabitEthernet 0/0
    ip address 172.10.12.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet 0/1
    ip address 172.10.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    router ospf 1
    network 172.10.1.0 0.0.0.255 area 0
    network 172.10.4.0 0.0.0.255 area 0
    network 172.10.12.0 0.0.0.255 area 4
    !
    end
    R1(config)#

    路由表RSB201-2的配置信息:
    R2(config)#show running-config
    !
    version RGOS 10.4(3b12) Release(151012)(Fri Dec 28 19:23:27 CST 2012 -ngcf67)
    hostname R2
    !
    interface Serial 2/0
    encapsulation HDLC
    clock rate 64000
    !
    interface Serial 3/0
    encapsulation HDLC
    ip address 172.10.2.1 255.255.255.0
    clock rate 64000
    !
    interface GigabitEthernet 0/1
    ip address 172.10.1.2 255.255.255.0
    duplex auto
    speed auto
    !
    router ospf 1
    network 172.10.1.0 0.0.0.255 area 0
    network 172.10.2.0 0.0.0.255 area 0
    !
    end
    R2(config)#

    路由表RSB201-3的配置信息:
    R3#show running-config
    !
    version RGOS 10.4(3b12) Release(151012)(Fri Dec 28 19:23:27 CST 2012 -ngcf67)
    hostname R3
    !
    interface Serial 2/0
    encapsulation HDLC
    ip address 172.10.2.2 255.255.255.0
    !
    interface Serial 3/0
    encapsulation HDLC
    !
    interface GigabitEthernet 0/0.20
    encapsulation dot1Q 20
    ip address 172.10.9.1 255.255.255.0
    !
    interface GigabitEthernet 0/0.30
    encapsulation dot1Q 30
    ip address 172.10.6.1 255.255.255.0
    !
    interface GigabitEthernet 0/1
    ip address 172.10.3.1 255.255.255.0
    duplex auto
    speed auto
    !
    router ospf 1
    network 172.10.2.0 0.0.0.255 area 0
    network 172.10.3.0 0.0.0.255 area 0
    network 172.10.6.0 0.0.0.255 area 3
    network 172.10.9.0 0.0.0.255 area 2
    !
    end
    路由表RSB201-4的配置信息:
    R4#show running-config
    version RGOS 10.4(3b12) Release(151012)(Fri Dec 28 19:23:27 CST 2012 -ngcf67)
    hostname R4
    !
    diffserv domain default
    !
    vlan 1
    !
    interface Serial 2/0
    encapsulation HDLC
    clock rate 64000
    !
    interface Serial 3/0
    encapsulation HDLC
    ip address 172.10.4.1 255.255.255.0
    clock rate 64000
    !
    interface GigabitEthernet 0/0
    ip address 172.10.3.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet 0/1
    duplex auto
    speed auto
    !
    router ospf 1
    network 172.10.3.0 0.0.0.255 area 0
    network 172.10.4.0 0.0.0.255 area 0
    !
    end
    R4#
    2.配置好的结果标注:

    3.查看各个路由表
    R1路由表:
    Gateway of last resort is no set
    C 172.10.1.0/24 is directly connected, GigabitEthernet 0/1
    C 172.10.1.1/32 is local host.
    O 172.10.2.0/24 [110/51] via 172.10.1.2, 02:22:58, GigabitEthernet 0/1
    O 172.10.3.0/24 [110/51] via 172.10.4.1, 01:15:17, Serial 3/0
    C 172.10.4.0/24 is directly connected, Serial 3/0
    C 172.10.4.2/32 is local host.
    O IA 172.10.6.0/24 [110/52] via 172.10.1.2, 02:22:58, GigabitEthernet 0/1
    [110/52] via 172.10.4.1, 01:15:17, Serial 3/0
    O IA 172.10.9.0/24 [110/52] via 172.10.1.2, 02:22:58, GigabitEthernet 0/1
    [110/52] via 172.10.4.1, 01:15:17, Serial 3/0
    C 172.10.12.0/24 is directly connected, GigabitEthernet 0/0
    C 172.10.12.1/32 is local host.

    R2路由表:
    Gateway of last resort is no set
    C 172.10.1.0/24 is directly connected, GigabitEthernet 0/1
    C 172.10.1.2/32 is local host.
    C 172.10.2.0/24 is directly connected, Serial 3/0
    C 172.10.2.1/32 is local host.
    O 172.10.3.0/24 [110/51] via 172.10.2.2, 02:30:53, Serial 3/0
    O 172.10.4.0/24 [110/51] via 172.10.1.1, 01:18:05, GigabitEthernet 0/1
    O IA 172.10.6.0/24 [110/51] via 172.10.2.2, 02:30:53, Serial 3/0
    O IA 172.10.9.0/24 [110/51] via 172.10.2.2, 02:30:53, Serial 3/0
    O IA 172.10.12.0/24 [110/2] via 172.10.1.1, 02:25:42, GigabitEthernet 0/1
    R3路由表:
    Gateway of last resort is no set
    O 172.10.1.0/24 [110/51] via 172.10.2.1, 02:32:13, Serial 2/0
    C 172.10.2.0/24 is directly connected, Serial 2/0
    C 172.10.2.2/32 is local host.
    C 172.10.3.0/24 is directly connected, GigabitEthernet 0/1
    C 172.10.3.1/32 is local host.
    O 172.10.4.0/24 [110/51] via 172.10.3.2, 01:19:10, GigabitEthernet 0/1
    C 172.10.6.0/24 is directly connected, GigabitEthernet 0/0.30
    C 172.10.6.1/32 is local host.
    C 172.10.9.0/24 is directly connected, GigabitEthernet 0/0.20
    C 172.10.9.1/32 is local host.
    O IA 172.10.12.0/24 [110/52] via 172.10.2.1, 02:26:51, Serial 2/0
    [110/52] via 172.10.3.2, 01:18:59, GigabitEthernet 0/1
    R4路由表:
    Gateway of last resort is no set
    O 172.10.1.0/24 [110/51] via 172.10.4.2, 01:25:39, Serial 3/0
    O 172.10.2.0/24 [110/51] via 172.10.3.1, 02:31:12, GigabitEthernet 0/0
    C 172.10.3.0/24 is directly connected, GigabitEthernet 0/0
    C 172.10.3.2/32 is local host.
    C 172.10.4.0/24 is directly connected, Serial 3/0
    C 172.10.4.1/32 is local host.
    O IA 172.10.6.0/24 [110/2] via 172.10.3.1, 02:31:12, GigabitEthernet 0/0
    O IA 172.10.9.0/24 [110/2] via 172.10.3.1, 02:31:12, GigabitEthernet 0/0
    O IA 172.10.12.0/24 [110/51] via 172.10.4.2, 01:25:39, Serial 3/0
    4.测试跟踪结果
    C:\Users\Administrator>ping 172.10.3.3

    正在 Ping 172.10.3.3 具有 32 字节的数据:
    来自 172.10.3.3 的回复: 字节=32 时间=14ms TTL=63
    来自 172.10.3.3 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.3.3 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.3.3 的回复: 字节=32 时间<1ms TTL=63

    172.10.3.3 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 14ms,平均 = 3ms

    C:\Users\Administrator>ping 172.10.9.2

    正在 Ping 172.10.9.2 具有 32 字节的数据:
    来自 172.10.9.2 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.9.2 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.9.2 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.9.2 的回复: 字节=32 时间<1ms TTL=63

    172.10.9.2 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 0ms,平均 = 0ms

    C:\Users\Administrator>ping 172.10.12.2

    正在 Ping 172.10.12.2 具有 32 字节的数据:
    来自 172.10.12.2 的回复: 字节=32 时间=46ms TTL=61
    来自 172.10.12.2 的回复: 字节=32 时间=38ms TTL=61
    来自 172.10.12.2 的回复: 字节=32 时间=40ms TTL=61
    来自 172.10.12.2 的回复: 字节=32 时间=41ms TTL=61

    172.10.12.2 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
    最短 = 38ms,最长 = 46ms,平均 = 41ms

    结论:各个主机之间均可互相通信。
    5.测试跟踪路径
    主机PC3到(PC4)172.10.12.2的路径:
    C:\Users\Administrator>tracert 172.10.12.2

    通过最多 30 个跃点跟踪
    到 NETPC014 [172.10.12.2] 的路由:

    1 <1 毫秒 <1 毫秒 <1 毫秒 172.10.6.1
    2 <1 毫秒 <1 毫秒 <1 毫秒 172.10.3.2
    3 43 ms 43 ms 43 ms 172.10.4.2
    4 50 ms 47 ms 47 ms NETPC014 [172.10.12.2]

    跟踪完成。

    关闭R1的S3/0接口
    R1#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    R1(config)#interface s3/0
    R1(config-if-Serial 3/0)#shutdown
    R1(config-if-Serial 3/0)#exit*Dec 25 18:42:24: %LINK-5-CHANGED: Interface Serial 3/0, changed state to administratively
    down.
    *Dec 25 18:42:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial 3/0, changed state to down.
    *Dec 25 18:42:24: %OSPF-5-ADJCHG: Process 1, Nbr 172.10.4.1-Serial 3/0 from Full to Down, KillNbr.

    R1(config)#

    关闭上述接口后,主机PC3到(PC4)172.10.12.2的路径:
    C:\Users\Administrator>tracert 172.10.12.2

    通过最多 30 个跃点跟踪
    到 NETPC014 [172.10.12.2] 的路由:

    1 <1 毫秒 <1 毫秒 <1 毫秒 172.10.6.1
    2 39 ms 39 ms 39 ms 172.10.2.1
    3 47 ms 39 ms 39 ms 172.10.1.1
    4 46 ms 43 ms 43 ms NETPC014 [172.10.12.2]

    跟踪完成。
    结论:断开某接口之后依然能ping通,但路径不同,设计成功,即实验成功。

    实验三 基于模拟互联网的网络协议分析
    一、课程设计(综合实验)的目的与要求
    在上面设计并实现的网络环境下,利用arp、ping、tracert等命令、浏览器和IIS、
    wireshark等截获所配置环境下的C/S端数据包,分类保存相关数据包文件,完成如下协
    议分析:
    以太网数据链路层帧格式分析;
    网络层分片;ICMP协议分析;
    ARP地址解析协议分析;
    TCP传输控制协议分析;(三次握手、数据传输、四次挥手)
    FTP协议分析;HTTP协议分析。
    二、设计(实验)正文
    配置应用服务器(Web服务器或FTP服务器),通过抓包工具分别在服务器端和客户端捕获数据。
    第一步,确定目标地址,选择ftp://172.10.6.2作为目标地址。
    第二歩,配置过滤器:针对协议进行过滤设置,ping使用的是ICMP协议,抓包前使用捕捉过滤器,过滤设置为icmp。
    第三步,启动抓包:点击【start】开始抓包,在命令提示符下键入ping ftp://172.10.6.2。
    第四步,停止抓包后,截取数据。
    第五步,分析数据包,选取一个数据包进行分析。
    1.以太网数据链路层帧格式分析

    目的物理地址:14:14:4b:31:e2:8a
    源物理地址:14:cf:92:e3:b1:1f
    类型:IPv4 (0x0800)
    2.网络层分片

    共分为三片:
    首部长度 总长度 MF DF 片偏移
    数据报片1 20 1500 1 0 0
    数据报片2 20 1500 1 0 1480
    数据报片3 20 68 0 0 2960

    3.ICMP协议分析

    Type为8的包为回射请求(Ping请求)
    Type为0的包为回射应答(Ping应答)
    从截获的ICMP数据可知,该ICMP类型为0,编码为0,即为回显应答;校验和真确,知道标识和序列号以及所包含的数据为3000字节。

    4.ARP地址解析协议分析

    第一行为ARP进程在本局域网上广播的一个ARP请求分组:信息为:我的IP地址为172.10.9.2,硬件地址为14:cf:92:e3:b1:1f,我想知道IP地址为172.10.9.1的硬件地址。
    第二行为ARP响应分组:信息为:我的IP地址为172.10.9.1,硬件地址为14:14:4b:31:e2:8a。
    5.TCP传输控制协议分析

    TCP首部格式

    源端口:1577
    目的端口:21
    序号:56
    确认号:295
    标志:
    在TCP首部中有6个标志比特。
    URG(Urgent Pointer Field Significant):紧急指针标志,用来保证TCP连接不被中断,并且督促中间设备尽快处理这些数据
    ACK(Acknowledgement Field Signigicant):确认号字段,该字段为1时表示应答字段有效,即TCP应答号将包含在TCP报文中。
    PSH(Push Function): 推送功能,所谓推送功能指的是接收端在接收到数据后立即推送给应用程序,而不是在缓冲区中排队。
    RST(Reset the connection): 重置连接,不过一搬表示断开一个连接。
    SYN(Synchronize sequence numbers):同步序列号,用来发起一个连接请求
    FIN(No more data from sender):表示发送端发送任务已经完成(既断开连接)
    6.FTP协议分析

    FTP协议有两种工作方式:PORT方式和PASV方式,中文意思为主动式和被动式。
    

    PORT(主动)方式的连接过程是:客户端向服务器的FTP端口(默认是21)发送连接请求,服务器接受连接,建立一条命令链路。当需要传送数据时,客户端在命令链路上用PORT命令告诉服务器:“我打开了XXXX端口,你过来连接我”。于是服务器从20端口向客户端的XXXX端口发送连接请求,建立一条数据链路来传送数据。
    PASV(被动)方式的连接过程是:客户端向服务器的FTP端口(默认是21)发送连接请求,服务器接受连接,建立一条命令链路。当需要传送数据时,服务器在命令链路上用PASV命令告诉客户端:“我打开了XXXX端口,你过来连接我”。于是客户端向服务器的XXXX端
    FTP是基于TCP的,三次握手建立连接之后服务器端向客户端发送自己的相关信息。
    状态码220表示服务准备就绪,230 表示登陆成功,421表示服务关闭。
    7.HTTP协议分析

    请求行:url为相对URL
    User-Agent:指明了发出请求的用户代理的浏览器的一些信息
    Accept-Encoding: gzip, deflate 指明该浏览器支持的编码格式,这里是压缩编码的方式。
    Accept-Language:指明了该浏览器支持的语言类型
    首部行:主机为172.10.6.2
    用户代理为Mozilla/4.0
    \r\n 代表下面的信息就是请求体的实体部分了。
    三、课程设计(综合实验)总结或结论
    在本次试验中学到了很多实际的知识,首先是认识性实验,其中包括了下一步设计实验中所需要的基本操作,由于每个实验都有很详细的步骤,因此完成的非常顺利,也没有遇到过什么困难,其中有些实验后面用不到,因此只做了基本的操作,只有路由器的配置、交换机的配置、ospf设置等几个做了详细的研究。
    其次是互联网的模拟,主要的部分在于拓扑图的设计和IP的分配上。由于开始认识不足,设计的拓扑非常的复杂,比如用三层交换机当成核心交换机后来设置VLAN,还有将路由器连接了三四个端口,由于这些错误导致进度很慢。在一-步步尝试修改后,拓扑图变得较为简单可行,路由器通过使用串口来解决多端口问题。我们遇到最大的问题则是在PC的IP分配上,由于开始没有认识到要按照拓扑图上对应的PC来分配地址,只是随机给四台电脑分配,所以连好拓扑分好IP配置好后,PC之间怎么也ping不通,而其他的都可以ping通,但是我们始终没有意识到是PC的问题,以为是其他原因,因此花费了相当多的时间在修改拓扑图,修改IP上,最后实在没有办法,请教老师才终于解决了问题。
    最后是抓包分析,这个实验我们做的最慢,因为对软件的使用非常不清楚,而且也确实是不明白抓包是怎样一个过程,经过查阅各种资料加上老师的耐心指导,终于成功实现。抓包成功后的主要的重心还是在分析上面。以前只听说过抓包,却不明白其中的道理,通过自己做实验,让我把那些死板的知识变的活跃了,非常珍惜这些让我们能够自己动手的机会。
    总的来说,这次的课程设计,充分锻炼了自己的动手能力及学到一些课程内其他没有学到过知识,感觉收获是颇多的!也让我明白,单单掌握理论知识还是远远不够的,能够要学以致用才是我们的最终目的。
    四、参考文献
    [1] 谢希仁.《计算机网络》. 北京:电子工业出版社, 第五版. 2008.

    课程设计报告
    ( 2019–2020年度第1学期)

    名 称: 计算机网络课程设计
    题 目: 基础、设计、抓包分析
    院 系: 控制与计算机工程学院计算机系
    班 级: 计算机科学与技术1701、1701、实1701班
    组 号: 第二大组01小组
    指导教师: 邸剑
    设计周数: 一

    序号 姓名 学号 成绩
    1 习梦圆
    2
    3
    4

    日期:2019年12月

    《计算机网络》课程设计
    任 务 书

    一、 目的与要求
    1.目的
    将网络基本原理及基本概念用于实际,将书本上抽象的概念与具体的实现技术结合起来,使学习深化,培养学生对基本原理的应用能力以及实际动手能力。
    2.要求
    独立完成课程设计题目以及课程设计报告。报告应包括设计思路、网络拓扑图、数据包文件、开发中遇到的问题以及解决方法。
    二、 主要内容
    1.网络设备认知及基本配置操作
    (1)了解路由器、交换机等网络设备结构。
    (2)完成以下实验,掌握路由器、交换机等的配置方法,理解相关网络协议。
    ①交换机的基本配置;
    ②路由器的基本操作;
    ③OSPF基本配置;
    ④RIP v2配置;
    ⑤静态路由配置;
    ⑥跨交换机实现VLAN;
    ⑦利用单臂路由实现VLAN间路由;
    ⑧广域网协议的封装。
    ⑨IPv6 任选一个
    2.互联网的模拟
    (1)结合实验环境,提出模拟网络互联需求,设计并完成组网,要求尽最大可能利用实验资源。
    ①网络物理拓扑结构设计及IP地址分配;
    ②网络逻辑拓扑结构设计;
    (2)网络设备配置实现
    按步骤(1)所设计的网络拓扑进行设备连接并配置。配置内容包括路由选择协议OSPF配置,VLAN划分等,并进行测试。

    3.基于模拟互联网的网络协议分析。
    在上面设计并实现的网络环境下,利用arp、ping、tracert等命令、浏览器和IIS、
    wireshark等截获所配置环境下的C/S端数据包,分类保存相关数据包文件,完成如下协
    议分析:
    ①以太网数据链路层帧格式分析;
    ②网络层分片;ICMP协议分析;
    ③ARP地址解析协议分析;
    ④TCP传输控制协议分析;(三次握手、数据传输、四次挥手)
    ⑤FTP协议分析;HTTP协议分析。
    4. 选做:网络编程或LINUX操作系统网络部分的源代码分析。
    三、 进度计划
    序号 设计内容 完成时间 备注
    1 网络设备认知及配置操作 第一天
    2 模拟环境设计及网络设备配置 第二、三天
    3 基于模拟互联网的网络协议分析 第四天
    4 验收、撰写课程设计报告 第五天
    四、 设计成果要求
    1.网络配置拓扑图准确,配置结果测试成功;
    2.网络协议分析准确;
    3. 课程设计报告格式规范,内容详实。
    五、 考核方式
    考勤、验收和课程设计报告。

    学生姓名:
    指导教师: 邸剑
    2019年12月23日

    实验一:网络设备认知及基本配置操作
    交换机的基本配置
    一、课程设计(综合实验)的目的与要求
    1.实验目的
    掌握交换机命令行各种操作模式的区别,能够使用各种帮助信息,以及用命令进行基本的配置。
    2.实验要求
    需要在交换机上熟悉各种不同的配置模式以及如何在配置模式间切换,使用命令进行基本的配置,并熟悉命令行界面的操作技巧。
    二、设计(实验)正文
    1.实验拓扑

    2.实验原理
    交换机的管理方式基本分为两种:带内管理和带外管理。通过交换机的Console口管理交换机属于带外管理,不占用交换机的网络接口,其特点是需要使用配置线缆,近距离配置。第一次配置交换机时必须利用Console端口进行配置。
    交换机的命令行操作模式,主要包括:用户模式、特权模式、全局配置模式、端口模式等几种。
    3.实验步骤
    第一步:交换机各个操作模式直接的切换。
    第二步:交换机命令行界面基本功能。
    第三步:配置交换机的名称和每日提示信息。
    第四步:配置接口状态。
    第五步:查看交换机的系统和配置信息。
    第六步:保存配置。
    4.实验结果
    此实验过程中小组成员练习了交换机的基本配置,熟悉了各个操作。
    路由器的基本配置
    一、课程设计(综合实验)的目的与要求
    1.实验目的
    理解路由器的工作原理,掌握路由器的基本操作。
    2.实验要求
    将计算机的Com口和路由器的Console口通过Console线缆连接起来,使用Windows 提供的超级终端工具进行连接,登录路由器的命令行界面进行配置。
    二、设计(实验)正文

    1. 实验拓扑

    2.实验原理
    路由器的管理方式基本分为两种:带内管理和带外管理。通过路由器的Console口管理路由器属于带外管理,不占用路由器的网络接口,但特点是线缆特殊,需要近距离配置。第一次配置路由器时必须利用Console进行配置,使其支持telnet远程管理。
    路由器的命令行操作模式,主要包括:用户模式、特权模式、全局配置模式、端口模式等几种。
    3.实验步骤
    第一步:路由器命令行的基本功能
    第二步:配置路由器的名称和每日提示信息
    Welcome to RouterA, if you are admin, you can config it. If you are not admin, please EXIT.
    第三步:配置路由器的接口并查看接口配置第四步:配置接口状态。
    第四步:查看路由器的配置。
    4.实验结果
    此实验过程中小组成员练习了路由器的基本配置,熟悉了各个操作。

    OSPF 单区域基本配置
    一、课程设计(综合实验)的目的与要求
    1.实验目的
    掌握在路由器上配置 OSPF 单区域。
    2.实验要求
    需要在路由器和交换机上配置 OSPF 路 由协议,使全网互通,从而实现信息的共享和
    传递
    二、设计(实验)正文

    1. 实验拓扑

    2.实验原理
    OSPF(Open Shortest Path First,开放式最短路径优先)协议,是目前网络中应用最
    广泛的路由协议之一。属于内部网关路由协议,能够适应各种规模的网络环境,是典型的链
    路状态(link-state)协议。
    OSPF 路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一
    个具有全网链路状态的数据库(LSDB),然后路由器采用 SPF 算法,以自己为根,计算到
    达其他网络的最短路径,最终形成全网路由信息。
    OSPF 属于无类路由协议,支持 VLSM(变长子网掩码)。OSPF 是以组播的形式进行
    链路状态的通告的。
    在大模型的网络环境中,OSPF 支持区域的划分,将网络进行合理规划。划分区域时必
    须存在 area0(骨干区域)。其他区域和骨干区域直接相连,或通过虚链路的方式连接。
    5.实验步骤
    第一步:在路由器和三层交换机配置 IP 地址
    三层交换机
    Ruijie(config)#hostname S3750
    S3750(config)#vlan 10
    S3750(config-vlan)#exit
    S3750(config)#vlan 50
    S3750(config-vlan)#exit
    S3750(config)#interface fastEthernet 0/1
    S3750(config-if-FastEthernet 0/1)#switchport access vlan 10
    S3750(config-if-FastEthernet 0/1)#exit
    S3750(config)#interface fastEthernet 0/2
    S3750(config-if-FastEthernet 0/2)#switchport access vlan 50
    S3750(config-if-FastEthernet 0/2)#exit
    S3750(config)#interface vlan 10
    S3750(config-if-VLAN 10)#*Dec 24 17:54:04: %LINEPROTO-5-UPDOWN: Line protocol on Interface VLAN 10, changed state to up.

    S3750(config-if-VLAN 10)#ip address 172.16.1.2 255.255.255.0
    S3750(config-if-VLAN 10)#no shutdown
    S3750(config-if-VLAN 10)#exit
    S3750(config)#interface vlan 50
    S3750(config-if-VLAN 50)#ip address 172.16.5.1 255.255.255.0
    S3750(config-if-VLAN 50)#no shutdown
    S3750(config-if-VLAN 50)#exit
    路由器RA
    Ruijie(config)#interface gi0/1
    Ruijie(config-if-GigabitEthernet 0/1)#ip address 172.116.1.1 255.255.255.0
    Ruijie(config-if-GigabitEthernet 0/1)#no shutdown
    Ruijie(config-if-GigabitEthernet 0/1)#exit
    Ruijie(config)#interface gi0/0
    Ruijie(config-if-GigabitEthernet 0/0)#ip address*Dec 24 17:00:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial
    3/0, changed state to down.

    % Incomplete command.

    Ruijie(config-if-GigabitEthernet 0/0)#ip address 172.116.2.1
    % Incomplete command.

    Ruijie(config-if-GigabitEthernet 0/0)#ip address 172.116.2.1 255.255.255.0
    Ruijie(config-if-GigabitEthernet 0/0)#no shutdown
    Ruijie(config-if-GigabitEthernet 0/0)#exit
    Ruijie(config)#*Dec 24 17:01:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial 3/0, changed state to up.
    路由器RB
    Ruijie(config)#interface gi0/0
    Ruijie(config-if-GigabitEthernet 0/0)#ip address 172.116.2.2 255.255.255.0
    Ruijie(config-if-GigabitEthernet 0/0)#no shutdown
    Ruijie(config-if-GigabitEthernet 0/0)#exit
    Ruijie(config)#interface gi0/1
    Ruijie(config-if-GigabitEthernet 0/1)#ip address 172.116.3.1 255.255.255.0
    Ruijie(config-if-GigabitEthernet 0/1)#no shutdown
    Ruijie(config-if-GigabitEthernet 0/1)#exit
    第二步:配置 OSPF 路由协议
    三层交换机:
    S3750(config)#router ospf
    S3750(config-router)#network 172.16.5.0 0.0.0.255 area 0
    S3750(config-router)#network 172.16.1.0 0.0.0.255 area 0
    S3750(config-router)#end
    路由器RA:

    第三步:验证测试
    三层交换机:
    S3750#show vlan
    VLAN Name Status Ports


    1 VLAN0001 STATIC Fa0/3, Fa0/4, Fa0/5, Fa0/6
    Fa0/7, Fa0/8, Fa0/9, Fa0/10
    Fa0/11, Fa0/12, Fa0/13, Fa0/14
    Fa0/15, Fa0/16, Fa0/17, Fa0/18
    Fa0/19, Fa0/20, Fa0/21, Fa0/22
    Fa0/23, Fa0/24, Gi0/25, Gi0/26
    10 VLAN0010 STATIC Fa0/1
    50 VLAN0050 STATIC Fa0/2
    S3750#show ip int
    S3750#show ip interface brief
    Interface IP-Address(Pri) IP-Address(Sec) Status Protocol
    VLAN 10 172.16.1.2/24 no address up up
    VLAN 50 172.16.5.1/24 no address up down
    S3750#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    C 172.16.1.0/24 is directly connected, VLAN 10
    C 172.16.1.2/32 is local host.
    S3750#
    路由器RA:
    Codes: C - connected, S - static, R - RIP B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

      • candidate default
        Gateway of last resort is no set
        C 172.16.1.0/24 is directly connected, GigabitEthernet 0/1
        C 172.16.1.1/32 is local host.
        C 172.16.2.0/24 is directly connected, GigabitEthernet 0/0
        C 172.16.2.1/32 is local host.
        O 172.16.3.0/24 [110/2] via 172.16.2.2, 00:05:21, GigabitEthernet 0/0
        O 172.16.5.0/24 [110/2] via 172.16.1.2, 00:14:51, GigabitEthernet 0/1
        路由器B
        RB#show ip route
        Codes: C - connected, S - static, R - RIP B - BGP
        O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
      • candidate default
        Gateway of last resort is no set
        O 172.16.1.0/24 [110/2] via 172.16.2.1, 00:05:58, GigabitEtherne 0/0
        C 172.16.2.0/24 is directly connected, GigabitEtherne 0/0
        C 172.16.2.2/32 is local host.
        C 172.16.3.0/24 is directly connected, GigabitEtherne 0/1
        C 172.16.3.1/32 is local host.
        O 172.16.5.0/24 [110/3] via 172.16.2.1, 00:15:22, GigabitEtherne 0/1

    RIP v2配置
    一、课程设计(综合实验)的目的与要求
    1.实验目的
    理解 RIP 两个版本之间的区别,掌握如何配置 RIPv2。
    2.实验要求
    两台路由器通过快速以太网端口连接在一起,每个路由器上设置 2 个 Loopback 端口模
    拟子网,在所有端口运行 RIP 路由协议,实现所有子网间的互通。
    二、设计(实验)正文

    1. 实验拓扑

    2.实验原理
    RIP 协议有两个版本 RIPv1 和 RIPv2。
    RIPv1 属于有类路由协议,不支持 VLSM(变长子网掩码),RIPv1 是以广播的形式进
    行路由信息的更新的;更新周期为 30 秒。
    RIPv2 属于无类路由协议,支持 VLSM(变长子网掩码),RIPv2 是以组播的形式进行
    路由信息的更新的,组播地址是 224.0.0.9。RIPv2 还支持基于端口的认证,提高网络的安全
    性。
    3.实验步骤
    第一步:配置两台路由器的主机名、接口 IP 地址
    第二步:在两台路由器上启用 RIPv2,但不关闭自动汇总
    第三步:查看路由表
    路由器RA
    RouterA(config)#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    R 10.0.0.0/8 [120/1] via 191.168.1.2, 00:00:09, GigabitEthernet 0/0
    C 172.16.1.0/24 is directly connected, Loopback 0
    C 172.16.1.1/32 is local host.
    C 172.16.2.0/24 is directly connected, Loopback 1
    C 172.16.2.1/32 is local host.
    C 191.168.1.0/24 is directly connected, GigabitEthernet 0/0
    C 191.168.1.1/32 is local host.
    路由器RB
    RouterB(config)#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    C 10.1.1.0/24 is directly connected, Loopback 0
    C 10.1.1.1/32 is local host.
    C 10.2.2.0/24 is directly connected, Loopback 1
    C 10.2.2.1/32 is local host.
    R 172.16.0.0/16 [120/1] via 191.168.1.1, 00:00:46, GigabitEthernet 0/1
    C 191.168.1.0/24 is directly connected, GigabitEthernet 0/1
    C 191.168.1.2/32 is local host.
    第四步:关闭自动路由汇总。
    第五步:查看 RIP 配置信息。
    路由表RA:
    RouterA#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    R 10.0.0.0/8 [120/1] via 191.168.1.2, 00:02:07, GigabitEthernet 0/0
    R 10.1.1.0/24 [120/1] via 191.168.1.2, 00:00:07, GigabitEthernet 0/0
    R 10.2.2.0/24 [120/1] via 191.168.1.2, 00:00:07, GigabitEthernet 0/0
    C 172.16.1.0/24 is directly connected, Loopback 0
    C 172.16.1.1/32 is local host.
    C 172.16.2.0/24 is directly connected, Loopback 1
    C 172.16.2.1/32 is local host.
    C 191.168.1.0/24 is directly connected, GigabitEthernet 0/0
    C 191.168.1.1/32 is local host.

    RouterA#show ip rip database
    10.0.0.0/8 auto-summary
    10.0.0.0/8
    [1] via 191.168.1.2 GigabitEthernet 0/0 02:03
    10.1.1.0/24
    [1] via 191.168.1.2 GigabitEthernet 0/0 00:03
    10.2.2.0/24
    [1] via 191.168.1.2 GigabitEthernet 0/0 00:03
    172.16.0.0/16 auto-summary
    172.16.1.0/24
    [1] directly connected, Loopback 0
    172.16.2.0/24
    [1] directly connected, Loopback 1
    191.168.0.0/16 auto-summary
    191.168.1.0/24
    [1] directly connected, GigabitEthernet 0/0
    路由表RB:
    RouterB#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default

    Gateway of last resort is no set
    C 10.1.1.0/24 is directly connected, Loopback 0
    C 10.1.1.1/32 is local host.
    C 10.2.2.0/24 is directly connected, Loopback 1
    C 10.2.2.1/32 is local host.
    R 172.16.1.0/24 [120/1] via 191.168.1.1, 00:03:01, GigabitEthernet 0/1
    R 172.16.2.0/24 [120/1] via 191.168.1.1, 00:03:01, GigabitEthernet 0/1
    C 191.168.1.0/24 is directly connected, GigabitEthernet 0/1
    C 191.168.1.2/32 is local host.

    RouterB#show ip rip
    Routing Protocol is “rip”
    Sending updates every 30 seconds
    Invalid after 180 seconds, flushed after 120 seconds
    Outgoing update filter list for all interface is: not set
    Incoming update filter list for all interface is: not set
    Redistribution default metric is 1
    Redistributing:
    Default version control: send version 2, receive version 2
    Interface Send Recv
    GigabitEthernet 0/1 2 2
    Loopback 0 2 2
    Loopback 1 2 2
    Routing for Networks:
    10.0.0.0 255.0.0.0
    191.168.0.0 255.255.0.0
    Distance: (default is 120)
    Graceful-restart disabled

    RouterB#show ip rip dat
    RouterB#show ip rip database
    10.0.0.0/8 auto-summary
    10.1.1.0/24
    [1] directly connected, Loopback 0
    10.2.2.0/24
    [1] directly connected, Loopback 1
    172.16.0.0/16 auto-summary
    172.16.0.0/16
    [16] via 191.168.1.1 GigabitEthernet 0/1 04:31 is possibly down
    172.16.1.0/24
    [1] via 191.168.1.1 GigabitEthernet 0/1 00:01
    172.16.2.0/24
    [1] via 191.168.1.1 GigabitEthernet 0/1 00:01
    191.168.0.0/16 auto-summary
    191.168.1.0/24
    [1]directly connected, GigabitEthernet 0/1
    第六步:测试网络连通性
    路由器RA
    RouterA#ping 10.1.1.1
    Sending 5, 100-byte ICMP Echoes to 10.1.1.1, timeout is 2 seconds:
    < press Ctrl+C to break >
    !!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/10 ms
    RouterA#ping 10.2.2.1
    Sending 5, 100-byte ICMP Echoes to 10.2.2.1, timeout is 2 seconds:
    < press Ctrl+C to break >
    !!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/10 ms
    路由器RB
    RouterB#ping 172.16.1.1
    Sending 5, 100-byte ICMP Echoes to 172.16.1.1, timeout is 2 seconds:
    < press Ctrl+C to break >
    !!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/8/10 ms
    RouterB#ping 172.16.2.1
    Sending 5, 100-byte ICMP Echoes to 172.16.2.1, timeout is 2 seconds:
    < press Ctrl+C to break >
    !!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/8/10 ms

    实验二 互联网的模拟
    一、课程设计(综合实验)的目的与要求

    1. 实验目的
      将网络基本原理及基本概念用于实际,将书本上抽象的概念与具体的实现技术结合起来,使学习深化,培养学生对基本原理的应用能力以及实际动手能力。
      1.实验要求
      (1)结合实验环境,提出模拟网络互联需求,设计并完成组网,要求尽最大可能利用实验资源。
      ①网络物理拓扑结构设计及IP地址分配;
      ②网络逻辑拓扑结构设计;
      (2)网络设备配置实现
      按步骤(1)所设计的网络拓扑进行设备连接并配置。配置内容包括路由选择协议OSPF配置,VLAN划分等,并进行测试。
      二、设计(实验)正文
    2. 实验拓扑
    3. 配置信息:
      交换机的

    路由表RSB201-1的配置信息:
    R1(config)#show running-config

    !
    version RGOS 10.4(3b12) Release(151012)(Fri Dec 28 19:23:27 CST 2012 -ngcf67)
    hostname R1
    !
    interface Serial 2/0
    encapsulation HDLC
    !
    interface Serial 3/0
    encapsulation HDLC
    ip address 172.10.4.2 255.255.255.0
    !
    interface GigabitEthernet 0/0
    ip address 172.10.12.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet 0/1
    ip address 172.10.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    router ospf 1
    network 172.10.1.0 0.0.0.255 area 0
    network 172.10.4.0 0.0.0.255 area 0
    network 172.10.12.0 0.0.0.255 area 4
    !
    end
    R1(config)#

    路由表RSB201-2的配置信息:
    R2(config)#show running-config
    !
    version RGOS 10.4(3b12) Release(151012)(Fri Dec 28 19:23:27 CST 2012 -ngcf67)
    hostname R2
    !
    interface Serial 2/0
    encapsulation HDLC
    clock rate 64000
    !
    interface Serial 3/0
    encapsulation HDLC
    ip address 172.10.2.1 255.255.255.0
    clock rate 64000
    !
    interface GigabitEthernet 0/1
    ip address 172.10.1.2 255.255.255.0
    duplex auto
    speed auto
    !
    router ospf 1
    network 172.10.1.0 0.0.0.255 area 0
    network 172.10.2.0 0.0.0.255 area 0
    !
    end
    R2(config)#

    路由表RSB201-3的配置信息:
    R3#show running-config
    !
    version RGOS 10.4(3b12) Release(151012)(Fri Dec 28 19:23:27 CST 2012 -ngcf67)
    hostname R3
    !
    interface Serial 2/0
    encapsulation HDLC
    ip address 172.10.2.2 255.255.255.0
    !
    interface Serial 3/0
    encapsulation HDLC
    !
    interface GigabitEthernet 0/0.20
    encapsulation dot1Q 20
    ip address 172.10.9.1 255.255.255.0
    !
    interface GigabitEthernet 0/0.30
    encapsulation dot1Q 30
    ip address 172.10.6.1 255.255.255.0
    !
    interface GigabitEthernet 0/1
    ip address 172.10.3.1 255.255.255.0
    duplex auto
    speed auto
    !
    router ospf 1
    network 172.10.2.0 0.0.0.255 area 0
    network 172.10.3.0 0.0.0.255 area 0
    network 172.10.6.0 0.0.0.255 area 3
    network 172.10.9.0 0.0.0.255 area 2
    !
    end
    路由表RSB201-4的配置信息:
    R4#show running-config
    version RGOS 10.4(3b12) Release(151012)(Fri Dec 28 19:23:27 CST 2012 -ngcf67)
    hostname R4
    !
    diffserv domain default
    !
    vlan 1
    !
    interface Serial 2/0
    encapsulation HDLC
    clock rate 64000
    !
    interface Serial 3/0
    encapsulation HDLC
    ip address 172.10.4.1 255.255.255.0
    clock rate 64000
    !
    interface GigabitEthernet 0/0
    ip address 172.10.3.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet 0/1
    duplex auto
    speed auto
    !
    router ospf 1
    network 172.10.3.0 0.0.0.255 area 0
    network 172.10.4.0 0.0.0.255 area 0
    !
    end
    R4#
    2.配置好的结果标注:

    3.查看各个路由表
    R1路由表:
    Gateway of last resort is no set
    C 172.10.1.0/24 is directly connected, GigabitEthernet 0/1
    C 172.10.1.1/32 is local host.
    O 172.10.2.0/24 [110/51] via 172.10.1.2, 02:22:58, GigabitEthernet 0/1
    O 172.10.3.0/24 [110/51] via 172.10.4.1, 01:15:17, Serial 3/0
    C 172.10.4.0/24 is directly connected, Serial 3/0
    C 172.10.4.2/32 is local host.
    O IA 172.10.6.0/24 [110/52] via 172.10.1.2, 02:22:58, GigabitEthernet 0/1
    [110/52] via 172.10.4.1, 01:15:17, Serial 3/0
    O IA 172.10.9.0/24 [110/52] via 172.10.1.2, 02:22:58, GigabitEthernet 0/1
    [110/52] via 172.10.4.1, 01:15:17, Serial 3/0
    C 172.10.12.0/24 is directly connected, GigabitEthernet 0/0
    C 172.10.12.1/32 is local host.

    R2路由表:
    Gateway of last resort is no set
    C 172.10.1.0/24 is directly connected, GigabitEthernet 0/1
    C 172.10.1.2/32 is local host.
    C 172.10.2.0/24 is directly connected, Serial 3/0
    C 172.10.2.1/32 is local host.
    O 172.10.3.0/24 [110/51] via 172.10.2.2, 02:30:53, Serial 3/0
    O 172.10.4.0/24 [110/51] via 172.10.1.1, 01:18:05, GigabitEthernet 0/1
    O IA 172.10.6.0/24 [110/51] via 172.10.2.2, 02:30:53, Serial 3/0
    O IA 172.10.9.0/24 [110/51] via 172.10.2.2, 02:30:53, Serial 3/0
    O IA 172.10.12.0/24 [110/2] via 172.10.1.1, 02:25:42, GigabitEthernet 0/1
    R3路由表:
    Gateway of last resort is no set
    O 172.10.1.0/24 [110/51] via 172.10.2.1, 02:32:13, Serial 2/0
    C 172.10.2.0/24 is directly connected, Serial 2/0
    C 172.10.2.2/32 is local host.
    C 172.10.3.0/24 is directly connected, GigabitEthernet 0/1
    C 172.10.3.1/32 is local host.
    O 172.10.4.0/24 [110/51] via 172.10.3.2, 01:19:10, GigabitEthernet 0/1
    C 172.10.6.0/24 is directly connected, GigabitEthernet 0/0.30
    C 172.10.6.1/32 is local host.
    C 172.10.9.0/24 is directly connected, GigabitEthernet 0/0.20
    C 172.10.9.1/32 is local host.
    O IA 172.10.12.0/24 [110/52] via 172.10.2.1, 02:26:51, Serial 2/0
    [110/52] via 172.10.3.2, 01:18:59, GigabitEthernet 0/1
    R4路由表:
    Gateway of last resort is no set
    O 172.10.1.0/24 [110/51] via 172.10.4.2, 01:25:39, Serial 3/0
    O 172.10.2.0/24 [110/51] via 172.10.3.1, 02:31:12, GigabitEthernet 0/0
    C 172.10.3.0/24 is directly connected, GigabitEthernet 0/0
    C 172.10.3.2/32 is local host.
    C 172.10.4.0/24 is directly connected, Serial 3/0
    C 172.10.4.1/32 is local host.
    O IA 172.10.6.0/24 [110/2] via 172.10.3.1, 02:31:12, GigabitEthernet 0/0
    O IA 172.10.9.0/24 [110/2] via 172.10.3.1, 02:31:12, GigabitEthernet 0/0
    O IA 172.10.12.0/24 [110/51] via 172.10.4.2, 01:25:39, Serial 3/0
    4.测试跟踪结果
    C:\Users\Administrator>ping 172.10.3.3

    正在 Ping 172.10.3.3 具有 32 字节的数据:
    来自 172.10.3.3 的回复: 字节=32 时间=14ms TTL=63
    来自 172.10.3.3 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.3.3 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.3.3 的回复: 字节=32 时间<1ms TTL=63

    172.10.3.3 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 14ms,平均 = 3ms

    C:\Users\Administrator>ping 172.10.9.2

    正在 Ping 172.10.9.2 具有 32 字节的数据:
    来自 172.10.9.2 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.9.2 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.9.2 的回复: 字节=32 时间<1ms TTL=63
    来自 172.10.9.2 的回复: 字节=32 时间<1ms TTL=63

    172.10.9.2 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 0ms,平均 = 0ms

    C:\Users\Administrator>ping 172.10.12.2

    正在 Ping 172.10.12.2 具有 32 字节的数据:
    来自 172.10.12.2 的回复: 字节=32 时间=46ms TTL=61
    来自 172.10.12.2 的回复: 字节=32 时间=38ms TTL=61
    来自 172.10.12.2 的回复: 字节=32 时间=40ms TTL=61
    来自 172.10.12.2 的回复: 字节=32 时间=41ms TTL=61

    172.10.12.2 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
    最短 = 38ms,最长 = 46ms,平均 = 41ms

    结论:各个主机之间均可互相通信。
    5.测试跟踪路径
    主机PC3到(PC4)172.10.12.2的路径:
    C:\Users\Administrator>tracert 172.10.12.2

    通过最多 30 个跃点跟踪
    到 NETPC014 [172.10.12.2] 的路由:

    1 <1 毫秒 <1 毫秒 <1 毫秒 172.10.6.1
    2 <1 毫秒 <1 毫秒 <1 毫秒 172.10.3.2
    3 43 ms 43 ms 43 ms 172.10.4.2
    4 50 ms 47 ms 47 ms NETPC014 [172.10.12.2]

    跟踪完成。

    关闭R1的S3/0接口
    R1#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    R1(config)#interface s3/0
    R1(config-if-Serial 3/0)#shutdown
    R1(config-if-Serial 3/0)#exit*Dec 25 18:42:24: %LINK-5-CHANGED: Interface Serial 3/0, changed state to administratively
    down.
    *Dec 25 18:42:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial 3/0, changed state to down.
    *Dec 25 18:42:24: %OSPF-5-ADJCHG: Process 1, Nbr 172.10.4.1-Serial 3/0 from Full to Down, KillNbr.

    R1(config)#

    关闭上述接口后,主机PC3到(PC4)172.10.12.2的路径:
    C:\Users\Administrator>tracert 172.10.12.2

    通过最多 30 个跃点跟踪
    到 NETPC014 [172.10.12.2] 的路由:

    1 <1 毫秒 <1 毫秒 <1 毫秒 172.10.6.1
    2 39 ms 39 ms 39 ms 172.10.2.1
    3 47 ms 39 ms 39 ms 172.10.1.1
    4 46 ms 43 ms 43 ms NETPC014 [172.10.12.2]

    跟踪完成。
    结论:断开某接口之后依然能ping通,但路径不同,设计成功,即实验成功。

    实验三 基于模拟互联网的网络协议分析
    一、课程设计(综合实验)的目的与要求
    在上面设计并实现的网络环境下,利用arp、ping、tracert等命令、浏览器和IIS、
    wireshark等截获所配置环境下的C/S端数据包,分类保存相关数据包文件,完成如下协
    议分析:
    以太网数据链路层帧格式分析;
    网络层分片;ICMP协议分析;
    ARP地址解析协议分析;
    TCP传输控制协议分析;(三次握手、数据传输、四次挥手)
    FTP协议分析;HTTP协议分析。
    二、设计(实验)正文
    配置应用服务器(Web服务器或FTP服务器),通过抓包工具分别在服务器端和客户端捕获数据。
    第一步,确定目标地址,选择ftp://172.10.6.2作为目标地址。
    第二歩,配置过滤器:针对协议进行过滤设置,ping使用的是ICMP协议,抓包前使用捕捉过滤器,过滤设置为icmp。
    第三步,启动抓包:点击【start】开始抓包,在命令提示符下键入ping ftp://172.10.6.2。
    第四步,停止抓包后,截取数据。
    第五步,分析数据包,选取一个数据包进行分析。
    1.以太网数据链路层帧格式分析

    目的物理地址:14:14:4b:31:e2:8a
    源物理地址:14:cf:92:e3:b1:1f
    类型:IPv4 (0x0800)
    2.网络层分片

    共分为三片:
    首部长度 总长度 MF DF 片偏移
    数据报片1 20 1500 1 0 0
    数据报片2 20 1500 1 0 1480
    数据报片3 20 68 0 0 2960

    3.ICMP协议分析

    Type为8的包为回射请求(Ping请求)
    Type为0的包为回射应答(Ping应答)
    从截获的ICMP数据可知,该ICMP类型为0,编码为0,即为回显应答;校验和真确,知道标识和序列号以及所包含的数据为3000字节。

    4.ARP地址解析协议分析

    第一行为ARP进程在本局域网上广播的一个ARP请求分组:信息为:我的IP地址为172.10.9.2,硬件地址为14:cf:92:e3:b1:1f,我想知道IP地址为172.10.9.1的硬件地址。
    第二行为ARP响应分组:信息为:我的IP地址为172.10.9.1,硬件地址为14:14:4b:31:e2:8a。
    5.TCP传输控制协议分析

    TCP首部格式

    源端口:1577
    目的端口:21
    序号:56
    确认号:295
    标志:
    在TCP首部中有6个标志比特。
    URG(Urgent Pointer Field Significant):紧急指针标志,用来保证TCP连接不被中断,并且督促中间设备尽快处理这些数据
    ACK(Acknowledgement Field Signigicant):确认号字段,该字段为1时表示应答字段有效,即TCP应答号将包含在TCP报文中。
    PSH(Push Function): 推送功能,所谓推送功能指的是接收端在接收到数据后立即推送给应用程序,而不是在缓冲区中排队。
    RST(Reset the connection): 重置连接,不过一搬表示断开一个连接。
    SYN(Synchronize sequence numbers):同步序列号,用来发起一个连接请求
    FIN(No more data from sender):表示发送端发送任务已经完成(既断开连接)
    6.FTP协议分析

    FTP协议有两种工作方式:PORT方式和PASV方式,中文意思为主动式和被动式。
    

    PORT(主动)方式的连接过程是:客户端向服务器的FTP端口(默认是21)发送连接请求,服务器接受连接,建立一条命令链路。当需要传送数据时,客户端在命令链路上用PORT命令告诉服务器:“我打开了XXXX端口,你过来连接我”。于是服务器从20端口向客户端的XXXX端口发送连接请求,建立一条数据链路来传送数据。
    PASV(被动)方式的连接过程是:客户端向服务器的FTP端口(默认是21)发送连接请求,服务器接受连接,建立一条命令链路。当需要传送数据时,服务器在命令链路上用PASV命令告诉客户端:“我打开了XXXX端口,你过来连接我”。于是客户端向服务器的XXXX端
    FTP是基于TCP的,三次握手建立连接之后服务器端向客户端发送自己的相关信息。
    状态码220表示服务准备就绪,230 表示登陆成功,421表示服务关闭。
    7.HTTP协议分析

    请求行:url为相对URL
    User-Agent:指明了发出请求的用户代理的浏览器的一些信息
    Accept-Encoding: gzip, deflate 指明该浏览器支持的编码格式,这里是压缩编码的方式。
    Accept-Language:指明了该浏览器支持的语言类型
    首部行:主机为172.10.6.2
    用户代理为Mozilla/4.0
    \r\n 代表下面的信息就是请求体的实体部分了。
    三、课程设计(综合实验)总结或结论
    在本次试验中学到了很多实际的知识,首先是认识性实验,其中包括了下一步设计实验中所需要的基本操作,由于每个实验都有很详细的步骤,因此完成的非常顺利,也没有遇到过什么困难,其中有些实验后面用不到,因此只做了基本的操作,只有路由器的配置、交换机的配置、ospf设置等几个做了详细的研究。
    其次是互联网的模拟,主要的部分在于拓扑图的设计和IP的分配上。由于开始认识不足,设计的拓扑非常的复杂,比如用三层交换机当成核心交换机后来设置VLAN,还有将路由器连接了三四个端口,由于这些错误导致进度很慢。在一-步步尝试修改后,拓扑图变得较为简单可行,路由器通过使用串口来解决多端口问题。我们遇到最大的问题则是在PC的IP分配上,由于开始没有认识到要按照拓扑图上对应的PC来分配地址,只是随机给四台电脑分配,所以连好拓扑分好IP配置好后,PC之间怎么也ping不通,而其他的都可以ping通,但是我们始终没有意识到是PC的问题,以为是其他原因,因此花费了相当多的时间在修改拓扑图,修改IP上,最后实在没有办法,请教老师才终于解决了问题。
    最后是抓包分析,这个实验我们做的最慢,因为对软件的使用非常不清楚,而且也确实是不明白抓包是怎样一个过程,经过查阅各种资料加上老师的耐心指导,终于成功实现。抓包成功后的主要的重心还是在分析上面。以前只听说过抓包,却不明白其中的道理,通过自己做实验,让我把那些死板的知识变的活跃了,非常珍惜这些让我们能够自己动手的机会。
    总的来说,这次的课程设计,充分锻炼了自己的动手能力及学到一些课程内其他没有学到过知识,感觉收获是颇多的!也让我明白,单单掌握理论知识还是远远不够的,能够要学以致用才是我们的最终目的。
    四、参考文献
    [1] 谢希仁.《计算机网络》. 北京:电子工业出版社, 第五版. 2008.

    展开全文
  • 计算机网络课程设计计算机网络课程设计计算机网络课程设计计算机网络课程设计
  • 计算机网络课程设计计算机网络课程设计计算机网络课程设计计算机网络课程设计计算机网络课程设计计算机网络课程设计
  • 计算机网络课程设计计算机网络课程设计计算机网络课程设计计算机网络课程设计
  • 计算机 网络课程设计

    2010-12-26 22:37:31
    计算机网络课程设计,大家可以都来参考一下啊啊啊啊
  • 计算机网络 课程设计

    2012-01-07 20:58:15
    课程设计绝对有帮助 提供文档和程序源代码和运行结果截图
  • 综合网络大量资源,节约大家时间:大学校园网网络建设方案的设计 高校校园网组网实例 计算机网络课程设计-学校校园网络规划 计算机网络课设 计算机网络校园网设计 兰州市第三十三中学校园网规划 苏州职业大学校园网...
  • 计算机网络课程设计计算机网络课程总结
  • 广工计算机网络课程设计
  • 计算机网络课程设计信息工程系网络工程方案设计,计算机网络课程设计
  • 吉林大学软件学院 计算机网络课程设计 套接字编程 VC
  • 计算机网络课程设计要求,请勿在未经授权的情况下上传任何涉及著作权侵权的资源,除非该资源完全由您个人创作。如有侵权立即删除
  • 计算机网络课程设计嗅探器,codeblock编程,完整代码。
  • 广东工业大学物联网计算机网络课程设计 广东工业大学物联网计算机网络课程设计 广东工业大学物联网计算机网络课程设计
  • 四川大学网络教育学院 课程设计说明书 课程名称 校外学习中心 计算机网络课程设计 专 层 业 次 计算机应用技术 专科 年 级 2013 级秋季 学生姓名 学 号 2016 年 3 月 18 日 目录 需求分析1 家庭网络需求概况2 方案...
  • 有关于高校计算机网络课程设计的参考资料,便于学生掌握和应用

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,125
精华内容 1,250
关键字:

计算机网络课程设计