精华内容
下载资源
问答
  • 计算机网络实验归纳总结报告.doc
    2021-06-25 08:27:25

    西安交通大学软件学院-计算网络实验

    PAGE 5

    计算机网络实验报告

    TOC \o "1-3" \h \z \u 实验1:组网试验 4

    1.1.1地点 4

    1.1.2课程目标 5

    1.1.3 机位 5

    1.2.1 实验目的 5

    1.2.2 实验内容 5

    1.2.3 实验环境与分组 5

    1.2.4 实验组网 5

    1.2.5 实验步骤 6

    1.2.6实验结果及分析 6

    2.1.1地点 8

    2.1.2 课程目标 8

    2.1.3 机位 8

    2.2.1 实验目的 8

    2.2.2 实验内容 8

    2.2.3 实验环境与分组 9

    2.2.4 实验组网 9

    2.2.5 实验步骤 9

    2.2.6 实验结果与分析 9

    2.3.1遇到的问题 12

    实验3:VLAN的配置与分析 12

    3.1.1 实验地点 12

    3.1.2 实验目标 12

    3.1.3 实验机位 12

    3.2.1 实验目的 12

    3.2.2 实验内容 13

    3.2.3 实验环境与分组 13

    3.2.4 实验组网 13

    3.2.5 实验步骤 14

    实验4:ARP协议分析 16

    4.1.1 实验地点 16

    4.1.2 实验目标 16

    4.1.3 实验机位 17

    4.2.1 实验目的 17

    4.2.2 实验内容 17

    4.2.3 实验环境与分组 17

    4.2.4 实验组网 17

    4.2.5 实验过程及结果分析 18

    5.1.1 实验地点 21

    5.1.2 实验目标 21

    5.2.1 实验目的 21

    5.2.3 实验环境与分组 21

    5.2.4 实验组网 22

    5.2.5 实验过程及结果分析 22

    6.1.1 实验地点 24

    6.1.2 实验目标 24

    6.1.3 实验机位 24

    6.2.1 实验目的 24

    6.2.2 实验内容 24

    6.2.3 实验环境与分组 24

    6.2.4 实验组网 25

    6.2.5 实验过程及结果分析 25

    实验7:静态路由及RIP协议配置 26

    7.1.1 实验地点 26

    7.1.2 实验目标 26

    7.1.3 实验机位 26

    7.2.1 实验目的 27

    7.2.2 实验内容 27

    7.2.3 实验环境与分组 27

    7.2.4 实验组网 27

    7.2.5 实验过程及结果分析 28

    8.1.1 实验地点 30

    8.1.2 实验目标 30

    8.1.3 实验机位 30

    8.2.1 实验目的 30

    8.2.2 实验内容 30

    8.2.3 实验环境与分组 30

    8.2.4 实验组网 31

    8.2.5 实验过程及结果分析 31

    实验9:IPV6实验 33

    9.1.1 实验地点 33

    9.1.2 实验目标 33

    9.1.3 实验机位 33

    9.2.1 实验目的 33

    9.2.2 实验内容 33

    9.2.3 实验环境与分组 33

    9.2.4实验组网 34

    9.2.5 实验步骤 34

    9.2.6 实验结果及分析 35

    实验10:OSPF邻居建立及报文交换过程分析 35

    10.1.1 实验地点 36

    10.1.2 实验目标 36

    10.1.3 实验机位 36

    10.2.1 实验目的 36

    10.2.2 实验内容 36

    10.2.3 实验环境与分组 36

    10.2.4实验组网 37

    实验总结 40

    实验建议 40

    参考资料 41

    实验1:组网试验

    1.1.1地点

    西一计算机网络实验室

    1.1.2课程目标

    掌握对路由器和交换机的配置工作,熟悉网络实验环境

    1.1.3 机位

    PC4

    1.2.1 实验目的

    掌握用路由器、交换机进行简单组网的方法,理解交换机、路由器的工作原理

    1.2.2 实验内容

    使用路由器和交换机进行组网,实现各PC间的互联互通

    1.2.3 实验环境与分组

    路由器1台,交换机2台;

    每组2-4名同学,每人一台PC,协同进行实验。

    1.2.4 实验组网

    图1-1 给出了本实验的组网实验示意图,鼓励各小组灵活自定义IP分配。

    1.2.5 实验步骤

    步骤1:按图连接好各设备,配置各PC的IP地址和默认网关。

    步骤2

    更多相关内容
  • 计算机网络实验总结

    2022-01-06 10:27:59
    验证性实验 ipconfig 实作一 使用 ipconfig/all 查看自己计算机网络配置,尽可能明白每行的意思,特别注意 IP 地址、子网掩码 Subnet Mask、网关 Gateway。 输入命令之后,可以看到本电脑的IP地址、子网掩码...

    目录

    验证性实验

    ipconfig

    实作一

    实作二

    ping

    实作一

    实作二

    tracert

    实作一

    ARP

    实作一

    实作三

    DHCP

    实作一

    netstat

    实作一

    DNS

    实作一

    实作三

     cache

    实作一

    Wireshark 实验

    数据链路层

    实作一 熟悉 Ethernet 帧结构

    实作二 了解子网内/外通信时的 MAC 地址

    实作三 掌握 ARP 解析过程

    网络层

    实作一 熟悉 IP 包结构

    实作二 IP 包的分段与重组

    实作三 考察 TTL 事件

    传输层

    实作一 熟悉 TCP 和 UDP 段结构

    实作二 分析 TCP 建立和释放连接

    应用层

    实作一 了解 DNS 解析

     Cisco Packet Tracer 实验

    直接连接两台 PC 构建 LAN

    用交换机构建 LAN

    交换机接口地址列表

    生成树协议(Spanning Tree Protocol)

    路由器配置初步

    虚拟局域网 VLAN


    验证性实验

    ipconfig

    实作一

    使用 ipconfig/all 查看自己计算机的网络配置,尽可能明白每行的意思,特别注意 IP 地址、子网掩码 Subnet Mask、网关 Gateway。

    输入命令之后,可以看到本电脑的IP地址、子网掩码和网关如下

    实作二

    使用 ipconfig/all 查看旁边计算机的网络配置,看看有什么异同。

     

    问题

    你的计算机和旁边的计算机是否处于同一子网,为什么?

    通过上述的观察两个电脑的IP地址和子网掩码,可以知道两台电脑不在同一个子网当中,因为两个电脑的ip地址分别与自己对于的子网掩码进行与运算之后,得到的网关并不是同一个。

    ping

    实作一

    要测试到某计算机如 重庆交通大学 Web 服务器的连通性,可以使用 ping www.cqjtu.edu.cn 命令,也可直接使用 IP 地址。

     请掌握使用该命令后屏幕显示的反馈回来信息的意思,如:TTL、时间等。

    TTL是指每一个被发送出去的IP包的存活的跳数,当信息报在网络中进行传输的时候,每经过一个路由器,TTL的值就减一,当其变为0的时候,该信息包就被抛弃。

    时间是指返回字节的延迟。

    实作二

    使用 ping/? 命令了解该命令的各种选项并实际使用。

    TroubleShooting

    假设你不能 ping 通某计算机或 IP,但你确定该计算机和你之间的网络是连通的,那么可能的原因是什么?该如何处理能保证 ping 通?

    第一步,先试着去ping12.0.0.1,测试自己的计算机的工作状态,如果没有问题,则说明自己的电脑网络连接工作正常,如果不能ping通,这说明问题出现在本机的网络连接。

    第二步可以去ping同一个子网当中的其他计算机,如果能够ping通,说明子网内部的网络连接正常,如果不能,则说明问题出在本机的网络出口和交换机之间,需要进行检查。

    第三步,去ping自己网络的网关,看是否能够ping通,如果能ping通,这说明自己的子网的出口工作是正常的,如果不行的话则问题出现在网关。

    第四步可以去ping一下其他网址,例如百度,如果无法ping通,则问题出在网关之外。

    tracert

    实作一

    要了解到某计算机如 www.baidu.com 中间经过了哪些节点(路由器)及其它状态,可使用 tracert www.baidu.com 命令,查看反馈的信息,了解节点的个数。

    可通过网站 http://ip.cn 查看这些节点位于何处,是哪个公司的,大致清楚本机到百度服务器之间的路径。

    查询120.241.48.190可知为广州深圳移动

     ping.pe 这个网站可以探测从全球主要的 ISP 到某站点如 棋歌的教学网站 的线路状态,当然也包括各线路到该主机的路由情况。请使用浏览器访问 http://ping.pe/qige.io 进行了解。

    问题一

    tracert 能告诉我们路径上的节点以及大致的延迟等信息,那么它背后的原理是什么?本问题可结合第二部分的 Wireshark 实验进行验证。

     tracert送出一个TTL是1的IP 数据包到目的地,当路径上的第一个路由器收到这个数据包时,它将TTL减1,则TTL变为0,所以该路由器会将此数据包丢掉,并送回一个消息,当tracert 收到这个消息后,可以知道这个路径上存在着路由器,接着tracert 再送出另一个TTL是2 的数据包,发现第2 个路由器...... 这个重复的动作一直持续到抵达目的地。

    问题二

    在以上两个实作中,如果你留意路径中的节点,你会发现无论是访问百度还是棋歌教学网,路径中的第一跳都是相同的,甚至你应该发现似乎前几个节点都是相同的,你的解释是什么?

    因为我们的电脑网络都是从本机出发,然后通过重庆交通大学的交换机进入通信子网,所以第一跳都是一样的。

    问题三

    在追踪过程中,你可能会看到路径中某些节点显示为 * 号,这是发生了什么?

    说明在追踪过程中,该节点并没有收到具体的反馈信息。

    ARP

    实作一

    运行 arp -a 命令查看当前的 arp 缓存, 请留意缓存了些什么

    缓存了一些MAC地址

     实作二

    请使用 arp /? 命令了解该命令的各种选项。

    实作三

    一般而言,arp 缓存里常常会有网关的缓存,并且是动态类型的。

    假设当前网关的 IP 地址是 192.168.0.1,MAC 地址是 5c-d9-98-f1-89-64,请使用 arp -s 192.168.0.1 5c-d9-98-f1-89-64 命令设置其为静态类型的。

    TroubleShooting

    你可能会在实作三的操作中得到 "ARP 项添加失败: 请求的操作需要提升" 这样的信息,表示命令没能执行成功,你该如何解决?

    netsh i i show in找到指定的ldx

    netsh -c “i ‘” add neighbors [ldx] [ip地址] [mac地址] 进行修改

    问题

    在实作三中,为何缓存中常常有网关的信息?

    我们将网关或其它计算机的 arp 信息设置为静态有什么优缺点?

    因为缓存会记录你访问过的pc网课和MAC物理地址

    静态分配方式是给每一个计算机都分配一个固定的IP地址,这样方便管理。但是其缺点是静态地址很有可能会被非法分子盗用,会对网络的正常使用造成影响,也会给用户造成不必要的损失。

    DHCP

    实作一

    一般地,我们自动获取的网络配置信息包括:IP 地址、子网掩码、网关 IP 以及 DNS 服务器 IP 等。使用 ipconfig/release 命令释放自动获取的网络配置,并用 ipconfig/renew 命令重新获取,了解 DHCP 工作过程和原理。

     问题

    在Windows系统下,如果由于某种原因计算机不能获取 DHCP 服务器的配置数据,那么Windows将会根据某种算法自动配置为 169.254.x.x 这样的 IP 地址。显然,这样的 IP 以及相关的配置信息是不能让我们真正接入 Internet 的,为什么?既然不能接入 Internet,那么Winodws系统采用这样的方案有什么意义?

     自动配置IP地址和信息只是短暂的解决计算机不能获取DHCP服务器的配置数据的问题,如果需要接入Internet还是需要计算机的正确IP地址。

    netstat

    实作一

    Windows 系统将一些常用的端口与服务记录在 C:\WINDOWS\system32\drivers\etc\services 文件中,请查看该文件了解常用的端口号分配。

    DNS

    实作一

    Windows 系统将一些固定的/静态的 DNS 信息记录在 C:\WINDOWS\system32\drivers\etc\hosts 文件中,如我们常用的 localhost 就对应 127.0.0.1 。请查看该文件看看有什么记录在该文件中。

     

     实作二

    解析过的 DNS 记录将会被缓存,以利于加快解析速度。请使用 ipconfig /displaydns 命令查看。我们也可以使用 ipconfig /flushdns 命令来清除所有的 DNS 缓存。

    实作三

    使用 nslookup qige.io 命令,将使用默认的 DNS 服务器查询该域名。当然你也可以指定使用 CloudFlare(1.1.1.1)或 Google(8.8.8.8) 的全球 DNS 服务器来解析,如:nslookup qige.io 8.8.8.8,当然,由于你懂的原因,这不一定会得到正确的答案。

     

     cache

    实作一

    打开 Chrome 或 Firefox 浏览器,访问 https://qige.io ,接下来敲 F12 键 或 Ctrl + Shift + I 组合键打开开发者工具,选择 Network 面板后刷新页面,你会在开发者工具底部看到加载该页面花费的时间。请进一步查看哪些文件被 cache了,哪些没有。

     实作二

    接下来仍在 Network 面板,选择 Disable cache 选项框,表明当前不使用 cache,页面数据全部来自于 Internet,刷新页面,再次在开发者工具底部查看加载该页面花费的时间。你可比对与有 cache 时的加载速度差异。

    有cache时要快很多

    Wireshark 实验

    数据链路层

    实作一 熟悉 Ethernet 帧结构

    使用 Wireshark 任意进行抓包,熟悉 Ethernet 帧的结构,如:目的 MAC、源 MAC、类型、字段等。

      问题

    你会发现 Wireshark 展现给我们的帧中没有校验字段,请了解一下原因。

    因为有的时候的校验会由网卡进行计算,这个时候wireshark抓到的本机发送的数据包和校验和都是错误的,所以关闭了校验。

    实作二 了解子网内/外通信时的 MAC 地址

    ping 你旁边的计算机(同一子网),同时用 Wireshark 抓这些包(可使用 icmp 关键字进行过滤以利于分析),记录一下发出帧的目的 MAC 地址以及返回帧的源 MAC 地址是多少?这个 MAC 地址是谁的?

    Src::56:3b:79:d8:15:6e 我的

    Dst:16:12:1f:40:2a:0d 旁边同学网关的

    然后 ping qige.io (或者本子网外的主机都可以),同时用 Wireshark 抓这些包(可 icmp 过滤),记录一下发出帧的目的 MAC 地址以及返回帧的源 MAC 地址是多少?这个 MAC 地址是谁的?

    Src: 56:3b:79:d8:15:6e  我的

    Dst: 16:12:1f:40:2a:0d  棋歌网关的

    再次 ping www.cqjtu.edu.cn (或者本子网外的主机都可以),同时用 Wireshark 抓这些包(可 icmp 过滤),记录一下发出帧的目的 MAC 地址以及返回帧的源 MAC 地址又是多少?这个 MAC 地址又是谁的?

    Src: 56:3b:79:d8:15:6e  我的

    Dst: 16:12:1f:40:2a:0d 重庆交通大学网关的

     问题

    通过以上的实验,你会发现:

    1. 访问本子网的计算机时,目的 MAC 就是该主机的
    2. 访问非本子网的计算机时,目的 MAC 是网关的

    请问原因是什么

    因为访问非子网计算机是通过路由器转接的,MAC地址是接入路由器端口的地址,再通过路由器发给相应计算机。

    实作三 掌握 ARP 解析过程

    1. 为防止干扰,先使用 arp -d * 命令清空 arp 缓存
    2. ping 你旁边的计算机(同一子网),同时用 Wireshark 抓这些包(可 arp 过滤),查看 ARP 请求的格式以及请求的内容,注意观察该请求的目的 MAC 地址是什么。再查看一下该请求的回应,注意观察该回应的源 MAC 和目的 MAC 地址是什么。

    网络层

    实作一 熟悉 IP 包结构

    使用 Wireshark 任意进行抓包(可用 ip 过滤),熟悉 IP 包的结构,如:版本、头部长度、总长度、TTL、协议类型等字段。

    问题

    为提高效率,我们应该让 IP 的头部尽可能的精简。但在如此珍贵的 IP 头部你会发现既有头部长度字段,也有总长度字段。请问为什么?

     为了在传输的时候识别IP长度节约时间

    实作二 IP 包的分段与重组

    根据规定,一个 IP 包最大可以有 64K 字节。但由于 Ethernet 帧的限制,当 IP 包的数据超过 1500 字节时就会被发送方的数据链路层分段,然后在接收方的网络层重组。

    缺省的,ping 命令只会向对方发送 32 个字节的数据。我们可以使用 ping 202.202.240.16 -l 2000 命令指定要发送的数据长度。此时使用 Wireshark 抓包(用 ip.addr == 202.202.240.16 进行过滤),了解 IP 包如何进行分段,如:分段标志、偏移量以及每个包的大小等

    问题

    分段与重组是一个耗费资源的操作,特别是当分段由传送路径上的节点即路由器来完成的时候,所以 IPv6 已经不允许分段了。那么 IPv6 中,如果路由器遇到了一个大数据包该怎么办?

    选择一个能支持该数据报的链路发送

    实作三 考察 TTL 事件

    在 IP 包头中有一个 TTL 字段用来限定该包可以在 Internet上传输多少跳(hops),一般该值设置为 64、128等。

    在验证性实验部分我们使用了 tracert 命令进行路由追踪。其原理是主动设置 IP 包的 TTL 值,从 1 开始逐渐增加,直至到达最终目的主机。

    请使用 tracert www.baidu.com 命令进行追踪,此时使用 Wireshark 抓包(用 icmp 过滤),分析每个发送包的 TTL 是如何进行改变的,从而理解路由追踪原理。

     每次到达一个新节点返回一个新节点,TTL加1。

     问题

    在 IPv4 中,TTL 虽然定义为生命期即 Time To Live,但现实中我们都以跳数/节点数进行设置。如果你收到一个包,其 TTL 的值为 50,那么可以推断这个包从源点到你之间有多少跳?

    50跳

    传输层

    实作一 熟悉 TCP 和 UDP 段结构

    用 Wireshark 任意抓包(可用 tcp 过滤),熟悉 TCP 段的结构,如:源端口、目的端口、序列号、确认号、各种标志位等字段。

    用 Wireshark 任意抓包(可用 udp 过滤),熟悉 UDP 段的结构,如:源端口、目的端口、长度等。

     

    问题

    由上大家可以看到 UDP 的头部比 TCP 简单得多,但两者都有源和目的端口号。请问源和目的端口号用来干什么?

    端口号可以用来唯一标识一个进程,源端口号标识发起通讯的进程,目的端口号标识接受通讯的进程。

    实作二 分析 TCP 建立和释放连接

    1. 打开浏览器访问 qige.io 网站,用 Wireshark 抓包(可用 tcp 过滤后再使用加上 Follow TCP Stream),不要立即停止 Wireshark 捕获,待页面显示完毕后再多等一段时间使得能够捕获释放连接的包。
    2. 请在你捕获的包中找到三次握手建立连接的包,并说明为何它们是用于建立连接的,有什么特征。
    3. 请在你捕获的包中找到四次挥手释放连接的包,并说明为何它们是用于释放连接的,有什么特征。

     

     当seq为1的时候,表示数据以及被发送出去

     ack为1的时候表示已经建立握手连接成功

    当fin为set的时候,表示关闭连接

    应用层

    实作一 了解 DNS 解析

    1. 先使用 ipconfig /flushdns 命令清除缓存,再使用 nslookup qige.io 命令进行解析,同时用 Wireshark 任意抓包(可用 dns 过滤)。
    2. 你应该可以看到当前计算机使用 UDP,向默认的 DNS 服务器的 53 号端口发出了查询请求,而 DNS 服务器的 53 号端口返回了结果。
    3. 可了解一下 DNS 查询和应答的相关字段的含义

     

    问题

    刷新一次 qige.io 网站的页面同时进行抓包,你会发现不少的 304 代码的应答,这是所请求的对象没有更改的意思,让浏览器使用本地缓存的内容即可。那么服务器为什么会回答 304 应答而不是常见的 200 应答?

     因为当你第一次访问并且成功的时候就会返回200,浏览器会帮你下载当前网页的一些文件,作为缓存存放起来,当这个页面没有改变的时候,再次进入就会返回304,如果这个页面改变,就会重新获取,返回200。

     Cisco Packet Tracer 实验

    直接连接两台 PC 构建 LAN

    将两台 PC 直接连接构成一个网络。注意:直接连接需使用交叉线。

    进行两台 PC 的基本网络配置,只需要配置 IP 地址即可,然后相互 ping 通即成功。

    用交换机构建 LAN

    构建如下拓扑结构的局域网:

    各PC的基本网络配置如下表:

    机器名

    IP

    子网掩码

    PC0

    192.168.1.1

    255.255.255.0

    PC1

    192.168.1.2

    255.255.255.0

    PC2

    192.168.2.1

    255.255.255.0

    PC3

    192.168.2.2

    255.255.255.0

     主机5ping主机6

     问题

    1. PC0 能否 ping 通 PC1、PC2、PC3 ?
    2. PC3 能否 ping 通 PC0、PC1、PC2 ?为什么?
    3. 将 4 台 PC 的掩码都改为 255.255.0.0 ,它们相互能 ping 通吗?为什么?
    4. 使用二层交换机连接的网络需要配置网关吗?为什么?

     1.不可以

    2.不可以,5,6处于同一个子网,可以ping通,但是8只能ping通7,无法ping通5、6。

    3.可以。因为这样他们就处于同一个子网

    4.需要,没有网关的话就无法与其他网络进行通信

    交换机接口地址列表

    二层交换机是一种即插即用的多接口设备,它对于收到的帧有 3 种处理方式:广播、转发和丢弃(请弄清楚何时进行何种操作)。那么,要转发成功,则交换机中必须要有接口地址列表即 MAC 表,该表是交换机通过学习自动得到的!

    仍然构建上图的拓扑结构,并配置各计算机的 IP 在同一个一个子网,使用工具栏中的放大镜点击某交换机如左边的 Switch3,选择 MAC Table,可以看到最初交换机的 MAC 表是空的,也即它不知道该怎样转发帧(那么它将如何处理?),用 PC0 访问(ping)PC1 后,再查看该交换机的 MAC 表,现在有相应的记录,请思考如何得来。随着网络通信的增加,各交换机都将生成自己完整的 MAC 表,此时交换机的交换速度就是最快的!

    生成树协议(Spanning Tree Protocol)

    交换机在目的地址未知或接收到广播帧时是要进行广播的。如果交换机之间存在回路/环路,那么就会产生广播循环风暴,从而严重影响网络性能。

    而交换机中运行的 STP 协议能避免交换机之间发生广播循环风暴。

    只使用交换机,构建如下拓扑:

    这是初始时的状态。我们可以看到交换机之间有回路,这会造成广播帧循环传送即形成广播风暴,严重影响网络性能。

    随后,交换机将自动通过生成树协议(STP)对多余的线路进行自动阻塞(Blocking),以形成一棵以 Switch4 为根(具体哪个是根交换机有相关的策略)的具有唯一路径树即生成树!

    经过一段时间,随着 STP 协议成功构建了生成树后,Switch5 的两个接口当前物理上是连接的,但逻辑上是不通的,处于Blocking状态(桔色)如下图所示:

    在网络运行期间,假设某个时候 Switch4 与 Switch5 之间的物理连接出现问题(将 Switch4 与 Switch5 的连线剪掉),则该生成树将自动发生变化。Switch5 上方先前 Blocking 的那个接口现在活动了(绿色),但下方那个接口仍处于 Blocking 状态(桔色)。如下图所示:

    路由器配置初步

    我们模拟重庆交通大学和重庆大学两个学校的连接,构建如下拓扑:

    说明一

    交通大学与重庆大学显然是两个不同的子网。在不同子网间通信需通过路由器。

    路由器的每个接口下至少是一个子网,图中我们简单的规划了 3 个子网:

    1. 左边路由器是交通大学的,其下使用交换机连接交通大学的网络,分配网络号 192.168.1.0/24,该路由器接口也是交通大学网络的网关,分配 IP 为 192.168.1.1
    2. 右边路由器是重庆大学的,其下使用交换机连接重庆大学的网络,分配网络号 192.168.3.0/24,该路由器接口也是重庆大学网络的网关,分配 IP 为 192.168.3.1
    3. 两个路由器之间使用广域网接口相连,也是一个子网,分配网络号 192.168.2.0/24

    说明二

    现实中,交通大学和重庆大学的连接是远程的。该连接要么通过路由器的光纤接口,要么通过广域网接口即所谓的 serial 口(如拓扑图所示)进行,一般不会通过双绞线连接(为什么?)。

    下面我们以通过路由器的广域网口连接为例来进行相关配置。请注意:我们选用的路由器默认没有广域网模块(名称为 WIC-1T 等),需要关闭路由器后添加,然后再开机启动。

    说明三

    在模拟的广域网连接中需注意 DCE 和 DTE 端(连线时线路上有提示,带一个时钟标志的是 DCE 端。有关 DCE 和 DTE 的概念请查阅相关资料。),在 DCE 端需配置时钟频率 64000

    说明四

    路由器有多种命令行配置模式,每种模式对应不同的提示符及相应的权限。

    请留意在正确的模式下输入配置相关的命令。

    • User mode:用户模式
    • Privileged mode:特权模式
    • Global configuration mode:全局配置模式
    • Interface mode:接口配置模式
    • Subinterface mode:子接口配置模式

    说明五

    在现实中,对新的路由器,显然不能远程进行配置,我们必须在现场通过笔记本的串口与路由器的 console 接口连接并进行初次的配置(注意设置比特率为9600)后,才能通过网络远程进行配置。这也是上图左上画出笔记本连接的用意。

    说明六

    在路由器的 CLI 界面中,可看到路由器刚启动成功后,因为无任何配置,将会提示是否进行对话配置(Would you like to enter the initial configuration dialog?),因其步骤繁多,请选择 NO

    问题

    现在交通大学内的各 PC 及网关相互能 ping 通,重庆大学也类似。但不能从交大的 PC ping 通重大的 PC,反之亦然,也即不能跨子网。为什么?

    因为在路由表中不能达到对方的路由路径。

    虚拟局域网 VLAN

    思考

    分析一下当前为何不同 VLAN 中的 PC 不能通信?网关在此起什么作用?我们的网关又在何处?如何发起广播测试?

    VLAN可以划分网络,同一个VLAN的端口可以不通过路由器直接通信,但是不同的VLAN之间需要路由器。网关的作用是进行协议转换。如果引入三层设备就可以发起广播测试。

    展开全文
  • 计算机网络实验总结.docx
  • 2021年计算机网络实验总结.pdf
  • 电子科技大学计算机网络实验总结报告二.docx
  • 计算机网络思科实验报告精选

    千次阅读 2021-07-28 05:17:53
    很多计算机专业的同学应该对于做实验已经是见怪不怪了,那么实验就避免不了要写实验报告,那么报告应该怎么写呢?不是很清楚的朋友可以看看下面这个范文。一、实验目的假设某校园网通过1台三层交换机连到校园网出口...

    很多计算机专业的同学应该对于做实验已经是见怪不怪了,那么实验就避免不了要写实验报告,那么报告应该怎么写呢?不是很清楚的朋友可以看看下面这个范文。

    一、实验目的

    假设某校园网通过1台三层交换机连到校园网出口路由器,路由器再和校园外的另一台路由器相接,现做适当配置,实现校园网内部主机与校园网外部主机的相互通信。

    通过对网络设备的连通和对拓扑的分析,加深对常见典型局域网拓扑的理解;通过路由建立起网络之间的连接,熟悉交换机、路由器的基本操作命令,了解网络路由的设计与配置。

    二、实验仪器或设备

    二层交换机五台、三层交换机-一台,路由器两台,学生实验主机五台及一台服务器。

    三、总体设计(设计原理、设计方案及流程等)

    1、三层交换机上划分vlan2vlan3vlan4vlan5vlan6并且配置dhcp。

    2、物理学院、化学院最多分计算机有250台,生物政管学院最多有120台计算机和服务器,需要对生物和政管学院划分子网。

    3、三层交换机和出口路由器ri相连。

    4、局域网内部三层交换机和路由器ri间利用ripv2实现全网互通。.

    5、pcopc lpc2pc3pc4的ip地址动态获得,对pc5配置ip172. 16. 1.2wwwwwmcin.com

    四、实验步骤(包括主要步骤、代码分析等)le

    按照如图拓扑图连接好设备

    bf743161e101a73916c5bff800a84b06.png

    (1)划分vlan并 且配置端口ip。

    s0(config)#vlan2

    s0(config- vlan)#exit

    s0(config)# intvlan2

    s0(config- if)#ipadd210.42.242.1255.255.255.0

    s0(c onfig-if)#nosh

    so(config)#intf0/2

    s0(c onfig.- if)#sw modacc

    s0(config- if)#swaccvlan2

    s0(config- if)#exit

    s0(c onfig)#vlan3

    s0(config- vlan)#exit

    s0(config)# intvlan3

    s0(config if# ipadd210.42.243.1255.255.255.0

    s0(config- if)#nosh

    s0(config- if)#exit

    s0(config )#intf0/3

    -i0)#swm

    s0(c onfigf)#swaccvlan3

    s0(config- i)#exit

    s0(config)#vlan4

    s0(config- vlan)#exit

    s0(config)# intvlan4

    s0(config- if)#ipadd210.42.2441255.255.255. 128

    sofonfigin#nosh

    soconfigidtexit

    s0(config)# intf0/4

    s0(config-if)#s wmodacc

    s0(c onfig-if)#s waccvlan4

    s0(config- if)#exit

    s0(c onfig)#vlan5

    s0(config- vlan)#exit

    s0(config )# intvlan5

    s0(config- if)# ipadd210.42.244.129255.255.255. 128

    #padd

    s0(config-if)#nosh

    s0(config- if#exit

    soconfig)#intf0/5

    s0(c onfig- if)#swmodacc

    s0(config- if)#swac cvlan5

    s0(config- if)#exit

    s0(c onfig)#vlan6

    s0(config- vlan)#exit

    s0(config)# intvlan6

    s0(config- i)# ipadd192.168.2.1255.255.255.0

    so(config-if)#nosh

    s0(config i)#exit

    s0(config)inttf0/1

    s0(config-if)#swmodacc

    s0(c onfigif)#s waccvlan6

    (3)给三层交换机配置dhcp

    s0(config)#ipdheppoljsj2

    s0(dhc p-config)#net210.42.242.0255.255.255.0

    s0(dhcp- cofig)#efault-routr210.42.242.1

    s0( dhcp-config)#dns210.42.241.2

    s0( dhc p-config)#e xit

    s0(c onfig)#ipdhc ppooljsj3

    s0( dhcp-c onfig)#net210.42.243.0255.255.255.0

    s0( dhc p-config)#default-router210.42.243.1

    s0(dhc p-config)#dns210.42.241.2

    s0( dhe p- config)#exit

    so(config)ipdh

    hppooljsj4

    s0(dhep-config)#net210.42.244.0255.255.255.128

    s0( dhep-c onfig)#dns210.42.241.2

    s0( dhe p-config)#exit

    s0(c onfig)#ipdhc ppooljsjs

    s0( dhe p-c onfig )#net210.42.244.128255.255.255.128

    s0(dhcp-config)#default-router210.42.244.129

    s0( dhcp-config)#dns210.42.241.2

    pcopcl1pc2pc 3获得的动态ip地址

    7f0f753f930c4b728975a46b9c2c4101.png

    r210.42.242. 0/24[120/2]via210.42.240.1,00:00:08,serial1/0r210.42

    .243.0/24[ 120/2 ]via210.42.240.1 ,00:00:08,serial1/0

    210.42.244.0/25 issubne ted,2 subnets

    r2 10.42.244.0[120/2]via210.42.240.1,00:00:08,serial1/0r210.42.244.1

    28[120/2]via210.42.240. 1,00:00:08,seriall/0 (6)测试结果

    用pc5pingpc0~ pc4

    b909b2010c6d238140923870b79ad5d4.png

    6、结果分析与总结

    1.做实验的过程的讲过的实验报告可以作为参考

    2.实验比较复杂,细节比较多,做实验的时候有耐心; .

    3.对于不明白的地方应该及时请教老师或者同学;

    4.由于是截图形式,打印出来效果会差-一点;

    5.做的过程中应该认真仔细,一个符号的错误就可能导致运行不出来;

    6.最终结果自己也比较满意,也是对老师和自己交出的一一个好成绩

    展开全文
  • PAGE 1 PAGE 3 PAGE 2 计算机网络实验报告 实验时间 参加人员 一实验名称 实验一 简单以太网的组建 二实验内容 1. 制作双绞线 2. 交叉电缆 3. 测试连通性 三实验步骤 1.材料准备 两台安装了操作系统的计算机 若干RJ-...
  • 计算机网络(自顶向下方法)》实验报告之实验六:VLAN的建立与配置,含实验目的、环境/工具、步骤(含每个步骤截图/实物照片)、结果、心得。
  • 计算机网络(自顶向下方法)》实验报告之实验三:FTP服务器的安装和配置,含实验目的、环境/工具、步骤(含每个步骤截图/实物照片)、结果、心得。
  • 计算机网络(自顶向下方法)》实验报告之实验一:双绞线的制作,含实验目的、环境/工具、步骤(含每个步骤截图/实物照片)、结果、心得。
  • 实验1:ARP包的抓取 实验2:Ping数据包的抓取 实验3:抓取http包的实验 实验4:抓取traceroute信息
  • 6/3/2020 南昌航空大学实验报告 南昌航空大学实验报告 年 月 日 年 月 日 课程名称 计算机网络与通信 实验名称 课程名称 计算机网络与通信 实验名称 网络层协 分析 网络层协 分析 班 级 学生姓名 邓佳威 学号 ...
  • 北航计算机网络实验总结

    千次阅读 多人点赞 2020-11-09 23:35:01
    一、网络实验入门 路由表的更新和维护对于路由器至关重要。主要有静态路由和动态路由两种方式: 静态路由通常手动配置,不能对网络的改变做出及时的反应,无法适应规模较大的网络。 动态路由能够自动维护、发现和...

    对网络一窍不通的小白在考试前的吐血复习


    一、网络实验入门

    路由表的更新和维护对于路由器至关重要。主要有静态路由和动态路由两种方式:

    1. 静态路由通常手动配置,不能对网络的改变做出及时的反应,无法适应规模较大的网络。
    2. 动态路由能够自动维护、发现和更新路由信息,常见的动态路由协议有:
      1. 距离矢量路由选择协议(RIP)
      2. 链路状态路由选择协议(OSPF)
      3. 边界网关协议(BGP)等。

    交换机是工作在数据链路层的网络连接设备。它的基本功能是在多个计算机或者网段之间交换数据。并且基于 MAC 地址的数据转发。

    基础命令

    1. reset
    reset saved-configuration
    reset arp all
    reset ospf process
    reset bgp all
    reboot
    
    1. display
    display ip routing-table
    display ospf routing-table
    display bgp routing-table ipv4
    display pim routing-table
    display ipv6 routing-table
    

    路由器 IP 地址配置命令

    <Quidway>system
    [Quidway]sysname R1
    [R1]interface e0/0
    [R1-Ethernet0]ip add 192.168.2.1 24
    [R1]interface e0/1
    [R1-Ethernet1]ip add 192.168.3.1 24
    

    NAT 和 ACL

    NAT 配置命令

    [R1]acl basic 2001 或 acl number 2001
    [R1-acl-2001]rule permit source 10.0.0.0  0.0.0.255
    [R1-acl-2001]rule deny source any
    #这个访问控制列表定义了允许IP源地址为10.0.0.0/24的外出数据包
    [R1]nat address-group 1
    [R1-address-group-1]address 192.168.5.105 192.168.5.109
    #这条命令定义了一个包含5个公网地址(5~9)的地址池,地址池名称为1
    [R1]interface e0/1
    [R1-Ethernet0/1]nat outbound 2001 address-group 1
    #在出接口E0/1启用地址转换
    [R1]ip route-static 0.0.0.0 0.0.0.0 192.168.5.1
    #在路由表添加静态路由(默认路由)
    

    NAT 原理

    网络转换 NAT 技术主要是为了解决全球 IPv4 地址短缺的问题。

    使用 NAT 技术可以将多个内部专用 IP 地址映射为少数几个甚至一个公网 IP 地址,用来减少公网 IP 地址的使用。

    NAT 技术主要包括三种方式:

    1. 静态 NAT:内部网络中的每个主机都被永久映射成外部网络中的某个外网 IP 的地址。
    2. 动态地址 NAT:定义一系列的外网 IP 地址,采用动态分配的方法映射到内部网络。
    3. 网络地址与端口转换 NAPT:把内部地址映射到外部网络的一个 IP 地址的不同端口上。

    二、数据链路层实验

    数据链路层位于 OSI 参考模型的第二层,在物理层基础上为网络层提供服务,为物理链路上提供可靠的数据传输。

    交换机是工作在数据链路层的网络设备,局域网的数据链路层协议有以太网、令牌环网等,广域网的数据链路层协议有 PPP、HDLC、Frame Relay 等。

    交换机的 MAC 地址表学习

    [S1]display mac-address
    No Mac addresses found.
    [S1]undo mac-address
    

    交换机的广播风暴

    解决方法一:STP

    [S1]stp enable
    

    解决方法二:路由聚合

    [S1]stp disable
    [S1]interface Ethernet 0/1
    [S1- Ethernet 0/1]duplex full
    [S1- Ethernet 0/1]speed 100
    [S1- Ethernet 0/1]interface Ethernet 0/2
    [S1- Ethernet 0/2]duplex full
    [S1- Ethernet 0/2]speed 100
    [S1]link-aggregation Ethernet 0/1 to Ethernet 0/2
    [S1]display link-aggregation
    [S1]undo link-aggregation
    # S2的配置类似
    

    VLAN 的配置与分析

    VLAN 端口:

    1. Access(Untagged)端口:只能属于1个VLAN,从该端口出去的数据包不带TAG,一般接主机或路由器;
    2. trunk端口:可以属于多个VLAN,可以接收和发送带多种VLAN标签的报文,一般用于交换机之间连接的端口;
    3. hybrid端口:可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于接用户的计算机。属于Access和trunk的混合模式。
      • Hybrid端口和trunk端口的不同之处在于hybrid端口可以允许多个VLAN的报文不打标签,而trunk端口只允许缺省VLAN的报文不打标签
    [S1]vlan 2
    [S1-vlan2]port e0/1 to e0/5
    [S1]vlan 3
    [S1-vlan3]port e0/20 to e0/24
    [S1]interface e0/13
    [S1-Ethernet 0/13]port link-type trunk
    [S1-Ethernet 0/13]port trunk vlan 2 3
    [S1-Ethernet0/13]port link-type hybrid
    [S1-Ethernet0/13]port hybrid pvid vlan 1
    [S1-Ethernet0/13]port hybrid vlan 2 tagged
    [S1-Ethernet0/13]port hybrid vlan 3 untagged
    

    三、网络层实验

    ARP 分析

    [S1]undo mac-address # 交换机清空 MAC 地址表
    <S1>reset arp all # 交换机清空 ARP 缓存
    $ arp-d # 计算机清空 ARP 缓存
    

    ICMP 分析

    ICMP(Internet Control Message Protocol)ICMP是一个网络层协议,是基于IP协议工作的,但是它并不是传输层的功能,因此仍然把它归结为网络层协议,Internet控制报文协议。它是TCP/IP协议簇的一个子协议,用于在IP主机、路由器之间传递控制消息。

    ICMP主要有两种功能:

    1. Ping:一般用于勘测到达目的网络的连通性
    2. Tracert:用于确定ip数据包访问目标所采取的路径

    Ping

    1. 首先ping命令会先发送一个 ICMP Echo Request(请求包)给对端
    2. 对端接收到之后, 会返回一个 ICMP Echo Reply(应答包)
    3. 若没有返回,就是超时了,会认为指定的网络地址不存在。

    Tracert

    [S1]ip ttl-expires enable
    [S1]ip unreachables enable
    
    1. 首先tracert送出3个TTL是1的IP UDP数据包到目的地,当路径上的第一个路由器收到这个数据包时,它将TTL减1,此时TTL等于0.
    2. 所以该路由器会将此数据包丢掉,并送回一个 ICMP time exceeded 消息(TTL超时消息),里面包括发IP包的源地址,IP包的所有内容及路由器的IP地址。
    3. tracert 收到这个消息后,便知道这个路由器存在于这个路径上,接着tracert 再送出另一个TTL是2 的数据包,发现第2 个路由器…以此类推
    4. 当数据包到达目的地后,该主机则不会送回 ICMP time exceeded消息
    5. 一旦到达目的地,由于tracert通过UDP数据包向不常见端口(30000以上)发送数据包,因此会收到 ICMP port unreachable 消息,故可判断到达目的地。

    IP 分析

    路由协议:

    1. 静态路由:由网络管理员在路由器上手工添加路由信息以实现路由目的。
    2. 动态路由:根据网络结构或流量的变化,路由协议会自动调整路由信息以实现路由。
    3. 缺省路由(也叫默认路由):Internet上大约99.99%的路由器上都存在一条缺省路由!缺省路由并不一定都是手工配置的静态路由,有时也可以由动态路由协议产生。

    路由配置:

    [QuidwayA]ip route-static 129.1.0.0 255.255.0.0  129.0.0.2 # 静态路由
    [QuidwayB]ip route-static 0.0.0.0  0.0.0.0   129.0.0.1 # 缺省路由
    

    四、OSPF 协议实验

    OSPF 协议概述和基本配置

    协议概述

    路由协议:

    1. 按寻径算法划分:
      • 矢量距离协议-RIP,BGP
      • 链路状态协议-OSPF,IS-IS
    2. 按网络范围划分:
      • 内部网关协议-RIP,OSPF,IS-IS
      • 外部网关协议-EGP,BGP

    RIP 协议的特点:周期性广播发送本路由器的所有RIP路由信息,有一定的盲目性,占用带宽;且每条路由的生成者不明确,易形成环路;协议在设计原理上存在缺陷,其优先级为100,较低;范围有限(15跳),只适用于小型网络;不需要维护邻居关系,协议实现简单;距离矢量算法的典型应用,开销小,效率较高,在特定环境下仍很实用。

    OSPF 协议是基于链路状态算法的内部网关协议,是开放最短路由优先的缩写(Open Shortest Path First)。

    OSPF 协议:

    1. 每个路由器生成自己周边的链路状态信息(明确指出其生成者);
    2. 相邻路由器转发获得的链路状态信息,但不改变其生成者;
    3. 每个路由器关于整个网络都有一个完整而准确的链路状态数据库,用最短路径优先算法计算路由。

    OSPF 核心思想(论述):每一台路由器将其周边的链路状态(包括接口的直连网段,相连的路由器等信息)描述起来,发送给网络中相邻的路由器。经过一段时间的链路状态信息交互,每台路由器都保存了一个链路状态数据库,该数据库是整个网络完整的链路状态描述。在此基础上,应用最短路径优先算法就可以计算出路由。

    • 自治系统(Autonomy System,AS):同一组选路策略的路由器的集合。系统内部可以自主采用路由选择协议,系统间使用 BGP 协议。
    • 区域(Area):一个路由器的集合,相同区域有着相同的拓扑结构数据库。
    • 区域 ID(Router ID):一个32-bit的无符号整数,它是一台路由器的唯一标识,在整个自治系统内唯一。如果一台路由器的 Router ID 在运行中改变,则必须重启OSPF协议或重启路由器才能使新的 Router ID 生效。

    邻居和邻接(Neighbors & Adjacencies):OSPF 路由器启动后,会向外发送 Hello 报文,收到 Hello 报文的 OSPF 路由器检查双方参数一致就会形成邻居关系。而只有当双方成功交换链路状态通告信息,才能形成邻接关系。

    基本配置

    1. 配置 Router ID
    2. 启动 OSPF
    3. 划分区域,设置 Area
    4. 指定网段使能 OSPF

    基本配置

    [R1]router id 1.1.1.1
    [R1]ospf
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 1.1.1.0 0.0.0.255 # 这个network命令实际上宣告了1.1.1.0-1.1.1.255 这256个地址。
    [R1-ospf-1-area-0.0.0.0]network 168.1.1.0 0.0.0.255
    

    引入直连路由

    [R1-ospf]import-route direct(引入直连路由)
    

    引入静态路由

    [R1]ip route-static 192.168.5.0 255.255.255.0 192.168.3.2
    [R1-ospf]import-route static(引入静态路由)
    

    其他命令

    reset ospf all (用户视图)重新启动OSPF进程
    display ospf peer 显示 OSPF 邻居信息
    display ospf brief 显示 OSPF 的概要信息
    display ospf error 显示 OSPF 错误信息
    display ospf routing 显示 OSPF 路由表的信息
    display ospf lsdb 显示 OSPF LSA 的信息
    

    OSPF 协议报文交互过程

    OSPF 的五种协议报文:

    1. Hello 报文:周期性地发送给本路由器的邻居,以发现及维持邻居关系,并选举DR,BDR。
    2. DD 报文(Database Description Packet,数据库描述报文):用来交换邻居路由器之间链路状态数据库(Link State Database,LSDB)的摘要信息,开始时,两个邻居路由器相互发送空DD报文来确定 Master/Slave 关系,
    3. LSR 报文(Link State Request Packet,链路状态请求报文):两台路由器相互交换了 DD 报文之后,通过比较确定缺少和需要更新的 LSA,并发送 LSR 报文向对方请求所需的 LSA。
    4. LSU 报文(Link State Update Packet,链路状态更新报文):向发送 LSR 报文的路由器发送其所需要的 LSA。
    5. LSAck 报文(Link State Acknowledge Packet,链路状态确认报文):对接收到的 LSU 报文进行确认。

    LSA( Link-State Advertisement,链路状态广播)是链路状态协议使用的一个分组,它包括有关邻居和链路成本的信息。LSAs 被路由器接收用于维护它们的 RIB(路由表)

    OSPF 协议的状态机和报文交互过程

    在这里插入图片描述

    获取 OSPF debug 信息

    <R1>debugging ospf event
    <R1>terminal debugging
    <R1>reset ospf all / reset ospf process
    

    问题:OSPF 协议中 Router ID 的作用是什么,它是如何产生的

    Router ID 通常要求人为指定,如果没有指定,路由器会自动选择一个接口的 IP 地址为 Router ID。

    问题:DD 主从关系的协商过程和协商结果,其隐含的确认机制

    1. 路由器认为自己是 Master,发送 DD 报文并指定 MS=1,Master 的选举与 Priority 无关。
    2. 选取 Router ID 最大的路由器作为 Master。
    3. 隐含确认机制:Master 定义序列号 Seq,每发送一个新 DD 报文,Seq+1,Salve 每次发送 DD 报文,携带最近接受到的一个 Master 发送的 DD 报文中的 Seq。
    4. 每个报文都有超时重传,加上隐含的确认机制,保证了传输是可靠的。

    问题:LSA 摘要信息交互过程,其隐含的可靠传输机制如何起作用

    确认与可靠传输机制起作用的方式:Slave 通过重复 Master 的序列号确认已收到的 Master 报文,Master 通过将序列号加1来确认已收到 Slave 的报文。

    问题:DR 和 BDR 的选举过程

    只有在广播或 NBMA(non-broadcast multiple access,非广播多路访问网络)类型接口才会选举 DR,在点到点或点到多点类型的接口上不需要选举 DR。DR 的生成是为了减少该网段中路由器之间交换报文的次数。

    1. 所有 Priority>0(默认是 1)的 OSPF 路由器认为自己是 DR。
    2. Priority 最大,相等时 Router ID 最大的路由器为 DR。次优的作为 BDR。
    3. 每台路由器相互发送 Hello 报文,写入自己选出的 DR,并共同选举出 DR。

    区域划分与 LSA 种类

    区域划分的原因

    1. 网络规模过大,导致单一区域的LSDB过于庞大。
    2. LSDB过于庞大,SPF算法运行的复杂度增加,CPU负担重。
    3. LSDB同步需要时间变长,网络动荡加剧,占用网络带宽,降低路由准确率。

    OSPF 协议通过将自治系统划分成不同的区域:减少 LSA 的数量,缩小网络变化波及的范围

    路由器的类型

    1. IAR(Internal Area Router)区域内路由器:所有接口属于一个区域,只有一个 LSA 和 LSDB。
    2. ABR(Area Border Router)区域边界路由器:接口属于两个以上区域,为所属的每个区域生成一个 LSA,保存一个 LSDB。
    3. ASBR(AS Boundary Router)自治系统边界路由器:引入其它路由协议的路由器,包括静态路由和直连路由,不一定在AS的边界。
    4. BBR(BackBone Router)骨干路由器:至少有一个接口属于骨干区域(Area=0)。

    前五类 LSA

    1. Router LSA(Type=1):本路由器运行 OSPF 的接口的连接状况和花费信息,每个区域一条 LSA,传递范围是整个区域。
    2. Network LSA(Type=2):由 DR 生成,Router LSA 只描述了到 DR 的连接,而 DR 通过 Network LSA 来描述本网段中所有已经同其建立了邻接关系的路由器(Router ID),传递范围是整个区域。
    3. Network Summary LSA(Type=3):由 ABR 生成,ABR 完成一个区域内的路由计算之后,查询路由表,将每一条 OSPF 路由封装成 Network Summary LSA 发送到相邻区域,传递范围是该 LSA 生成区域之外的其他区域。
    4. ASBR Summary LSA(Type=4):由 ABR 生成,描述本区域内部目的地址到 ASBR 的路由,传递范围是该 LSA 生成区域之外的其他区域。
    5. AS External LSA(Type=5):由 ASBR 生成,描述了自治系统外部路由的信息,与区域无关,传递范围是整个自治系统。

    显示 OSPF LSA

    [R1]display ospf lsdb
    [R1]display ospf lsdb router
    [R1]display ospf lsdb summary
    

    OSPF 设计型实验

    在这里插入图片描述

    1. VLAN 和 IP 配置
    [S1]INTER VLAN 1
    [S1-VLAN-INTERFACE1]IP ADDR 192.168.3.2 24
    [S1]VLAN 2
    [S1-VLAN2]PORT E 0/23
    [S1]INTER VLAN 2
    [S1-VLAN-INTERFACE2]IP ADDR 192.168.5.1 24
    [S1]VLAN 3
    [S1-VLAN3]PORT E 0/2
    [S1]INTER VLAN 3
    [S1-VLAN-INTERFACE3]IP ADDR 192.168.4.2 24
    [S1]VLAN 4
    [S1-VLAN4]PORT E 0/24
    [S1]INTER VLAN 4
    [S1-VLAN-INTERFACE4]IP ADDR 192.168.6.1 24
    
    [S2]VLAN 2
    [S2-VLAN2]PORT E 0/1
    [S2]INTER VLAN 2
    [S2-VLAN-INTERFACE2]IP ADDR 202.112.1.2 24
    [S2]VLAN 3
    [S2-VLAN3]PORT E 0/2
    [S2]INTER VLAN 3
    [S2-VLAN-INTERFACE3]IP ADDR 202.112.2.2 24
    [S2]INTER LOOPBACK 1
    [S2-LOOPBACK1]IP ADDR 211.100.2.1 24
    
    [R1]INTER E 0/0
    [R1-ETHERNET0]IP ADDR 202.112.1.1 24
    [R1]INTER E 0/1
    [R1-ETHERNET1]IP ADDR 192.168.3.1 24
    [R1]INTER S 0/0
    [R1-SERIAL0]IP ADDR 192.168.0.1 24
    
    [R2]INTER E 0/0
    [R2-ETHERNET0]IP ADDR 202.112.2.1 24
    [R2]INTER E 0/1
    [R2-ETHERNET1]IP ADDR 192.168.4.1 24
    [R2]INTER S 0/0
    [R2-SERIAL0]IP ADDR 192.168.0.2 24
    
    1. OSPF 配置
    [S1]OSPF
    [S1-OSPF]AREA 0
    [S1-OSPF-AREA-0.0.0.0]NETWORK 192.168.3.0 0.0.0.255
    [S1-OSPF-AREA-0.0.0.0]NETWORK 192.168.4.0 0.0.0.255
    [S1]INTER VLAN 1
    [S1-VLAN-INTERFACE1]OSPF COST 100
    [S1]INTER VLAN 3
    [S1-VLAN-INTERFACE3]OSPF COST 200
    
    [R1]OSPF
    [R1-OSPF]AREA 0
    [R1-OSPF-AREA-0.0.0.0]NETWORK 192.168.0.1 0.0.0.255
    [R1-OSPF-AREA-0.0.0.0]NETWORK 192.168.3.1 0.0.0.255
    [R1]INTER E0/1
    [R1-ETHERNET1]OSPF COST 100
    [R1]INTER S0/0
    [R1-SERIAL0]OSPF COST 200
    
    [R2]OSPF
    [R2-OSPF]AREA 0
    [R2-OSPF-AREA-0.0.0.0]NETWORK 192.168.0.2 0.0.0.255
    [R2-OSPF-AREA-0.0.0.0]NETWORK 192.168.4.1 0.0.0.255
    [R2]INTER E0/1
    [R2-ETHERNET1]OSPF COST 200
    [R2]INTER S0/0
    [R2-SERIAL0]OSPF COST 200
    
    1. 静态+引入方法实现路由备份
    # 3.1 S1 引入直连路由
    [S1-OSPF]IMPORT-ROUTE DIRECT
    # 3.2 R1、R2 配置静态路由,引入并配置不同的花费
    [R1]IP ROUTING-STATIC 211.100.2.1 255.255.255.0 202.112.1.2
    [R1-OSPF]IMPORT-ROUTE STATIC COST 100
    [R1-OSPF]IMPORT-ROUTE DIRECT COST 100
    [R2]IP ROUTING-STATIC 211.100.2.1 255.255.255.0 202.112.2.2
    [R2-OSPF]IMPORT-ROUTE STATIC COST 200
    [R2-OSPF]IMPORT-ROUTE DIRECT COST 200
    # 3.3 S2 配置路由聚合的静态路由
    [S2]IP ROUTING-STATIC 192.168.0.0 255.255.0.0 202.112.1.1 PRE 50
    [S2]IP ROUTING-STATIC 192.168.0.0 255.255.0.0 202.112.2.1 PRE 60
    

    五、BGP 协议实验

    BGP 的基本分析

    协议概述

    自治系统:Internet中相对独立的系统称为AS(自治系统),每个AS都由Internet注册机构分配一个唯一的数来表示。AS是一个拥有统一的策略,在统一的管理下运行的一组路由器。通过不同的编号来区分不同的自治系统。

    BGP(Border Gateway Protocol)描述:BGP 是一种自治系统间的动态路由协议,基本功能是在自治系统间自动交换无环路的路由信息,通过交换带有 AS 号序列属性的路径可达信息,来构造自治区域的拓扑图,从而消除路由环路并实施用户配置的路由策略。

    自治系统内部的路由协议(IGP)主要是发现和计算路由,自治系统之间的外部路由协议(EGP)主要是控制路由的传播和选择最好的路由。(BGP 是 EGP,OSPF 和 RIP 是 IGP)

    BGP 的工作机制:BGP 运行在一个特定的路由器上。系统启动时通过发送整个 BGP 路由表交换路由信息,之后为了更新路由表只交换更新报文(Update),并在系统运行过程中,通过 KEEP ALIVE 报文来检测连接是否正常。EBGP 对等体是不同自治系统交换 BGP 报文的对等体,IBGP 对等体是同一个自治系统交换 BGP 报文的对等体。

    1. BGP 协议仅仅在 BGP 对等体(邻居)之间管理和维护它所得到的路由。
    2. BGP 是 AS 之间的路由协议,AS 内部的边界路由器之间也要建立邻居关系。

    BGP 报文的四种类型

    1. Open:对版本,BGP 标识符等信息进行协商。
    2. KeepAlive:BGP 对等体间周期性发送,以确保连接有效。
    3. Update:携带路由更新信息,包括撤销路由信息和可达路由信息及其路径属性。
    4. Notification:BGP 检测到差错时关闭同对等体的连接。

    基本配置

    [S1]bgp 300
    [S1-bgp-default]peer 1.1.1.1 as-number 100 # 加入邻居
    [S1-bgp-default]peer 3.1.1.2 as-number 300
    [S1-bgp-default]address-family ipv4 unicast
    [S1-bgp-default-ipv4]peer 1.1.1.1 enable
    [S1-bgp-default-ipv4]peer 3.1.1.2 enable
    [S1-bgp-default-ipv4]peer 3.1.1.2 next-hop-local # 强制下一跳地址(两个都为 IBGP)
    [S1-bgp-default-ipv4]network 5.5.5.5 255.255.255.255 # 注入 5.5.5.5 网段的路由信息
    [R1]ping-a 5.5.5.5 4.4.4.4 # 以 5.5.5.5 为源地址 ping 4.4.4.4
    

    BGP 状态转换分析

    在这里插入图片描述

    1. Idle 状态:idle 是 BGP 连接的第一个状态,BGP等待一个启动事件。启动事件出现后,BGP 初始化资源/复位连接重试计数器,发起一条 TCP 连接,同时转入 CONNNECT 状态。
    2. Connect 状态:BGP 发起第一个 TCP 连接,如果超时就重新发起 TCP 连接,并继续保持 connect 状态,如果连接成功就转入 open-sent 状态,失败则转入 Active 状态。
    3. Active 状态:BGP 总是试图建立 TCP 连接,如果重试计时器超时,就退回到 connect 状态,若连接成功就转入 open-sent 状态,如果失败就保持 Active 状态,并继续发起 TCP 连接。
    4. Open-sent状态:TCP 连接已经建立,BGP 也已经发送了一个 open 消息,等待对等体发送 open 消息。检查收到的 open 消息,如果有错就发送出错通知并退回到 idle 状态,如果没错就开始发送 keepalive 消息,并复位 keepalive 计时器,开始计时,同时转入 open-confirm 状态。
    5. Open-confirm 状态:BGP 等待一个 keepalive 消息,同时复位保持计时器,如果收到了一个 keepalive 消息就转入 established 阶段,建立 peer 关系。
    6. Establish 状态:对等体关系已建立,对等体之间交换 update 消息,同时复位保持计时器。

    获取 BGP debug 信息

    <R1>debugging bgp event
    <R1>terminal debugging
    <R1>reset bgp all
    

    BGP 的路由聚合

    [r1]bgp 100
    [r1-bgp-default] address-family ipv4 unicast  
    [r1-bgp-default-ipv4]aggregate 192.168.0.0 255.255.240.0
    [r1-bgp-default-ipv4]aggregate 192.168.0.0 255.255.240.0 detail-suppressed
    

    BGP 的基本路由属性

    1. Origin 起点:路径信息的来源,IGP,EGP,Incomplete 等。
    2. AS-Path 路径:标识路径经过的 AS 序列,即列出在到达所通告的网络之前所经过的 AS 清单。
    3. Next-hop 属性:到达更新报文所列网络的下一跳边界路由器的 IP 地址。
    [S1-bgp]import-route dicect
    [r1-bgp]display bgp routing-table ipv4
    

    next-hop-local 配置

    1. BGP 在向 IBGP 通告其他 EBGP 的路由时,不改变路由的下一跳地址。
    2. BGP 在向 EBGP 通告路由时,下一跳属性是与本地 BGP 与对端连接的端口地址。
    3. 如果不强制下一跳,会出现路由地址不可达的问题。

    BGP 的路由策略

    基于 ACL 的路由过滤

    acl number 2000
    rule 0 deny source 5.0.0.0 0.255.255.255
    rule 1 permit source 0.0.0.0 255.255.255.255
    bgp 300
    peer 2.1.1.2 filter-policy 2000 export                  //配置基于ACL的路由过滤
    

    基于 AS-PATH 的路由过滤

    ip as-path-acl 1 deny \b200$                       //设置拒绝来自AS200的路由
    ip as-path-acl 1 permit ^$                         //设置允许本AS的路由
    bgp 300
    peer 1.1.1.1 as-path-acl 1 export                  //配置基于AS-Path的路由过滤
    

    基于 Route Policy 的路由过滤

    acl number 2001
    rule 1 deny source 6.0.0.0 0.255.255.255
    rule 2 permit source any
    
    [s1]Route-policy deny6 permit node 10    
    [s1-route-policy-deny6-10]if match ip address acl 2001      //不通告 6.0.0.0 0 的路由信息
    [s1-route-policy-deny6-10]apply cost  888                   //通告其他路由信息的 cost 都为 888
    
    [s1]Bgp 300
    [S1-bgp-default] address-family ipv4 unicast
    [R1-bgp-default-ipv4]peer 1.1.1.1 route-policy deny6 export   //配置基于Route Policy的路由过滤
    

    BGP 设计型实验

    在这里插入图片描述

    1. VLAN 和 IP 配置
    [S1]INTERRFACE VLAN 1
    [S1-VLAN-INTERFACE1]IP ADDRESS 11.2.1.2 16
    [S1]VLAN 2
    [S1-VLAN2]PORT GE1/0/24
    [S1-VLAN2]INTER VLAN 2
    [S1-VLAN-INTERFACE2]IP ADD 11.4.1.1 16
    [S1]INTER LOOPBACK 1
    [S1-LOOPBACK1]IP ADD 3.3.3.3 32
    
    [S2]INTER VLAN 1
    [S2-VLAN-INTERFACE1]IP ADD 11.3.1.2 16
    [S2-VLAN-INTERFACE1]VLAN 2
    [S2-VLAN2]PORT E1/0/24
    [S2-VLAN2]INTER VLAN 2
    [S2-VLAN-INTERFACE2]IP ADD 11.4.1.2 16
    [S2-VLAN-INTERFACE2]INTER LOOPBACK 1
    [S2-LOOPBACK1]IP ADD 4.4.4.4 32
    [S2-LOOPBACK1]INTER LOOPBACK 2
    [S2-LOOPBACK2]IP ADD 5.5.5.5 32
    
    [R1]INTER G0/0
    [R1-GIGABITETHERNET0/0]IP ADD 11.2.1.1 16
    [R1]INTER LOOPBACK 1
    [R1-LOOPBACK1]IP ADD 1.1.1.1 32
    [R1]INTER LOOPBACK 2
    [R1-LOOPBACK2]IP ADD 6.6.6.6 32
    
    [R2]INTER G0/0
    [R2-GIGABITETHERNET0/0]IP ADD 11.3.1.1 16
    [R2]INTER LOOPBACK 1
    [R2-LOOPBACK2]IP ADD 2.2.2.2 32
    
    1. BGP 配置
    [S1]BGP 200
    [S1-BGP-DEFAULT]PEER 11.2.1.1 AS-NUMBER 100
    [S1-BGP-DEFAULT]PEER 11.4.1.2 AS-NUMBER 300
    [S1-BGP-DEFAULT]ADDRESS-FAMILY IPV4 UNICAST
    [S1-BGP-DEFAULT-IPV4]PEER 11.4.1.2 ENABLE
    [S1-BGP-DEFAULT-IPV4]PEER 11.2.1.1 ENABLE
    [S1-BGP-DEFAULT-IPV4]NETWORK 3.3.3.3 32
    
    1. 配置 BGP 路由策略
    [S1]IP AS-PATH 1 DENY 300$ # S1 不通告 AS 300 路由
    [S1]IP AS-PATH 1 PERMIT ^$ # S1 通告本 AS 路由
    [S1]IP AS-PATH 1 PERMIT \B400$ # S1 通告 AS 400 路由
    [S1]BGP 200
    [S1-BGP]PEER 11.2.1.1 AS-PATH-ACL 1 EXPORT
    

    六、组播实验

    IP 组播基础

    1. 主机加入组播组:启动一个应用程序,应用程序向 IP 模块注册组播 IP 地址,请求加入组播组。同时数据链路层将该组播的 MAC 地址加入到数据链路层接收列表中。
    2. 主机接收组播数据:数据链路层接收数据帧后,将数据帧的 MAC 地址与接收列表进行匹配,同样网络层也将目的 IP 地址与网络层接收列表进行匹配,若匹配则接收该数据。
    3. 主机离开组播组:应用程序通告 IP 模块,将该组播 IP 从网络层接收列表中删除,同理 IP 模块会通告数据链路层,使其从数据链路层接收列表中删除该组播的 MAC 地址。

    IGMP 实验

    IGMP 加入组机制

    1. 主机会主动向其要加入的组播组发送 IGMP 成员关系报告报文以声明加入,而不必等待 IGMP 查询器发来的 IGMP 查询报文。
    2. IGMP 查询器周期性地以组播方式向本地网段内的所有主机与路由器发送 IGMP 查询报文。
    3. 收到查询报文后,关注 G1 的 PAC 或 PCB 之一会向 G1 发送 IGMP 成员关系报告报文,以宣告其属于 G1,而本地网段的其他主机不在发送报告报文,即 IGMP 成员关系报告抑制机制,有助于减少本地网段的信息流量

    IGMP 离开组机制

    1. 主机向本地网段内的所有组播路由器发送离开组报文。
    2. 查询器收到该报文后,向该主机的组播组发送特定组查询报文。
    3. 如果所在组还要其他长远主机,则会发送成员关系报告报文。
    4. 如果在最大响应时间内收到了成员关系报告报文,则继续位于该组播组的成员关系,否则认为该网段内已无该组播组的成员,不在维护成员关系。

    配置命令

    [Quidway] multicast routing-enable # 启动组播应用
    [Quidway-e0/1] igmp enable # 启动 IGMP
    [Quidway-VLAN-interface10] igmp host-join 225.0.0.1 port ethernet 1/1 # 模拟主机行为——加入一个组
    [Quidway-VLAN-interface10] igmp version 1 # 指定 IGMP 版本号
    [Quidway] display igmp interface # 显示 IGMP 接口信息
    [Quidway] display igmp group # 显示 IGMP 组播组信息
    

    PIM-DM 协议实验

    • PIM-DM(协议无关组播-密集模式)
    • PIM-SM(协议无关组播-稀疏模式)

    逆向路径转发(RPF,Reverse Path Forwarding):组播包的转发不是基于 IP 包的目的地址的,而是用RPF 检查决定是转发还是丢弃该组播包。路由器检查到达组播包的源地址,如果组播包是在可返回源站点的接口上到达,则 RPF 检查成功,组播包被转发;如果RPF检查失败,丢弃组播包。

    配置命令

    # 1. 配置组播路由协议,交换机在每个 VLAN 配置,路由器在每个接口配置
    [s1]multicast routing-enable # v7 为 multicast routing
    [s1-Vlan-interface2]pim dm
    [s1-Vlan-interface3]pim dm
    [r1]multicast routing-enable # v7 为 multicast routing
    [r1-Ethernet0/0]pim dm
    [r1-Ethernet0/1]pim dm
    # 2. 启动 IGMP
    [r1-Ethernet0/0]igmp enable
    # 3. 为了分析 pim dm 协议过程,禁用 pim state-refresh
    [s1-Vlan-interface2]undo pim state-refresh-capable
    [s1-Vlan-interface3]undo pim state-refresh-capable
    [r1-Ethernet0/0]undo pim state-refresh-capable
    [r1-Ethernet0/1]undo pim state-refresh-capable
    # 4. 查看组播路由表和邻居
    [s1]display pim routing-table
    [s1]display pim neighbor
    
    

    PIM-SM 协议实验

    配置命令

    # 其余与 pim dm 相同
    [R1-Ethernet0/0]pim sm
    [R1]pim
    [R1-pim]c-bsr 10.3.1.2 hash-length 4 priority 1        
    [R1-pim]c-rp 10.3.1.2
    

    七、网络管理实验

    被管对象必须维持可供管理程序读写的若干控制和状态信息,这些信息总称为管理信息库 MIB(Management Information Base)

    网络管理协议:并不是网管协议本身来管理网络,网管协议就是管理程序和代理程序之间进行通信的规则。

    RMON(Remote Monitoring,远程网络监视)是对 SNMP 的增强,RMON 可以有效地降低对网络带宽的要求,实现网络数据的增值分析,减轻网管站和网络的负担。

    RMON 原理:把一部分原来在网管侧实现的功能放到设备上去进行。避免了网络上许多不必要的流量,在减轻网络负担的同时也有效降低了对网络带宽的要求。

    SNMP 工作方式:SNMP 代理是一个软件进程,监听 UDP 端口 161 上的 SNMP 信息,每一个 SNMP 报文都含有想要读取或修改的管理对象的列表,和一个密码(共同体名),如果共同体名一致则处理该请求。支持 MIB-II 的被管设备将维护关于其每个接口的管理信息。网管程序通过周期性地用 UDP 数据报来发送 SNMP 请求报文,来请求被管设备的信息。

    SNMPv1 定义的协议数据单元 PDU 有五种类型

    1. get-request:从代理进程处提取一个或多个参数值。
    2. get-next-request:从代理进程处提取一个或多个参数值的下一个参数值。
    3. set-request:设置代理进程的一个或多个参数值。
    4. get-response:由代理进程返回的一个或多个参数值。
    5. trap:代理进程主动发出,通知管理进程有事情发生。

    配置命令

    [Switch]snmp-agent
    [Switch]snmp-agent sys-info version all
    [Switch]snmp com write private
    [Switch]snmp com read public
    [Switch]snmp trap enable
    [Switch]snmp target-host trap address udp-domain 10.0.0.11 params securityname public # 配置 trap 报文的目的主机
    

    八、传输层实验

    TCP 基本分析

    TCP 连接的建立:TCP 连接的建立采用了 3 次握手方式。

    1. PCA 发送连接请求报文:SYN,SEQ=x
    2. PCB 发送确认报文:SYN,ACK,SEQ=y,ACK=x+1
    3. PCA 发送确认报文:ACK,SEQ=x+1,ACK=y+1

    TCP 连接的建立过程中,还进行了双方最大报文段长度(MSS,Maximum Segment Size)的协商,使用较小的 MSS 应用于数据传送。

    TCP 数据的传送:为了保证传输的可靠性,采用面向字节的方式,每个字节对应一个序号。在连接建立时,双方协商初始序号;在发送数据报文中,序号字段为发送字节的序号;在确认报文中,确认号字段表示了此序号之前的字节均已收到。这样既做到了可靠传输,也做到了全双工通信。

    TCP 连接的释放:TCP 连接的释放采用了 4 次挥手方式。

    1. PCA 发送连接释放请求报文:FIN,SEQ=x
    2. PCB 发送确认报文:ACK,SEQ=y,ACK=x+1(在这之后 PCB 还可以向 PCA 发送数据,但不再接收 PCA 发来的数据)
    3. PCB 发送连接释放请求报文:FIN,ACK,SEQ=y,ACK=x+1(SEQ=y 因为ACK报文不消耗序号)
    4. PCA 发送确认报文:ACK,SEQ=x+1,ACK=y+1(SEQ=x+1 因为FIN报文要消耗序号)

    TCP 的拥塞控制

    TCP 的拥塞控制和流量控制:保证可靠传输的同时,尽量提高传输效率。

    TCP 的滑动窗口机制:TCP 使用大小可变的滑动窗口进行流量控制,窗口大小的单位是字节。发送窗口在连接建立时由双方协定,但在通信过程中,接收方可以通过更改接收窗口,发送方可以通过更改拥塞窗口,从而动态调整发送窗口的值

    1. 接收端口(rwnd,receiver window):接收端根据可接收缓存的大小,动态地调整接收端口的大小,其值在接收端发送的窗口字段中。
    2. 拥塞端口(cwnd,congestion window):发送端根据当前网络拥塞程度而确认的窗口值,其大小与网络的带宽和时延密切相关。
    3. 发送端口:Min(cwnd,rwnd)

    窗口的滑动:发送窗口其左边沿对应已发送数据中被确认的最高序号 +1

    1. 窗口合拢:左边沿向右移动,表示数据被发送和确认
    2. 窗口张开:右边沿向右移动,表示接收端释放了 TCP 缓存
    3. 窗口收缩:右边沿向左移动,表示网络拥塞程度加大

    TCP 的糊涂窗口综合征和 Nagle 算法

    什么是糊涂窗口综合征:接收方处理较慢,每次从接收缓存取走少量数据并改变接收端口,这样发送方会频繁发送很多小的报文段,而不是等待接收窗口变得更大而发送一个大的报文段,降低了网络的传输效率。

    Nagle 算法解决糊涂窗口综合征:

    1. 接收端避免通告小窗口:接收缓存可用空间达到一半或一个 MSS 再通告。
    2. 发送端尽量发送大报文:发送数据填满发送缓存的一半或一个 MSS 再发送。

    TCP 的慢启动和拥塞避免:为了保证网络的平稳高效,防止网络流量的剧烈起伏振荡。

    1. 慢启动:发送端逐渐增大拥塞窗口的值,每收到一个确认报文,拥塞窗口增加一个 MSS。
    2. 拥塞避免:发送方每收到一个确认报文,拥塞窗口增加 SMSS*SMSS/cwnd,即每收到 cwnd 个确认报文,cwnd 加一。(SMSS 是发送端的 MSS)

    慢启动与拥塞避免算法,拥塞窗口增加的方式分别是指数方式和线性方式。需要设置一个门限变量 ssthresh,来进行慢启动和拥塞避免的切换,避免网络拥塞。

    网络拥塞的处理:网络拥塞是指发送端没有按时收到确认报文或者收到了重复的确认报文。

    只要发送端发现网络拥塞,立即进行处理:

    1. ssthresh = max(cwnd/2,2*MSS)
    2. cwnd = 1

    能够迅速减少主机到网络的分组数,使得发生拥塞的主机或者路由器有时间把队列中的积压分组处理完毕。

    TCP 的超时与重传:发送端每发送一个报文段,TCP 都保留其副本,并设定一个定时器等待确认信息。如果定时器超时,却并没有得到确认,则重传这一报文。重传超时时间应略大于平均往返时延 RTT。

    Karn 算法:计算平均往返时延 RTT 时,不计算发生过报文段重传的往返时延样本;同时报文段每重传一次,相应增大重传时间:新的重传时间 = γ*旧的重传时间,典型 γ=2。当不再发生报文段重传时,再根据往返时延更新 RTT 和重传时间的数值。

    TCP 的窗口探查技术:接收端的接收缓存已满,向发送端发送窗口为 0 的通告报文。发送方使用一个坚持定时器来周期性地向接收方查询,以便发现窗口是否已经增大。(窗口探查是包含一个字节的数据的报文段)

    TCP 的快重传与快恢复:为了避免 TCP 因等待重传定时器超时而空闲较长时间。

    1. 快重传:当发送端连续收到三个重复的 ACK 报文,即可认为某一报文段丢失并且网络仍能够正常报文传输,因此不必等待报文的定时器超时,而直接重传认为丢失的报文段。(连续收到重复 ACK 说明收到报文的字节序中有一段丢失)
    2. 快恢复:是慢启动算法的补充,当网络拥塞时,设置 cwnd = ssthresh,并直接进入拥塞避免状态,而不是设置 cwnd = 1,并进入慢启动状态。(快恢复的慢启动算法只在 TCP 建立连接时使用)

    UDP 分析

    UDP:UDP 也是位于 IP 之上,封装在 IP 报文中进行传输,基于数据报文的协议。UDP 报文的传输没有建立连接,传输过程中也没有确认。UDP 是无连接的、不可靠的传输层协议。


    九、IPv6 技术实验

    IPv6 基础实验

    IPv6 配置

    [RT1]ipv6
    [RT1]interface e0/0
    [RT1-Ethernet0/0]ipv6 address 1::1/64
    [RT1-Ethernet0/0]undo ipv6 nd ra halt # 打开 nd 协议中的 ra 公告
    [RT2]ipv6 route-static 2001:: 64 2007::1
    [RT2]ipv6 route-static 2004:: 64 2003::2
    [RT2]display ipv6 routing-table
    
    • 在路由器上:ping ipv6
    • 在windows下:ping

    ICMPv6 分析实验

    查看 PC 加入的组播组

    C:\WINDOWS\system32>netsh
    netsh>interface
    netsh interface>ipv6
    netsh interface ipv6>show join
    netsh interface ipv6>show address
    netsh interface ipv6>show route
    netsh interface ipv6>show neighbors interface=5
    

    IPv6 地址解析实验

    C:\WINDOWS\system32>netsh
    netsh>interface
    netsh interface>ipv6
    netsh interface ipv6>show neighbors interface=5
    netsh interface ipv6>show destinationcache
    

    问题:On-link 和 Off-link 地址解析的全过程:源和目的地址在同一链路上(On-link),源和目的地址在不同链路上(Off-link)。

    IPv4 通过 ARP 解析,IPv6 通过 NS 和 NA 解析(没有广播)。

    1. On-link:处于同一链路的两条主机要通信就要知道对方的 mac 地址,在 IPV4 中通过 ARP 实现,ARP 是通过广播实现的,但是 IPV6 中并没有广播的概念。在 IPV6 中,通过 ND 协议来完成这个地址解析的工作。ND 协议使用 ICMPv6 报文,其地址解析过程如下:
      1. 首先查找邻居缓存表(IPV6 nc),没有则进行地址解析 (类似于查找ARP表)。
      2. 源主机发送组播NS报文,该报文的目的地址为目标IPV6地址所对应的被请求节点组播地址(Solicited-node),在其中也包含了自己的链路层地址。
      3. 目标主机收到NS报文后,就会了解到发送主机的IPV6地址和相应链路层地址;同时由于目标主机正在使用报文内的目标地址,所以会目标主机向源主机单播发一个邻接点公告报文(NA),该报文中包含自己的链路层地址。
    2. Off-link:支持 IPV6 的主机有一个数据结构DestinationCache,要发送数据到某个目的地址的时候,首先查询这个数据结构,如果查不到,就查路由表,然后将查到的信息记录在这个数据结构中。如果查询到的目的地址是 on-link 的,将目的地址本身加入 DC 表的 nexthop 域;如果目的地址是 off-link 的,将路由表中的下一跳加入 DC 的 nexthop 域。

    OSPFv3 协议分析实验

    目前针对 IPv4 协议使用的是 OSPFv2,针对 IPv6 协议使用的是 OSPFv3。OSPFv3 是基于链路(Link)运行,OSPFv2 是基于网段(Network)运行

    OSPFv3 配置

    [R1]ospfv3 1 # 启动 OSPF
    [R1-ospfv3-1]router-id 2.2.2.2 # 在 OSPF 内部定义 Router ID
    [R1]interface e0/0
    [R1-Ethernet0/0]ospfv3 1 area 0 # 基于链路配置 OSPF
    

    2020年上半年卷子实践采坑统计

    基础

    1. 静态路由配置的下一跳地址不能为自身地址,否则就会出现invalid nexthop address错误。
    2. 进入交换机接口为inter g1/0/1,进入路由器接口为inter s1/0
    3. 实验室中的两台路由器的 S 口是默认连接的。
    4. 实验中的路由器连接主机可以使用 Hub 相连。
    5. windows 如何截图:
      1. PrintScreen 按键
      2. 开始搜索:截图

    NAT

    [R1]acl basic 2001 或 acl number 2001 # 定义 acl 2001
    [R1-acl-2001]rule permit source 10.0.0.0  0.0.0.255 # 允许内网的流量,注意掩码为后 8 位,表示允许所有子网的流量
    [R1-acl-2001]rule deny source any # 拒绝其他流量
    [R1]nat address-group 1 # 定义 nat 1
    [R1-address-group-1]address 192.168.5.105 192.168.5.109 # 定义地址池
    [R1]interface e0/1
    [R1-Ethernet0/1]nat outbound 2001 address-group 1 # 在出接口E0/1启用地址转换,满足 acl 2001 的启动 nat 1
    [R1]ip route-static 0.0.0.0 0.0.0.0 192.168.5.1 # 在路由表添加静态路由(默认路由),默认联网到 Internet
    

    OSPF

    配置

    router id 1.1.1.1 # 首先配置 router id
    ospf
    area 0
    network 192.168.1.1 0.0.0.255 # 引入接口在 area 的网段,掩码为 0.0.0.255
    ospf cost 100 # ospf 的花费需要在每个接口处配置
    

    查看配置情况

    dis ospf rou
    dis ospf lsdb
    dis ip rou
    

    问题:OSPF 的报文种类和第一类和第二类 LSA 的信息

    OSPF 的报文种类:

    1. Hello 报文:周期性地发送给本路由器的邻居,以发现及维持邻居关系,并选举DR,BDR。
    2. DD 报文(Database Description Packet,数据库描述报文):用来交换邻居路由器之间链路状态数据库(Link State Database,LSDB)的摘要信息,开始时,两个邻居路由器相互发送空DD报文来确定 Master/Slave 关系,
    3. LSR 报文(Link State Request Packet,链路状态请求报文):两台路由器相互交换了 DD 报文之后,通过比较确定缺少和需要更新的 LSA,并发送 LSR 报文向对方请求所需的 LSA。
    4. LSU 报文(Link State Update Packet,链路状态更新报文):向发送 LSR 报文的路由器发送其所需要的 LSA。
    5. LSAck 报文(Link State Acknowledge Packet,链路状态确认报文):对接收到的 LSU 报文进行确认。

    第一类和第二类 LSA 的信息:

    1. Router LSA(Type=1):本路由器运行 OSPF 的接口的连接状况和花费信息,每个区域一条 LSA,传递范围是整个区域。
    2. Network LSA(Type=2):由 DR 生成,Router LSA 只描述了到 DR 的连接,而 DR 通过 Network LSA 来描述本网段中所有已经同其建立了邻接关系的路由器(Router ID),传递范围是整个区域。

    BGP

    配置

    [R1]INTER LOOPBACK 2
    [R1-LOOPBACK2]IP ADD 6.6.6.6 32 # Loopback 的掩码必须为 32
    [S1]BGP 200
    [S1-BGP-DEFAULT]PEER 11.2.1.1 AS-NUMBER 100
    [S1-BGP-DEFAULT]PEER 11.4.1.2 AS-NUMBER 300
    [S1-BGP-DEFAULT]ADDRESS-FAMILY IPV4 UNICAST
    [S1-BGP-DEFAULT-IPV4]PEER 11.4.1.2 ENABLE
    [S1-BGP-DEFAULT-IPV4]PEER 11.2.1.1 ENABLE
    [S1-BGP-DEFAULT-IPV4]NETWORK 3.3.3.3 32 # 引入 Loopback
    ping -a 3.3.3.3 4.4.4.4 # ping 必须带上源地址
    

    查看配置情况

    dis bgp rou
    dis bgp peer
    dis ip rou
    

    问题:BGP 的报文种类

    1. Open:对版本,BGP 标识符等信息进行协商。
    2. KeepAlive:BGP 对等体间周期性发送,以确保连接有效。
    3. Update:携带路由更新信息,包括撤销路由信息和可达路由信息及其路径属性。
    4. Notification:BGP 检测到差错时关闭同对等体的连接。

    组播

    组播需要在交换机的每个 vlan 和路由器的每个接口配置如下命令:

    pim dm
    igmp enable
    

    之后查看组播信息可用:

    display pim routing-table
    display neighbor
    

    问题:根据 IGMP 报文分析加入组和离开组的机制

    尝试了断开连接,主动离开组,主动加入组,截获到了如下几种报文:

    1. Membership Query
    2. Membership Report
    3. Leave Group

    IGMP 加入组机制:

    1. 主机会主动向其要加入的组播组发送 IGMP 成员关系报告报文以声明加入,而不必等待 IGMP 查询器发来的 IGMP 查询报文。
    2. IGMP 查询器周期性地以组播方式向本地网段内的所有主机与路由器发送 IGMP 查询报文。
    3. 收到查询报文后,关注 G1 的 PAC 或 PCB 之一会向 G1 发送 IGMP 成员关系报告报文,以宣告其属于 G1,而本地网段的其他主机不在发送报告报文,即 IGMP 成员关系报告抑制机制,有助于减少本地网段的信息流量

    IGMP 离开组机制:

    1. 主机向本地网段内的所有组播路由器发送离开组报文。
    2. 查询器收到该报文后,向该主机的组播组发送特定组查询报文。
    3. 如果所在组还要其他长远主机,则会发送成员关系报告报文。
    4. 如果在最大响应时间内收到了成员关系报告报文,则继续位于该组播组的成员关系,否则认为该网段内已无该组播组的成员,不在维护成员关系。

    IPv6

    • 需要在交换机和路由器上打开:ipv6
    • 配置 ipv6 地址:ipv6 addr 1::1 64
    • ping ipv6:ping ipv6 1::2
    • 配置静态路由:ipv6 route-static 1::1 64 2::2

    配置 OSPFv3

    reset ospf all
    ospfv3 1
    router-id 1.1.1.1 # 在 ospfv3 视图配置 router-id,不是 router id !!!
    ospfv3 1 area 0 # 在每个端口配置 area,不需要引入 network
    

    查看配置情况

    dis ospfv3 routing-table
    dis ospfv3 lsdb
    dis ip rou
    

    问题:On-link 和 Off-link 的过程解析

    IPv4 通过 ARP 解析,IPv6 通过 NS 和 NA 解析(没有广播)。

    1. On-link:处于同一链路的两条主机要通信就要知道对方的 mac 地址,在 IPV4 中通过 ARP 实现,ARP 是通过广播实现的,但是 IPV6 中并没有广播的概念。在 IPV6 中,通过 ND 协议来完成这个地址解析的工作。ND 协议使用 ICMPv6 报文,其地址解析过程如下:
      1. 首先查找邻居缓存表(IPV6 nc),没有则进行地址解析 (类似于查找ARP表)。
      2. 源主机发送组播NS报文,该报文的目的地址为目标IPV6地址所对应的被请求节点组播地址(Solicited-node),在其中也包含了自己的链路层地址。
      3. 目标主机收到NS报文后,就会了解到发送主机的IPV6地址和相应链路层地址;同时由于目标主机正在使用报文内的目标地址,所以会目标主机向源主机单播发一个邻接点公告报文(NA),该报文中包含自己的链路层地址。
    2. Off-link:支持 IPV6 的主机有一个数据结构DestinationCache,要发送数据到某个目的地址的时候,首先查询这个数据结构,如果查不到,就查路由表,然后将查到的信息记录在这个数据结构中。如果查询到的目的地址是 on-link 的,将目的地址本身加入 DC 表的 nexthop 域;如果目的地址是 off-link 的,将路由表中的下一跳加入 DC 的 nexthop 域。

    问题:OSPFv3 报文种类

    截获完整 ospfv3 报文需要重启 ospf:

    1. Hello 报文:周期性地发送给本路由器的邻居,以发现及维持邻居关系,并选举DR,BDR。
    2. DD 报文(Database Description Packet,数据库描述报文):用来交换邻居路由器之间链路状态数据库(Link State Database,LSDB)的摘要信息,开始时,两个邻居路由器相互发送空DD报文来确定 Master/Slave 关系,
    3. LSR 报文(Link State Request Packet,链路状态请求报文):两台路由器相互交换了 DD 报文之后,通过比较确定缺少和需要更新的 LSA,并发送 LSR 报文向对方请求所需的 LSA。
    4. LSU 报文(Link State Update Packet,链路状态更新报文):向发送 LSR 报文的路由器发送其所需要的 LSA。
    5. LSAck 报文(Link State Acknowledge Packet,链路状态确认报文):对接收到的 LSU 报文进行确认。

    配置 BGP4+

    [R1] bgp 100
    [R1-bgp] router-id 1.1.1.1 # 使用 router-id !!!
    [R1-bgp] peer 1::2 as-number 200
    [R1-bgp] address-family ipv6
    [R1-bgp-ipv6] peer 1::2 enable
    [R1-bgp-ipv6] network 4::1 128
    
    展开全文
  • 1、了解常用网络命令的工作原理 2、掌握常用网络命令的使用 1、Ping命令的使用技巧 2、Netstat命令 3、ipconfig 4、ARP(地址转让协议)的使用技巧 5、Tracert 6、NBTStat命令
  • 计算机网络教程相关的实验报告,含有机柜设备的认识和网络拓扑的简略介绍
  • 计算机网络实验——抓包,实验内容+优秀实验报告
  • 基于Cisco Packet Tracer工具的计算机网络课程实验教学总结.pdf
  • 计算机网络通信的大学实验,全部都是xmind格式的思维导图,比较清晰的分析了各个实验中的重要知识点和考点。
  • 计算机网络实验报告

    2014-05-31 17:26:28
    实验网络组建: 第一项试验——组网试验; 第二项试验——路由配置试验; 第三项试验——VLAN 划分试验; 第四项试验——访问控制配置试验; 实验二Socket编程: 编写一个 FTP 客户端。 本程序已经完成的功能...
  • 计算机网络实验报告及心得体会

    热门讨论 2008-12-11 21:04:34
    计算机网络实验报告---- 包括网线制作,路由器配置,VLan,防火墙, ARP等 心得体会
  • 计算机网络vlan设置实验学习总结

    千次阅读 2020-05-31 20:16:25
    1 [画出拓扑图] 如下: 器材: 使用直连线 PC机 交换机 1.1设置PC机IP(如图) 2 [创建VLAN(打开cui)] 命令如下 en conf t vlan 2 name (名字)修改名字 end 3 [把端口VLAN加到0/2里面] ...Switch(config-if)# s
  • 计算机网络(自顶向下方法)》实验报告之实验四:(1) 学习IPTool网络抓包工具,含实验目的、环境/工具、步骤(含每个步骤截图/实物照片)、结果、心得。
  • 实验目的: 1. 掌握网络常用命令Hostname、Ipconfig、Route、Arp、Ping、Tracert、Nslookup、Net use、NbtStat、Netstat、Net view的使用方法; 2. 理解网络常用命令Hostname、Ipconfig、Route、Arp、Ping、Tracert...
  • 一、实验目的 (1)理解静态路由的含义。 (2)掌握路由器静态路由的配置方法。 (3)理解默认路由的含义。 (4)掌握默认路由的配置方法。 ... 二、实验仪器 ...所以,静态路由主要适合网络规模...
  • 实验目的 交换机的Telnet远程登陆配置 实验原理 远程登陆及端口应用的关系 实验环境 Windows10操作系统下的Cirsco Packet Tracer5.3 实验方案设计 1.配置pc6: 2.配置PC7: 3.配置Switch1 4.配置Router2 5.同理配置...
  • 计算机网络课程实验报告 实验1Internet应用及典型应用层协议的深入知识 姓名 院系 软件学院 学号 任课教师 指导教师 实验地点 软件学院三楼机房 实验时间 2011-5-6 实验课表现 出勤表现得分(10) 实验报告 得分(40) ...
  • 计算机网络(自顶向下方法)》实验报告之实验五:交换机基础配置,含实验目的、环境/工具、步骤(含每个步骤截图/实物照片)、结果、心得。
  • 广东工业大学实 验 报 告实验名称计算机网络实验开 课 学 院计算机学院指导教师姓名专 业 班 级学 生 姓 名学 生 学 号实验名称GNS3安装使用与交换机技术实验日期学生姓名一、实验目的1、掌握GNS3搭建网络拓扑2、...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 71,009
精华内容 28,403
关键字:

计算机网络实验总结