精华内容
下载资源
问答
  • 计算机网络综合实验

    2018-04-20 12:29:08
    大连理工大学计算机网络实验答案,学长之前传下来的,分享给大家!!!!!!!!!!!!!!!!!!!!
  • 地方本科院校计算机网络综合实验探索研究.pdf
  • PAGE 1 通信工程专业综合实验 第一部分 计算机网络综合实验 实验报告 学院 电子信息工程学院 目 录 实验一网络设备的基本操作 (2) 实验二网络交换机实验 (5) 实验三路由器基本应用实验 (11) 实验一网络设备的基本...
  • 关于计算机网络类的论文计算机网络类论文:计算机网络综合实验室在实习实训中的作用.pdf
  • 一种基于多虚拟平台的计算机网络综合实验模拟系统构建.pdf
  • 河南大学计算机网络实验综合设计实验源码加实验报告,包含网络VLAN规划表和IP地址规划表,网络的拓扑图,所有用到的交换机和路由器的配置文件,下载之后直接导入就可以运行。
  • 利用抓包软件获取报文,进行协议分析 在capture菜单中选中options,可以设置抓包选项
  • 实验目的 综合回顾并考察本学期实验内容 实验内容 模拟某学校网络拓扑结构 在该学校网络接入层采用 S2126 交换机 接入层交换机划分 了办公网 VLAN2 和学生网 VLAN4 VLAN2 和 VLAN4 通过汇聚层 S3550 与路由器 A 相连...
  • 实验目的 综合回顾并考察本学期实验内容 实验内容 模拟某学校网络拓扑结构 在该学校网络接入层采用 S2126 交换机接入层交换机划分了办公网 VLAN2 和学生网 VLAN4 VLAN2 和 VLAN4 通过汇聚层 S3550 与路由器 A 相连...
  • 基于eNSP的计算机网络实验(三)   本次实验的一下两个内容: 使用单臂路由和两台二层交换机实现不同VLAN的互通 使用单个三层交换机实现不同VLAN的互通 背景知识     要进行下面的实验,我们需要首先...

    基于eNSP的计算机网络实验(三)

      本次实验的一下两个内容:

    之前的两个实验:
    基于eNSP模拟结合实际操作的计算机网络实验(二)
    基于eNSP模拟结合实际操作的计算机网络实验(一)
    之后的实验:
    实验四

    • 使用单臂路由和两台二层交换机实现不同VLAN的互通
    • 使用单个三层交换机实现不同VLAN的互通

    背景知识


        要进行下面的实验,我们需要首先需要熟悉下面的这些基础知识,就是要掌握,不然做实验的时候会云里雾里,之前我也是这样,不过在大佬的帮助下实验虽然完成了,但是还是后面总结的时候才真正理解,进而在eNSP上进行再次模拟。


    1. 不同网络进行互联需要设置网关。

    2. PC访问其他的网段同样需要设置网关。

    3. 路由器的网口可以设置子接口,子接口的数量为4094个,与VLAN的个数是一致的,即一个子接口只能对应一个VLAN,即只能作为一个VLAN的网关。

    4. 路由器通过子接口可以实现在一个物理接口上设置多个网关对应同样数目的VLAN。

    5. 二层、三层交换机都可以设置VLAN。

    6. 三层交换机可以给VLAN设置虚接口,并给虚接口配置IP地址,实现网关、路由等网络层的功能,也就是VLAN管理IP。



    使用单臂路由和两台二层交换机实现不同VLAN的互通

      这个实验的组网拓扑于表格内容如下所示:

    在这里插入图片描述


    设备信息表格如下所示:

    设备名称接口接口类型所属VLAN or PVIDIP地址、掩码和网关
    二层交换机sw1Ethernet0/0/1
    Ethernet0/0/2
    g0/0/3
    access
    trunk
    trunk
    vlan 10
    allow-pass vlan 10 20
    allow-pass vlan 10 20
    -
    -
    -
    二层交换机sw2Ethernet0/0/1
    Ethernet0/0/2
    access
    trunk
    vlan 20
    allow-pass vlan 10 20
    -
    -
    路由器AR1g0/0/1.10
    g0/0/1.20
    子接口
    子接口
    -ip add 192.168.1.254 24
    ip add 192.168.2.254 24
    PC1Ethernet0/0/1accessvlan 10192.168.1.1
    255.255.255.0
    192.168.1.254
    PC2Ethernet0/0/1accessvlan 20192.168.1.2
    255.255.255.0
    192.168.2.254

    第一个交换机设置如下所示:

    The device is running!
    
    <Huawei>sys
    
    [Huawei]sysn sw1
    [sw1-Ethernet0/0/1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]port default vlan 10
    
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type trunk
    [sw1-Ethernet0/0/2]port trunk allow-pass vlan 10 20
    
    [sw1-Ethernet0/0/2]int g0/0/1
    [sw1-GigabitEthernet0/0/1]port link-type trunk
    [sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20
    [sw1-GigabitEthernet0/0/1]
    

    第二个交换机设置如下所示:

    <Huawei>sys
    
    [Huawei]sysn sw2
    [sw2]int e0/0/1
    
    [sw2-Ethernet0/0/1]q
    [sw2]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2]int e0/0/1
    [sw2-Ethernet0/0/1]port link-type access
    [sw2-Ethernet0/0/1]port default vlan 20
    [sw2-Ethernet0/0/1]port e0/0/2
    
    [sw2]int e0/0/2
    [sw2-Ethernet0/0/2]port link-type trunk
    
    [sw2-Ethernet0/0/2]port trunk allow-pass vlan 10 20
    [sw2-Ethernet0/0/2]
    
    

    路由器设置如下所示:

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]int g0/0/1.1
    [Huawei-GigabitEthernet0/0/1.1]q
    [Huawei]int g0/0/1.10
    [Huawei-GigabitEthernet0/0/1.10]ip add 192.168.1.254 24
    
    [Huawei-GigabitEthernet0/0/1.10]dot1q termination vid 10
    
    [Huawei-GigabitEthernet0/0/1.10]q
    [Huawei]int g0/0/1.20
    [Huawei-GigabitEthernet0/0/1.20]ip add 192.168.2.25
                                                        ^
    Error:Incomplete command found at '^' position.
    [Huawei-GigabitEthernet0/0/1.20]ip add 192.168.2.254 24
    [Huawei-GigabitEthernet0/0/1.20]dot1q termination vid 20
    
    [Huawei-GigabitEthernet0/0/1.20]arp broadcast enable
    [Huawei-GigabitEthernet0/0/1.20]q
    [Huawei]int g0/0/1.10
    [Huawei-GigabitEthernet0/0/1.10]arp broadcast enable
    [Huawei-GigabitEthernet0/0/1.10]
    
    

      在这里说一下,在实际操作中,我们不需要使用到arp broadcast enable 命令,在ensp上进行模拟的时候需要输入这个命令罢了,原因是在实际的华为这个上面它是默认配置了的,但是我们在ensp上需要手动输入配置ARP广播,是因为路由器的接口隔离了广播域,其中,每一个接口就是一个广播域,而ARP报文只能够在同一个广播域之中泛洪,所以我们在这里开启ARP广播。

      而对路由器配置子接口,主要是为了节省接口,在实际操作过程中节省费用,降低使用成本。

      子接口配置dot1q的目的是为了带VLAN的数据帧进入的时候比较PVID,如果相同则接收,不同则丢弃,带VLAN的数据帧出去的时候比较PVID相同则剥掉tag,不同则丢弃,和ACCESS接口类似,这方面的知识不懂的去看我前一篇博客有 详细介绍


    使用单个三层交换机实现不同VLAN的互通

      这个实验的组网拓扑于表格内容如下所示:

    在这里插入图片描述

    设备名称接口接口类型所属VLAN or PVIDIP地址、掩码和网关
    三层交换机sw1GE0/0/1
    GE0/0/2
    access
    access
    vlan 10
    vlan 10
    -
    -
    int vlan 10

    int vlan 20
    ip address 192.168.1.254 24
    ip address 192.168.2.254 24
    PC1Ethernet0/0/1accessvlan 10192.168.1.2
    255.255.255.0
    192.168.1.254
    PC2Ethernet0/0/1accessvlan 20192.168.2.3
    255.255.255.0
    192.168.2.254

    第一个交换机的脚本设置如下所示:

    <Huawei>
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysn sw1
    [sw1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]int g0/0/1
    [sw1-GigabitEthernet0/0/1]port link-type access
    [sw1-GigabitEthernet0/0/1]port default vlan 10
    [sw1-GigabitEthernet0/0/1]int g0/0/2
    [sw1-GigabitEthernet0/0/2]port link-type access
    [sw1-GigabitEthernet0/0/2]port default vlan 20
    [sw1-GigabitEthernet0/0/2]
    [sw1]int vlan 10
    [sw1-Vlanif10]ip address 192.168.1.254 24
    [sw1-Vlanif10]int vlan 20
    [sw1-Vlanif20]ip address 192.168.2.254 24
    

       我们需要注意的是三层交换机的用户,将连接PC的端口加入到某一个VLAN之中,不能够直接对交换机的端口添加IP地址,因为交换机的端口默认为2层接口,不能直接添加IP地址,所以需要通过将VLAN与接口绑定后,针对VLAN添加IP地址,相当于对其绑定的接口添加IP地址。

    展开全文
  • 静态动态路由神马的简直是弱爆了,果断ACL实验走起,含实验代码以及详细过程,简单易懂,自己做的哦
  • 基于eNSP的计算机网络实验-----完结篇一、路由器基本配置和静态路由1.背景知识2.ENSP模拟过程3.实际网络设备操作二、路由器动态配置(RIP、OSPF协议) 【有时间再细细回想来写】1.背景知识2.ENSP模拟过程3.实际网络...



    之前实验:
    基于eNSP模拟结合实际操作的计算机网络实验(三)
    基于eNSP模拟结合实际操作的计算机网络实验(二)
    基于eNSP模拟结合实际操作的计算机网络实验(一)

    • 对静态路由进行配置,测试网络连通性
    • 路由器动态配置(RIP、OSPF协议),对动态路由进行配置,测试网络连通性
    • 运用基本ACL来进行访问控制配置,测试网络连通性


    一、路由器基本配置和静态路由

    1.背景知识

        3台路由器分别连接到不同的网络,在路由器上进行适当配置,实现不同网段之间PC机之间的相互通信。

    配置静态路由相关指令命令:
        ip route-static :静态路由配置命令(command)
        Network:目标网络(destination network)
        mask:网络掩码(subnet mask)
        Address:下一跳地址(Next-hop address)
        Interface:本地出接口(Local outgoing interface)
        Distance:管理距离(administrative distance )

    路由:是把一个数据从一个网络转发到另一个网络的过程,完成这个过程的设备就是路由器。
    路由器:是网络层设备,是一个根据IP包头信息,选择最佳路径,将数据包转发出去的设备,路由器中的路由数据包有目的地址、源地址、可能路由、最佳路由、维护和更新路由信息组成。
    生成路由项
      配置路由表接口IP地址和子网掩码 —— 直连路由
      手工配置 —— 静态路由
      协议自动配置 —— 动态路由

    路由过程中的数据包交换:
    (1) 主机A发B的数据在网络层封装IP数据包,包首部包含源地址和目标地址;
    (2) 主机A用本机24IP掩码与目标地址进行与运算。若不在一个网段,则将ip数据包发到网关;
    (3) 发往网关前A通过ARP请求获得网关MAC地址。将IP数据包封装成帧。再发往网关,也就是路由器一个接口;
    (4) 网关路由器接收到以太网数据帧,如目标MAC地址是自己某个端口物理地址,路由器把以太网帧封装去掉,路由器会认为这个IP数据包要通过自己进行转发,接着就匹配路由表,匹配后,将包发往下一条地址。
    总之,路由器转发数据包始终不改IP ,只改MAC地址。

    2.ENSP模拟过程

    模拟组网内容描述:
    (1) R1、R2、R3三台路由器,R1连接PC1,R3连接PC2,PC1、PC2处于不同网段
    (2) 配置R1、R2、R3,使处于不同网段的PC1、PC2能够ping通
    (3) 模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

    对路由器设置:

    R1:[R1] int g0/0/0
        [R1-GigabitEthernet0/0/0] ip add 192.168.53.1 24
        [R1-GigabitEthernet0/0/1] int g0/0/1 
        [R1-GigabitEthernet0/0/1] ip add 192.168.50. 254 24
        [R1] ip route-static 192.168.60.0 24 192.168.53.2
         
    R2:[R2] int g0/0/0
        [R2-GigabitEthernet0/0/0] ip add 192.168.53.2 24
        [R2-GigabitEthernet0/0/1] int g0/0/1 
        [R2-GigabitEthernet0/0/1] ip add 192.168.57. 1 24
        [R2] ip route-static 192.168.60.0 24 192.168.57.2
        [R2] ip route-static 192.168.50.0 24 192.168.53.1
    
    R3:[R3] int g0/0/0
    	[R3-GigabitEthernet0/0/0] ip add 192.168.57.2 24
        [R3-GigabitEthernet0/0/0] int g0/0/1 
        [R3-GigabitEthernet0/0/1] ip add 192.168.60. 254 24
        [R3] ip route-static 192.168.50.0 24 192.168.57.1
    

    在这里插入图片描述
    上图可见,我们模拟成功,进入实际设备操作环节;

    3.实际网络设备操作

    设备名称接口接口类型所属VLANIP地址、掩码和网关
    PC1Ethernet0/0/1access/192.168.100.2
    255.255.255.0
    192.168.100.1
    PC2Ethernet0/0/1access/192.168.103.100
    255.255.255.0
    192.168.103.1
    R1GigabitEthernet0/0/0子接口
    子接口
    -ip add 192.168.1.254 24
    ip add 192.168.2.254 24
    PC1Ethernet0/0/1accessvlan 10192.168.1.1
    255.255.255.0
    192.168.1.254
    PC2Ethernet0/0/1accessvlan 20192.168.1.2
    255.255.255.0
    192.168.2.254

    路由器R1:
    在这里插入图片描述
    在这里插入图片描述

    【就贴一个R1的图吧,图太多太乱不想找了,就这样吧,实际设备问题挺多的,但是和模拟的流程差不多】

    结果:
    在这里插入图片描述

    二、路由器动态配置(RIP、OSPF协议) 【有时间再细细回想来写】

    1.背景知识

    动态路由是路由协议自动建立和管理的路由,常见动态路由协议有:
        RIP(Routing Information Protocol) 最古老的路由协议;
        IGRP(Interior Gateway Routing Protocol)思科私有路由协议,现已基本淘汰;
        EIGRP(Enhance Interior Gateway Routing Protocol);
        OSPF(Open Shortest Path First)思科私有路由协议,高级的距离矢量;
        BGP(Backbone Getway Protocol)外部网关协议,企业内部不适用;
    不可路由协议,NetBEUI协议。
        对于不同的路由协议到一个目的地的路由信息,路由器选择信任哪个路由信息源?管理距离AD 管理距离:是标识路由可信度的信任等级。AD值越低,优先级越高。

    RIP协议简介:
        RIP协议是基于距离矢量算法的。它使用“跳数” 来衡量到达目标地址的路由距离。路由器交换信息是通过定期广播整个路由表所能到达的适用网络号码。(网络规模大时路由表大,难维护。

    OSPF协议简介:
        OSPF协议采用链路状态算法。执行该算法的路由器不是简单的从相邻的路由器学习路由,而是把路由器分成区域,收集区域内所有路由器的链路状态信息,根据链路状态信息生成网络拓扑结构,每一个路由器再根据拓扑结构图计算出路由。(配置相对复杂)
    在这里插入图片描述

    2.ENSP模拟过程

    RIP调试命令

    display ip routing-table           /*显示路由表*/
    undo route rip                     /*删除RIP路由配置*/
    display ip interface br            /*查看接口的启用ip地址*/
    display interfaces                 /*显示接口信息*/
    debugging hdlc all serial0         /*显示所有信息*/
    debugging hdlc event serial0       /*调试事件信息*/
    debugging hdlc packet serial0      /*显示包的信息*/
    

    OSPF调试命令

    ospf 1                             /*1代表进程号,如果没注明,默认进程为1*/
    area 0                             /*声明ospf区域为area 0*/
    Network 192.168.100.0 0.0.0.255    /*发布自身直连的网段,后加反掩码*/ 
    

    模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

    基于RIP协议下路由器的设置如下:
    R1:

    [R1] int g0/0/0
    [R1-GigabitEthernet0/0/0] ip add 192.168.53.1 24
    [R1-GigabitEthernet0/0/1] int g0/0/1 
    [R1-GigabitEthernet0/0/1] ip add 192.168.50. 254 24
    [R1] rip 1                            
    [R1-rip-1] version 2
    [R1-rip-1] network 192.168.50.0
    [R1-rip-1] network 192.168.53.0
    [R1-rip-1] q
    

    R2:

    [R2] int g0/0/0
    [R2-GigabitEthernet0/0/0] ip add 192.168.53.2 24
    [R2-GigabitEthernet0/0/1] int g0/0/1 
    [R2-GigabitEthernet0/0/1] ip add 192.168.57. 1 24
    [R2] rip 1
    [R2-rip-1] version 2
    [R2-rip-1] network 192.168.53.0
    [R2-rip-1] network 192.168.57.0
    [R2-rip-1] q
    

    R3:

    [R3] int g0/0/0
    [R3-GigabitEthernet0/0/0] ip add 192.168.57.2 24
    [R3-GigabitEthernet0/0/0] int g0/0/1 
    [R3-GigabitEthernet0/0/1] ip add 192.168.60. 254 24
    [R3] rip 1
    [R3-rip-1] version 2
    [R3-rip-1] network 192.168.57.0
    [R3-rip-1] network 192.168.60.0
    [R3-rip-1] q
    

    3.实际网络设备操作


    啊,我好懒,上面的设备表懒得打了,直接贴实际操作代码了
    R1:

    <Huawei>sys
    [Huawei]sysn R1-OSPF
    [R1-OSPF]int g0/0/0
    [R1-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.1 24
    [R1-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R1-OSPF-GigabitEthernet0/0/1]ip add 192.168.50.254 24
    [R1-OSPF-GigabitEthernet0/0/1]q
    [R1-OSPF]ospf 1 router-id 2.2.2.2
    [R1-OSPF-ospf-1]area 0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.50.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]q
    


    R2:

    [Huawei]sysn R2-OSPF
    [R2-OSPF]int g/0/0/0
    [R2-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.2 24
    [R2-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R2-OSPF-GigabitEthernet0/0/1]ip add 192.168.57.1 24
    [R2-OSPF-GigabitEthernet0/0/1]q
    [R2-OSPF-ospf-1]area 0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]q
    


    R3:

    [Huawei]sysn R3-OSPF
    [R3-OSPF]int g0/0/1
    [R3-OSPF-GigabitEthernet0/0/1]ip add 192.168.60.254 24
    [R3-OSPF-GigabitEthernet0/0/1]intg0/0/0
    [R3-OSPF-GigabitEthernet0/0/0]ip add 192.168.57.2 24
    [R3-OSPF-GigabitEthernet0/0/0]q
    [R3-OSPF]ospf 1 router-id 3.3.3.3
    [R3-OSPF-ospf-1]area 0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.60.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]
    

    在这里插入图片描述
    在这里插入图片描述 在这里插入图片描述


    三、ACL和NAT配置

    1.背景知识

    1.1 ACL

    运用基本ACL配置来实现对于一个网络进行访问控制,其实验拓扑图如下所示:
    在这里插入图片描述
        这里的话我们就用两台电脑来实现访问控制,在实际场景下的我们可以通过对不同的接口进行选取来实现两台PC进行访问控制列表ACL
        主要的实验要求就是两个PC之间只有休息时间可以进行通信,其余时间不能够进行通信,我们通过设置两对端口之间能够正常进行通信,另外两个端口这些时间不能进行通信。

    基本ACL配置步骤:
      (1) 配置路由器端口地址
      (2) 配置路由
      (3) 配置ACL生效时间
      (4) 创建ACL列表
      (5) 配置ACL规则
      (6) 在接口下应用ACL

    配置访问控制列表ACL相关指令命令
        acl [ number ] 命令用来创建一个ACL,并进入ACL视图
        rule [ rule-id ] { deny | permit } source { source-address source-wildcard | any } 命令用来增加或修改ACL的规则。deny用来指定拒绝符合条件的数据包,permit用来指定允许符合条件的数据包,source用来指定ACL规则匹配报文的源地址信息,any表示任意源地址。
        traffic-filter { inbound | outbound }acl{ acl-number }命令用来在接口上配置基于ACL对报文进行过滤。
        本示例中,主机A发送的流量到达RTA后,会匹配ACL2000中创建的规则rule deny source192.168.1.0 0.0.0.255,因而将被拒绝继续转发到Internet。主机B发送的流量不匹配任何规则,所以会被RTA正常转发到Internet。

    ACL还有很多原理和规则自己百度,我很懒,不想打了。

    1.2 NAT

    在这里插入图片描述
    NAT基本配置实验原理
        NAT是指把局域网内部私有地址与Internet全局地址(公网地址)建立对应关系,这种关系称为映射;
        使用内部地址的主机在访问Internet时或被Internet上的主机访问时,数据报均在该局域网的网关(路由器)上进行地址之间的转换;
        NAT设置在内部网域外部公用网连接处的路由器上,路由器至少有一个内部端口以及一个外部端口,内部端口连接内部网络用户使用内部专用ip地址,外部端口连接的是外部的网络,如internet,使用的是公网ip地址;

    NAT分类:
        (1) 静态NAT:将内部专用地址与全局合法地址进行一对一的转换,需要指定和哪个合法地址进行转换;
        (2) 动态NAT:pool NAT执行专用地址与全局地址的一对一转换,但全局地址与专用地址的对应关系不是一成不变的,它是从全局地址池(pool)中动态的选择一个全局地址与一个内部专用地址相对应;
        (3) 复用地址转换:Port NAT可以允许多个内部本地地址共用一个全局合法地址,当只申请到少量全局合法ip地址,但却经常同时有多个用户上外部网络时,这种转换是很有用的;

    NAT工作流程什么的自己百度,不再详述。

    2.ENSP模拟过程

    2.1 ACL

    这个实验我们是基于之前所做的动态路由来做的,所以经过如下配置,我们能够使PC1 ping 通PC2,我们在路由器R3上进行ACL的设置,使之能够拒绝PC1网段的访问,那么,我们所期待的结果就是经过设置ACL后,PC1无法ping通PC2

    模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

                                jiang学主义好!!
                             ▅▅▅▅▅▆▇▅▅▄▄▄▄▄▄▄
                            ▄▅▅▅▇█▇▆▆▆▇▆▄▄▄▄
                            ▄▄▄▆▇▆▅▄▃▃▄▆▆▄▄▄
                            ▄▄▄█▇▅▄▃▃▃▃▅▇▄▄▄
                            ▃▄▄█▇▆▄▃▃▃▃▄▇▄▄▃
                            ▃▃▃▇█▇▆▅▅▅▄▅▆▃▃▃
                            ▃▃▃▆▇▆▅▆▆▅▄▅▄▃▃▂
                            ▂▃▂▅▇▅▄▆▄▅▄▄▃▂▂▂
                            ▂▂▂▄▇▆▅▆▄▄▄▃▂▂▂▂
                            ▂▂▂▂▆▆▆▆▄▄▄▃▂▂▂▁
                            ▁▂▁▁▆▇▆▅▄▃▄▂▁▁▁▁
                            ▁▁▁▄▇▇▇▅▄▄▃ ▁▁▁▁
                              ▃▇██▆▆▇▆▅▅▅▂   
                            ▅█████▄▃▅▁▅██▆▃ 
                            ██████▅▄▇▄▅████▆

    对于各个路由器的设置如下:
    R1:

    [Huawei]sysn R1-OSPF
    [R1-OSPF]int g0/0/0
    [R1-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.1 24
    [R1-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R1-OSPF-GigabitEthernet0/0/1]ip add 192.168.50.254 24
    [R1-OSPF-GigabitEthernet0/0/1]q
    [R1-OSPF]ospf 1 router-id 1.1.1.1
    [R1-OSPF-ospf-1]area 0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.50.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]q
    

    R2:

    [Huawei]sysn R2-OSPF
    [R2-OSPF]int g/0/0/0
    [R2-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.2 24
    [R2-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R2-OSPF-GigabitEthernet0/0/1]ip add 192.168.57.1 24
    [R2-OSPF-GigabitEthernet0/0/1]q
    [R2-OSPF]ospf 1 router-id 2.2.2.2
    [R2-OSPF-ospf-1]area 0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]q
    

    R3:

    [Huawei]sysn R3-OSPF
    [R3-OSPF]int g0/0/1
    [R3-OSPF-GigabitEthernet0/0/1] ip add 192.168.60.254 24
    [R3-OSPF-GigabitEthernet0/0/1] int g0/0/0
    [R3-OSPF-GigabitEthernet0/0/0] ip add 192.168.57.2 24
    [R3-OSPF-GigabitEthernet0/0/0] q
    [R3-OSPF] ospf 1 router-id 3.3.3.3
    [R3-OSPF-ospf-1] area 0
    [R3-OSPF-ospf-1-area-0.0.0.0] network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0] network 192.168.60.0 255.255.255.0
    [R3] time-range lc 06:00 to 22:59 working-day
    [R3] acl number 3000
    [R3-acl-adv-3000] rule 0 deny ip source 192.168.50.0 0.0.0.255 destionation 192.168.60.0 0.0.0.255 time range lc
    [R3-acl-adv-3000] int g0/0/1
    [R3-GigabitEthernet0/0/1] traffic-filter outbound acl 3000
    

    2.2 NAT

    如上图实验拓扑图所示,我们对于NAT实验的各类IP设置如下所示:

    内网PC ip 为:192.168.50.1
    外网PC ip 为:202.1.1.9
    

    3.实际网络设备操作

    3.1访问控制列表ACL实际实验

    在这里插入图片描述
    在这里插入图片描述

    3.2 网络地址转换NAT实际实验

    在这里插入图片描述

    4.ACL和NAT实验结果:

    4.1 ACL实验结果

    在这里插入图片描述
    在这里插入图片描述

    4.2 NAT实验结果

    在这里插入图片描述

    展开全文
  • 基于eNSP的计算机网络实验 2019-05-13 11:06:34 tags: [eNSP] [计算机网络] 基于eNSP的相关计算机网络实验    这个实验记录随着学习进度的进行不断进行更新,主要为基于华为eNSP环境下进行的熟悉计算机网络的相关...

    基于eNSP的相关计算机网络实验


    2019-05-13 11:06:34

    更新的下一篇内容:基于eNSP结合实际操作的的计算机网络实验(二)
    next:实验(三)
    终结篇:实验(终章)


       这个实验记录随着学习进度的进行不断进行更新,主要为基于华为eNSP环境下进行的熟悉计算机网络的相关实验,这个实验主要为熟悉掌握计算机网络的结构和工作原理,深入理解交换机、路由器、无限网络的工作原理,目前这个实验包括下面几个内容:

    • 单台PC机联通交换机的实验配置
    • 单台交换机上使用VLAN来隔离PC
    • 跨交换机实现不同VLAN的通信与隔离
    • 不同VLAN间实现通信

    实操图如下 (#_#)
    在这里插入图片描述
    在这里插入图片描述

    单台PC机联通交换机的实验配置

    相关操作如下所示:

    1. 进入系统视图
    2. 交换机接口配置
    3. 添加交换机虚拟ip
    4. 尝试ping

    在这里插入图片描述

       在eNSP上交换机的设置脚本如下所示:

    The device is running!
    
    <Huawei>
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]
    May 14 2019 10:26:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 4, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]
    May 14 2019 10:27:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 5, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]interface vlanif1
    [sw1-Vlanif1]ip address 10.10.10.6 255.255.255.0
    [sw1-Vlanif1]
    May 14 2019 10:28:58-08:00 sw1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
     on the interface Vlanif1 has entered the UP state.
    [sw1-Vlanif1]display currn
    May 14 2019 10:29:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 6, the c
    hange loop count is 0, and the maximum number of records is 409
    #
    sysname sw1
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
     ip address 10.10.10.6 255.255.255.0
    
    [sw1-Vlanif1] User interface con0 is available
    

    在这里插入图片描述

    在这里插入图片描述


    单台交换机上使用VLAN来隔离PC

    相关操作如下所示:

    1. 在单台交换机上使用不同的vlan域来对进行PC隔离
    2. 交换机端口配置
    3. 配置PC的ip地址
    4. 划分vlan区域

    在这里插入图片描述
       在eNSP上交换机的设置脚本如下所示:

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]
    May 14 2019 10:33:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 5, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]port default vlan 10
    [sw1-Ethernet0/0/1]
    May 14 2019 10:34:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 7, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type access
    [sw1-Ethernet0/0/2]port default vlan 20
    [sw1-Ethernet0/0/2]
    May 14 2019 10:34:27-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 9, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]port link-type access
    [sw1-Ethernet0/0/3]
    May 14 2019 10:34:47-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 10, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/3]port default vlan 10
    [sw1-Ethernet0/0/3]
    May 14 2019 10:34:53-08:00 sw1 %%01IFNET/4/IF_STATE(l)[0]:Interface Vlanif1 has 
    turned into DOWN state.
    May 14 2019 10:34:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 11, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/3] User interface con0 is available
    

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    实现效果图如下所示:

    在这里插入图片描述


    跨交换机实现不同VLAN的通信与隔离

    相关操作如下所示:

    1. 配置两台交换机的接口VLAN
    2. 配置交换机与PC的端口连接
    3. 配置交换机端口间的连接方式
    4. 配置PC的ip地址
    5. 验证PC机两两之间的连通性

    在这里解释一下两台交换机之间进行的trunk,trunk是端口进行汇聚的意思,它允许交换机与交换机、交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行进行连接,同时传输来提供更高的带宽、更大的吞吐量,大幅度提高整个网络能力。VLAN trunk是指设置了多个VLAN之后,想通过一个端口来传输我们设置的多个VLAN,我们就需要在交换机这里设置这个端口为trunk。trunk技术使得一条物理线路可以传送多个VLAN的数据,更加具体的细节你想了解的话可以去查查资料。

    在这里插入图片描述
       在eNSP上交换机的设置脚本如下所示:

    <Huawei>sys 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]
    May 14 2019 10:38:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 4, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]port default v
    May 14 2019 10:39:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 5, the c
    hange loop count is 0, and the maximum number of records is 4095.
                                      ^
    Error:Incomplete command found at '^' position.
    [sw1-Ethernet0/0/1]q
    [sw1]
    [sw1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]
    May 14 2019 10:39:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 6, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]port default vlan 10
    [sw1-Ethernet0/0/1]
    May 14 2019 10:39:47-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 7, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type access
    [sw1-Ethernet0/0/2]port defa
    May 14 2019 10:40:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 8, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-port-group-defa]port default vlan 20
    [sw1-port-group-defa]q
    [sw1]
    May 14 2019 10:40:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 9, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/2
    [sw1-Ethernet0/0/2]port default vlan 20
    [sw1-Ethernet0/0/2]int e
    May 14 2019 10:40:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 10, the 
    change loop count is 0, and the maximum number of records is 4095.
                       ^
    Error: Unrecognized command found at '^' position.
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]port link-type trunk
    [sw1-Ethernet0/0/3]port trunk
    May 14 2019 10:43:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 11, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-port-group-trunk]port trunk allow-pass 
    May 14 2019 10:44:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 12, the 
    change loop count is 0, and the maximum number of records is 4095.
                                                ^
    Error:Incomplete command found at '^' position.
    [sw1-port-group-trunk]q
    [sw1]int e0/0/3
    [sw1-Ethernet0/0/3]port trunk allow-pass vlan 10 20
    [sw1-Ethernet0/0/3]
    May 14 2019 10:44:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 13, the 
    change loop count is 0, and the maximum number of records is 4095.
    

    另一个交换机的设置也是差不多的,这里就不展示了
    在这里插入图片描述

    在这里插入图片描述
    在这里插入图片描述

    不同VLAN间实现通信

    相关操作如下所示:

    1. 交换机接口配置
    2. 创建多个VLAN域
    3. 设置PC的ip地址、网关配置

    在这里插入图片描述
       在eNSP上交换机的设置脚本如下所示:

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]
    May 14 2019 10:50:47-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 4, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]
    May 14 2019 10:50:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 5, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]
    May 14 2019 10:51:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 6, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]port default vlan 10
    [sw1-Ethernet0/0/1]int
    May 14 2019 10:51:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 7, the c
    hange loop count is 0, and the maximum number of records is 4095.
                       ^
    Error: Unrecognized command found at '^' position.
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type access
    [sw1-Ethernet0/0/2]port 
    May 14 2019 10:51:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 8, the c
    hange loop count is 0, and the maximum number of records is 4095.
                            ^
    Error:Incomplete command found at '^' position.
    [sw1-Ethernet0/0/2]port default vlan 20
    [sw1-Ethernet0/0/2]
    May 14 2019 10:52:06-08:00 sw1 %%01IFNET/4/IF_STATE(l)[0]:Interface Vlanif1 has 
    turned into DOWN state.
    May 14 2019 10:52:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 9, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/2]int vlanif10
    [sw1-Vlanif10]
    May 14 2019 10:52:21-08:00 sw1 %%01IFNET/4/IF_STATE(l)[1]:Interface Vlanif10 has
     turned into UP state.
    [sw1-Vlanif10]ip address 192.168.1.254 24
    [sw1-Vlanif10]
    May 14 2019 10:53:16-08:00 sw1 %%01IFNET/4/LINK_STATE(l)[2]:The line protocol IP
     on the interface Vlanif10 has entered the UP state.
    May 14 2019 10:53:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 10, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Vlanif10]int  vlanif20
    [sw1-Vlanif20]
    May 14 2019 10:53:28-08:00 sw1 %%01IFNET/4/IF_STATE(l)[3]:Interface Vlanif20 has
     turned into UP state.
    [sw1-Vlanif20]ip address 192.168.2.254 24
    [sw1-Vlanif20]
    May 14 2019 10:53:57-08:00 sw1 %%01IFNET/4/LINK_STATE(l)[4]:The line protocol IP
     on the interface Vlanif20 has entered the UP state.
    May 14 2019 10:53:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 11, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Vlanif20]q
    [sw1]display ip interface brief
    *down: administratively down
    ^down: standby
    (l): loopback
    (s): spoofing
    The number of interface that is UP in Physical is 3
    The number of interface that is DOWN in Physical is 2
    The number of interface that is UP in Protocol is 3
    The number of interface that is DOWN in Protocol is 2
    
    Interface                         IP Address/Mask      Physical   Protocol  
    MEth0/0/1                         unassigned           down       down      
    NULL0                             unassigned           up         up(s)     
    Vlanif1                           unassigned           down       down      
    Vlanif10                          192.168.1.254/24     up         up        
    Vlanif20                          192.168.2.254/24     up         up        
    [sw1]
    

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    总结: …等试验内容更完了再写

    展开全文
  • 计算机网络综合实验(期末)

    千次阅读 2018-12-21 17:57:48
    拓扑关系图 配置情况: ...如相连的为pc2\31\32\41\42,总结其网络地址相连即可 默认路由的配置(总的在R0上配置),即跳到与要指向路由器的相连接口地址即可 在R22上配置RIP,同R21理,但是要将版本改成version 2。 R22
    拓扑关系图

     

    配置情况:

    交换机:

    S1
    S2

     

    S0

     

    路由器:

    (lan1)

    R13

    在左边虚网中,需要在三台路由器中配置OSPF协议。

    R12

     

    R11

    R11作为总更新OSPF协议的路由器

    需要使用default-information originate 命令将该静态路由包括从路由

    R12/13发出的OSPF更新。

    R0

    在R0上配置总静态路由步骤:

    (1).总结所有主机网络

    (2).计算总结掩码

    (3).主机相关的路由器接口地址

    如:与pc2 相关路由器为R21的se0/0/1 --172.16.3.1

           与pc31/32/41/42相关为R21的se0/0/0--172.16.2.18

           与pc12/13相关为R21的fa0/0--172.16.2.2

    (lan2)

    R21

    在R21上配置rip(动态),在全局配置(config)模式下进入路由配置模式(route rip),

    直连pc的有类网络地址。如相连的为pc2\31\32\41\42,总结其网络地址相连即可

    默认路由的配置(总的在R0上配置),即跳到与要指向路由器的相连接口地址即可

    在R22上配置RIP,同R21理,但是要将版本改成version 2。

    R22
    展开全文
  • 基于eNSP的计算机网络实验(二) 小雅的博客   本次实验的一下两个内容: 基于trunk和access实现不同VLAN间通信(上一篇的第四个内容为使用了VLAN接口配置ip,所以能够实现不同VLAN间的通信,这里是另一个方法) ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 36,456
精华内容 14,582
关键字:

计算机网络综合实验