精华内容
下载资源
问答
  • 交换机端口安全配置
    千次阅读
    2020-11-12 06:21:26

    写在前面:一般在网络中会在接入层交换机边缘端口上配置端口安全用于防止非法或不可以信任的网络设备接入到网络中,以便于提高网络的安全性。
    1.拓扑图
    在这里插入图片描述
    2.网络需求
    在接入层交换机上配置端口安全提高网络安全性能,实现网络互通。

    3.配置
    [SW1-GigabitEthernet0/0/1]port-security enable
    a.接口使能端口安全功能时,接口上之前学习到的动态MAC地址表项将被删除,之后学习到的MAC地址将变为安全动态MAC地址。

    [SW1-GigabitEthernet0/0/1]port-security mac-address sticky
    b. 接口使能Sticky MAC功能时,接口上的安全动态MAC地址表项将转化为Sticky MAC地址,之后学习到的MAC地址也变为Sticky MAC地址。

    [SW1-GigabitEthernet0/0/1]undo port-security enable
    c.接口去使能端口安全功能时,接口上的安全动态MAC地址将被删除,重新学习动态MAC地址。

    [SW1-GigabitEthernet0/0/1]undo port-security mac-address sticky
    d.接口去使能Sticky MAC功能时,接口上的Sticky MAC地址,会转换为安全动态MAC地址。

    3.1SW1的配置
    [SW1]display current-configuration

    sysname SW1

    cluster enable
    ntdp enable
    ndp enable

    drop illegal-mac alarm

    diffserv domain default

    drop-profile default

    aaa
    authentication-scheme default
    authorization-scheme default
    accounting-scheme default
    domain default
    domain default_admin
    local-user admin password simple admin
    local-user admin service-type http

    interface Vlanif1

    interface MEth0/0/1

    interface GigabitEthernet0/0/1
    port-security enable
    port-security protect-action shutdown
    port-security max-mac-num 3
    port-security aging-time 200

    interface GigabitEthernet0/0/2

    interface GigabitEthernet0/0/3

    interface GigabitEthernet0/0/4

    interface GigabitEthernet0/0/5

    interface GigabitEthernet0/0/6

    interface GigabitEthernet0/0/7

    interface GigabitEthernet0/0/8

    interface GigabitEthernet0/0/9

    interface GigabitEthernet0/0/10

    interface GigabitEthernet0/0/11

    interface GigabitEthernet0/0/12

    interface GigabitEthernet0/0/13

    interface GigabitEthernet0/0/14

    interface GigabitEthernet0/0/15

    interface GigabitEthernet0/0/16

    interface GigabitEthernet0/0/17

    interface GigabitEthernet0/0/18

    interface GigabitEthernet0/0/19

    interface GigabitEthernet0/0/20

    interface GigabitEthernet0/0/21

    interface GigabitEthernet0/0/22

    interface GigabitEthernet0/0/23

    interface GigabitEthernet0/0/24

    interface NULL0

    user-interface con 0
    user-interface vty 0 4

    return

    更多相关内容
  • 包括端口安全简介、安全功能 ,安全配置,安全特性,配置安全的MAC等具体操作
  • 交换机端口安全配置PPT课件.pptx
  • 思科模拟器 --- 交换机端口安全配置

    万次阅读 多人点赞 2019-11-15 09:34:21
    学习目标:掌握交换机端口安全功能,控制用户的安全接入 1.实验环境:对公司网络严格控制,防止公司用户的IP地址冲突和公司内部的网络攻击和破坏行为,为每一个员工分配固定的IP地址,某公司员工分配的IP地址为:...

    学习目标:掌握交换机的端口安全功能,控制用户的安全接入

    1.实验环境:对公司网络严格控制,防止公司用户的IP地址冲突和公司内部的网络攻击和破坏行为,为每一个员工分配固定的IP地址,某公司员工分配的IP地址为:192.168.2.2/24,主机的MAC地址是:0060.5C5B.3152,该主机连接在 1台 S2960 上 。

    2.实验目的:针对交换机的所有端口,配置最大连接数为 1,针对 PC 0 主机的接口进行 MAC 地址绑定。

    3.实验设备:Switch-2960 1台、PC 1台、直通线

    4.配置 PC 0 的IP地址

    PC 0的IP地址:192.168.2.2

    MAC地址:255.255.255.0

    5.在 PC 0上打开CMD 命令提示符窗口,执行 ipconfig /all 命令 查看 PC 0 的IP和MAC地址

    6.配置交换机 Switch 0

    Switch>en

    Switch#conf t

    Switch(config)#int f0/1           进入 f0/1 端口

    Switch(config-if)#switchport mode access      配置交换机 f0/1 端口模式为 access

    Switch(config-if)#switchport port-security        开启交换机的端口安全功能

    Switch(config-if)#switchport port-security maximum 1       配置端口的最大连接数为 1

    Switch(config-if)#switchport port-security violation shutdown     配置安全违规的处理方式为 shutdown

    Switch(config-if)#end

    Switch#show port-security        查看交换机的端口安全配置     

    7.配置交换机端口的 MAC 地址绑定

    Switch(config)#int f0/1           进入 f0/1 端口

    Switch(config-if)#switchport port-security             开启交换机的端口安全功能

    Switch(config-if)#switchport port-security mac-address 0060.5C5B.3152      端口和 MAC地址的绑定

    Switch#show port-security address           查看地址安全绑定配置

     

    扩展实验:有感兴趣的小伙伴可以加大实验难度,针对三层交换机端口安全配置下面的实验:

             

    部分交换机配置仅供参考,以真实实验环境为主:(希望对您上面的实验有帮助 (*^▽^*))

    1.配置二层交换机

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#vlan 3

    Switch(config-vlan)#exit

    Switch(config)#int f0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 2

    Switch(config-if)#exit

    Switch(config)#int f0/3

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 3

    Switch(config-if)#exit

    Switch(config)#int f0/1

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan 2,3

    Switch(config-if)#exit

    2.配置三层交换机

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#vlan 3

    Switch(config-vlan)#exit

    Switch(config)#int f0/1

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan 2,3

    Switch(config-if)#exit

    Switch(config)#int vlan 2

    Switch(config-if)#ip add 192.168.10.2 255.255.255.0

    Switch(config-if)#exit

    Switch(config)#int vlan 3

    Switch(config-if)#ip add 192.168.20.2 255.255.255.0

    Switch(config-if)#exit

    Switch(config)#ip routing

    展开全文
  • H3CNE交换机端口安全配置(802.1x 端口隔离 端口绑定) 交换机-端口绑定与端口安全
  • 计算机网络工程 计算机网络工程实验 计算机网络工程实用教程 实验目的 交换机端口安全功能配置 1理解什么是交换机的端口安全性 2掌握交换机的端口安全功能控制用户的安全接入 交换机端口安全配置 背景描述 你是一个...
  • 交换机端口安全配置PPT学习教案.pptx
  • 实验拓扑: 实验目标: 理解端口安全的基本命令 实验步骤: 1、配置MAC地址静态绑定; 2、配置端口MAC地址粘滞;

    实验拓扑:

    实验目标:

    理解端口安全的基本命令

    实验步骤:

    1、配置MAC地址静态绑定;

    2、配置端口MAC地址粘滞;

    3、调整端口安全默认参数。

    实验配置:

    首先,配置所有PC的IP地址:

    配置PC0的IP地址:

    配置PC1的IP地址 :

     配置PC2的IP地址 :

    配置PC3的IP地址 : 

    配置PC4的IP地址 : 

    配置PC5的IP地址 : 

     1、配置端口MAC地址静态绑定

    PC0测试PC2: 

    2、更换PC(相当于更换MAC地址):用fa0/1链接测试机PC1

    此时的拓扑将变为 

    PC1测试PC2: 

    此时,PC1是ping不通PC2的。

    3、端口安全相关检查命令

     SW1#show port-security

     SW1#show port-security address

     SW1#show port-security interface fa0/1

    4、配置端口粘滞 

    (此处省略部分输出) 

    SW1#show run inter fa0/3(此命令PT模拟器不支持,但此命令很重要) 

     5、更改端口安全默认参数

     更换PC(相当于更换MAC地址):用fa0/1链接测试机PC0

    此时的拓扑将变为 

    此时,PC0与SW1之间是不连通的

    那么我们需要重新打开端口 

    然后,PC2测试PC0: 

    PC3测试PC0: 

    用SW2的fa0/3连接测试机PC4(相当于更换MAC地址):

    此时拓扑图将变为:

    PC4测试PC0: 

     PC3测试PC0:

     到此,实验十五:配置交换机端口安全,实验完

    展开全文
  • ensp-配置交换机端口安全

    千次阅读 2021-05-06 15:21:16
    拓扑图如下: 1,配置主机IP 2,配置交换机端口安全 3,用PC1去pingPC2和PC3 4,交换pc1机与pc2机的直通线 4,在pc1机上ping pc2机与pc3机发现交换机原E0/0/2端口关闭(PC2无法接入交换机)

    拓扑图如下:
    在这里插入图片描述
    1,配置主机IP
    2,配置交换机端口安全
    在这里插入图片描述
    3,用PC1去pingPC2和PC3
    在这里插入图片描述

    4,交换pc1机与pc2机的直通线
    在这里插入图片描述

    展开全文
  • 配置交换机端口安全实验

    千次阅读 2020-05-21 17:22:44
    交换机的端口安全配置 实验目的 掌握交换机的端口安全功能,控制用户的安全接入 实验拓扑 实验原理 交换机端口安全功能,是指针对交换机的端口进行安全属性的配置,从而控制用户的安全接入。交换机端口安全主要有...
  • 2016计算机网络技术实验实训教程:实验一交换机端口安全配置计算机网络技术实验实训教程网络安全实验实验一 交换机端口安全配置实验名称:交换机端口安全配置。实验目的:掌握交换机的端口安全功能。技术原理...
  • 配置交换机端口安全

    千次阅读 2020-06-03 22:35:13
    2,端口的安全配置 [SW1] int e0/01 //进入接口 [SW1-Ethernet0/0/1]port-security enable //开启端口安全 [SW1-Ethernet0/0/1]port-security mac-address sticky //将经过接口的MAC地址和接口动态关联起来 [SW1-...
  • 交换机端口安全技术的配置 Cisco

    千次阅读 2020-03-18 20:19:37
    实验目的:掌握交换机端口安全功能,控制用户的安全接入 实验背景:公司网络采用个人固定IP上网方案,为了防止公司内部用户IP地址借用、冒用,私自接入交换机等违规行为,同时防止公同内部的网络攻击和破坏行为,...
  • 今天我们来介绍一下交换机端口安全配置内容,主要防止公司内部的网络攻击和破坏行为,详细的教程,请看下文介绍,需要的朋友可以参考下
  • 一、前言     同系列前几篇:         网络设备配置–1、配置交换机enable、console、telnet密码         网络...而我们可以通过配置交换机端口安全可以一定防范这些攻击,配置端口安全可以只
  • 思科交换机接口安全配置

    千次阅读 2020-04-10 19:10:35
    交换机执行命令: Switch>en //进入特权模式 Switch#conf //全局配置 Configuring from terminal, memory, or network [terminal]? Enter configuration commands, one per line. End with CNTL/Z. Switch...
  • 实验二交换机端口安全功能配置 实验目的 交换机端口安全功能配置 1理解什么是交换机的端口安全性 2掌握交换机的端口安全功能控制用户的安全接入 交换机端口安全配置 背景描述 你是一个公司的网络管理员公司要求对...
  • 路由器有一两台三四台的情况下可以进行静态路由配置,如果路由器多了的话如果在配置静态路由就会很麻烦,还要一台一台的去配置,这...首先打开华为模拟器,拖入两个路由器,用线连接后配置端口的IP地址 如下图: ...
  • 交换机工作原理及端口安全配置

    千次阅读 2019-12-10 21:21:19
    目录相关概念认识交换机工作原理交换机端口安全 相关概念认识 交换机是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。最常见的交换机是以太网交换机。交换机...
  • 交换机端口配置与管理 二、实验目的 1.认识Packet Tracer软件 2.交换机的基本配置与管理 三、实验内容和要求 1.认识Packet Tracer软件 2.交换机的基本配置与管理 3.新建Packet Tracer拓扑图 4.了解...
  • 交换机上应用以下基本安全措施可确保交换机的安全,当然,事在人为,没有绝对安全的作法,以下是安全配置的基本方法步骤,基本功是要做的。请看理论,文档有详细的配置方法,是从思科教程里面整理出来的。 为设备...
  • 1、 根据拓扑完成上图 ,可以配置pc的地址为192.168.1.1-192.168.1.42、 配置安全端口Switch>enableswitch#conf tSwitch(config)#interface f0/1Switch(config-if)#switchport mode access 配置access模式Switch...
  • 企业网络安全涉及到方方面面。从交换机来说,首选需要保证交换机端口的安全。在这篇文章中,脚本之家的小编就是大家谈谈Cisco交换机配置端口安全性的三种方法的特性及优缺点,需要的朋友可以参考下

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 42,726
精华内容 17,090
关键字:

交换机端口安全配置

友情链接: Aerial_mmdet.zip