精华内容
下载资源
问答
  • 基于eNSP计算机网络实验-----完结篇一、路由器基本配置和静态路由1.背景知识2.ENSP模拟过程3.实际网络设备操作二、路由器动态配置(RIP、OSPF协议) 【有时间再细细回想来写】1.背景知识2.ENSP模拟过程3.实际网络...



    之前实验:
    基于eNSP模拟结合实际操作的计算机网络实验(三)
    基于eNSP模拟结合实际操作的计算机网络实验(二)
    基于eNSP模拟结合实际操作的计算机网络实验(一)

    • 对静态路由进行配置,测试网络连通性
    • 路由器动态配置(RIP、OSPF协议),对动态路由进行配置,测试网络连通性
    • 运用基本ACL来进行访问控制配置,测试网络连通性


    一、路由器基本配置和静态路由

    1.背景知识

        3台路由器分别连接到不同的网络,在路由器上进行适当配置,实现不同网段之间PC机之间的相互通信。

    配置静态路由相关指令命令:
        ip route-static :静态路由配置命令(command)
        Network:目标网络(destination network)
        mask:网络掩码(subnet mask)
        Address:下一跳地址(Next-hop address)
        Interface:本地出接口(Local outgoing interface)
        Distance:管理距离(administrative distance )

    路由:是把一个数据从一个网络转发到另一个网络的过程,完成这个过程的设备就是路由器。
    路由器:是网络层设备,是一个根据IP包头信息,选择最佳路径,将数据包转发出去的设备,路由器中的路由数据包有目的地址、源地址、可能路由、最佳路由、维护和更新路由信息组成。
    生成路由项
      配置路由表接口IP地址和子网掩码 —— 直连路由
      手工配置 —— 静态路由
      协议自动配置 —— 动态路由

    路由过程中的数据包交换:
    (1) 主机A发B的数据在网络层封装IP数据包,包首部包含源地址和目标地址;
    (2) 主机A用本机24IP掩码与目标地址进行与运算。若不在一个网段,则将ip数据包发到网关;
    (3) 发往网关前A通过ARP请求获得网关MAC地址。将IP数据包封装成帧。再发往网关,也就是路由器一个接口;
    (4) 网关路由器接收到以太网数据帧,如目标MAC地址是自己某个端口物理地址,路由器把以太网帧封装去掉,路由器会认为这个IP数据包要通过自己进行转发,接着就匹配路由表,匹配后,将包发往下一条地址。
    总之,路由器转发数据包始终不改IP ,只改MAC地址。

    2.ENSP模拟过程

    模拟组网内容描述:
    (1) R1、R2、R3三台路由器,R1连接PC1,R3连接PC2,PC1、PC2处于不同网段
    (2) 配置R1、R2、R3,使处于不同网段的PC1、PC2能够ping通
    (3) 模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

    对路由器设置:

    R1:[R1] int g0/0/0
        [R1-GigabitEthernet0/0/0] ip add 192.168.53.1 24
        [R1-GigabitEthernet0/0/1] int g0/0/1 
        [R1-GigabitEthernet0/0/1] ip add 192.168.50. 254 24
        [R1] ip route-static 192.168.60.0 24 192.168.53.2
         
    R2:[R2] int g0/0/0
        [R2-GigabitEthernet0/0/0] ip add 192.168.53.2 24
        [R2-GigabitEthernet0/0/1] int g0/0/1 
        [R2-GigabitEthernet0/0/1] ip add 192.168.57. 1 24
        [R2] ip route-static 192.168.60.0 24 192.168.57.2
        [R2] ip route-static 192.168.50.0 24 192.168.53.1
    
    R3:[R3] int g0/0/0
    	[R3-GigabitEthernet0/0/0] ip add 192.168.57.2 24
        [R3-GigabitEthernet0/0/0] int g0/0/1 
        [R3-GigabitEthernet0/0/1] ip add 192.168.60. 254 24
        [R3] ip route-static 192.168.50.0 24 192.168.57.1
    

    在这里插入图片描述
    上图可见,我们模拟成功,进入实际设备操作环节;

    3.实际网络设备操作

    设备名称接口接口类型所属VLANIP地址、掩码和网关
    PC1Ethernet0/0/1access/192.168.100.2
    255.255.255.0
    192.168.100.1
    PC2Ethernet0/0/1access/192.168.103.100
    255.255.255.0
    192.168.103.1
    R1GigabitEthernet0/0/0子接口
    子接口
    -ip add 192.168.1.254 24
    ip add 192.168.2.254 24
    PC1Ethernet0/0/1accessvlan 10192.168.1.1
    255.255.255.0
    192.168.1.254
    PC2Ethernet0/0/1accessvlan 20192.168.1.2
    255.255.255.0
    192.168.2.254

    路由器R1:
    在这里插入图片描述
    在这里插入图片描述

    【就贴一个R1的图吧,图太多太乱不想找了,就这样吧,实际设备问题挺多的,但是和模拟的流程差不多】

    结果:
    在这里插入图片描述

    二、路由器动态配置(RIP、OSPF协议) 【有时间再细细回想来写】

    1.背景知识

    动态路由是路由协议自动建立和管理的路由,常见动态路由协议有:
        RIP(Routing Information Protocol) 最古老的路由协议;
        IGRP(Interior Gateway Routing Protocol)思科私有路由协议,现已基本淘汰;
        EIGRP(Enhance Interior Gateway Routing Protocol);
        OSPF(Open Shortest Path First)思科私有路由协议,高级的距离矢量;
        BGP(Backbone Getway Protocol)外部网关协议,企业内部不适用;
    不可路由协议,NetBEUI协议。
        对于不同的路由协议到一个目的地的路由信息,路由器选择信任哪个路由信息源?管理距离AD 管理距离:是标识路由可信度的信任等级。AD值越低,优先级越高。

    RIP协议简介:
        RIP协议是基于距离矢量算法的。它使用“跳数” 来衡量到达目标地址的路由距离。路由器交换信息是通过定期广播整个路由表所能到达的适用网络号码。(网络规模大时路由表大,难维护。

    OSPF协议简介:
        OSPF协议采用链路状态算法。执行该算法的路由器不是简单的从相邻的路由器学习路由,而是把路由器分成区域,收集区域内所有路由器的链路状态信息,根据链路状态信息生成网络拓扑结构,每一个路由器再根据拓扑结构图计算出路由。(配置相对复杂)
    在这里插入图片描述

    2.ENSP模拟过程

    RIP调试命令

    display ip routing-table           /*显示路由表*/
    undo route rip                     /*删除RIP路由配置*/
    display ip interface br            /*查看接口的启用ip地址*/
    display interfaces                 /*显示接口信息*/
    debugging hdlc all serial0         /*显示所有信息*/
    debugging hdlc event serial0       /*调试事件信息*/
    debugging hdlc packet serial0      /*显示包的信息*/
    

    OSPF调试命令

    ospf 1                             /*1代表进程号,如果没注明,默认进程为1*/
    area 0                             /*声明ospf区域为area 0*/
    Network 192.168.100.0 0.0.0.255    /*发布自身直连的网段,后加反掩码*/ 
    

    模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

    基于RIP协议下路由器的设置如下:
    R1:

    [R1] int g0/0/0
    [R1-GigabitEthernet0/0/0] ip add 192.168.53.1 24
    [R1-GigabitEthernet0/0/1] int g0/0/1 
    [R1-GigabitEthernet0/0/1] ip add 192.168.50. 254 24
    [R1] rip 1                            
    [R1-rip-1] version 2
    [R1-rip-1] network 192.168.50.0
    [R1-rip-1] network 192.168.53.0
    [R1-rip-1] q
    

    R2:

    [R2] int g0/0/0
    [R2-GigabitEthernet0/0/0] ip add 192.168.53.2 24
    [R2-GigabitEthernet0/0/1] int g0/0/1 
    [R2-GigabitEthernet0/0/1] ip add 192.168.57. 1 24
    [R2] rip 1
    [R2-rip-1] version 2
    [R2-rip-1] network 192.168.53.0
    [R2-rip-1] network 192.168.57.0
    [R2-rip-1] q
    

    R3:

    [R3] int g0/0/0
    [R3-GigabitEthernet0/0/0] ip add 192.168.57.2 24
    [R3-GigabitEthernet0/0/0] int g0/0/1 
    [R3-GigabitEthernet0/0/1] ip add 192.168.60. 254 24
    [R3] rip 1
    [R3-rip-1] version 2
    [R3-rip-1] network 192.168.57.0
    [R3-rip-1] network 192.168.60.0
    [R3-rip-1] q
    

    3.实际网络设备操作


    啊,我好懒,上面的设备表懒得打了,直接贴实际操作代码了
    R1:

    <Huawei>sys
    [Huawei]sysn R1-OSPF
    [R1-OSPF]int g0/0/0
    [R1-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.1 24
    [R1-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R1-OSPF-GigabitEthernet0/0/1]ip add 192.168.50.254 24
    [R1-OSPF-GigabitEthernet0/0/1]q
    [R1-OSPF]ospf 1 router-id 2.2.2.2
    [R1-OSPF-ospf-1]area 0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.50.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]q
    


    R2:

    [Huawei]sysn R2-OSPF
    [R2-OSPF]int g/0/0/0
    [R2-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.2 24
    [R2-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R2-OSPF-GigabitEthernet0/0/1]ip add 192.168.57.1 24
    [R2-OSPF-GigabitEthernet0/0/1]q
    [R2-OSPF-ospf-1]area 0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]q
    


    R3:

    [Huawei]sysn R3-OSPF
    [R3-OSPF]int g0/0/1
    [R3-OSPF-GigabitEthernet0/0/1]ip add 192.168.60.254 24
    [R3-OSPF-GigabitEthernet0/0/1]intg0/0/0
    [R3-OSPF-GigabitEthernet0/0/0]ip add 192.168.57.2 24
    [R3-OSPF-GigabitEthernet0/0/0]q
    [R3-OSPF]ospf 1 router-id 3.3.3.3
    [R3-OSPF-ospf-1]area 0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.60.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]
    

    在这里插入图片描述
    在这里插入图片描述 在这里插入图片描述


    三、ACL和NAT配置

    1.背景知识

    1.1 ACL

    运用基本ACL配置来实现对于一个网络进行访问控制,其实验拓扑图如下所示:
    在这里插入图片描述
        这里的话我们就用两台电脑来实现访问控制,在实际场景下的我们可以通过对不同的接口进行选取来实现两台PC进行访问控制列表ACL
        主要的实验要求就是两个PC之间只有休息时间可以进行通信,其余时间不能够进行通信,我们通过设置两对端口之间能够正常进行通信,另外两个端口这些时间不能进行通信。

    基本ACL配置步骤:
      (1) 配置路由器端口地址
      (2) 配置路由
      (3) 配置ACL生效时间
      (4) 创建ACL列表
      (5) 配置ACL规则
      (6) 在接口下应用ACL

    配置访问控制列表ACL相关指令命令
        acl [ number ] 命令用来创建一个ACL,并进入ACL视图
        rule [ rule-id ] { deny | permit } source { source-address source-wildcard | any } 命令用来增加或修改ACL的规则。deny用来指定拒绝符合条件的数据包,permit用来指定允许符合条件的数据包,source用来指定ACL规则匹配报文的源地址信息,any表示任意源地址。
        traffic-filter { inbound | outbound }acl{ acl-number }命令用来在接口上配置基于ACL对报文进行过滤。
        本示例中,主机A发送的流量到达RTA后,会匹配ACL2000中创建的规则rule deny source192.168.1.0 0.0.0.255,因而将被拒绝继续转发到Internet。主机B发送的流量不匹配任何规则,所以会被RTA正常转发到Internet。

    ACL还有很多原理和规则自己百度,我很懒,不想打了。

    1.2 NAT

    在这里插入图片描述
    NAT基本配置实验原理
        NAT是指把局域网内部私有地址与Internet全局地址(公网地址)建立对应关系,这种关系称为映射;
        使用内部地址的主机在访问Internet时或被Internet上的主机访问时,数据报均在该局域网的网关(路由器)上进行地址之间的转换;
        NAT设置在内部网域外部公用网连接处的路由器上,路由器至少有一个内部端口以及一个外部端口,内部端口连接内部网络用户使用内部专用ip地址,外部端口连接的是外部的网络,如internet,使用的是公网ip地址;

    NAT分类:
        (1) 静态NAT:将内部专用地址与全局合法地址进行一对一的转换,需要指定和哪个合法地址进行转换;
        (2) 动态NAT:pool NAT执行专用地址与全局地址的一对一转换,但全局地址与专用地址的对应关系不是一成不变的,它是从全局地址池(pool)中动态的选择一个全局地址与一个内部专用地址相对应;
        (3) 复用地址转换:Port NAT可以允许多个内部本地地址共用一个全局合法地址,当只申请到少量全局合法ip地址,但却经常同时有多个用户上外部网络时,这种转换是很有用的;

    NAT工作流程什么的自己百度,不再详述。

    2.ENSP模拟过程

    2.1 ACL

    这个实验我们是基于之前所做的动态路由来做的,所以经过如下配置,我们能够使PC1 ping 通PC2,我们在路由器R3上进行ACL的设置,使之能够拒绝PC1网段的访问,那么,我们所期待的结果就是经过设置ACL后,PC1无法ping通PC2

    模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

                                jiang学主义好!!
                             ▅▅▅▅▅▆▇▅▅▄▄▄▄▄▄▄
                            ▄▅▅▅▇█▇▆▆▆▇▆▄▄▄▄
                            ▄▄▄▆▇▆▅▄▃▃▄▆▆▄▄▄
                            ▄▄▄█▇▅▄▃▃▃▃▅▇▄▄▄
                            ▃▄▄█▇▆▄▃▃▃▃▄▇▄▄▃
                            ▃▃▃▇█▇▆▅▅▅▄▅▆▃▃▃
                            ▃▃▃▆▇▆▅▆▆▅▄▅▄▃▃▂
                            ▂▃▂▅▇▅▄▆▄▅▄▄▃▂▂▂
                            ▂▂▂▄▇▆▅▆▄▄▄▃▂▂▂▂
                            ▂▂▂▂▆▆▆▆▄▄▄▃▂▂▂▁
                            ▁▂▁▁▆▇▆▅▄▃▄▂▁▁▁▁
                            ▁▁▁▄▇▇▇▅▄▄▃ ▁▁▁▁
                              ▃▇██▆▆▇▆▅▅▅▂   
                            ▅█████▄▃▅▁▅██▆▃ 
                            ██████▅▄▇▄▅████▆

    对于各个路由器的设置如下:
    R1:

    [Huawei]sysn R1-OSPF
    [R1-OSPF]int g0/0/0
    [R1-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.1 24
    [R1-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R1-OSPF-GigabitEthernet0/0/1]ip add 192.168.50.254 24
    [R1-OSPF-GigabitEthernet0/0/1]q
    [R1-OSPF]ospf 1 router-id 1.1.1.1
    [R1-OSPF-ospf-1]area 0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.50.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]q
    

    R2:

    [Huawei]sysn R2-OSPF
    [R2-OSPF]int g/0/0/0
    [R2-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.2 24
    [R2-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R2-OSPF-GigabitEthernet0/0/1]ip add 192.168.57.1 24
    [R2-OSPF-GigabitEthernet0/0/1]q
    [R2-OSPF]ospf 1 router-id 2.2.2.2
    [R2-OSPF-ospf-1]area 0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]q
    

    R3:

    [Huawei]sysn R3-OSPF
    [R3-OSPF]int g0/0/1
    [R3-OSPF-GigabitEthernet0/0/1] ip add 192.168.60.254 24
    [R3-OSPF-GigabitEthernet0/0/1] int g0/0/0
    [R3-OSPF-GigabitEthernet0/0/0] ip add 192.168.57.2 24
    [R3-OSPF-GigabitEthernet0/0/0] q
    [R3-OSPF] ospf 1 router-id 3.3.3.3
    [R3-OSPF-ospf-1] area 0
    [R3-OSPF-ospf-1-area-0.0.0.0] network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0] network 192.168.60.0 255.255.255.0
    [R3] time-range lc 06:00 to 22:59 working-day
    [R3] acl number 3000
    [R3-acl-adv-3000] rule 0 deny ip source 192.168.50.0 0.0.0.255 destionation 192.168.60.0 0.0.0.255 time range lc
    [R3-acl-adv-3000] int g0/0/1
    [R3-GigabitEthernet0/0/1] traffic-filter outbound acl 3000
    

    2.2 NAT

    如上图实验拓扑图所示,我们对于NAT实验的各类IP设置如下所示:

    内网PC ip 为:192.168.50.1
    外网PC ip 为:202.1.1.9
    

    3.实际网络设备操作

    3.1访问控制列表ACL实际实验

    在这里插入图片描述
    在这里插入图片描述

    3.2 网络地址转换NAT实际实验

    在这里插入图片描述

    4.ACL和NAT实验结果:

    4.1 ACL实验结果

    在这里插入图片描述
    在这里插入图片描述

    4.2 NAT实验结果

    在这里插入图片描述

    展开全文
  • 计算机网络综合实训指导书-基于eNSP,适用于两周的综合实训内容,包括tcp/IP协议等,路由交换原理,vlsm子网划分,可分解可以综合等
  • 实验二:VLAN间路由1.1 实验目的和内容1.1.1 实验目的1.1.2 实验内容1.2 实验原理1.3 实验过程1.3.1 单臂路由1.3.2 三层交换1.4 实验结果1.4.1 单臂路由1.4.2 三层交换1.5 实验分析1.6 实验心得 1.实验二:VLAN间...

    1.实验二:VLAN间路由

    1.1 实验目的和内容

    1.1.1 实验目的

    (1)掌握VLAN路由的应用场景;

    (2)掌握VLAN路由的工作原理;

    (3)掌握VLAN路由的基本配置。

    1.1.2 实验内容

    (1)单臂路由;

    (2)三层交换,使得不同VLAN可以通信。

    1.2 实验原理

      三层交换机是在二层交换机的基础上实现了三层的路由功能。三层交换机基于“一次路由,多次交换”的特性,在局域网环境中转发性能远远高于路由器。而且三层交换机同时具备二层的功能,能够和二层的交换机进行很好的数据转发。三层交换机的以太网接口要比一般的路由器多很多,更加适合多个局域网段之间的互联。三层交换机的所有端口在默认情况下都属于二层端口,不具备路由功能。不能给物理端口(即VLAN端口)直接配置IP地址,但可以开启物理端口的三层路由功能。

    1.3 实验过程

    1.3.1 单臂路由

    (1)绘制拓扑图

    在这里插入图片描述

            图1 单臂路由拓扑图

    (2)进行线路连接

      确保线路已经完全连接好,线路完全按照图1拓扑图中所示的接口连接完成,且没有松动。

    (3)更改IP和网关

      将IP和网关改成图1拓扑图中所分配的相应数值。

    (4)按要求敲代码

    链路层配置

    [SWA]vlan batch 2 3
    
    [SWA-GigabitEthernet0/0/1]port link-type trunk
    
    [SWA-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 3 
    
    [SWA-GigabitEthernet0/0/2]port link-type access
    
    [SWA-GigabitEthernet0/0/2]port default vlan 2 
    
    [SWA-GigabitEthernet0/0/3]port link-type access 
    
    [SWA-GigabitEthernet0/0/3]port default vlan 3
    

    网络层配置

    [RTA]interface GigabitEthernet0/0/1.1
    
    [RTA-GigabitEthernet0/0/1.1]dot1q termination vid 2
    
    [RTA-GigabitEthernet0/0/1.1]ip address 192.168.2.254 24 
    
    [RTA-GigabitEthernet0/0/1.1]arp broadcast enable 
    
    [RTA]interface GigabitEthernet0/0/1.2
    
    [RTA-GigabitEthernet0/0/1.2]dot1q termination vid 3
    
    [RTA-GigabitEthernet0/0/1.2]ip address 192.168.3.254 24 
    
    [RTA-GigabitEthernet0/0/1.2]arp broadcast enable
    

    1.3.2 三层交换

    (1)绘制拓扑图

    在这里插入图片描述

              图2 三层交换拓扑图

    (2)进行线路连接

      这个实验不需要用到路由器,所以较第一个实验相比,线相对好连。但要保证接口连接的正确性。

    (3)更改IP和网关

      该步骤与实验一相同,按照图2所示更改四台电脑的IP和网关。

    (4)按要求敲代码

    创建vlan

    [SWA]vlan batch 2 3
    
    [SWA-GigabitEthernet0/0/1]port link-type access 
    
    [SWA-GigabitEthernet0/0/1]port default vlan 2 
    
    [SWA-GigabitEthernet0/0/2]port link-type access 
    
    [SWA-GigabitEthernet0/0/2]port default vlan 3
    

    网络层配置

    [SWA]interface vlanif 2
    
    [SWA-Vlanif2]ip address 192.168.2.254 24 
    
    [SWA-Vlanif2]quit
    
    [SWA]interface vlanif 3
    
    [SWA-Vlanif3]ip address 192.168.3.254 24 [SWA-Vlanif3]quit
    
     
    
    [SWB]interface vlanif 3
    
    [SWB-Vlanif3]ip address 192.168.3.253 24 
    
    [SWB-Vlanif3]quit
    
    [SWB]interface vlanif 4
    
    [SWB-Vlanif4]ip address 192.168.4.254 24 
    
    [SWB-Vlanif4]quit
    
     
    
    [SWA-GigabitEthernet0/0/3]port link-type access 
    
    [SWA-GigabitEthernet0/0/3]port default vlan 3
    
    [SWA]ip route-static 192.168.4.0 24 192.168.3.253
    
    [SWB-GigabitEthernet0/0/3]port link-type access 
    
    [SWB-GigabitEthernet0/0/3]port default vlan 3
    
    [SWB]ip route-static 192.168.2.0 24 192.168.3.254
    

    1.4 实验结果

    1.4.1 单臂路由

    在这里插入图片描述
    在这里插入图片描述

            图3 单臂路由—两台主机互ping结果

    1.4.2 三层交换

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

            图4 三层交换—四台主机互ping结果

    1.5 实验分析

      1.在单臂路由中,主机与交换机直接的连线类型为access,路由器与交换机之间的连线类型为trunk,通过把路由器的一个端口分为两个子端口,在路由器的地址表中发现了发往另一个主机的网关,于是实现了两个主机之间的ping通,也就是经过了数据链路层和物理层,实现两个主机之间互发消息。

      2.在三层交换中,首先要划分vlan,其次要配好端口和ip,最后通过ip route-static 192.168.4.0 24 192.168.3.253,实现两个vlan可以互相传输数据,比如说一个主机想与192.168.4这个网络进行通信,那么就必须要通过192.168.3.253这个网关才行,两个交换机都有192.168.3这个网络号,因此可以实现通信。

    1.6 实验心得

      在动手做实验之前,应该先弄懂实验原理和设计思路,画好拓扑图后再进行实验,否则在实验过程中很容易把自己绕晕,同时在正式开始实验之前一定要修改主机的IP和网关,否则后期连好线后会导致ping不通。希望以后的几次实验中可以汲取本次实验的教训,更加顺利的完成后续实验。

    展开全文
  • 实验一 使用eNSP搭建基础网络实验目的 1掌握eNSP模拟器的基本设置方法 2掌握使用eNSP搭建简单的端到端网络的方法 3掌握在eNSP中使用Wireshark捕获IP报文的方法 二实验环境 配置网卡的计算机华为ensp模拟软件...
  • 基于eNSP计算机网络实验(二) 小雅的博客   本次实验的一下两个内容: 基于trunk和access实现不同VLAN间通信(上一篇的第四个内容为使用了VLAN接口配置ip,所以能够实现不同VLAN间的通信,这里是另一个方法) ...

    基于eNSP的计算机网络实验(二)

    实验一
    实验(终章)
      本次实验的一下两个内容:

    • 基于trunk和access实现不同VLAN间通信(上一篇的第四个内容为使用了VLAN接口配置ip,所以能够实现不同VLAN间的通信,这里是另一个方法)

    • 使用hybrid端口实现两个二层交换机不同VLAN间的互通

    背景知识


        要进行下面的实验,我们需要首先需要熟悉下面的这些基础知识,就是要掌握,不然做实验的时候会云里雾里,之前我也是这样,不过在大佬的帮助下实验虽然完成了,但是还是后面总结的时候才真正理解,进而在eNSP上进行再次模拟。


    一、PVID

        PVID为Port-base Vlan ID,也就是端口的 VLAN ID,关系到端口收发 数据帧时的VLAN TAG 标记,也就是空白帧进入交换机时打上的标签值,看英文翻译,基于端口的VLAN ID,一个端口可以属于多个VLAN,但是它只能有一个VLAN ID。

     

    二、VLAN

        VLAN(Virtual Local Area Network)的中文名为"虚拟局域网",这里不多说了,自己百度百科一大堆,主要在这里列这个主要就是要你区分好VLAN 和 PVID之间的关系,这两者直接需要去区别。

     

    三、access、trunk、hybrid端口收报文

      1.access端口收报文:

        收到一个报文,判断是否有Vlan信息:如果没有则打上端口的PVID,并进行交换 转发,如果有则直接丢弃(缺省)。

      2.trunk端口收报文:

        收到一个报文,判断是否有Vlan信息:如果没有则打上端口的PVID,并进行交换 转发,如果有判断该trunk端口是否允许该 Vlan的数据进入:如果允许则报文携带原有 Vlan标记进行转发,否则丢弃该报文。

      3.hybrid端口收报文:

        收到一个报文,判断是否有Vlan信息:如果没有则打上端口的PVID,并进行交换 转发,如果有则判断该hybrid端口是否允许该Vlan的数据进入:如果可以则转发,否则 丢弃

     

    四、access、trunk、hybrid端口发报文

     

      1.acess端口发报文:

        将报文的vlan tag剥离,直接发送出去。
     

      2.trunk端口发报文:

        比较端口的PVID和将要发送报文的Vlan信息,如果两者相等则剥离Vlan信息,再 发送,否则报文将携带原有的Vlan标记转发。

      3.hybrid端口发报文:

        先判断该Vlan在本端口的属性:
         1. 如果是untag则剥离Vlan信息,再发送; 相当于access
         2. 如果是tag则比较端口的PVID和将要发送报文的Vlan信息,如果两者相等则剥离 Vlan信息,再发送,否则报文将携带原有的Vlan标记进行转发。相当于trunk


    基于trunk和access实现不同VLAN间通信

      这个实验的组网拓扑于表格内容如下所示:

    在这里插入图片描述


    设备信息表格如下所示:

    设备名称接口接口类型所属VLAN or PVIDIP地址、掩码和网关
    二层交换机sw1Ethernet0/0/1
    Ethernet0/0/2
    trunk
    access
    pvid:vlan 10
    vlan 10
    -
    二层交换机sw2Ethernet0/0/1
    Ethernet0/0/2
    trunk
    access
    pvid:vlan 20
    vlan 20
    -
    PC1Ethernet0/0/1accessvlan 10192.168.1.1
    255.255.255.0
    PC2Ethernet0/0/1accessvlan 20192.168.1.2
    255.255.255.0

    第一个交换机设置如下所示:

    The device is running!
    
    <Huawei>
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type access
    [sw1-Ethernet0/0/2]port default vlan 10
    [sw1-Ethernet0/0/2]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type trunk
    [sw1-Ethernet0/0/1]port trunk allow-pass vlan 10 20
    [sw1-Ethernet0/0/1]port trunk pvid vlan 10
    

    第二个交换机设置如下所示:

    The device is running!
    
    <Huawei>
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw2
    [sw2]vlan batch 10 20
    [sw2]int e0/0/2
    [sw2-Ethernet0/0/2]port link-type access
    [sw2-Ethernet0/0/2]port default vlan 20
    [sw2-Ethernet0/0/2]int e0/0/1
    [sw2-Ethernet0/0/1]port link-type trunk
    [sw2-Ethernet0/0/1]port trunk allow-pass vlan 10 20
    [sw2-Ethernet0/0/1]port trunk pvid vlan 20
    
    

    eNSP实验结果懒得截图了,反正就这样,设置都给了,你照着做绝对能够成功,不然就是你有问题,能够理解其实际流程最好,因为这样会让你对标签能够更好的理解。

    实际操作通过连接交换机和PC机、笔记本进行实验的截图如下:

    在这里插入图片描述


    使用hybrid端口实现两个二层交换机不同VLAN的互通

      这个实验的组网拓扑于表格内容如下所示:

    在这里插入图片描述

    设备信息表格懒得做了,有空再补。

    第一个交换机的脚本设置如下所示:

    <Huawei>
    <Huawei>sys
    [name]sys sw1
    [sw1]int e0/0/2
    [sw1]vlan batch 10 20 30
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type hybrid
    [sw1-Ethernet0/0/2]port hybrid pvid vlan 10
    [sw1-Ethernet0/0/2]port hybrid untagged vlan 10
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]port link-type hybrid
    [sw1-Ethernet0/0/3]port hybrid pvid vlan 20
    [sw1-Ethernet0/0/3]port hybrid untagged vlan 10 20
    [sw1-Ethernet0/0/3]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type trunk
    [sw1-Ethernet0/0/1]port trunk allow-pass vlan 10 20 30
    [sw1-Ethernet0/0/1]port trunk pvid vlan 30
    

    第二个交换机的配置图如下所示:

    <Huawei>
    <Huawei>sys
    [Huawei]sys sw2
    [sw2]vlan batch 10 20 30
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2]int e0/0/1
    [sw2-Ethernet0/0/1]port link-type trunk
    [sw2-Ethernet0/0/1]port trunk allow-pass vlan 10 20 30
    [sw2-Ethernet0/0/1]port trunk pvid vlan 30
    [sw2-Ethernet0/0/1]int e0/0/2
    [sw2-Ethernet0/0/2]port link-type hybrid
    [sw2-Ethernet0/0/2]port hybrid pvid vlan 10
    [sw2-Ethernet0/0/2]port hybrid untagged vlan 10 20
    [sw2-Ethernet0/0/2]
    

    在ensp上的实验结果如下:

    在这里插入图片描述

    在实际操作设备中的实验结果如下:

    在这里插入图片描述

    在这里插入图片描述

    展开全文
  • 计算机网络原理》实验报告
  • eNSP与物理机连接 Cloud相当于物理层连接类似于hub直接与物理机连接 分别选择绑定信息中的UDP和本地连接再点击增加创建两条绑定信息 AR1的g0/0/0地址配置为物理机物理网卡所在网段的主机地址如物理机物理网卡所在网...
  • 实验设备:计算机一台;eNSP模拟软件一套。 实验目的: 学习和掌握eNSP软件的安装过程及eNSP的基本使用方法和常规操作方法, 实验内容: 实现eNSP的安装,学习eNSP的基本使用方法和常规操作方法,并能使用eNSP对设备...

    实验六 实验名称:eNSP基础

    实验设备:计算机一台;eNSP模拟软件一套。
    实验目的: 学习和掌握eNSP软件的安装过程及eNSP的基本使用方法和常规操作方法,
    实验内容: 实现eNSP的安装,学习eNSP的基本使用方法和常规操作方法,并能使用eNSP对设备进行简单配置,在eNSP环境中再次完成实验五的内容。
    实验学时:2
    每组人数:1
    实验类型:验证型
    实验步骤:
    一、eNSP简介
    eNSP(Enterprise Network Simulation Platform)是华为针对华为网络设备开发的图形化网络仿真平台,该平台通过对真实网络设备的仿真模拟,帮助广大ICT从业者(Information Communications Technology,简称ICT,它是信息技术与通信技术相融合而形成的一个新的概念和新的技术领域。)和客户快速熟悉华为数通系列产品,了解并掌握相关产品的操作和配置、提升对企业ICT网络的规划、建设、运维能力,从而帮助企业构建更高效,更优质的企业ICT网络。
    针对越来越多的ICT从业者的对真实网络设备模拟的需求,不同的ICT厂商开发出来了针对自家设备的仿真平台软件。但目前行业中推出的仿真平台软件普遍存在着仿真程度不够高、仿真系统更新不够及时、软件操作不够方便等系列问题,这些问题也困扰着广大ICT从业者,同时也极大的影响了模拟真实设备的操作体验,降低了用户了解相关产品进行操作和配置的兴趣。
    为了避免现行仿真软件存在的这些问题,华为研发出了一款界面友好,操作简单,并且具备极高仿真度的数通设备模拟器——eNSP。这款仿真软件运行是物理设备的VRP操作系统,最大程度地模拟真实设备环境,您可以利用eNSP模拟工程开局与网络测试,协助您高效地构建企业优质的ICT网络。eNSP支持对接真实设备,数据包的实时抓取,可以帮助您深刻理解网络协议的运行原理,协助您更好得进行网络技术的钻研和探索。另外,eNSP还贴合想要考取华为认证的ICT从业者的最真实需求,您可以利用eNSP模拟华为认证相关实验(HCDA、HCDP-Enterprise、HCIE-Enterprise),助您更快地获得华为认证,成就技术专家之路。

    二、eNSP软件的安装

    1. 下载并安装eNSP软件,安装过程中请尽量使用默认安装选项。
    2. 安装过程中,eNSP软件会根据当前系统情况自动安装需要的支持软件(包含:WinPcap、Wireshark、VirtualBox),如图1所示,请勿人为修改安装软件的选择。
      在这里插入图片描述

    图1 支持软件的安装

    1. 安装VirtualBox时,需要安装一个或多个设备,如图2所示,请点击“安装”按钮进行安装。
      在这里插入图片描述

    图2 安装设备

    三、eNSP软件的使用

    1. 打开eNSP,界面如图3所示。
    2. 选择“菜单——文件——新建拓扑”,新建一个空白的工作区。
    3. 在图3的左侧红框区域中选择实验需要的实验设备及连线,并使用鼠标左键拖拽(或左键单击创建)到工作区,合理排列各种实验设备及连线,完成拓扑图的创建。
    4. eNSP中有很多设备(例如: AR1220及以上型号的路由器)都支持通过添加接口卡来实现功能扩展。
      为设备添加新接口卡的方法:选中需要添加新接口卡的设备,鼠标右键单击,弹出的菜单中选择“设置”,鼠标拖拽你需要的接口卡到空的接口卡槽即可(注意:设备添加新接口卡时必须先关闭设备,否则操作无效)。
      在这里插入图片描述

    图3 eNSP软件的界面

    1. 设备的配置和使用,都必须首先开启设备。
      设备开启的方法:选中需要开启的设备,鼠标右键单击,弹出的菜单中选择“启动”即可。
      设备配置的方法:选中需要配置的设备,鼠标右键单击,弹出的菜单中选择“CLI”(Command-Line Interface,是一种对设备的操作系统进行设置的方式)。交换机、路由器等设备也可添加一台计算机并连接配置线缆到设备的Console口,在计算机中实现设备配置。
    2. 新建一个新的拓扑,使用S3700交换机,完成实验五的全部内容,请注意:由于使用的交换机不同,配置命令略有区别,请灵活使用系统提供的帮助信息。

    提问:
    ①使用真实设备和eNSP软件进行设备配置的区别在哪?

    注释:
    S3700系列以太网交换机(简称S3700)是华为公司推出的集接入、汇聚和传送功能于一身的二层/三层以太网交换机,满足企业网对多业务可靠接入和高质量传输的要求。S3700定位于企业网接入和汇聚层,具有大容量、高密度、高性价比的分组转发能力。借助S3700可构建高可靠的环形网络拓扑,具有多业务接入能力、良好的扩展性、QoS(Quality of Service)、强大的组播复制能力和运营级的安全性。
    S3700提供Console配置管理接口,控制台终端可以通过串口登录到Console接口,从而实现本地和远程配置。
    S3700提供10/100BASE-T以太网电接口(Ethernet)、10/100/1000BASE-T以太网电接口(GigabitEthernet)和100/1000BASE-X以太网光接口(eNSP软件中的S3700不支持该接口),支持Access、Trunk和Hybrid等多种接口类型。
    对于千兆光纤连接,S3700提供可插拔的SFP(Small Form-Factor Pluggable)类型光模块。光纤长度可以根据用户对传输距离的需求灵活选配。
    S3700可以组成树状、星型和环状以太网。对于环状以太网,S3700提供STP(Spanning Tree Protocol)和RRPP(Rapid Ring Protection Protocol,快速环网保护协议,该协议为华为的私有协议),消除环路并提供快速保护倒换。
    S5700千兆以太网交换机系列是华为公司自主研发的二层/三层千兆以太网交换机,该系列交换机比S3700系列定位更高端,提供灵活的全千兆接入以及万兆上行端口,广泛应用于企业园区接入和汇聚、数据中心接入等多种应用场景。

    解答

    选择“菜单——文件——新建拓扑”,新建一个空白的工作区。

    在图3的左侧红框区域中选择实验需要的实验设备及连线,并使用鼠标左键拖拽(或左键单击创建)到工作区,合理排列各种实验设备及连线,完成拓扑图的创建。
    在这里插入图片描述

    接口卡到空的接口卡槽

    在这里插入图片描述

    启动
    在这里插入图片描述

    设置配置
    在这里插入图片描述

    新建一个新的拓扑,使用S3700交换机
    在这里插入图片描述

    展开全文
  • 基于eNSP计算机网络实验(三)   本次实验的一下两个内容: 使用单臂路由和两台二层交换机实现不同VLAN的互通 使用单个三层交换机实现不同VLAN的互通 背景知识     要进行下面的实验,我们需要首先...
  • 基于eNSP计算机网络实验 2019-05-13 11:06:34 tags: [eNSP] [计算机网络] 基于eNSP的相关计算机网络实验    这个实验记录随着学习进度的进行不断进行更新,主要为基于华为eNSP环境下进行的熟悉计算机网络的相关...
  • 计算机网络实验指导书.包括一一到七个实验。
  • 实验三:静态路由基础2.1 实验目的和内容2.1.1 实验目的2.1.2 实验内容2.2 实验过程2.2.1 静态路由配置2.2.2 负载分担2.2.3 路由备份2.2.4 缺省路由2.2.5 静态路由应用2.3 实验分析2.4 实验心得 2.实验三:静态路由...
  • eNSP组网--实验教程.pdf

    2020-05-25 14:11:50
    计算机网络里面的一个很重要的内容就是ipv4地址的划分,我用eNSP仿真器实现了两个网络的互联,其中涉及到了路由器的地址分配还有静态路由的配置,主机的地址分配就随性很多了,重要的是学会子网划分,本教程...
  • ENSP三层交换机实验

    2021-08-02 16:51:09
    交换机发生在OSI参考模型第二层(数据链路层),而路由发生在第三层,即网络层。这一区别决定了路由和交换机在移动信息的过程中需使用不同的控制信息,所以说两者实现各自功能的方式是不同的。 路由器: ...
  • 目录 前言 一、视图 (一... 结语 以上就是本次计算机网络华为eNSP模拟器实验的VRP通用路由平台介绍,篇幅较长,感谢您的阅读和支持,若有表述或代码中有不当之处,望指出!您的指出和建议能给作者带来很大的动力!!!
  • 文章目录3 实验四:动态路由协议3.1 实验目的和内容3.1.1实验目的3.1.2 实验内容3.2 实验过程3.2.1 基于RIP动态路由协议的网络互联3.2.2 基于OSPF动态路由协议的ipv43.2.3 基于OSPF动态路由协议的ipv63.3 实验分析...
  • 目录 前言 一、关闭泛洪信息 二...) 结语 以上就是本次计算机网络华为eNSP模拟器实验的的全部内容,篇幅较长,感谢您的阅读和支持,若有表述或代码中有不当之处,望指出!您的指出和建议能给作者带来很大的动力!!!
  • 综合组网实验(eNSP)

    2021-01-26 10:11:45
    解压后打开OK1.topo文件即可 配合博文使用更佳:https://blog.csdn.net/qq_45740212/article/details/113172950
  • ensp三层交换机配置实验

    千次阅读 2021-08-20 19:05:59
    ​ 文章目录前言 前言 ...下面让我们一起看看实验​​​​​​​ 1.设备 设备说明:三个S5700-28C-HI三层交换机和四个PC机,其中LSW和2LSW3充当二层交换机使用。 2.配置: PC1 PC2 PC3 PC4 LSW2
  • (1)掌握ACL在企业网络中的应用 (2)掌握ACL的工作原理 (3)掌握ACL的配置 4.2 实验过程 4.2.1 基本ACL (1)拓扑图             图24 基本ACL拓扑图 (2)实验代码 交换机 system-view vlan batch...
  • 这里写目录标题原理解释实验 原理解释 访问控制列表(ACL) 控制数据通信可达性主要需要使用两种组件: 1,数据匹配工具 2,数据控制工具 必须同时使用否则没有意义。 中国公民如果犯了法匹配到犯罪嫌疑人分类(匹配...
  • Lsw1 Ar1 Ar2 验证
  • 设备名 接口 IP地址 前缀 默认网关 PC1 2000+学号后两位:11 64 2000+学号后两位:1 PC2 2001+学号后两位:2 64 2001+学号后两位:1 PC3 2001+学号后两位:3 64 2001+学号后两位:1 Client 无 无 无 AR1 G0/0/0 2002+学号...
  • 计算机网络实验-eNSP路由器配置

    千次阅读 2021-11-22 18:05:07
    计算机网络实验-eNSP路由器配置 文章目录计算机网络实验-eNSP路由器配置1.实验图配置2.PC机ip地址、网关、子网掩码配置3.全选,开启设备设置ip地址5.同理,对路由器AR2进行配置6.路由器静态设置 1.实验图配置 2....
  • 原理 基于MAC地址划分VLAN只处理Untagged数据帧,这里VLAN指的是单层VLAN,只有收到的数据帧中原来没有VLAN标签才可以根据交换机所...这样一来可以使得该划分方式主要针对终端用户设备,而非针对其他网络设备。 步骤
  • 本章笔记将讲述华为eNSP模拟器的安装步骤,因为 一、 结语 以上就是本次华为eNSP的安装教程,篇幅较长,感谢您的阅读和支持,若有表述或代码中有不当之处,望指出!您的指出和建议能给作者带来很大的动力!!! .....
  • 目录一、用户级别三、用户页面四、用户页面的命令1、Console用户界面2、虚拟类型终端VTY用户界面五、用户界面的用户认证1、...0级,访问级:网络诊断工具命令(ping、tracert)、从本设备出发访问外部设备的命令(包
  • 目录前言结语 ...以上就是本次计算机网络华为eNSP模拟器实验的的全部内容,篇幅较长,感谢您的阅读和支持,若有表述或代码中有不当之处,望指出!您的指出和建议能给作者带来很大的动力!!! ...
  • 这是计算机网络课程必须要做的几个实验,因此我上传了这些材料,希望你们珍惜啊!
  • 目录一、用户级别结语 ...以上就是本次计算机网络华为eNSP模拟器实验的的全部内容,篇幅较长,感谢您的阅读和支持,若有表述或代码中有不当之处,望指出!您的指出和建议能给作者带来很大的动力!!! ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 704
精华内容 281
关键字:

计算机网络实验ensp