精华内容
下载资源
问答
  • 包括端口安全简介、安全功能 ,安全配置,安全特性,配置安全的MAC等具体操作
  • 三、系统端口安全配置 下面先是介绍关于端口的一些基础知识,主要是便于我们下一步的安全配置打下基础,如果 你对端口方面已经有较深了解可以略过这一步。 端口是计算机和外部网络相连的逻辑接口,也是计算机的第...
  • 交换机端口安全配置

    2013-01-03 23:57:12
    交换机端口安全配置  最常用的对端口安全的理解就是可根据MAC地址来做对网络流量的控制和管理,比如MAC地址与具体的端口绑定,限制具体端口通过的MAC地址的数量,或者在具体的端口不允许某些MAC地址的帧流量通过...
  • 企业网络安全涉及到方方面面。从交换机来说,首选需要保证交换机端口的安全。在这篇文章中,脚本之家的小编就是大家谈谈Cisco交换机配置端口安全性的三种方法的特性及优缺点,需要的朋友可以参考下
  • H3CNE交换机端口安全配置(802.1x 端口隔离 端口绑定) 交换机-端口绑定与端口安全
  • 思科模拟器 --- 交换机端口安全配置

    千次阅读 多人点赞 2019-11-15 09:34:21
    学习目标:掌握交换机的端口安全功能,控制用户的安全接入 1.实验环境:对公司网络严格控制,防止公司用户的IP地址冲突和公司内部的网络攻击和破坏行为,为每一个员工分配固定的IP地址,某公司员工分配的IP地址为:...

    学习目标:掌握交换机的端口安全功能,控制用户的安全接入

    1.实验环境:对公司网络严格控制,防止公司用户的IP地址冲突和公司内部的网络攻击和破坏行为,为每一个员工分配固定的IP地址,某公司员工分配的IP地址为:192.168.2.2/24,主机的MAC地址是:0060.5C5B.3152,该主机连接在 1台 S2960 上 。

    2.实验目的:针对交换机的所有端口,配置最大连接数为 1,针对 PC 0 主机的接口进行 MAC 地址绑定。

    3.实验设备:Switch-2960 1台、PC 1台、直通线

    4.配置 PC 0 的IP地址

    PC 0的IP地址:192.168.2.2

    MAC地址:255.255.255.0

    5.在 PC 0上打开CMD 命令提示符窗口,执行 ipconfig /all 命令 查看 PC 0 的IP和MAC地址

    6.配置交换机 Switch 0

    Switch>en

    Switch#conf t

    Switch(config)#int f0/1           进入 f0/1 端口

    Switch(config-if)#switchport mode access      配置交换机 f0/1 端口模式为 access

    Switch(config-if)#switchport port-security        开启交换机的端口安全功能

    Switch(config-if)#switchport port-security maximum 1       配置端口的最大连接数为 1

    Switch(config-if)#switchport port-security violation shutdown     配置安全违规的处理方式为 shutdown

    Switch(config-if)#end

    Switch#show port-security        查看交换机的端口安全配置     

    7.配置交换机端口的 MAC 地址绑定

    Switch(config)#int f0/1           进入 f0/1 端口

    Switch(config-if)#switchport port-security             开启交换机的端口安全功能

    Switch(config-if)#switchport port-security mac-address 0060.5C5B.3152      端口和 MAC地址的绑定

    Switch#show port-security address           查看地址安全绑定配置

     

    扩展实验:有感兴趣的小伙伴可以加大实验难度,针对三层交换机端口安全配置下面的实验:

             

    部分交换机配置仅供参考,以真实实验环境为主:(希望对您上面的实验有帮助 (*^▽^*))

    1.配置二层交换机

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#vlan 3

    Switch(config-vlan)#exit

    Switch(config)#int f0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 2

    Switch(config-if)#exit

    Switch(config)#int f0/3

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 3

    Switch(config-if)#exit

    Switch(config)#int f0/1

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan 2,3

    Switch(config-if)#exit

    2.配置三层交换机

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#vlan 3

    Switch(config-vlan)#exit

    Switch(config)#int f0/1

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan 2,3

    Switch(config-if)#exit

    Switch(config)#int vlan 2

    Switch(config-if)#ip add 192.168.10.2 255.255.255.0

    Switch(config-if)#exit

    Switch(config)#int vlan 3

    Switch(config-if)#ip add 192.168.20.2 255.255.255.0

    Switch(config-if)#exit

    Switch(config)#ip routing

    展开全文
  • 思科设备端口安全配置

    千次阅读 2018-01-04 14:09:20
    限制端口连接数量:   Switch>enable Switch#conf t Switch(config-vlan)#int vlan 1 Switch(config-if)#no shutdown Switch(config-if)#exit Switch(config)#ip routing Switch(config)#vlan 2 ...

    限制端口连接数量:


             

    Switch>enable
    Switch#conf t
    Switch(config-vlan)#int vlan 1
    Switch(config-if)#no shutdown 
    Switch(config-if)#exit 
    Switch(config)#ip routing
    Switch(config)#vlan 2
    Switch(config-vlan)#int fa0/2
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#int vlan 2
    Switch(config-if)#ip address 192.168.2.1 255.255.255.0
    Switch(config-if)#int vlan 1
    Switch(config-if)#ip address 172.21.1.1 255.255.255.0
    Switch(config-if)#exit
    Switch(config)#int fa0/3
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport port-security 
    Switch(config-if)#switchport port-security maximum 2
    Switch(config-if)#switchport port-security violation shutdown
    



    展开全文
  • 计算机网络工程 计算机网络工程实验 计算机网络工程实用教程 实验目的 交换机端口安全功能配置 1理解什么是交换机的端口安全性 2掌握交换机的端口安全功能控制用户的安全接入 交换机端口安全配置 背景描述 你是一个...
  • H3C S3100V2端口安全配置

    千次阅读 2019-06-03 15:21:57
    一、端口安全简介 端口安全是一种基于MAC地址对网络接入进行控制的安全机制,是对已有的802.1X认证和MAC地址认证的扩充。这种机制通过检测端口收到的数据帧中的源MAC地址来控制非授权设备对网络的访问,通过检测从...

    一、端口安全简介
           端口安全是一种基于MAC地址对网络接入进行控制的安全机制,是对已有的802.1X认证和MAC地址认证的扩充。这种机制通过检测端口收到的数据帧中的源MAC地址来控制非授权设备对网络的访问,通过检测从端口发出的数据帧中的目的MAC地址来控制对非授权设备的访问。

           端口安全的主要功能是通过定义各种端口安全模式,让设备学习到合法的源MAC地址,以达到相应的网络管理效果。启动了端口安全功能之后,当发现非法报文时,系统将触发相应特性,并按照预先指定的方式进行处理,既方便用户的管理又提高了系统的安全性。这里的非法报文是指:MAC地址未被端口学习到的用户报文; 未通过认证的用户报文。

    1、端口安全模式描述:

    安全模式

    工作机制

    NTK/入侵检测

    缺省情况

    noRestrictions

    表示端口的安全功能关闭,端口处于无限制状态

    无效

    端口控制MAC地址学习

    autoLearn

    端口可通过手工配置或自动学习MAC地址。这些新的MAC地址被称为安全MAC,并被添加到安全MAC地址表中

    当端口下的安全MAC地址数超过端口安全允许学习的最大MAC地址数后,端口模式会自动转变为secure模式。之后,该端口停止添加新的安全MAC,只有源MAC地址为安全MAC地址、手工配置的MAC地址的报文,才能通过该端口

    该模式下,端口禁止学习动态MAC地址

    可触发

    secure

    禁止端口学习MAC地址,只有源MAC地址为端口上的安全MAC地址、手工配置的MAC地址的报文,才能通过该端口

    配置任务

    说明

    使能端口安全功能

    必选

    配置端口安全允许的最大MAC地址数

    可选

    配置端口安全模式

    必选

    配置端口安全的特性

    配置Need To Know特性

    可选

    根据实际组网需求选择其中一种或多种特性

    配置入侵检测特性

    配置Trap特性

    配置安全MAC地址

    可选

    配置当前端口不应用服务器下发的授权信息

    可选

    二、步骤说明:

    1、使能端口安全功能

    操作

    命令

    说明

    进入系统视图

    system-view

    -

    使能端口安全功能

    port-security enable

    必选

    缺省情况下,端口安全功能处于关闭状态

    2、配置端口安全允许的最大MAC地址数

    操作

    命令

    说明

    进入系统视图

    system-view

    -

    进入二层以太网端口视图

    interface interface-type interface-number

    -

    配置端口安全允许的最大MAC地址数

    port-security max-mac-count count-value

    必选

    缺省情况下,最大MAC地址数不受限制

    3、配置端口安全安全模式

    操作

    命令

    说明

    进入系统视图

    system-view

    -

    配置允许通过认证的用户OUI值

    port-security oui oui-value index index-value

    可选

    缺省情况下,没有配置允许通过认证的用户OUI值

    该命令仅在配置userlogin-withoui安全模式时必选

    进入二层以太网端口视图

    interface interface-type interface-number

    -

    配置端口的安全模式

    port-security port-mode { autolearn | mac-authenticationmac-else-userlogin-secure | mac-else-userlogin-secure-ext | secure | userlogin | userlogin-secure | userlogin-secure-ext | userlogin-secure-or-mac | userlogin-secure-or-mac-ext | userlogin-withoui }

    必选

    缺省情况下,端口处于noRestrictions模式

    4、配置入侵检测特性

    操作

    命令

    说明

    进入系统视图

    system-view

    -

    进入二层以太网端口视图

    interface interface-type interface-number

    -

    配置入侵检测特性

    port-security intrusion-mode { blockmac | disableport | disableport-temporarily }

    必选

    缺省情况下,不进行入侵检测处理

    退回系统视图

    quit

    -

    配置系统暂时关闭端口连接的时间

    port-security timer disableport time-value

    可选

    缺省情况下,系统暂时关闭端口连接的时间为20秒

    5、配置安全MAC地址

    在配置安全MAC地址之前,需要完成以下配置任务:

    使能端口安全功能

    设置端口安全允许的最大MAC地址数

     配置端口安全模式为autoLearn

    操作

    命令

    说明

    进入系统视图

    system-view

    -

    配置安全MAC地址的老化时间

    port-security timer autolearn aging time-value

    可选

    缺省情况下,安全MAC地址不会老化

    配置安全MAC地址

    在系统视图下

    port-security mac-address security [ sticky ] mac-address interface interface-type interface-number vlan vlan-id

    二者必选其一

    缺省情况下,未配置安全MAC地址

    在二层以太网端口视图下

    interface interface-type interface-number

    port-security mac-address security [ sticky ] mac-address vlan vlan-id

    quit

    进入二层以太网端口视图

    interface interface-type interface-number

    -

    配置安全地址的老化方式为无流量老化

    port-security mac-address aging-type inactivity

    可选

    缺省情况下,安全MAC地址按照固定时间进行老化,即在配置的安全MAC地址的老化时间到达后立即老化

    将Sticky MAC地址设置为动态类型的安全MAC地址

    port-security mac-address dynamic

    可选

    缺省情况下,Sticky MAC地址能够被保存在配置文件中,设备重启后也不会丢失

    案例:

    [office-2F-UPS-S3100I]port-security enable #使能端口安全

    interface Ethernet1/0/4
     port access vlan 19
     port-security max-mac-count 1 #最多允许1个MAC地址
     port-security port-mode autolearn #端口安全模式
     port-security intrusion-mode disableport #入侵检测,并执行对应操作
     port-security mac-address security sticky f48e-38f8-e144 vlan 19 #检测到设备之后,自动绑定MAC和vlan

    [office-2F-UPS-S3100I]display  port-security interface Ethernet  1/0/4
     Equipment port-security is enabled
     Intrusion trap is enabled
     AutoLearn aging time is 0 minutes
     Disableport Timeout: 20s
     OUI value:

     Ethernet1/0/4 is link-down
       Port mode is secure
       NeedToKnow mode is disabled
       Intrusion Protection mode is DisablePort
       Max MAC address number is 1
       Stored MAC address number is 1
       Authorization is permitted
       Security MAC address learning mode is sticky
       Security MAC address aging type is absolute

    展开全文
  • 交换机工作原理及端口安全配置

    千次阅读 2019-12-10 21:21:19
    目录相关概念认识交换机工作原理交换机端口安全 相关概念认识 交换机是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。最常见的交换机是以太网交换机。交换机...

    相关概念认识

    交换机是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。最常见的交换机是以太网交换机。交换机工作于OSI参考模型的第二层,即数据链路层。
    冲突域
    冲突域是数据必然发送到的区域。
    HUB是无智能的信号驱动器,有入必出,整个由HUB组成的网络是一个冲突域。
    交换机的一个接口下的网络是一个冲突域,所以交换机可以隔离冲突域。
    广播域
    广播数据时可以发送到的区域是一个广播域。
    交换机和集线器对广播帧是透明的,所以用交换机和HUB组成的网络是一个广播域。
    路由器的一个接口下的网络是一个广播域。所以路由器可以隔离广播域。

    交换机工作原理

    1.交换机根据收到数据帧中的源MAC地址建立该地址同交换机端口的映射,并将其写入MAC地址表中。(学习)
    2.交换机将数据帧中的目的MAC地址同已建立的MAC地址表进行比较,以决定由哪个端口进行转发。(转发)
    3.如数据帧中的目的MAC地址不在MAC地址表中,则向所有端口转发。这一过程称为泛洪(flood)。(广播)
    4.更新(老化时间300s)交换机如果发现一个帧的入端口和MAC地址表中源MAC地址的所在端口不同,交换机将MAC地址重新学习到新的端口。
    一句话总结:根据MAC地址表转发数据帧,如果地址未知,则广播。

    交换机主要作用:分割冲突域,实现全双工通信,存储,过滤转发

    交换机端口安全

    为了防止新加的设备对交换机进行操作,所以需要对交换机的端口进行安全属性的配置,从而控制用户的安全接入。具体有两种方法,一是限制交换机端口的最大连接数,从而控制交换机端口下链接的主机数。二是针对交换机端口进行mac地址,ip地址的绑定,从而实现用户的严格控制。
    对安全违例的处理方式有以下3种。
    ① protect 当安全地址个数满后,安全端口将丢弃未知名的地址包
    ② restrict 当违例产生时,将发送一个Trap通知
    ③ shutdown 当违例产生时,将关闭端口并发送一个Trap通知
    交换机端口安全功能只能在Access接口进行配置

    switch>enable
    switch#config terminal
    switch(config)#int fastethernet 0/1
    switch(config-if)#speed 100                 /设置fastethernet0/1端口速率为10Mbit/s
    switch(config-if)#duplex full               /设置fastethernet0/1端口为全双工
    switch(config-if)#no shutdown              /启用端口
    switch(config-if)#switchport mode access     /设置当前端口为Access
    Switch(config-if)#switchport port-security     /打开当前端口安全功能
    Switch(config-if)#switchport port-security maximum 1    /设置端口安全地址的最大个数
    Switch(config-if)#switchport port-security mac-address 0001.C7E9.6EC0   /绑定mac地址
    Switch(config-if)#switchport port-security violation shutdown   /配置处理违例的方式
    

    (shutdown中断开的是逻辑连接,物理连接依然开启。所以要重启断开要先关闭物理连接【shutdown】在开启物理连接【no shutdown】就可以了)

    在一个简单的交换式网络中,交换机所有端口默认情况都在一个网络(vlan1),只要将电脑连接到交换机并配置同一个网络内地址,就可以进行通信。

    交换机分类:傻瓜交换机、可管理型交换机(二层)、三层交换机(带路由功能)

    展开全文
  • 端口安全是一种基于 MAC 地址对网络接入进行控制的安全机制,是对已有的802.1X 认证和MAC 地址认证的扩充。这种机制通过检测端口收到的数据帧中的源MAC 地址来控制非授权设备对网络 的访问,通过检测从端口发出的...
  • 交换机端口安全技术的配置 Cisco

    千次阅读 2020-03-18 20:19:37
    实验目的:掌握交换机的端口安全功能,控制用户的安全接入 实验背景:公司网络采用个人固定IP上网方案,为了防止公司内部用户IP地址借用、冒用,私自接入交换机等违规行为,同时防止公同内部的网络攻击和破坏行为,...
  • CISCO 交换机,端口安全配置实例。

    千次阅读 2017-11-15 14:49:00
    最近,要求做Cisco交换机端口安全的情形越来越多。这里的端口安全主要是指通过绑定客户端MAC地址来限制端口接入的访问,不包括vlan间的ACL。您在这方面有什么好的经验吗?  借鉴了前辈的经验,同时总结自己的调试...
  • 可在端口上配置端口安全技术,使该端口只允许特定的设备访问。 端口安全技术通过MAC地址定义了允许访问的设备。 允许访问的设备的MAC地址可以手工配置或通过交换机自动“学习”。 端口上能配置的安全MAC...
  • 1.网络管理员要求您配置新... 在本练习中,您将使用一系列要求配置新交换机的初始设置、SSH 和端口安全。 2. banner motd//连接后显示 service password-encryption 将会把所有password用思科私有方式加密 ...
  • ensp-配置交换机端口安全

    千次阅读 2021-05-06 15:21:16
    拓扑图如下: 1,配置主机IP 2,配置交换机端口安全 3,用PC1去pingPC2和PC3 4,交换pc1机与pc2机的直通线 4,在pc1机上ping pc2机与pc3机发现交换机原E0/0/2端口关闭(PC2无法接入交换机)
  • Cisco PT模拟实验(7) 交换机的端口安全配置实验目的: 掌握交换机的端口安全功能,控制用户的安全接入实验背景: 公司网络采用个人固定IP上网方案,为了防止公司内部用户IP地址借用、冒用,私自接入交换机等违规行为...
  • 1、端口安全实验配置步骤

    万次阅读 多人点赞 2020-05-03 22:54:39
    配置只允许一个MAC通信 <Huawei>system-view //进入全局模式 [Huawei]undo info-center enable //关闭信息告警提示 ...[Huawei-GigabitEthernet0/0/1]port-security enable //开启端口安全,...
  • 安全的路由交换--端口安全

    千次阅读 2019-05-31 00:15:09
    2019/5/30 - - - 此文章是关于在思科交换机上启用交换机端口安全特性,起到防止mac地址欺骗和mac地址泛洪的作用 实验环境:在eve中模拟真实环境,三台交换机,其中...端口安全配置 防止mac地址泛洪的配置 思路:限制...
  • 配置交换机端口安全实验

    千次阅读 2020-05-21 17:22:44
    交换机的端口安全配置 实验目的 掌握交换机的端口安全功能,控制用户的安全接入 实验拓扑 实验原理 交换机端口安全功能,是指针对交换机的端口进行安全属性的配置,从而控制用户的安全接入。交换机端口安全主要有...
  • 5 配置端口安全

    千次阅读 2020-02-21 09:14:53
    配置端口安全 网络拓扑图 1 在交换机上启用端口安全特性 2 手工配置VPC17的mac地址,即保证只有VPC17可以接到此端口 查看VPC17的ip 配置 3 配置端口接入数量的限制 4 配置当此端口违规时的操作 5 验证测试 5.1...
  • 配置交换机端口安全

    2020-06-03 22:35:13
    2,端口的安全配置 [SW1] int e0/01 //进入接口 [SW1-Ethernet0/0/1]port-security enable //开启端口安全 [SW1-Ethernet0/0/1]port-security mac-address sticky //将经过接口的MAC地址和接口动态关联起来 [SW1-...
  • 1. 配置源IP地址集,将几个不允许访问服务器的IP加入地址集 配置安全策略时可以直接指定多个IP地址或地址段,但是对于零散的、不连续...本例中服务器使用的是非知名端口,必须配置自定义服务集,然后在安全策略中引用。
  • 今天我们来介绍一下交换机端口安全配置内容,主要防止公司内部的网络攻击和破坏行为,详细的教程,请看下文介绍,需要的朋友可以参考下

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 533,717
精华内容 213,486
关键字:

端口安全配置