精华内容
下载资源
问答
  • 路由与交换技术

    2017-03-28 14:27:00
    很深刻的路由与交换技术描述
  • 路由与交换技术路由与交换技术路由与交换技术路由与交换技术路由与交换技术
  • 路由与交换技术应用课后习题答案 华为3认证 路由与交换技术
  • 复习题-路由与交换技术 复习题-路由与交换技术
  • 路由与交换技术》实验指导书cisco版,共包含12项实验
  • 路由与交换技术(常用版)

    千次阅读 2019-12-27 23:30:39
    参考资料《路由与交换技术》及其实验指导,清华大学出版社;总结了常用的一些知识点,其他也会陆续总结分享。 其中有部分知识点重复,重复的知识点是相互补充,加深记忆,还望见谅。 一、网络分层设计模型 二、...

    路由知识

    参考资料《路由与交换技术》及其实验指导,清华大学出版社;总结了常用的一些知识点,其他也会陆续总结分享。
    其中有部分知识点重复,重复的知识点是相互补充,加深记忆,还望见谅。

    一、网络分层设计模型

    在这里插入图片描述

    二、交换网部分

    1.交换机的工作原理(广播域、冲突域的理解)

    工作原理:
    a、地址学习
    b、帧的转发
    c、环路防止
    广播域:广播数据时可以发送到的区域
    冲突域:数据必然发送到的区域

    2.交换机的基本配置

    (登录方法、视图模式、?和TAB键的作用、恢复出厂设置、显示运行配置)
    在这里插入图片描述
    登录方法:en
    视图模式:conf t
    ? :显示该命令下的所有命令及简单描述(以结尾)
    Tab :自动补全当前代码
    恢复出厂:set default(交换机)、del(路由器)
    显示运行:show …(ip router)
    重启:reload
    查看运行配置:show running-config

    3.VLAN的作用、划分方法和划分配置

    Vlan的作用:
    VLAN优点:广播控制,安全性,带宽利用,延迟;
    VLAN的缺点:VLAN之间的信号交流复杂,加大了路由器负载,过多的VLAN会造成网络性能下降,导致网络主干链路流量加大,增加了网络的抽象性,专用性仍然很强。
    Vlan的划分方法:vlan 10;vlan 20;
    Vlan的划分配置:
    Int fa0/1
    switchport mode access
    switchport access vlan 100

    4.二层和三层交换机上的Trunk链路配置,VLAN网关配置

    Trunk配置:
    (二层交换机)
    Int fa0/1
    Switchport mode trunk
    Switchport trunk allowed vlan all
    No shutdown

    (三层交换机)
    Int fa0/1
    SWitchport trunk encapsulation dot1q
    Switchport mode trunk
    Switchport trunk allowed vlan all
    No shutdown

    配置VLAN的IP地址:
    Switch(config)#interface vlan 10 //进入VLAN10
    Switch(config-if)#ip add 192.168.10.1 255.255.255.0 //给VLAN10配置IP地址
    Switch(config-if)#exit

    5.交换机端口链路聚合

    静态链路聚合:
    Switch(config)#int port-channel 1(聚合号)
    #exit
    #Int range fa0/1-2
    #channel-group 1 mode on
    动态链路聚合:
    int port-channel 1
    interface ethernet 0/0/1-2
    channel-group 1 mode active

    6.生成树协议(判断根桥、根端口和指定端口 spanning-tree配置)

    在这里插入图片描述
    S(config)# spanning-tree vlan 10 root primary (主根)
    S(config)# Spanning-tree vlan 10 root secondary (备份根)

    S(config)# Spanning-tree vlan 10 priority 24576 (网桥优先级)

    S(config)# int fa0/1
    S(config)# Spanning-tree port-priorit 110 (端口优先级)
    判断根桥:
    根据优先级和MAC地址,优先级小的那个就是根桥;
    如果优先级一样就看MAC地址,MAC最小的就剩根桥
    判断根端口:
    端口所在ID值较小的端口(离根桥最近,花销最小的设备上的端口)
    判断指定端口:
    根桥上的端口全是指定端口
    (如果是非根桥的指定端口,选择端口所在ID值较小的端口)

    三、冲突域与广播域

    1、交换机(链路层)

    所有端口同一广播域;同一端口同一冲突域。

    2、路由器(网络层)

    它的一个接口就是一个广播域;它的一个接口就是一个冲突域。
    (无255.255.255.255)

    3、一个vlan一个广播域。

    4、集线器(物理层)

    所有端口在同一个广播域;所有端口同一个冲突域。

    四、注意点1(vlan创建)

    1、VLAN创建后,其配置信息写在交换机的flash中,配置文件是vlan.dat
    2、要删除某个VLAN,则只要在全局模式下使用no命令即可
    (但先要将该VLAN中的端口指定到其它VLAN中,然后删除该VLAN)
    3、如要彻底删除VLAN的配置,必须删除文件VLAN.dat
    4、同一个vlan主机间可自由通信,不同vlan之间必须通过路由器或三层交换机进行数据包路由转发。
    5、Vlan作用:广播控制,安全性,带宽利用,延迟。
    6、交换机分割了冲突域,但不能分割广播域,随着交换机端口数量的增多,网络中广播增多,降低了网络效率,为了分割广播域,引入vlan。

    五、注意点2(三层交换机与静态链路聚合)

    1、三层交换机与两层交换机相比,trunk多了一个封装:
    switchport trunk encapsulation dot1q
    switchport mode trunk
    swichport trunk allowed vlan all

    2、链路聚合:(静态链路聚合)
    int port-channel channel-id
    exit
    interface ethernet interface-id
    channel-group channel-id mode on

    六、网络基础部分

    1.理解IP地址,子网掩码,路由器接口IP地址配置命令

    IP地址:(IPv4地址总数=232=42亿个)例如172.16.122.1
    在这里插入图片描述
    子网掩码:
    在这里插入图片描述在这里插入图片描述

    IP地址配置命令:
    int fa0/1
    IP address 192.168.100.1 255.255.255.0
    no shutdown(打开端口)

    2.掌握使用CIDR地址计算网址的方法

    在这里插入图片描述

    3.IP地址中网关的作用和配置

    作用:网关实质上是一个网络通向其他网络的IP地址
    IP地址配置:IP address 192.168.1.1 255.255.255.0

    4.子网划分

    在这里插入图片描述

    七、路由网部分

    1.路由器的工作原理(广播域、冲突域的理解)

    工作原理:路由与转发
    在这里插入图片描述
    广播域(基于第二层(链路层)):
    广播域就是说如果站点发出一个广播信号后能接收到这个信号的范围。通常来说一个局域网就是一个广播域。
    冲突域(基于第一层(物理层)):
    一个站点向另一个站点发出信号。除目的站点外,有多少站点能收到这个信号。这些站点就构成一个冲突域。

    2.路由器的基本配置

    (登录方法、视图模式、显示运行配置)
    登陆方法,视图模式:
    在这里插入图片描述
    显示历史记录:show history

    3.路由器的VLAN单臂路由、VLAN间路由、直连路由,静态路由,默认路由

    单臂路由(实现Vlan间的通信):
    Router_config# Int f0/0
    Router_config# no shutdown
    exit
    Int f0/0.10(子接口)
    encapsulation dot1q 10
    ip address 192.168.10.254(网关地址) 255.255.255.0(子网掩码)

    直连路由:
    interface f0/0
    ip address 10.1.1.1 255.0.0.0(或者192.168.2.1 255.255.255.0)
    no shutdown

    静态路由:
    ip route 192.168.1.0(目的网络地址) 255.255.255.0 (子网掩码) 192.168.2.1(下一跳IP地址,与本路由器直接相连的下一路由器的接口地址)

    ip route 192.168.1.0 255.255.255.0 s0/0 (下一跳路由接口号)

    默认路由:当在路由表中找不到目标网络的条目时,请求转发到默认路由接口
    ip route 0.0.0.0 0.0.0.0 192.168.2.2
    Vlan间路由即vlan间通信成功

    4.动态路由RIP、OSPF、EIGRP配置

    RIP配置:
    router rip
    version 2 //version 2代表rip 2不能变\或默认路由:default_information orig
    no auto-summary \关闭自动汇总
    network 192.168.1.0
    network 192.168.2.0(需要配置rip的网络地址)

    EIGRP配置:
    router eigrp 10
    no auto-summary
    network 192.168.9.0(需要配置的网段地址)

    OSPF配置:
    router ospf 10(进程号)
    router-id 1.1.1.1 (路由器ID:标识路由器)
    network 192.168.3.0(网络号) 0.0.0.255(反向子网掩码) area 0 (区域号)
    network 172.16.0.0 0.0.255.255 area 0

    Router ID——是在OSPF区域内唯一标识一台路由器的IP地址

    5.RIP和OSPF 特点对比

    在这里插入图片描述

    6.广域网配置(PPP,认证PAP)

    PPP(Point to Point Protocol)协议:
    在点对点链路上运行的数据链路层协议
    PAP:
    两次握手认证协议,口令以明文传送,被认证方首先发起认证请求。
    PPP配置:
    单向认证:

    (被认证方)
    host name Ra
    Int s0/1/1
    ip address ip 200.100.100.1 255.255.255.0
    encapsulation ppp
    ppp pap sent-username Ra password 123456 //Ra发送过去的认证消息
    No shutdowm
    exit

    (主认证方)
    host name Rb
    user-name Ra password 123456
    Int s0/1/1
    ip address 200.100.100.2 255.255.255.0
    encapsulation ppp
    ppp authentication pap
    No shutdown
    exit
    双向认证:
    在这里插入图片描述

    八、注意点3(vlan间路由技术与ip路由协议)

    1、vlan间路由技术: 三层交换
    2、单臂路由产生的瓶颈:数据量大,路由器和交换机之间的路径会成为整个网络的瓶颈。
    解决:应用三层交换机—>二层交换+三层转发
    3、创建VLAN: vlan 30
    4、配置网关地址
    interface vlan 30
    ip address 192.168.30.1 255.255.255.0
    5、启动IP路由协议
    ip routing

    九、注意点4(各类路由)

    1、直连路由:在路由器上配置了接口的IP地址
    Int f 0/0
    ip add 10.1.1.1 255.0.0.0
    no shut
    特点:运用在规模较小,拓扑机构固定的网络中
    2、静态路由:由管理员手工配置,是单向的;
    ip route 192.168.1.0(目标地址)255.255.255.0 192.168.2.1(下一站地址)
    特点:路由表是人工设置的,除非网络管理员干预,否则静态路由不发生变化。
    2、默认路由:
    IP route 0.0.0.0 0.0.0.0 192.168.2.2(下一跳地址)
    特点:默认路由的优先级最低,即没有找到其他路由项时使用。
    使用环境:一般应用在只有一个出口的末端网络,用于连接Internet,安全性不高,作为其他路由的补充。
    4、单臂路由:(此时交换机上做trunk)
    Int f0/0.10
    encapsulation dotlq 10
    ip add 192.168.10.1 255.255.255.0
    int f0/0 no shut

    十、注意点5(各类配置)

    1、路由技术(动态路由):路由器之间通过路由协议动态地构建路由表
    2、自治系统:执行统一路由策略的一组网络设备的组合
    Rip、eigrp、ospf三种动态路由协议工作原理、特点和度量方法
    3、rip配置(路由标记是R)
    route rip
    version 2// 默认路由是default_imformation orig
    no auto-summary
    network
    show IP route

    4、Eigrp配置 (路由标记是D)
    router eigrp 10
    no auto-summary
    network 192.168.1.0
    show ip route show ip eigrp neighbor show ip eigrp topology

    5、Ospf配置(路由标记是O)
    route ospf 1
    router -id 1.1.1.1
    network 192.168.3.0 0.0.0.255 area 0
    show ip route show ip ospf neighbor show ip ospf database

    十一、注意点6(PPP和PAP拓展)

    1、Ppp协议:在串行链路上封装上层数据报文的方法,采用链路控制协议来建立配置控制和测试,采用网络控制协议来支持多种网络层路由协议。
    2、Ppp链路建立:链路不可用,链路建立 认证 网络层协议 链路终止阶段
    优点:支持同步或异步串行链路的传输,支持多种网络层协议,支持错误检测,支持用户认证,允许进行数据压缩。
    3、pap两次握手协议:口令以明文发送,认证方首先发起认证请求

    十二、网络安全部分

    1.路由器和三层交换机上的ACL作用及其配置(标准和扩展)

    *可以限制网络流量、提高网络性能。   
    *提供对通信流量的控制手段。   
    *是提供网络安全访问的基本手段。
    *可以在路由器端口处决定哪种类型的通信流量被转发或被阻塞。
    *访问控制列表(ACL)——应用于路由器接口的指令列表 ,用于指定哪些数据包可以接收转发,哪些数据包需要拒绝

    2.NAT(静态NAT、动态NAT和端口NAT)

    1.路由器和三层交换机上的ACL作用及其配置(标准和扩展)
    *可以限制网络流量、提高网络性能。   
    *提供对通信流量的控制手段。   
    *是提供网络安全访问的基本手段。
    *可以在路由器端口处决定哪种类型的通信流量被转发或被阻塞。
    *访问控制列表(ACL)——应用于路由器接口的指令列表 ,用于指定哪些数据包可以接收转发,哪些数据包需要拒绝
    2.NAT(静态NAT、动态NAT和端口NAT)
    .NAT的3种实现方式
    *静态转换——内部私有IP的服务器对内网和外网提供WEB、FTP等服务
    *动态转换——内部主机(私有IP)通过NAT转换使用公用地址池访问INTERNET
    *端口转换——内部主机(私有IP)通过NAT转换使用同1个公用地址访问INTERNET

    十三、ACL

    1、标准访问控制列表

    只使用源地址进行过滤,表明是允许还是拒绝

    2、访问控制列表号

    从1到99

    3、扩展访问控制列表

    *基于源和目的地址、传输层协议和应用端口号进行过滤
    *每个条件都必须匹配,才会施加允许或拒绝条件
    *使用扩展ACL可以实现更加精确的流量控制
    *访问控制列表号从100到199

    展开全文
  • 这是计算机网络工程课程路由与交换技术的较为详细的演示文稿
  • CCIE实验笔记之路由与交换技术.rar CCIE实验笔记之路由与交换技术.rar
  • 包含RIP,ospf,BGP,帧中继,多层交换技术的详细描述和实验
  • 本学期学习了路由与交换技术,因此将其中一些重点内容记录下来,代码部分多为伪代码,只标记了重点步骤,一些进入接口、接口类型等基本操作多已省略 一、交换机 1. 双工模式 双工模式是指接口传输数据的方向性。...

    本学期学习了路由与交换技术,因此将其中一些重点内容记录下来,代码部分多为伪代码,只标记了重点步骤,一些进入接口、接口类型等基本操作多已省略

    一、交换机

    1. 双工模式

    双工模式是指接口传输数据的方向性。如果一个接口在全双工模式下,表示可以同时在收发两个方向上传输和处理数据,若是半双工则同一时间只能收收或发。华为交换机通常会启用自动协商机制设置模式,因此若我们要强制设置的话需要执行以下语句

    undo negotiation auto        //关闭该接口的自动协商功能
    speed 10                //该接口速率为10Mbit/s
    duplex half      //设置为半双工模式,全双工则把half变为full
    

    2. MAC地址

    交换机上存储映射关系的逻辑表叫作MAC地址表(告诉交换机:数据怎么走?)

    display max-address      //查看当前交换机的MAC地址表
    //静态配置的条目不会老化且优先级高于动态学习得来的
    //配置静态地址,意思为要去MAC地址要通过接口A,在vlan1(默认就是vlan1)下有效
    mac-address static MAC地址 接口A vlan 1
    display mac-address aging-time      //查看当前交换机的动态条目老化时间
    mac-address aging-time (秒数)     //设置老化时间,如果为0表示禁用老化功能
    

    3. VLAN

    VLAN(Virtual LAN虚拟局域网)的根本作用就是让交换机具备分隔广播域的能力
    数据帧类比为乘客;VLAN是公交车。VLAN技术通过为数据打上标签从而让交换机知道这是属于哪一辆公交车的乘客,即使公交车A和公交车B的目的地相同,但是A的乘客也是不能做B车的。因此划分VLAN后洪泛也只是洪泛同一个VLAN的地址

    vlan 2    //在交换机创建VLAN2并进入此VLAN配置视图
    vlan batch 10 20   //创建VLAN10和VLAN20
    vlan batch 10 to 20  //创建VLAN10至20
    display vlan (数字)   //查看当前交换机所有VLAN,若有数字则看对应VLAN信息
    display vlan 10 verbose  //查看VLAN10的详细信息
        
    只有设置了接口类型后才能知道这个接口的VLAN是多少(首先判断交换机有没有再判断类型中如何规定)
    

    Access接口

    发送出来的数据会去除VLAN标签;进入的数据会打上VLAN标签。常用于终端设备与交换机之间
    终端接收到的数据是最终数据,不能有标签。终端没有为数据打标签的功能,因此需要帮助打标签便于在VLAN中转发

    注意:交换机与路由器连接的接口也需要使用access接口。这是因为路由器中的消息也不带VLAN标签,就像终端一样,保证路由器的数据能够进入交换机领域,数据由路由器进入交换机是会被打上默认标签,接着猜按照交换机间VLAN的规则行走。简单理解就是把路由器当作终端

    interface e0/0/1      //进入e/0/1接口
    port link-type access    //设置接口类型为access
    port default vlan 5    //只允许VLAN5的数据进入或发送
    

    Trunk接口

    发送出去的数据有VLAN标签(为了让对方知道数据划分);接收的数据也有VLAN标签(知道对方数据划分)。常用于交换机与交换机之间
    交换机与交换机之间会有多个VLAN流量,因此要正确转发需要打上标签进行发送

    interface g0/0/1      //进入g/0/1接口
    port link-type trunk    //设置接口类型为trunk
    port trunk allow-pass vlan 5    //只允许VLAN5的数据进入或发送
    

    Hybrid接口

    既有Access接口的特点,也有Trunk接口的特点
    根据需要对某些接口设置带标签(需要Trunk的地方),对某些设置不用带标签(需要Access的地方)

    //进入接口
    port link-type hybrid     //将接口类型设置为Hybrid
    //接口接送Vlan10和Vlan20的数据时带标签,其中vlan也可以用to语句或者valn all等
    port hybrid tagged vlan 10 20  
    //接口接送所有VLAN数据时都不带标签
    port hybrid untagged vlan all  
    //当用了untagged后意味着去标签,但是终端设备发送数据时又没有打标签的功能,因此需要设置端口的 //pvid,即当设置了去标签时,从这个端口出去的数据都会打上设置好的pvid标签
    port hybrid pvid vlan 5  //设置此端口的默认VLAN为Vlan5
    

    GVRP

    全称为通用属性注册协议。管理员手动配置的VLAN为"静态VLAN",通过GVRP自动学习到的VLAN为"动态VLAN"
    GVRP不仅需要在端口(必须是Trunk)上进行配置,也需要在交换机全局上进行配置。
    GVRP是单向协议,只有进入的方向才会动态学习,如下图

    gvrp     //在交换机全局进行配置
    //配置trunk接口
    gvrp     //在接口上配置
    

    示意图配置完所有接口后并启动GVRP协议后
    由LSW1创建一个VLAN10,则LSW2的G1会动态学习到VLAN10,G2不会学习到;LSW3的G1会学习到。
    此时若想要G2学习到VLAN,可以在LSW3上创建VLAN10,则箭头方向会反过来,因此G2就会学习到了。

    4. 生成树协议STP

    由于通信只靠一条线路很容易出现故障(一条路不通就没得走了)。因此在实际线路中回有很多环路,但是环路一多很容易产生广播风暴(交换机互相转发造成死锁,MAC地址表不断更新),为了解决这个问题,出现了生成树协议。
    其原理是在拥有冗余链路的交换环境中,既保证每个节点可达,又能打破网络中的逻辑环路。
    其中一个有效的方法是通过判断当前端口是否适合转发数据(会不会环路),若不合适则阻塞

    功能

    • 消除环路:STP可以通过阻塞冗余端口,保证交换网络无环且连通
    • 链路备份:当正在转发数据的链路因故障而断开时,STP会马上检测到这一情况,并根据需要自动开启某些处于阻塞状态的冗余端口,以迅速恢复交换网络的连通性

    具体实现

    执行选举、赢得选举的端口成为转发端口,剩下的端口自然成为阻塞端口

    选举出的角色?

    • 根网桥(根交换机):这是交换网络中的一台交换机,它将成为STP树的树根
    • 根端口:这是交换网络中的一些端口,负责转发数据
    • 指定端口:这是交换网络中的一些端口,负责转发数据
    • 预备端口:这是交换网络中的一些端口,处于阻塞状态,不能转发数据。预备端口并不是选举出来的,而是在所有选举中全部落选的端口
    选举角色 参选者 选举范围
    根网桥 交换机 整个交换网络
    根端口 端口 每台交换机
    指定端口 端口 每个网段
    • 整个交换网络:一整个二层广播域
    • 每台交换机:以自身为单位,在多个端口中选举
    • 每个网段:指以两个或两个以上的网卡为边界的一段物理链路

    示意图

    1. 选举根网桥:每个STP网络中都有且只有一台根网桥,作为根网桥的这台交换机就是STP所构建的生成树的根
    2. 选举根端口:非根交换机会在自己的所有端口之间,选出距离根网桥最近的端口,这个端口就是根端口
    3. 选举指定端口:在直连的两个端口之间选择出一个距离根网桥最近的端口为指定端口
    4. 阻塞剩余端口:选出根端口和指定端口后,STP会把那些既不是根端口,也不是指定端口的其他所有端口置于阻塞状态

    桥协议数据单元BPDU

    • 配置BPDU:在初始形成STP树的过程中,各STP交换机都会周期性地(默认为2秒)主动产生并发送Configuration BPDU(配置BPDU)。在STP树形成后的稳定期,只有根网桥才会周期性地产生并发送Configuration BPDU;相应地,非根交换机会从自己的根端口周期性地接收到Configuration BPDU,并立即被触发而产生自己的Configuration BPDU,且从自己的指定端口发送出去。
    • 拓扑变化通知BPDU:是非根交换机通过根端口向向根网桥方向发送的。当非根交换机检测到拓扑变化后就会发送出去。

    根网桥如何选举?

    选举范围是每台交换机
    交换机之间相互对比的参数是"桥ID"
    桥ID是由16比特优先级加上48比特的MAC地址构成的,其中桥ID最小的当选
    MAC地址是自带的,优先级可由管理员设置,16比特即0~65535,默认优先级为32768

    1. 在交换机刚连接到网络中时,每台交换机都会以自己为根网桥,从所有启动的端口向外发送BPDU
    2. 接着收到BPDU的交换机则会用对方BPDU中的根网桥ID与自己的根网桥ID进行对比,如果对端BPDU中的根网桥ID数值小,交换机就会按照对方的根网桥ID修改自己BPDU中的根网桥ID,这也就表示这台交换机承认了对端认可的根网桥。

    根端口(Root Port或RP)如何选举?

    选举范围是每台非根交换机,从自己所有启动的端口中选举一个根端口

    1. 选择路径开销(Root Path Cost,RPC)最低(路径权值最低)的端口【到根网桥最近】
    2. 若多个端口RPC相等,选择对端桥ID最低的端口(对端交换机BID最小的端口)
    3. 若有多个端口对端桥ID相等,选择对端端口ID(PID,优先级【0~240,华为默认128,16的倍数】和端口号【g0/0/1,小的当选】)最低的端口

    指定端口(Designated Port或DP)如何选举?

    参选者是同处于这个网段中的所有端口(不包括已经被选举为根端口的端口)

    1. 选择路径开销(Root Path Cost,RPC)最低(路径权值最低)的端口
    2. 若多个端口RPC相等,选择桥ID最低的端口(直连交换机BID最小的端口)
    3. 若有多个端口对端桥ID相等,选择端口ID(PID,优先级【0~240,华为默认128,16的倍数】和端口号【g0/0/1,小的当选】)最低的端口

    阻塞剩余端口

    在物理环路网络STP域中,当一个端口既不是根端口也不是指定端口时称为预备端口
    预备端口会处于逻辑的阻塞状态,这类端口不会接收或发送任何书籍,但它会监听BPDU。在网络因为一些端口出现故障时,STP会让==预备端口(Alternate Port或AP)==开始转发数据,以恢复网络正常通信

    端口状态

    • 阻塞状态(Discarding):这是一种稳定状态,阻塞状态表示如果这个端口进入转发状态的话,STP域中就会出现交换环路。这时端口接收并处理BPDU,不发送BPDU,不学习MAC地址表,不转发数据
    • 侦听状态(Listening):这是一种过渡状态,这时端口接收并处理BPDU,参与STP计算,不学习MAC地址表,不转发数据
    • 学习状态(Learning):这是一种过渡状态,这时端口接收并处理BPDU,参与STP计算,学习MAC地址表,不转发数据
    • 转发状态(Forwarding):这是一种稳定状态,也是根端口和指定端口的最终状态。这时接收并处理BPDU,参与STP计算,学习MAC地址表,转发数据
    • 未启用(Disabled):端口未启用,什么也干不了

    配置

    stp enable         //在交换机上启动stp服务(实际上默认就是启动的)
    stp mode stp     //华为交换机默认STP模式是MSTP,因此需要进行模式修改
    stp priority 4096   //设置STP优先级,范围0~61440,且为4096倍数
    display stp      //查看STP状态,如果根网桥BID与本地交换机BID相同说明本地交换机就是根网桥
    display stp brief   //查看交换机上的STP端口角色
    stp timer forward-delay 200  //转发延迟设置,单位为厘秒(0.01s)
    stp timer hello 1000   //修改hello计时器时间(发送配置BPDU时间),默认为2秒
    stp timer max-age 2000  //修改保存BPDU时间,默认为20秒。当STP环境中发生故障时,若处于阻塞状态的端口(预备端口)无法从对端的指定端口收到BPDU,那么在MaxAge计时器超时候,交换机会重新计算STP
        
    //三个计时器值的设置需要满足以下条件
    2*(	转发延迟-1)>=MaxAge>=2*(Hello时间+1)
    stp bridge-diameter 个数  //指定STP网络直径,让STP根据直径自动计算出适合这个网络的计时器数值
    

    5. 快速生成树协议RSTP

    一个处于阻塞状态的端口所在的交换机由于网络故障,没有再接收到任何BPDU而触发交换机重新计算STP,到STP重新计算后,相应端口进入转发状态,需要花费50秒时间,随着网络规模增大,全网新执行STP收敛的时间会变得更长,这是不能接受的。
    STP过慢是RSTP着意希望解决的问题

    对于传统STP中的非根非指定端口,RSTP将其分为了两种情况:预备端口(AP)和备份端口(BP)

    • 如果这个端口接收到的更优BPDU是由其他网桥转发过来的,代表其为预备端口,这类端口可以在根端口及其链路出现故障时,接任根端口的角色,为交换机和根网桥之间提供另一条转发通道
    • 如果这个端口接收到的更优BPDU是由本网桥转发过来的,代表其为备份端口,这类端口可以在根端口及其链路出现故障时,接任指定端口的角色,为根网桥与那个物理网段之间提供另一条转发通道

    如果一台交换机根端口进入丢弃状态,且这台交换机上有预备端口,那么这个根端口的所有预备端口中,优先级最高的会立刻接任根端口的角色。
    若对端设备处于转发状态的话,则预备端口会立刻进入转发状态,不需要等待任何计时器和过渡;备份端口转变为指定端口同理,不过可能有过渡状态

    为什么可以不需要计时器?

    RSTP将端口定义为两种类型:点到点类型和共享类型。边缘端口属于点到点端口中的一种特殊类型
    对于非边缘的点到点类型,RSTP针对点到点链路的指定端口引入了一种P/A(Proposal/Agreement)机制用来提高收敛效率(无需计时器)

    当故障链路恢复后,传统的STP需要30秒才能重新收敛更新状态,而P/A机制通过发送Proposal消息告诉对方字要立刻进入转发状态,对方收到Proposal消息后,先确认消息来源是不是根端口,确认完毕后为避免环路而阻塞自己所有非边缘指定端口,这个过程叫P/A同步。完成同步后,返回Agreement消息同意消息来源切换到转发状态。当消息来源收到Agreement后就可以进入转发状态

    如果一台交换机通过自己的指定端口发送了Proposal,但没有接收到对方(比如终端设备)相应的Agreement,或者这台交换机的指定端口类型是共享型,那么这个端口就会回归传统STP状态转换的方式,也就是30秒后进入转发状态

    特殊类型的端口-----边缘端口

    如果交换机的端口连接的是终端设备而不是其他交换机的端口,那么这类端口进入转发状态不可能造成环路。因此,让连接终端设备的端口直接过渡到转发状态只会提高网络的效率,并不会引入任何风险
    当然交换机并不知道自己的哪些端口连接的是终端设备。所以,如果希望这些边缘端口实现快速收敛,需要管理员通过手动配置来为交换机指定边缘端口。在将端口配置为边缘端口之后,RSTP会认为这些端口不会再下游产生环路,因此在计算拓扑时就不会考虑这些端口

    配置

    stp mode rstp    //设置华为交换机STP模式为RSTP
    stp root primary   //设置当前交换机为根网桥,优先级被固定为0
    stp root secondary  //将当前交换机设置为次根网桥,优先级被固定为4096
    stp edged-port default  //(系统视图)将交换机所有端口默认设置为边缘端口
    stp edged-port enable   //将交换机上指定端口设置为边缘端口
    stp bpdu-protection    //让边缘端口在接收到BPDU消息时被交换机直接禁用,而不会参与STP计算
    

    6. 多生成树协议MSTP

    STP与RSTP无法解决划分了VLAN环境中的路由环路问题,因此有了MSTP
    以VLAN为单位进行计算,管理员可以根据自己需求将一个或者多个VLAN划分到一个多生成树实例(MST Instance,MSTI)中。此后交换机可以以MSTI为单位进行收敛,为每个MSTI收敛出一个独立的生成树。
    如:Instance1:VLAN1、VLAN2 Instance2:VLAN3
    注意:一个Instance中可以包含多个VLAN,但一个VLAN只能属于某一个Instance

    一个交换机可以拥有多个VLAN,因此交换机也就会多个实例(Instance)–VLAN映射关系。MSTP将相同实例—VLAN映射关系的交换机划分到同一个MST域中

    • 在域内,域内各台交换机的MSTP会以每个实例为单位,计算出实例在域内的生成树
    • 在全网,所有交换机的MSTP都会以交换机为单位,计算出一个全网的总生成树,这个生成树被称为公共和内部生成树CIST,CIST的根网桥为整个网络中优先级最高的交换机,称为总根
    • 在域间,所有交换机上的MSTP会以每个域为单位,计算出一个域生成树。这个生成树被称为公共生成树CST,CST的根就是总根所在的域

    MSTP根据不同的数据对不同的端口进行阻塞,并没有哪条链路会被完全阻塞,每一条链路都是有条件的阻塞,链路利用率会得到提高且交换机的转发工作负载也得到了分担

    配置

    stp region-configuration    //进入MST视图
    region-name 名字   //指定这个MST域使用的名称
    instance 10 vlan 10   //建立实例10和VLAN10的映射关系
    active region-configuration    //激活MST域中配置的参数
    stp instance 10 root primary  //为实例10指定根网桥
    stp instance 10 root secondary  //为实例10指定次根网桥
    check region-configuration   //在MST视图下的操作,查看当前域配置
    display stp brief   //查看汇总信息
    

    7. 二层交换机链路聚合

    所谓链路聚合就是多条线路拥有共同的功能,实现更大带宽。而在交换机中提供了类似机制

    interface Eth-Trunk 1 //创建并进入聚合链路组1,一台设备可创建多个聚合组,聚合组编号本地有效
    mode manual load-balance //设置本聚合组模式位手工负载分担模式,创建的聚合组默认为此模式
    load-balance src-dst-mac   //基于源目的MAC的负载 
    trunkport GigabitEthernet 0/0/1 0/0/2 //将物理接口GigabitEthernet 0/0/1 0/0/2划入此聚合组
    least active-linknumber 1      //设置此聚合组链路最少活动成员的数量位1,低于此数量此聚合链路将自动关闭(默认阈值为1,最大阈值数为8,两端可以不一样,不一样时以下限阈值最大的为标准)
    port link-type trunk           //端口模式为trunk模式
    port trunk allow-pass vlan all //允许所有VLAN通过
    display interface Eth-Trunk   //查看交换机链路聚合情况
        
    [SW-1-Eth-Trunk1]load-balance ?
      dst-ip       //本Eth-Trunk接口的对数据的负载分担方式为居于目的IP地址的负载
      dst-mac      //基于目的mac的负载
      src-dst-ip   //基于源目的ip的负载 
      src-dst-mac  //基于源目的MAC的负载 
      src-ip       //基于源ip的负载
      src-mac      //基于源mac的负载
    
    

    链路聚合详情

    8. 三层交换技术

    二层交换机内部无法对不同的VLAN之间进行通信,但是这项功能又是特别必要的,因此出现了三层交换机,它可以实现将终端设备隔离在不同VLAN中,同时为这些终端提供VLAN间路由功能(跨VLAN通信)
    在三层交换机上,通过VLANIF虚拟接口实现VLAN间路由

    interface vlanif 10  //为VLAN10创建一个VLANIF接口并进入
    进入VLANIF后将其看作路由器进行配置IP地址为网关即可
    VLANIF编号必须与VLAN ID一一对应
    交换机接口类型依然需要配置,三层交换机实际上是交换机承担了路由器部分功能
    display ip routing-table   //三层交换机可查看路由表
    

    二、路由器

    MAC地址好比人的相貌,与生俱来;而IP地址可以看作是家庭住址
    假设有人在教室里掉了身份证被你捡到,则你归还的方法就是比对相貌寻找并归还;而如果是在路上掉了身份证被捡,比对相貌显然是不合理的,一个好的方法是根据身份证上的地址邮政过去,收件人再进行相貌比对。
    上述例子即MAC地址与IP地址对应关系,MAC地址适用于小范围,IP地址适用于大范围。交换机是二层设备无法使用IP地址,而路由器时网络层设备可以使用IP地址,这就是路由器的作用。

    display ip routing-table   //查看路由表信息
    ip address IP地址 掩码   //在接口上配置IP地址,一般与终端设备相连的接口是网关
    display ip interface brief  //查看路由器接口的IP地址和状态
    

    1. 直连路由

    同一个路由器连接的路由会叫直连路由,其条目不需要学习,会自动出现在路由表中

    示意图

    2. 静态路由

    静态路由是管理员通过命令手动添加到路由表里的路由,告诉路由器数据该往哪里走
    注意:配置静态路由时要双向配置,因此数据发送出去后还要接收响应才算完成

    //下一跳地址表示下一次到哪里,是对端的位置,填写端口号或IP地址都行
    ip route-static 最终目的IP 掩码 下一跳位置   //配置静态路由
    //路由匹配是根据最大掩码依次向下匹配,因此当掩码为0时优先级最低
    //掩码为0表示任何网络号都可以接受,即默认路由表示任何地址
    ip route-static 0.0.0.0 0 下一跳位置  //配置默认路由,当不知道目的地址时候就转发到指定下一跳
    

    有类编制方案

    • 0.0.0.0~127.255.255.255之间的地址为A类地址。前8位为网络位,后24位为主机位
    • 128.0.0.0~191.255.255.255之间的地址为B类地址。前16位为网络位,后16位为主机位
    • 192.0.0.0~223.255.255.255之间的地址为C类地址。前24位为网络位,后8位为主机位

    静态路由汇总

    无类编制方案

    这种技术称为无类域间路由CIDR,CIDR支持使用任意长度的前缀地址来分配地址,以及对数据包进行路由

    假设当前有3个网段,

    ①10.8.80.0/24 ②10.8.81.0/24 ③10.8.82.0/24
    我们通过二进制转换从左向右匹配,将其中的相同的部分提取出来,其二进制为为掩码长度,不同的部分用0填充,即10.8.80.0/22。这就是三个网段汇总后的网段。具体应用如下图,本质是提取同类项

    ip route-static 10.8.80.0 22 192.168.25.2 //如果想去汇总的三个网段,走192.168.25.2
    

    拓扑图

    如果汇总之后的网络,包含了被汇总网络之外的网络,这样的汇总网络有一定风险

    浮动静态路由

    静态路由的一大缺陷是缺乏适应性。如果管理员为路由器配置的静态路由已经无法用来转发去往那个网络的数据包,那么即使这台路由器还有其他路径可以去往那个网络,路由器还是无法自动利用新的路径对这些数据包进行转发,因此有了浮动静态路由。

    当一台路由器上有两条以不同路径去往同一个网络的等优先级静态路由时,路由器就会同时利用这两条链路来转发流量
    通过修改静态路由优先级,使一条路由成为某条主用路由备份条目的路由为浮动静态路由。

    配置

    //没有特殊语句,仅仅通过控制优先级实现浮动路由,静态路由优先级默认为60
    ip route-static 10.8.84.0 24 192.168.25.2 preference 优先级
    display ip routing-table protocol static  //查看路由器静态路由条目
    

    当优先级不同时,若路径发送故障,则路径选择会按照优先级进行顺延

    3. 动态路由

    网络规模很大,使用静态部署路由就显得不现实,因此需要动态部署
    路由器通过其他路由器分享的路由信息来获取远端网络路由条目的方式称为动态学习,为实现路由器相互分享路由信息而定义的标准称为动态路由协议

    路由学习

    路由表由三部分组成:子网,度量(权),下一跳地址
    直连路由拥有最高优先级,度量值为0。用以下例子说明具体学习过程

    在这里插入图片描述

    • 初始状态每个路由器都拥有自己的直连路由,度量值为0
    • R1向R2学习得到了30.1.1.0/24网段,将其记录在路由表内。由于R1是从R2学习到的,因此在R2相关条目的度量值上+1,也就是1
    • R2同时也向R1和R3的路由表学习得到新网段10.1.1.0/24和40.1.1.0/24,度量值分别为1
    • R1向R2学习到40.1.1.0/24网段,这一条目的度量值+1=2更新到R1路由表中
    • 同理R3R1向R2学习到10.1.1.0/24网段,这一条目的度量值+1=2更新到R3路由表中

    环路隐患

    如上图,若是10.1.1.0/24网段出现故障会出现什么情况?

    由于次网段是直连路由,R1路由器当下会在路由表中对故障路由进行删除。因此通过动态学习,R1又从R2那儿学来了这条网段路由,度量值为2,下一跳为R2。假设R3收到发往这个网段的数据包时,R3查询路由表将其发送给R2,R2发给R1,R1又发给R2,如此循环……

    RIP原理

    RIP是一种距离矢量路由协议
    路由器以RIP更新计时器设置的参数作为周期,每周期向外通过一次路由更新信息

    每当一台路由器针对某些路由的更新计时器到期时。它就会封装一个RIP响应消息对外发送。如果收到消息的路由器针对这条路由的老化计时器还没有过期,那么老化计时器就会重置;如果已经进入了垃圾收集计时器,那么这条路由会被重新激活并关闭

    通过老化计时器将一段时间没有启用的路由标记为不可达(度量值16),默认180秒
    通过垃圾收集计时器记录的是老化后,需要多久彻底删除的时间,默认120秒

    如果启动了垃圾计时器,那么路由器就会在网络中发生关于这条路由不可达的更新消息,让其他路由器也更新关于这条路由已经不可达的信息,计时器超时后会将这条路由从RIP数据库中彻底删除

    度量值X表示到达目的地址还需要经过X个路由器

    水平分割

    禁止路由器将从一个接口学习到的路由,再从同一个接口通告出去(RIP2自带水平分割)
    即我从你这里学到的已经是最好的,既然是最好的,你就不可能再从我这学到更好的回去,因此我禁止再告诉你错误消息,避免环路

    毒性反转

    当路由器从一个接口学习到一条去往某个网络时,它就会通过这个接口通告一条该网络不可达的路由(路由毒化)
    即你已经告诉过我一次,我告诉你不用再告诉我了,避免环路

    配置

    //配置路由ip等……
    rip        //在交换机上启动RIP协议
    version 2     //切换成RIPv2版本
    network 10.0.0.0   //当前路由器接口地址属于10.0.0.0子网的都开启RIP服务,A类地址(0~127)取8位,B类(128~191)16位,C类(192~223)24位
    display rip    //查看RIP情况   
    display rip 1 route    //查看RIP路由    
    由于RIP需要发送和接收响应,因此只有设置了RIP的路由器才会相互学习
    rip poison-reverse   //毒性反转,是在接口上的操作,优先级高于水平分割
    display rip 1 interface g0/0/0 verbose //查看路由器g0/0/0接口的RIP详情
    display current-configuration configuration rip //查看路由器上的RIP配置
    display ip routing-table protocol rip //查看通过RIP学到的路由
    undo rip split-horizon  //接口上禁用水平分割
    //RIPv2默认禁用水平分割后才会启动自动汇总
    rip summary-address 10.0.0.0 255.255.128.0 //将当前路由器下属于10.0.0.0/17子网的网络都汇总为10.0.0.0向外发送响应,其中掩码必须使用点分十进制位表示
    default-route originate //此语句使用于添加了默认路由后,进入RIP状态下动态发布默认路由
    
    掩码32位代表这个网络中只有一台主机。就是IP地址本身的主机
    interface loopback 0 //创建一个环回接口0,这是虚拟接口,像真正接口一样使用即可
    
    RIPV2支持明文认证和MD5认证
    其认证需要配置在接口上,以链路为单位,只要直连设备之间使用相同密码,就可以使他们通过认证并建立邻居关系
    rip authentication-mode simple zyl //将接口明文密码设置为zyl,有相同密码的相邻路由器才互相学习
    display this //查看端口配置信息,明文密码会被查到,因此明文配置不安全
    //采用md5加密,数据包可选择nonstandard(IETF)或usual(华为格式)加密,cipher可以把设置的密码进行加密,最后的数字1是MD5认证的密钥ID
    rip authentication-mode md5 nonstandard/usual cipher 密码 1  
    display rip 1 neighbor   //查看邻居情况
    timers rip 更新计时器时间 老化计时器时间 垃圾收集计时器时间 //在RIP视图下设置计时器时间
    preference 优先级  //在RIP视图下设置RIP学习到的路由优先级(1~255)
    
    silent-interface  //在RIP视图下使用,令所有接口或指定接口不向外发送广播或组播RIP更新
    undo rip output  //接口上使用,令此接口不向外发送RIP更新
    undo rip input  //接口上使用,令此接口不再接收RIP更新
    

    OSPF

    OSPF是一个链路状态型路由协议

    4. 路由优先级

    路由类型 路由表中标识 优先级(越小越先)
    直连路由 Direct 0
    OSPF路由 OSPF 10
    静态路由 Static 60
    RIP路由 RIP 100

    5. 单臂路由

    将一个路由器接口逻辑化成多个接口的技术

    配置

    interface g0/0/0.10    //进入g0/0/0的10端口
    ↓配置后,在接收数据时,路由器会剥除数据中对应的VLAN标签并三层转发,是否带VLAN标签由出站接口决定
    dot1q termination vid 10//配置802.1Q封装(与对端交换机保持一致),指定端口接收PVID(VLAN值)
    ip address xxx xx   //为这个有端口的接口正常配置ip地址和掩码
    arp broadcast enable  //使接口能够处理广播帧(单臂路由独有语句)
    

    6. DHCP

    一种利用路由器自动分配IP地址的技术

    dhcp enable   //打开DHCP服务
    interface XXX  //进入要放出地址的接口
    dhcp select global  //在哪些接口上发送地址
    quit  //退出接口模式
    ip pool for-net10  //创建地址池for-net10并进入视图
    network 10.0.0.0 mask 8  //for-net10地址池为10.0.0.0子网下的终端分配地址
    gateway-list 10.10.10.254  //该地址的网关为10.10.10.254 
    dns-list 8.8.8.8   //使用电信服务划分
    excluded-ip-address 10.10.10.253  //其中10.10.10.253不要划分出去
    lease day 1     //这些地址租期为1天
    quit
        
    //进入接口
    dhcp select relay
    dhcp relay server-ip DHCP服务器IP地址  //分配地址经端口都要配置DHCP中继服务
    
    展开全文
  • 包括路由与交换技术的所有实验,不容错过
  • 想学习路由交换技术,往网络工程师方向发展的可以看看。
  • 本实验模拟企业网络场景。该公司使用两台路由器R2和R3作为出口网关连接到外网R1,R2和R3运行VRRP协议,两台路由器在同一个虚拟组。当R2为主路由器时,所有业务流量都由R2承担,高峰期时 会造成网络阻塞,而R3一直...
  • 一本 路由器交换机配置书籍,思科 华三,华为都有
  • RIP协议在收到某一邻居网关发布的路由信息后,下述对度量值的不正确处理是( )。 (2.0分) • A、 对本路由表中没有的路由项,只在度量值少于不可达时增加该路由项 • B、 对本路由表中已有的路由项,当发送报文...
  • 访问控制列表可以用于防火墙; 访问控制列表可以用于Qos(Quality of Service),对数据流量进行控制; 在DCC中,访问控制列表还可用来规定触发拨号的...在配置路由策略时,可以利用访问控制列表来作路由信息的过滤。
  • 1 使用全局配置命令 spanning-tree vlan vlan-id root primary 可以改变网桥的优先级。使用该命令后,一般情况下网桥的优先级为( )。 (2.0分) A、 0 B、 比最低的网桥优先级小1 C、 ...32768
  • 路由与交换技术试题

    2020-02-22 17:09:27
    多层交换功能 C. 支持多种可路由协议 D. 具有存储、转发、寻址功能 路由器在转发数据包到非直连网段的过程中, 依靠数据 包中的哪一个选项来寻找下一跳地址 ( B ) A. 帧头 B. IP 报文头部 C. SSAP ...

    本文转载自https://blog.csdn.net/include_ice/article/details/80111915?locationNum=13&fps=1

    一、选择题

    1. 交换机和路由器相比,主要的区别有 ( AB )

    A. 交换机工作在 OSI 参考模型的第二层

    B. 路由器工作在 OSI 参考模型的第三层

    C. 交换机的一个端口划分一个广播域的边界

    D. 路由器的一个端口划分一个冲突域的边界

    1. 以下不会在路由表里出现的是 : ( D )

    A. 下一跳地址

    B. 网络地址

    C. 度量值

    D. MAC 地址

    1. 路由器是一种用于网络互连的计算机设备, 但作为路由 器,并不具备的是 ( B )

    A. 支持多种路由协议

    B. 多层交换功能

    C. 支持多种可路由协议

    D. 具有存储、转发、寻址功能

    1. 路由器在转发数据包到非直连网段的过程中, 依靠数据 包中的哪一个选项来寻找下一跳地址 ( B )

    A. 帧头

    B. IP 报文头部

    C. SSAP 字段

    D. DSAP 字段

    1. IP 地址 190.233.27.13是(B )类地址

    A. A

    B. B

    C. C

    D. D

    1. IP 地址 224.0.0.5代表的是什么地址 ? ( C )

    A. 主机地址

    B. 网络地址

    C. 组播地址

    D. 广播地址

    1. 在 TCP/IP协议栈中, 下面哪一组选项能够唯一地确定一 个 TCP 连接:( D )

    A. 源 IP 地址和源端口号

    B. 源 IP 地址和目的端口号

    C. 目的地址和源端口号

    D. 源地址、目的地址、源端口号和目的端口号

    1. 如果要满足全线速二层(全双工)转发,则某种带有 24个固定 10/100M端口的交换机的背板带宽最小应为多 少? ( D )

    A. 24Gbps

    B. 12Gbps

    C. 2.4Gbps

    D. 4.8Gbps

    1. 下面的描述正确的是:( BCD )

    A. 集线器工作在 OSI 参考模型的第一、二两层

    B. 集线器能够起到放大信号,增大网络传输距离的 作用

    C. 集线器上连接的所有设备同属于一个冲突域

    D. 集线器支持 CSMA/CD技术

    1. 在访问控制列表中地址和屏蔽码为 168.18.0.0

    0.0.0.255所表示的 IP 地址范围是 ( B )

    A. 168.18.67.1~168.18.70.255

    B. 168.18.0.1~168.18.0.255

    C. 168.18.63.1~168.18.64.255

    D. 168.18.64.255~168.18.67.255

    1. 请问能够在路由器的下列哪个模式使用 debug 命令 ( B )

    A. 用户模式

    B. 特权模式

    C. 全局配置模式

    D. 接口配置模式

    1. 下面的说法正确的是 ( ABD )

    A. DNS 是用来解析 IP 地址和域名地址(互联网地址) 的

    B. 默认网关是互连内网和外网的通道

    C. 每个 Windows 用户都可以创建域,并使用域中的一 个帐号

    D. 每个 Windows 用户都可以创建工作组,创建了一个 工作组,计算机重启后就会自动加入到该工作组

    1. 数据分段(segment )是 OSI 七层模型中的哪一层的数据 名称 ( D )

    A. 物理层

    B. 数据链路层

    C. 网络层

    D. 传输层

    1. 集线器目前一般应用最多的是在 ( A )

    A. 一个办公室内部实现互连的时候

    B. 一个楼层各个办公室的互连

    C. 一个多媒体教室中主机的互连

    D. 一个建筑物内部两个地点间距离超过了 200米的 时候

    1. 下列属于距离矢量路由协议容易引起的问题是 : ( C )

    A. 水平分割

    B. 路径中毒

    C. 计数到无穷

    D. 抑制时间

    1. 如果对 C 类地址段 193.11.22.0/24进行可变长子网划分, 则下列地址能够成为其子网地址的有:BC_

    A. 193.11.22.174

    B. 193.11.22.192

    C. 193.11.22.172

    D. 193.11.22.122

    1. 下列 VLSM 的理解正确的是 : ( ACD )

    A. VLSM 就是 Variable Length Subnet Mask的缩写形 式,即可变长子网掩码

    B. 是指使用不同于整个字节的子网掩码划分方法, 使用按位划分网络位和主机位的子网划分方法 C. 如果仅仅使用非整字节的子网掩码位数,并不能 称之为 VLSM

    D. 如果一个企业使用了一个 C 类的网络进行了整体 的规划,并且划分了至少 6个不同大小的网络,则 可以肯定这个企业内部的 IP 地址一定使用了 VLSM 进行规划

    1. IP 地址为:192.168.100.138, 子网掩码为:255.255.255.192所在的网络地址是什么,和 IP 地址 192.168.100.153是否 在同一个网段? ( A )

    A. 192.168.100.128,是

    B. 192.168.100.0, 是

    C. 192.168.100.138, 是

    D. 192.168.100.128, 不是

    1. 一个网段 150.25.0.0的子网掩码是 255.255.224.0,

    (BCD )是有效的主机地址

    A. 150.25.0.0

    B. 150.25.16.255

    C. 150.25.2.24

    D. 150.15…30

    1. 一个 B 类网络 , 有 5位掩码加入缺省掩码用来划分子网 , 每 个子网最多(D )台主机

    A. 510

    B. 512

    C. 1022

    D. 2046

    1. BPDU 报文是通过(C )进行传送的

    A. IP 报文

    B. TCP 报文

    C. 以太网帧

    D. UDP 报文

    1. 下列对 IEEE802.1Q 标准的理解正确的是:( BD )

    A. 它在 MAC 层帧中插入了一个 16bit 的 VLAN 标识符

    B. 它通过插入 3个 bit 位来定义 802.1p 优先级,对流 入交换机的帧进行排序

    C. 一旦在交换机中启动了 IEEE802.1Q VLAN标记功 能,则所有进出交换机的帧都被加了标记

    D. IEEE802.1Q 解决了跨交换机的相同 VLAN 间的通信 问题

    1. 要想拒绝主机 192.168.100.3/24访问服务器201.10.182.10/24的 WWW 服务,下面的访问控制列表配 置及其模式均正确的是:( D )

    A. Router#ip access-list 101 deny tcp

    192.168.100.3 0.0.0.255 201.10.182.10 0.0.0.255 eq 80

    B. Router(config)#ip access-list 10 deny tcp 192.168.100.30 0.0.0.255 201.10.182.10 0.0.0.255 eq 80

    C. Router(config-serial1/0)#ip access-list 10 deny tcp 192.168.100.3 0.0.0.255

    201.10.182.10 0.0.0.255 eq 80

    D. Router(config)#ip access-list 101 deny tcp 192.168.100.3 0.0.0.255 201.10.182.10 0.0.0.255 eq 80

    1. 下列对访问控制列表的描述不正确的是:( C )

    A. 访问控制列表能决定数据是否可以到达某处

    B. 访问控制列表可以用来定义某些过滤器

    C. 一旦定义了访问控制列表,则其所规范的某些 数据包就会严格被允许或拒绝

    D. 访问控制列表可以应用于路由更新的过程当中

    1. 以下情况可以使用访问控制列表准确描述的是:( C )

    A. 禁止有 CIH 病毒的文件到我的主机

    B. 只允许系统管理员可以访问我的主机

    C. 禁止所有使用 Telnet 的用户访问我的主机

    D. 禁止使用 UNIX 系统的用户访问我的主机

    1. 路由器中时刻维持着一张路由表, 这张路由表可以是静 态配置的,也可以是(C )产生的

    A. 生成树协议

    B. 链路控制协议

    C. 动态路由协议

    D. 被承载网络层协议

    1. 以太网交换机的每一个端口可以看做一个 ( A )

    A. 冲突域

    B. 广播域

    C. 管理域

    D. 阻塞域

    1. 下面的描述正确的是:( C )

    A. 集线器不能延伸网络的可操作的距离

    B. 集线器不能在网络上发送变弱的信号

    C. 集线器不能过滤网络流量

    D. 集线器不能放大变弱的信号

    1. DNS 的作用是 ( C )

    A. 为客户机分配 IP 地址

    B. 访问 HTTP 的应用程序

    C. 将域名翻译为 IP 地址

    D. 将 MAC 地址翻译为 IP 地址

    1. OSI 代表什么 ( D )

    A. 标准协会组织

    B. Internet 标准组织

    C. 开放标准协会

    D. 开放系统互连

    1. 如下图所示是一个简单的路由表,从这个路由表中,可 以得出:( CD )

    A. 这台路由器有三个端口连接了线缆并处于 UP 状 态, FastEthernet0/0、 Loopback0、 Loopback1

    B. 这台路由器启动了 OSPF 路由协议

    C. 这台路由器只启动了 RIP 协议

    D. 这台路由器只能将目标是

    1.1.1.0/2.0.0.0/3.0.0.0/4.4.4.0/5.5.5.0网 络的数据包发送出去,其他的数据都将被丢弃并 返回目标网络不可达信息

    1. 当路由器接收的 IP 报文中的目标网络不在路由表中时, (没有缺省路由时)采取的策略是 ( A )

    A. 丢掉该报文

    B. 将该报文以广播的形式发送到所有直连端口

    C. 直接向支持广播的直连端口转发该报文

    D. 向源路由器发出请求,减小其报文大小

    1. 对应下图的网络环境, 配置静态路由使所有相关的网络 段全部可以互通, 则 R1的配置中哪条是不配也不影响正 常的数据包传输的:( CE

    )

    A. Router_config# ip route 192.168.4.0 255.255.255.0 192.168.3.2

    B. Router_config# ip route 192.168.5.0 255.255.255.0 192.168.2.2

    C. Router_config# ip route 192.168.6.0 255.255.255.0 192.168.2.2

    D. Router_config# ip route 192.168.7.0 255.255.255.0 192.168.2.2

    E. Router_config# redistribute connect

    1. 当路由器接收的 IP 报文的生存时间值等于 1时,采取的 策略是 ( A )

    A. 丢掉该报文

    B. 转发该报文

    C. 将该报文分段

    D. 其它三项答案均不对

    1. 一个 C 类网络需要划分 5个子网,每个子网至少包含 32个主机,请问,合适的子网掩码应为多少? ( D )

    A. 255.255.255.224

    B. 255.255.255.192

    C. 255.255.255.252

    D. 没有合适的子网掩码

    1. 规划一个 C 类网 , 需要将整个网络分为 9个子网 , 最大的子 网有 15台主机 , 下列哪个是合适的子网掩码 ? ( D )

    A. 255.255.224.0

    B. 255.255.255.224

    C. 255.255.255.240

    D. 没有合适的子网掩码

    1. 下列地址表示私有地址的是:( DE )

    A. 202.118.56.21

    B. 1.2.3.4

    C. 192.118.2.1

    D. 172.16.33.78

    E. 10.0.1.2

    私有IP地址范围有:

    A类:10.0.0.0-10.255.255.255

    B类:172.16.0.0-172.31.255.255

    C类:192.168.0.0-192.168.255.255

    1. 某台路由器上配置了如下一条访问列表 ( C )

    access-list 4 permit 202.38.160.1 0.0.0.255

    access-list 4 deny 202.38.0.0 0.0.255.255

    表示:

    A. 只禁止源地址为 202.38.0.0网段的所有访问

    B. 只允许目的地址为 202.38.0.0网段的所有访问

    C. 检查源 IP 地址,禁止 202.38.0.0大网段的主机, 但允许其中的 202.38.160.0小网段上的主机

    D. 检查目的 IP 地址,禁止 202.38.0.0大网段的主 机,但允许其中的 202.38.160.0小网段的主机

    1. 交换机如何转发收到的二层数据帧? ( A )

    A. 比较数据帧的 MAC 地址是否在 MAC 端口对应表中命 中,如果命中即向此端口转发

    B. 比较数据帧的 MAC 地址是否在 MAC 端口对应表中命 中,如果没有命中即丢弃该帧

    C. 交换机存储此二层数据帧,待目的设备发出查询, 再发向目的设备

    D. 交换机察看二层帧对应的 IP 地址是否在端口地址 表中,如果在,则向所有端口转发

    1. 下面关于生成树协议优缺点描述不正确的是 ( C )

    A. 生成树协议能够管理冗余链路

    B. 生成树协议能够阻断冗余链路,防止环路的产生

    C. 生成树协议能够防止网络临时失去连通性

    D. 生成树协议能够使透明网桥工作在存在物理环路 的网络环境中

    1. 在以太网中, 是根据 (D )地址来区分不同的设备的

    A. IP 地址

    B. IPX 地址

    C. LLC 地址

    D. MAC 地址

    1. 路由器启动时访问不同类型存储器的先后顺序是: ( A )

    A. ROM ->FLASH->NVRAM

    B. FLASH ->ROM->NVRAM

    C. ROM ->NVRAM->FLASH

    D. FLASH ->NVRAM->ROM

    1. 以下对于缺省路由描述正确的是:( BC )

    A. 缺省路由是优先被使用的路由

    B. 缺省路由是最后一条被使用的路由

    C. 缺省路由是一种特殊的静态路由

    D. 缺省路由是一种特殊的动态路由

    1. 目前网络设备的 MAC 地址由(C )位二进制数字构 成, IP 地址由 ___位二进制数字构成

    A. 48, 16

    B. 64, 32

    C. 48, 32

    D. 48, 48

    1. 在缺省的情况下, 如果一台路由器在所有接口同时运行 了 RIP 和 OSPF 两种动态路由协议, 下列说法中正确的是 : ( B )

    A. 针对到达同一网络的路径,在路由表中只会显示 RIP 发现的那一条,因为 RIP 协议的优先级更高

    B. 针对到达同一网络的路径,在路由表中只会显示 OSPF 发现的那一条, 因为 OSPF 协议的优先级更高

    C. 针对到达同一网络的路径,在路由表中只会显示 RIP 发现的那一条, 因为 RIP 协议的花费值 (metric ) 更小

    D. 针对到达同一网络的路径,在路由表中只会显示 OSPF 发现的那一条,因为 OSPF 协议的花费值 (metric )更小

    1. 解决路由环问题的方法有 ( ABD )

    A. 水平分割

    B. 触发更新

    C. 路由器重启

    D. 定义最大跳步数

    1. IP 报文头中固定长度部分为(B )字节

    A. 10

    B. 20

    C. 30

    D. 40

    1. 某公司申请到一个 C 类 IP 地址,但要连接 6个子公司,最 大的一个子公司有 26台计算机, 各个子公司需要在不同 的网段中,如果使用统一的子网掩码划分子网,则掩码 可以是:( D )

    A. 255.255.255.0

    B. 255.255.255.128

    C. 255.255.255.192

    D. 255.255.255.224

    1. 一个 32位的 IP 地址与它的掩码作异或计算,所得到的 32位二进制数是此 IP 地址的 ( B )

    A. A 类地址

    B. 主机地址

    C. 网络地址

    D. 解析地址

    1. 下面有关 HelloTime 时间间隔的配置,描述不正确的为 ( D )

    A. 较长的 HelloTime 可以降低生成树计算的消耗, 因为网桥可以不那么频繁的发送配置消息

    B. 较短的 HelloTime 可以在丢包率较高的时候,增 强生成树的健壮性,避免因为丢包而误认为链路 故障

    C. 过长的 HelloTime 会导致因为链路丢包而使网桥 认为链路故障,开始生成树重新计算

    D. HelloTime 配置的越短越好

    1. 下列对生成树协议的理解正确的是:( A )

    A. 生成树协议就是在交换网络中形成一个逻辑上的 树形结构,从而避免某些物理上的环路形成的交换网中的无用帧形成的拥塞

    B. 生成树协议实际已经在交换网络中形成了一个物 理上的树形结构

    C. 生成树协议状态一旦稳定,后续发送的数据包将 都沿着这个树形路径转发到目的地

    D. 生成树协议只是为了消除环路的存在,并不能提 供冗余备份地功能

    1. 如下访问控制列表的含义是:( C )

    access-list 11 deny icmp 10.1.10.10 0.0.255.255 any host-unreachable

    A. 规则序列号是 100,禁止发送到 10.1.10.10主机 的所有主机不可达报文

    B. 规则序列号是 100,禁止发送到 10.1.0.0/16网段 的所有主机不可达报文

    C. 规则序列号是 100,禁止从 10.1.0.0/16网段发出 的所有主机不可达报文

    D. 规则序列号是 100,禁止从 10.1.10.10主机发出 的所有主机不可达报文

    1. OSPF 协议具有如下特点:( BCD )

    A. 最多可支持近百台路由器

    B. 如果网络的拓扑结构发生变化, OSPF 立即发送更 新报文

    C. 算法本身保证了不会生成自环路由

    D. 区域划分减少了路由更新时占用的网络带宽

    1. RARP 的作用是 ( D )

    A. 将自己的 IP 地址转换为 MAC 地址

    B. 将对方的 IP 地址转换为 MAC 地址

    C. 将对方的 MAC 地址转换为 IP 地址

    D. 知道自己的 MAC 地址,通过 RARP 协议得到自己的 IP 地址

    1. IP 地址为 192.168.100.132, 子网掩码为 255.255.255.192的 地址,可以划分多少个子网位,多少个主机位 ( B )

    A. 2, 32

    B. 4, 30

    C. 254, 254

    D. 2, 30

    1. 在无盘工作站向服务器申请 IP 地址时, 使用的是 (B ) 协议

    A. ARP

    B. RARP

    C. BOOTP

    D. ICMP

    1. 当交换机检测到一个数据包携带的目的地址与源地址 属于同一个端口时,交换机会怎样处理? ( B )

    A. 把数据转发到网络上的其他端口

    B. 不再把数据转发到其他端口

    C. 在两个端口间传送数据

    D. 在工作在不同协议的网络间传送数据

    1. 以下关于以太网交换机的说法哪些是正确的 ? ( D )

    A. 以太网交换机是一种工作在网络层的设备

    B. 以太网交换机最基本的工作原理就是 802.1D

    C. 生成树协议解决了以太网交换机组建虚拟私有网 的需求

    D. 使用以太网交换机可以隔离冲突域

    1. 关于交换机交换方式的描述正确的是:( B )

    A. 碎片隔离式交换:交换机只检查进入交换机端口 的数据帧头部的目的 MAC 地址部分,即把数据转发 出去

    B. 存储转发式交换:交换机要完整地接收一个数据 帧,并根据校验的结果以确定是否转发数据

    C. 直通式交换:交换机只转发长度大于 64字节的数 据帧,而隔离掉小于 64字节的数据

    D. 这些说法全部正确

    1. 下面哪些地址可以正确地表示 MAC 地址:( C )

    A. 0067.8GCD.98EF

    B. 007D.7000.ES89

    C. 0000.3922.6DDB

    D. 0098.FFFF.0AS1

    1. (A )为两次握手协议,它通过在网络上以明文的 方式传递用户名及口令来对用户进行验证

    A. PAP

    B. IPCP

    C. CHAP

    D. RADIUS

    1. 在访问控制列表中地址和掩码为 168.18.64.0 0.0.3.255表示的 IP 地址范围 ( B )

    A. 168.18.67.0~168.18.70.255

    B. 168.18.64.0~168.18.67.255

    C. 168.18.63.0~168.18.64.255

    D. 168.18.64.255~168.18.67.255

    1. 把一台 WWW 服务器从一个网段转移到另外一个网段, 以下哪个措施能够最好地保持客户端浏览器与 WWW 服 务器之间原有的映射关系 ? ( D )

    A. 改变服务器的 IP 地址和 URL 地址

    B. 改变服务器的 IP 地址而不改变 URL 地址

    C. 不改变服务器的 IP 地址而改变 URL 地址

    D. 不改变服务器的 IP 地址也不改变 URL 地址

    1. 如果需要配置一个交换机作为网络的根, 则应该配置下 面哪个参数 ( B )

    A. 桥的 HelloTime

    B. 桥的优先级

    C. 该桥所有端口配置为边缘端口

    D. 将给该桥所有端口的路径花费配置为最小

    1. 广播风暴是如何产生的 ( B )

    A. 大量 ARP 报文产生

    B. 存在环路的情况下,如果端口收到一个广播报 文,则广播报文会增生从而产生广播风暴

    C. 站点太多,产生的广播报文太多

    D. 交换机坏了,将所有的报文都广播

    1. 下面关于生成树协议的原理描述,哪个是错误的 ( D )

    A. 从网络中的所有网桥中,选出一个作为根网桥 (Root )

    B. 计算本网桥到根网桥的最短路径

    C. 对每个 LAN ,选出离根桥最近的那个网桥作为指 定网桥,负责所在 LAN 上的数据转发

    D. 网桥选择若干个根端口,该端口给出的路径是此 网桥到根桥的最佳路径

    1. 要从一台主机远程登录到另一台主机, 使用的应用程序 为 ( C )

    A. HTTP

    B. PING

    C. TELNET

    D. TRACERT 68. 能正确描述了数据封装的过程的是 ( D )

    A. 数据段 ->数据包 ->数据帧 ->数据流 ->数据

    B. 数据流 ->数据段 ->数据包 ->数据帧 ->数据

    C. 数据 ->数据包 ->数据段 ->数据帧 ->数据流

    D. 数据 ->数据段 ->数据包 ->数据帧 ->数据流

    1. 共享式以太网采用了(D )协议以支持总线型的结 构

    A. ICMP

    B. ARP

    C. SPX

    D. CSMA/CD

    1. 一台 IP 地址为 10.110.9.113/21 主机在启动时发出的广播 IP 是 ( B )

    A. 10.110.9.255

    B. 10.110.15.255

    C. 10.110.255.255

    D. 10.255.255.255

    1. 采用 CSMA/CD技术的以太网上的两台主机同时发送数 据,产生碰撞时,主机应该做何处理 ( A )

    A. 产生冲突的两台主机停止传输,在一个随机时间 后再重新发送

    B. 产生冲突的两台主机发送重定向信息,各自寻找 一条空闲路径传输帧报文

    C. 产生冲突的两台主机停止传输,同时启动计时 器, 15秒后重传数据

    D. 主机发送错误信息,继续传输数据

    1. 集线器一般用于哪种网络拓扑中:( B )

    A. 总线形

    B. 星形网络

    C. 环形网络

    D. 树形网络

    1. 传输层协议端口号小于(C )的已保留与现有服务 一一对应,此数字以上的端口号可自由分配

    A. 100

    B. 199

    C. 1024

    D. 2048

    1. IP 协议的特征是 ( B )

    A. 可靠 , 无连接

    B. 不可靠 , 无连接

    C. 可靠 , 面向连接

    D. 不可靠 , 面向连接

    1. 可能会使用以下哪些信息实现地址转换 ( ABC )

    A. IP 地址

    B. TCP 端口号

    C. UDP 端口号

    D. 其他都不是

    1. D 类地址的缺省子网掩码有(D )位

    A. 8

    B. 16

    C. 24

    D. 其他三项都不对

    1. 交换机如何知道将帧转发到哪个端口 ( A )

    A. 用 MAC 地址表

    B. 用 ARP 地址表

    C. 读取源 ARP 地址

    D. 读取源 MAC 地址

    1. 列对 OSI 参考模型各层对应的数据描述不正确的是: ( C )

    A. 应用层、表示层和会话层的数据统称为协议数据 单元(PDU )

    B. 网络层的数据被称为数据报(Datagram )

    C. 传输层的数据被称为数据报(Datagram )

    D. 物理层的数据被称为数据位(Bits )

    1. 哪种网络设备可以屏蔽过量的广播流量? ( B )

    A. 交换机

    B. 路由器

    C. 集线器

    D. 防火墙

    1. 下列关于路由的描述中, 哪一项较为接近静态路由的定 义 ( B )

    A. 明确了目的地网络地址,但不能指定下一跳地址 时采用的路由

    B. 由网络管理员手工设定的,明确指出了目的地网 络和下一跳地址的路由

    C. 数据转发的路径没有明确指定,采用特定的算法 来计算出一条最优的转发路径

    D. 其它说法都不正确

    1. 下列关于路由的描述中, 哪一项较为接近动态路由的定 义 ( C )

    A. 明确了目的地网络地址,但不能指定下一跳地址 时采用的路由

    B. 由网络管理员手工设定的,明确指出了目的地网 络和下一跳地址的路由

    C. 数据转发的路径没有明确指定,采用特定的算法 来计算出一条最优的转发路径

    D. 其他说法都不正确

    1. 下列所述的哪一个是无连接的传输层协议? ( B )

    A. TCP

    B. UDP

    C. IP

    D. SPX

    1. 以太网交换机一个端口在接收到数据帧时, 如果没有在 MAC 地址表中查找到目的 MAC 地址,通常如何处理? ( C )

    A. 把以太网帧复制到所有端口

    B. 把以太网帧单点传送到特定端口

    C. 把以太网帧发送到除本端口以外的所有端口

    D. 丢弃该帧

    1. 以太网是(A )标准的具体实现

    A. IEEE802.3

    B. IEEE802.4

    C. IEEE802.1Q

    D. IEEE802.z

    1. 下列对访问控制列表的描述不正确的是:( C )

    A. 访问控制列表能决定数据是否可以到达某处

    B. 访问控制列表可以用来定义某些过滤器

    C. 一旦定义了访问控制列表,则其所规范的某些数据 包就会严格被允许或拒绝

    D. 访问控制列表可以应用于路由更新的过程当中

    二、简答题

    1. 请简述 STP 协议判断最短路径的规则

    答:①比较路径开销,带宽越小开销越大;

    ② 比较发送者的 Bridge ID,选择参数小的;

    ③ 比较发送者的 Port ID,选择参数小的;

    ④ 比较接收者的 Port ID,选择参数小的

    1. 请简要说明交换网络中为什么形成环路、 产生广播风暴 的原理?

    答:交换网络中单链路的网络容易形成单点故障,为了缓解 单点故障对网络造成的影响,希望能够在交换网络中提供冗 余链路,也就是从一点到达另一点时有多条链路可以达到。 交换机对于广播帧的处理方式是除接收数据接口外, 向其 他所有接口进行复制、扩散。这样,在存在环路的交换网络 中,只要有一个广播数据帧,所有交换机将不停地复制、扩 散,在很短的时间内使整个交换网络中充斥着大量的广播数据,占用大量的带宽和设备 CPU 资源,从而造成全网性能下 降或网络中断。

    1. 请讲述交换机的启动过程

    答:①交换机开机加电自检硬件;

    ②交换机从 ROM 中读取微代码从 FLASH 中加载操作系 统(RGNOS )

    ③将操作系统(RGNOS )加载到 RAM 中,操作系统启 动完成

    ④系统从 FLASH 中检测是否有配置文件(config.text ) , 如有,将配置文件加载到 RAM 中(running-config )

    ⑤如无配置文件, 将启动 setup 命令, 进行交互式基本配 置。

    1. 二层交换机与路由器有什么区别,为什么交换机一般 用于局域网内主机的互联, 不能实现不同 IP 网络的主 机互相访问。

    答:①从 OSI 的角度分析交换机和路由器的区别:

    交换机属于数据链路层设备,识别数据帧的 MAC 地 址信息进行转发;路由器属于网络层设备,通过识别网络层 的 IP 地址信息进行数据转发。

    ②数据处理方式的区别:

    交换机对于数据帧进行转发,交换机不隔离广播,交 换机对于未知数据帧进行扩散;路由器对 IP 包进行转发,路 由器不转发广播包,路由器对于未知数据包进行丢弃。 ③数据转发性能方面:

    交换机是基于硬件的二层数据转达,转发性能强; 路由器是基于软件的三层数据转发,转发性能相对较差。 ④接口类型:

    交换机一般只具备以太网接口,类型单一,接口密 度大;路由器能够提供各种类型的广域网接口,能够连接不 同类型的网络链路,接口数较少。

    ⑤应用环境:

    交换机一般应用于局域网内部,大量用户的网络接入 设备。路由器一般用于网络间的互联。

    1. 请讲述 VLAN 技术的种类和各自的特点

    答:①基于端口的 VLAN :针对交换机的端口进行 VLAN 的 划分,不受主机的变化影响

    ②基于协议的 VLAN :在一个物理网络中针对不同的 网络层协议进行安全划分

    ③基于 MAC 地址的 VLAN :基于主机的 MAC 地址进 行 VLAN 划分,主机可以任意在网络移动而不需要重新划分 ④基于组播的 VLAN :基于组播应用进行用户的划分

    ⑤基于 IP 子网的 VLAN :针对不同的用户分配不同子 网的 IP 地址,从而隔离用户主机,一般情况下结合基于端口 的 VLAN 进行应用

    1. 请简要说明一下 NAT 可以解决的问题以及 NAT 受到 的限制 。

    答:NAT 可以解决的问题:

    ① 解决地址空间不足的问题; ② 私有 IP 地址网络与公网互联;

    ③ 非注册 IP 地址网络与公网互联; ④ 网络改 造中,避免更改地址带来的风险

    NAT 受到的限制:

    ①影响网络性能; ②不能处 理 IP 报头加密的报文;

    ③无法实现端到端的路径跟踪(traceroute ) ;④某些应 用可能支持不了:内嵌 IP 地址

    1. 请讲述一下 RIP 协议的配置步骤及注意事项?

    答:① 开启 RIP 协议进程

    ② 申明本路由器参数 RIP 协议计算的接口网段(注意:不需申请非直接网段)

    ③指定版本(注意 :路由器版本要保持一致,路由器默认 可以接收 RIPv1、 RIPv2的报文)

    ④ RIPv2支持关闭自动路由汇总功能

    1. PAP 和 CHAP 各自的特点是什么?

    答:PAP 的特点:

    ① 由客户端发出验证请求,服务器端无法区分是否为 合法请求,可能引起攻击

    ② 客户端直接将用户名和密码等验证信息以明文方式 发送给服务器端,安全性低

    ③ 由客户端发出验证请求,容易引起客户端利用穷举 法暴力破解密码

    ④相比 CHAP 性能高,两次握手完成验证

    CHAP 的特点:

    ① 由服务器端发出挑战报文 ② 在整个认 证过程中不发送用户名和密码

    ③解决了 PAP 容易引起的问题 ④ 占用网络资 源,认证过程相对于 PAP 慢

    1. 请问有类路由协议和无类路由协议有什么区别? 答:1、原理:有类路由协议发送路由更新信息时不包含子网 掩码信息;无类路由协议包含。

    2、处理:有类路由协议路由器收到无法识别的更新信息时,只能按照标准的 A 、 B 、 C 类子网信息进行处理;无类 路由协议能够从路由信息中识别其子网信息。

    3、 后果:有类路由协议不支持不连续的变长子网路由; 无类路由协议支持 VLSM 无类路由协议能够更灵活进行子网 划分应用,节约 IP 地址资源。

    1. 请问距离矢量协议和链路状态协议有什么区别? 答:距离矢量路由协议 ::

    ① 向邻居发送路由信息 ;

    ② 定时更新路由信息 ;

    ③ 将本机全部路由信息做为更新信息

    链路状态路由协议:

    ① 向全网扩散链路状态信息 ;

    ② 当网络结构发生变化立即发送更新信息 ;

    ③ 只发送需更新的信息

    1. 请问端口号的作用是什么?请问当一台客户端主机访 问互联网某服务器的 WEB 服务时, 传输层封装的源端 口、目的端口分别是什么?

    答:1、传输层端口号的作用:区分上层应用层的不同应用服 务进程的

    2、客户端向服务器端发数据时,源端口为大于 1024随机 端口,如 1150,目的端口为服务器 WEB 服务端口, 如 80 。

    3、 当服务器端向客户端发数据时, 源端口为 80, 目的端 口为 1150 。

    三、网络配置

    ACL 配置

    操作拓扑

    现有若干台路由器(路由器名称分别为 R1、 R2、 R3、 R4、 R5、 R6)组成的网络,请为各设备进行配置,以实现 ACL 的功能。具体要求如下:

    (1) 根据要求,分别在 R1、 R3、 R4路由器上配置基本命令:①配置主机名分别为 R1, R3, R4; en config t

    Router(config)#host R1

    Router(config)#host R3

    Router(config)#host R4

    ②在路由器上关闭 DNS 查询;

    R1(config)#no ip domain-lookup

    R3(config)#no ip domain-lookup

    R4(config)#no ip domain-lookup

    ③在 R3上配置特权密码和 vty 密码,密码均为 cisco ; R3(config)#enable secret cisco

    R3(config)#line vty 0 4

    R3(config-if)#password cisco

    R3(config-if)#login

    (2) 在 R1, R3, R4上分别配置各接口的 IP 地址等信息(圆 圈表示环回接口) ,

    并设置时钟频率为 64000 。

    提示:请在路由器的串口上配置 clock rate 64000

    R1(config)#int s0/0/0

    R1(config-if)#ip add 10.1.1.2 255.255.255.0 R1(config-if)#clock rate 64000

    R1(config-if)#no sh

    R1(config)#int s0/0/1

    R1(config-if)#ip add 192.168.12.1 255.255.255.0

    R1(config-if)#clock rate 64000

    R1(config-if)#no sh

    R1(config)#int f0/1

    R1(config-if)#ip add 172.16.1.1 255.255.255.0

    R1(config-if)#no sh

    备注:R1共配置三个端口,两个串口均配置 clock rate 64000,一个 g 口不用配置 clock rate 64000,默认时物理 端口没有打开,所以使用物理端口前需要使用 no shut 打开。 下同

    R3(config)#int s0/3/1

    R3(config-if)#ip add 192.168.12.2 255.255.255.0

    R3(config-if)#clock rate 64000

    R3(config-if)#no sh

    R3(config)#int s0/2/1

    R3(config-if)#ip add 192.168.23.1 255.255.255.0

    R3(config-if)#clock rate 64000

    R3(config-if)#no sh

    R3(config)#int loopback 0

    R3(config-if)#ip add 2.2.2.2 255.255.255.0 备注:R3共配置三个端口,两个串口均配置 clock rate 64000,一个 lo 口不用配置 clock rate 64000,默认时 lo 端口是打开的,所以使用该端口不需要使用 no shut命令 R4(config)#int s0/2/0

    R4(config-if)#ip add 192.168.23.2 255.255.255.0

    R4(config-if)#clock rate 64000

    R4(config-if)#no sh

    R4(config)#int s0/0/0

    R4(config-if)#ip add 172.16.3.1 255.255.255.0

    R4(config-if)#clock rate 64000

    R4(config-if)#no sh

    备注:R4共配置两个端口, 两个串口均配置 clock rate 64000

    (3) 在 R1, R3, R4上启用路由协议 RIP V2, 并关闭自动汇总。 R1(config)#router rip

    R1(config-router)#version 2

    R1(config-router)#network 192.168.12.0 R1(config-router)#network 10.0.0.0

    R1(config-router)#network 172.16.0.0 R1(config-router)#no auto-summary

    备注:在配置 Rip V2时,使用 network 通告网络,通 告时使用主网络地址即可, 因为 Rip V2会自动传送子网信息, 比如 R1上直连网络为 172.16.1.0/24,该网络为 B 类,在通 告时只需要使用 network 172.16.0.0即可,下同

    R3(config)#router rip

    R3(config-router)#version 2

    R3(config-router)#network 2.0.0.0

    R3(config-router)#network 192.168.23.0 R3(config-router)#network 192.168.12.0 R3(config-router)#no auto-summary

    R4(config)#router rip

    R4(config-router)#version 2

    R4(config-router)#network 192.168.23.0 R4(config-router)#network 172.16.0.0 R4(config-router)#no auto-summary

    (4) 在 R3上 创 建 标 准 访 问 控 制 列 表 , 禁 止 网 络 172.16.1.0/24数据包通过,并应用在 S0/3/1的 in 方向。 提示:配置完 ACL 后需要将ACL应用到相应端口才会起效 R3(config)#access-list 99 deny 172.16.1.0 0.0.0.255

    R3(config)#access-list 99 permit any R3(config)#int s0/3/1

    R3(config-if)#ip access-group 99 in

    静态路由配置

    操作拓扑

    现有若干台路由器 (路由器名称分别为 R1、 R2、 R3)组 成的网络,请为各设备进行配置,以使得各设备间能进行通 信。具体操作如下:

    (1)根据要求,分别在每台路由器上配置基本命令:

    ①配置主机名分别为 R1, R2, R3;

    Router(config)#host R1

    Router(config)#host R2

    Router(config)#host R3

    ②关闭 DNS 查询;

    R1(config)#no ip domain-lookup

    R2(config)#no ip domain-lookup

    R3(config)#no ip domain-lookup

    ③配置时钟设为当前时间;

    提示:以下仅为命令使用示例,考试时请务必设置为考试当 天的时间! ! !

    R1#clock set 12:13:50 28 July 2009

    R2#clock set 12:13:50 28 July 2009

    R3#clock set 12:13:50 28 July 2009

    ④设置特权密码为 cisco ;

    R1(config)#enable password cisco

    R2(config)#enable password cisco

    R3(config)#enable password cisco

    ⑤正确启用密码加密。

    R1(config)#service password-encryption R2(config)#service password-encryption R3(config)#service password-encryption

    (2)根据要求,分别在各路由器端口上配置 IP 地址和时钟 频率,保证直连端口畅通;

    圆圈表示 R1、 R2、 R3上的环回接口 0,时钟频率设为 64000。

    R1(config)#int loopback 0

    R1(config-if)#ip add 1.1.1.1 255.255.255.0

    R1(config)#int s0/0/0

    R1(config-if)#ip add 192.168.12.1 255.255.255.0

    R1(config-if)#clock rate 64000

    R1(config-if)#no shut

    R2(config)#int loopback 0

    R2(config-if)#ip add 2.2.2.2 255.255.255.0

    R2(config)#int s0/0/0

    R2(config-if)#ip add 192.168.12.2 255.255.255.0

    R2(config-if)#clock rate 64000

    R2(config-if)#no shut

    R2(config)#int s0/0/1

    R2(config-if)#ip add 192.168.23.2 255.255.255.0

    R2(config-if)#clock rate 64000

    R2(config-if)#no shut

    备注:R2上 IP 地址请务必使用拓扑图上标示的 IP ! ! ! R3(config)#int loopback 0

    R3(config-if)#ip add 3.3.3.3 255.255.255.0

    R3(config)#int s0/3/0

    R3(config-if)#ip add 192.168.23.3 255.255.255.0

    R3(config-if)#clock rate 64000

    R3(config-if)#no shut

    (3) 在 R1上 创 建 静 态 路 由 指 向 2.2.2.0/24, 192.168.23.0/24, 3.3.3.0/24 ;

    在 R2上创建静态路由指向 1.1.1.0/24, 3.3.3.0/24 ; 在 R3上 创 建 静 态 路 由 指 向 1.1.1.0/24, 192.168.12.0/24, 2.2.2.0/24 。

    R1(config)#ip route 2.2.2.0 255.255.255.0 192.168.12.2

    R1(config)#ip route 3.3.3.0 255.255.255.0 192.168.12.2

    R1(config)#ip route 192.168.23.0 255.255.255.0 192.168.12.2

    R2(config)#ip route 1.1.1.0 255.255.255.0 192.168.12.1

    R2(config)#ip route 3.3.3.0 255.255.255.0 192.168.23.3

    R3(config)#ip route 1.1.1.0 255.255.255.0 192.168.23.2

    R3(config)#ip route 2.2.2.0 255.255.255.0 192.168.23.2

    R3(config)#ip route 192.168.12.0 255.255.255.0 192.168.23.2

    VLAN 的配置

    操作拓扑

    预览:
    现有若干台路由器和交换机 (路由器名称分别为 R1、 R4、 R6、 R7,交换机名称分别为 SW1、 SW2)组成的网络,主要 对交换机设备进行配置,以实现 VLAN 的功能。具体操作如 下:

    (1) 根据要求,分别在每台路由器和交换机上配置基本命 令:

    ①配置主机名分别为 R1, R4, R6, R7, SW1和 SW2; Switch(config)#host SW1

    Switch(config)#host SW2

    Router(config)#host R1

    Router(config)#host R6

    Router(config)#host R4

    Router(config)#host R7

    ②关闭 DNS 查询。

    SW1(config)#no ip domain-lookup

    SW2(config)#no ip domain-lookup

    R1(config)#no ip domain-lookup

    R6(config)#no ip domain-lookup

    R4(config)#no ip domain-lookup

    R7(config)#no ip domain-lookup

    (2)配置 SW1:创建 2个 VLAN :VLAN 2和 VLAN 3,分别命 名为 SALE 和 TECH , 将交换机 SW1的端口 F0/23分配给 VLAN 2, 端口 F0/24分配给 VLAN 3,将 F0/22配置成中继端口,同时 把三个端口的速度设为 100M ,并设为全双工模式。

    提示:交换机上创建 VLAN 可以在 vlan database 或全局模式 下配置,以下以 vlan database模式为例进行配置

    SW1#vlan database

    SW1(vlan)#vlan 2 name SALE

    SW1(vlan)#vlan 3 name TECH

    SW1(vlan)#exit

    SW1(config)#int f0/23

    SW1(config-if)#switchport mode access SW1(config-if)#switchport access vlan 2 SW1(config-if)#speed 100

    SW1(config-if)#duplex full

    SW1(config-if)#no shut

    SW1(config-if)#int f0/24

    SW1(config-if)#switchport mode access SW1(config-if)#switchport access vlan 3 SW1(config-if)#speed 100

    SW1(config-if)#duplex full

    SW1(config-if)#no shut

    SW1(config-if)#int f0/22

    SW1(config-if)#switchport mode trunk SW1(config-if)#speed 100

    SW1(config-if)#duplex full

    SW1(config-if)#no shut

    (3)配置 SW2:创建 2个 VLAN :VLAN 2和 VLAN 3分别命名 为 SALE 和 TECH ,将交换机 SW2的端口 F0/24分配给 VLAN 2, 端口 F0/23分配给 VLAN 3,将 F0/22配置成中继端口,同时 把三个端口的速度设为 100M ,并设为全双工模式。

    SW2#vlan database

    SW2(vlan)#vlan 2 name SALE

    SW2(vlan)#vlan 3 name TECH

    SW2(vlan)#exit

    SW2(config)#int f0/23

    SW2(config-if)#switchport mode access SW2(config-if)#switchport access vlan 3 SW2(config-if)#speed 100

    SW2(config-if)#duplex full

    SW2(config-if)#no shut

    SW2(config-if)#int f0/24

    SW2(config-if)#switchport mode access SW2(config-if)#switchport access vlan 2 SW2(config-if)#speed 100

    SW2(config-if)#duplex full

    SW2(config-if)#no shut

    SW2(config-if)#int f0/22

    SW2(config-if)#switchport mode trunk SW2(config-if)#speed 100

    SW2(config-if)#duplex full

    SW2(config-if)#no shut

    (4)在路由器 R1, R4, R6, R7上关闭路由功能,并把路由 器端口设为全双工模式;同时分配 IP 地址如下:

    R1的 G0/0:172.16.1.1 /24 R7的 F0/0:172.16.1.2 /24

    R6的 F0/0:172.16.2.1 /24 R4的 G0/0:172.16.2.2 /24

    预览:
    提示:在路由器上使用命令 no ip routing关闭路由功能, 则路由器可以模拟为主机

    R1#conf t

    R1(config)#no ip routing

    R1(config)#int g0/0

    R1(config-if)#ip add 172.16.1.1 255.255.255.0

    R1(config-if)#duplex full

    R1(config-if)#no shut

    R4#conf t

    R4(config)#no ip routing

    R4(config)#int g0/0

    R4(config-if)#ip add 172.16.2.2 255.255.255.0

    R4(config-if)#duplex full

    R4(config-if)#no shut

    R6#conf t

    R6(config)#no ip routing

    R6(config)#int f0/0

    R6(config-if)#ip add 172.16.2.1 255.255.255.0

    R6(config-if)#duplex full

    R6(config-if)#no shut

    R7#conf t

    R7(config)#no ip routing

    R7(config)#int f0/0

    R7(config-if)#ip add 172.16.1.2 255.255.255.0

    R7(config-if)#duplex full

    R7(config-if)#no shut

    展开全文
  • 交换机会终止这个数据因为它不在此MAC地址中。 • B、 交换机发送给所有端口除了数据来源端口。 • C、 交换机会转发这个数据给默认网关。 • D、 交换机发送一个ARP请求给所有端口出了数据来源端口。
  • 路由与交换技术实验

    2019-10-09 19:05:15
    书42页三层交换机配置欢迎使用Markdown编辑器博客教程记录 ↓新的改变功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接图片如何插入一段漂亮的代码片生成一个适合你的列表创建一个表格设定...

    欢迎使用Markdown编辑器

    1. 你要知道交换端口不允许设置IP
      如果你是三层交换机的话可以进入端口,输入 no switchport 然后再设置IP就可以了。
      要么你就创建一个vlan,将vlan设置IP,然后把端口属于vlan也是一样的
    2. 交换机端口是没办法配置IP的。只能在给VLAN配置管理IP。
      switchA(config)#int VLAN VLAN_ID
      switchA(config-if)#ip address 192.168.1.101 255.255.255.0
      这样才可以。

    博客教程记录 ↓

    新的改变

    我们对Markdown编辑器进行了一些功能拓展与语法支持,除了标准的Markdown编辑器功能,我们增加了如下几点新功能,帮助你用它写博客:

    1. 全新的界面设计 ,将会带来全新的写作体验;
    2. 在创作中心设置你喜爱的代码高亮样式,Markdown 将代码片显示选择的高亮样式 进行展示;
    3. 增加了 图片拖拽 功能,你可以将本地的图片直接拖拽到编辑区域直接展示;
    4. 全新的 KaTeX数学公式 语法;
    5. 增加了支持甘特图的mermaid语法1 功能;
    6. 增加了 多屏幕编辑 Markdown文章功能;
    7. 增加了 焦点写作模式、预览模式、简洁写作模式、左右区域同步滚轮设置 等功能,功能按钮位于编辑区域与预览区域中间;
    8. 增加了 检查列表 功能。

    功能快捷键

    撤销:Ctrl/Command + Z
    重做:Ctrl/Command + Y
    加粗:Ctrl/Command + B
    斜体:Ctrl/Command + I
    标题:Ctrl/Command + Shift + H
    无序列表:Ctrl/Command + Shift + U
    有序列表:Ctrl/Command + Shift + O
    检查列表:Ctrl/Command + Shift + C
    插入代码:Ctrl/Command + Shift + K
    插入链接:Ctrl/Command + Shift + L
    插入图片:Ctrl/Command + Shift + G
    查找:Ctrl/Command + F
    替换:Ctrl/Command + G

    合理的创建标题,有助于目录的生成

    直接输入1次#,并按下space后,将生成1级标题。
    输入2次#,并按下space后,将生成2级标题。
    以此类推,我们支持6级标题。有助于使用TOC语法后生成一个完美的目录。

    如何改变文本的样式

    强调文本 强调文本

    加粗文本 加粗文本

    标记文本

    删除文本

    引用文本

    H2O is是液体。

    210 运算结果是 1024.

    插入链接与图片

    链接: link.

    图片: Alt

    带尺寸的图片: Alt

    居中的图片: Alt

    居中并且带尺寸的图片: Alt

    当然,我们为了让用户更加便捷,我们增加了图片拖拽功能。

    如何插入一段漂亮的代码片

    博客设置页面,选择一款你喜欢的代码片高亮样式,下面展示同样高亮的 代码片.

    // An highlighted block
    var foo = 'bar';
    

    生成一个适合你的列表

    • 项目
      • 项目
        • 项目
    1. 项目1
    2. 项目2
    3. 项目3
    • 计划任务
    • 完成任务

    创建一个表格

    一个简单的表格是这么创建的:

    项目 Value
    电脑 $1600
    手机 $12
    导管 $1

    设定内容居中、居左、居右

    使用:---------:居中
    使用:----------居左
    使用----------:居右

    第一列 第二列 第三列
    第一列文本居中 第二列文本居右 第三列文本居左

    SmartyPants

    SmartyPants将ASCII标点字符转换为“智能”印刷标点HTML实体。例如:

    TYPE ASCII HTML
    Single backticks 'Isn't this fun?' ‘Isn’t this fun?’
    Quotes "Isn't this fun?" “Isn’t this fun?”
    Dashes -- is en-dash, --- is em-dash – is en-dash, — is em-dash

    创建一个自定义列表

    Markdown
    Text-to-HTML conversion tool
    Authors
    John
    Luke

    如何创建一个注脚

    一个具有注脚的文本。2

    注释也是必不可少的

    Markdown将文本转换为 HTML

    KaTeX数学公式

    您可以使用渲染LaTeX数学表达式 KaTeX:

    Gamma公式展示 Γ(n)=(n1)!nN\Gamma(n) = (n-1)!\quad\forall n\in\mathbb N 是通过欧拉积分

    Γ(z)=0tz1etdt. \Gamma(z) = \int_0^\infty t^{z-1}e^{-t}dt\,.

    你可以找到更多关于的信息 LaTeX 数学表达式here.

    新的甘特图功能,丰富你的文章

    Mon 06Mon 13Mon 20已完成 进行中 计划一 计划二 现有任务Adding GANTT diagram functionality to mermaid
    • 关于 甘特图 语法,参考 这儿,

    UML 图表

    可以使用UML图表进行渲染。 Mermaid. 例如下面产生的一个序列图:

    张三李四王五你好!李四, 最近怎么样?你最近怎么样,王五?我很好,谢谢!我很好,谢谢!李四想了很长时间,文字太长了不适合放在一行.打量着王五...很好... 王五, 你怎么样?张三李四王五

    这将产生一个流程图。:

    链接
    长方形
    圆角长方形
    菱形
    • 关于 Mermaid 语法,参考 这儿,

    FLowchart流程图

    我们依旧会支持flowchart的流程图:

    Created with Raphaël 2.2.0开始我的操作确认?结束yesno
    • 关于 Flowchart流程图 语法,参考 这儿.

    导出与导入

    导出

    如果你想尝试使用此编辑器, 你可以在此篇文章任意编辑。当你完成了一篇文章的写作, 在上方工具栏找到 文章导出 ,生成一个.md文件或者.html文件进行本地保存。

    导入

    如果你想加载一篇你写过的.md文件,在上方工具栏可以选择导入功能进行对应扩展名的文件导入,
    继续你的创作。


    1. mermaid语法说明 ↩︎

    2. 注脚的解释 ↩︎

    展开全文
  • 第三章 路由与交换设备... 2 一、交换机... 2 二、路由器... 3 三、课后题... 4 第四章 交换机与路由器的基础配置... 4 一、交换机命令模式概要... 4 二、访问与配置交换机... 5 三、路由器基本命令概要... 5...
  • 访问列表如下: access-list 4 deny 202.38.0.0 0.0.0.255 access-list 4 permit 202.38.160.1 0.0.0.255 应用于该路由器端口的配置如下: (config)# int s0 (config-if-Serial0)# ip access-group 4 in ...
  • 1 路由器中的路由表( ) (2.0分) • A、 需要包含到达所有主机的完整路径信息 • B、 需要包含到达所有主机的下一步路径信息 • C、 需要包含到达目的网络的完整路径信息 ...需要包含到达目的网络的下一步路径信息
  • 在交换机上作如下配置:Switch(config)# ip default-gateway 192.168.2.1 其作用是( )。 (2.0分) • A、 配置交换机的默认网关,为了可以实现对交换机进行跨网段的管理 • B、 配置交换机的默认网关,为了使连接...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,207
精华内容 482
关键字:

路由与交换技术