精华内容
下载资源
问答
  • 在路由/交换领域,VLAN的中继端口叫做trunktrunk技术用在交换机之间互连,使不同VLAN通过共享链路与其它交换机中的相同VLAN通信。 交换机之间互连的端口就称为trunk端口。trunk是基于OSI第二层数据链路层...

    在路由/交换领域,VLAN的中继端口叫做trunk
    trunk技术用在交换机之间互连,使不同VLAN通过共享链路与其它交换机中的相同VLAN通信。

    交换机之间互连的端口就称为trunk端口。trunk是基于OSI第二层数据链路层(DataLinkLayer)的技术。

    两台交换机上分别创建了多个VLAN(VLAN是基于Layer 2的),在两台交换机上相同的VLAN(比如VLAN10)要通信,需要将交换机A上属于VLAN10的一个端口与交换机B上属于VLAN10的一个端口互连;如果这两台交换机其它相同VLAN间需要通信,那么交换机之间需要更多的互连线,端口利用率就太低了。 交换机通过trunk功能,事情就简单了,只需要两台交换机之间有一条互连线,将互连线的两个端口设置为trunk模式,这样就可以使交换机上不同VLAN共享这条线路。

    trunk不能实现不同VLAN间通信,需要通过三层设备(路由/三层交换机)来实现。

    交换端口两种模式:access和trunk。

    连接终端(如PC)用access模式,设备级连接用trunk模式。把access端口加入到某个VLAN,那么这个端口就只将这个VLAN的数据转发给PC,PC发送的数据通过这个端口后会打上这个VLAN的ID,转发到相同VLAN。

    Access端口、Trunk端口和Hybrid端口
    Access类型:端口只能属于1个VLAN,一般用于连接计算机;
    Trunk类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接;
    Hybrid类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

    Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    三种类型的端口可以共存在一台设备上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

    Access端口只能属于1个VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;Hybrid端口和Trunk端口可以属于多个VLAN,所以需要设置端口的缺省VLAN ID。

    Acess端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)

    Acess端口发报文:

    将报文的VLAN信息剥离,直接发送出去

    trunk端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有判断该trunk端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃

    trunk端口发报文:

    比较端口的PVID和将要发送报文的VLAN信息,如果两者相等则剥离VLAN信息,再发送,如果不相等则直接发送

    hybrid端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则判断该hybrid端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用)

    hybrid端口发报文:

    1,判断该VLAN在本端口的属性(dispinterface即可看到该端口对哪些VLAN是untag,哪些VLAN是tag)

    2,如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送

    例如

    [Switch-Ethernet0/1]inte0/1

    [Switch-Ethernet0/1]portlink-type hybrid

    [Switch-Ethernet0/1]port hybrid pvid vlan 10

    [Switch-Ethernet0/1]port hybrid vlan 10 20 untagged

    [Switch-Ethernet0/1]inte0/2

    [Switch-Ethernet0/2]portlink-type hybrid

    [Switch-Ethernet0/2]porthy bridpvid vlan 20

    [Switch-Ethernet0/2]porthy brid vlan 10 20 untagged

    此时intere0/1和intere0/2下的所接的PC是可以互通的,但互通时数据所走的往返vlan是不同的。

    以下以intere0/1下的所接的pc1访问intere0/2下的所接的pc2为例进行说明

    pc1所发出的数据,由inter0/1所在的pvidvlan10封装vlan10的标记后送入交换机,交换机发现intere0/2允许vlan10的数据通过,于是数据被转发到intere0/2上,由于intere0/2上vlan10是untagged的,于是交换机此时去除数据包上vlan10的标记,以普通包的形式发给pc2,此时pc1->p2走的是vlan10

    再来分析pc2给pc1回包的过程,pc2所发出的数据,由inter0/2所在的pvidvlan20封装vlan20的标记后送入交换机,交换机发现intere0/1允许vlan20的数据通过,于是数据被转发到intere0/1上,由于intere0/1上vlan20是untagged的,于是交换机此时去除数据包上vlan20的标记,以普通包的形式发给pc1,此时pc2->pc1走的是vlan20
    ---------------------***

    展开全文
  • vlan标签详解 accesstrunk和hybrid的区别 我们知道,不同网段间需要通过路由转发才能通信; 那在同一网段不同vlan之间的PC,是不能互相通信的。其实这并不是绝对的。了解vlan的各种标签后,我们就能不通过路由也能...

    vlan标签详解 access、trunk和hybrid的区别

    我们知道,不同网段间需要通过路由转发才能通信;
    那在同一网段不同vlan之间的PC,是不能互相通信的。其实这并不是绝对的。了解vlan的各种标签后,我们就能不通过路由也能实现不同网段的数据互通。

    Vlan的三种接口

    access、trunk和hybrid
    我们所说的vlan,就是给数据打上了vlan的标签
    交换机的数据转发,我们可以理解为
    数据进入时,默认是要带标签进入的
    若数据没标签,我们可以选择给数据打上标签后放通和不打标签放通
    若有标签,在根据我们的配置来检查是否要放通数据

    数据离开时,默认是要给他脱标签的
    若无标签,那也省事,直接放通
    若有标签,查看设置,又分三种情况:1脱去标签放通 2带标签放通 3丢弃数据

    接口特性

    Access口特性,默认数据进入时打上此端口所属vlan的标签,数据出去时脱去所属vlan的标签

    Trunk口特性,可以设置允许通过哪些标签的数据通过,也就是可以阻止部分数据通过。
    华为交换机的命令port trunk allow-pass vlan 10 20 30 //10,20,30为vlan标签号,也可以用all表示所有vlan号

    hybrid口,就比较灵活,可以设置打的标签号,命令port hybrid pvid vlan 10
    也可以设置脱哪些标签,命令port hybrid untagged vlan 30 40
    还可以设置放哪些标签通过,命令port hybrid tagged vlan 20 50

    实验

    下面,来做个实验验证一下
    拓扑图
    在这里插入图片描述
    Lsw3配置
    vlan batch 10 20 30

    interface Ethernet0/0/1
    port link-type access
    port default vlan 10

    interface Ethernet0/0/2
    port link-type access
    port default vlan 20

    interface Ethernet0/0/3
    port link-type access
    port default vlan 30

    interface GigabitEthernet0/0/1
    port link-type trunk
    undo port trunk allow-pass vlan 1
    port trunk allow-pass vlan 10 20

    Lsw6配置
    vlan batch 10 20 30

    interface Ethernet0/0/1
    port hybrid pvid vlan 10
    port hybrid untagged vlan 10 20

    interface Ethernet0/0/2
    port hybrid pvid vlan 20
    port hybrid untagged vlan 10 20

    interface Ethernet0/0/3
    port link-type access
    port default vlan 30

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 10 20

    各pc机IP如图上所标
    测试结果
    PC6与PC7不通 我们常规理解的不同vlan不能通信
    PC6与PC8通,却PC6与PC9不通,是因为PC9回数据时,打上了vlan20的标签,在传到PC6的过程中,始终带着标签。而PC只接受无标签数据,故不通
    PC8与PC9通,是应为数据最后都被脱去了标签
    PC12与PC13不通,是因为他们的数据带的是vlan30的标签,在trunk口这,没有被允许通过,故不通

    展开全文
  • VLAN中accessTrunk和Hybrid三种端口区别: acesss:1、发送不带标签的报文 2、一般与PC\server相连时使用 3、只可以属于一个VLAN Trunk:1、发送带标签的报文 2、一般用于交换机级联端口传递多组VLAN信息使用...

    VLAN中access、Trunk和Hybrid三种端口区别:

    acesss:1、发送不带标签的报文

    2、一般与PC\server相连时使用

    3、只可以属于一个VLAN

    Trunk:1、发送带标签的报文

    2、一般用于交换机级联端口传递多组VLAN信息使用

    3、可以属于多个VLAN

    Hybrid:1、混合端口可以同时属于多个vlan

    2、混合端口是人为指定其发送的报文是否带标签

    3、对于一个特点VLAN,混合端口传送的所有报文必须是同一种类型的

    4、可以用于交换机之间的级联,也可以连接PC,server等终端设备

    转载于:https://www.cnblogs.com/linxinyi/p/10927706.html

    展开全文
  • 交换机VLAN 模式trunk和access 区别

    万次阅读 多人点赞 2019-08-23 11:43:58
    普通交换机的二层端口有三种常见的端口类型:accesstrunk、hybird, access端口一般用作PC或服务器主机接入,通过该端口的数据包都是不带VLAN tag的; trunk端口可以允许多个VLAN的数据包通过,一般连接其他...

     

    普通交换机的二层端口有三种常见的端口类型:access、trunk、hybird,

    access端口一般用作PC或服务器主机接入,通过该端口的数据包都是不带VLAN tag的;

    trunk端口可以允许多个VLAN的数据包通过,一般连接其他交换机;

    hybird端口比较灵活,可以根据用户需求,对通过该端口的数据包进行VLAN tag打标和去标动作,可以连主机也可以连其他交换机;在开始讲解之前,请记住交换机内部的所有数据报文是有VLAN tag的,

    下面我们通过分析交换机端口的进、出两个方向对VLAN tag的处理过程来详细说明这三种端口类型的区别;

    access端口:

        通过access端口的数据包都是不带VLAN tag的,且只属于一个VLAN;

        在access端口进方向,交换机接收到数据包后,先判断是否带VLAN tag,有则丢弃数据包,没有则打上该端口已配置的VLAN tag;

        在access端口出方向,交换机将打了与端口相同VLAN tag的数据包转发出去,并且去掉VLAN tag变成普通数据包。

     

    trunk端口:

        通过trunk端口的数据包都必须带上VLAN tag;

        在trunk端口进方向,交换机接收到数据包后,先判断是否带VLAN tag,没有则丢弃数据包,有则按照对应VLAN进行转发;

        在trunk端口出方向,交换机将带VLAN tag的数据包原封不动转发出去,没有带VLAN tag数据包不会从trunk端口转发出去。

        在trunk端口上有一种特殊情况,如果配置了native VLAN(也叫PVID),转发方式等同于access端口,当从端口进来的报文不带vlan tag时,就打上Native vlan tag; 当从端口出去的报文带Native vlan tag时,会剥离TAG。

    hybird端口:

        顾名思义,这是一种混合端口,是access和trunk两种端口的混合,既可以转发无vlan tag报文,也可以转发有vlan tag报文;在hybird端口上通常会配置tag vlan和untag vlan,对于tag vlan,其转发方式与trunk口相同,对于untag vlan,其转发方式与access口相同;

        在hybird端口进方向,交换机接收到数据包后,先判断是否带VLAN tag,没有则丢弃,如果没有vlan tag但是配置了PVID,则打上PVID的vlan tag;有则按照对应VLAN进行转发;进方向不看untag配置;

        在hybird端口出方向,对于配置了tag vlan的数据包,原封不动发送出去,对于端口配置了untag vlan的数据包,则去掉vlan tag再发送出去;如果是PVID的vlan,则去掉vlan tag再发送出去;

    展开全文
  • 展开全部区别如下:1、端口用途不同:truck端口为与其它交换机62616964757a686964616fe4b893e5b19e31333365666237端口相连的VLAN汇聚口。access端口为交换机与VLAN域中主机相连的端口。2、trunk一般是打tag标记的,...
  • 以太网端口有三种链路类型:Access、Hybrid和Trunk: 这三种链路类型的连接终端有所区别Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口; Trunk类型的端口可以允许多个VLAN通过,可以接收和发送...
  • 首先我们看三种端口对接收不带Tag带tag的报文...access性质的端口只能属于一个vlan,且该端口不打tag,trunk可以属于多个vlan,可以接收发送多个vlan的报文,一般用于交换机之间的连接;hybrid也可以属于多个v...
  • 如果CPU在DMA初始化设置启动硬盘操作等方面用了1000个时钟周期,并且在DMA传送完成后的中断处理需要500个时钟,则在硬盘100%处于工作状态的情况下, CPU用于硬盘I/O操作的时间百分比大约是多少?案例分析二:请求...
  • 通过实例理解access trunk hybrid 端口特性和区别 设备型号 最后更新时间 华为S5720 2020.3.1 原创文章,转载请注明出处 文章涉及的交换机配置均为华为S5720交换机上配置 开始 注意方向,在理解这3种端口...
  • 一、access和trunk口的区别1、access口。收到报文:没有vlan标签的打上pvid标签,有vlan标签的,丢弃数据包。发送报文:去掉vlan标签2、truank口。收到报文:没有vlan标签的,打上pvid标签。有vlan标签的,允许...
  • trunkaccess区别

    2021-01-12 00:40:42
    先说观点:我认为trunkaccess并没有本质的区别access收到带vlan的帧自己所属vlan比较,相同转发,不相同丢弃。(1) trunk 收到带vlan的帧自己所属vlan比较,相同转发,不相同丢弃。(2) access收到不带...
  • 交换机以太网端口有3种链路类型:accesstrunk、hybird。Access类型端口:只能属于1个VLAN,一般用于连接计算机端口;Trunk类型端口:可以允许多个VLAN通过,可以接收发送多个VLAN报文,一般用于交换机与交换机相关...
  • 以太网端口有三种链路类型:Access、Hybrid和TrunkAccess类型的端口只能属于1个VLAN,一般用于连接计算机的端口; Trunk类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间...
  • Access、Hybrid和Trunk

    2013-07-11 14:02:46
    关于Access、Hybrid和Trunk三者区别
  • 提示:结合access和trunk端口在接收数据、发送数据时对标签的处理。 1、 终端1向终端2发送数据时,在每一段链路及端口上,数据帧携带标签情况。 终端1发出一个没有VLAN ID 的数据帧,到达交换机1的e0/0/1Access端口...
  • 原标题:交换机的Access、Hybrid和Trunk三种端口模式交换机的端口类型有很多种,很多小伙伴都不明白这些端口由什么区别,所以,我们今天就来分享关于交换机端口方面的知识。 以太网的端口有3种链路类型:access、...
  • 转载自:https://blog.51cto.com/shyln/2087240一,Access、Hybrid和Trunk三种模式的理解Tag,untag以及交换机的各种端口模式是网络工程技术人员调试交换机时接触最多的概念了,然而笔者发现在实际工作中技术人员...
  • access trunk hybrid的区别

    千次阅读 2010-12-22 23:24:00
    Access端口 (1)收到一个二层帧 (2)判断是否有VLAN标签:没有则转到第3步,有则转到第4步 (3)打上端口的PVID,并进行交换转发 (4)若VLAN标签PVID一致,转发VLAN帧;否则直接丢弃...
  • Trunk 链路同一时刻可以支持多个 VLAN 的数据转发, 数据携带 VLAN 标签(native vlan 除外); Access 链路同一时刻只能传输一个 VLAN 的数据, 发送接收的数据,都没有标签;
  • Access端口只属于1个VLAN,一般用于连接计算机端口。 Trunk类型的端口可用于多VLAN通信。 Hybrid类型的端口允许多VLAN通过,可以接收发送多VLAN报文,可用于交换机与交换机的连接,也可用于交换机计...
  • 大家知道,交换机会把广播报文(目的mac地址全1的报文)未知单播报文从所有端口转发出去(除了报文的接收端口),这就是广播。(对未知多播报文如何处理呢,我不知道,应该也会广播出去,这是一个遗留问题,哪位...
  • 以太网端口有三种链路类型:access、hybrid和trunkAccess类型的端口只能属于一个vlan,一般用于连接计算机的端口;trunk类型的端口可以属于多个vlan,可以接收和发送多个vlan的报文,一般用于交换机之间连接的端口...
  • [导读]很多朋友一直在问到交换机的几种端口具体是什么作用,这个确实在我们平时中很多朋友...以太网端口有 3种链路类型:accesstrunk、hybirdAccess类型端口:只能属于1个VLAN,一般用于连接计算机端口;Trunk类型...
  • access: 主要用来接入终端设备,如PC...以太网端口的链路类型 AccessTrunk和Hybrid Access类型:端口只能属于1个VLAN,一般用于连接计算机; Trunk类型:端口可以属于多个VLAN,可以接收发送多个VLAN的报文,一...

空空如也

空空如也

1 2 3 4 5
收藏数 95
精华内容 38
关键字:

access和trunk区别