精华内容
下载资源
问答
  • VLan划分命令、详细的VLAN划分方法
  • WLAN中的VLAN划分方法

    千次阅读 2014-08-29 18:52:52
    WLAN中的VLAN划分方法 VLAN的好处在于有效地限制了L2的广播域。对于有线网络,常见的VLAN划分方法包括基于交换机端口的划分、基于MAC地址的划分、基于L3的IP划分以及基于802.1x的安全凭证划分等,这方面的资料...

    WLAN中的VLAN划分方法

    VLAN的好处在于有效地限制了L2的广播域。对于有线网络,常见的VLAN划分方法包括基于交换机端口的划分、基于MAC地址的划分、基于L3的IP划分以及基于802.1x的安全凭证划分等,这方面的资料比较多,支持的产品也很多,应用很成熟。

    但对于WLAN,该如何划分VLAN呢?

    WLAN的网络结构基本单位是BSS。BSS有两种形态:独立基础结构(IBSS,也叫自组网Adhoc)和基础结构Infrastructure。自组网就是多个站点自发组成一个可以互通的WLAN,而基础结构模式则以AP为中心,其它站点都先与AP关联,然后才能与BSS中的其它站点进行通信。以下所提到的BSS仅指基础结构。

    WLAN中的VLAN划分必须要有AP的支持。每一个VLAN由一个VLAN ID来标示,因此以什么作为VLAN ID的依据,决定了VLAN在哪个层次划分。根据VLAN与BSS的关系,WLAN中的VLAN划分有几种情况。

    1. 以MAC层依据作为VLAN ID

    一个AP至少可以组建一个BSS,而且不少实际的产品还支持同时虚拟出多个BSS,每个BSS拥有不同的BSSID。对于每个BSS,一些AP产品还可以同时支持多个SSID,不同的SSID共享大部分的BSS配置和Radio接口配置,可以有少部分配置不一样(比如密钥)。

    1.1 以SSID或BSSID为划分依据

    一种容易实现的VLAN划分方法就是以SSID为划分依据,每个SSID对应一个VLAN ID。这种划分依据完全来自于802.11 MAC层的SSID,因此可以完全在AP内部实现。根据AP对多SSID支持情况的不同,具体情况又有所不同。

    1.1.1 AP支持多个BSS,每个BSS又支持多个SSID

    这种情况下按照SSID来划分VLAN,所有连接到该SSID的站点都属于同一个VLAN。每个SSID提供给STATION的接入端口均为VLAN的Access端口,是不带tag的端口。

    由于一个BSS内有多个SSID,因此一个BSS内就会有多个VLAN。由于这些SSID均属于同一BSS,因此如果位于两个VLAN内的STATION要通信,只需要经过AP内部的转发桥接即可。

    1.1.2 AP仅支持一个BSS,每个BSS支持多SSID

    这种情况下按照SSID来划分VLAN,跟上面的情况类似。

    1.1.3 AP支持多个BSS,每个BSS仅支持一个SSID

    这种情况下SSID与BSSID一一对应,因此根据SSID来划分VLAN与根据BSSID来划分是一样的。这种情况下属于同一个BSS的站点属于同一个VLAN,位于两个VLAN内的STATION要通信,只需要经过AP内部的转发桥接即可也仅仅需要AP内部的转发。

    1.1.4 AP仅支持BSS,每个BSS仅支持一个SSID

    这种情况下如果按照SSID或BSSID来划分VLAN,则整个BSS均属于同一VLAN。由于不存在多个VLAN,因此不存在VLAN互通的问题。

    可见,如果在同一AP内部划分不同的VLAN,那么这些VLAN间的互通仅需要AP内部的MAC桥接即可实现,而不需要将数据交到更高层进行转发或桥接。

    1.2 以MAC地址为划分依据

    这种情况根据STATION的MAC地址在BSS内划分VLAN。AP根据从STATION发来的帧中的源地址决定该STATION所属的VLAN,从而可以保证同一VLAN的互通和不同VLAN的桥接。

    上面的两种划分均是以802.11 MAC层的信息作为VLAN ID的划分依据,因此同一VLAN内部的转发和不同VLAN之间的桥接均可在AP内部实现,而不需要分发。

    在上面的两种情况下,在AP内部只需要维护两张表即可:一张表是VLAN ID与VLAN依据(SSID/BSSID或MAC地址)之间的对应表,另一张表示VLAN ID与VLAN接口之间的对应表。Access端口上的数据收发情况如下:

    进入Access端口的数据:可以不带tag。如果需要分发到AP外(目的地址不是BSSID且不是任何BSS中的其它站点),则加上tag通过分发接口分发;如果不需要分发到AP外,则有几种情况:

    DA为BSSID,则由AP接收并处理;
    DA为同一VLAN中的其它STATION,则MAC层转发;
    DA为不同VLAN,但同一AP中的其它STATION,则执行VLAN之间的桥接协议。
    从Access端口发出的数据:不带tag,直接发到STATION。

    这种划分的缺点仅适合于较小的网络,灵活性较差。比如,无法实现跨AP的VLAN,也就是连接到不同AP的两个STATION无法划分到同一个VLAN。

    2. 动态VLAN划分方式

    动态划分方式并不由AP来决定VLAN ID,而是由其它更高级的设备来决定。一种方法是由RADIUS服务器来划分。当一个STATION与AP关联时,AP中的RADIUS客户端与RADIUS服务器进行通信,从而得到该STATION所属的VLAN ID。RADIUS决定STATION服务器所属VLAN的依据可以是用户名、IP地址等,因此具有很大的灵活性。当用户的位置改变后,他所属的VLAN仍然不变。

    采用动态VLAN方式后,同一个AP的同一个SSID中的两个STATION可能属于不同的VLAN,而连接到两个不同AP中的STATION却可能属于同一VLAN。因此这种情况下,要实现同一VLAN中不同STATION之间的互通,需要更高层的转发和桥接,可能需要经过位于WDS接口或以太网DS接口等接口之上的VLAN trunk、hybrid端口。

    本文来自CSDN博客,转载请标明出处:http://blog.csdn.net/rangzh/archive/2008/07/02/2606778.aspx

    展开全文
  • VLAN划分方法及优缺点

    2012-07-30 18:13:23
    VLAN划分方法及优缺点链接:http://url7.me/sudR ...
    VLAN划分方法及优缺点
    链接:http://url7.me/sudR

    来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/27214137/viewspace-738799/,如需转载,请注明出处,否则将追究法律责任。

    转载于:http://blog.itpub.net/27214137/viewspace-738799/

    展开全文
  • 很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多交换机,因此,我们今天以华为交换机为例,来讲解vlan的3种划分方法,360度来了解vlan。如果你以对vlan了解不多,那么这篇文章可以带你深入学习...

    前面我们发布了华为、锐捷、H3C交换机的配置,有很多的朋友提到了vlan的划分,今天我们来看下具体应用。

    很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多交换机,因此,我们今天以华为交换机为例,来讲解vlan的3种划分方法,360度来了解vlan。

    如果你以对vlan了解不多,那么这篇文章可以带你深入学习vlan,都有详细注释。

    e27eff62531c00bca22e3789ca7c08d4.png

    我们前面曾说到,关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan基于mac地址划分vlan基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。

    一、基于端口的vlan划分方法

    这里面为了方便大家理解,直接用实例讲解更清楚。

    1、组网需求如图1所示,某企业的交换机连接有很多用户,且相同业务用户通过不同的设备接入企业网络。为了通信的安全性,也为了避免广播报文泛滥,企业希望业务相同用户之间可以互相访问,业务不同用户不能直接访问。


    可以在交换机上配置基于端口划分VLAN,把业务相同的用户连接的端口划分到同一VLAN。

    也就是不同VLAN的用户不能直接进行二层通信同一VLAN内的用户可以直接互相通信。

    4bc22f90bd64b692d6584362bbef03b3.png

    2、配置步骤

    步骤1 在SwitchA创建VLAN2和VLAN3,并将连接用户的端口分别加入VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [Quidway] system-view          //进入配置视图
    [Quidway] sysname SwitchA   //给交换机命名
    [SwitchA] vlan batch 2 3          //同时创建vlan2与vlan3
    [SwitchA] interface ethernet 0/0/1   //进入端口0/0/1
    [SwitchA-Ethernet0/0/1] port link-type access   //设置端口模式为access
    [SwitchA-Ethernet0/0/1] port default vlan 2      //将端口加入vlan2中
    [SwitchA-Ethernet0/0/1] quit   //退出
    [SwitchA] interface ethernet 0/0/2   //进入端口0/0/2
    [SwitchA-Ethernet0/0/2] port link-type access  //端口模式为access
    [SwitchA-Ethernet0/0/2] port default vlan 3    //将端口加入vlan3中
    [SwitchA-Ethernet0/0/2] quit   //退出

    步骤2 配置SwitchA上与SwitchB连接的端口类型及通过的VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interface ethernet 0/0/3 //进入端口0/0/3
    [SwitchA-Ethernet0/0/3] port link-type trunk   
    //设置端口模式为trunk
    [SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3  
     //trunk口允许通过vlan2与vlan3的数据包

    步骤3 验证配置结果将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。

    User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。

    二、基于MAC地址vlan划分方法

    1、组网需求
    某个公司的网络中,网络管理者将同一部门的员工划分到同一VLAN。为了提高部门内的信息安全,要求只有本部门员工的PC才可以访问公司网络。

    如图2所示,PC1、PC2、PC3为本部门员工的PC,要求这几台PC可以通过SwitchA、Switch访问公司网络,如换成其他PC则不能访问。可以配置基于MAC地址划分VLAN,将本部门员工PC的MAC地址与VLAN绑定,从而实现该需求。

    8fc072304fba82d151b7b627e830fc2b.png

    2、操作步骤

    这里面弱电君对上面重复的注释就不再解释了,和上面一样,大家也可以验证下,经过上面的理解,是否能认识下面的配置代码。

    步骤1 配置Switch

    # 创建VLAN[Quidway] system-view  
    [Quidway] vlan batch 10 100

    # 配置接口的PVID和加入VLAN[Quidway] interface ethernet 0/0/1  
    [Quidway-Ethernet0/0/1] port hybrid pvid vlan 100 
    //将接口以加入到vlan100

    [Quidway-Ethernet0/0/1] port hybrid untagged vlan 10   //untagged是指当数据离开端口时脱掉标签,指定端口允许VLAN 10的数据帧通过,且发送时不带VLAN标签  

    [Quidway-Ethernet0/0/1] quit  #退出

    [Quidway] interface ethernet 0/0/2    #进入端口0/0/2
    [Quidway-Ethernet0/0/2] port hybrid tagged vlan 10 
    //tagged是指当数据离开端口时带着标签,指定允许VLAN 10的数据帧通过,且发送时必须带有VLAN标签  

    [Quidway-Ethernet0/0/2] quit

    # PC的MAC地址与VLAN10关联[Quidway] vlan 10
    [Quidway-Vlan10] mac-vlan mac-address 22-22-22  

    //关联pc1的mac地址
    [Quidway-Vlan10] mac-vlan mac-address 33-33-33 

     //关联pc2的mac地址

    [Quidway-Vlan10] mac-vlan mac-address 44-44-44   

    //关联pc3的mac地址

    [Quidway-Vlan10] quit

    # 使能接口的基于MAC地址划分VLAN功能[Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] mac-vlan enable 

     //起动端口的mac-vlan功能

    [Quidway-Ethernet0/0/1] quit

    三、基于IP子网的vlan划分

    1、组网需求

    某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的IP地址网段各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

    如图3所示,Switch接收到用户报文有数据、IPTV、语音等多种业务,用户设备的IP地址网段各不相同。现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLANID分流到不同的远端服务器上以实现业务互通。

    这类在实际应用中是比较多的。

    37bd3be19a578fa62ca75383a015666f.png

    2、配置思路

    采用如下的思路配置基于IP子网划分VLAN:

    a、创建VLAN,确定每种业务所属的VLAN。
    b、关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。
    c、配置端口加入VLAN,实现基于IP子网的VLAN通过当前端口。
    d、配置VLAN划分方式的优先级,确保优先选择基于IP子网划分VLAN。
    e、使能基于IP子网划分VLAN。

    3、操作步骤

    步骤1 创建VLAN# 在Switch上创建VLAN100、VLAN200和VLAN300。
    [Quidway] system-view
    [Quidway] vlan batch 100 200 300

    步骤2 配置接口

    # 在Switch上配置接口Eth0/0/1为Hybrid类型,并加入VLAN100、VLAN200和VLAN300。

    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] port link-type hybrid    //设置端口为hybrid模式

    [Quidway-Ethernet0/0/1] port hybrid untagged vlan100 200 300   //指定端口允许VLAN 100、vlan200、vlan300的数据帧通过,且发送时不带VLAN标签  

    [Quidway-Ethernet0/0/1] quit

    # 在Switch上配置接口Eth0/0/2加入VLAN100。

    [Quidway] interface ethernet 0/0/2
    [Quidway-Ethernet0/0/2] port link-type trunk
    [Quidway-Ethernet0/0/2] port trunk allow-pass vlan 100    //接口0/0/2加入vlan100

    [Quidway-Ethernet0/0/2] quit

    # 在Switch上配置接口Eth0/0/3加入VLAN200。[Quidway] interface ethernet 0/0/3
    [Quidway-Ethernet0/0/3] port link-type trunk
    [Quidway-Ethernet0/0/3] port trunk allow-pass vlan 200  //接口0/0/3加入vlan200

    [Quidway-Ethernet0/0/3] quit

    # 在Switch上配置接口Eth0/0/4加入VLAN300。[Quidway] interface ethernet 0/0/4
    [Quidway-Ethernet0/0/4] port link-type trunk
    [Quidway-Ethernet0/0/4] port trunk allow-pass vlan 300  //接口0/0/4加入vlan300

    [Quidway-Ethernet0/0/4] quit

    # 在Switch上配置接口Eth0/0/1使能基于IP子网划分VLAN功能。[Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] ip-subnet-vlan enable
    [Quidway-Ethernet0/0/1] quit

    步骤3 配置基于IP子网划分VLAN

    # 在Switch上配置VLAN100与IP地址192.168.1.2/24关联,优先级为2。

    [Quidway] vlan 100
    [Quidway-vlan100] ip-subnet-vlan 100 ip 192.168.1.2 24 priority 2
    [Quidway-vlan100] quit


    # 在Switch上配置VLAN200与IP地址192.168.2.2/24关联,优先级为3。
    [Quidway] vlan 200
    [Quidw
    ay-vlan200] ip-subnet-vlan 200 ip 192.168.2.2 24 priority 3
    [Quidway-vlan200] quit


    # 在Switch上配置VLAN300与IP地址192.168.3.2/24关联,优先级为4。
    [Quidway] vlan 300[Quidway-vlan300] ip-subnet-vlan 300 ip 192.168.3.2 24 priority 4[Quidway-vlan300] quit

    步骤4 验证配置结果

    在Switch上执行以下命令,显示信息如下:
    [Quidway] display ip-subnet-vlan vlan all
    ----------------------------------------------------------------
    Vlan Index IpAddress SubnetMask Priority
    ----------------------------------------------------------------
    100 1 192.168.1.2 255.255.255.0 2
    200 1 192.168.2.2 255.255.255.0 3
    300 1 192.168.3.2 255.255.255.0 4
    ----------------------------------------------------------------
    ip-subnet-vlan count: 3 total count: 3

    即为组网配置成功。

    d137e60ca49c2a2bb3d2d57d746861c0.png

    最新弱电资料更新—弱电智能化施工报价与施工指导2020年5月8日

    展开全文
  • 华为交换机常用的三种vlan划分方法前面我们发布了华为交换机的基本配置,这篇内容是华为交换机的基本配置,今天我们来看下具体应用,以华为交换机为例,也是用的比较多,来看下它的具体配置,这个在实际项目中经常会...

    原标题:什么是vlan?华为交换机常用的三种vlan划分方法

    前面我们发布了华为交换机的基本配置,这篇内容是华为交换机的基本配置,今天我们来看下具体应用,以华为交换机为例,也是用的比较多,来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你以对vlan了解不多,那么这篇文章可以带你深入学习vlan,都有详细注释。

    端口类型

    在学习划分vlan前,必须要了解华为交换机的端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面的vlan划分会用到。

    1、Access类型端口

    执行命令port default vlan vlan-id,将端口加入到指定的VLAN中。

    Access类型端口只能属于1个VLAN,一般用于连接计算机端口;

    2、Trunk类型端口

    Trunk类型端口可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    3、Hybrid类型端口

    – 选择执行其中一个步骤配置Hybrid端口加入VLAN的方式:Hybrid类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文。

    我们前面曾说到,关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。

    一、基于端口的vlan划分方法

    这里面为了方便大家理解,直接用实例讲解更清楚。

    1、组网需求

    如图1所示,某企业的交换机连接有很多用户,且相同业务用户通过不同的设备接入企业网络。为了通信的安全性,也为了避免广播报文泛滥,企业希望业务相同用户之间可以互相访问,业务不同用户不能直接访问。

    可以在交换机上配置基于端口划分VLAN,把业务相同的用户连接的端口划分到同一VLAN。

    也就是不同VLAN的用户不能直接进行二层通信,同一VLAN内的用户可以直接互相通信。

    2、配置步骤

    步骤1 在SwitchA创建VLAN2和VLAN3,并将连接用户的端口分别加入VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [Quidway] system-view //进入配置视图

    [Quidway] sysname SwitchA //给交换机命名

    [SwitchA] vlan batch 2 3 //同时创建vlan2与vlan3

    [SwitchA] interface ethernet 0/0/1 //进入端口0/0/1

    [SwitchA-Ethernet0/0/1] port link-type access //设置端口模式为access

    [SwitchA-Ethernet0/0/1] port default vlan 2 //将端口加入vlan2中

    [SwitchA-Ethernet0/0/1] quit //退出

    [SwitchA] interface ethernet 0/0/2 //进入端口0/0/2

    [SwitchA-Ethernet0/0/2] port link-type access //端口模式为access

    [SwitchA-Ethernet0/0/2] port default vlan 3 //将端口加入vlan3中

    [SwitchA-Ethernet0/0/2] quit //退出

    步骤2 配置SwitchA上与SwitchB连接的端口类型及通过的VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interface ethernet 0/0/3 //进入端口0/0/3

    [SwitchA-Ethernet0/0/3] port link-type trunk //设置端口模式为trunk

    [SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3 //trunk口允许通过vlan2与vlan3的数据包

    步骤3 验证配置结果将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。

    User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。

    二、基于MAC地址vlan划分方法

    1、组网需求

    某个公司的网络中,网络管理者将同一部门的员工划分到同一VLAN。为了提高部门内的信息安全,要求只有本部门员工的PC才可以访问公司网络。

    如图2所示,PC1、PC2、PC3为本部门员工的PC,要求这几台PC可以通过SwitchA、Switch访问公司网络,如换成其他PC则不能访问。可以配置基于MAC地址划分VLAN,将本部门员工PC的MAC地址与VLAN绑定,从而实现该需求。

    2、操作步骤

    这里面弱电君对上面重复的注释就不再解释了,和上面一样,大家也可以验证下,经过上面的理解,是否能认识下面的配置代码。

    步骤1 配置Switch

    # 创建VLAN

    [Quidway] system-view

    [Quidway] vlan batch 10 100

    # 配置接口的PVID和加入VLAN

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] port hybrid pvid vlan 100 //将接口以加入到vlan100

    [Quidway-Ethernet0/0/1] port hybrid untagged vlan 10 //untagged是指当数据离开端口时脱掉标签,指定端口允许VLAN 10的数据帧通过,且发送时不带VLAN标签

    [Quidway-Ethernet0/0/1] quit #退出

    [Quidway] interface ethernet 0/0/2 #进入端口0/0/2

    [Quidway-Ethernet0/0/2] port hybrid tagged vlan 10 //tagged是指当数据离开端口时带着标签,指定允许VLAN 10的数据帧通过,且发送时必须带有VLAN标签

    [Quidway-Ethernet0/0/2] quit

    # PC的MAC地址与VLAN10关联

    [Quidway] vlan 10

    [Quidway-Vlan10] mac-vlan mac-address 22-22-22

    //关联pc1的mac地址

    [Quidway-Vlan10] mac-vlan mac-address 33-33-33

    //关联pc2的mac地址

    [Quidway-Vlan10] mac-vlan mac-address 44-44-44

    //关联pc3的mac地址

    [Quidway-Vlan10] quit

    # 使能接口的基于MAC地址划分VLAN功能

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] mac-vlan enable

    //起动端口的mac-vlan功能

    [Quidway-Ethernet0/0/1] quit

    三、基于IP子网的vlan划分

    1、组网需求

    某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的IP地址网段各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

    如图3所示,Switch接收到用户报文有数据、IPTV、语音等多种业务,用户设备的IP地址网段各不相同。现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLANID分流到不同的远端服务器上以实现业务互通。

    这类在实际应用中是比较多的。

    2、配置思路

    采用如下的思路配置基于IP子网划分VLAN:

    a、创建VLAN,确定每种业务所属的VLAN。

    b、关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。

    c、配置端口加入VLAN,实现基于IP子网的VLAN通过当前端口。

    d、配置VLAN划分方式的优先级,确保优先选择基于IP子网划分VLAN。

    e、使能基于IP子网划分VLAN。

    3、操作步骤

    步骤1 创建VLAN

    # 在Switch上创建VLAN100、VLAN200和VLAN300。

    [Quidway] system-view

    [Quidway] vlan batch 100 200 300

    步骤2 配置接口

    # 在Switch上配置接口Eth0/0/1为Hybrid类型,并加入VLAN100、VLAN200和VLAN300。

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] port link-type hybrid //设置端口为hybrid模式

    [Quidway-Ethernet0/0/1] port hybrid untagged vlan100 200 300 //指定端口允许VLAN 100、vlan200、vlan300的数据帧通过,且发送时不带VLAN标签

    [Quidway-Ethernet0/0/1] quit

    # 在Switch上配置接口Eth0/0/2加入VLAN100。

    [Quidway] interface ethernet 0/0/2

    [Quidway-Ethernet0/0/2] port link-type trunk

    [Quidway-Ethernet0/0/2] port trunk allow-pass vlan 100 //接口0/0/2加入vlan100

    [Quidway-Ethernet0/0/2] quit

    # 在Switch上配置接口Eth0/0/3加入VLAN200。

    [Quidway] interface ethernet 0/0/3

    [Quidway-Ethernet0/0/3] port link-type trunk

    [Quidway-Ethernet0/0/3] port trunk allow-pass vlan 200 //接口0/0/3加入vlan200

    [Quidway-Ethernet0/0/3] quit

    # 在Switch上配置接口Eth0/0/4加入VLAN300。

    [Quidway] interface ethernet 0/0/4

    [Quidway-Ethernet0/0/4] port link-type trunk

    [Quidway-Ethernet0/0/4] port trunk allow-pass vlan 300 //接口0/0/4加入vlan300

    [Quidway-Ethernet0/0/4] quit

    # 在Switch上配置接口Eth0/0/1使能基于IP子网划分VLAN功能。

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] ip-subnet-vlan enable

    [Quidway-Ethernet0/0/1] quit

    步骤3 配置基于IP子网划分VLAN

    # 在Switch上配置VLAN100与IP地址192.168.1.2/24关联,优先级为2。

    [Quidway] vlan 100

    [Quidway-vlan100] ip-subnet-vlan 100 ip 192.168.1.2 24 priority 2

    [Quidway-vlan100] quit

    # 在Switch上配置VLAN200与IP地址192.168.2.2/24关联,优先级为3。

    [Quidway] vlan 200

    [Quidway-vlan200] ip-subnet-vlan 200 ip 192.168.2.2 24 priority 3

    [Quidway-vlan200] quit

    # 在Switch上配置VLAN300与IP地址192.168.3.2/24关联,优先级为4。

    [Quidway] vlan 300

    [Quidway-vlan300] ip-subnet-vlan 300 ip 192.168.3.2 24 priority 4

    [Quidway-vlan300] quit

    步骤4 验证配置结果

    在Switch上执行以下命令,显示信息如下:

    [Quidway] display ip-subnet-vlan vlan all

    ----------------------------------------------------------------

    Vlan Index IpAddress SubnetMask Priority

    ----------------------------------------------------------------

    100 1 192.168.1.2 255.255.255.0 2

    200 1 192.168.2.2 255.255.255.0 3

    300 1 192.168.3.2 255.255.255.0 4

    ----------------------------------------------------------------

    ip-subnet-vlan count: 3 total count: 3

    即为组网配置成功。返回搜狐,查看更多

    责任编辑:

    展开全文
  • 很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多交换机,因此,我们今天以华为交换机为例,来讲解vlan的3种划分方法,360度来了解vlan。如果你以对vlan了解不多,那么这篇文章可以带你深入学习...
  • 简单vlan划分方法视频

    2008-10-07 22:04:19
    很简单的vlan划分 自己录的视频 希望对刚刚接触网络的人有所帮助。。。
  • 企业中常用的vlan划分方法

    千次阅读 2017-12-06 11:14:19
    静态vlan 就是指将端口划分给某个vlan 而动态vlan是根据其他的信息自动将客户端划分vlan中,一般用的最多的就是静态vlan,静态vlan的工作量教大,但配置简单。 在不同的设备中的配置命令是不一样的, 在CISCO中的...
  • 关于vlan划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。一...
  • 很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多交换机,因此,我们今天以华为交换机为例,来讲解vlan的3种划分方法,360度来了解vlan。如果你以对vlan了解不多,那么这篇文章可以带你深入学习...
  • 我们今天以华为交换机为例,来讲解vlan的3种划分方法,360度来了解vlan。如果你以对vlan了解不多,那么这篇文章可以带你深入学习vlan,都有详细注释。端口类型在学习划分vlan前,必须要了解华为交换机的端口类型,...
  • 很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多交换机,因此,我们今天以华为交换机为例,来讲解vlan的3种划分方法,360度来了解vlan。如果你以对vlan了解不多,那么这篇文章可以带你深入学习...
  • 关于vlan划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。一...
  • 一、端口为类型在学习划分vlan前,必须要了解华为交换机的端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面的vlan划分会用到。1、Access类型端口执行命令port default vlan vlan-...
  • 端口类型在学习划分vlan前,必须要了解华为交换机的端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面的vlan划分会用到。1、Access类型端口执行命令port default vlan vlan-id,将...
  • 前面我们发布了华为交换机的基本配置,这篇内容是华为交换机的基本配置,...端口类型在学习划分vlan前,必须要了解华为交换机的端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面...
  • 很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多交换机,因此,我们今天以华为交换机为例,来讲解vlan的3种划分方法,360度来了解vlan。如果你以对vlan了解不多,那么这篇文章可以带你深入学习...
  • 1端口类型在学习划分vlan前,必须要了解华为交换机的端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面的vlan划分会用到。1、Access类型端口执行命令port default vlan vlan-id,...
  • 联系小E微信:SPOTO123456作为华为设备的网络工程师,华为交换机也是用的比较多,接下来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你对vlan了解不多,那么这篇文章可以带你深入学习vlan,都...
  • vlan划分

    2019-09-18 06:16:38
    基于端口划分的VLAN这是最常应用的一种VLAN划分方法,应用也最为广泛、最有效,目前绝大多数VLAN协议的交换机都提供这种VLAN配置方法。这种划分VLAN的方法是根据以太网交换机的交换端口来划分的,它是将VLAN交换机上...
  • VLAN划分方法

    2011-03-11 14:33:42
    这是最常应用的一种VLAN划分方法,应用也最为广泛、最有效,目前绝大多数VLAN协议的交换机都提供这种VLAN配置方法。这种划分VLAN的方法是根据以太网交换机的交换端口来划分的,它是将VLAN交换机上的物理端口和VLAN...
  • VLAN划分与互联.ppt

    2019-09-08 19:20:07
    VLAN划分方法 基于端口划分的VLAN 基于MAC地址划分VLAN 基于网络层协议划分VLAN 根据IP组播划分VLAN
  • (2)掌握VLAN的原理及基于交换机端口的VLAN划分方法。实验设备:交换机一台,主机四台,直通线四根实验步骤:1、给交换机划分VLAN100和VLAN200。(1)打开交换机的命令操作行,首先进入特权模式下Switch>enable(2)...
  • VLAN划分

    2018-04-28 16:51:30
    今天给大家介绍下静态vlan划分、vlan Trunk的配置以及端口聚合,vlan是什么呢?其实vlan就是(Virtual Local Area Network)也就是"虚拟局域网"的...下面就用GNS3模拟拓扑图为大家详细介绍下vlan划分的具体方法,首先...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 509
精华内容 203
关键字:

vlan划分方法