精华内容
下载资源
问答
  • VLAN配置实例详解

    2013-12-23 13:12:16
    [CCNA图文笔记二十]VLAN配置实例详解
  • VLAN配置实例详解[归纳].pdf
  • 学网络,就在IE-LAB国内高端网络工程师培养基地MUX VLAN(Multiplex VLAN )提供了一种通过VLAN进行网络资源控制的机制。通过MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相通信,而企业外来访客之间...

    7e530ebfc4c9af3adb48e626ab7f6909.png

    学网络,就在IE-LAB

    国内高端网络工程师培养基地


    MUX VLAN(Multiplex VLAN )提供了一种通过VLAN进行网络资源控制的机制。通过MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相通信,而企业外来访客之间的互访是隔离的。

    b97e0a22ae47a8bb596372f071633f69.png

    为了实现报文之间的二层隔离,用户可以将不同的端口加入不同的VLAN,但这样会浪费有限的VLAN资源。采用端口隔离功能,可以实现同-VLAN内端口之间的隔离。

    在安全性要求较高的网络中,交换机可以开启端口安全功能,禁止非法MAC地址设备接入网络;当学习到的MAC地址数量达到上限后不再学习新的MAC地址,只到MAC地址的设备通信。

    1、MUX VLAN:

    对于企业来说。希望企业内部员工之间可以互相访问,而企业外来访客之间是隔离的,可通过配置每个访客使用不同的VLAN来实现。但如果企业拥有大量的外来访客员工,此时不但需要耗费大量的VLAN ID,还增加了网络维护的难度。

    MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相通信,而企业外来访客之间的互访是隔离的。

    MUX VLAN分为主VLAN和从VLAN,从VLAN又分为隔离型从VLAN和互通型从VLAN。

    主VLAN(PrincipalVLAN):Principal port可以和MUX VLAN内的所有接口进行通信。

    隔离型从VLAN(SeparateVLAN):Separate port只能和Principal port进行通信,和其他类型的接口实现完全隔离。

    每个隔离型从VLAN必须绑定一个主VLAN。

    互通型从VLAN(Group VLAN):Group port可以和Principalport进行通信,在同一组内的接口也可互相通信,但不能和其他组接口或Separate port通信。每个互通型从VLAN必须绑定一个主VLAN。

    2、端口隔离

    端口隔离分为二层隔离三层互通和二层三层都隔离两种模式:

    如果用户希望隔离同一VLAN内的广播报文,但是不同端口下的用户还可以进行三层通信,则可以将隔离模式设置为二层隔离三层互通;

    如果用户希望同一vlan不同端口下用户彻底无法通信,则可以将隔离模式配置为二层三层均隔离;

    端口隔离技术也有缺点,一是计算机之间共享不能实现;二是隔离只能在一台交换机上实现,不能在堆叠交换机之间实现,如果是堆叠环境,只能改成交换机之间级连。

    3、端口安全

    如果说网络中存在非法用户时,可以使用端口安全技术保证网络的安全。一般使用在如下场景:

    ①应用在接口层设备:通过配置端口安全可以防止仿冒用户从其他端口攻击;

    ②应用在汇聚层设备,通过配置端口安全可以控制接入用户的数量。

    端口安全(Port Security),从基本原理上讲,PortSecurity特性会通过MAC地址表记录连接到交换机端口的以太网MAC地址,并只允许某个MAC地址通过本端口通信。其他MAC地址发送的数据包通过此端口时,端口安全特性会阻止它。

    使用端口安全特性可以防止未经允许的设备访问网络,并增强安全性。另外,端口安全特性也可用于防止MAC地址泛洪造成MAC地址表填满。

    端口安全的类型:

    端口安全( Port Security )通过将接口学习到的动态MAC地址转换为安全MAC地址(包括安全动态MAC、安全静态MAC和Sticky MAC )阻止非法用户通过本接口和交换机通信,从而增强设备的安全性。

    1、接口使能端口安全功能时,接口上之前学习到的动态MAC地址表项将被删除,之后学习到的MAC地址将变为安全动态MAC地址。

    2、接口使能Sticky MAC功能时,接口上的安全动态MAC地址表项将转化为StickyMAC地址,之后学习到的MAC地址也变为StickyMAC地址。

    3、接口去使能端口安全功能时,接口上的安全动态MAC地址将被删除,重新学习动态MAC地址。

    4、接口去使能Sticky MAC功能时,接口上的StickyMAC地址会转换为安全动态MAC地址。

    超过安全MAC地址限制后得到的动作:

    接口上安全MAC地址数达到限制后,如果收到源MAC地址不存在的报文,端口安全则认为有非法用户攻击,就会根据配置的动作对接口做保护处理。缺省情况下,保护动作是restrict。

    Restrict:丢弃源MAC地址不存在的报文并上报警。推荐使用该动作。 注:设备收到非法MAC地址的报文时,每30s至少警告1次,至多警告2次。

    Protect:只丢弃源MAC地址不存在的报文,不上告报警。

    Shutdown:接口状态被置为error-down,并上报告警。 默认情况下,接口关闭后不会自动恢复,只能由管理员手动恢复。

    IE-LAB有优质雄厚师资力量支撑,全面的学习平台和完善的教学服务,我们培养了一批又一批的HCIE/CCIE学员,加入我们,成就未来。

    61f8dac98e4c33bf82e9bc7816f0343a.png

    往期【网工知识角】技术回顾:

    关于ESXi的基本介绍及其五大优点,网工知识角

    网工知识角|网络内部漏洞如何解决?有802.1X协议不用怕

    网络端口镜像技术三分钟详细总结一篇搞定,就在网工知识角

    网工知识角|温故知新之关于语音你不得不知的PSTN协议详解

    网工知识角|关于会话初始协议 SIP超详细介绍,建议收藏

    网工知识角|一分钟记熟NFV网络功能虚拟化技术介绍

    网工知识角|IPSec协议是如何确保网络安全的?

    网工知识角|华为认证配置指南之SSL协议知多少

    网工知识角|快速掌握华为认证交换机配置之端口安全机制

    网工知识角|掌握这四种方式完成垃圾邮件过滤,守护网络安全

    IPSec协议超详细解读网络安全协议的重要性就在网工知识角

    光纤通信技术知多少?WDM技术原理概述就在网工知识角

    网工知识角|你不得不了解的VRRP负载均衡技术详解

    乘SDN的热潮,NETCONF协议“重出江湖”,五大优点总结就在网工知识角

    网工请戳!交换机配置指南半分钟即可掌握关于SSL配置的内容

    热门无线技术中这个知识点你知多少?WLAN WDS技术详解一篇搞定

    MSDP协议的三个优点你知多少,就在网工知识角

    VLAN攻击如何有效防范?搞定虚拟局域网就在网工知识角

    一分钟掌握NFV基本概念,就在网工知识角

    三分钟掌握热点路由技术之DLSW,技术详解就在网工知识角

    避免引起网络安全问题,6步完成华为设备风暴控制的配置,网工知识角

    关于OSPF协议重点学习笔记之OSPFv3和OSPFv2的区别

    思科路由协议IGRP和EIGRP超详细总结,了解它们之间的关联和区别

    网工知识角|NAT64基本原理概述,它的局限性又有哪些?

    快速掌握网络通讯流量资源浪费的环路解决方法,网工知识角

    新网工技术一分钟解读Openflow工作原理,网工知识角

    网工知识角|用于管理和控制IPv6组播组的MLDsnooping技术详解

    网工知识角|快速理解FTP和TFTP的区别,实用收藏

    新网工都要了解的无线技术,你却连Mesh网络是什么都不知道?

    网工知识角|零基础入门学网络,三分钟掌握DTP协议的五种接口模式

    网工知识角|思科全新EI及无线方向你必须要去了解的WLAN漫游技术

    网工知识角|基础入门务必掌握这两个常用协议,快速攻克面试难关

    网工知识角|技术大牛自检时间到,关于MLD技术你知多少?

    网工知识角|不可忽略的三个关键点,确保端口安全配置无误

    网工知识角|一分钟搞定802.1x认证配置,了解三种授权模式的区别

    快速完成华为IPSG配置一分钟看完即会,网工知识角每天进步一点点

    网工知识角|一分钟轻松掌握Mac地址漂移使用的场景

    网络工程师技术难点分析MTU和PMTU是什么?就在网工知识角

    华为网络初级工程师快速掌握基于MAC地址的VLAN划分实用收藏

    网工知识角|华为网络技术面试题详解QOS流量整形令牌桶机制和规则

    这样总结隧道Tunnel技术工作原理更容易记住 网络工程师还不收藏?

    你知道NAC网络准入控制的5大功能5种类型和3重优点吗?

    网工知识角|什么是虚拟化?史上最全云计算基础虚拟化技术各种概念高薪面试必备

    网工知识角|网络工程师快收下这份华为MUXVLAN的原理和配置,华为HCIP数通网络实用技术

    网工知识角|华为HCIE数通认证基础必学之GVRP协议是什么

    网工知识角|CCIE网络工程师安全基础之AAA认证的三个基本组件

    网工知识角|EI CCIE企业网软定义中的VxLAN分布式网关两种部署方式

    网工知识角|关于OSPF V3你了解吗?不懂没关系,收下这份配置

    纯干货网工知识角|入门IT网络工程师收下这份关于NTP网络时间协议解读

    学思科和华为都需要掌握之网络安全技术防火墙的4种分类,网工知识角

    网工知识角|信息安全入门反病毒技术全面解说5种传播途径

    网工知识角|没人会告诉你的网络SDN软定义技术中VXLAN的4个特点

    网工知识角|你不可不知的WLAN的安全技术体系

    网工知识角|什么是思科软件定义接入(SD-Access)? 新一代网工必学的自动化技术

    网工知识角|什么是华为CSS 集群?简单易懂,面试收藏

    网工知识角|三分钟了解QOS的处理流程和分类

    网工知识角|Qos的基本原理

    网工知识角|LACP技术详解

    网工知识角|802.1X协议介绍

    网工知识角|OpenFlow协议简介

    网工知识角|MSTP协议详解

    网工知识角|快速了解IGMP协议

    网工知识角|快速了解和掌握HSRP协议简介和配置

    网工知识角|1分钟了解GRE协议浅析

    网工知识角|DHCP服务详解和基于eNSP DHCP配置

    网工知识角|P2P协议简介

    网工知识角|OSPFv3技术概述

    网工知识角|防火墙双机热备三大协议(VRRP-VGMP-HRP)简述

    网工知识角|一分钟了解交换机的堆叠技术

    网工知识角|简单了解Cisco PVST协议

    网工知识角|MPLS LDP简介

    网工知识角|GLBP网关负载均衡协议原理

    网工知识角|Cisco VTP解析

    网工知识角|DLDP技术简述

    网工技术分享|Cisco策略路由PBR详解

    网工技术分享|Cisco CEF浅析

    ca6c4a3789c438a64ef6f2b546a39d7d.gif

    CCIE备考交流QQ群:134074975

    思科华为免费公开课QQ群:134403299

    每日打卡一个技术点,关注IE-LAB哔哩哔哩:370947524

    每日下午4点准时直播,关注IE-LAB抖音:135654500 

    IE-LAB官网:http://www.ie-lab.cn

    分享给更多网工同伴一起进步

    2b5f97614f0019d49e8d6a7b13411b23.png关注本订阅号,点个““”在看

    展开全文
  • VLAN的简单配置实例(图文并茂)

    万次阅读 多人点赞 2019-10-18 23:09:31
    VLAN的简单配置实例(图文并茂) 一.实验环境 首先我们得有简单的实验环境:GNS3,C2691路由器 二.实验图示 如图,先建立如图所示的简单拓扑图。 注:记得给交换机设置好参数。如图 三.实验步骤 首先我们得配置好...

    VLAN的简单配置实例(图文并茂)

    **

    前言:vlan是什么

    **
    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。 [1]
    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点: 网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。 [1]
    在计算机网络中,一个二层网络可以被划分为多个不同的广播域,一个广播域对应了一个特定的用户组,默认情况下这些不同的广播域是相互隔离的。不同的广播域之间想要通信,需要通过一个或多个路由器。这样的一个广播域就称为VLAN。

    一.实验环境

    首先我们得有简单的实验环境:GNS3,C2691路由器

    二.实验图示mark

    如图,先建立如图所示的简单拓扑图。

    注:记得给交换机设置好参数。如图

    mark mark

    三.实验步骤

    首先我们得配置好三台主机的ip地址。配置如图。

    pc1mark
    pc2mark
    pc3mark

    主机配置完成。接下来我们开始设置交换机。如图mark

    mark

    我们可以查看路由功能查看我们已经设置好的vlan和接口。mark先配好三个vlan,10,20,30,然后退出vlan模式

    mark

    如图配置好f1/0 接口的vlan。第二个红框可以简写为sw mo acc。第三个红框可以简写为sw acc vlan10.

    同样的我们也可以对f1/1 和f1/2设置。如下。

    mark

    图片转存中…(img-4xQeqhXG-1571411349141)]

    至此,简单的vlan配置实验完毕。有兴趣的童鞋可以去测试下,刚开始三台主机是可以互通的,但经过我们的vlan实验操作之后,三台主机便不能互通了,形成了隔离。
    结论:这里的vlan就是将本可以互通的几台虚拟机给分开,可以联系生物的物种隔离来类比做理解。

    展开全文
  • VLAN配置实例

    千次阅读 多人点赞 2020-05-15 15:46:56
    实验配置思路: 1.PC2/4/5/6处于同一网段–DHCP下放IP地址 PC1/3–使用路由器子接口DHCP下放IP地址 2.为满足实验要求: 将PC2划分到VLAN3、可以在同一VALN,也可以在不同VLAN,在这,我是把PC4/PC5都划分到VLAN4、PC...

    实验拓扑图

    说明:图上当时把端口编号托错位置—互换LSW2和LSW3上相连端口编号。此图下的图上为正确图
    在这里插入图片描述
    实验要求:

    1.PC1和PC3所在接口为access;PVLAN VLAN2
    PC2/4/5/6 处于同一网段;其中PC2可以访问PC4/5/6;但PC4可以访问PC5,不能访问PC6;

    2.PC5不能访问PC6

    实验配置思路:

    1.PC2/4/5/6处于同一网段–DHCP下放IP地址 PC1/3–使用路由器子接口DHCP下放IP地址

    2.为满足实验要求:

    划分VLAN:PC1/PC3处于VLAN2;PC2处于VLAN3;PC4/5处于VLAN4;PC6处于VLAN5

    3.规划端口模式:
    在这里插入图片描述

    配置

    • 交换机上创建VLAN
      [SW1]vlan batch 2 to 5
      [SW2]vlan batch 2 to 5
      [SW3]vlan batch 2 to 5

    • 根据上图配置端口模式

    SW1:

    interface GigabitEthernet0/0/1
    port hybrid tagged vlan 2
    port hybrid untagged vlan 3 to 5

    interface GigabitEthernet0/0/2
    port link-type trunk //接口模式改为trunk模式
    port trunk allow-pass vlan 2 to 5 //允许通过的VLAN

    interface GigabitEthernet0/0/3
    port link-type access
    port default vlan 2

    interface GigabitEthernet0/0/4
    port hybrid pvid vlan 3
    port hybrid untagged vlan 3 to 5

    在这里插入图片描述

    SW2:

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 5

    interface GigabitEthernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 2 to 5

    interface GigabitEthernet0/0/3
    port link-type access
    port default vlan 2

    interface GigabitEthernet0/0/4
    port hybrid pvid vlan 4
    port hybrid untagged vlan 3 to 4

    在这里插入图片描述

    SW3:

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 5

    interface GigabitEthernet0/0/2
    port hybrid pvid vlan 4
    port hybrid untagged vlan 3 to 4

    interface GigabitEthernet0/0/3
    port hybrid pvid vlan 5
    port hybrid untagged vlan 3 5

    在这里插入图片描述

    • 配置DHCP,下放IP地址
      display current-configuration

    sysname R1

    dhcp enable //全局开启DHCP

    ip pool a
    gateway-list 172.16.1.1
    network 172.16.1.0 mask 255.255.255.0
    dns-list 8.8.8.8

    ip pool b
    gateway-list 192.168.1.1
    network 192.168.1.0 mask 255.255.255.0
    dns-list 8.8.8.8

    interface GigabitEthernet0/0/0
    ip address 192.168.1.1 255.255.255.0
    dhcp select global

    interface GigabitEthernet0/0/0.1 //子接口
    dot1q termination vid 2
    ip address 172.16.1.1 255.255.255.0
    arp broadcast enable
    dhcp select global

    • 测试
      1)PC使用DHCP自动获取IP地址
      例:PC1、PC2
      在这里插入图片描述
      在这里插入图片描述
      2)测试连通性
      PC1 ping PC3 相同VLAN的通信(PC1IP地址-172.16.1.253 PC3–172.16.1.254)
      在这里插入图片描述
      PC2 ping PC4可通(PC4IP地址为192.168.1.251)
      在这里插入图片描述
      PC2 ping PC5 -可通
      在这里插入图片描述
      PC2 ping PC6-可通(基于hybrid端口实现不同VLAN间进行通信)
      在这里插入图片描述
      PC4 ping PC5-可通(相同VLAN)
      在这里插入图片描述
      PC4 ping PC6 --不通(不同VLAN)
      在这里插入图片描述
      PC5 ping PC6–不通(不同VLAN间不能进行通信)
      在这里插入图片描述
    展开全文
  • linux vlan配置详解

    2021-05-09 07:20:27
    本文主要给大家介绍了关于linux虚拟网络设备之vlan配置的相关资料,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,希望能帮助到大家。简介VLAN是网络栈的一个附加功能,且位于下两...

    本文主要给大家介绍了关于linux虚拟网络设备之vlan配置的相关资料,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,希望能帮助到大家。

    简介

    VLAN是网络栈的一个附加功能,且位于下两层。首先来学习Linux中网络栈下两层的实现,再去看如何把VLAN这个功能附加上去。下两层涉及到具体的硬件设备,日趋完善的Linux内核已经做到了很好的代码隔离,对网络设备驱动也是如此,如下图所示:

    5fbc02e684cceaff39e098f78611d39d.png

    这里要注意的是,Linux下的网络设备net_dev并不一定都对应实际的硬件设备,只要注册一个struct net_device{}结构体(netdevice.h)到内核中,那么这个网络设备就存在了。该结构体很庞大,其中包含设备的协议地址(对于IP即IP地址),这样它就能被网络层识别,并参与路由系统,最有名的当数loopback设备。不同的设备(包括硬件和非硬件)的ops操作方法各不相同,由驱动自己实现。一些通用性的、与设备无关的操作流程(如设备锁定等)则被Linux提炼出来,我们称为驱动框架。

    linux虚拟网络设备之vlan配置

    我们通过一个网桥两个设备对,来连接两个网络名字空间,每个名字空间中创建两个vlan

    643748eeebfd0a12a834ba9742411fb4.png

    借助vconfig来配置vlan:#创建网桥

    brctl addbr br-test-vlan

    #创建veth对儿

    ip link add veth01 type veth peer name veth10

    ip link add veth02 type veth peer name veth20

    #将veth对儿的一段添加到网桥

    brctl addif br-test-vlan veth01

    brctl addif br-test-vlan veth02

    #启动设备

    ip link set dev br-test-vlan up

    ip link set dev veth01 up

    ip link set dev veth02 up

    ip link set dev veth10 up

    ip link set dev veth20 up

    #创建网络名字空间

    ip netns add test-vlan-vm01

    ip netns add test-vlan-vm02

    #将设备对儿的另一端添加到另个名字空间(其实在一个名字空间也能玩,只是两个名字空间更加形象)

    ip link set veth10 netns test-vlan-vm01

    ip link set veth20 netns test-vlan-vm02

    #分别进入两个名字空间创建vlan和配置ip

    #配置名字空间test-vlan-vm01

    ip netns exec test-vlan-vm01 bash

    #配置vlan 3001 和 vlan 3002

    vconfig add veth10 3001

    vconfig add veth10 3002

    #启动两个vlan的设备

    ip link set veth10.3001 up

    ip link set veth10.3002 up

    #分别在两个vlan上配置ip (这里简单起见,使用了同一个网段了IP,缺点是,需要了解一点儿路由的知识)

    ip a add 172.16.30.1/24 dev veth10.3001

    ip a add 172.16.30.2/24 dev veth10.3002

    #添加路由

    route add 172.16.30.21 dev veth10.3001

    route add 172.16.30.22 dev veth10.3002

    #配置名字空间test-vlan-vm02

    ip netns exec test-vlan-vm02 bash

    #配置vlan 3001 和 vlan 3002

    vconfig add veth20 3001

    vconfig add veth20 3002

    #启动两个vlan的设备

    ip link set veth20.3001 up

    ip link set veth20.3002 up

    #分别在两个vlan上配置ip (这里简单起见,使用了同一个网段了IP,缺点是,需要了解一点儿路由的知识)

    ip a add 172.16.30.21/24 dev veth20.3001

    ip a add 172.16.30.22/24 dev veth20.3002

    #添加路由

    route add 172.16.30.1 dev veth20.3001

    route add 172.16.30.2 dev veth20.3002

    查看一下vlan配置:# cat /proc/net/vlan/config

    VLAN Dev name | VLAN ID

    Name-Type: VLAN_NAME_TYPE_RAW_PLUS_VID_NO_PAD

    veth10.3001 | 3001 | veth10

    veth10.3002 | 3002 | veth10

    现在,我们可以分别在两个名字空间来ping另外一个名字空间的两个IP,虽然两个IP都能ping通,但是使用的源IP是不同的,走的vlan也是不同的,我们可以在veth01/veth10/veth02/veth20/br-test-vlan 任意一个上抓包,会看到vlan信息:# tcpdump -i veth10 -nn -e

    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

    listening on veth10, link-type EN10MB (Ethernet), capture size 262144 bytes

    15:38:18.381010 82:f7:0e:2d:3f:62 > 9e:58:72:fa:11:15, ethertype 802.1Q (0x8100), length 102: vlan 3001, p 0, ethertype IPv4, 172.16.30.1 > 172.16.30.21: ICMP echo request, id 19466, seq 1, length 64

    15:38:18.381183 9e:58:72:fa:11:15 > 82:f7:0e:2d:3f:62, ethertype 802.1Q (0x8100), length 102: vlan 3001, p 0, ethertype IPv4, 172.16.30.21 > 172.16.30.1: ICMP echo reply, id 19466, seq 1, length 64

    15:38:19.396796 82:f7:0e:2d:3f:62 > 9e:58:72:fa:11:15, ethertype 802.1Q (0x8100), length 102: vlan 3001, p 0, ethertype IPv4, 172.16.30.1 > 172.16.30.21: ICMP echo request, id 19466, seq 2, length 64

    15:38:19.396859 9e:58:72:fa:11:15 > 82:f7:0e:2d:3f:62, ethertype 802.1Q (0x8100), length 102: vlan 3001, p 0, ethertype IPv4, 172.16.30.21 > 172.16.30.1: ICMP echo reply, id 19466, seq 2, length 64

    15:38:23.162052 82:f7:0e:2d:3f:62 > 9e:58:72:fa:11:15, ethertype 802.1Q (0x8100), length 102: vlan 3002, p 0, ethertype IPv4, 172.16.30.2 > 172.16.30.22: ICMP echo request, id 19473, seq 1, length 64

    15:38:23.162107 9e:58:72:fa:11:15 > 82:f7:0e:2d:3f:62, ethertype 802.1Q (0x8100), length 102: vlan 3002, p 0, ethertype IPv4, 172.16.30.22 > 172.16.30.2: ICMP echo reply, id 19473, seq 1, length 64

    如果试图从veth10.3001 去ping 172.16.30.22 是不能通的,因为是不同的vlan呀:# ping -I veth10.3001 172.16.30.22

    PING 172.16.30.22 (172.16.30.22) from 172.16.30.1 veth10.3001: 56(84) bytes of data.

    ^C

    --- 172.16.30.22 ping statistics ---

    9 packets transmitted, 0 received, 100% packet loss, time 8231ms

    不适用vconfig的解法:ip link add link veth10 name veth10.3001 type vlan id 3001

    另: vlan 一般以 设备名.vlanid 来命名,不过并非强制,如下命名为 vlan3003也是没问题的# ip link add link veth10 name vlan3003 type vlan id 3003

    注意:一个主设备上相同vlan好的子设备最多只能有一个# ip link add link veth10 name vlan3001 type vlan id 3001

    RTNETLINK answers: File exists

    所以,正常来讲,一般是这样的:

    4675fb23810a6217213c78c7f9935dce.png

    相关推荐:

    展开全文
  • 华三模拟器vlan配置实例

    千次阅读 2019-03-23 11:46:25
    1. 配置步骤(1)配置Device A<... system-view[DeviceA] vlan 100[DeviceA-vlan100] port gigabitethernet 1/0/1[DeviceA-vlan100] quit[DeviceA] vlan 200[DeviceA-vlan100] port gigabitethernet 1/0/2[Device...
  • H3C交换机VLAN基础配置实例.doc
  • 1、VLAN基础知识 VLAN(Virtual Local Area Network)的中文名为:“虚拟局域网”,注意和'VPN'(虚拟专用网)进行区分。 VLAN是一种将局域网设备从逻辑上划分(不是从物理上划分)成一个个网段,从而实现虚拟...
  • 原标题:一步步详解华为交换机配置实例,一看就会前几天我们发布了关于H3C交换机恢复出厂和各种基本配置,有不少朋友提到华为的交换机的配置,华为的交换机确实在项目中用的非常多,无法避开,熟练的了解配置才能在...
  • 华为mux-vlan设置

    2018-09-12 20:08:30
    华为mux-vlan设置,总体步骤,代码片段,实现二层交换机隔离
  • [ 网络协议篇 ] vlan 详解之 super vlan 详解

    千次阅读 多人点赞 2021-12-20 22:16:15
    Super VLAN 主要通过实现多个 VLAN 共用同一个 IP 网段,从而达到节省IP地址资源的目的。
  • 华为交换机配置VLANVLANif

    千次阅读 2020-12-24 02:47:09
    那么今天小编将指导大家完成华为交换机的vlan配置和vlanif接口的配置请自行准备好华为交换机和电脑并且让你的电脑和交换机连接上使用system-view命令进入[]模式创建一个vlan[Quidway]vlan 2添加端口[Quid...
  • ensp-vlan配置

    千次阅读 2020-03-28 17:57:00
    实验拓扑图如下: 实验要求: 1、将交换机的名称分别修改为SW1和SW2。 2、在SW1上创建vlan 10和vlan 20。 3、将PC1和PC2加入vlan 10中,将PC3和PC4加入vlan ...6、配置SW1和SW2之间的链路为trunk链路。 7、测试PC1与PC...
  • ENSP配置 实例一 不同VLAN间通信

    千次阅读 2020-06-19 11:31:22
    ENSP配置实列 实例1 不同VLAN间通信 SW1 [SW1]vlan batch 10 20 [SW1]interface g0/0/1 [SW1-GigabitEthernet0/0/1]port link-type access [SW1-GigabitEthernet0/0/1]port default vlan 10 [SW1-GigabitEthernet0/...
  • 基本VLAN划分,基本VLAN配置,同一24口交换机,两个不同部门资源不互访。
  • 详细介绍了MOXA的有关配置VLAN是指在不改变物理连接的条件下,对网络做逻辑分组
  • Cisco(思科)VLAN配置(详细)

    万次阅读 多人点赞 2020-12-13 15:06:41
    思科(Cisco)VLAN配置 一、拓扑图 1.VLAN的理解 交换机可以划分成很多个vlan,将局域网划分成很多个网段,来减少广播域和冲突域,默认情况下交换机各个接口接的都是vlan1,我们可以进入vlan数据库(database)...
  • 华为vlan配置

    万次阅读 多人点赞 2018-06-11 21:50:15
    一、实现同个vlan,不同网段的主机互通1、拓扑图2、案例LSW1交换机配置1)任意创建vlan,这里演示vlan100[Huawei]vlan 1002)进入vlan100配置IP,注意第二个IP后面加sub[Huawei]interface Vlanif 100 [Huawei-Vlanif...
  • 随着无线网络技术的日益成熟,无线设备的价格也降到了我们普通消费者能接受的水平。我们不用为了让家中两个房间的电脑可以同时上网而大费周折的拉网线配代理服务器了。一台无线宽带路由器、一块无线网卡就可以轻松...
  • 有关VLAN的技术标准IEEE 802.1Q早在1999年6月份就由IEEE委员正式颁布实施了,而且最早的VLNA技术早在1996年Cisco(思科)公司就提出了随着...-VLAN技术,并针对中、小局域网VLAN的网络配置实例的方式向大家简单介绍...
  • 华为super-vlan配置

    千次阅读 2020-05-08 10:28:18
    实现同一个子网网段下,VLAN2和VLAN3二层隔离、三层互通(通过super-...1.配置vlan,并把接口加入相应的sub-vlan [Huawei]vlan batch 2 3 23 [Huawei]int g0/0/1 [Huawei-GigabitEthernet0/0/1]port link-type ac ...
  • H3C VLAN的配置 VLAN配置实例

    千次阅读 2012-05-07 09:35:36
    1,配置VLAN端口类型 <h3c>system-view [h3c]interface Ethernet 1/0/2 [H3C-Ethernet1/0/2]port link-type Access|trunk|Hybrid [H3C-Ethernet1/0/2]quit 2,配置将端口加入指定的vlan <h3c>system...
  • VLAN的划分和网络的配置实例 1、VLAN基础知识 VLAN(Virtual Local Area Network)的中文名为:“虚拟局域网”,注意和'VPN'(虚拟专用网)进行区分。 VLAN是一种将局域网设备从逻辑上划分(不是从物理上划分)成...
  • 华为路由器交换机VLAN配置实例!!!!!!!!!!!!!!!!!!!!
  • 本期分享:系列15点到16点半-技术热讯 感谢大家关注-最铁头的网工,请...我们都知道,VLAN技术是用来隔离广播域的,通常,我们都是1个三层IP网段对应一个VLAN,那么问题来了,有的VLAN只需要几个IP,我们却要给它...
  • 今天给大家介绍MUIX VLAN的相关理论知识,同时使用华为eNSP模拟器,完成了企业网中常见的MUX VLAN配置。 一、MUX VLAN原理 MUX VLAN是一种VLAN控制层面的访问控制技术,使用MUX VLAN,可以实现VLAN间的流量隔离,...
  • vlan经典配置实例

    2009-06-05 19:56:58
    很详细。可以应用到实践当中.跟大家分享。一起努力
  • 交换机vlan配置示例

    千次阅读 2016-12-05 21:21:17
    锐捷交换机vlan配置示例,能够帮助理解vlan原理

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,688
精华内容 675
关键字:

vlan配置实例详解

友情链接: d3dlesson4.rar