精华内容
下载资源
问答
  • VLAN间通信

    2015-03-12 10:02:42
    VLAN间通信,对我们网络的划分很有帮助
  • vlan间通信

    2018-10-28 16:01:31
    两种方法实现vlan间通信 1、三层交换机 2、单臂路由
    pc ip mask default gateway
    0 192.168.1.10 255.255.255.0 192.168.1.1
    1 192.168.1.20 255.255.255.0 192.168.1.1
    2 192.168.2.30 255.255.255.0 192.168.2.1
    3 192.168.2.40 255.255.255.0 192.168.2.1

    三层交换机实现vlan间通信

    图1

    Switch_3:
    #en
    #configure terminal
    #vlan2
    #vlan3
    #int range fa0/1-2
    #switchport mode access
    #switchport access vlan2
    #no shutdown
    #int range fa0/2-3
    #switchport mode access
    #switchport access vlan3
    #no shutdown
    #int fa0/24
    #switchport mode trunk
    #switchport trunk allowed vlan all
    #no shutdown
    
    Switch_0:
    #en
    #configure terminal
    #ip routing
    #vlan 2
    #vlan 3
    #int vlan2
    #ip add 192.168.1.1 255.255.255.0
    #exit
    #int vlan3
    #ip add 192.168.2.1 255.255.255.0
    #exit
    #int fa0/24
    #switchport mode trunk
    #switchport trunk allowed vlan all
    
    

    单臂路由实现vlan间通信

    图2
    交换机和pc的配置都不变,以下是路由器的配置

    #en
    #configure terminal
    #int fa0/0
    #no shutdown
    #exit
    #int fa0/0.1
    #encapsulaton dot1Q 2
    #ip address 192.168.1.1 255.255.255.0
    #exit
    #int fa0/0.2
    #encapsulation dot1Q 3
    #ip address 192.168.2.1 255.255.255.0
    #exit 
    #end
    #show ip route
    
    

    图3
    图4

    展开全文
  • VLAN了解及VLAN间通信

    2020-02-27 22:19:48
    VLAN是虚拟局域网,介于数据链路层和网络层之间,VLAN可以隔离广播包,不同VLAN不能正常通信,VLAN间通信需要引入路由技术,可以通过二层交换机配合路由器来实现,也可以通过三层交换机来实现,通信的原理是指通过...

    VLAN概述

    VLAN是虚拟局域网,介于数据链路层和网络层之间,VLAN可以隔离广播包,不同VLAN不能正常通信,VLAN间通信需要引入路由技术,可以通过二层交换机配合路由器来实现,也可以通过三层交换机来实现,通信的原理是指通过利用三层设备识别并转换Tag标签。

    VLAN间路由

    VlAN间通信常见的方式是单臂路由和三层交换技术

    1. 单臂路由拓扑如下图所示
      在这里插入图片描述
      R1配置及注释如下
    interface GigabitEthernet0/0/0.1
    
     dot1q termination vid 2    识别VID为2的数据报文
    
     ip address 10.1.2.254 255.255.255.0   配置接口地址
    
     arp broadcast enable        开启arp代理
    
    #
    
    interface GigabitEthernet0/0/0.2
    
     dot1q termination vid 3     识别VID为3的数据报文
    
     ip address 10.1.3.254 255.255.255.0
    
     arp broadcast enable
    
    1. 三层交换拓扑如下图所示

    在这里插入图片描述

    LSW7配置配置及注释如下

    
    
    vlan batch 2 to 3        配置VLAN 2 3
    
    #
    
    interface Vlanif2
    
     ip address 10.1.2.254 255.255.255.0    配置VLAN 2地址
    
    #
    
    interface Vlanif3
    
     ip address 10.1.3.254 255.255.255.0
    
    #
    
    interface GigabitEthernet0/0/1
    
     port link-type trunk            链路配置为中继链路
    
     port trunk allow-pass vlan 2 to 4094    允许所有带tag的VLAN通过
    
    #
    
    interface GigabitEthernet0/0/2
    
     port link-type trunk
    
     port trunk allow-pass vlan 2 to 4094
    
    

    注:上述两种拓扑在不添加三次路由器和三层交换机的情况下,配置基本类似,在此不一一列举,有一点需要注意的是,三层设备摆放的位置,如果是只连接一侧交换机,那么需要在连接三层设备的交换机配置另一个交换机VLAN,举例来说,路由器摆放位置在LSW6交换机一边,那么LSW5交换机过来的包会通过LSW6,然而LSW6没有LSW5对应的VLAN配置会直接丢包。

    展开全文
  • 一、VLAN间通信的两种方式我们知道默认不同VLAN间数据时不能通信的,想要实现不同VLAN间通信常用的有两种方式:1、通过三层交换路由功能实现不同VLAN之间的通信2、通过单臂路由实现不同VLAN之间的通信通过三层交换...

    一、VLAN间通信的两种方式

    我们知道默认不同VLAN间数据时不能通信的,想要实现不同VLAN间通信常用的有两种方式:

    1、通过三层交换路由功能实现不同VLAN之间的通信

    2、通过单臂路由实现不同VLAN之间的通信

    通过三层交换路由功能实现不同VLAN之间的通信实战:

    ec8c16b238665e3f3da20b6fe17d70e0.png

    vlan batch 20 30

    interface Vlanif1

    ip address 192.168.1.1 255.255.255.0

    interface Vlanif20

    ip address 192.168.20.1 255.255.255.0

    interface Vlanif30

    ip address 192.168.30.1 255.255.255.0

    interface Ethernet0/0/1

    port link-type access

    port default vlan 20

    interface Ethernet0/0/2

    port link-type access

    port default vlan 30

    ip route-static 192.168.20.0 255.255.255.0 192.168.1.2

    ip route-static 192.168.30.0 255.255.255.0 192.168.1.2

    交换机的B配置

    vlan batch 40

    interface Vlanif1

    ip address 192.168.1.2 255.255.255.0

    interface Vlanif40

    ip address 192.168.40.1 255.255.255.0

    ip route-static 192.168.40.0 255.255.255.0 192.168.1.1

    在两个交换配之间端口做trunk配置,并允许所有的vlan通过

    二、单臂路由实现VLAN间通信实战

    单臂路由:

    5c00cc5c219189d4cc977614ef4ea5dd.png

    说明:AR1属于vlan4 ,AR3属于vlan8. 通过单臂路由的方式实现AR1和AR3之间的通信

    SW1的配置:

    1.创建vlan4 和8.

    vlan batch 4 8

    2.E0/0/1接口配置:

    interface Ethernet0/0/1

    port link-type access

    port default vlan 4

    3.E0/0/3接口配置:

    interface Ethernet0/0/3

    port link-type access

    port default vlan 8

    4.G0/0/2接口配置:

    interface GigabitEthernet0/0/2

    port link-type trunk

    undo port trunk allow-pass vlan 1

    port trunk allow-pass vlan 4 8

    #

    重点:

    AR2的配置:

    1.创建子接口:G0/0/1.1和G0/0/1.3

    2.interface GigabitEthernet0/0/1.1

    dot1q termination vid 4

    ip address 10.0.4.254 255.255.255.0

    arp broadcast enable

    3.interface GigabitEthernet0/0/1.3

    dot1q termination vid 8

    ip address 10.0.8.254 255.255.255.0

    arp broadcast enable

    #

    说明:1.配置子接口是为了节省接口。从而节省费用

    2.子接口配置dot1q的目的是为了带vlan的数据帧进入的时候比较pvid,如果相同则收,不同则丢弃。

    带vlan的数据帧出去的时候比较pvid相同剥掉tag,不同丢弃。(其实和Access端口的功能相同)

    (dot1q就是802.1q,是vlan的一种封装方式。dot就是点的意思,就简写为dot1q了.)

    3.配置ARP 广播是因为路由器的接口隔离广播域,每一个接口就是一个广播域,而ARP报文只能在同一个 广播域泛洪,所以要开启ARP广播。

    欢迎学网络的小伙伴们入圈交流,圈内持续更新分享网络技术,争取早日进圈修炼成为网络狂热分子!

    展开全文
  • VLAN间通信问题

    2021-01-08 23:00:01
    上篇文章我们讲了VLAN原理与配置,今天我们来说说VLAN的局限性,如何解决VLAN间通信问题。 VLAN的优点 既能够隔离广播域,又能够提升网络的安全性,避免冲突的恶化,限制广播域的范围,减少广播流量。 VLAN的...

    目录

     

    前言

    什么是VLAN?

    VLAN的优点

    VLAN的局限性

    解决VLAN间通信问题

    第一种方法:在路由器上为每个VLAN分配一个单独的接口,并使用一条物理链路连接到二层交换机上。

    第二种方法:单臂路由

    第三种方法: 三层交换

    最后


    前言

    上篇文章我们讲了VLAN原理与配置,今天我们来说说VLAN的局限性,如何解决VLAN间通信问题。

     

    什么是VLAN?

    VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的局域网在逻辑上划分成多个广播域的技术。通过在交换机上配置VLAN,可以实现在同一个VLAN内的用户可以进行二层互访,而不同VLAN间的用户被二层隔离。

     

    VLAN的优点

    既能够隔离广播域,又能够提升网络的安全性,避免冲突的恶化,限制广播域的范围,减少广播流量。

     

    VLAN间通信问题

    正所谓人无完人,再好的事物都会有点小缺陷。

    VLAN在分割了二层广播域,也严格地隔离了各个VLAN之间的任何二层流量,属于不同VLAN的用户之间不能进行二层通信。比如:主机1有悄悄话想和主机2说,由于它们不在同一个VLAN中,无法说悄悄话,也就是说通信不了,造成了VLAN间的通信问题。

    局限性

     

    解决VLAN间通信问题

    出现问题了,我们当然要想办法解决问题啦,解决VLAN间通信问题有很多种,我们今天来讲三种解决方法。

    第一种方法:在路由器上为每个VLAN分配一个单独的接口,并使用一条物理链路连接到二层交换机上。

    方法一

    当VLAN间的主机需要通信时,数据会经由路由器进行三层路由,并被转发到目的VLAN内的主机,这样就可以实现VLAN之间的相互通信。

    缺点:随着每个交换机上VLAN数量的增加,这样做必然需要大量的路由器接口,而路由器的接口数量是极其有限的。并且,某些VLAN之间的主机可能不需要频繁进行通信,如果这样配置的话,会导致路由器的接口利用率很低。

    因此,实际应用中一般不会采用这种方案来解决VLAN间的通信问题。

     

    第二种方法:单臂路由

    在交换机和路由器之间仅使用一条物理链路连接。在交换机上,把连接到路由器的端口配置成Trunk类型的端口,并允许相关VLAN的帧通过。在路由器上需要创建子接口,逻辑上把连接路由器的物理链路分成了多条。一个子接口代表了一条归属于某个VLAN的逻辑链路。

    单臂路由

    配置子接口时,需要注意以下几点:

    • 必须为每个子接口分配一个IP地址。
    • 该IP地址与子接口所属VLAN位于同一网段。
    • 需要在子接口上配置802.1Q封装,来剥掉和添加VLAN Tag,从而实现VLAN间互通。
    • 在子接口上执行命令arp broadcast enable使能子接口的ARP广播功能。

    本例中,主机A发送数据给主机B时,RTA会通过G0/0/1.1子接口收到此数据,然后查找路由表,将数据从G0/0/1.2子接口发送给主机B,这样就实现了VLAN2和VLAN3之间的主机通信。

    第三种方法: 三层交换

    在三层交换机上配置VLANIF接口来实现VLAN间路由。如果网络上有多个VLAN,则需要给每个VLAN配置一个VLANIF接口,并给每个VLANIF接口配置一个IP地址。用户设置的缺省网关就是三层交换机中VLANIF接口的IP地址。

    三层交换

     

    最后

    好了,VLAN的局限性解决方法就讲到这里,有讲得不好的地方,请在评论区告诉我,谢谢。

    下篇文章讲解决局限性的方法的配置,敬请期待!!!

     

     

     

     

    展开全文
  • 单臂路由实现vlan间通信,请使用Cisco Packet Tracer Student打开
  • VLAN间通信1. VLAN间通信1.1 二层交换机+路由器(多臂路由)1.1.1 原理1.1.2 数据流分析1.1.3 缺点1.2 单臂路由方式实现1.2.1 原理1.2.2 配置方式1.2.3 数据流1.2.4 不足1.3 Vlanif逻辑接口(三层交换机)1.3.1 三层...
  • 交换机不同vlan间通信

    2020-10-31 17:41:51
    有两台二层交换机SwitchA和SwitchB, 一台路由器Gw,网络拓扑如图4-...主机PC1、PC2、 PC3、PC4的IP地址及所属VLAN如图4-27所示, 对四台主机、交换机及路由器进行恰当的配置,实现跨交换机相同VLAN内通信和VLAN间通信
  • VTP与VLAN间通信

    2011-10-12 15:38:07
    实验VTP与VLAN间通信实验VTP与VLAN间通信
  • VLAN间通信

    2019-11-10 12:40:40
    交换是疏通领域另一个知识块,与路由一样有着举足轻重的地方,本片就通过不同vlan间通信的三个实现方式来讲解交换的通信过程。 二、不同vlan间通信实现方法 1.使用二层设备实现 如下图所示,两个交换机之间使用端口...
  • STP选根及VLAN间通信

    2019-03-21 16:44:30
    使用华为模拟器,模拟实验交换机STP选根及VLAN间通信
  • 三层交换机实现vlan间通信,请使用Cisco Packet Tracer Student打开
  • 三层交换机怎么设置vlan间通信?在三层交换机与二层交换机之间采用trunk链路,实现各子网的互联,但是具体该怎么设置呢?下面我们来看看三层交换机vlan通信的设置方法,需要的朋友可以参考下
  • VLAN间通信原理

    2020-11-05 10:04:35
    VLAN间通信分为两种 1.使用子接口 2.使用Vlanif ----更好,在交换机内部即可完成一次路由,多次交换。 分别在两个接口开启抓包,然后使用PC1pingPC2。 PC1与PC2不在同一个网段。 自己抓包实验现象跟官方产品文档有...
  • VlAN和VLAN间通信1、实验拓扑2、实验要求3、配置思路及验证结果3.1 创建 VLAN 并划分对应接口3.2 配置 VLANIF 接口3.3 配置 OSPF3.4 验证实验结果 1、实验拓扑 2、实验要求 如图所示,配置设备名称和IP地址 sw1与...
  • VLAN间通信的三种方法

    2020-08-08 14:42:44
    解决VLAN间通信的三种方法: 二层交换机+一台路由器实现VLAN间通信(多臂路由) 单臂路由的方式实现VLAN间通信 现网中实际运用vlanif逻辑接口来实现VLAN之间通信(三层交换) 多臂路由: 优点:原理简单 缺点:当...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,843
精华内容 737
关键字:

vlan间通信