精华内容
下载资源
问答
  • flutter安装

    千次阅读 2020-06-04 17:24:26
    一、下载FlutterSdk https://flutter.dev/docs/development/tools/sdk/releases?tab=windows 二、配置FlutterSdk 1、点开我的电脑属性,点开高级属性,找到环境变量 2、点击选择系统变量中的path变量,在path变量中...

    一、下载FlutterSdk

    https://flutter.dev/docs/development/tools/sdk/releases?tab=windows

    在这里插入图片描述

    二、配置FlutterSdk

    1、点开我的电脑属性,点开高级属性,找到环境变量

    2、点击选择系统变量中的path变量,在path变量中添加fluttersdk的bin目录的路径【目录不要有中文不要有空格】
    在这里插入图片描述
    3、黑窗口测试一下
    在这里插入图片描述

    三、国内镜像【建议】

    1、flutter官方提供国内镜像

    2、在系统变量中新建,变量为key,变量值为value
    在这里插入图片描述
    在这里插入图片描述
    3、cmd 运行flutter -doctor检测

    展开全文
  • Flutter安装程序 Flutter Installer是Flutter构建的Flutter安装程序 :blue_heart: :smiling_face_with_sunglasses: :victory_hand: 特征 使用GUI界面安装Flutter,对初学者和专家有帮助 安装Flutter所需的软件,因此...
  • flutter安装终极教程

    千次阅读 多人点赞 2020-10-18 18:12:59
    flutter环境配置安装终极教程 环境安装流程 java环境 flutter sdk android SDK androidstudio dart sdk vscode 除了最后一个vscode是可选,其他几个是必须安装,缺一个都跑不起来。我们主要梳理一下下载安装这些...

    flutter环境配置安装终极教程

    环境安装流程

    1. java环境
    2. flutter sdk
    3. android SDK
    4. androidstudio
    5. dart sdk
    6. vscode

    除了最后一个vscode是可选,其他几个是必须安装,缺一个都跑不起来。我们主要梳理一下下载安装这些东西中存在的坑。

    一.java环境配置

    ​ 我们第一步需要先配置java环境,没配的看看,看过的已经可以去下面了。

    首先第一步下jdk,传送门:https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

    这里面存在一个问题,因为版本问题,配置环境会有一些差别,老版本需要配jre新版只用jdk,大家下载的时候尽量逮jdk8或者8以上的版本下。而且在配置环境的时候,上网找教程尽量找年代比较进的教程,那样版本应该和你的比较一致,如果太远的容易出问题。包括下载jdk的网站都变了,笔者下载的时候是个老网站,现在已经换新了。找下载的地方一开始都没找到。
    在这里插入图片描述
    在这里插入图片描述

    jdk下好之后是配环境,没配过环境的同学自己动手配一下,除了java,后面flutter也要配,很麻烦。具体安装推荐这个博主的:

    https://blog.csdn.net/qq_41436122/article/details/82620080?utm_medium=distribute.pc_relevant.none-task-blog-BlogCommendFromMachineLearnPai2-7.channel_param&depth_1-utm_source=distribute.pc_relevant.none-task-blog-BlogCommendFromMachineLearnPai2-7.channel_param

    安装下载jdk的时候一定要看好自己的版本和教程的版本,免得出错。

    配好之后测一下

    java _version
    在这里插入图片描述

    java
    在这里插入图片描述

    二 .flutterSDK

    先挂一下官方地址,大家去这个地方下载

    https://flutterchina.club/setup-windows/

    如果打不开,直接百度搜索flutter,找中文社区,在哪里面找下载也行

    找到了之后先根据官方教程配镜像

    随后,跟配置java环境一样打开环境变量

    在这里插入图片描述

    这时候我们要分清,一个是用户变量,一个是系统变量,我们把镜像地址要扔到用户变量里。如果不配镜像,会出问题,所以大家先配镜像。

    然后配好了之后可以下载flutterSDK了
    在这里插入图片描述

    新手建议点第一个,如果有github第二个也行。这个下载链接似乎被墙了,如果有大学生,联系一下自己认识的老师,用大学的专用网能打开,如果不是,只能自己搭梯子了(或者换个镜像试试,我没试过)。

    在这里插入图片描述

    下载好了之后,打开下载好的文件,找到bin目录,配置文件。
    在这里插入图片描述

    拷贝一下bin的路径,配置在path环境变量中
    在这里插入图片描述

    就跟java一样,把路径放底下就行
    在这里插入图片描述
    放好之后测一下,有的电脑可能反应慢,等一会:
    在这里插入图片描述

    然后找flutter_console
    在这里插入图片描述

    点一下

    在这里插入图片描述
    再测一下flutter doctor
    在这里插入图片描述
    目前第一行绿了就行,说明sdk搞好了

    三.android sdk

    然后再安卓sdk

    安装Android的SDK环境可以去这
    网站地址:
    https://www.androiddevtools.cn/
    在这里插入图片描述
    android sdk tools .24.4.1下安装包或者压缩包都行。下载好解压到除c盘外的盘里。

    下载好了打开
    找sdk Manager,打开是一个目录,可能会闪退,我也不知道为啥。
    在这里插入图片描述
    在这里插入图片描述

    打开是一个目录,在那一堆包里,先取消掉所有对勾,然后照着我这个打勾,选这几个包就行。选多了搞不好一次下10几个G,直接原地裂开。选好之后右下角下载(install…),下载时候记得点接受证书(Accept license)。

    四.android studio

    有的同学问我,为啥要下个android studio,用vscode不行吗,我只能说,没这玩意真不行。遇上的神奇报错都要用这个解决。

    我们先说第一个错(我的已经修好了,所以没图)

    Android license not accepted.

    没有安卓证书,怎么办。运行这个flutter doctor --android-licenses

    好开始经典无法理解命令,输入这个还报错Android license status unknown怎么办。无法理解命令,需要安装几个插件

    打开android studio,
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    点那一行图标里面,小手机旁边的滔博标志
    注意几个地方

    在这里插入图片描述

    这里选自己sdk的路径,打开SDK Tool选这几个包,都勾上,下载。

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    如果还有这个问题:Flutter requires Android SDK 28 and the Android BuildTools 28.0.3.

    你需要下载:

    打开SDK Platforms,下载这个:

    在这里插入图片描述

    再下载
    在这里插入图片描述

    升级一下android manager

    /Users/***/Android/sdk/tools/bin/sdkmanager --update,路径在自己android sdk bin目录下

    重新flutter doctor看看
    在这里插入图片描述

    第一个和第二个对勾绿了就好了。

    五.Dart sdk

    在这里插入图片描述

    目前版本的flutter以及包含了完整的dartSDK,无需专门下载了

    六.vscode

    在这里插入图片描述
    在这里插入图片描述

    在vscde里下载dart和flutter插件,下载好就ok了

    展开全文
  • Flutter安装

    2020-09-17 14:35:11
    安装前准备:Android Studio 、VS Code、Git 1. 使用镜像 添加用户环境变量: FLUTTER_STORAGE_BASE_URL = https://storage.flutter-io.cn PUB_HOSTED_URL=https://pub.flutter-io.cn 2.git克隆flutter git clone -b...

    安装前准备:Android Studio 、VS Code、Git

    1. 使用镜像

    添加用户环境变量:
    FLUTTER_STORAGE_BASE_URL = https://storage.flutter-io.cn
    PUB_HOSTED_URL=https://pub.flutter-io.cn

    2.git克隆flutter

    git clone -b stable https://github.com/flutter/flutter.git
    避坑:在克隆flutter前先执行git config --global http.postBuffer 2097152000 重新设置通信缓存大小
    不然容易等很久还克隆失败
    ps:如果出现Unable to find git in your PATH错误, 添加系统环境变量Path:git安装目录的bin文件夹(例如:C:\Program Files\Git\bin)
    这个过程很慢很慢很慢。。。

    3.执行flutter doctor

    在Flutter安装目录下找到flutter_console.bat,双击运行并启动flutter命令行
    在这里插入图片描述

    坑1:Android Studio没有安装Dart和Flutter扩展
    在这里插入图片描述
    在这里插入图片描述

    坑2:VS Code没有安装Flutter扩展
    在这里插入图片描述

    手机USB连接电脑
    坑3:没有连接真机设备

    手机USB连接电脑
    开启开发者模式
    启动USB调试,USB配置不要设置为仅充电/不进行数据传输,设置为USB网络共享
    询问是否允许USB调试,允许。
    在这里插入图片描述

    4.OK!

    在连接着真机的时候再次执行flutter doctor
    在这里插入图片描述

    展开全文
  • flutter安装 第一步安装 参考了大佬的安装教程,包含安装flutter插件和Dart插件:https://blog.csdn.net/qq_43652113/article/details/109147765 第二部添加设备 添加设备,可以在Android studio 中右上角...
    • flutter安装

    1. 安装
      参考了大佬的安装教程,包含安装flutter插件和Dart插件:https://blog.csdn.net/qq_43652113/article/details/109147765
    2. 添加设备
      添加设备,可以在Android studio 中右上角点击AVD Manage 选择一个设备进行下载,等待
    3. 启动
      设备添加完毕,直接点击启动,即可以看到官方提供的模板
    4. 使用:
      1. 在项目路径 ->  cmd ->  flutter pub get (类型于npm install)
      2. 启动项目(flutter run /  Android studio 小绿标)中可能会报错:大概内容是connection timed out:connect
        解决办法:下载gradle-6.3-all.zip压缩包
        修改配置文件:android\gradle\wrapper
      3. E:\lolordProject\04-Activity\00-SourceCode\eventChckApp\eventapp\android\gradle\wrapper\gradle-wrapper.properties   ->  file:/F://flutter/gradle-6.3-all.zip
    • flutter依赖

    1. 在根目录下找到pubspec.yaml文件
    2. 找到dependencies
      dependencies:
        flutter:
          sdk: flutter
       
       
        # The following adds the Cupertino Icons font to your application.
        # Use with the CupertinoIcons class for iOS style icons.
        cupertino_icons: ^1.0.0
        english_words: ^3.1.0    //我要添加的依赖
    3. 在terminal执行:flutter packages get,等待即可

    • flutter达成apk包,安装测试

    1.  flutter build apk --debug

    所遇到问题

    • 在添加图片的时候,一直提示找不到图片;

      1. 在根目录下创建images文件夹
      2.  
      3. pubspec.yaml文件进行配置
    • 在启动时遇到一个错误:Execution failed for task ':app:mergeDexDebug'.

    解决办法:在android/app/build.gradle文件中加入代码:

    dependencies {
      compile 'com.android.support:multidex:1.0.3' 
      //find latest version from here https://developer.android.com/studio/build/multidex
    }
     
    android {
        defaultConfig {
            multiDexEnabled true
        }
    }

    • 直接复制代码在另外电脑上运行,因为没有进行配置,出现了:Failed to install the following Android SDK packages as some licenses have not been accepted.

    解决办法:

    1. 一般在错误里面会有一个路径提示,进入路径
    2. 在路径中进入bin目录(在没有更新sdkmanager之前,需要执行 ./sdkmanager --update)
    3. win + R ,输入cmd
    4. 执行 sdkmanager --license 会一直提示y/N ,一直y就可以了
    5. 最好是重启一下Andriod studio

         

    • 在导入新的项目时,首先肯定是执行flutter pub get,导入依赖,但是一直报错:

    提示dart版本过低

    我的错误示范:File -> Settings -> Languages & Frameworks -> Dart -> Dart SDK path中直接修改,当时已经修改为2.13版本,但是重新执行 flutter pub get时,还是会报同样的错误,执行 flutter --version 查看dart版本,并未修改成功。 

    正确做法:因为flutter是包含dart的,所以需要重新导入flutter,并且重新配置

    1. 下载 flutter     flutter下载地址:https://flutter.dev/docs/development/tools/sdk/releases
    2. 解压,最好是放在C盘以外的其他盘
    3. 电脑属性 -> 高级系统配置 -> 环境变量 -> path中添加解压后flutter的bin目录
    4. 在flutter目录下执行 flutter doctor
    5. 可以执行 flutter --version ,查看当前dart版本
    6. 在Android studio中 File -> Settings -> Languages & Frameworks -> Flutter -> Flutter SDK path 修改成解压文件夹路径
    7. 重启即可(最好是重启电脑)

    如果提示gradle版本的问题,那么重新下载指定版本,不需要解压,直接放入配置文件中即可

    gradle的下载地址:https://services.gradle.org/distributions/

    展开全文
  • Flutter安装(环境搭建)

    千次阅读 2019-11-04 21:52:21
    毫无疑问Flutter即将或已经成为跨平台的主流。
  • Flutter Installer是使用Flutter构建的Flutter安装程序Install Flutter Installer Flutter Installer是使用Flutter构建的Flutter安装程序:victory_hand:特点使用GUI界面安装Flutter,对初学者和专家都很有帮助...
  • Flutter安装教程

    2020-03-31 16:44:46
    Flutter框架是谷歌的移动UI框架, 如今正在被越来越多的人熟知和使用. 它可以在ios和android上快速构建高质量的原生用户界面, 且性能方面比react-native要高. 不过对于前端来说比RN更难入门. 因为RN用的是javaScript...
  • flutter安装与环境配置flutter安装与环境配置添加国内镜像获取flutter SDK获取Android SDK安装xcodevscode插件安装 flutter安装与环境配置 你好! 这是你第一次使用 Markdown编辑器 所展示的欢迎页。如果你想学习...
  • 这个库主要是一些Flutter学习资料,个人总结,项目示例代码。如果你想快速学习Flutter,欢迎看这个库,对你很有帮助的。喜欢的话就给个Star ,谢谢。欢迎大家多提意见,帮忙完善这个库。如果有问题,欢迎提问题。想...
  • Flutter安装入门教程

    千次阅读 2019-07-07 08:56:22
    前言 Flutter是谷歌的移动UI框架,可以快速在iOS和Android上构建高质量的原生...我本人也是非常安好Flutter,所以也进入到了Flutter学习行列啦,今天主要讲一下Flutter安装,具体包括: Flutter需要配置的工具 Fl...
  • Flutter安装依赖包

    千次阅读 2020-07-31 11:17:35
    1、添加依赖 在pubspec.yaml文件,dependencies...2、安装依赖包 flutter packages get 此时会自动在pubspec.lock文件中列出已经下载到本项目的包和他们的版本等信息 然后就可以在需要的地方去信用。 3、引入 import
  • 一。准备软件包 1.windows >... 2。下载好Flutter sdk后,我们就要动手安装咯!... 将安装包zip解压到你想...注意,不要将flutter安装到需要一些高权限的路径如C:\Program Files\)。 这是解压后存放的目录地址 ...
  • Flutter安装踩坑教程

    2020-05-27 22:46:23
    文章目录Flutter安装过程中的坑差不多都踩了选定想安装的目录cmd配置环境配置Java版本在flutter目录下打开flutter_console.bat配置Android Studio在Android Studio中导入flutter,并创建一个flutter项目 Flutter安装...
  • 1.安装flutter插件 2.安装dart 3下载flutter sdk 去flutter官网下载其最新可用的安装包,点击下载; 注意,Flutter的渠道版本会不停变动,请以Flutter官网为准。另外,在中国大陆地区,要想正常获取安装包...
  • Flutter 安装 (Mac)

    千次阅读 2018-06-26 19:19:19
    看到Flutter之后,就想试试,在安装期间出现各种问题,看了很多教程,总是不太详细,对新手不太友好啊,就把自己在安装过程中碰到的坑,大致记了一下,做了一个总结。 一、安装Flutter 大家都知道的一个共识,...
  • Flutter - 极速构建漂亮的原生应用 Flutter是谷歌的移动UI框架,可以快速在iOS和Android上构建高质量的原生用户界面。 Flutter可以与现有的代码一起工作。在全世界,Flutter正在被越来越多的开发者和组织使用,并且...
  • 如何查看Dart 和 Flutter安装路径

    千次阅读 2021-03-07 11:35:30
    环境:Win 10 +Flutter SDK(已配置环境变量) win + R 进入运行输入CMD回车进入命令行 输入:where flutter dart 或者which flutter dart 回车,即可看到,如下图; 注意:where 命令获取的路径一般都是在环境...
  • 国内下载flutter安装依赖实在是太太太太太慢了!!!简直无法忍受!!! 解决方案 下面是国内几个镜像,PUB_HOSTED_URL是Dart依赖包地址,FLUTTER_STORAGE_BASE_URL是Flutter依赖文件地址。 下载安装包 要手动下载...
  • Flutter 安装 (Mac环境)

    万次阅读 2018-06-22 00:47:05
    Flutter 安装 今天偶然看到一个公众号写了一篇关于Flutter 的文章, 感觉挺好, 所以就来尝试一下, 整个安装过程挺简单, 但也不是特别顺利, 因为我自己使用的是Mac系统所以这里所有操作都是Mac系统下的操作 安装...
  • Flutter安装及开发环境配置(Mac版)

    万次阅读 2020-09-11 11:23:57
    Flutter安装及开发环境配置,以及Android Studio 配置,为你的第一个Flutter程序准备好开发环境。
  • flutter安装过程的坑

    2019-12-26 18:28:40
    1、cmd 的时候出现 :Error: Unable to find git in your PATH. 的错误提示; 解决方法,打开环境变量,“用户变量”下,新建变量名:Path,变量值:E:\Git\bin\git.exe;E:\Git\cmd;...表明flutter ...
  • Flutter安装第三方库

    2020-08-04 17:40:20
    4.找到项目的pubspec.yaml文件,在dependencies下面添加刚刚复制的内容,ctrl+s保存,编译器会自动执行flutter packages get命令,如果没有报错就是安装成功了 5.点击Example,里面有引入类库方法和使用示例 ...
  • Flutter安装遇到的问题解决办法 这里只说明其中一些遇到的问题及解决办法,其他详细安装步骤请参考官方文档。 官方文档地址:Flutter中文,Flutter英文 1. brew安装Ios运行环境报错问题 当我们运行flutter doctor...
  • Flutter安装详解 as版本

    千次阅读 2019-04-02 21:07:37
    1 第一步下载flutter sdk 选择我们需要下载flutter sdk 的目录鼠标右键打开 Git BashHere 输入以下文字 点击回车 等待下载完成即可。 git clone -b alpha https://github.com/flutter/flutter.git 2.配置...
  • 2.下载flutter 安装包 解压到安装的位置最好不要将 Flutter 安装在需要高权限的文件夹内,例如C:\Program Files\。 解压后打开文件夹--点击flutter console看能否打开 3.记得配置用户环境变量ANDROID_HOME= D:\xx\...
  • 这篇主要是简单版的Flutter安装配置,写了: Flutter 安装 环境变量配置 Flutter vscode 配置 Flutter new Demo and run Flutter 安装 准备:首先在你的Mac上必须还有700M的空间(下载的SDK有600M)、并且有一...
  • 1、进入到根目 cd 2、打开.bash_profile : open .bash_profile 在 .bash_profile 中编辑: export PATH=文件夹路径/flutter/bin:$PATH 3、刷新 source .bash_profile

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,933
精华内容 4,773
关键字:

flutter安装