精华内容
下载资源
问答
  • IPv6

    2019-04-02 21:08:03
    无论是NAT,还是CIDR 等都是缓解IP 地址短缺的手段,...1.1 IPV6优点 IPv4的设计思想成功地造就了目前的国际Internet,其核心价值体现在简单、灵活和开放性。但随着新应用的不断涌现,传统的IPv4协议已经难以支持...

    无论是NAT,还是CIDR 等都是缓解IP 地址短缺的手段,而IPv6 才是解决地址短缺的最终方法。IPv6是由IETF设计的下一代Internet协议,目的是取代现有的Internet协议IPv4。

    1 IPv6概述

    1.1 IPV6优点

      IPv4的设计思想成功地造就了目前的国际Internet,其核心价值体现在简单、灵活和开放性。但随着新应用的不断涌现,传统的IPv4协议已经难以支持Internet的进一步扩张和新业务的特性,如时应用和服务质量保证等。IPv6能够解决IPv4存在的许多问题,如地址短缺和服务质量保证等。同时IPv6还对IPv4进行了大量的改进,包括由和网络自幼配置等IPv6和IPv4将在过渡期内存几年,并由IPv6渐渐取代IPv4。IPv6的特点如下:

    ①128比特的地址方案为将来数十年提供了足够的地址空间;

    ②充足的地址空间将极大地满足那些伴随着网络智能设备的出现而对地址增加的需求,例如个人数据助理、移动电话和家庭网络接入设备等;

    ③多等级编址层次有助于路由聚合,提高了路由选择的效率和可扩展性;

    ④自幼配置使得在Internet上大规模布置新设备成为可能;

    ⑤ARP广播被本地链路多播代替;

    ⑥IPv6对数据包头进行了简化,以减少处理器开销节省网络带宽;

    ⑦IPv6中流标签字段可以提供流量区域;

    ⑧IPv6的组播可以区分永久性与临时性地址,更有利于组播功能的实现;

    ⑨IPv6地址本身的分层体系更加支持域名解析体系中得制集聚和地址更改;

    ⑩IPv6协议内置安全机制并已经标准化;

    (11)IPv6协议能更好地支持移动性;

    (12)IPv6提供了更加优秀的QoS保障 ;

    (13)IPv6中没有广播地址,它的功能正在被组播地址所代替。

     

    1.2 IPv6地址

     

    IPv4地址表示为点分十进制数据格式,而IPv6采用冒号十六进制数据格式。例如:2007;00dd3;0000;2F3B;02BB;00FF;FE28;2000 是一个完整的IPv6地址。

    【提示】

    ①IPv6地址中每个16位分组的前导零位可以去除做简化表示 ;

    ②可以将冒号分十六进制数据格式中相邻的连续零位合并,用双冒号”∷”表示;

    ③要在一个URL中使用文本IPv6地址,文本地址应该用符号 “[“ 和 “]” 来封闭。

     

      IPv6地址3种类型:单播、任意播和组播,在每种地址中,又有一个种或者多种类型的地址,如单播有本地链路地址、本地站点地址、可聚合全球地址、回环地址和末指定地址;任意播有本地链路地址、本地站点地址和可聚合全球地址;多播有指定地址和请求节点地址。下面主要介绍几个常用地址类型。

    (1)本地链路地址

    在一个节点上起用IPv6协议栈,当启动时,节点的每个接口自动配置一个本地,前缀为FE80V∷/10。

    (2)本地站点地址

    本地站点地址与RFC1918所定义的私有IPv4地址空间类似,因此,本地站点地址不能在全球IPv6 Internet上路由,前缀为FEC0∷/10。

    (3)可聚合全球单播地址

    IANA分配IPv6寻址空间中的一个IPv6地址前缀作为可聚合全球单播地址。

    (4)IPv4兼容地址

    与IPv4兼容的IPv6地址是由过度机制使用的特殊单播IPv6地址,目的是在主机和路由器上自动创建IPv4隧道以上IPv4网络传送IPv6数据包。

    (5)回环地址

    单播地址0;0;0;0;0;0;0;1 称为回环地址,节点用它来向自身发送IPv6包。它不能分配给任何物理接口。

    (6)不确定地址

    单播地址0;0;0;0;0;0;0;0 称为不确定地址,它不能分配给任何节点。

    (7)多播指定地址

    RFC2373 在多播范围内为IPv6协议的操作定义和保留了几个IPv6地址,这些保留地址称为多播指定地址。

    (8)请求节点地址

    对于节点或路由器的接口上配置每个单播和任意播地址,都自动启动一个对应的被请求节点地址。被请求节点地址手限于本地链路。

    2 IPv6路由

    2.1  实验1:IPv6静态路由

     

    1.实验目的

     

    通过本实验可以掌握:

    ①启用IPv6流量转发;

    ②配置IPv6地址;

    ③IPv6静态路由配置和调试;

    ④IPv6默认路由配置和调试。

     

    2.实验拓扑图如图22-1所示

    图22-1 IPv6静态路由

     

    3.实验步骤

     

    (1)步骤1:配置路由器R1

    R1(config)#ipv6 unicast-routing
    
    R1(config)#interface Loopback0
    
    R1(config-if)#ipv6 address 2006;AAAA∷1/64
    
    R1(config)#interface Loopback1
    
    R1(config-if)#ipv6 address 2006;BBBB∷1/64
    
    R1(config)#interface Serial0/0/0
    
    R1(config-if)#ipv6 address 2007;CCCC∷1/64
    
    R1(config-if)#no  shutdown
    
    R1(config)#ipv6 address 2008;DDDD∷/64 Serial0/0/0   //配置IPv6静态路由
    
    
    
    (2)步骤2:配置路由器R2
    
    
    
    R2(config)#ipv6 unicast-routing
    
    R2(config)#interface Loopback0
    
    R2(config-if)#ipv6 address 2008;DDDD∷1/64
    
    R2(config)#interface Loopback1
    
    R2(config-if)#ipv6 address 2008;CCCC∷1/64
    
    R2(config)#interface Serial0/0/0
    
    R2(config-if)#ipv6 address 2007;CCCC∷1/64
    
    R2(config-if)#clockrate 128000
    
    R2(config-if)#no  shutdown
    
    R2(config)#ipv6 route∷/0 Serial0/0/0           配置IPv6默认路由

     

    4.实验调试

    (1)show ipv6 interface

    该命令来查看IPv6的接口信息。

    R1#show ipv6 interface s0/0/0

    Serial0/0/0 is up,line protocol is up

     IPv6 is enabled,link-local address is FE80∷C800;BFF;FE80;0

    //本接口启用IPv6,本地链路地址自动配置

    Global unicast address(es);

      2007;CCCC∷1,subnet is 2007;CCCC∷/64

    //全球聚合地址

    Joined group address(es);

      FF02∷1

    //表示本地链路上的所有节点和路由器

      FF02∷2

    //表示本地链路上的所有路由器

      FF02∷1;FF00;1

    //用于替换ARP机制的被请求节点的多播地址

      FF02∷1FF80;0

    //与单播地址2007;CCCC∷1相关的被请求节点多播地址

      MTU is 1500 bytes

      ICMP error messages limited to one every 100 milliseconds

      ICMP redirects are enabled

    //启用ICMP重定向

      ND DAD is enabled,number of DAD attempts;1

    //邻居发现和重复地址检测启动

      ND reachable time is 30000 miliseconds

    //ND 可达时间

      Hosts use stateless autoconfig for addresses.

    //使用无状态自动配置地址

     

    (2)show ipv6 route

     

    该命令用来查看IPv6路由表。

     

    R1#show ipv6 route

    IPv6 Routing Table - 9 entries

    Codes;C - Connectd,L - Local,S - Static,R -RIP,B - BGP

          U - Per-user Static route,M - MIPv6

          I1- ISIS L1,I2-ISIS L2,IA-ISIS interarea,IS-ISIS summary

          O - OSPF intra,O1-OSPF inter,OE1-OSPF ext 1,OE2-OSPF ext 2

          ON1 -OSPF NSSA ext 1,ON2-OSPF NSSA ext 2

          D - EIGRP,EX - EIGRP external

      C  2006;AAAA∷/64[0/0]

         via∷,Loopback0

      L  2006;AAAA∷/128[0/0]

         via∷,Loopback0

      C  2006;BBBB∷/64[0/0]

         via∷,Loopback1

      L  2006;BBBB∷/128[0/0]

         via∷,Loopback1

      C  2007;CCCC∷/64[0/0]

         via∷,Serial0/0/0

      L  2007;CCCC∷/128[0/0]

         via∷,Serial0/0/0

      S  2008;DDDD∷/64[0/0]

         via∷,Serial0/0/0

      L  FE80∷/10[0/0]

          via∷Null0

      L  FF00∷/8[0/0]

          via∷Null0

     

    R2#show ipv6 route

    IPv6 Routing Table - 9 entries

    Codes;C - Connectd,L - Local,S - Static,R -RIP,B - BGP

          U - Per-user Static route,M - MIPv6

          I1- ISIS L1,I2-ISIS L2,IA-ISIS interarea,IS-ISIS summary

          O - OSPF intra,O1-OSPF inter,OE1-OSPF ext 1,OE2-OSPF ext 2

          ON1 -OSPF NSSA ext 1,ON2-OSPF NSSA ext 2

          D - EIGRP,EX - EIGRP external

      S  ∷/0[1/0]

         via ∷,Serial0/0/0

      C  2007;CCCC∷/64[0/0]

         via ∷,Serial0/0/0

      L  2007;CCCC∷2/128[0/0]

         via ∷,Serial0/0/0

      C  2008;DDDD∷/64[0/0]

         via ∷,Loopback0

      L  2008;DDDD∷2/128[0/0]

         via ∷,Loopback0

      L  FE80∷/10[0/0]

          via∷,Null0

      L  FF00∷,Null0

     以上输出表明路由器R1上有一条IPv6的静态路由,R2上有一条IPv6的静态路由,R2上有一条IPv6的默认路由,IPv6中的默认路由是没有”*”的。

    (3)ping

     

    R2#ping ipv6 2006;AAAA∷1

    Type escape sequence to abort

    Sending 5,100-byte ICMP Echos to 2006;AAAA∷1,timeout is 2 seconds;

    !!!!!

    Success rat is 100 percent (5/5),round-trip min/avg/max=24/72/124 ms

     

    2.2 实验2:IPV6 RIPng

     

    实验目的

     

    通过本实验可以掌握:

     

    ①启用IPv6流量转发;

    ②向RIPng 网络注入默认路由;

    ③RIPng 配置和调试。

     

    2.拓扑结构

    实验拓扑图如图22-2所示。

     

    图22-2 IPv6 RIPng配置

     

    3.实验步骤

     

    (1)步骤1:配置路由器R1

    
    R1(config)#ipv6 unicast-routing
    
    R1(config)#ipv6 router rip cisco        //启用IPv6 RIPng 进程
    
    R1(config-rtr)#Split-horizon            //起用水平分割
    
    R1(config-rtr)#poison-reverse           //启用毒化反转
    
    R1(config)#interface Loopback0
    
    R1(config-if)#ipv6 address 2006;1111∷1/64
    
    R1(config-if)#ipv6 rip cisco enable     //在接口上启用RIPng
    
    R1(config)#interface Serial0/0/0
    
    R1(config-if)#ipv6 address 2007;12∷1/64
    
    R1(config-if)#ipv6 rip cisco enable
    
    R1(config-if)#ipv6 rip cisco default-information originate
    
    //向 IPv6 RIPng 区域注入一条默认路由(∷/0)
    
    R1(config-if)#no shutdown
    
    R1(config)#ipv6 route∷/0 Loopback0    //配置默认路由
    
    
    
    【提示】
    
    “ipv6 rip cisco default-information only”命令也可以向IPv6 RIPng 区域注入一条默认路由,但是该命令只从该接口发送默认的IPv6路由,而该接口其他的IPv6 的RIPng 路由都被抑制了。
    
    
    
    (2)步骤2:配置路由器R2
    
    
    
    R2(config)#ipv6 unicast-routing
    
    R2(config)#ipv6 router rip cisco
    
    R2(config-rtr)#split-horzon
    
    R2(config-rtr)#poison-reverse
    
    R2(config)#interface Serial0/0/0
    
    R2(config-if)#ipv6 address 2007;12∷2/64
    
    R2(config-if)#ipv6 rip cisco enable
    
    R2(config-if)#clock rate 128000
    
    R2(config-if)#no shutdown
    
    R2(config)#interface Serial0/0/1
    
    R2(config-if)#ipv6 address 2007;23∷2/64
    
    R2(config-if)#ipv6 rip cisco enable
    
    R2(config-if)#clock rate 128000
    
    R2(config-if)#no shutdown
    
    
    
    (3)步骤3:配置路由器R3
    
    
    
    R3(config)#ipv6 unicast-routing
    
    R3(config)#ipv6 router rip cisco
    
    R3(config-rtr)#split-horzon
    
    R3(config-rtr)#poison-reverse
    
    R3(config)#interface Serial0/0/0
    
    R3(config-if)#ipv6 address 2007;34∷3/64
    
    R3(config-if)#ipv6 rip cisco enable
    
    R3(config-if)#clockrate 128000
    
    R3(config-if)#no shutdown
    
    R3(config)#interface Serial0/0/1
    
    R3(config-if)#ipv6 address 2007;23∷3/64
    
    R3(config-if)#ipv6 rip cisco enable
    
    
    
    R3(config-if)#no shutdown
    
    
    
    (4)步骤4:配置路由器R4
    
    
    
    R4(config)#ipv6 unicast-routing
    
    R4(config)#ipv6 router rip cisco
    
    R4(config-rtr)#split-horzon
    
    R4(config-rtr)#poison-reverse
    
    R4(config)#interface Loopback0
    
    R4(config-if)#ipv6 address 2008;4444∷4/64
    
    R4(config-if)#ipv6 rip cisco enable
    
    R4(config)#interface Serial0/0/0
    
    R4(config-if)#ipv6 address 2007;34∷4/64
    
    R4(config-if)#ipv6 rip cisco enable
    
    R4(config-if)#no shutdown

    4.实验调试

     

    (1)show ipv6 route

     

    R2#show ipv6 route

    IPv6 Routing Table - 9 entries

    Codes;C - Connectd,L - Local,S - Static,R -RIP,B - BGP

          U - Per-user Static route,M - MIPv6

          I1- ISIS L1,I2-ISIS L2,IA-ISIS interarea,IS-ISIS summary

          O - OSPF intra,O1-OSPF inter,OE1-OSPF ext 1,OE2-OSPF ext 2

          ON1 -OSPF NSSA ext 1,ON2-OSPF NSSA ext 2

          D - EIGRP,EX - EIGRP external

     R  ∷/0 [120/2]

        via  FE80∷C800;AFF;FE90;0,Serial0/0/0

     R  2006;1111∷/64[120/2]

        via FE80∷C800;AFF;FE90;0,Serial0/0/0

     C  2007;12∷/64[0/0]

        via∷,Serial0/0/0

     L  2007;12∷2/128[0/0]

        via∷,Serial0/0/1

     C  2007;12∷/64[0/0]

        via∷,Serial0/0/0

     L  2007;12∷2/128[0/0]

        via∷,Serial0/0/1

     R  2007;34∷/64[120/2]

        via FE80∷C802;AFF;FE90;0,Serial0/0/1

     

     

     R  2008;4444∷/64[120/3]

        via FE80∷C802;AFF;FE90;0,Serial0/0/1  

     L  FE80∷/10[0/0]

         via∷,Nnll0

     L  FF00∷/8[0/0]

         via∷,Nnll0

     

      以上输出表明R1确实向IPv6 RIPng 网络注入一条IPv6的默认路由,同时收到3条 IPv6 RIPng 路由条目,而且所有 IPv6 RIPng 路由条目的下一跳地址均为邻居路由器接口的”Iink-local”地址。可以通过”show ipv6 rip next-hops”命令查看RIPng 的下一跳地址。

     

    R2#show ip ipv6 next-hops

     RIP process “cisco”,Next Hops

      FE80∷C800;AFF;FE90;0/Serial0/0/0[3 patahs]

      FE80∷C802;AFF;FE90;0/Serial0/0/1[3 patahs] 

     

    (2)show IP Protocols

     

    R2#show ipv6 protocols

    IPv6 Routing Protocol is “connected”

    IPv6 Routing Protocol is “static”

    IPv6 Routing Protocol is “rip cisco”

      Interfaces;

         Serial0/0/1

         Serial0/0/0

      Redistribution;

         None

     

      以上输出表明启动的IPv6 RIPng进程为Cisco,同时在Serial0/0/1和Serial0/0/1  接口上启用RIPng。

     

    (3)show ipv6 rip database

    该命令用来查看RIPng的数据库。

     

    R2#show ipv6 rip database

    RIP process”cisco” RIB

     2006;1111∷/64,metric 2,installed

          Serial0/0/0FE80∷C800;AFF;FE90;0,expires in 178 secs

     2007;12∷/64,metric 2

          Serial0/0/0FE80∷C800;AFF;FE90;0,expires in 178 secs

     2007;23∷/64,metric 2

          Serial0/0/1FE80∷C802;AFF;FE90;0,expires in 168 secs

     2007;34∷/64,metric 2,installed

          Serial0/0/1FE80∷C802;AFF;FE90;0,expires in 168 secs

     

     2008;4444∷/64,metric 3,installed

          Serial0/0/1FE80∷C802;AFF;FE90;0,expires in 168 secs

     ∷/0,metric 2,installed

          Serial0/0/0FE80∷C800;AFF;FE90;0,expires in 178 secs

     

      以上输出显示了R2的RIPng的数据库。

     

    (4)debug ipv6 rip

    该命令用来动态查看RIPng的更新。

     

    R2#debug ipv6 rip

    RIP Routing Protocol debugging is on

    R2#debug ipv6 route *

     *Feb 15 14;17;34.851;RIPng;Sending multicast update on Serial0/0/1 for cisco

     *Feb 15 14;17;34.851;      src=FE02∷C801;AFF;FE90;0

     *Feb 15 14;17;34.855;      dst=FE02∷9(Serial0/0/1)

     *Feb 15 14;17;34.855;      sport=521,dport=521,length=92

     *Feb 15 14;17;34.859;      command=2,version=1,mbz=0,#rte=4

     *Feb 15 14;17;34.859;      tag=0,metric=2,prefix=2006;1111∷/64

     *Feb 15 14;17;34.859;      tag=0,metric=1,prefix=2007;12∷/64

     *Feb 15 14;17;34.863;      tag=0,metric=1,prefix=2007;23∷/64

     *Feb 15 14;17;34.853;      tag=0,metric=1,prefix=∷/0

     *Feb 15 14;17;34.867;RIPng;Sending multicast update on Serial0/0/1 for cisco

     *Feb 15 14;17;34.867;      src=FE80∷C801;AFF;FE90;0

     *Feb 15 14;17;34.871;      dst=FE02∷9(Serial0/0/0)

     *Feb 15 14;17;34.871;      sport=521,dport=521,length=92

     *Feb 15 14;17;34.871;      command=2,version=1,mbz=0,#rte=4

     *Feb 15 14;17;34.875;      tag=0,metric=1,prefix=2007;12∷/64

     *Feb 15 14;17;34.875;      tag=0,metric=1,prefix=2007;23∷/64

     *Feb 15 14;17;34.879;      tag=0,metric=2,prefix=2007;34∷/64

     *Feb 15 14;17;34.879;      tag=0,metric=3,prefix=2008;4444∷/64

     *Feb 15 14;17;43.439;RIPng;response received from FE80∷C800;AFF;FE90;0 on Serial0/0/0 for cisco

     *Feb 15 14;17;43.443;      src=FE80∷C801;AFF;FE90;0(Serial0/0/0)

     *Feb 15 14;17;43.443;      dst=FE02∷9

     *Feb 15 14;17;43.447;      sport=521,dport=521,length=72

     *Feb 15 14;17;43.447;      command=2,version=1,mbz=0,#rte=3

     *Feb 15 14;17;43.447;      tag=0,metric=1,prefix=2007;1111∷/64

     *Feb 15 14;17;43.871;      tag=0,metric=1,prefix=2007;12∷/64

     *Feb 15 14;17;43.451;      tag=0,metric=1,prefix=∷/0

     *Feb 15 14;17;57.815;RIPng;response received from FE80∷C802;AFF;FE90;0 on Serial0/0/1 for cisco

     *Feb 15 14;17;57.819;      src=FE80∷C802;AFF;FE90;0(Serial0/0/1)

     *Feb 15 14;17;57.819;      dst=FE02∷9

     *Feb 15 14;17;57.823;      sport=521,dport=521,length=72

     

    * Feb 15 14;17;57.823;      command=2,version=1,mbz=0,#rte=3

     *Feb 15 14;17;57.823;      tag=0,metric=1,prefix=2007;23∷/64

     *Feb 15 14;17;57.827;      tag=0,metric=1,prefix=2007;34∷/64

     *Feb 15 14;17;57.827;      tag=0,metric=2,prefix=2008;4444∷/64

     

      以上输出显示路由器 R2发送和接收RIPng的信息。

     

    2.3实验3:OSPFv3

     

    1.实验目的

     

    通过本实验可以掌握:

    ①启用IPv6流量转发;

    ②向OSPFv3网络注入默认路由;

    ③OSPFv3多区域配置和调试

     

    2.拓扑结构

    实验拓扑图22-3所示。

     

       图22-3  OSPFv3P配置

     

    3.实验步骤

    1)步骤:配置路由器R1
    
    
    
    R1(config)#ipv6 unicast-routing
    
    R1(config)#ipv6 router ospf 1       //启用OSPFv3 路由进程
    
    R1(config-rtr)#router-id 1.1.1.1    //定义路由器ID
    
    R1(config-rtr)#default-information originate metric 30 metric-type 2
    
                                        //向OSPFv3网络注入一条默认路由
    
    R1(config)#interface Serial0/0/0
    
    R1(config-if)#ipv6 address 2007;12∷1/64
    
    R1(config-if)#ipv6 ospf 1 area 1    //接口上启用OSPFv3,并声明接口所在区域
    
    R1(config-if)no shutdown
    
    
    
    
    
    R1(config)#ipv6 route∷/0 s0/0/1    //配置默认路由
    
    
    
    (2)步骤: 配置路由器R2
    
    
    
    R2(config)#ipv6 unicast-routing
    
    R2(config)#ipv6 router ospf 1      
    
    R2(config-rtr)#router-id 2.2.2.2
    
    R2(config)#interface Serial0/0/0
    
    R2(config-if)#ipv6 address 2007;12∷2/64
    
    R2(config-if)#ipv6 ospf 1 area 1
    
    R2(config-if)#clock rate 128000
    
    R2(config-if)#no shutdown
    
    R2(config)#interface Serial0/0/1
    
    R2(config-if)#ipv6 address 2007;23∷2/64
    
    R2(config-if)#ipv6 ospf 1 area 0
    
    R2(config-if)#closck rate 128000
    
    R2(config-if)#no shutdown
    
    
    
    (3)步骤: 配置路由器R3
    
    
    
    R3(config)#ipv6 unicast-routing
    
    R3(config)#ipv6 router ospf 1      
    
    R3(config-rtr)#router-id 3.3.3.3
    
    R3(config)#interface Serial0/0/0
    
    R3(config-if)#ipv6 address 2007;34∷3/64
    
    R3(config-if)#ipv6 ospf 1 area 2
    
    R3(config-if)#clock rate 128000
    
    R3(config-if)#no shutdown
    
    R3(config)#interface Serial0/0/1
    
    R3(config-if)#ipv6 address 2007;23∷3/64
    
    R3(config-if)#ipv6 ospf 1 area 0
    
    R3(config-if)#no shutdown
    
    
    
    (4)步骤4:配置路由器R4
    
    
    
    R4(config)#ipv6 unicast-routing
    
    R4(config)#ipv6 router ospf 1      
    
    R4(config-rtr)#router-id 4.4.4.4
    
    R4(config)#interface gigabitEthernet0/0
    
    R4(config-if)#ipv6 address 2007;4444∷4/64
    
    R4(config-if)#ipv6 ospf 1 area 2
    
    R4(config-if)#no shutdown
    
    R4(config)#interface Serial0/0/0
    
    R4(config-if)#ipv6 address 2007;34∷4/64
    
    
    
    
    
    R4(config-if)#ipv6 ospf 1 area 0
    
    R4(config-if)#no shutdown

     

    4.实验调试

     

    (1)show ipv6 route

     

    R4#show ipv6 route

    IPv6 Routing Table - 9 entries

    Codes;C - Connectd,L - Local,S - Static,R -RIP,B - BGP

          U - Per-user Static route,M - MIPv6

          I1- ISIS L1,I2-ISIS L2,IA-ISIS interarea,IS-ISIS summary

          O - OSPF intra,O1-OSPF inter,OE1-OSPF ext 1,OE2-OSPF ext 2

          ON1 -OSPF NSSA ext 1,ON2-OSPF NSSA ext 2

          D - EIGRP,EX - EIGRP external

     OE2  ∷/0 [110/30],tag 1

          via  FE80∷C800;AFF;FE90;0,Serial0/0/0

     OI   2007;12∷/64[110/192]

          via FE80∷C800;AFF;FE90;0,Serial0/0/0

     OI   2007;23∷/64[110/128]

          via FE80∷C802;AFF;FE90;0,Serial0/0/0

     C    2007;34∷/64[0/0]

          via∷,Serial0/0/0

     L    2007;12∷4/128[0/0]

          via∷,Serial0/0/0

     C    2008;4444∷4/64[0/0]

          via∷,GigabitEthernet0/0

     L    2008;4444∷4/128[0/0]

          via∷,GigabitEthernet0/0

     L    FE80∷/10[0/0]

          via∷,Null0

     L    FE00∷/8[0/0]

          via∷,Null0

     

      以上输出表明OSPFv3的外部路由代码为”OE2”或”OE1”,区域间路由代码为”OI”,区域内路由代码为”O”。

     

    (2)show ip protocols

     

    R2#show ipv6 protocols

    IPv6 Routing Protocol is “connected”

    IPv6 Routing Protocol is “staic”

    IPv6 Routing Protocol is “ospf 1”

       Interfaces(Area 0);

     

     

         Serial0/0/1

       Interfaces(Area 0);

         Serial0/0/1

       Redistribution;

         None

     

      以上输出表明启动的OSPFv3进程ID为1,Serial0/0/1 和Serial0/0/0 接口上启用OSPFv3,Serial0/0/1属于区域0,Serial0/0/0属于区域1。

     

    (3)show ipv6 ospf database

     

    该命令用来查看OSPFv3拓扑结构数据库。

     

    R4#show ipv6 ospf database

     

                 OSPFv3 Router with ID(4.4.4.4)(Process ID 1)

     

                     Router Link States(Area 2)

     

    ADV Router      Age     Seq#          Fragment ID     Link count     Bits

    3.3.3.3           418     0x80000002    0               1            B

    4.4.4.4           315     0x80000004    0               1            None

     

                     Inter Area Prefix Link States(Area 2)

     

    ADV Router      Age     Seq#          Prefix

    3.3.3.3           450     0x80000001    2007;23∷/64

    3.3.3.3           440     0x80000001    2007;12∷/64

     

                     Inter Area Router Link States(Area 2)

     

    ADV Router      Age     Seq#          Link ID        Dest RtrID       

    3.3.3.3           440     0x80000001    16843009       1.1.1.1

     

                     Link(Type-8)Link States(Area 2)

     

    ADV Router      Age     Seq#          Link ID        Interface       

    4.4.4.4           415     0x80000001    3              Fa0/0

    3.3.3.3           463     0x80000001    4              Sa1/0

    4.4.4.4           437     0x80000001    3              Sa1/0

     

     

     

                     Inter Area Prefix Link States(Area 2)

     

    ADV Router      Age     Seq#          Link ID        Ref-lstype     Ref-LsID       

    3.3.3.3           463     0x80000001    0              0x2001         0

    4.4.4.4           430     0x80000002    0              0x2001         0

     

                     Type-5 AS External Link States

     

    ADV Router      Age     Seq#          Prefix

    1.1.1.1           6       0x80000013    ∷/0               

     

      以上输出显示了路由器R4的OSPFv3的拓扑结构数据库.

     

    (4)show ipv6 ospf neighbor

     

    R2#show ipv6 ospf neighbor

     

    NeighborID    Pri    State         Dead Time      InterfaceID    Interface

    3.3.3.3         1    FULL/  -      00;00;30       5              Serial0/0/1

    1.1.1.1         1    FULL/  -      00;00;37       4              Serial0/0/0

     

      以上输出表明路由器R2有两个OSPFv3的邻居.

     

    (5)show ip ospf interface

     

    R2#show ipv6 ospf interface s0/0/0

    Serial0/0/0 is up,line protocol is up

      Link Local Address FE80∷C801;AFF;FE90;0,Interface ID 4

      Area 1,Process ID 1,Instance ID 0,Router ID 2.2.2.2

      Network Type POINT_TO_POINT,Cost;64

      Transmit Delay is 1 sec,State POINT_TO_POINT,

      Timer intervals configured,Hello 10,Dead 40,Wait 40,Retransmit 5

        Hello due in 00;00;04

      Index 1/1/1,flood queue length 0

      Next 0x0(0)/0x0(0)/0x0(0)

      Last flood scan length is 1,maximum is 1

      Last flood scan time is 0 msec,maximum is 0 msec

      Neighbor Count is 1,Adjacent neighbor count is 1

        Adjacent with neighbor 1.1.1.1

      Suppress hello for 0 neighbor(s)

     

      以上输出上OSPFv3路由器接口的基本信息,和OSPFv2非常相似,包括路由器ID、网络类型、计时器的值以及邻居的数量等信息。

     

     

     

    2.2.4  实验4.IPv6 EIGRP

     

    1.实验目的

     

    通过本实验可以掌握:

    ①启用IPv6流量转发;

    ②IPv6 EIGRP配置和调试。

     

    2.拓扑结构

     

    实验拓扑图如图22-4所示。

    图22-4 IPv6 EIGRP配置

     

    3.实验步骤

    (1)步骤:配置路由器R1
    
    
    
    R1(config)#ipv6 unicast-routing
    
    R1(config)#ipv6 router eigrp 1         //配置IPv6 eigrp
    
    R1(config-rtr)#router-id 1.1.1.1       //配置路由器ID
    
    R1(config-rtr)#no shutdown             //启用IPv6 EIGRP 进程
    
    R1(config-rtr)#redistribute connected metric 10000 100 255 1 1500
    
                                           //将直连重分布到IPv6 EIGRP中
    
    R1(config)#interface Loopback0
    
    R1(config-if)#ipv6 address 2006;1111∷1/64
    
    R1(config)#interface Serial0/0/0
    
    R1(config-if)#ipv6 address 2007;12∷1/64
    
    R1(config-if)#ipv6 eigrp 1            //在接口上启用IPv6 EIGRP
    
    R1(config-if)#no shutdown
    
    
    
    (2)步骤:配置路由器R2
    
    
    
    R2(config)#ipv6 unicast-routing
    
    R2(config)#ipv6 router eigrp 1        
    
    R2(config-rtr)#router-id 2.2.2.2      
    
    R2(config-rtr)#no shutdown
    
    
    
    
    
    R2(config)#interface Serial0/0/0           
    
    R2(config-if)#ipv6 address 2007;12∷2/64
    
    R2(config-if)#clock rate 128000
    
    R2(config-if)#ipv6 eigrp 1
    
    R2(config-if)#no shutdown
    
    R2(config)#interface Serial0/0/1
    
    R2(config-if)#ipv6 address 2007;23∷2/64
    
    R2(config-if)#clock rate 128000
    
    R2(config-if)#ipv6 eigrp 1
    
    R2(config-if)#no shutdown
    
    
    
    (3)步骤3:配置路由器R3
    
    
    
    R3(config)#ipv6 unicast-routing
    
    R3(config)#ipv6 router eigrp 1        
    
    R3(config-rtr)#router-id 3.3.3.3      
    
    R3(config-rtr)#no shutdown
    
    R3(config)#interface Serial0/0/0           
    
    R3(config-if)#ipv6 address 2007;34∷3/64
    
    R3(config-if)#clock rate 128000
    
    R3(config-if)#ipv6 eigrp 1
    
    R3(config-if)#no shutdown
    
    R3(config)#interface Serial0/0/1
    
    R3(config-if)#ipv6 address 2007;23∷3/64
    
    R3(config-if)#clock rate 128000
    
    R3(config-if)#ipv6 eigrp 1
    
    R3(config-if)#no shutdown
    
    
    
    (4)步骤4:配置路由器R4
    
    
    
    R4(config)#ipv6 unicast-routing
    
    R4(config)#ipv6 router eigrp 1        
    
    R4(config-rtr)#router-id 4.4.4.4      
    
    R4(config-rtr)#no shutdown
    
    R4(config)#interface Loopback0
    
    R4(config-if)#ipv6 address 2008;4444∷4/64
    
    R4(config-if)#ipv6 eigrp 1
    
    R4(config)#interface Serial0/0/0
    
    R4(config-if)#ipv6 address 2007;34∷4/64
    
    R4(config-if)#ipv6 eigrp 1
    
    R4(config-if)#no shutdown
    
    

    4.实验调试

     

    (1)show ipv6 route eigrp

     

    该命令来查看IPv6 EIGRP 的路由。

     

    R2#show ipv6 route

    IPv6 Routing Table - 9 entries

    Codes;C - Connectd,L - Local,S - Static,R -RIP,B - BGP

          U - Per-user Static route,M - MIPv6

          I1- ISIS L1,I2-ISIS L2,IA-ISIS interarea,IS-ISIS summary

          O - OSPF intra,O1-OSPF inter,OE1-OSPF ext 1,OE2-OSPF ext 2

          ON1 -OSPF NSSA ext 1,ON2-OSPF NSSA ext 2

          D - EIGRP,EX - EIGRP external

     D   2007;23∷/64[90/21024000]

         via  FE80∷219;55FF;FE66;6320,Serial0/0/0

     D   2007;34∷/64[90/21536000]

         via  FE80∷219;55FF;FE66;6320,Serial0/0/0

     D   2008;4444∷/64[90/21664000]

        via  FE80∷219;55FF;FE66;6320,Serial0/0/0

    R2#show ipv6 route eigrp

    IPv6 Routing Table - 9 entries

    Codes;C - Connectd,L - Local,S - Static,R -RIP,B - BGP

          U - Per-user Static route,M - MIPv6

          I1- ISIS L1,I2-ISIS L2,IA-ISIS interarea,IS-ISIS summary

          O - OSPF intra,O1-OSPF inter,OE1-OSPF ext 1,OE2-OSPF ext 2

          ON1 -OSPF NSSA ext 1,ON2-OSPF NSSA ext 2

          D - EIGRP,EX - EIGRP external

     EX  2006;1111∷/64[170/20537600]

         via  FE80∷219;55FF;FE35;B548,Serial0/0/0

     D   2007;34∷/64[90/21024000]

         via  FE80∷219;55FF;FE35;B548,Serial0/0/1

     D   2008;4444∷/64[90/21152000]

         via  FE80∷219;55FF;FE35;B548,Serial0/0/1

     

      以上输出说明路由表中的下一跳是对方的本地链路地址,同时IPv6 EIGRP也能够区分内部路由和外部路由,外部路由代码为”EX”.

     

    (2)show ipv6 eigrp neighbors

     

    该命令用来查看IPv6 EIGRP 的邻居。

     

    R2#show ipv6 eigrp neighbors

    IPv6-EIGRP neighbors for process 1

    H    Address    Interface   Hold   Uptime    SRTT  RTO   Q    Seq

                               (sec)             (ms)         Cnt   Num

     

     

    1    Link-local address;         Se0/0/1     14     00;33;32  13    1140  0    24

         FE80∷219;55FF;FE35;B548

    0    Link-local address;         Se0/0/0     14     00;33;32  10    1140  0    9

         FE80∷219;55FF;FE35;B528

        

      以上输出表明路由器R2有两个IPv6 EIGRP邻居,邻居的地址用对方的本地链路地址表示。

     

    (3)show ipv6 eigrp topology

    该命令用来查看IPv6 EIGRP的拓扑结构信息。

     

    R2#show ipv6 eigrp topology

    IPv6-EIGRP Topology Table for AS(1)/ID(2.2.2.2)

     

    Codes;P-Passive,A-Active,U-Upbate,Q-Query,R-Reply,

          r-reply Status,s - sia Status

     

    P2007;12∷/64,1 successors,FD is 20512000

            via Connected,Serial0/0/0

    P2006;1111∷/64,1 successors,FD is 20537600

            via FE80∷219;55FF;FE35;B828(20537600/281600),Serial0/0/0

    P2007;23∷/64,1 successors,FD is 20512000

            via Connected,Serial0/0/1

    P2007;34∷/64,1 successors,FD is 21024000

            via FE80∷219;55FF;FE35;B528(21024000/20512000),Serial0/0/1

    P2007;4444∷/64,1 successors,FD is 21152000

            via FE80∷219;55FF;FE35;B548(21152000/20640000),Serial0/0/1

     

    (4)show ipv6 protocols

     

    R2#show ipv6 protocols

    IPv6 Routing Protocol is “connected”

    IPv6 Routing Protocol is “static”

    IPv6 Routing Protocol is “eigrp 1”

    //IPv6 EIGRP 进程

      EIGRP metric weight K1=1,K2=0,K3=1,K4=0,K5=0

    //计算度量之的因子

      EIGRP maximum hopcount 100

    //最大跳数

      EIGRP maximum metric variance 1

    //variance 值为1,表示默认只支持等价路由负载均衡

      Interfaces;

         Serial0/0/0

         Serial0/0/1

    //以上3行表示启用IPv6 EIGRP 接口

     

     

      Redistribution;

       None

      Maximum path;16

    //默认最大等价路由径为16条,最多可以配置64条

      Distance;internal 90 external 170

    //IPv6 EIGRP 的内部路由管理距离为90,外部路由管理距离为170

     

    3 IPv6 命令汇总

     

    表22-1 列出了本章涉及到的主要的命令

     

     表 22-1 本章命令汇总

     

    命令

    作用

    show ipv6 route

    查看IPv6路由表

    show ipv6 interface

    查看IPv6接口信息

    show ipv6 protocols

    查看和IPv6路由协议相关的信息

    show ipv6 rip next-hops debug ipv6 rip

    查看RIPng的下一跳地址

    show ipv6 rip datasee

    查看RIPng的数据库

    show ipv6 ospf neighbor

    查看OSPFv3邻居的 基本信息

    show ipv6 ospf interface

    查看OSPFv3路由器接口的信息

    show ipv6 ospf database

    查看OSPFv3拓扑结构数据库

    show ipv6 ospf

    查看OSPFv3进程及其细节

    show ipv6 route eigrp

    查看IPv6 EIGRP 的路由

    show ipv6 eigrp topology

    查看IPv6 EIGRP的拓扑结构信息

    show ipv6eigro neighbors

    查看IPv6 EIGRP的邻居

    debug ipv6 rip

    动态查看 RIPng的更新

    ipv6 unicast-routing

    启动IPv6流量转发

    ipv6 address

    在接口下配置IPv6地址

    ipv6 route

    配置IPv6静态路由

    ipv6 router rip

    启动IPv6 RIPng 进程

    split-horizon

    启用水平分割

    poison-reverse

    启用毒化反转

    ipv6 rip tag enable

    在接口上启用RIPng

    ipv6 rip default-information originate

    向IPv6 RIPng区域注入一条默认路由

    ipv6 router ospf

    启用OSPFv3 路由进程

    router-id

    配置路由器ID

    default-information originate

    向OSPFv3网络注入一条默认路由

    ipv6 ospf process-id area area-id

    接口上启用OSPFv3,并声明接口所在区域

    ipv6 router eigrp

    配置IPv6 EIGRP路由协议

    ipv6 eigrp

    接口下启用IPv6 EIGRP

    maximum-patahs

    配置能支持的等价路径的条数

    variance

    配置IPv6 EIGRP非等价负载均衡

     

    展开全文
  • 本节书摘来自异步社区《IPv6技术精要》一书中的第1...IPv6技术精要本节将介绍IPv6优点,下面简要列举了IPv6的主要优点及功能特性。 极大扩展的地址空间:与IPv4的32比特地址长度相比,IPv6的源地址和目的地址长度...

    本节书摘来自异步社区《IPv6技术精要》一书中的第1章,第1.5节,作者 【美】Rick Graziani,更多章节内容可以访问云栖社区“异步社区”公众号查看

    1.5 IPv6的优点

    IPv6技术精要
    本节将介绍IPv6的优点,下面简要列举了IPv6的主要优点及功能特性。

    极大扩展的地址空间:与IPv4的32比特地址长度相比,IPv6的源地址和目的地址长度均为128比特,可以提供巨大的地址空间——2128即340兆兆兆个地址,足够为地球上的每粒沙子都分配一个IP地址。
    无状态自动配置:IPv6提供了一种配置机制,允许主机自己生成一个可路由地址。IPv4的自动配置地址(RFC 3330和5735)只能在本地子网(链路本地)内部使用,路由器不会转发这些地址。IPv6还支持利用DHCPv6进行状态化自动配置。
    消除了NAT/PAT(Network Address Translation / Port Address Translation,网络地址转化/端口地址转换):由于IPv6拥有足够多的公有IPv6地址,因而不再需要NAT/PAT。每个客户站点(从最大型的企业站点到单一的家庭站点)都能得到一个公有IPv6地址,从而避免了NAT给应用(如VoIP、视频会议以及其他P2P应用)带来的很多负面问题。虽然“不再使用NAT”被视为IPv6的重要优势之一,但NAT64(Network Address Translation IPv6 to IPv4,IPv6到IPv4的网络地址转换)在目前仍然被用作后向兼容IPv4网络的重要工具。另一个与NAT相关的问题是,许多组织机构将自己的IPv4网络隐藏在NAT设备之后,一旦使用了可公开访问的IPv6地址之后,这些组织机构就不得不更改其网络安全策略。有关NAT的详细讨论,请参考本书第11章。
    消除了广播:IPv6不再使用三层广播地址,不过,IPv6采用了被请求节点的多播地址(solicited node multicast address),这是一种更有效也更具选择性的用于处理地址解析等应用的技术。与IPv4使用广播地址进行ARP(Address Resolution Protocol,地址解析协议)不同,IPv6使用被请求节点的多播地址来实现相同的目的,而且全部节点多播地址(all-node multicast address)在本质上与IPv4广播地址拥有相同的效果。有关多播地址和地址解析的相关内容将在后续章节进行详细讨论。
    迁移工具:IPv6提供了多种工具以支持IPv4向IPv6的迁移,包括隧道和NAT。隧道机制将IPv6报文封装到IPv4报文中,从而可以经由IPv4-only网络进行传输。NAT提供了一种将IPv4地址转换为IPv6地址或者将IPv6地址转换为IPv4地址的机制。IPv4也可以通过隧道机制在IPv6网络中进行传输。有关隧道的相关内容将在第10章进行详细讨论。

    展开全文
  • IPV6

    2019-08-11 01:12:50
    一、 IPV4缺点 IPV4地址空间不足(划分不合理,地址浪费) IPV4具有复杂的头部 IPV4头部安全性较低 IPV4地址不能作为标识符和定位符 二、 改进IPV4缺点 使用私有地址,进行NAT转换(破坏...三、IPV6优点 巨大地址空...

    一、 IPV4缺点

    1. IPV4地址空间不足(划分不合理,地址浪费)
    2. IPV4具有复杂的头部
    3. IPV4头部安全性较低
    4. IPV4地址不能作为标识符和定位符
      二、 改进IPV4缺点
    5. 使用私有地址,进行NAT转换(破坏数据端到端的连接,做认证,加密不易实现
      NAT非常消耗路由器资源)
    6. DHCP
    7. VLSM子网划分 CIDR子网汇总 (两者并不是节约IP地址,只是充分利用)
      三、IPV6优点
      巨大地址空间
      简单头部
      支持可移动性和安全特性(任意播)
      IPV6支持穿越IPV4
      IPV6没有校验和、没有广播

    IPV4 IPV6 数据包头比较
    在这里插入图片描述
    Version:版本,描述数据包的IP版本号,4bit,4个字段设置为二进制的0100表示ipv4。
    IHL: header length,字段长度4bit,观察数据包结构,不算最后一行的可选项,每一行是32bit,也就是4字节,所以最小数据包长度为20字节,但是默认首部长度是0101,5又如何能代表20字节呢,所以单位并不是一个bit,单位表示是32bit,则最小的IP报头为20字节,4bit的二进制最大表示为1111,所以最大的IP报头为60字节,所以范围是20-60字节,但是并不是任意数字,当IP头部长度不是4的倍数的时候,必须用最后的填充字段填充。
    Type of service :TOS,服务类型,8bit长度,用来标识不同流量,保留第八位。一般不会使用,只有在区分服务时,这个字段才会起作用。做QOS使用,分为TOS标记与DSCP标记,TOS标记前三位(0 1 2),DSCP区分服务代码点,用前6bit,分配越多,QOS更强大,现在使用的PHB,解决两者兼容性,后面两位表示拥塞位。
    Total length:数据包总长度,16bit,其中包括IP报头以及数据。IP数据包总长度减去IP报头长度,得出数据包数据有效载荷的大小。IP数据包总长度最大是65535。
    Identification:标识位,占16位,设置这个字节的原因是因为IP软件在存储器中维持一个计数器,每产生一个数据包,计数器就加1,这个时候就会把这个数字赋给标识符了,这个标识位并不是序号,因为数据包不存在按序接收的问题。当数据报由于长度超过网络的 MTU 而必须分片时,这个标识字段的值就被复制到所有的数据报的标识字段中.相同的标识字段的值使分片后的各数据报片最后能正确地重装成为原来的数据报.
    Flags:标记字段,3bit。第一位不使用,第二位是不分段位(DF),DF为1时表示不分段;第三位是更多分段(MF)位,一般除了最后一个数据包分片MF位为0,其他的都为1。
    Fragment offset:分段偏移,13bit,标明分段起始点对于报头起始点的偏移量。分段可能会出现顺序错误,因此分段偏移字段可以确保正确的顺序。以 8个字节为偏移单位,这就是说,每个分片的长度一定是 8字节(64位)的整数倍.
    Time to live:生存时间,TTL,8bit,防止数据无休止被传输。最初设置时候表示时间,现在表示跳数,当跳数为0的时候,数据包会被丢弃。
    Protocol:协议,8bit,指定了数据包的信息类型以及描述上层使用何种协议和封装。ICMP 1 IGMP 2 OSPF 88 EIGRP 89
    Header checksum:报头校验和,16bit,针对IP报头的纠错字段,IP报头是否完整。这是因为数据报每经过一个路由器,都要重新计算一下首都检验和 (一些字段,如生存时间,标志,片偏移等都可能发生变化)Source and destination address:32bit。
    Options:可选项,主要用于测试,支持排错以及安全措施。如:松散路由,严格路由,记录路由以及时间戳(让每个路由器都记下IP数据报经过每一个路由器的IP地址和当地时间)。可选项的最大长度是40字节,能说明可以记录10个IP地址吗?不行,最多为9个,还有其他时间戳等属性占一定长度。
    Padding:填充,在可选项字段后加0来补足32位或者32的倍数。

    Version 版本,4bit,0110
    Traffic class:流量分类,8bit
    Flow label:流标签,20bit,暂时保留
    Payload length:负载长度,8bit,IPV6数据包数据长度,IPV4里的总长度减去头部长度
    Next header:下一个头部,8bit,与protocol一致,不一样的是IPV6有扩展头部,比如认证头,选路头,路由头等。
    Hop limit:跳数,与TTL一样

    四.IPV6地址书写
    IPV6使用128 bit构成,使用十六进制书写(32个十六进制数),分为八组,每组四个
    2001:0:101:1100:0:0:0:1011
    2001:0:101:1100::1011
    2001::101:1100:0:0:0:1011
    书写方式:1.首选格式 2.压缩格式 3.IPV6兼容性地址
    1.首选格式,直译
    2.压缩格式:

    1.若某组以0开始,则该可以省略 ,整组为0可以省略为0
    2.若某组全为0或连续多个组都为0可以省略为::,::仅能使用一 次
    2001:11:0:23ab:0:0:0:1111
    2001:11::23ab:0:0:0:1111
    2001:11:0:23ab::1111
    2001:11::23ab::1111
    3.IPV6到IPV4兼容性地址
    主要在IPV4向IPV6过渡时使用的技术,自动tunnel使用地址
    将IPV4地址映射至IPV6地址(该IPV4地址为公有地址)
    比如:10.20.30.42/24
    0000 1010.0001 0100.0001 1110.0010 1010
    0814:1E2A:
    2002:814:1E2A::/48 2002是固定的
    五.IPV6地址分类
    IPV6单播地址 IPV6组播地址 IPV6任意播地址

    IPV6单播地址:
    1.全球单播地址:AGUA,全球可聚合单播地址
    2000::/3地址进行分类
    最小地址:2000:0000:0000:0000:0000:0000:0000:0000
    最大地址:3FFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF
    2001::/16 商用internet地址
    2002::/16 IPV6兼容性地址
    3FFF::/16 非商用internet地址,教育网
    2.link-local 地址,链路本地地址 标识在网络中的唯一性,类似于Mac地址
    动态路由学习的下一跳地址也为link-local地址
    FE80::/10地址范围
    Link-local地址使用eui-64产生主机位
    1.将接口MAC地址中间拆开
    2.将FF-FE插入
    3.将第七bit反转
    在这里插入图片描述
    在这里插入图片描述
    Ca01.d170.0006——Ca01.d1FF.FE70.0006——C801.d1FF.FE70.0006——
    FE80 ::C801:D1FF:FE70:0006
    注意:在非以太网接口上不存在MAC地址,使用本设备上接口最小 MAC地址进行EUI-64转换,一般为F0/0接口MAC地址
    3.FEC0::/10 , 私有IPv6地址,该地址段已被收回
    4.环回地址 ::1/128 ,本地环回地址,相当于IPV4中的127.0.0.1
    5.无效地址 ::

    IPV6组播地址:
    FF00::/8
    被请求源组播地址:FF02::1:FF00:0,在局域网中类似于广播地址(当配置了AGUA地址后,会自动产生站点本地地址,将后24位作为补充,)
    FF02::1:FFxx:xxxx,一般用于发送本地信令帧时使用,例如ARP
    在这里插入图片描述
    IPV6任意播地址:就等于IPV6 单播地址(1对最近传输nearest)
    Ipv6支持多宿主,一个接口可以配置多个IPV6地址,所以一般配置一个任意播地址和AGUA地址
    在这里插入图片描述
    在这里插入图片描述

    六.ICMPV6协议----互联网消息控制协议
    Type : 类型字段. 类型字段范围0-255
    0-127,ICMPV6中的错误报文(error)
    128-255,信令报文

    1.ICMPV6路径MTU协商,从源到目标感知整条路径上最小的MTU值.
    2.NDP:邻居发现协议
    ICMPV6 代替ARP功能,使用ICMPV6类型135NS(邻居发现)和类型 136的 NA(邻居通告)学习对方的MAC地址
    Type 135:
    在这里插入图片描述
    IPV6组播MAC地址,将被请求源组播地址后32位前加上33:33构成组播MAC地址
    Type 136
    在这里插入图片描述

    地址无状态化自动配置:
    使用ICMPV6中类型133 RS(路由发现)和类型 134 RA(路由通告) 进行网络前缀通告(使用RA携带,周期间隔为200s,超时时间为 1800s)

    首先可以手动配置IPV6地址与link-local地址(注意link-local必须是fe80开头的)
    在这里插入图片描述

    而动态获取地址时候成为自动化配置,分为有状态化(采用DHCPV6)自动配置与无状态化(ICMPV6协议中的auto-config)自动配置。
    无状态化意思就是地址推送,一个路由器上面有地址,对端路由器没有地址,可以直接把自己的网络前缀推送过去,加上eui-64成为对端的IPV6地址,前提推送地址的一方开启了IPV6的路由功能,若不开启,前缀推送功能是不会开启的。
    有状态化就是限制了网络前缀,可以穿越路由器分配地址,地址池并不是接口的IPV6地址网段(与IPV4 DHCP不一样)
    Link-local地址是必然存在的
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    Type 133:(希望获取的地址发送)
    在这里插入图片描述
    Ff02::2相当于224.0.0.2,只有路由器开启了IPV6的单播功能,才会接收这个报文
    Type 134:(R1的link-local地址给R2的link-local地址)
    在这里插入图片描述
    当然R1也可以禁止通告前缀
    在这里插入图片描述

    IPV6地址有状态化自动配置------DHCPV6协议
    使用报文:
    在这里插入图片描述
    1.源地址为自己的link-local地址,目标地址为FF02::1:2
    2.advertise 和 reply中使用单播发送
    3.DHCPV6 地址池必须在接口中调用
    4.DHCPV6分配的地址可以和调用接口不在同一网段
    5.接口必须关闭地址的无状态自动分配功能
    Sever端
    定义DHCPV6地址池
    在这里插入图片描述
    接口配置
    在这里插入图片描述
    客户端查看
    在这里插入图片描述
    在这里插入图片描述

    DAD:重复地址检测 (代替无故ARP的)
    使用type 135: NS 请求自己IP地址对应的MAC地址,
    源IPV6地址为:::
    目标IPV6地址:自己AGUA地址对应的site-local地址(指定源组播地址)
    在目标IPV6地址中使用自己IP地址对应的被请求源组播地址.
    在这里插入图片描述

    展开全文
  • IPv6 IPv6 即互联网协议 IPv4 的下一代版本。它是网络从业者为了解决 IPv4 的不足而研究开发的,IPv6 的出现除了众所周知的 IPv4 的地址即将使用殆尽的问题得到了有效解决之外,还做了报头的更新等工作,增加了编址...

    但行好事,莫问前程

    IPv6

    IPv6 即互联网协议 IPv4 的下一代版本。它是网络从业者为了解决 IPv4 的不足而研究开发的,IPv6 的出现除了众所周知的 IPv4 的地址即将使用殆尽的问题得到了有效解决之外,还做了报头的更新等工作,增加了编址方式的灵活性,管理更加方便灵活,网络的性能也得到了提升。安全性和效率也得到了显著提高。

    从IPV4到IPV6过渡可能运用到的技术

    为了运行以上两种网络,解决过渡性的问题主要有三种基本技术:

    (一)双协议栈 ( Dual Stack)
      双协议栈技术就是指在一台设备上同时具备 IPv4 和 IPv6两种协议栈。即此设备既能在 IPv4 网络上通信,又能在 IPv6网络上进行通信。如果这台设备是一个路由器,那么这台路由器的不同接口上,分别配置了 IPv4 地址和 IPv6 地址,并很可能分别连接了 IPv4 网络和 IPv6 网络。如果这台设备是一个计算机,那么它将同时拥有 IPv4 地址和 IPv6 地址,并具备同时处理这两个协议地址的功能。这种方式对 IPv4 和 IPv6 提供了完全的兼容,但是对于 IP 地址耗尽的问题却没有任何帮助。由于需要双路由基础设施,这种方式反而增加了网络的复杂度。
    (二)隧道技术 ( Tunnel)
      此处隧道技术是指利用 IPv4 的隧道传送 IPv6 数据报文的技术。即将 IPv6 数据报文封装在 IPv4 数据报中,在 IPv4 网络中传送。工作时,边界路由器会把 IPv6 报文加上一个 IPv4 报头,变成一个标准的 IPv4 报文在 IPv4 网络上正常传输,另一端的边界路由器会在接收到这个数据报之后去掉 IPv4 报头,还原成为原来的 IPv6 报文。两端的工作在 IPv6 协议下的主机就可以以纯粹的 IPv6 协议进行通信。这样漂浮在 IPv4 海洋上了 IPv6孤岛就可以实现连通。
    (三)地址转换技术 (NAT-PT)
      这种技术可以将设备两端不同的网络协议进行转换,并对不同的数据分组做出与协议相符的语义翻译的中间通信设备,地址转换技术使 IPv4 和 IPv6 两种网络站点之间实现通信。这种技术的缺陷是不能支持所有的应用。

    IPV6的优点

    1、更大地址空间:128位的地址空间可以满足每个人
    2、无需NAT:保障端到端通信
    3、没有广播地址:包括单播、多播、任意播
    4、支持移动性和安全性:有助于确保遵循移动IP标准和Ipsec标准
    5、更简单的报文提高了路由器的效率
    6、接口标识:从接口的数据链路层

    展开全文
  • 深入讲解IPV6

    千次阅读 2017-07-06 16:31:18
    IPv6是InternetProtocolVersion6的缩写,其中InternetProtocol译为“互联网协议”。IPv6是IETF(互联网工程任务组,InternetEngineeringTaskForce)设计的用于替代现行版本IP... IPV6优点  1、更大地址空间:128位
  • IPv6 基础 目录 IPv6 基础 1-1 目录 1-2 1 引言 1-3 1.1 编写目的 1-3 2 IPv6 优点2-3 3 IPv6 新特性3-3 4 IPv6 格式4-3 5 IPv6 地址5-4 5.1 地址分类 5-4 5.1.1 单播unicast地址 5-4 5.1.2 任播anycast 地址 5-5 ...
  • 相比IPV4,IPV6有什么优点

    万次阅读 2017-07-15 21:38:49
    IPv4是一个被广泛使用的互联网协议,而IPV6是下一版本的互联网协议。随着互联网的迅速发展,IPV4定义的有限地址空间将被耗尽,地址空间的不足必将妨碍互联网的进一步发展。为了扩大地址空间,拟通过iPv6重新定义地址...
  • ipv6

    千次阅读 2013-06-24 10:29:48
    也说技术:校园IPV6协议免费上网、高速下载的方法!  * 发布在 也说技术  * , Posted by 老饕  * 2009, 八月 6 校园ipv6协议免费上网的方法.jpg 在宿舍的同学们,教你怎么样利用学校的漏洞,只要...
  • IPv6笔记01

    2012-05-16 20:50:37
    一、IPv6优点 1、更大的地址空间。 2、简化了报头。 3、移动性。 4、安全性。 5、自动配置。 6、QoS。 二、IPv4和IPv6报头比较 三、IPv6地址类型 1、单播地址-----可汇聚全球单播地址(公网地址)(2000::...
  • IPv6笔记(一)

    2012-04-21 18:40:21
    一、IPv6优点 1、更大的地址空间。 2、简化了报头。 3、移动性。 4、安全性。 5、自动配置。 6、QoS。 二、IPv4和IPv6报头比较 三、IPv6地址类型 1、单播地址-----可汇聚全球单播地址(公网地址)(2000::...
  • IPV6地址解释

    2013-11-09 19:33:46
    ipv6详解。针对ipv4地址的一系问题,然后解释ipv6优点
  • 本节书摘来自异步社区《IPv6技术精要》一书中的第1章,第1.9节,作者 【美】Rick Graziani,更多章节内容可以访问云栖社区“异步社区”公众号查看 ...虽然有关IPv6优点的讨论将贯穿本书始终,但大家对IPv6的优点...
  • IPv6简介

    2019-10-06 03:33:01
    IPv6优点 更大的地址空间 名字叫IPv6,但它的长度并不是64位,而是128位,总的地址空间大约为3.4*1038,一个亿是10的8次方,那么IPv6就有340万亿亿亿亿个地址(4个亿连一起),所以说给地球上的每一粒沙子分配一...
  • IPv6介绍

    2016-10-10 11:40:22
    一、为什么需要IPv6  为了扩大地址空间,拟通过IPv6重新定义地址空间。IPv4采用32位地址长度,只有大约43亿个地址,估计在2005~2010年间将被分配完毕,而IPv6采用128位地址长度,几乎可以不受限制地提供地址。按...
  • IPv6学习

    千次阅读 2018-07-24 17:30:06
    IPv6(互联网协议第六版Internet Protocol Version 6) 地址长度:128位 数量2^128 表示方法: IPv6的地址长度为128b,是IPv4地址长度的4倍。于是IPv4点分十进制格式不再适用,而采用十六进制表示。IPv6有3种...
  • 相信IPv6的地址数量优势已为大家熟知,丰沛的地址存量是IPv6被选作新一代网络承载协议并逐渐商用部署的根本驱动力。 然而IPv6协议相比于IPv4,不仅地址数量接近无限,还在网络安全性方面更胜一筹。本文将为您集中...
  • IPv6 解析

    千次阅读 2019-04-09 11:00:28
    IP协议是整个互联网最核心的协议,而我们现在使用的主流IP协议(IPv4),是在1981年制定的,从目前互联网规模来看,已经有些力不从心了。主要问题是IPv4的32位地址...IPv6,孕育于1990年,出生于1998年。实际上,IET...
  • IPV6详解

    千次阅读 多人点赞 2020-03-03 14:49:11
    IPV6 特征-升级点: 1、全球单播地址 ---- IPV4地址下的公有地址 V6下没nat 2、可聚合性(IANA组织对全球的地址进行合理分配) 3、多宿主—一个物理接口可以同时拥有多个不同网段的IPV6地址;但不同接口不 能在同一...
  • IPV6协议

    2019-05-31 10:13:02
    IPV6的配置 一、接口配置IPV6的单播地址 1、link-local (1) R1(config)#interface fastEthernet 0/0 R1(config-if)#ipv6 enable (2)手工或自动配置一个IPV6的AGUA,均会生成一个link-local地址;但...
  • 网络 IPV6

    2021-03-04 15:07:18
    IPV6作为IPV4的续命神术,从被提出到现今,逾26年之久。而IPV6在中国更是犹抱琵琶半遮面,千呼万唤难出来,IPV6取代IPV4之路,为何道阻且长? 2011年2月3日,IANA宣布:IPv4地址空间最后5个地址块已经被分配给...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 13,734
精华内容 5,493
关键字:

ipv6优点