精华内容
下载资源
问答
  • 华为链路聚合

    2021-03-11 09:05:17
    链路聚合概述网络拓扑图手动配置LACP配置连通性测试链路聚合测试LACP验证 概述 网络拓扑图 手动配置 交换机sw1: interface Eth-Trunk1 interface GigabitEthernet0/0/1 eth-trunk 1 interface GigabitEthernet0/0...

    概述

    网络拓扑图

    在这里插入图片描述

    手动配置

    交换机sw1:
    interface Eth-Trunk1

    interface GigabitEthernet0/0/1
    eth-trunk 1

    interface GigabitEthernet0/0/2
    eth-trunk 1

    交换机sw2:
    interface Eth-Trunk1

    interface GigabitEthernet0/0/1
    eth-trunk 1

    interface GigabitEthernet0/0/2
    eth-trunk 1

    LACP配置

    直接修改mode报错:
    在这里插入图片描述
    去掉eth-trunk 1 中的端口
    在这里插入图片描述
    在这里插入图片描述
    两边都要去掉

    sw1上的配置:
    interface Eth-Trunk1
    mode lacp-static
    load-balance src-dst-mac

    interface GigabitEthernet0/0/1
    eth-trunk 1

    interface GigabitEthernet0/0/2
    eth-trunk 1

    sw2上的配置:
    interface Eth-Trunk1
    mode lacp-static
    load-balance src-dst-mac

    interface GigabitEthernet0/0/1
    eth-trunk 1

    interface GigabitEthernet0/0/2
    eth-trunk 1

    连通性测试

    在这里插入图片描述

    启用负载均衡:
    sw1和sw2配置命令:
    interface Eth-Trunk1
    load-balance src-dst-mac

    在这里插入图片描述

    验证配置:
    在这里插入图片描述

    在这里插入图片描述

    在这里插入图片描述

    链路聚合测试

    down掉一个线g0/0/1口
    在这里插入图片描述
    恢复线路g0/0/1
    在这里插入图片描述

    LACP验证

    在这里插入图片描述
    证明带宽增加了:
    在这里插入图片描述

    展开全文
  • 华为链路聚合Eth-Trunk配置实例

    千次阅读 2020-08-14 15:39:59
    华为链路聚合Eth-Trunk配置实例 目录华为链路聚合Eth-Trunk配置实例什么是链路聚合链路聚合实例拓扑配置要求配置思路配置命令SW1:SW2:SW3:检测 什么是链路聚合 链路聚合就是把多个物理接口汇聚在一起,形成一个逻辑...

    华为链路聚合Eth-Trunk配置实例

    什么是链路聚合

    链路聚合就是把多个物理接口汇聚在一起,形成一个逻辑接口。可以实现基于接口的一个负载均衡。当其中一个接口down了之后,就停止在此接口发送数据,直接走另一条路径,可以实现接口down的也不会出现网络中断的现象。

    链路聚合实例拓扑

    拓扑图

    配置要求

    --------所有主机能互通

    配置思路

    SW1做主三层,汇聚层,用于连接边界设备
    SW1配置eth-trunk 1,eth-trunk 2,绑定21,22,23,24端口
    SW1的vlanif ip做PC的网关
    SW2-3做旁交换,接口1与接口2分别对应vlan10与vlan20
    Vlan 10 分配IP:192.168.10.0/24
    Vlan 20 分配IP:192.168.20.0/24

    配置命令

    SW1:

    vlan batch 2 10 20 #创建vlan 10 20
    interface Vlanif10
    ip address 192.168.10.1 255.255.255.0 #配置vlan 10 ip
    interface Vlanif20
    ip address 192.168.20.1 255.255.255.0 #配置vlan 20 ip
    interface Eth-Trunk1 #创建eth-trunk 1
    port link-type trunk #eth接口设为trunk
    port trunk allow-pass vlan 10 20 #放行vlan 10 20
    interface Eth-Trunk2
    port link-type trunk
    port trunk allow-pass vlan 10 20
    interface GigabitEthernet0/0/21 #接口加入eth2
    eth-trunk 2
    interface GigabitEthernet0/0/22
    eth-trunk 2
    interface GigabitEthernet0/0/23
    eth-trunk 1
    interface GigabitEthernet0/0/24
    eth-trunk 1

    SW2:

    vlan batch 10 20
    interface Vlanif10
    ip address 192.168.10.2 255.255.255.0
    interface Vlanif20
    ip address 192.168.20.2 255.255.255.0
    interface Eth-Trunk1
    port link-type trunk
    port trunk allow-pass vlan 10 20
    interface GigabitEthernet0/0/1
    port link-type access
    port default vlan 10
    interface GigabitEthernet0/0/2
    port link-type access
    port default vlan 20
    interface GigabitEthernet0/0/23
    eth-trunk 1
    interface GigabitEthernet0/0/24
    eth-trunk 1

    SW3:

    vlan batch 10 20
    interface Vlanif10
    ip address 192.168.10.2 255.255.255.0
    interface Vlanif20
    ip address 192.168.20.2 255.255.255.0
    interface Eth-Trunk1
    port link-type trunk
    port trunk allow-pass vlan 10 20
    interface GigabitEthernet0/0/1
    port link-type access
    port default vlan 10
    interface GigabitEthernet0/0/2
    port link-type access
    port default vlan 20
    interface GigabitEthernet0/0/21
    eth-trunk 1
    interface GigabitEthernet0/0/22
    eth-trunk 1

    检测

    可以通过display eth-trunk 1/eth-trunk 2查看当前eth-trunk逻辑接口下关联了哪些接口。
    在这里插入图片描述
    通过主机1ping其他主机IP 通则成功。
    在这里插入图片描述

    展开全文
  • 华为链路聚合技术

    2020-07-24 11:03:11
    链路聚合(Link Aggregation)是将—组物理接口捆绑在一起作为一个逻辑接口来增 加带宽的一种方法,又称为多接口负载均衡组(Load Sharing Group)或链路聚合组(Link Aggregation Group),相关的协议标准请参考...

    链路聚合(Link Aggregation)是将—组物理接口捆绑在一起作为一个逻辑接口来增
    加带宽的一种方法,又称为多接口负载均衡组(Load Sharing Group)或链路聚合组(Link Aggregation Group),相关的协议标准请参考IEEE802.3ad。
    通过在两台设备之间建立链路聚合组,可以提供更高的通讯带宽和更高的可靠性。
    链路聚合不仅为设备间通信提供了冗余保护,而且不需要对硬件进行升级。
    在这里插入图片描述
    配置手工负载分担模式链路聚合
    当需要增加两台设备之间的带宽或可靠性,而两台设备中有一台不支持LACP协议时,可在Switch设备上创建手工负载分担模式的Eth-Trunk,并加入多个成员接口增加设备间的带宽及可靠性
    Eth-Trunk的创建、成员接口的加入都需要手工配置完成,没有LACP (linkAggregation Control Protocol )协议报文的参与
    手工负载分担模式允许在聚合组中手工加入多个成员接口, 所有的接口均处于转发状态,分担负载的流 量

    配置SW1和SW2之间G1到G3口的eth-trunk
    [SW1]interface Eth-Trunk 1
    [SW1-Eth-Trunk1]mode manual load-balance — 缺省情况下,
    Eth-Trunk 的工作模式为手工负载分担模式。该命令不会显
    示到现有配置。如果本端配置手工负载分担模式Eth-Trunk ,那么对端设备也必须要配置手工负载分担模式Eth-Trunk
    [SW1-Eth-Trunk1]trunkport GigabitEthernet 0/0/1 to 0/0/3 -
    – 直接把接口加入以太通道,物理接口下会自动添加配置

    interface GigabitEthernet0/0/1
    eth-trunk 1 //在物理成员接口下加入eth-trunk

    修改eth-trunk的链路类型
    interface Eth-Trunk1
    port link-type trunk —在逻辑接口而非物理接口下完成链路类型的修改
    支持任意类型的以太类型(access、trunk、hybrid、qinq等)
    修改eth-trunk的活动接口数目上限为3,下限为2
    least active-linknumber 2
    max bandwidth-affected-linknumber 3

    验证eth-trunk
    [SW2]display eth-trunk 1 verbose

    静态LACP模式的链路聚合
    静态LACP模式也称为M∶N模式。这种方式同时可以实现链路负载分担和链路冗余备份的双重功能。 在链路聚合组中M 条链路处于活动状态,这些链路负责转发数据并进行负载分担,另外N 条链路处于非活动状态作为备份链路,不转发数据。当M条链路中有链路出现故障时, 系统会从N 条备份链路中选择优先级最高的接替出现故障的链路,同时这条替换故障链路的备份链路状态变为活动状态开始转发数据。
    静态LACP模式与手工负载分担模式的主要区别为:静态LACP模式有备份链路,而手工负载分担模式所有成员接口均处于转发状态,分担负载流量

    interface Eth-Trunk12
    mode lacp-static //先配置为静态LACP模式( 此时会自动修改活动的上下限)
    lacp preempt enable //开启抢占
    max active-linknumber 3 //设置最大的活动的数量,如果两端配置活动接口数的上限阈值不同,则以上限阈值数值较小的一端为准。
    lacp preempt delay 10 //设置抢占时延
    least active-linknumber 2 配置最少活动链接数为2
    配置静态LACP模式活动接口数目上限阈值可以控制Eth-Trunk中活动接口的最大数M,剩余的成员接口处于备份状态

    配置系统以及接口下的LACP优先级业内用于抢占成为active接口
    数值越小越优先;系统LACP 优先级,静态LACP 模式下,两端设备所选择的活动接口必须保持一致,否则链路聚合组就无法建立。而要想使两端活动接口保持一致,可以使其中一端具有更高的优先级,另一端根据高优先级的一端来选择活动接口即可。系统LACP 优先级就是为了区分两端优先级的高低而配置的参数
    第一步:
    1.选择主动端
    先比较优先级,优先级数值越小越优先,
    如果优先级相同,则比较MAC地址,MAC地址越小越优先
    [SW1] lacp priority 0 //修改lacp系统优先级为0.为主动端 默认系统优先级为32768

    2.选择活动接口
    选择活动接口一定要在主动端设备上配置
    先比较优先级,优先级数值越小越优先,
    如果优先级相同,则比较端口ID,端口ID 越小越优先
    interface GigabitEthernet0/0/3
    lacp priority 65355 //设置接口的优先级,成为备份端口,默认接口优先级为32768

    注意事项
    ⚫ 每个Eth-Trunk接口下最多可以包含8 个成员接口。
    ⚫ 成员接口不能配置任何业务和静态MAC地址。
    ⚫ 成员接口加入Eth-Trunk时,必须为缺省的hybrid类型接口。
    ⚫ Eth-Trunk接口不能嵌套,即成员接口不能是Eth-Trunk。
    ⚫ 一个以太网接口只能加入到一个Eth-Trunk 接口,如果需要加入其它Eth-Trunk接口,必须先退出原来的Eth-Trunk接口。
    ⚫ 一个Eth-Trunk 接口中的成员接口必须是同一类型,例如:FE口和GE口不能加入同一个Eth-Trunk接口。
    ⚫ 可以将不同接口板上的以太网接口加入到同一个Eth-Trunk。
    ⚫ 如果本地设备使用了Eth-Trunk,与成员接口直连的对端接口也必须捆绑为Eth-Trunk接口,两端才能正常通信。
    ⚫ 当成员接口的速率不一致时,实际使用中速率小的接口可能会出现拥塞,导致丢包。
    ⚫ 当成员接口加入Eth-Trunk后,学习MAC地址时是按照Eth-Trunk来学习的,而不是按照成员接口来学习

    eth-trunk的负载分担方式
    ⚫ dst-ip(目的IP地址)模式:从目的IP地址、出端口的TCP/UDP端口号中分别选择指定位的3bit数值进
    行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    ⚫ dst-mac(目的MAC地址)模式:从目的MAC地址、VLAN ID、以太网类型及入端口信息中分别选择指
    定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    ⚫ src-ip(源IP地址)模式:从源IP地址、入端口的TCP/UDP 端口号中分别选择指定位的3bit数值进行异
    或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    ⚫ src-mac(源MAC地址)模式:从将源MAC地址、VLAN ID、以太网类型及入端口信息中分别选择指定
    位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    ⚫ src-dst-ip (源IP 地址与目的IP 地址的异或)模式:从目的IP 地址、源IP 地址两种负载分担模式的运算结
    果进行异或运算,根据运算结果选择Eth-Trunk 表中对应的出接口。
    ⚫ src-dst-mac(源MAC地址与目的MAC地址的异或)模式:从目的MAC地址、源MAC地址、VLAN ID、以
    太网类型及入端口信息中分别选择指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中
    对应的出接口。
    修改eth-trunk的负载方式为基于目的IP
    [SW2]interface Eth-Trunk 1
    [SW2-Eth-Trunk1] load-balance dst-ip
    [SW2]dis eth-trunk 1

    展开全文
  • 华为链路聚合实验

    千次阅读 2018-07-07 01:40:50
    关于我的链路聚合有两张,首先对于链路聚合,在不同网段且不同vlan的时候需要在三层交换机上配置虚拟IP,且该IP地址为该网段的网关地址, 下面我仅仅使用了一个链路聚合,我曾做过这样的实验,如果主机在相同网段...

     

    关于我的链路聚合有两张,首先对于链路聚合,在不同网段且不同vlan的时候需要在三层交换机上配置虚拟IP,且该IP地址为该网段的网关地址,

     

    下面我仅仅使用了一个链路聚合,我曾做过这样的实验,如果主机在相同网段相同网段。则不需要在交换机上配置IP地址,如果主机在不同网段且不同vlan下的时候,则需要在交换机上配置IP地址

     

    实验如下:

     

     

    确保pc1、pc2、pc3能够相互通信,且不在相同网段和不同vlan

     

     

     

    实验如下:

     

    sw5配置:

    [s1]vlan batch 10 20 30                 //需要在三层交换机上面操作,创建三个vlan
    [s1]int Vlanif 10                       //虚接口
    [s1-Vlanif10]ip add 192.168.1.1 24      //配置IP,IP地址为网关地址
    [s1]int Vlanif 20
    [s1-Vlanif20]ip add 192.168.2.1 24
    [s1]int Vlanif 30
    [s1-Vlanif30]ip add 192.168.3.1 24
    [s1]int Eth-Trunk 1                     //配置Eth-Trunk
    [s1-Eth-Trunk1]int g0/0/1               //捆绑物理接口
    [s1-Eth-Trunk1]int g0/0/2
    [s1-Eth-Trunk1]int g0/0/3                 
    [s1-Eth-Trunk1] port link-type trunk    //使用trunk接口
    [s1-Eth-Trunk1] port trunk allow-pass vlan 10 20 30     //放行vlan10、20、30的流量

     

    sw4配置:

    [s2]vlan batch 10 20 30                 //需要在三层交换机上面操作,创建三个vlan
    [s2]int Vlanif 10                       //虚接口
    [s2]int Vlanif 20
    [s2]int Vlanif 30
    [s2]int Eth-Trunk 1                     //配置Eth-Trunk
    [s2-Eth-Trunk1]int g0/0/1               //捆绑物理接口
    [s2-Eth-Trunk1]int g0/0/2
    [s2-Eth-Trunk1]int g0/0/3                 
    [s2-Eth-Trunk1] port link-type trunk    //使用trunk接口
    [s2-Eth-Trunk1] port trunk allow-pass vlan 10 20 30     //放行vlan10、20、30的流量

     

    配置access端口

    [s2]int g0/0/4
    [s2-GigabitEthernet0/0/4] port link-type access         //使用access接口
    [s2-GigabitEthernet0/0/4] port default vlan 10          //放行vlan10流量
    [s2]int g0/0/5
    [s2-GigabitEthernet0/0/5] port link-type access
    [s2-GigabitEthernet0/0/5] port default vlan 20
    [s2]int g0/0/6
    [s2-GigabitEthernet0/0/6] port link-type access
    [s2-GigabitEthernet0/0/6] port default vlan 30

     

     

     

     

     

     

     

    展开全文
  • 华为链路聚合配置

    万次阅读 多人点赞 2016-12-21 09:15:29
    运行环境:公司这边有2层楼 分别运行着不同的业务 本来两个楼层的网络是分开的...那又为什么要用配链路聚合呢(应为一根网线不够用啊) 原来的运行方式:2台S5700分别配置Eth-Trunk1 分别将需要通信的3条线路的端口加入
  • 华为链路聚合
  • 华为交换机链路聚合命令配置链路聚合1、创建聚合组sysinterface eth-trunk 22、配置聚合模式为手工模式interface eth-trunk 2mode manual load-balance 表示手工模式mode lacp lacp模式,可以自动检测链路是否错误;...
  • 手工负载分担模式链路聚合介绍了手工负载分担模式链路聚合配置场景、step及注意事项。1.1.1 建立配置任务1.1.2 创建Eth-Trunk1.1.3 (可选)配置Eth-Trunk 工作模式为手工负载分担模式1.1.4 向Eth-Trunk 中加入成员...
  • 点击上面“蓝字”关注我们 9.10文章目录一、为什么要用到聚合二、链路聚合三、拓扑四、基本配置五、部署 链路聚合课堂笔记一、为什么要用到聚合1、二层环境为什么要用到聚合(1)接入层的流量剧增;(2)现行存储数据...
  • 华为汇聚交换机链路聚合配置命令为了增加带宽和网络连接的安全性,一般汇聚交换机都会具备链路聚合的功能。华为汇聚交换机也不例外,本文主要介绍华为汇聚交换机S6500/S8500、S7800、S9300系列的链路聚合数据配置:...
  • 华为配置链路聚合

    2021-01-07 16:29:00
    1、手工负载分担模式链路聚合 手工负载分担模式下,Eth-Trunk的建立、成员接口的加入完全由手工来配置。该模式下所有活动链路都参与数据的转发,平均分担流量,因此成为负载分担模式。如果某活动链路故障,链路聚合...
  • CISCO交换机与华为交换机链路聚合 CISCO交换机与华为交换机链路聚合
  • 华为eNSP配置链路聚合

    千次阅读 2021-01-24 11:08:37
    链路聚合/链路捆绑/端口聚合/eth-channel。采用链路聚合技术可以在不进行硬件升级的条件下,通过将多个物理接口捆绑为一个逻辑接口,来达到增加链路带宽的目的。在实现增大带宽目的的同时,链路聚合采用备份链路的...
  • 链路捆绑/链路聚合/链路汇聚/ Etherchannel/以太网通道-定义将多个类似的链路,捆绑在一起,将其看作是一个端口来配置与使用从而增加设备之间的互联带宽,以实现降低数据转发延迟和丢包率等问题。-背景随着网络规模...
  • 华为与思科链路聚合

    2015-10-26 14:53:38
    链路聚合
  • 实验一:手工模式聚合链路 实验环境 实验思路 1.设置手工模式聚合链路 2.查看接口 具体实施 实验二:LACP模式聚合链路 实验环境 实验思路 1.将各个接口退出手工聚合链路 2.设置LACP模式聚合链路 3.比较优先级确认...
  • 华为交换机链路聚合命令

    千次阅读 2018-10-12 12:05:25
    配置链路聚合1、创建聚合组sysinterface eth-trunk 22、配置聚合模式为手工模式interface eth-trunk 2mode manual load-balance 表示手工模式mode lacp lacp模式,可以自动检测链路是否错误;3、将接口成员加入聚合...
  • 华为以太网链路聚合原理及配置

    千次阅读 2020-08-13 12:06:16
    链路聚合华为交换机中称Eth-Trunk,是将一组相同类型的物理以太网口绑定在一起的逻辑接口,是一种用于增加链路带宽的方法。该逻辑接口与物理接口一样,可以被配置为Access、Hybrid、Trunk或Tunnel端口类型,将其...
  • 基本知识概述链路聚合(Link Aggregation)是将—组物理接口捆绑在一起作为一个逻辑接口来增加带宽的一种方法。随着网络规模不断扩大,用户对骨干链路的带宽和可靠性提出越来越高的要求。在传统技术中,常用更换高速率...
  • 华为 Eth-Trunk链路聚合

    千次阅读 多人点赞 2020-09-09 20:11:32
    文章目录一、为什么要用到聚合二、链路聚合三、拓扑四、基本配置五、部署Link Aggregation-链路聚合 一、为什么要用到聚合 1、二层环境为什么要用到聚合 (1)接入层的流量剧增; (2)现行存储数据剧增; (3)监控...
  • 华为交换机链路聚合Eth-trunk实例

    千次阅读 2019-08-30 14:03:33
    链路聚合在中小企业特别盛行,因为可以用低成本的技术来提高核心链路的带宽,充分利用所有设备的端口及端口处理能力,增加设备间的带宽,并且在其中一条链路出现故障时,可以快速地将流量转移到其他链路,这种切换为...
  • HCIA-以太网链路聚合实验目的:1.增加链路带宽 2.提供链路备份 3.链路负载分担链路聚合模式简介手工模式: 手工模式不需要支持LACP协议,默认所有链路都是活动链路,进行有限的故障检查 LACP模式: 基于LACP协议动态...
  • 思科和华为交换机链路聚合命令对比在本人经历过的项目中,有思科交换机和华为交换机对接,通过链路聚合将两条以上物理线路绑在一起成为一条逻辑线路。因为是两个品牌的交换机,其中的配置不同,稍有差错将聚合不成功...
  • 以太网链路聚合是指将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。链路聚合分为手工模式和LACP模式。LACP模式需要有链路聚合控制协议LACP的参与。当需要在两个直连设备间提供一个较...
  • 华为 手动配置链路聚合

    千次阅读 多人点赞 2018-06-29 10:29:09
    一、组网需求 1、如图所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20,且SwitchA和SwitchB之间有...采用如下的思路配置负载分担链路聚合: 创建Eth-Trunk接口并加入成员接口,实现增加链路带宽。 创...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 389
精华内容 155
关键字:

华为链路聚合