精华内容
下载资源
问答
  • 思科DHCP配置命令

    千次阅读 2021-09-24 10:55:45
    DHCP配置 ip dhcp pool VLAN10 //定义DHCP地址池VLAN10为vlan id network 172.16.2.0 255.255.255.0 //配置地址池的网络和掩码 default-router 172.16.2.254 //配置默认网关 domain-name cisco.com //域名,可选...

    DHCP配置

    ip dhcp pool VLAN10                 //定义DHCP地址池VLAN10为vlan id

    network 172.16.2.0 255.255.255.0              //配置地址池的网络和掩码

    default-router 172.16.2.254                //配置默认网关

    domain-name cisco.com                   //域名,可选配置

    dns-server 172.16.1.100              //dns服务地址,可配置多个

    //可选配置

    分配WINS服务器地址netbios-name-server 172.16.2.30

    分配TFTP服务器地址option 150 ip 172.16.2.10

    ip dhcp excluded-address 172.16.2.200            //排除地址

    lease infinite                 //租期为无限长

    DHCP侦听(交换机上配置)

    ip dhcp snooping         //开启DHCP侦听功能

    ip dhcp snooping vlan 2-5         //配置侦听vlan2-5上的的DHCP数据包

    ip dhcp snooping information option       

    //开启交换机option 82功能,开启DHCP后该功能默认开启

    ip dhcp snooping database flash:dhcp_snooping_s2.db        

    //将DHCP监听绑定表保存在Flash中,文件名为dhcp_snooping_s2.db,目的是防止断电后,记录丢失。如果记录过多可以把文件保存到TFTP或者FTP服务器中

    ip dhcp snooping database write-delay 15

    //指监听绑定表发生更新后,等待15S,再写入文件,默认为300S,可选范围为15-86 400S

    ip dhcp snooping database timeout 15

    //指DHCP监听绑定表尝试写入操作失败后,重新尝试写入操作,直到15S后停止尝试。默认300S,可选范围为0-86400S。

    ip dhcp snooping information option allow-untrusted

    //配置交换机,如果从非信任端口接收到的DHCP数据包中带有option 82 选项,也接收该DHCP数据包,默认是不接收。

    interface port-channel 1

    ip dhcp snooping trust        //配置信任端口,默认所有端口都是非信任端口

    其他配置

    Interface range fastEthernet 0/1-20

    ip dhcp snooping limit rate 5             //限制接口每秒钟能接收DHCP数据包数量为5个

    Interface range fastEthernet 0/21-22

    ip dhcp snooping trust        //配置f0/21,f0/22为信任接口

    配置DAI(交换机上配置)

    ip arp inspection vlan 2-5           //在vlan2-5启用DAI

    ip arp inspection validate src-mac dst-mac ip

    //配置DAI要检查ARP数据包(包括请求和相应)中的源mac地址、目的mac地址、源ip地址和DHCP snooping绑定中的信息是否一致

    interface range fastEthernet 0/21-22

    ip arp inspection trust         //配置DAI信任接口

    interface range fastEthernet 0/1-20

    ip arp inspection limit rate 5              //限制接口每秒钟能接收DHCP数据包数量为5个

    DHCP中继

    Interface range vlan 2-5

    ip helper-address 172.16.2.1             //配置帮助地址,用于完成DHCP中继(在与中继设备链接的三层接口配置)

    show ip interface   vlan id                  //查看vlan信息 其中Helper address is是帮助地址

    show命令

    show ip dhcp pool              //查看地址池信息

    show ip dhcp binding          //查看已分配的地址

    show ip dhcp server statistics             //查看统计信息

    show ip dhcp snooping                    //查看侦听情况

    show ip dhcp snooping binding               //查看绑定表内信息

    show ip dhcp snooping database              //查看绑定表配置信息

    show ip arp inspection                      //查看arp配置信息

    show ip arp inspection interfaces              //查看arp可信接口

    文章笔记,如有侵权请联系删除!

    展开全文
  • 思科设备配置DHCP命令

    万次阅读 多人点赞 2019-03-24 14:16:45
    DHCP(Dynamic Host Configuration Protocol)基本知识点: ...2 、DHCP最常见的应用是,自动给终端设备分配IP地址,掩码,默认网关,但是DHCP也同样可以给终端设备自动配置其他options,比如DNS server,tim...

    DHCP(Dynamic Host Configuration Protocol)基本知识点:

    1 、DHCP协议在RFC2131中定义,使用udp协议进行数据报传递,使用的端口是67(DHCP服务器)和68(DHCP客户端)。

    2 、DHCP是最常见的应用,自动给终端设备分配IP地址,掩码,默认网关,但是DHCP也同样可以给终端设备自动配置其他options,比如DNS server,time zones, NTP servers 以及其他的配置内容,更有些厂家,利用自己开发的第3方软件,把自己的一些配置信息,利用dhcp协议来实现对终端设备的自动配置。

    3 、DHCP服务的系统最基本的构架是 client/server模式,client向server发请求去获取IP地址。并且如果client 和server不再同一个2层网络内(即广播可以到达的网络范围),则必须要有能够透过广播报文的中继设备,或者能把广播报文转化成单播报文的设备(cisco的ios就引进了这种功能)

    4、同一个网段DHCP服务器可以有多个,这不会影响终端设备从服务器获取配置信息,终端设备以接受到的第一组配置信息为准。以后收到的服务器返回的DHCP配置信息被抛弃。

    客户端在开机的时候会主动的发送讯息给网域上的所有机器,如果网域上没有DHCP主机,那么客户端计算机会发送四次请求信息,第一次等待时间为 1 秒,其余三次的等待时间分别是 9、13、16 秒。如果还是没有DHCP服务器的响应,那么在5分钟之后,客户端计算机会重复这一动作。

    参考:https://blog.csdn.net/killmice/article/details/53007476

     

    cisco设备DHCP配置:

    Router(config)#service dhcp //开启dhcp服务,默认开启

    Router(config)#no ip dhcp conflict logging //检测到地址冲突会记录到conflict,一旦记录在conflict里的ip地址就不会再分配,命令取消地址冲突记录日志,(由于可能手工配置了IP,dhcp在分配地址前会使用arp或ping的方式测试ip是否在存在,如果在用就排除,如果没用才会分配)

    Router(config)#ip dhcp pool vlan10 //创建dhcp地址池,名字为vlan10

    Router(dhcp-config)#network 192.168.1.0 /24 //地址范围

    Router(dhcp-config)#default-router 192.168.1.1 //分配的网关

    Router(dhcp-config)#dns-server 8.8.8.8 4.4.4.4 1.1.1.1 //分配的dns

    Router(dhcp-config)#lease 1 16 30 //租用期顺序是天、时、分,这样设置意思是1天16分30秒,默认是1天

    Router(config)#ip dhcp excluded-address 192.168.1.1 //排除192.168.1.1地址,不被分配

    Router(config)#ip dhcp excluded-address 192.168.1.10 192.168.1.20 //排除地址192.168.1.10-192.168.1.20的地址,不被分配

    Router(config)#ip dhcp ping packets 3 //DHCP服务器在分配一个地址之前,先对这个地址PING一下(不配置默认是PING两个包),用来确定这个地址是否已被其他主机所用。

     

    需要给MAC地址:aabb.cc00.0600分配特定的地址,需要另外创建地址池:

    Router(config)#ip dhcp pool pc2

    Router(dhcp-config)# host 192.168.2.188 255.255.255.0 //指定分配的ip地址

     Router(dhcp-config)# client-identifier aabb.cc00.0600 //为指定的aabb.cc00.0600 MAC的主机分配地址

    Router(dhcp-config)# default-router 192.168.2.1  //分配的网关

     

    Router(config-if)#ip helper-address 10.1.1.1 //dhcp代理,地址指向dhcp服务器的地址,在需要向dhcp获取地址的接口下配置,前提是要和dhcp 10.1.1.1服务器能通

     

    关于DHCP保护功能,需要在接入交换机上配置

    DHCP Snooping(DHCP保护):

    Switch(config)#ip dhcp snooping //开启dhcp snooping 功能

    Switch(config)#ip dhcp snooping vlan 10 //snooping为vlan 10生效,只监控vlan10

    Switch(config)#no ip dhcp snooping information option //关闭添加选项字段,默认为添加选项字段,如果添加选项dhcp服务器可能无法识别;或者在DHCP服务器端添加Switch(config-if)#ip dhcp relay information trusted 命令,信任information选项字段。

    Switch(config-if)#ip dhcp snooping trust //上连接口配置为信任,默认所有接口都是非信任接口,非信任接口不能发送offer包

     

    Source Guard(IP原保护):

    Switch(config-if)#ip verify source //接口开启ip原保护功能,客户端手动设置的ip地址就无法访问网络,通过source binding表只校验ip地址

    Switch(config)#ip source binding aabb.CC00.0310 vlan 10 192.168.1.2 interface Et0/1 //如果想让某台设备手动设置ip地址可以访问网络,需要手动配置这条命令

     

    Switch(config-if)#switchport  port-security //开启端口安全

    Switch(config-if)#ip verify source port-security //配合端口安全使用以及配合ip verify source使用,同时校验ip地址和mac地址,通过source binding表校验

     

     

    Dynamic ARP Inspection (DAI,动态ARP侦测):

    Switch(config)#ip arp inspection vlan 10 //只检测vlan

    Switch(config-if)#ip arp inspection trust //上行链路配置为信任接口,默认所有接口为非信任

     

     

    在开启了DHCP服务的上查看命令:

    show ip dhcp pool //查看DHCP 地址池的信息

    show ip dhcp pool vlan20 //查看vlan20地址池情况

    show ip dhcp binding //查看地址分配情况

    show ip dhcp conflict  //查看检冲突导致ip而不会被分配的地址

     

    clear ip dhcp binding * //清除所有dhcp地址分配地址记录

    clear ip dhcp conflict  //清除conflict 记录

     

    如果是用路由器模拟pc获取ip地址,可以在模拟pc的设备上用以下命令查看获取情况:

    Router#show dhcp lease //查看获取的IP地址、掩码、网关等参数

    Router#show dhcp server //查看获取的dns信息

     

    在接入交换机上查看snooping信息:

    Switch#show ip dhcp snooping //查看snooping信息

    Switch#show ip dhcp snooping binding //查看终端获取的地址对应信息

    Switch#show ip source binding //source binding表和snooping binding信息一样

     

    展开全文
  • Cisco DHCP配置实验

    万次阅读 多人点赞 2018-05-22 16:35:40
    一、PC动态获取IP地址(路由器做DHCP服务器) 1. 拓扑图 2. 配置步骤(有些顺序不...3. 配置命令 三、跨网段的动态获取IP地址(路由器做DHCP服务器)即分配不同网段 1. 拓扑图 2. 配置步骤(有些顺序不重要) 3....

    一、PC动态获取IP地址(路由器做DHCP服务器)

    1. 拓扑图

    这里写图片描述

    2. 配置步骤(有些顺序不重要)

    1.创建地址池
    2.分配的地址池范围
    3.配置网关
    4.配置dns
    5.给路由器端口配置IP
    6.如有需要则配置不自动分配的地址段或某个地址

    3. 命令配置(之后的命令解析参考该实验)

    Router>en
    Router#config t
    Router(config)#ip dhcp pool LAN (创建地址池,名字(LAN)自定义)
    Router(dhcp-config)#network 192.168.1.0 255.255.255.0 (地址池范围)
    Router(dhcp-config)#default-router 192.168.1.1 (默认网关)
    Router(dhcp-config)#dns-server 192.168.1.2 (dns-server服务)
    Router(dhcp-config)#int fa 0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0 (路由端口IP)
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.9 (表示某一段IP地址不由DHCP分配)
    Router(config)#ip dhcp excluded-address 192.168.1.254 (表示某一个IP地址不由DHCP分配)

    二、路由器端口动态获取IP地址(路由器做DHCP服务器)

    1. 拓扑图

    这里写图片描述

    2. 配置步骤(有些顺序不重要)

    R1:
    1.创建地址池
    2.分配地址池范围
    3.分配网关
    4.分配DNS
    5.给路由器配置端口IP
    6.如有需要则配置不自动分配的地址段或某个地址

    R2:
    1.进入接口
    2.配置接口使用动态的方式从DHCP服务器获得IP地址

    3. 配置命令

    R1的配置和上面路由器配置一样
    Router1:
    Router>en
    Router#config t
    Router(config)#ip dhcp pool LAN
    Router(dhcp-config)#network 192.168.1.0 255.255.255.0
    Router(dhcp-config)#default-router 192.168.1.1
    Router(dhcp-config)#dns-server 192.168.1.2
    Router(dhcp-config)#int fa 0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.9
    Router(config)#ip dhcp excluded-address 192.168.1.254

    Router2:
    Router>en
    Router#config t
    Router(config)#int fa 0/0
    Router(config-if)#ip address dhcp (配置接口使用动态的方式从DHCP服务器获得IP地址)
    Router(config-if)#no shutdown
    Router(config-if)#end
    Router#show ip int fa 0/0 (查看接口IP)

    三、跨网段的动态获取IP地址(路由器做DHCP服务器)即分配不同网段

    1. 拓扑图

    这里写图片描述

    2. 配置步骤(有些顺序不重要)

    1.创建地址池
    2.分配地址池范围
    3.分配网关
    4.分配DNS
    5.如有需要则配置不自动分配的地址段或某个地址
    (由于有两个网段,所以要配置两次,修改范围、网关、dns、ip及地址)
    6.给路由器接口配置IP

    3. 配置命令

    Router>
    Router>en
    Router#config t
    Router(config)#ip dhcp exclude 192.168.10.1 192.168.10.9
    Router(config)#ip dhcp pool a
    Router(dhcp-config)#network 192.168.10.0 255.255.255.0
    Router(dhcp-config)#default-router 192.168.10.1
    Router(dhcp-config)#dns-server 192.168.10.1
    Router(dhcp-config)#exit

    Router(dhcp-config)#ip dhcp exclude 192.168.11.1 192.168.11.9
    Router(config)#ip dhcp pool b
    Router(dhcp-config)#network 192.168.11.0 255.255.255.0
    Router(dhcp-config)#default-router 192.168.11.1
    Router(dhcp-config)#dns-server 192.168.11.1

    Router(config-if)#int fa0/0
    Router(config-if)#ip address 192.168.10.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#int fa0/1
    Router(config-if)#ip address 192.168.11.1 255.255.255.0
    Router(config-if)#no shutdown

    四、跨网段的动态获取IP地址(计算机做DHCP服务器)

    1. 拓扑图

    这里写图片描述

    2. 配置步骤

    1.给路由器端口配置IP
    2.给不和DHCP服务器在同一网段的客户端设备指定服务器
    3.配置服务器IP
    4.配置服务器DHCP

    3. 配置命令

    Router>en
    Router#configure terminal
    Router(config)#interface FastEthernet0/0
    Router(config-if)#ip address 192.168.10.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config)#interface FastEthernet0/1
    Router(config-if)#ip address 192.168.11.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#int fa 0/0
    Router(config-if)#ip helper-address 192.168.11.5 (/指定dhcp服务器的地址,表示通过Ethernet0向该服务器发送DHCP请求包/ ,如果有多个服务器则再写该命令,改下地址)

    服务器配置:
    1.配置IP、掩码和网关
    2.配置DHCP:
    这里写图片描述

    五、无线自动获取IP

    六、DHCP知识点

    1. 关于ip helper-address命令

    在客户端设备和DHCP服务器不在同一广播域内的时候,中间设备即路有器(路有功能的设备)必须要能够转发这种广播包,具体到cisco的设备上,则启用ip helper-address命令,来实现这种中继。

    2.DHCP服务器分配地址原理

    DHCP服务器要给终端设备分配地址则需要掌握两个重要的信息:
      第一,该客户端设备所在网络的子网掩码,DHCP服务器依据子网掩码的信息来判断,服务器该分配哪个IP地址,以使得该ip地址在那个子网内,
      第二,DHCP服务器必须知道客户端的MAC地址,以维护DHCP服务器的ip 地址和MAC之间的映射关系,由此保证同样一台客户机,每次启动后能获得和前一次相同的ip地址。

    3.DHCP请求过程

    配置了ip helper-address命令之后的路由器在中继DHCP请求时的工作过程如下:
      a,DHCP客户端发送请求,由于没有ip地址,所以自己的源IP地址为0.0.0.0,而且也不知道目的DHCP服务器的地址,所以为广播255.255.255.255。该数据报中当然还包含其他信息,比如二层的信息,源mac地址,和目的mac地址FFFFFFFFFFFF。
      b,当路由器接收到该数据报的时候,他就用自己的接口地址(接收到数据报的接口)来取代源地址0.0.0.0,并且用ip help-address 命令中指定的地址来取代目的地址255.255.255.255
      c,当DHCP服务器接收到路有器转发过来的DHCP请求包时,他有了足够的信息,(由源IP地址中的地址,确定客户机所在的子网掩码,由此分配相应地址池中的空闲地址,并且知道了客户记得MAC地址,把它写入自己的数据库,建立IP地址和MAC的映射关系)然后DHCP服务器做出响应,并且由路有器把数据报转发会客户端。(整个过程应该在客户机和服务器之间还有一次会话,由于这不是路由器DHCP配置的讨论重点,这里不谈)
      4、如果配置了两个DHCP服务器,我们必须分别用ip helper-address 命令指明,路有器会转发DHCP请求包到所有的DHCP服务器上。很多企业的做法都是至少有两台DHCP服务器,有提高冗余和可靠性的作用。此时,如果客户端受到几个来自不同DHCP服务器的应答,则只选择最先接收到的应答数据报。
      

    4. ip helper-address 命令的注意事项

      必须要注意的是:ip helper-address 命令不仅仅是只转发DHCP请求包,事实上,在默认情况下,他还转发其他的UDP报(比如DNS请求)到ip helper-address命令所指定的服务器上,所以这种额外的数据流量可能会增加DHCP服务器链路的负担以及服务器CPU负担。

    5. DHCP好处:

    避免手工设置IP与子网掩码产生的错误。避免IP地址冲突。
    灵活设置地址租期(需要查资料)
    DHCP属于TCP/IP标准协议。
    与DHCP相似的协议:BOOTP(主用于收银终端)都是客户/服务模式,都使用UDP的67和68号端口。BOOTP需预先手工配置主机信息。

    参考链接:https://zhidao.baidu.com/question/552774419.html

    展开全文
  • 思科交换机VLAN,DHCP配置模拟实例

    千次阅读 2020-10-10 15:15:04
    1.要求: 左边的电脑自动获取IP为192...3.点击最上面那个交换机,开始配置(图里的交换机型号有误,应该是2960) 4.建立 vlan 10并分配IP地址 Switch> Switch>enable Switch#conf t Enter configuration command

    1.要求:
    左边的电脑自动获取IP为192.168.1.1段
    右边的电脑自动获取IP为192.168.2.1段
    在这里插入图片描述
    2.开始准备工作,f0/1接左边交换机,f0/2接右边交换机,实际工作中,一定要接这个口,你要是接反了或者接到其他口去,获取的IP就不对了
    在这里插入图片描述

    3.点击最上面那个交换机,开始配置(图里的交换机型号有误,应该是2960)
    在这里插入图片描述
    4.建立 vlan 10并分配IP地址
    Switch>
    Switch>enable
    Switch#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface vlan 10
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#
    在这里插入图片描述
    5.配置DHCP地址池和相应参数(实际运用中你可能上不去网,改下DNS地址就行了)
    Switch(config)#ip dhcp pool 10 (建立名为 10 的地址池)
    Switch(dhcp-config)#network 192.168.1.0 255.255.255.0(网络地址)
    Switch(dhcp-config)#dns-server 192.168.1.1(DNS 地址)
    Switch(dhcp-config)#default-router 192.168.1.1(默认网关)
    Switch(dhcp-config)#exit
    Switch(config)#ip dhcp excluded-address 192.168.1.1(设置保留不分配的 IP地址)
    Switch(config)#exit
    Switch#
    在这里插入图片描述
    6.进入端口 f0/1 ,并把端口加入vlan 10
    Switch(config)#interface f0/1
    Switch(config-if)#switchport access vlan 10 (打完这个还要按一次回车,如图)
    附:删除vlan和多个端口加入vlan,这个我没有试
    在这里插入图片描述
    在这里插入图片描述
    7.查看电脑端是否能自动获取IP
    在这里插入图片描述
    在这里插入图片描述
    8.再加两台电脑,依旧正常获取IP,左边设置完成在这里插入图片描述
    9.设置右边交换机,重复456即可,依旧在最上面那个交换机里设置,全命令如下
    Switch>enable
    Switch#conf t
    Switch(config)#interface vlan 20
    Switch(config-if)#ip address 192.168.2.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#ip dhcp pool 20
    Switch(dhcp-config)#network 192.168.2.1 255.255.255.0
    Switch(dhcp-config)#dns-server 192.168.2.1
    Switch(dhcp-config)#default-router 192.168.2.1
    Switch(dhcp-config)#exit
    Switch(config)#ip dhcp excluded-address 192.168.2.1
    Switch(config)#exit

    Switch#conf t
    Switch(config)#interface f0/2
    Switch(config-if)#switchport access vlan 20
    在这里插入图片描述
    在这里插入图片描述
    10.模拟实验完成。
    注:vlan 10和 vlan 20 是不能互通的,互通要额外的设置,这个还不会,哪天学会了补上来

    展开全文
  • Cisco思科三层交换机配置DHCP服务

    万次阅读 多人点赞 2020-01-22 16:53:01
    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢? 在小型网络中直接将DHCP服务直接配置在核心三层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省...
  • 思科 三层交换 DHCP配置

    千次阅读 2018-12-22 16:06:54
    思科 三层交换 DHCP配置 :   拓扑结构:   步骤: 在SW1和SW2上分别完成VLAN配置,并在VLAN中添加相应的端口成员,同时配置Trunk端口      在L3Switch 上创建VLAN10 和VLAN20 ,并配置VLAN10 的虚...
  • 思科交换机 DHCP 服务配置

    万次阅读 2019-01-12 15:16:04
    说明:有 3 个 VLAN,VLAN2 与 VLAN3 是用户 VLAN,而 VLAN 88 则是 DHCP 服务器的 VLAN,在实验演示一中,DHCP 服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP 服务器则在后续中继的过程中使用到。 ...
  • 思科DHCP中继配置实例

    2021-04-10 21:54:31
    DHCP中继代理实验 一.简介 1.什么是DHCP中继 DHCPRelay(DHCPR)DHCP中继(也叫做DHCP中继代理)是DHCP衍生出来的一个新技术,其功能是可以实现在不同子网之间处理和转发dhcp信息的功能。 2.DHCP中继工作原理 1....
  • Cisco最全配置命令

    2018-12-13 15:36:34
    DHCP配置 4 静态路由 6 浮动静态路由 6 向网络中注入一条默认路由 7 RIP 8 RIP的基本配置 8 被动接口与单播更新 10 RIPv2的基本配置 11 RIPv 2的手动汇总 13 RIPv2认证和触发更新 13 EIGRP配置 17 Eigrp的基本配置 ...
  • DHCP中继配置思科

    千次阅读 2020-01-18 11:35:19
    1、配置 DHCP 客户端 确保每个 PC 为 自动获取IP地址的方式; 2、配置SW1、SW2、SW3、SW4 为4台交换机相连接的二层端口配置trank确保vlan间通过中继链路通信 3、配置VTP域 使交换机之间互相学习VLAN表(VTP...
  • 路由器的DHCP功能及配置命令

    千次阅读 2017-05-21 09:39:44
    DHCP的功能 ...动态分配是使用动态主机配置协议(Dynamic Host Configuration Protocol,DHCP),由网络站点提出DHCP请求,从DHCP地址服务器上自动获取一个IP地址与缺省网关、域名及域名服务器的I
  • 思科模拟器-DHCP配置

    千次阅读 2019-04-29 14:55:00
    一、如图做好以下拓扑图(下图我取消显示端口号) 二、配置最下面的四台上网终端为自动获取ip 三、配置中间的二层交换机:添加vlan,同时所有端口设为access类型并将其...六、配置dhcp并启动dhcp服务 七、...
  • 思科 DHCP服务器配置DHCP中继

    千次阅读 2018-01-15 14:00:26
    思路:1、配置 DHCP 客户端 确保每个 PC 为 自动获取IP地址的方式;2、配置 SW1 # 创建 VLAN 10 , 20 # 将相关的端口,放入到对应的 VLAN ; # 配置交换机之间的互联链路 - Trunk ;3、配置 SW # 创建 VLAN 10 ...
  • 三层交换机作为DHCP服务器,路由器作为DHCP中继,PC通过DHCP中继获取IP地址 实验拓扑: 配置步骤: 1. 配置路由器和三层交换机端口IP地址 Router6: R6#conf t R6(config)#int f0/0 R6(config-if)#ip address ...
  • 思科DHCP配置和DHCP中继的配置

    千次阅读 多人点赞 2019-06-02 19:38:46
    三层设备充当DHCP服务器的配置 拓扑图 主要应用于小型企业上,直接在三层设备上开启DHCP服务,为用户分配地址 直接在三层设备(SW1)上配置 interface Vlan10 ip add 192.168.10.254 255.255.255.0 ...
  • 实验拓扑: DHCP 服务器配置:     
  • 华为DHCP池塘配置 [r1]dhcp enable (先开启DHCP服务) [r1]ip pool a [r1-ip-pool-a]network 192.168.1.0 mask 255.255.255.0 [r1-ip-pool-a]gateway-list 192.168.1.254 [r1-ip-pool-a]dns-list 114.114.114.114 ...
  • Cisco 防火墙 ASA DHCP 配置

    千次阅读 2019-01-17 19:16:10
    1、网络初始化(防火墙 IP...3、配置 DHCP 功能以及特性,实现内网能够获取到地址 4、验证 5、DHCP 的其他参数 6、子接口的形式配置方法 7、ASA 上面的 DHCP 中继配置方法 8、NAT 配置,使得内网用户能够访问 intern...
  • 思科模拟器配置DHCP的几种方式

    万次阅读 多人点赞 2019-10-29 16:44:51
    思科模拟器配置DHCP的几种方式 第一种:基于三层交换机+路由器的DHCP拓扑图 1.知识点梳理: 二层交换机: 配置vlan 端口划分进vlan 连向三层的端口配置trunk模式 三层交换机: 配置vlan vlan端口配置ip 连向路由...
  • 思科路由器配置命令(一)

    千次阅读 2020-09-29 16:01:46
    一、路由器基本配置命令 R1>enable 进入特权模式 R1#disable 退出特权模式 R1> R1#configure terminal 进入全局配置命令 R1(config)#no ip domain-lookup 关闭域名解析 R1(config)#hostname SW1 ...
  • DHCP协议-Cisco路由配置实例(命令详解)
  • 文章详细技术了一个云计算项目中涉及到思科N9K设备的配置内容,N9K和普通的2系3系还是有比较大的不同,如果有同样喜欢研究路由协议的同学,可以留言相互交流。
  • 思科三层交换机配置DHCP中继

    千次阅读 2021-03-20 11:52:04
    三层交换机配置DHCP中继 实验目的: 通过本实验掌握如何给不同网段配置DHCP,掌握DHCP中继配置。 实验拓扑: 对交换机SW1进行预配置。 Switch>en Switch#conf t Enter configuration commands, one per line. ...
  • 3.配置PC PC0和PC1自动获取IP地址 4.配置路由器各个接口的IP地址 Router0 Router>en Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(conf...
  • cisco3560配置DHCP

    千次阅读 2016-07-07 10:25:05
    cisco3560上配置为例:开启3560的L3层功能,划分3个vlan,为每个vlan分配DHCP地址池。实现不同vlan不同的地址池。 3560(config)#vlan 3 3560(config-vlan)#name 17.31net 3560(config-vlan)#exit 3560(co
  • Cisco packet tracer下配置DHCP方法

    万次阅读 2017-06-06 17:36:35
    Cisco packet tracer下配置DHCP方法 ●.DHCP配置步骤:  ■ 启用DHCP服务(此软件默认为打开状态)  ■ 建立地址池,其标识符为自己喜欢的名字(如token)。下面的命令将对其设置。  ■ 设置DHCP地址池token的...
  • 思科 Packet Tracer 实验七 DHCP基本配置

    千次阅读 2020-05-18 19:52:52
    了解思科网络设备的配置基本特点及 IOS 命令基本操作方法 了解DHCP的工作原理及基本配置 二、实验内容 a) 实验拓扑 (两个路由器之间是Serial端口,需要添加WIC-2T模块,如何添加看这篇文章的开头:...
  • CISCO路由器DHCP 配置

    2017-11-12 19:34:00
    【基本配置】 R5充当DHCP 服务器 ip dhcp pool VLAN146 network 155.1.146.0 /24 default-router 155.1.146.4 dns 202.106.46.151 exit ! ip dhcp excluded-address 155.1.146.4 //排除地址 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,342
精华内容 2,536
关键字:

思科dhcp配置命令