精华内容
下载资源
问答
  • 两台主机之间的通信,但是VLAN不一样,这是就需要跨vlan通信了,这个实验报告就详细的介绍了跨vlan的通信
  • 这是三层交换机跨Vlan通信实验的Cisco Packet Tracer文件。实验包括有两个vlan,两个二层交换机,一个三层交换机。
  • 思科模拟器之跨VLAN通信VLAN(虚拟局域网)是对连接到的第二层交换机端口的网络用户的逻辑分段,不受网络用户的物理位置限制而根据用户需求进行网络分段。一个VLAN可以在一个交换机或者跨交换机实现。VLAN可以根据网络...
    思科模拟器之跨VLAN通信

    VLAN(虚拟局域网)是对连接到的第二层交换机端口的网络用户的逻辑分段,不受网络用户的物理位置限制而根据用户需求进行网络分段。一个VLAN可以在一个交换机或者跨交换机实现。VLAN可以根据网络用户的位置、作用、部门或者根据网络用户所使用的应用程序和协议来进行分组。基于交换机的虚拟局域网能够为局域网解决冲突域、广播域、带宽问题。

    物理层

    设备图表

    设备列表:三层交换机*1、二层交换机*2、PC*4

    设备接线:

                    Multilayer Switch1(F0/1)----Switch0(F0/24)

                    Multilayer Switch1(F0/2)----Switch1(F0/24)

                    Switch0(F0/1)----PC0

                    Switch0(F0/11)----PC1

                    Switch1(F0/1)----PC2

                    Switch1(F0/11)----PC3

    77341ccdffaf657fa3e6f5dddad0d7b6.png

    设备配置

    整体思路

        1. 二层交换机:划分VLAN,将与三层交换机连接点解的端口配置为串口

        2. 三层交换机:划分VLAN,为VLAN配置IP、子网源码,启动IP路由

    配置交换机0
    Switch>enSwitch#conf tSwitch(config)#vlan 10    //创建VLAN10Switch(config-vlan)#vlan 20    //创建VLAN20Switch(config-vlan)#exSwitch(config)#int ra f0/1-10        //配置1-10口Switch(config-if-range)#sw acc vlan 10    //划分为vlan10Switch(config-if-range)#exSwitch(config)#int ra f0/11-20Switch(config-if-range)#sw acc vlan 20Switch(config-if-range)#exSwitch(config)#int f0/24    //配置24口Switch(config-if)#sw mode tr    //转为串口模式Switch(config-if)#exSwitch(config)#

    acecec763999edfe3e804c19c45d0aae.png

    配置交换机1

    交换机1与交换机配置一样

    Switch>enSwitch#conf tEnter configuration commands, one per line.  End with CNTL/Z.Switch(config)#vlan 30    //创建VLAN30Switch(config-vlan)#vlan 10    //创建VLAN10Switch(config-vlan)#exSwitch(config)#int ra f0/1-10    //配置1-10口Switch(config-if-range)#sw acc vlan 30    //划分为VLAN30Switch(config-if-range)#int ra f0/11-20Switch(config-if-range)#sw acc vlan 10Switch(config-if-range)#exSwitch(config)#int f0/24    //进入24口Switch(config-if)#sw  mode tr    //转串口模式

    6aa804cb169c7ea79c39db36bdd01058.png

    配置三层交换机
    Switch>enSwitch#conf tSwitch(config)#vlan 10    //创建VLAN10Switch(config-vlan)#vlan 20Switch(config-vlan)#vlan 30Switch(config-vlan)#exSwitch(config)#int vlan 10    //配置VLAN10//配置IP及掩码,格式:ip add IP地址 子网掩码Switch(config-if)# ip add 192.168.10.1 255.255.255.0Switch(config-if)#exSwitch(config)#int vlan 20    //配置VLAN20Switch(config-if)# ip add 192.168.20.1 255.255.255.0Switch(config-if)#exSwitch(config)#int vlan 30Switch(config-if)# ip add 192.168.30.1 255.255.255.0Switch(config-if)#exSwitch(config)#int ra f0/1-2    //配置1-2口//将1-2口转为ACCESS口再转为串口模式Switch(config-if-range)#sw mode accSwitch(config-if-range)#sw mode trunkSwitch(config-if-range)#exSwitch(config)#ip routing    //启用IP路由功能

    c04b60f5ce56e697f03f04ebe24a5162.png

    show run信息

    三层交换机

    ip routinginterface FastEthernet0/1switchport trunk encapsulation dot1qswitchport mode trunkswitchport nonegotiate!interface FastEthernet0/2switchport trunk encapsulation dot1qswitchport mode trunkswitchport nonegotiateinterface Vlan10mac-address 000b.bea4.6201ip address 192.168.10.1 255.255.255.0!interface Vlan20mac-address 000b.bea4.6202ip address 192.168.20.1 255.255.255.0!interface Vlan30mac-address 000b.bea4.6203ip address 192.168.30.1 255.255.255.0

    59e5a56df8b1d210ea3e4acb44b311e4.png

    78d905ee10d7e64d5ec6a8f4433e7885.png

    二层交换机

    interface FastEthernet0/1switchport access vlan 10switchport mode accessinterface FastEthernet0/11switchport access vlan 20switchport mode accessinterface FastEthernet0/24switchport mode trunkinterface Vlan10mac-address 00e0.f736.e701no ip address!interface Vlan20mac-address 00e0.f736.e702no ip address!interface Vlan30mac-address 00e0.f736.e703no ip address

    16caae8b51ed92d87b450ef989dc7fd4.png

    4ea475e53d371fb3b5624ac50a36bb44.png

    测试

    配置网络信息

    配置PC0-3 IP地址、掩码及网关

    ea9ffd6044342830b9722161c0dc8a7c.png

    ping测试

    将PC0 ping PC1-3的IP

    如果访问正常即成功

    37d87e524a6c287dc6089fcd9218e02b.png

    实验结束

    需要源文件公众号回复"跨VLAN"

    --END--

    展开全文
  • 跨vlan通信-----单臂路由技术 实验目标: 1):实现跨vlan通信 为什么要使用vlan: 1):提高性能-----------------同一个广播域发送广播,造成网络堵塞。 2):提高安全性--------------同一广播域中,机器设备过多...

    跨vlan通信-----单臂路由技术

    实验目标

    1):实现跨vlan通信

    为什么要使用vlan

    1):提高性能-----------------同一个广播域发送广播,造成网络堵塞。

    2):提高安全性--------------同一广播域中,机器设备过多,安全性降低。

     

    实验网络拓扑

    wKiom1UuNUmhmGx3AAEEn9LDkzQ874.jpg

    pc1                             pc2

    wKiom1UuNb7BQFuPAABQksw8cxU222.jpgwKioL1UuNxHCGj8QAABMWHUz_Vs391.jpg

    pc3                                 pc4

    wKiom1UuNb6BBuznAABTwXmumB8884.jpgwKioL1UuNxHCyQijAABOvCy4nJg174.jpg



    VLAN划分与设定

    进入交换机1

    <Huawei>system-view

    [Huawei]vlan bat 10 20//新建vlan10vlan20

    [Huawei]intg0/0/1//进入g0/0/1接口

    [Huawei-GigabitEthernet0/0/1]portlink-type access// 只允许一条通过

    [Huawei-GigabitEthernet0/0/1]port default vlan 10//将默认的接口加入vlan10

    [Huawei-GigabitEthernet0/0/1]int g0/0/2进入到g0/0/2接口

    [Huawei-GigabitEthernet0/0/2]portlink-type access//只允许一条默认接口通过

    [Huawei-GigabitEthernet0/0/2]port default vlan 20//将默认接口加入vlan20

    [Huawei]int g0/0/5//进入到g0/0/5接口

    [Huawei-GigabitEthernet0/0/5]port link-type trunk//转为中继口模式

    [Huawei-GigabitEthernet0/0/5]port trunk allow-pass vlan 10 20//默认的接口可以通过vlan10vlan20

    [Huawei-GigabitEthernet0/0/5]intg0/0/24

    [Huawei-GigabitEthernet0/0/24]portlink-type trunk

    [Huawei-GigabitEthernet0/0/24]port trunk allow-pass vlan 10 20

    注:

    在交换机中新建两个vlan.vlan10vlan20.pc1加入到vlan10.pc2加入到vlan20.再将交换机的两个接口都设置成中继口模式.设置成所有成员通过.即可以通过vlan10vlan20

     

    [Huawei]display vlan//查看vlan

    wKiom1UuNffgRLCPAAGOGSI_F6c374.jpg

    通过上图.我们看以看出新建的vlan.已经将默认接口加入到vlan当中了

     

    进入交换机2

    <Huawei>system-view

    [Huawei]vlan bat 10 20//新建vlan10vlan20

    [Huawei]intg0/0/3//进入到g0/0/3接口

    [Huawei-GigabitEthernet0/0/3]portlink-type access//只允许默认接口通过

    [Huawei-GigabitEthernet0/0/3]portdefault vlan 10//将默认接口加入vlan10

    [Huawei]intg0/0/4//进入g0/0/4接口

    [Huawei-GigabitEthernet0/0/4]portlink-type access//只允许默认接口通过

    [Huawei-GigabitEthernet0/0/4]portdefault vlan 20//将默认接口加入到vlan20

    [Huawei-GigabitEthernet0/0/4]intg0/0/5//进入g0/0/5接口中

    [Huawei-GigabitEthernet0/0/5]portlink-type trunk //转接到中继口模式

    [Huawei-GigabitEthernet0/0/5]porttrunk allow-pass vlan 10 20//允许默认接口可以通过vlan10vlan20

    在交换机中新建两个vlan.vlan10vlan20.pc3加入到vlan10.pc4加入到vlan20.再将交换机的一个接口设置成中继口模式.即可以通过vlan10vlan20. Vlan10中有pc1pc3//vlan20中有pc2pc4

    trunk链路也叫干道链路,使得两个不同的vlan能够像通.允许设定的vlan通过!如:设定trunk为一条线.3vlana.b.c)在trunk线两边.trunk线设定了只允许vlana.b)通过,那么vlanc)是不能通过trunk线的。

     

    [Huawei]displayvlan//查看vlan

    wKioL1UuN17R2frUAAFUHmQ41sE160.jpg

    通过上图.我们看以看出新建的vlan.已经将默认接口加入到vlan当中了,上图中我们已经新建的vlan,并将默认接口加入到其vlan当中,在交换机的g0/0/5接口,我们将其转为中继口模式.因为vlan10vlan20都要通过.

     

    路由器R1

    <Huawei>system-view

    [Huawei]int g0/0/1//进入到g0/0/1接口

    [Huawei-GigabitEthernet0/0/1]ip add 12.0.0.1 30//设置默认接口ip

    [Huawei]ip route-static 0.0.0.0 0.0.0.0 12.0.0.2//

    这是设置路由路径默认路由:0.0.0.0+掩码+ip地址

    注:0.0.0.0 表示所有IP地址 掩码为012.0.0.2为转接的下个地址

     

    单臂路由实现跨vlan通讯的配置命令和方法

    路由器R2

    [Huawei]int g0/0/1

    [Huawei-GigabitEthernet0/0/1]ip add12.0.0.2 30

    [Huawei]ip route-static 0.0.0.0 0.0.0.0 12.0.0.1

    [Huawei]int g0/0/0.1//定义子端口0.1//在路由器以太网接口上划分子接口,使用以太网的子接口的ip地址作为网关,并且在子接口上封装802.1q协议.每个都可以划分为“1—4096”个子接口

    [Huawei-GigabitEthernet0/0/0.1]dot1q terminationvid 10//封装dot1q

    [Huawei-GigabitEthernet0/0/0.1]ip add 192.168.1.124//用以太网的子接口的ip地址作为网关

    [Huawei-GigabitEthernet0/0/0.1]arp broadcast enable// 使能终结子接口的ARP广播功能

    [Huawei-GigabitEthernet0/0/0.1]int g0/0/0.2

    [Huawei-GigabitEthernet0/0/0.2]dot1qtermination vid 20//

    [Huawei-GigabitEthernet0/0/0.2]ip add192.168.2.1 24//设置其划分子接口的默认网关

    [Huawei-GigabitEthernet0/0/0.2]arp broadcast enable//使能终结子接口的ARP广播功能

     

    [Huawei]dis ip int b//查看设备当前配置

    wKioL1UuN26hrRn4AAD387NiHt0678.jpg

    注:可以看到.划分的两个子接口中的默认网关已设置.并且接口是开着的.

    在数据帧传输的时候,交换机会给帧添加一个标签,即:dot1p标签交换机按照他的vid来确定他是属于哪一个vlan如:dot1q termination vid 10”vid 10  是属于vlan 10中的

     

    检验:

    Pc机与默认网关能够ping通。

    Pc机与其他pc机能够ping通。

    wKioL1UuN5DBFz83AAFLijIsxnU671.jpg

    wKioL1UuN5DAVxgwAAEr5oSeuoU453.jpg

    wKiom1UuNj3xTrrYAAEvvKlnrjY248.jpg

    wKiom1UuNj2CTgKvAAFTG3cBpxQ713.jpg


    结论:

    1vlan可以通过控制交换机有效分派出入局域网的分组到正确的出入端口,达到对不同实体局域网中的设备进行逻辑分群管理。

    2vlan的划分,“即将一个大的广播域.划分为多个广播域”,可以降低局域网内大量数据流通,优化网络的联通性能。

    3Vlan还有隔离功能,在同一个局域网.设备过多会有安全隐患.vlan的划分.可以大大降低。

     

    思考.

    pc机分为两个网段,不要路由,.不划分vlan Pc1发送广播报文pc2能否收到广播?

     

    答:

    能够收到广播,虽然没有划分vlan,但在他们基础之上本就有一个vlan,即vlan 1

    解析:

    ip地址设为不通网段.就认为广播收不到,这是自欺欺人的,

    这就是化vlan到原因,划分了vlan之后  不管你在同一个网段还是不在同一个网段.他们都能通。










    本文转自 于学康 51CTO博客,原文链接:http://blog.51cto.com/blxueyuan/1633053,如需转载请自行联系原作者

    展开全文
  • 华为跨vlan通信

    2020-05-14 21:35:42
    拓扑 要求:pc2可以ping通pc4,5,6 pc4可以ping通pc5 pc6只能ping通pc2 sw1: sw2 sw3 结果: pc2可以ping通pc4,5,6 pc4可以ping通pc5 pc4与pc5不能ping通pc6

    拓扑
    在这里插入图片描述要求:pc2可以ping通pc4,5,6
    pc4可以ping通pc5
    pc6只能ping通pc2

    sw1:
    在这里插入图片描述
    sw2
    在这里插入图片描述
    sw3
    在这里插入图片描述结果:
    在这里插入图片描述在这里插入图片描述
    pc2可以ping通pc4,5,6

    在这里插入图片描述
    pc4可以ping通pc5
    在这里插入图片描述pc4与pc5不能ping通pc6

    展开全文
  • 一、在一台交换机下分配VLAN 搭建网络拓扑,在一个交换机下分配VLAN,交换机使用CISCO的3725路由器模仿 启动所有设备,并为每台PC配置IP地址 PC1> ip 192.168.0.101 255.255.255.0 Checking for duplicate ...

     一、在一台交换机下分配VLAN

     搭建网络拓扑,在一个交换机下分配VLAN,交换机使用CISCO的3725路由器模仿

     启动所有设备,并为每台PC配置IP地址

    PC1> ip 192.168.0.101 255.255.255.0
    Checking for duplicate address...
    PC1 : 192.168.0.101 255.255.255.0


    PC2> ip 192.168.0.102 255.255.255.0
    Checking for duplicate address...
    PC1 : 192.168.0.102 255.255.255.0

    PC3> ip 192.168.0.103 255.255.255.0
    Checking for duplicate address...
    PC1 : 192.168.0.103 255.255.255.0

    PC4> ip 192.168.0.104 255.255.255.0
    Checking for duplicate address...
    PC1 : 192.168.0.104 255.255.255.0

    接下来在交换机中分配每个端口的VLAN id。在交换机中建立两个VLAN,id分别是10 和20

    ESW1#vlan d
    % Warning: It is recommended to configure VLAN from config mode,
      as VLAN database mode is being deprecated. Please consult user
      documentation for configuring VTP/VLAN in config mode.

    ESW1(vlan)#vlan 10 name vlan10
    VLAN 10 modified:
        Name: vlan10
    ESW1(vlan)#vlan 20 name vlan20
    VLAN 20 modified:
        Name: vlan20
    ESW1(vlan)#apply
    APPLY completed.
    ESW1(vlan)#exit
    APPLY completed.
    Exiting....

     

    为f1/1 f1/2分配VLAN 10,为f1/3 f1/4分配VLAN20

    ESW1#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    ESW1(config)#int f1/1
    ESW1(config-if)#switchport mode access
    ESW1(config-if)#switchport access vlan 10
    ESW1(config-if)#exit
    ESW1(config)#int f1/2
    ESW1(config-if)#switchport mode access
    ESW1(config-if)#switchport access vlan 10
    ESW1(config-if)#exit
    ESW1(config)#int f1/3
    ESW1(config-if)#switchport mode access
    ESW1(config-if)#switchport access vlan 20
    ESW1(config-if)#ex
    ESW1(config)#int f1/4
    ESW1(config-if)#switchport access vlan 20
    ESW1(config-if)#exit

    在配置f1/4时我们没有设置端口的类型为access,但是最后得到的效果是一样的,说明交换机默认的端口类型为access

    access类型只允许被标记为被分配VLAN id的信息通过,如端口f1/4分配VLAN id 20,交换机中消息标签是20的消息才会被转发到该接口

    配完VLAN后各PC的通信状况

    二、跨交换机分配VLAN

    扩充网络拓扑如下

     

    和上文中分配IP地址一样,为PC5和PC6分配id 192.168.0.105 和192.168.0.106,类似的,在ESW2上建立两个VLAN id分别是10和20,并为f1/1和f1/2分别分配VLAN id 10和20

    到现在PC1 PC2 PC5属于VLAN10 ,PC2 PC3 PC6属于VLAN20 ,但还不能跨交换机通信,需要在两个交换机上配置汇聚链路 trunk

    ESW1(config)#int f1/0
    ESW1(config-if)#switchport mode trunk
    *Mar  1 00:33:06.135: %DTP-5-TRUNKPORTON: Port Fa1/0 has become dot1q trunk   //(可以看到trunk类型下默认是dot1q类型的封装,所以可以不用设置trunk的封装类型)
    ESW1(config-if)#switchport trunk allowed vlan all
    ESW1(config-if)#ex

    ESW2(config)#int f1/0
    ESW2(config-if)#switchport mode trunk
    *Mar  1 00:24:00.687: %DTP-5-TRUNKPORTON: Port Fa1/0 has become dot1q trunk
    ESW2(config-if)#switchport trunk allowed vlan all
    ESW2(config-if)#exit

     

    现在PC1 PC2 PC5可以互相通信 ,PC2 PC3 PC6可以互相通信,但是VLAN10和VLAN20不能互相通信

    三、利用单臂路由进行跨VLAN实验

    网络拓朴如下

     

    其中R1是c3725路由器,ESW连接R1的网络层接口

    将ESW的f1/5接口类型设置为trunk类型,和设置两个交换机之间的汇聚链路操作相同。

    启动R1的f0/0接口,并在配置f0/0两个子接口f0/0.1和f0/0.2的VLAN id 和ip地址

    R1#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R1(config-if)#no shutdown
    *Mar  1 00:03:33.375: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    *Mar  1 00:03:34.375: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R1(config-if)#ex
    R1(config)#int f0/0.1
    R1(config-subif)#encapsulation dot1Q 10
    *Mar  1 00:03:58.903: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    R1(config-subif)#ip address 192.168.0.1 255.255.255.0
    R1(config-subif)#ex
    R1(config)#int f0/0.2
    R1(config-subif)#en
    R1(config-subif)#encapsulation dot1Q 20
    R1(config-subif)#ip address 192.168.1.1 255.255.255.0
    R1(config-subif)#ex
    R1(config)#exit

     

    可以看到此时两个子接口都已经分配了IP地址,并且已打开

    一个物理接口的子接口需要在不同网段,所以为了使子接口f0/0.2可以和VLAN 20中的PC通信,将VLAN 20中的主机的IP地址的第三位修改为1,并将网关设置为192.168.1.1

    如主机PC3

     

    主机PC4和主机PC6分别设置 ip 192.168.1.104 255.255.255.0 192.168.1.1和ip 192.168.1.106 255.255.255.0 192.168.1.1

     

    为VLAN10中的主机添加网关192.168.0.1

    如PC1

    PC2和PC5分别设置ip 192.168.0.102 255.255.255.0 192.168.0.1和ip 192.168.0.105 255.255.255.0 192.168.0.1

    打开R1的路由功能,在配置环境下输入ip routing

    在VLAN10中的PC1上pingVLAN20中的PC6

     

     

     

     

     

     

     

         

     

    展开全文
  • 网络实验八:用路由器实现跨vlan通信 一:网络拓扑图如下: 详细的介绍前几次实验都已详细的说明啦,由于时间的关系,这次就简单明了的说明重点: 二:首先对交换机S1,S2进行配置即vlan的划分 s1: ...
  • 计算机网络实验报告:包含拓扑图的详细配置,以及实现原理分析。 计算机网络实验报告:包含拓扑图的详细配置,以及实现原理分析。
  • 1)华为的VLAN规则: ①所有数据帧在一个交换机内部转发时,必须存在标签 ②在每一个交换机的接口上均存在转发允许列表,只有被允许的流量才能通过该接口进或出 ③流量从一个接口出去时,可以继续携带标签或者被剥离...
  • 二层设备跨vlan通信

    2013-04-16 01:13:10
    三种端口接收到与缺省自己vlanid相同的帧时,它们就会接受,而不同时,access端口就丢弃。Trunk和Hybrid端口看看是否和自己允许的vlanid相同,相同时接受,不同时,抛弃。 在发送时,三种端口vlanid...
  • 实验涉及命令以及知识补充(涉及Vlan通过的以太网口需要设置为Trunk口) 单臂路由 父接口 no ip address ;删除实现单臂路由接口的IP no shutdown 虚拟子接口 R2(config)#int f0/0.10 ; 进入虚拟子接口 R2(config...
  • 拓扑如下: 其中g0/0.1与g0/0.2是基于g0/0口(物理端口)的虚拟端口,...注意:encapsulation dot1Q 10 为封装协议,其中10要与Vlan号一样,即vlan10的网关要封装dot1Q 10,vlan20封装dot1Q 20,以此类推。 PC1: ...
  • Hybrid技术------华为专利...和Trunk接口一样,Hybrid接口也能够允许多个VLAN帧通过并且还可以指定哪些VLAN数据帧被剥离标签。在设置允许指定的VLAN通过Hybrid端口之前,该VLAN必须已经存在。 Hybrid端口和Trunk端口...
  •         网络设备配置–2、通过交换机划分vlan         网络设备配置–3、生成树协议和端口聚合         网络设备配置–4、配置交换机端口安全         网络设备配置–5、配置静态...
  • 利用 trunk实现交换机VLAN通信
  • 设备VLAN通信

    2020-07-15 20:50:34
    在SW1上创建两个VLAN:10及20(分别将这两个VLAN分配给技术部与会计部),然后将GE0/0/1和GE0/0/2接口加入VLAN 10,那么这两个接口所连接的PC(PC1、PC2)也就加入了VLAN 10,并且它们属于同一个广播域。 将GE0/0/3加入...
  • 最近了解了一下VLAN的知识,根据现有设备搭建了如下网络环境,在此记录一下学习的过程。其中使用的两台交换机型号为H3C S5120-28P-SI,路由器的型号为H3C MSR 36-40,其中交换机为三层交换机,支持路由功能,并且...
  • 我们使用Trunk实现交换机VLAN通信。还有以太网通道的操作哦。 实验拓扑 两台交换机直连,每台下面再连接两台VPC,划分VLAN,地址规划如下: 名称 接口 VLAN 地址 PC1 SW1-f1/0 vlan 10 192.168.10.10/24 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 511
精华内容 204
关键字:

跨vlan通信