精华内容
下载资源
问答
  • 静态路由的配置

    2019-10-18 10:19:04
    静态路由的配置 简单的配置静态路由使得两台PC机互通 一:实验目的 1、掌握简单的IP地址配置 2、掌握路由器上接口的基础命令配置 3、掌握网络之间的静态路由配置方法 二:实验环境 装有GNS3软件的电脑 三:实验内容 ...

    静态路由的配置

    简单的配置静态路由使得两台PC机互通

    一:实验目的

    1、掌握简单的IP地址配置

    2、掌握路由器上接口的基础命令配置

    3、掌握网络之间的静态路由配置方法

    二:实验环境

    装有GNS3软件的电脑

    三:实验内容

    1、在GNS3中添加两台pc机和三台路由器,用交叉双绞线将PC机和路由器连接,然后把IP地址标记对应的接口旁边,(IP 地址自己随意标记,但同一网段的网络号是要相同的)。再点击开启,整个图已经一目了然了。如下图
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-sfS00bBa-1571365127127)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571361547557.png)]
    2、下面就开始配置PC机的IP地址和路由器的接口地址,双击点每一台机子,会出现一个弹框

    PC1、PC2配置IP地址的命令:ip(空格)ip地址(空格)网关地址
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-AVAWKEah-1571365127131)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571362953152.png)]
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-amXfh1uF-1571365127134)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571362999028.png)]
    路由器R1、R2、R3配置接口地址的命令:ip(空格)address(空格)接口地址(空格)子网掩码,首先先进入全局模式(config terminal),再进入接口模式(interface fastethernet 0/0),可以按几个字母再按键盘上的Tab键补全。每一个地址配置好之后再no shut

    R1
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-QvgKyzyC-1571365127136)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571363543147.png)]
    R2
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-WR9Yvtxt-1571365127139)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571363862278.png)]
    R3
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-WSvxXFEj-1571365127141)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571363972007.png)]
    每个地址配置完成之后可以在特权模式下输入show ip interface brief,查看接口是否配置好。
    在这里插入图片描述
    3、每个地址配置完成了,接下来配置路由器的静态路由。在全局模式下配置命令:ip route 网络号+子网掩码+下一跳地址

    R1
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-7rUewemh-1571365127143)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571364613772.png)]
    R2
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-83SU5ZmW-1571365127146)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571364640378.png)]
    R3

    R3比较特殊,因为有两个下一跳地址,所以要配置两条
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-3rZbQdzU-1571365127148)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571364662784.png)]
    4、现在已经都配置完成了,接下来就开始ping,看是否PC1、PC2互相通讯。

    在PC1上ping PC2
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-j59CZpEs-1571365127150)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571364781330.png)]
    在PC2上ping PC1
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-CNwYQvAN-1571365127153)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571364811896.png)]
    这个样子显示出来的就代表两台PC机已经互通了。

    展开全文
  • 等价静态路由、浮动静态路由、缺省静态路由的配置 等价静态路由 等价静态路由:只有下一跳地址不一样的N条路由。 等价静态路由在路由表中查看时,只显示一条路由但有N个不同下一跳。 等价路由的配置实验:  ...

    等价静态路由、浮动静态路由、缺省静态路由的配置


    等价静态路由

    • 等价静态路由:只有下一跳地址不一样的N条路由。
    • 等价静态路由在路由表中查看时,只显示一条路由但有N个不同下一跳。


      等价路由的配置实验:
      在这里插入图片描述
            根据该图,此实验R3与R2需要配置等价静态路由,R1与R4需要配置两条静态路由。
      R3路由的配置:
    interface  fa0/0
    no shutdown
    ip address 17.3.3.1 255.255.255.252
    exit
    interface fa1/0
    no shutdown
    ip address 17.3.3.14 255.255.255.252
    exit
    interface fa2/0
    no shutdown
    ip address 17.3.3.64 255.255.255.192
    exit
    ip route 17.3.3.128 255.255.255.192 17.3.3.2
    ip route 17.3.3.128 255.255.255.192 17.3.3.13
    show ip route
    

    上述配置过程中:
    ip route 17.3.3.128 255.255.255.192 17.3.3.2
    ip route 17.3.3.128 255.255.255.192 17.3.3.13
         例如该两条路由只有下一跳地址不相同,目的网络地址与子网掩码都相同的路由——称为等价路由。
    等价路由由于优先级相同,所以在转发数据时随机选择通过路由。

    R3路由配置结果:
    在这里插入图片描述
    由图可以看出有三条直连路由,一条静态路由,但含有两个不同的下一跳地址。

    浮动(备份)静态路由

    • 在一个链路中,优先级高的叫主静态路由,优先级低的叫浮动静态路由。
    • 浮动路由配置成功后,在路由表中查看时只显示主路由。
    • 当主路由失效(有故障)时,浮动路由加入路由表并起数据转发作用。
    • 数值越小,优先级越高

    缺省路由

    • 目的网络地址,子网掩码都是0的特殊路由
    • 缺省路由配置时,注意只有一个出口时可以配缺省路由,多出口不可以配缺省路由。
    • 如果报文的目的地址无法匹配路由表中任何一项,路由表将按照缺省路由转发。
    • 全0网络地址为 全网地址


      缺省路由的配置实验
      在这里插入图片描述
      R2路由配置代码:
    interface fa0/0 
    no shutdown
    ip address 10.0.12.1 255.255.255.0
    exit
    interface fa1/0
    no shutdown
    ip address 192.186.4.1 255.255.255.0
    exit
    ip route 0.0.0.0  0.0.0.0  10.0.12.2
    show ip route
    

    R2路由配置结果:
    在这里插入图片描述
        有图可以看出,有一条缺省路由S*,优先级为1。

    展开全文
  • 静态路由的配置实验

    千次阅读 2019-10-17 18:34:04
    静态路由的配置实验 路由器会根据自己的“路由表”转发数据,当路由表中同时存在静态路由和默认路由的时候,静态路由优先级最高,会最先发送静态路由的数据。本实验通过静态路由器实现三台PC互联互通。 静态路由的...

    静态路由的配置实验

    路由器会根据自己的“路由表”转发数据,当路由表中同时存在静态路由和默认路由的时候,静态路由优先级最高,会最先发送静态路由的数据。本实验通过静态路由器实现三台PC互联互通。

    静态路由的配置:Router(config)# IP route +网络号+子网掩码+下一跳

    1. 设置三台虚拟机和四台路由器。每台路由器设置128MB储存,储存路由表信息。在这里插入图片描述

    2. 三台虚拟机连接三块不同的虚拟网卡,关闭防火墙。打开网络共享中心。
      在这里插入图片描述
      点击Windows防火墙,启动或是关闭Windows防火墙。在这里插入图片描述
      关闭防火墙。
      在这里插入图片描述

    3. 连接所有设备并且标上设置的IP地址和端口号。
      在这里插入图片描述

    实验流程

    1. 首先将每台路由器的端口设置IP域。以R1为例,其两个端口IP分别为:f0/1,192.168.10.2;f0/0,192.168.20.1.
      在这里插入图片描述
      输入do show ip route显示
      在这里插入图片描述
    2. 设置PC机上的IP地址、子网掩码和默认网关。例如,Host1的IP:192.168.10.1;子网掩码:255.255.255.0;默认网关:192.168.10.2.默认网关就是路由器连接PC机端口的IP。在这里插入图片描述
    3. 现在手动配置每台路由器上的静态路由地址。以R1为例,现在R1的路由表里只有两个默认的与其相连的网段,要想与其他网段连通,就需要手动添加。没有与R1相连的有四个网段,分别是192.168.50.0;192.168.60.0;192.168.30.0和192.168.40.0.而R1无论是发送数据或是接收数据需要通过R2的f1/0端口,192.168.20.2即下一条。所以R1设置的静态路由地址其中的一个是这样写的:IP route 192.168.30.0 255.255.255.0 192.168.20.2.其他网段同理可得:IP route 192.168.40.0 255.255.255.0 192.168.20.2;IP route 192.168.50.0 255.255.255.0 192.168.20.2;IP route 192.168.60.0 255.255.255.0 192.168.20.2.在这里插入图片描述输入 do ip route显示在这里插入图片描述
      说明现在R1已经完成了静态路由配置。
    4. 现在R1完成了静态路由配置了,这时对其他路由器进行相似的操作进行静态路由配置。否则数据包发出不会回到R1路由器中,其他路由器会因为找不到R1所在的网段而进行丢包。
    5. 所有路由器完成静态路由配置后进行ping包。Host1pingHost2
      在这里插入图片描述
      说明Host1与Host2已经连通,再去ping其他Host ping通说明此实验成功。
    展开全文

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,940
精华内容 2,376
关键字:

静态路由的配置