精华内容
下载资源
问答
  • VRRP配置实例

    2021-07-12 22:22:24
    今天主要给大家介绍一下VRRP的相关配置,本位从一个现实中的需求开始,使用华为eNSP模拟器,实现华为设备上VRRP配置实例。 阅读本文,您需要对VRRP基础知识有一定的了解,如果您对VRRP还存在困惑,欢迎查阅VRRP...

    今天主要给大家介绍一下VRRP的相关配置,本位从一个现实中的需求开始,使用华为eNSP模拟器,实现华为设备上VRRP的配置实例。
    阅读本文,您需要对VRRP基础知识有一定的了解,如果您对VRRP还存在困惑,欢迎查阅VRRP详解

    一、实验要求及拓扑

    在这里插入图片描述
    实验拓扑如上所示,现在要求R1和R2使用VRRP配置虚拟网关冗余备份,并实现底层PC的负载分担。但是,考虑到当主设备挂掉之后再次上线,可能该设备运行了BGP协议,为了给BGP协议运行和路由传递流出时间,因此VRRP使能抢占功能,但是抢占延时配置为30s。

    二、实验配置

    接下来,让我们看一下VRRP的相关配置命令

    (一)接口VRRP配置

    以路由器R1为例,在路由器接口G0/0/1上配置命令如下:

    interface GigabitEthernet0/0/1
     ip address 192.168.100.1 255.255.255.0 
     vrrp vrid 1 virtual-ip 192.168.100.254
     vrrp vrid 1 priority 101
     vrrp vrid 1 preempt-mode timer delay 60
     vrrp vrid 1 track interface GigabitEthernet0/0/0
     vrrp vrid 2 virtual-ip 192.168.100.253
    

    在上述配置命令中,vrid后面紧跟着的数字就是VRID号码,virtual IP表示虚拟的VRRP IP地址,priority后面的数字表示优先级(在华为设备中,VRRP优先级默认为100,且优先级越高越优先,优先级相同时接口IP地址越大越优先)。preempt-mode timer delay后面跟的数字表示抢占时延,单位为秒。在这种配置下,为了实现底层的负载分担,配置了两个VRID,这两个VRID可以分别作为底层设备的网关。

    (二)底层PC配置

    底层PC配置如下所示:
    在这里插入图片描述
    在这里插入图片描述
    整个网络拓扑运行OSPF协议实现路由互通,ospf配置及接口IP地址配置略。

    三、实现效果

    在配置完成后,实验效果查验如下:

    (一)查看VRRP的主备情况

    在这里插入图片描述

    (二)查看VRRP的负载分担情况

    在PC1上:
    在这里插入图片描述

    在PC2上:
    在这里插入图片描述

    四、路由器代码附录

    在这里,只粘贴和本实验相关的代码:
    R1:

    interface GigabitEthernet0/0/0
     ip address 155.1.12.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.100.1 255.255.255.0 
     vrrp vrid 1 virtual-ip 192.168.100.254
     vrrp vrid 1 priority 101
     vrrp vrid 1 preempt-mode timer delay 200
     vrrp vrid 1 track interface GigabitEthernet0/0/0
     vrrp vrid 2 virtual-ip 192.168.100.253
    #
    ospf 1 
     area 0.0.0.0 
      network 155.1.12.0 0.0.0.255 
      network 192.168.100.0 0.0.0.255 
    

    R2:

    #
    interface GigabitEthernet0/0/0
     ip address 155.1.23.3 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.100.2 255.255.255.0 
     vrrp vrid 1 virtual-ip 192.168.100.254
     vrrp vrid 2 virtual-ip 192.168.100.253
     vrrp vrid 2 priority 101
     vrrp vrid 2 track interface GigabitEthernet0/0/0
    #
    ospf 1 
     area 0.0.0.0 
      network 155.1.23.0 0.0.0.255 
      network 192.168.100.0 0.0.0.255 
    #
    

    原创不易,转载请说明出处:https://blog.csdn.net/weixin_40228200/article/details/118685388

    展开全文
  • 楼层1和楼层2分别通过两条线路做冗余接入交换机(本示例只考虑vrrp,暂不考虑其他方面)。当其中一段链路故障时,能通过另外一条链路传输。 配置信息: <lsw9>dis cu # sysname lsw9 # vlan ...

    示例图:

    其实说白了就是做线路冗余,达到热备切换。

    组网需求:

    楼层1和楼层2分别通过两条线路做冗余接入交换机(本示例只考虑vrrp,暂不考虑其他方面)。当其中一段链路故障时,能通过另外一条链路传输。

    配置信息:

    <lsw9>dis cu
    
    #
    
    sysname lsw9
    
    #
    
    vlan batch 10 20
    
    #
    
    stp mode stp
    
    #
    
    interface Ethernet0/0/2
    
     port link-type access
    
     port default vlan 10
    
    #
    
    interface Ethernet0/0/3
    
     port link-type access
    
     port default vlan 20
    
    #
    
    interface GigabitEthernet0/0/1
    
     port link-type trunk
    
     port trunk allow-pass vlan 10 20
    
    #
    
    interface GigabitEthernet0/0/2
    
     port link-type trunk
    
     port trunk allow-pass vlan 10 20
    
     stp instance 0 cost 200000000
    
    #
    
    return
    
    <lsw9>

    --------------------------

    <lsw11>dis cu
    
    #
    
    sysname lsw11
    
    #
    
    vlan batch 30
    
    #
    
    stp mode stp
    
    #
    
    interface Ethernet0/0/2
    
     port link-type access
    
     port default vlan 30
    
    #
    
    interface Ethernet0/0/3
    
     port link-type access
    
     port default vlan 30
    
    #
    
    interface GigabitEthernet0/0/1
    
     port link-type trunk
    
     port trunk allow-pass vlan 30
    
     stp instance 0 cost 200000000
    
    #
    
    interface GigabitEthernet0/0/2
    
     port link-type trunk
    
     port trunk allow-pass vlan 30
    
    #
    
    return
    
    <lsw11>

    -------------------------

    <lsw7>dis cu
    
    #
    
    sysname lsw7
    
    #
    
    vlan batch 10 20 30 100
    
    #
    
    stp mode stp
    
    #
    
    interface Vlanif1
    
    #
    
    interface Vlanif10
    
     description to 1 L
    
     ip address 10.155.10.254 255.255.255.0
    
     vrrp vrid 1 virtual-ip 10.155.10.252
    
     vrrp vrid 1 priority 120
    
     vrrp vrid 1 preempt-mode timer delay 20
    
    #
    
    interface Vlanif20
    
     ip address 10.155.20.254 255.255.255.0
    
     vrrp vrid 1 virtual-ip 10.155.20.252
    
     vrrp vrid 1 priority 120
    
     vrrp vrid 1 preempt-mode timer delay 20
    
    #
    
    interface Vlanif30
    
     description to 5 L
    
     ip address 10.156.40.254 255.255.255.0
    
     ip address 10.156.30.254 255.255.255.0 sub
    
     vrrp vrid 1 virtual-ip 10.156.30.252
    
     vrrp vrid 2 virtual-ip 10.156.40.252
    
     vrrp vrid 2 priority 120
    
     vrrp vrid 2 preempt-mode timer delay 20
    
    #
    
    interface Vlanif100
    
     ip address 10.10.10.1 255.255.255.0
    
    #
    
    interface MEth0/0/1
    
    #
    
    interface GigabitEthernet0/0/1
    
     port link-type access
    
     port default vlan 100
    
    #
    
    interface GigabitEthernet0/0/11
    
     port link-type trunk
    
     port trunk pvid vlan 100
    
     port trunk allow-pass vlan 2 to 4094
    
    #
    
    interface GigabitEthernet0/0/21
    
     port link-type trunk
    
     port trunk allow-pass vlan 30
    
    #
    
    ospf 1
    
     area 0.0.0.0
    
      network 10.10.10.0 0.0.0.255
    
      network 10.155.0.0 0.0.255.255
    
      network 10.156.0.0 0.0.255.255
    
    #
    
    return

    --------------------------------------

    <lsw8>dis cu
    
    #
    
    sysname lsw8
    
    #
    
    vlan batch 10 20 30 200
    
    #
    
    stp mode stp
    
    #
    
    interface Vlanif1
    
    #
    
    interface Vlanif10
    
     description to 1 L
    
     ip address 10.155.10.253 255.255.255.0
    
     vrrp vrid 1 virtual-ip 10.155.10.252
    
    #
    
    interface Vlanif20
    
     description to 1 L
    
     ip address 10.155.20.253 255.255.255.0
    
     vrrp vrid 1 virtual-ip 10.155.20.252
    
    #
    
    interface Vlanif30
    
     description to 5 L
    
     ip address 10.156.30.253 255.255.255.0
    
     ip address 10.156.40.253 255.255.255.0 sub
    
     vrrp vrid 1 virtual-ip 10.156.30.252
    
     vrrp vrid 1 priority 120
    
     vrrp vrid 1 preempt-mode timer delay 20
    
     vrrp vrid 2 virtual-ip 10.156.40.252
    
    #
    
    interface Vlanif200
    
     ip address 10.10.20.1 255.255.255.0
    
    #
    
    interface MEth0/0/1
    
    #
    
    interface GigabitEthernet0/0/1
    
    #
    
    interface GigabitEthernet0/0/2
    
     port link-type trunk
    
     port trunk allow-pass vlan 10 20
    
    #
    
    interface GigabitEthernet0/0/12
    
     port hybrid pvid vlan 200
    
     port hybrid tagged vlan 1 to 4094
    
    #
    
    interface GigabitEthernet0/0/22
    
     port link-type trunk
    
     port trunk allow-pass vlan 30
    
    #
    
    ospf 1
    
     area 0.0.0.0
    
      network 10.155.0.0 0.0.255.255
    
      network 10.156.0.0 0.0.255.255
    
      network 10.10.20.0 0.0.0.255
    
    #
    
    return
    
    <lsw8>

    -----------------

    <R4>dis cu
    
    #
    
    sysname R4
    
    #
    
    stp instance 0 root primary
    
    stp enable
    
    #
    
    interface GigabitEthernet0/0/1
    
     ip address 10.10.10.254 255.255.255.0
    
     stp enable
    
    #
    
    interface GigabitEthernet0/0/2
    
     ip address 10.10.20.254 255.255.255.0
    
     stp enable
    
    #
    
    interface GigabitEthernet0/0/3
    
     ip address 61.128.128.6 255.255.255.0
    
    #
    
    return
    
    <R4>

     

     

    参考:

    http://www.023wg.com/kkxpz/85.html(以上内容转自此篇文章) 

     

    转载于:https://www.cnblogs.com/EasonJim/p/9591094.html

    展开全文
  • 华为VRRP+MSTP配置实例

    2018-07-16 21:37:44
    配置MSTP+VRRP组合组网示例 配置MSTP+VRRP组合组网示例
  • 华为交换机MSTP+VRRP配置实例说明文档 拓扑图 IP地址规划表 设备名称 设备接口 对端设备 对端接口 VLAN VLAN /接口地址 备注 SW0 ...

    华为交换机MSTP+VRRP配置实例说明文档

    • 拓扑图

    • IP地址规划表

    设备名称

    设备接口

    对端设备

    对端接口

    VLAN

    VLAN /接口地址

    备注

    SW0

    GE0/0/23

    SW2

    GE0/0/23

    VLAN200

    10.0.1.1/24

     

    GE0/0/24

    SW1

    GE0/0/24

    VLAN100

    10.0.0.1/24

     

    SW1

    GE0/0/24

    SW0

    GE0/0/24

    VLAN100

    10.0.0.2/24

     

    GE0/0/11

    GE0/0/12

    SW1

    GE0/0/11

    GE0/0/12

    VLAN 10:192.168.0.253/24

    VLAN 20:192.168.1.253/24

    Vir - ip: 192.168.0.254/24

    Vir - ip: 192.168.1.254/24

    链路聚合

    Eth-trunk1

    GE0/0/13

    SW4

    Eth0/0/13

     

    GE0/0/1

    SW3

    GE0/0/1

     

    SW2

    GE0/0/23

    SW0

    GE0/0/23

    VLAN200

    10.0.1.2/24

     

    GE0/0/11

    GE0/0/12

    SW1

    GE0/0/11

    GE0/0/12

    VLAN 10:192.168.0.253/24

    VLAN 20:192.168.1.253/24

    Vir - ip: 192.168.0.254/24

    Vir - ip: 192.168.1.254/24

    链路聚合

    Eth-trunk1

    GE0/0/14

    SW3

    Eth0/0/14

     

    GE0/0/1

    SW4

    GE0/0/1

     

    SW3

    GE0/0/1

    SW1

    GE0/0/1

       

    Eth0/0/14

    SW3

    GE0/0/14

       

    Eth0/0/1

    CLENT1

    Eth0/0/1

       

    SW4

    GE0/0/1

    SW2

    GE0/0/1

       

    Eth0/0/13

    SW1

    GE0/0/13

       

    Eth0/0/1

    CLENT2

    Eth0/0/1

       

    CLENT1

    Eth0/0/1

    SW3

    Eth0/0/1

     

    192.168.0.1/24

     

    CLENT2

    Eth0/0/1

    SW4

    Eth0/0/1

     

    192.168.1.1/24

     
    • MSTP简介

    MSTP(多生成树协议)是在STP的基础上发展而来的,用于在局域网中消除数据链路层的物理环路,作为一种二层协议,MSTP通过选择性的阻塞网络中的冗余链路来消除二层环路,将环路网络结构修剪无环路的树型网络结构,从而防止在环路网络中不断增生和无限循环,避免设备由于重复接收相同报文造成报文处理能力的下降;同时,它还具备链路备份的能力。与STP相比,MSTP可以实现网络拓扑的快速收敛,也能使不同VLAN的流量沿各自的路径转发,从而为冗余链路提供了更好的负载分担机制。

    • VRRP简介

    VRRP用来为网关设备提供冗余备份。VRRP将可以承担网关功能的一组设备加入到备份组中,形成一台虚拟路由器,局域网内的主机将此虚拟路由器设置为缺省网关。VRRP根据优先级从备份组中选举一台网关设备作为Master,负责转发局域网内主机与外部通信的流量,其他网关设备作为Backup。当Master出现故障后,VRRP重新选举新的Master,保证流量转发不会中断。

     

     

    • 配置脚本说明

    [SW0]

    <Huawei>sys

    //进入特权模式

    [Huawei]sysname SW0

    //修改主机名

    [SW0]vlan batch 100 200

    //声明VLAN 100 200

    [SW0]interface Vlanif100

    //进入VLAN100的Svi接口模式

    [SW0-Vlanif100]ip address 10.0.0.1 255.255.255.0

    //配置VLAN100的Svi地址

    [SW0-Vlanif100]qu

    //退出Svi配置模式

    [SW0]interface Vlanif200

    //进入VLAN200的Svi接口模式

    [SW0-Vlanif200]ip address 10.0.1.1 255.255.255.0

    //配置VLAN100的Svi地址

    [SW0-Vlanif200]qu

    //退出VLAN200的接口配置模式

    [SW0]interface GigabitEthernet 0/0/23

    //进入到GE0/0/23的接口配置模式

    [SW0-GigabitEthernet 0/0/23]port link-type access

    //配置GE0/0/23的接口类型为access

    [SW0-GigabitEthernet 0/0/23]port default vlan 200

    //把GE0/0/23划分到VLAN200

    [SW0-GigabitEthernet 0/0/23]qu

    //退出GE0/0/23的接口模式

    [SW0]interface GigabitEthernet0/0/24

    //进入到GE0/0/24的接口配置模式

    [SW0-GigabitEthernet 0/0/24]port link-type access

    //配置GE0/0/24的接口类型为access

    [SW0-GigabitEthernet 0/0/24]port default vlan 100

    //把GE0/0/23划分到VLAN100

    [SW0-GigabitEthernet 0/0/23]qu

    //退出GE0/0/23的接口模式

    [SW0]rip 1

    //进入到RIP路由协议配置模式

    [SW0-rip-1]network 10.0.0.0

    //声明直连网段

    [SW0-rip-1]qu

    //退出RIP路由协议的配置模式

    [SW0]qu

    //退出特权模式

    <SW0>sa

    //保存配置

     

     

    [SW1]

    <Huawei>sys

    //进入特权模式

    [Huawei]sysname SW1

    //修改主机名

    [SW1]vlan batch 10 20 100

    //声明VLAN 10 20 100

    [SW1]interface Vlanif10

    //进入VLAN10的Svi接口模式

    [SW1-Vlanif10]ip address 192.168.0.253 255.255.255.0

    //配置VLAN10的Svi地址

    [SW1-Vlanif10]qu

    //退出Svi配置模式

    [SW1]interface Vlanif20

    //进入VLAN20的Svi接口模式

    [SW1-Vlanif20]ip address 192.168.1.253 255.255.255.0

    //配置VLAN20的Svi地址

    [SW1-Vlanif20]qu

    //退出Svi配置模式

    [SW1]interface Vlanif100

    //进入VLAN100的Svi接口模式

    [SW1-Vlanif100]ip address 10.0.0.2 255.255.255.0

    //配置VLAN100的Svi地址

    [SW1-Vlanif100]qu

    //退出Svi配置模式

    [SW1]interface Eth-Trunk1

    //进入到链路聚合配置模式

    [SW1-Eth-Trunk1]port link-type trunk

    //配置聚合链路的链路类型为trunk

    [SW1-Eth-Trunk1]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过链路

    [SW1-Eth-Trunk1]qu

    //退出链路聚合配置模式

    [SW1]interface GigabitEthernet0/0/1

    //进入到GE0/0/1的接口配置模式

    [SW1-GigabitEthernet 0/0/1]port link-type trunk

    //配置GE0/0/1的链路类型为trunk

    [SW1-GigabitEthernet 0/0/1]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过链路

    [SW1-GigabitEthernet 0/0/1]qu

    //退出GE0/0/1的接口配置模式

    [SW1]interface GigabitEthernet0/0/11

    //进入到GE0/0/11的接口配置模式

    [SW1-GigabitEthernet 0/0/11] eth-trunk 1

    //将GE0/0/11加入到聚合链路中

    [SW1-GigabitEthernet 0/0/11]qu

    //退出链路接口配置模式

    [SW1]interface GigabitEthernet0/0/12

    //进入到GE0/0/12的接口配置模式

    [SW1-GigabitEthernet 0/0/12]eth-trunk 1

    //将GE0/0/12加入到聚合链路中

    [SW1-GigabitEthernet 0/0/12]qu

    //退出GE0/0/12的接口配置模式

    [SW1]interface GigabitEthernet0/0/13

    //进入到GE0/0/13的接口配置模式

    [SW1-GigabitEthernet 0/0/13]port link-type trunk

    //配置GE0/0/13的链路类型为trunk

    [SW1-GigabitEthernet 0/0/13]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过链路

    [SW1-GigabitEthernet 0/0/13]qu

    //退出GE0/0/13的接口配置模式

    [SW1]interface GigabitEthernet0/0/24

    //进入到GE0/0/24的接口配置模式

    [SW1-GigabitEthernet 0/0/24]port link-type access

    //配置GE0/0/24的链路类型为access

    [SW1-GigabitEthernet 0/0/24]port default vlan 100

    //将GE0/0/24划分到VLAN100

    [SW1-GigabitEthernet 0/0/24]qu

    //退出GE0/0/24的接口配置模式

    【MSTP配置】

    [SW1]stp region-configuration

    //进入到stp配置模式

    [SW1-mst-region] region-name vrrp

    //配置MSTP名称

    [SW1-mst-region]instance 1 vlan 10

    //将VLAN10映射到实例1

    [SW1-mst-region]instance 2 vlan 20

    //将VLAN20映射到实例2

    [SW1-mst-region]active region-configuration

    //激活区域配置

    [SW1-mst-region]qu

    //退出MSTP配置模式

    [SW1]stp instance 1 root primary

    //设置实例1为主根

    [SW1]stp instance 2 root secondary

    //设置实例2为从根

    【VRRP配置】

    [SW1]interface Vlanif10

    //进入到VLAN10的Svi接口模式下

    [SW1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.0.254

    //声明虚拟备份组1并配置虚拟网关ip

    [SW1-Vlanif10]vrrp vrid 1 priority 120

    //配置虚拟备份组1的优先级为120

    [SW1-Vlanif10]qu

    //退出Svi接口配置模式

    [SW1]interface Vlanif20

    //进入到VLAN20的Svi接口模式下

    [SW1-Vlanif20]vrrp vrid 2 virtual-ip 192.168.1.254

    //声明虚拟备份组2并配置虚拟网关ip

    [SW1-Vlanif20]qu

    //退出Svi接口配置模式

     

    [SW1]rip 1

    //进入到RIP路由协议配置模式

    [SW1-rip-1]network 10.0.0.0

    //声明直连网段

    [SW1-rip-1]network 192.168.0.0

    //声明直连网段

    [SW1-rip-1]network 192.168.1.0

    //声明直连网段

    [SW1-rip-1]qu

    //退出RIP路由协议的配置模式

    [SW1]qu

    //退出特权模式

    <SW1>sa

    //保存配置

     

    [SW2]

    <Huawei>sys

    //进入特权模式

    [Huawei]sysname SW2

    //修改主机名

    [SW2]vlan batch 10 20 200

    //声明VLAN 10 20 200

    [SW2]interface Vlanif10

    //进入VLAN10的Svi接口模式

    [SW2-Vlanif10]ip address 192.168.0.253 255.255.255.0

    //配置VLAN10的Svi地址

    [SW2-Vlanif20]qu

    //退出Svi配置模式

    [SW2]interface Vlanif20

    //进入VLAN20的Svi接口模式

    [SW2-Vlanif20]ip address 192.168.1.253 255.255.255.0

    //配置VLAN20的Svi地址

    [SW2-Vlanif20]qu

    //退出Svi配置模式

    [SW2]interface Vlanif200

    //进入VLAN200的Svi接口模式

    [SW2-Vlanif200]ip address 10.0.1.2 255.255.255.0

    //配置VLAN200的Svi地址

    [SW2-Vlanif200]qu

    //退出Svi配置模式

    [SW2]interface Eth-Trunk1

    //进入到链路聚合配置模式

    [SW2-Eth-Trunk1]port link-type trunk

    //配置聚合链路的链路类型为trunk

    [SW2-Eth-Trunk1]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过链路

    [SW2-Eth-Trunk1]qu

    //退出链路聚合配置模式

    [SW2]interface GigabitEthernet0/0/1

    //进入到GE0/0/1的接口配置模式

    [SW2-GigabitEthernet 0/0/1]port link-type trunk

    //配置GE0/0/1的链路类型为trunk

    [SW2-GigabitEthernet 0/0/1]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过链路

    [SW2-GigabitEthernet 0/0/1]qu

    //退出GE0/0/1的接口配置模式

    [SW2]interface GigabitEthernet0/0/11

    //进入到GE0/0/11的接口配置模式

    [SW2-GigabitEthernet 0/0/11] eth-trunk 1

    //将GE0/0/11加入到聚合链路中

    [SW1-GigabitEthernet 0/0/11]qu

    //退出链路接口配置模式

    [SW2]interface GigabitEthernet0/0/12

    //进入到GE0/0/12的接口配置模式

    [SW2-GigabitEthernet 0/0/12]eth-trunk 1

    //将GE0/0/12加入到聚合链路中

    [SW2-GigabitEthernet 0/0/12]qu

    //退出GE0/0/12的接口配置模式

    [SW2]interface GigabitEthernet0/0/14

    //进入到GE0/0/14的接口配置模式

    [SW2-GigabitEthernet 0/0/14]port link-type trunk

    //配置GE0/0/14的链路类型为trunk

    [SW2-GigabitEthernet 0/0/14]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过链路

    [SW2-GigabitEthernet 0/0/14]qu

    //退出GE0/0/14的接口配置模式

    [SW2]interface GigabitEthernet0/0/23

    //进入到GE0/0/23的接口配置模式

    [SW2-GigabitEthernet 0/0/23]port link-type access

    //配置GE0/0/23的链路类型为access

    [SW2-GigabitEthernet 0/0/23]port default vlan 200

    //将GE0/0/23划分到VLAN200

    [SW2-GigabitEthernet 0/0/23]qu

    //退出GE0/0/23的接口配置模式

    【MSTP配置】

    [SW2]stp region-configuration

    //进入到stp配置模式

    [SW2-mst-region] region-name vrrp

    //配置MSTP名称

    [SW2-mst-region]instance 1 vlan 10

    //将VLAN10映射到实例1

    [SW2-mst-region]instance 2 vlan 20

    //将VLAN20映射到实例2

    [SW2-mst-region]active region-configuration

    //激活区域配置

    [SW2-mst-region]qu

    //退出MSTP配置模式

    [SW2]stp instance 1 root secondary

    //设置实例1为从根

    [SW2]stp instance 2 root primary

    //设置实例2为主根

    【VRRP配置】

    [SW2]interface Vlanif10

    //进入到VLAN10的Svi接口模式下

    [SW2-Vlanif10]vrrp vrid 1 virtual-ip 192.168.0.254

    //声明虚拟备份组1并配置虚拟网关ip

    [SW2-Vlanif10]qu

    //退出Svi接口配置模式

    [SW2]interface Vlanif20

    //进入到VLAN20的Svi接口模式下

    [SW2-Vlanif20]vrrp vrid 2 virtual-ip 192.168.1.254

    //声明虚拟备份组2并配置虚拟网关ip

    [SW2-Vlanif20]vrrp vrid 2 priority 120

    //配置虚拟备份组2的优先级为120

    [SW2-Vlanif20]qu

    //退出Svi接口配置模式

    [SW2]rip 1

    //进入到RIP路由协议配置模式

    [SW2-rip-1]network 10.0.0.0

    //声明直连网段

    [SW2-rip-1]network 192.168.1.0

    //声明直连网段

    [SW2-rip-1]network 192.168.0.0

    //声明直连网段

    [SW2-rip-1]qu

    //退出RIP路由协议的配置模式

    [SW2]qu

    //退出特权模式

    <SW2>sa

    //保存配置

     

     

    [SW3]

     

    <Huawei>sys

    //进入特权模式

    [Huawei]sysname SW3

    //修改主机名

    [SW3]vlan batch 10 20

    //声明VLAN 10 20

    [SW3]interface Ethernet0/0/1

    //进入到Eth0/0/1的接口模式

    [SW3-Ethernet0/0/1]port link-type access

    //配置Eth0/0/1的链路类型为access

    [SW3-Ethernet0/0/1]port default vlan 10

    //将Eth0/0/1划分到VLAN10

    [SW3-Ethernet0/0/1]qu

    //退出Eth0/0/1接口模式

    [SW3]interface Ethernet0/0/14

    //进入到Eth0/0/14的接口模式

    [SW3-Ethernet0/0/14]port link-type trunk

    //将Eth0/0/14的链路类型配置为trunk

    [SW3-Ethernet0/0/14]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过

    [SW3-Ethernet0/0/14]qu

    //退出Eth0/0/14的接口模式

    [SW3]iinterface GigabitEthernet0/0/1

    //进入到GE0/0/1的接口配置模式

    [SW3-GigabitEthernet 0/0/1]port link-type trunk

    //配置GE0/0/1的接口模式为trunk

    [SW3-GigabitEthernet 0/0/1]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过

    [SW3-GigabitEthernet 0/0/1]qu

    //退出GE0/0/1的接口配置模式

    【MSTP】

    [SW3]stp region-configuration

    //进入到STP配置模式

    [SW3]stp region-configuration

    //进入到stp配置模式

    [SW3-mst-region] region-name vrrp

    //配置MSTP名称

    [SW3-mst-region]instance 1 vlan 10

    //将VLAN10映射到实例1

    [SW3-mst-region]instance 2 vlan 20

    //将VLAN20映射到实例2

    [SW3-mst-region]active region-configuration

    //激活区域配置

    [SW3-mst-region]qu

    //退出MSTP配置模式

    [SW3]qu

    //退出特权模式

    <SW3>sa

    //保存配置

     

    [SW4]

     

    <Huawei>sys

    //进入特权模式

    [Huawei]sysname SW4

    //修改主机名

    [SW4]vlan batch 10 20

    //声明VLAN 10 20

    [SW4]interface Ethernet0/0/1

    //进入到Eth0/0/1的接口模式

    [SW4-Ethernet0/0/1]port link-type access

    //配置Eth0/0/1的链路类型为access

    [SW4-Ethernet0/0/1]port default vlan 10

    //将Eth0/0/1划分到VLAN10

    [SW4-Ethernet0/0/1]qu

    //退出Eth0/0/1接口模式

    [SW4]interface Ethernet0/0/13

    //进入到Eth0/0/13的接口模式

    [SW4-Ethernet0/0/13]port link-type trunk

    //将Eth0/0/13的链路类型配置为trunk

    [SW4-Ethernet0/0/13]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过

    [SW4-Ethernet0/0/13]qu

    //退出Eth0/0/13的接口模式

    [SW4]iinterface GigabitEthernet0/0/1

    //进入到GE0/0/1的接口配置模式

    [SW4-GigabitEthernet 0/0/1]port link-type trunk

    //配置GE0/0/1的接口模式为trunk

    [SW4-GigabitEthernet 0/0/1]port trunk allow-pass vlan 2 to 4094

    //允许所有VLAN通过

    [SW4-GigabitEthernet 0/0/1]qu

    //退出GE0/0/1的接口配置模式

    【MSTP】

    [SW4]stp region-configuration

    //进入到STP配置模式

    [SW4]stp region-configuration

    //进入到stp配置模式

    [SW4-mst-region] region-name vrrp

    //配置MSTP名称

    [SW4-mst-region]instance 1 vlan 10

    //将VLAN10映射到实例1

    [SW4-mst-region]instance 2 vlan 20

    //将VLAN20映射到实例2

    [SW4-mst-region]active region-configuration

    //激活区域配置

    [SW4-mst-region]qu

    //退出MSTP配置模式

    [SW4]qu

    //退出特权模式

    <SW4>sa

    //保存配置

     

    • 总结

    MSTP+VRRP配置步骤

        1、配置交换机路由器的基本配置,例如接口信息、主机名等

        2、配置交换机互连链路为trunk

        3、配置主VRRP ID、虚拟IP、优先级,然后设置备VRRP的虚拟IP、优先级(此处的优先级一定要比主设备的低)

        4、配置MSTP,进入MSTP配置接口、配置name、实例映射、激活,退出后设置主备

        5、配置完成

    转载于:https://www.cnblogs.com/zlshare/p/6564053.html

    展开全文
  • 华为VRRP+VLAN+DHCP配置实例

    千次阅读 2020-07-07 17:14:28
    VRRP配置实例配置命令检测 什么是VRRP? VRRP全称为(Virtual Router Redundancy Protocol),即虚拟路由冗余协议,简单来说就是用于解决静态网关单点故障的问题。可以把多台网关设备合并为一台。使其中一台网关设备...

    什么是VRRP?

    VRRP全称为(Virtual Router Redundancy Protocol),即虚拟路由冗余协议,简单来说就是用于解决静态网关单点故障的问题。可以把多台网关设备合并为一台。使其中一台网关设备down掉后,可以保证不会出现断网现象。

    VRRP配置实例

    拓扑结构图:
    在这里插入图片描述
    配置需求:
    AR1为边界路由器
    采用OSPF动态路由协议互联网段
    SW1与SW2做VRRP虚拟网关
    创建VLAN 10 VLAN20分割内网
    VLAN10 IP:192.168.1.0 /24
    VLAN20 IP: 192.168.2.0/24
    虚拟网关:192.168.1.254/192.168.2.254
    创建DHCP服务器网关指向虚拟网关
    作用:
    当SW1的下联接口down掉时,sw2可立马响应做为新网关,使内网网络不中断

    配置命令

    AR1:
    interface GigabitEthernet0/0/0 #配置接口地址
    ip address 11.0.0.1 255.255.255.0

    interface GigabitEthernet0/0/1 #配置接口地址
    ip address 12.0.0.1 255.255.255.0

    interface LoopBack0 #配置环回口地址
    ip address 1.1.1.1 255.255.255.255

    ospf 100 router-id 1.1.1.1 #设置ospf进程号为100,ID为1.1.1.1
    area 0.0.0.0 #设置为area0
    network 1.1.1.1 0.0.0.0 #宣告环回口
    network 11.0.0.1 0.0.0.0 #宣告接口地址
    network 12.0.0.1 0.0.0.0 #宣告接口地址
    SW1:
    sysname SW1 #设置此交换机名称为SW1

    vlan batch 10 20 30 #创建VLAN 10 20 30

    dhcp enable #启用DHCP功能

    ip pool dhcp2 #创建DHCP地址池,名字为dhcp2
    gateway-list 192.168.2.254
    network 192.168.2.0 mask 255.255.255.0
    excluded-ip-address 192.168.2.250 192.168.2.253
    dns-list 114.114.114.114 8.8.8.8

    ip pool dncp1 #创建DHCP地址池,名字为dhcp1
    gateway-list 192.168.1.254
    network 192.168.1.0 mask 255.255.255.0
    excluded-ip-address 192.168.1.250 192.168.1.253
    dns-list 114.114.114.114 8.8.8.8

    interface Vlanif10 #进入vlan10接口
    ip address 192.168.1.1 255.255.255.0 #配置vlan10 ip
    vrrp vrid 1 virtual-ip 192.168.1.254 #启用vrrp设置为组1,虚拟IP为192.168.1.254
    vrrp vrid 1 priority 150 #修改此路由vrrp组1的优先级
    dhcp select global #接口全局启用DHCP

    interface Vlanif20
    ip address 192.168.2.2 255.255.255.0
    vrrp vrid 2 virtual-ip 192.168.2.254
    dhcp select global

    interface Vlanif30
    ip address 11.0.0.2 255.255.255.0

    interface GigabitEthernet0/0/23 #进入接口
    port link-type trunk #接口模式改为trunk
    port trunk allow-pass vlan 2 to 4094 #允许所有vlan通过

    interface GigabitEthernet0/0/24
    port link-type access #接口模式改为access
    port default vlan 30 #接口绑定vlan 30

    ospf 100 router-id 2.2.2.2
    area 0.0.0.0
    network 11.0.0.2 0.0.0.0
    network 192.168.1.0 0.0.0.255
    network 192.168.2.0 0.0.0.255
    SW2:
    sysname SW2

    vlan batch 10 20 40

    dhcp enable

    ip pool dhcp1
    gateway-list 192.168.1.254
    network 192.168.1.0 mask 255.255.255.0
    excluded-ip-address 192.168.1.250 192.168.1.253
    dns-list 114.114.114.114 8.8.8.8

    ip pool dhcp2
    gateway-list 192.168.2.254
    network 192.168.2.0 mask 255.255.255.0
    excluded-ip-address 192.168.2.250 192.168.2.253
    dns-list 114.114.114.114 8.8.8.8

    interface Vlanif10
    ip address 192.168.1.2 255.255.255.0
    vrrp vrid 1 virtual-ip 192.168.1.254
    dhcp select global

    interface Vlanif20
    ip address 192.168.2.1 255.255.255.0
    vrrp vrid 2 virtual-ip 192.168.2.254
    dhcp select global

    interface Vlanif40
    ip address 12.0.0.2 255.255.255.0

    interface GigabitEthernet0/0/23
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094

    interface GigabitEthernet0/0/24
    port link-type access
    port default vlan 40

    ospf 100 router-id 3.3.3.3
    area 0.0.0.0
    network 12.0.0.2 0.0.0.0
    network 192.168.1.0 0.0.0.255
    network 192.168.2.0 0.0.0.255
    SW3:
    sysname SW3

    vlan batch 10 20

    interface Ethernet0/0/1
    port link-type access
    port default vlan 10

    interface Ethernet0/0/2
    port link-type access
    port default vlan 20

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094

    interface GigabitEthernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094

    检测

    使用displady vrrp brief 可查看vrrp的状态
    在这里插入图片描述
    使用displady vrrp 可查看vrrp详细信息
    在这里插入图片描述

    展开全文
  • 组网需求:楼层1和楼层2分别通过两条线路做冗余接入交换机(本示例只考虑vrrp,暂不考虑其他方面)。当其中一段链路故障时,能通过另外一条链路传输。配置信息:dis cu#sysname lsw9#vlan batch 10 20#stp mode stp#...
  • 华为VRRP配置详解

    千次阅读 2018-02-09 14:19:16
    2.路由器端口配置ip,如拓扑图所示,配置如下R1配置:[R1]interface g0/0/0[R1-GigabitEthernet0/0/0]ip address 192.168.1.254 24[R1]interface g0/0/1[R1-GigabitEthernet0/0/1]ip address 192.168.13.1 24 R2配置...
  • 首先用思科的HSRP热备份路由协议配置。 首先在为这个拓扑配置命令前先分析一下这个拓扑图,了解它的实验目的及要求与想要达成的效果。 然后在看需要为这拓扑配置的命令。 分析拓扑图:(不论配置什么协议实现...
  • 虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议,1998年已推出正式的RFC2338协议标准。VRRP广泛应用在边缘网络中,它的设计...
  • 华为VRRP配置

    万次阅读 2018-02-03 19:26:33
    #S1 system-view [Huawei]vlan 10 [Huawei-vlan10]q [Huawei]int Vlanif 10 [Huawei-Vlanif10]ip add 192.168.0.252 255.255.255.0 [Huawei-Vlanif10]vrrp vrid 1 virtual-ip 192.168.0.254 [Huawei-Vlanif1
  • 虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议,1998年已推出正式的RFC2338协议标准。VRRP广泛应用在边缘网络中,它的设计...
  • VRRP详解、VRRP配置实例 关于IPv6: 相关链接如下:IPv6报文格式讲解及其科学性探究、IPv6地址简介、IPv6各地址计算方式汇总、IPv6地址解析详解、IPv6 SLAAC原理详解及配置。 一、IPv6下VRRP与IPv4下VRRP的异同
  • VRRP+MSTP 实验拓扑 一、VLAN配置 SW3配置 sy sw3 un in en vlan batch 10 20 30 40 interface g0/0/2 port link-type access port default vlan 10 q interface g0/0/3 port link-type access port default...
  • 华为ensp配置vrrp

    万次阅读 多人点赞 2019-09-22 16:51:07
    虚拟路由冗余协议VRRP通过几台路由器设备组成一台虚拟的路由设备,将虚拟路由...在R1和R2配置VRRP备份组,对外宣称为一台虚拟路由器,实现链路冗余备份 基本配置 R1,R2,R3配置ospf互联 [Huawei]sys [Huawei]sysname...
  • 华为----vrrp配置

    万次阅读 多人点赞 2018-08-08 19:45:36
    华为--vrrp配置     1.规划网段 如上图所示: 2.在各交换机上完成基本配置,使得各网段能够互通 sw3配置: sys vlan 10 vlan 20 quit int g0/0/3 port link-type access port default vlan 10 quit...
  • 博文目录: 一、双机热备是什么? 二、什么是VRRP? 三、VRRP的两种角色 四、VRRP的三个状态机 五、VRRP选举Master路由器和Backup路由器的流程 六、通过VGMP实现VRRP备份组的统一管理 七、双机热备的配置 ...华为...
  • 华为VRRP和NQA联动

    千次阅读 2019-09-21 15:24:09
    拓扑图 -------------------------------------------------------------------------------...ISP1、ISP2、NET配置OSPF进行模拟 [NET]int GigabitEthernet 0/0/0 [NET-GigabitEthernet0/0/0]ip add 100.1....
  • 1、根据图示,在R1、R2的E1端口配置VRRP,VRID为111,E0端口配置VRRP,VRID为222. 2、在R1的E1端口配置VRRP优先级为250,E0端口配置VRRP优先级为50. 3、从PC1上PINGPC3,查看流量的走向(PC1-R1-PC3-R2-PC1)。 4、在...
  • 华为路由器配置VRRP(实操可跟做)

    千次阅读 2019-09-04 07:36:37
    原理性的东西我就不啰嗦了,关于华为防火墙VRRP双机热备的原理及配置大家可以参看博文华为防火墙VRRP双机热备的原理及实例配置 此博文主要是一个模拟环境,在路由器上配置VRRP,模拟主路由器故障网络走备份路由器...
  • 华为路由器配置VRRP

    2020-10-23 13:21:46
    配置: R1: 配置直连 [R1]interface GigabitEthernet 0/0/1 [R1-GigabitEthernet0/0/1]ip address 192.168.1.1 24 [R1-GigabitEthernet0/0/1]quit [R1]int GigabitEthernet 0/0/0 [R1-GigabitEthernet0/0/0]ip ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 483
精华内容 193
关键字:

华为vrrp配置实例