精华内容
下载资源
问答
  • 交换机端口安全违背的几种方式
    2022-04-13 10:03:19

    switchport port-security violation 功能:当超过设定 MAC 地址数量的最大值,或访问该端口的设备 MAC 地址不是这个 MAC 地址表中该端口的 MAC 地址,或同一个 VLAN 中一个 MAC 地址被配置在几个端口上时, 就会引发违反 MAC 地址安全。

    protect :安全违背保护模式,当该端口违反了mac地址安全,则不学习新的mac,并丢弃数据,不发送警告。

    recovery :恢复违背模式,触发端口违背动作后,恢复mac学习功能。

    restrict:安全违背限制模式,触发违背动作后,不关闭端口,不学习新的mac,丢弃数据包,发送snmp trap,同时在syslog日志中记录。

    shutdown :安全违背关闭模式,是安全违背的缺省模式,在这种情况下,端口被立即关闭,发送SNMP trap, 同时在syslog 日志中记录。

    更多相关内容
  • 交换机端口安全配置

    2013-01-03 23:57:12
    交换机端口安全配置  最常用的对端口安全的理解就是可根据MAC地址来做对网络流量的控制和管理,比如MAC地址与具体的端口绑定,限制具体端口通过的MAC地址的数量,或者在具体的端口不允许某些MAC地址的帧流量通过...
  • 交换机端口安全

    2018-04-19 11:01:32
    交换机端口安全描述,交换机的端口的安全设置交换机端口安全实训操作
  • 某单位中有一台Cisco3550交换机,出于网络安全的考虑,对某些端口安全性要求较高,即只能接入指定的主机,比如设置一间办公室只有某台笔记本电脑可以接入网络,当他带着笔记本出去后,即使空出了网络接口,其它的...
  • 今天我们来介绍一下交换机端口安全的配置内容,主要防止公司内部的网络攻击和破坏行为,详细的教程,请看下文介绍,需要的朋友可以参考下
  • ensp-配置交换机端口安全

    千次阅读 2021-05-06 15:21:16
    拓扑图如下: 1,配置主机IP 2,配置交换机端口安全 3,用PC1去pingPC2和PC3 4,交换pc1机与pc2机的直通线 4,在pc1机上ping pc2机与pc3机发现交换机原E0/0/2端口关闭(PC2无法接入交换机)

    拓扑图如下:
    在这里插入图片描述
    1,配置主机IP
    2,配置交换机端口安全
    在这里插入图片描述
    3,用PC1去pingPC2和PC3
    在这里插入图片描述

    4,交换pc1机与pc2机的直通线
    在这里插入图片描述

    展开全文
  • 下面我们就通过一个实例,先来探讨一下对于交换机端口配置和接入安全性保障的实战演练!  场景:某单位中有一台CISCO3550交换机,出于网络安全的考虑,对某些端口的安全性要求较高,即只能接入指定的主机,比如...
  • 配置交换机端口安全实验

    千次阅读 2020-05-21 17:22:44
    交换机端口安全主要有两种类项:一是限制交换机端口的最大连接数,二是针对交换机端口进行MAC地址、IP地址的绑定。 限制交换机端口的最大连接数可以控制交换机端口下连的主机数,并防止用户进行恶意的ARP欺骗。 ...

    实验名称
    交换机的端口安全配置

    实验目的
    掌握交换机的端口安全功能,控制用户的安全接入

    实验拓扑
    在这里插入图片描述
    实验原理

    • 交换机端口安全功能,是指针对交换机的端口进行安全属性的配置,从而控制用户的安全接入。交换机端口安全主要有两种类项:一是限制交换机端口的最大连接数,二是针对交换机端口进行MAC地址、IP地址的绑定。
    • 限制交换机端口的最大连接数可以控制交换机端口下连的主机数,并防止用户进行恶意的ARP欺骗。
    • 交换机端口的地址绑定,可以针对IP地址、MAC地址、IP+MAC进行灵活的绑定。可
      以实现对用户进行严格的控制。保证用户的安全接入和防止常见的内网的网络攻击。如ARP欺骗、IP、MAC地址欺骗,IP地址攻击等。
    • 配置了交换机的端口安全功能后,当实际应用超出配置的要求,将产生一个安全违例,产生安全违例的处理方式有3种:
      • protect 当安全地址个数满后,安全端口将丢弃未知名地址(不是该端口的安全
        地址中的任何一个)的包。
      • restrict 当违例产生时,将发送一个Trap通知。
      • shutdown 当违例产生时,将关闭端口并发送一个Trap通知。
      • 当端口因为违例而被关闭后,在全局配置模式下使用命令errdisable recovery来
        将接口从错误状态中恢复过来

    实验步骤

    首先给三台PC机配上IP地址和掩码
    这里用192.168.0.0/24的网段

    二层交换机Switch0

    Switch(config)#int f0/1
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport port-security       //开启端口安全,默认是关闭的
    Switch(config-if)#switchport port-security maximum 1      //指定最大连接数为 1,默认 128
    Switch(config-if)#switchport port-security violation shutdown       //指定违例后端口关闭
    

    实验验证
    PC2 ping PC0或PC1的的其中一台是可以 ping 通的,若PC2 ping 过PC0之后再 ping PC1就会发现集线器连接交换机的端口已经down掉了
    或者集线器下任意一台PC机 ping 向交换机之后,另一台PC机再 ping 交换机也是会down掉。如图所示
    在这里插入图片描述
    连接交换机的端口down掉之后PC0和PC1是可以互相 ping 通的,但是两台都不能ping向交换机

    注意事项
    违例后有三种选项,第一种 restrict 为丢包,不转发该数据包、第二种 protect 为丢包,并返回信息告知、第三种 shutdown 为关闭该端口,可在全局模式下使用 errdisable recovery 命令将其恢复为 UP 状态(模拟器恢复不了)

    展开全文
  • 思科模拟器 --- 交换机端口安全配置

    万次阅读 多人点赞 2019-11-15 09:34:21
    学习目标:掌握交换机端口安全功能,控制用户的安全接入 1.实验环境:对公司网络严格控制,防止公司用户的IP地址冲突和公司内部的网络攻击和破坏行为,为每一个员工分配固定的IP地址,某公司员工分配的IP地址为:...

    学习目标:掌握交换机的端口安全功能,控制用户的安全接入

    1.实验环境:对公司网络严格控制,防止公司用户的IP地址冲突和公司内部的网络攻击和破坏行为,为每一个员工分配固定的IP地址,某公司员工分配的IP地址为:192.168.2.2/24,主机的MAC地址是:0060.5C5B.3152,该主机连接在 1台 S2960 上 。

    2.实验目的:针对交换机的所有端口,配置最大连接数为 1,针对 PC 0 主机的接口进行 MAC 地址绑定。

    3.实验设备:Switch-2960 1台、PC 1台、直通线

    4.配置 PC 0 的IP地址

    PC 0的IP地址:192.168.2.2

    MAC地址:255.255.255.0

    5.在 PC 0上打开CMD 命令提示符窗口,执行 ipconfig /all 命令 查看 PC 0 的IP和MAC地址

    6.配置交换机 Switch 0

    Switch>en

    Switch#conf t

    Switch(config)#int f0/1           进入 f0/1 端口

    Switch(config-if)#switchport mode access      配置交换机 f0/1 端口模式为 access

    Switch(config-if)#switchport port-security        开启交换机的端口安全功能

    Switch(config-if)#switchport port-security maximum 1       配置端口的最大连接数为 1

    Switch(config-if)#switchport port-security violation shutdown     配置安全违规的处理方式为 shutdown

    Switch(config-if)#end

    Switch#show port-security        查看交换机的端口安全配置     

    7.配置交换机端口的 MAC 地址绑定

    Switch(config)#int f0/1           进入 f0/1 端口

    Switch(config-if)#switchport port-security             开启交换机的端口安全功能

    Switch(config-if)#switchport port-security mac-address 0060.5C5B.3152      端口和 MAC地址的绑定

    Switch#show port-security address           查看地址安全绑定配置

     

    扩展实验:有感兴趣的小伙伴可以加大实验难度,针对三层交换机端口安全配置下面的实验:

             

    部分交换机配置仅供参考,以真实实验环境为主:(希望对您上面的实验有帮助 (*^▽^*))

    1.配置二层交换机

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#vlan 3

    Switch(config-vlan)#exit

    Switch(config)#int f0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 2

    Switch(config-if)#exit

    Switch(config)#int f0/3

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 3

    Switch(config-if)#exit

    Switch(config)#int f0/1

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan 2,3

    Switch(config-if)#exit

    2.配置三层交换机

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#vlan 3

    Switch(config-vlan)#exit

    Switch(config)#int f0/1

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan 2,3

    Switch(config-if)#exit

    Switch(config)#int vlan 2

    Switch(config-if)#ip add 192.168.10.2 255.255.255.0

    Switch(config-if)#exit

    Switch(config)#int vlan 3

    Switch(config-if)#ip add 192.168.20.2 255.255.255.0

    Switch(config-if)#exit

    Switch(config)#ip routing

    展开全文
  • 配置交换机端口安全

    千次阅读 2020-06-03 22:35:13
    [SW1-Ethernet0/0/1]port-security enable //开启端口安全 [SW1-Ethernet0/0/1]port-security mac-address sticky //将经过接口的MAC地址和接口动态关联起来 [SW1-Ethernet0/0/1]port-security max-mac-num 1 //设置
  • 我们会对pc0在交换机上进行mac地址绑定,pc1访问时则交换机断开端口 1.为pc机配置ip地址 pc0:192.168.1.1 pc1:192.168.1.2 pc2:192.168.1.3 2,交换机设置 enable 进入特权模式 configure terminal 进入...
  • 交换机工作原理及端口安全配置

    千次阅读 2019-12-10 21:21:19
    目录相关概念认识交换机工作原理交换机端口安全 相关概念认识 交换机是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。最常见的交换机是以太网交换机。交换机...
  • 4.4交换机端口安全.ppt

    2020-02-04 23:35:33
    4.4交换机端口安全 相关知识--- 端口安全概述 端口安全Port Security是一种对网络接入进行控制的安全机制是对已有的802.1X二层协议认证和MAC地址认证的扩充 1端口安全作用 防止非授权设备访问连接网络 控制接口合法...
  • 交换机端口安全

    千次阅读 2020-03-26 17:57:23
    端口安全(Port Security),从基本原理上讲,Port Security特性会通过MAC地址表记录连接到交换机端口的以太网MAC地址(即网卡号),并只允许某个MAC地址通过本端口通信。其他MAC地址发送的数据包通过此端口时,端口...
  • 思科交换机端口安全

    千次阅读 2017-11-16 20:20:00
    交换机端口安全1.本实验是将switch中的f0/1的端口做成安全端口,构建mac地址绑定,只让pc0能够进入这个单口,pc1不能进入2.在f0/1上进行配置,先进入端口 1>Switch(config)#int f0/1 Switch(config-if)#shut...
  • 前提: 在部署园区网的时候,对于...端口安全Port-Security特点 交换机大多工作在OSI模型的第二层,即数据链路层中,交换机根据数据包包头的源目MAC地址生成相应的MAC Adress表项,且通过这个表项进行定位物理端.
  • 1)要求控制交换机端口安全,禁止私接网络设备 2)PC1可以ping通Server1,PC2无法ping通Server1 1.2 方案 实验拓扑如图-1所示,搭建实验环境时首先确保PC1正常通信,再加入PC2。 图-1 1.3 步骤 实现此案例需要按照...
  • 交换机端口安全技术的配置 Cisco

    千次阅读 2020-03-18 20:19:37
    实验目的:掌握交换机端口安全功能,控制用户的安全接入 实验背景:公司网络采用个人固定IP上网方案,为了防止公司内部用户IP地址借用、冒用,私自接入交换机等违规行为,同时防止公同内部的网络攻击和破坏行为,...
  • 一、前言     同系列前几篇:         网络设备配置–1、配置交换机enable、console、telnet密码         网络...而我们可以通过配置交换机端口安全可以一定防范这些攻击,配置端口安全可以只
  • 5.2.2.7---配置交换机端口安全 - PKA

    千次阅读 2021-10-22 08:15:47
    2.(1)第 1 部分: 配置端口安全 a. 访问 S1 的命令行并在快速以太网端口 0/1 和 0/2 上启用端口安全。 interface range F0/1-2 b. 设置最大值,以便只有一台设备能够访问快速以太网端口 0/1 和 0/2。 switch port-...
  • 2、H3C交换机端口安全

    2019-09-18 05:25:07
    一、开启端口安全[switch] port-security enable 二、配置端口安全允许的最大安全MAC地址数[switch] interfaceinterface-typeinterface-number //进入端口[switch-interface] port-security max-mac-count count-...
  • 2016计算机网络技术实验实训教程:实验一交换机的端口安全配置计算机网络技术实验实训教程网络安全实验实验一 交换机的端口安全配置实验名称:交换机...交换机端口安全有限制交换机端口的最大连接数和端口的安全地址...
  • Cisco 交换机端口安全

    2018-11-01 19:50:20
    交换机 端口安全 问题的产生:大家都熟悉,交换机的基本工作原理,以及mac地址标的形成过程。当交换机收到数据帧之后,会根据数据帧的源mac地址和接收该数据帧的接口形成映射。同时,当交换机接收到数据帧之后,将...
  • 原标题:交换机端口安全的认识理解与特性,MAC绑定与限制等 大家好,今天我们来学习交流一下交换机端口安全的认识理解与特性,MAC绑定与限制等。通过本文实验,主要了解为以下几点1、理解交换机的 MAC 表;2、理解...
  • 华为交换机安全端口实验

    千次阅读 2020-12-13 13:42:48
    将设备端口学习到的MAC地址变为安全MAC地址(分为两类:安全动态MAC地址和Sticky安全地址,这两类地址是设备信任的地址),以阻止除了安全动态MAC和静态MAC之外的主机通过本接口和交换机通信。 安全MAC地址类型: 1....
  • 1:配置要求 使用静态路由和多层交换网络技术完成如下要求的网络配置,通过网络配置,使所有计算机都能连通,要求: 1、使两台核心交换机之间形成一根聚合了两条物理...3、在交换机S3和S4上启用交换机端口安全,交...
  • 在现今的企业网络中,信息安全的威胁从某种程度上讲,来自企业内部的安全威胁高于企业外部的安全威胁,比如:无控制行为的任意主机接入、移动存储...交换机端口安全属于数据链路层安全策略,也是多众企业网络接入...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 36,942
精华内容 14,776
热门标签
关键字:

交换机端口安全设置

友情链接: jiaowuguanli.rar