精华内容
下载资源
问答
  • 路由聚合
    千次阅读
    2021-09-23 20:32:50

    通过上节的学习,我们知道了路由器收到数据包后是根据匹配自己路由表的条目来把数据包进行相应地转发的。那么试想,在今天如此大规模的网络互联环境下,尤其是负责核心网建设的运营商,处在核心网的路由器要处理海量的数据,必然它就要存储特别长的路由表(可能会包含几万条路由项),路由表过长就会引起匹配条目的时间过长,也就导致了数据转发延迟过长,造成网络质量差的效果,为了解决这个问题,提出了路由聚合的技术,也称为超网


    VLSM和CIDR

    VLSM是指“可变长子网掩码”,这个概念我们在前面其实已经了解到,但没有正式提出这个术语。可变长的意思是根据实际的需求,打破A/B/C类标准的子网掩码。例如,在一个公司的不同部门,技术部要求100台电脑,财务部要求30台电脑,研发部要求10台电脑,此时公司申请到一个C类地址块,该怎样划分子网来符合这样的需求,就是应用可变长的掩码来进行划分子网的。

    虽然在这里VLSM并不是一个新概念,但是在这里提出是为了更好的引出CIDR的概念,因为CIDR是在VLSM的基础上发展而来的。

    CIDR是指“无类别域间路由”,只看这个定义中的“无类”两个字,就能知道提出CIDR的概念之后,传统的A/B/C等有类的IP地址和子网掩码的概念就不存在了。CIDR有自己独特的表示IP地址和掩码的形式,事实上,现在我们更多用的是这种CIDR的表示形式,因为它更简洁。

    因为有了CIDR概念之后,不再区分传统的A/B/C类的地址,所以也就不必在乎到底哪一类的IP地址的网络位有几位,主机位有几位的问题了

    用CIDR表示IP地址和掩码的方式是这样的:(IP地址/网络前缀)。这个形式也被称为“斜线记法”,斜线前面是IP地址,后面是网络前缀。网络前缀就可以理解成以前的网络号,比如192.168.5.0/24,这就代表着此IP地址的前24位是网络位,那自然后8位就是主机位了。可以看出来,这种记法比传统的写IP地址,再写子网掩码的表示形式简洁多了。


    CIDR地址块

    通过上面用CIDR记法举的例子,我们会发现,CIDR把网络前缀都相同的连续的IP地址组成一个“CIDR地址块”,在这个块内的所有IP地址的网络位都是相同的。(其实跟传统有类IP地址的网段的概念,以及子网掩码必须是连续的0和1,有异曲同工之妙)。

    我们只要知道了一个给定的CIDR地址块中的任何一个地址,都能够推算出来这个地址块里面包含多少个IP地址,并且能推算出这个地址块的最小地址和最大地址。

    比如,给定一个地址块:192.168.123.7/20,现在要算出该地址块的范围:

    第一步,先把IP地址转换为二进制,然后根据“/20”可知前20位是网络位:

    11000000.10101000.01111011.00000111(其中橙色为网络位,紫色为主机位)

    第二步,最小地址即为:把主机位全部为0。最大地址即为:把主机位全部为1:
    11000000.10101000.01110000.00000000(192.168.112.0即为最小地址)
    11000000.10101000.01111111.11111111(192.168.127.255即为最大地址)

    但是要注意的是,因为我们说过主机位是全0和全1都是属于特殊IP地址,一般不用。那么,我们在做题目的时候,如果题目中要求算出“可用的地址范围”的话,那么就要把最小地址加1,最大地址减1,即:可用的地址范围是192.168.112.1~192.168.127.254。

    通过这个简单的例子,就能充分解释CIDR地址块的灵活性,因为我例子给的是“/20”,当然实际情况下,可能会出现各种比如“/13、/14、/23、/27……”,根据网络前缀的位数不同,可包含的主机数就不同,就能灵活地根据需求来组织网络规模的大小。

    由于一个CIDR地址块中有很多地址,所以在路由表中就利用CIDR地址块来查找目的网络,这就是路由聚合的核心思想,它使得路由表中的一个条目可以表示原来传统的有类IP地址的很多个条目,所以路由聚合也称为超网,尤其在大规模的网络中,使路由表缩减的效果极其明显

    现在我们做一个路由聚合成超网的例题,感受路由表缩减的效果:

    使用CIDR技术把4个C类网络202.15.145.0/24、202.15.147.0/24、202.15.149.0/24、202.15.150.0/24汇聚成一个超网,得到的地址是?(此题选自2017下半年网络工程师考试真题)

    做这种题目的方法就是,把这几个IP转换成二进制,观察它们最后的相同位,就确定出了网络前缀的长度,接着再把后面的位数写成0就可以了。

    观察这四个IP,会发现它们都是202.15开头的,只有第三段不一样,所以我们只把每个IP的第三段转换二进制(用橙色把它们四个IP的相同的位数标出来):

    145:10010001

    147:10010011

    149:10010101

    150:10010110

    可以看出这四个数的二进制,前5位是一样的。再加上前面的202.15这16个二进制位,可知汇聚之后的网络前缀是5+16=21,接着再把“10010”后面的位数全为0,即为10010000,转为十进制是144,所以最后的结果是202.15.144.0/21。汇聚完成,原路由表中的四个表项合并成了一个。


    最长前缀匹配

    最长前缀匹配指的是使用CIDR技术之后路由器收到数据包之后,根据数据包目的IP地址来匹配自身路由条目的原则。上节我们学习过的路由器中会存储一个(目的网络,掩码,下一跳)这样的路由表。那么使用CIDR之后,路由表就可以变成(目的网络,前缀,下一跳)这样的格式

    但是这样又存在一个问题,即根据数据包的目的IP来匹配路由表条目,可能会有多个条目都符合结果,这时候路由器应该怎么决定此数据包走哪一个下一跳,所以提出了“最长前缀匹配”原则,如果多个条目都符合结果,那就要比较哪个条码匹配的前缀最长,前缀越长,匹配的结果就越精准

    例如,假定现在路由器中的路由表是这样的:

    目的网络前缀下一跳
    206.0.68.0/22180.15.2.5
    206.0.71.128/25190.16.6.2

    而现在此路由器收到一个目的IP为206.0.71.130的数据包,首先数据包目的IP和本路由表的两个条目的前缀进行“AND”运算(不懂AND运算的话,请回看第29节)

    206.0.71.130和11111111.11111111.11111100.00000000(前22位是1),得出结果是206.0.68.0/22
    206.0.71.130和11111111.11111111.11111111.10000000(前25位是1),得出结果206.0.71.128/25

    可以看出路由表的两个条目都匹配,到底应该交给哪个下一跳,比较前缀的长度,发现第二条明显前缀要比第一条长,所以应该按照第二条路径,下一跳应该交给190.16.6.2。


    本节介绍路由聚合到此为止,原理比较好理解,主要是汇聚路由条目的计算方法以及最长前缀的匹配。下一节,我们将学习NAT技术。

    参考教材:谢希仁《计算机网络》第七版

    更多相关内容
  • 华为 BGP路由聚合

    万次阅读 多人点赞 2020-07-01 11:03:17
    文章目录BGP路由聚合的作用和聚合的方式拓扑基础配置策略与观察TS排错 BGP的聚合相对其他协议的聚合差异较大,且重要性较高,关于手动聚合的属性及策略运用要熟练掌握。 BGP路由聚合的作用和聚合的方式 1、减少...

    业精于勤,荒于嬉;行成于思,毁于随。

    BGP的聚合相对其他协议的聚合差异较大,且重要性较高,关于手动聚合的属性及策略运用要熟练掌握。

    一、BGP聚合

    在中型或大型BGP网络中,BGP路由表会变得十分庞大,存储路由表占用大量的交换机内存资源,传输和处理路由信息需要占用大量的网络资源。使用路由聚合(Routes Aggregation)可以大大减小路由表的规模;另外通过对路由进行聚合,隐藏一些具体的路由,可以减少路由震荡对网络带来的影响。

    BGP路由聚合结合灵活的路由策略,使BGP更有效的传递和控制路由。

    1、减少路由表项网络设备的硬件资源的占用
    2、提高网络的稳定性

    BGP支持两种聚合方式:自动聚合和手动聚合。自动聚合的路由优先级低于手动聚合的路由优先级(宣告聚合路由–配合静态来实现)。

    1.1 BGP路由聚合的作用

    (1)减少路由表的明细路由(减少空间占用和维护每条明细路由带来压力)
    (2)减少因为某些明细路由的频繁更新导致网络波动

    1.2 BGP路由聚合的方式

    (1)summary automatic 自动聚合
    (2)Aggregation 手动聚合
    (3)静态宣告 宣告时宣告手动汇总后的路由(需要再ip路由表静态部署一条指向null 0的手动聚合后的路由)

    二、拓扑

    在这里插入图片描述

    三、基础配置

    1、AS-200运行OSPF协议属于区域0

    2、如图构建BGP邻居,全部建立EBGP邻居(AR-4不运行BGP),开启团体属性通告功能

    3、在AR-4将静态路由及Loopback 1直连路由引入进OSPF,引入后的路由开销为150,类型值为2

    [AR-4]acl 2000                                           //创建基本acl 2000 来匹配192.168.1.4/32的主机路由
    [AR-4-acl-basic-2000]rule permit source 192.168.1.4 0 
    [AR-4-acl-basic-2000]quit 
    [AR-4]route-policy ospf_cost permit node 10              //创建名称为ospf_cost的路由策略节点10	
    [AR-4-route-policy]if-match acl 2000                     //此节点匹配acl 2000抓取的路由
    [AR-4-route-policy]apply cost 150                        //此节点匹配到路由修改开销为150
    [AR-4-route-policy]quit 
    
    [AR-4]ospf 1                                             //进入OSPF进程
    [AR-4-ospf-1]import-route direct route-policy ospf_cost  //引入直连路由时挂接名称为ospf_cost的路由策略进行路由过滤与开销修改
    [AR-4-ospf-1]import-route static cost 150                //引入此设备的静态路由并修改开销为150
    [AR-4-ospf-1]quit 
    

    3.1 自动聚合

    (1)只对引入的BGP路由会自动聚合,network宣告进BGP的路由无法执行自动聚合。
    (2)只对始发与本地的BGP路由聚合会生效,对于通过其他BGP设备传递而来的外部路由聚合不会生效。
    (3)只将聚合后的路由发布出去
    (4)聚合后自动在本地生成一条指向聚合的Null路由来防止可能出现的环路
    (5)默认情况BGP设备的自动聚合是关闭的

    1、在AR-3将Loopback 1接口地址引入进BGP协议并开启自动聚合

    [AR-3]bgp 300	
    [AR-3-bgp]net 192.168.1.3 32 
    [AR-3-bgp]ipv4-family unicast 
    [AR-3-bgp-af-ipv4]summary automatic  //开启本BGP设备的自动汇总,自动汇总只对引入(重分发)进本BGP的路由有效,会将路由汇总为主类路由
    

    四、策略与观察

    1、查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-patch值判断AR-2对于此路由的最优来源选择

    dis bgp routing-table
    在这里插入图片描述
    MED值为0;AS-patch值为300;
    主要是该路由到达目的地的路由是唯一的,所以直接优选。

    2、在AR-2将OSPF路由引入进BGP协议,查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-path值判断AR-2对于此路由的最优来源选择

    [AR-2]bgp 200
    [AR-2-bgp]import-route ospf 
    

    dis bgp routing-table
    在这里插入图片描述
    MED值为150,AS-path值为空(本地产生);为本地始发
    Origin i>e>?
    主要是该路由到达目的地的路由是唯一的,所以直接优选,对到达同一目的地的路由不存在多条。

    3、在AR-2开启自动聚合,查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-path值判断AR-2对于此路由的最优来源选择

    [AR-2]bgp 200
    [AR-2-bgp]summary automatic 
    

    dis bgp routing-table
    在这里插入图片描述
    4、在AR-2通过手动聚合产生192.168.1.0/24的BGP路由,查看AR-2 BGP路由表针对192.168.1.0/24路由的MED值,AS-patch值判断AR-2对于此路由的最优来源选择
    (通告查看192.168.1.0的bgp详细路由信息来区分路由是自动聚合或是手动聚合产生)

    起源属性为“?”是自动聚合产生;
    起源属性为“i”可能是自动聚合产生,也可能是动聚合产生。

    [AR-2-bgp]aggregate 192.168.1.0 24
    

    dis bgp routing-table
    在这里插入图片描述

    [AR-2-bgp]undo summary automatic 
    

    dis bgp routing-table
    在这里插入图片描述
    5、当完成上述内容后,在AR-2的BGP路由表存在几条192.168.1.0/24的路由,同时存在这些路由时优选哪个起源属性的路由,并得出BGP本地起源属性的规则

    BGP本地起源属性:

    BGP的第四条选路原则只有当BGP设备针对同一条路由有多个获取源时,使用第四条选路原则
    手动聚合>自动聚合>IGP>BGP的规则来原则最佳路由

    五、TS排错

    1、现要求AS-100的路由器可以正常接收聚合路由192.168.2.0/24

    [AR-2-bgp]aggregate 192.168.2.0 255.255.255.0 detail-suppressed
    

    dis bgp routing-table
    在这里插入图片描述
    2、此路由需要最好的放环属性

    [AR-2-acl-basic-2000]acl 2020
    [AR-2-acl-basic-2020]rule 20 permit source 192.168.2.0 0.0.0.255
    [AR-2-acl-basic-2020]quit
    [AR-2]route-policy no-ad permit node 10
    [AR-2-route-policy]if-match acl 2020
    [AR-2-route-policy]apply community no-advertise
    [AR-2-route-policy]quit
    [AR-2]route-policy no-ad  permit node 20
    [AR-2-route-policy]quit
    [AR-2]bgp 200
    [AR-2-bgp]peer 12.1.1.1 route-policy no-ad  export 
    

    3、同时只接收192.168.2.0/24内的明细路由192.168.2.3/32

    请在AR-2进行故障排查,修改缺失或者错误配置及策略,满足以上题目需求
    (注意:可做修改与增加配置,不要删除任何配置)

    我这里用的是“反向操作”!!但是最好所有的问题和需求都在聚合策略下完成

    [AR-2]acl 2030
    [AR-2-acl-basic-2030]rule 30 permit source 192.168.2.2 0
    [AR-2-acl-basic-2030]rule 40 permit source 192.168.2.4 0
    [AR-2-acl-basic-2030]quit
    [AR-2]route-policy aa permit node 10
    [AR-2-route-policy]if-match acl 2030
    [AR-2-bgp]undo  peer 12.1.1.1 route-policy no-ad export
    [AR-2-bgp]aggregate 192.168.2.0 255.255.255.0 as-set suppress-policy aa 
    

    dis bgp routing-table
    在这里插入图片描述

    5.1 手动聚合

    1、聚合后明细和聚合路由都发布出去

    (1)对宣告;引入;始发;以及通过BGP学到的路由都会生效
    (2)汇总后将明细和汇总路由都传递出去
    (3)汇总后的路由不再携带明细路由的AS号,只携带汇总设备的AS号,此路由以汇总设备作为始发。
    (4)聚合后自动在本地生成一条指向聚合的Null路由来防止可能出现的环路

      [AR-2-bgp]aggregate 192.168.2.0 24 ?
              as-set              //发出聚合路由时携带明细路由的AS号
              attribute-policy    //为聚合路由添加属性值
              detail-suppressed   //抑制所有的明细路由,只发出聚合路由
              origin-policy       //只有命中指定路由后才会产生此聚合路由(被route-policy命中的的明细)
              suppress-policy     //选择性抑制明细路由(被suppress-policy命中的路由会被抑制)
    

    2、聚合后的路由携带明细AS发布出去

    (1)默认情况下聚合后的路由不再携带原明细路由的AS号,只有本聚合设备的AS然后开始传递,这样聚合路由回传存在环路的风险
    (2)对聚合路由赋予as-set属性,此聚合路由将保留原明细路由的AS属性

    [AR-2-bgp]aggregate 192.168.0.0 22 as-set                  //手动聚合的这条路由将携带明细路由的AS-Path属性发布出去。
    
    [AR-2-bgp]aggregate 40.1.0.0 22 detail-suppressed as-set   //只将聚合后的路由发送给邻居,并携带明细路由的AS-Path属性。
    

    3、只将聚合后的路由发布出去

    (1)对宣告;引入;始发;以及通过BGP学到的路由都会生效
    (2)汇总后只将汇总路由传递出去 ,参与汇总的明细路由将在本地BGP路由表打上“S”被抑制
    (3)汇总后的路由不再携带明细路由的AS号,只携带汇总设备的AS号,此路由以汇总设备作为始发。

     [AR-2-bgp]aggregate 192.168.2.0 24 detail-suppressed        //手动聚合后只将聚合路由传递下去
    
     [AR-2-bgp]aggregate 192.168.2.0 24 suppress-policy aa      //手动聚合后的路由和经过路由策略AAA过滤完的明细路由传递下去
    

    六、策略

    suppress-policy 抑制策略

    作用:抑制BGP对的路由(被抑制的路由不会被邻居通告)
    匹配:Route-policy

    attribute-policy 聚合路由路径属性策略

    作用:修改聚合路由属性
    匹配:Route- policy

    origin- policy 起源策略

    作用:限制聚合路由的条件(只有被origin- policy命中的路由才可以产生聚合路由)
    匹配:route policy

    route policy 路由策略

    作用:过滤路由修改路由属性,匹配路由(抓取路由–基于cost路由匹配)
    匹配:ACL,匹配所以路由

    在这里插入图片描述

    本人所有文章都受版权保护,著作权归艺博东所有!未经授权,转载必究或附上其原创链接。

    展开全文
  • 路由聚合是指将多条具有相同IPv4前缀的路由聚合成一条路由。当大规模部署OSPF网络时,可能会出现由于OSPF路由表规模过大而降低路由查找速度的现象,为了解决这个问题,可以配置路由聚合,减小路由表的规模,降低管理...

    素材来源:华为路由器配置指南

    一边学习一边整理试验笔记,并与大家分享,侵权即删,谢谢支持!

    附上汇总贴:玩转华为ENSP模拟器系列 | 合集_COCOgsta的博客-CSDN博客_ensp实验大全


    目标

    举例说明通过OSPF ABR实现路由聚合的配置方法。

    组网需求

    路由聚合是指将多条具有相同IPv4前缀的路由聚合成一条路由。当大规模部署OSPF网络时,可能会出现由于OSPF路由表规模过大而降低路由查找速度的现象,为了解决这个问题,可以配置路由聚合,减小路由表的规模,降低管理的复杂度。此外,如果被聚合的IPv4地址范围内的某条链路频繁Up和Down,该变化并不会通告到被聚合的IPv4地址范围外的设备。因此,路由聚合还可以避免网络中的路由振荡,在一定程度上提高了网络的稳定性。

    如图1所示,所有设备上都运行OSPF。在ABR上对Area 1内的具有相同前缀(10.0.X.X)的路由聚合为一条路由10.0.0.0/16之后,ABR将只发布这一条路由到Area 0区域中,从而减小路由表的规模,降低管理的复杂度,并提高了网络的稳定性。

    配置思路

    • 配置各接口的IP地址,使网络互通。
    • 在所有设备上使能OSPF的基本功能。
    • 在ABR上配置OSPF ABR路由聚合。

    操作步骤

    1. 配置各接口的IP地址(略)
    2. 配置OSPF基本功能

    配置Device A。

    DeviceA:
    router id 3.3.3.3
    ospf 1
     area 0.0.0.1
      network 10.0.12.0 0.0.0.255
    

    配置Device B。

    DeviceB:
    router id 1.1.1.1
    ospf 1
     area 0.0.0.0
      network 10.1.24.0 0.0.0.255
    

    配置Device C。

    DeviceC:
    router id 4.4.4.4
    ospf 1
     area 0.0.0.1
      network 10.0.34.0 0.0.0.255
    

    配置ABR。

    ABR:
    router id 2.2.2.2
    ospf 1
     area 0.0.0.0
      network 10.1.24.0 0.0.0.255
     area 0.0.0.1
      network 10.0.12.0 0.0.0.255
      network 10.0.34.0 0.0.0.255
    

    配置完成后,执行display ospf peer命令,可以看到Device A、Device B和Device C与ABR之间建立了邻居关系。以ABR的显示结果为例:

    [~ABR]dis ospf peer
    (M) Indicates MADJ neighbor
              OSPF Process 1 with Router ID 2.2.2.2
                    Neighbors
     Area 0.0.0.0 interface 10.1.24.2 (Eth1/0/2)'s neighbors
     Router ID: 1.1.1.1              Address: 10.1.24.1        
       State: Full           Mode:Nbr is Slave      Priority: 1
       DR: 10.1.24.2         BDR: 10.1.24.1         MTU: 0
       Dead timer due in  31  sec
       Retrans timer interval: 5
       Neighbor is up for 00h00m26s
       Neighbor Up Time : 2019-12-28 09:46:36
       Authentication Sequence: [ 0 ]
     Area 0.0.0.1 interface 10.0.34.2 (Eth1/0/0)'s neighbors
     Router ID: 4.4.4.4              Address: 10.0.34.1        
       State: Full           Mode:Nbr is Master     Priority: 1
       DR: 10.0.34.1         BDR: 10.0.34.2         MTU: 0
       Dead timer due in  34  sec
       Retrans timer interval: 5
       Neighbor is up for 00h02m55s
       Neighbor Up Time : 2019-12-28 09:44:06
       Authentication Sequence: [ 0 ]
     Area 0.0.0.1 interface 10.0.12.2 (Eth1/0/1)'s neighbors
     Router ID: 3.3.3.3              Address: 10.0.12.1        
       State: Full           Mode:Nbr is Master     Priority: 1
       DR: 10.0.12.1         BDR: 10.0.12.2         MTU: 0
       Dead timer due in  40  sec
       Retrans timer interval: 5
       Neighbor is up for 00h02m49s
       Neighbor Up Time : 2019-12-28 09:44:12
       Authentication Sequence: [ 0 ]
              OSPF Process 65534 with Router ID 128.1.138.138
                    Neighbors
     Area 0.0.0.0 interface 128.1.138.138 (Eth1/0/0.4094)'s neighbors
     Router ID: 128.1.138.137        Address: 128.1.138.137    
       State: Full           Mode:Nbr is Slave      Priority: 1
       DR: None              BDR: None              MTU: 0
       Dead timer due in  38  sec
       Retrans timer interval: 5
       Neighbor is up for 00h53m31s
       Neighbor Up Time : 2019-12-28 08:53:31
       Authentication Sequence: [ 0 ]
     Area 0.0.0.0 interface 128.1.138.138 (Eth1/0/1.4094)'s neighbors
     Router ID: 128.1.138.139        Address: 128.1.138.139    
       State: Full           Mode:Nbr is Master     Priority: 1
       DR: None              BDR: None              MTU: 0
       Dead timer due in  39  sec
       Retrans timer interval: 5
       Neighbor is up for 00h53m33s
       Neighbor Up Time : 2019-12-28 08:53:29
       Authentication Sequence: [ 0 ]
     Area 0.0.0.0 interface 128.1.138.138 (Eth1/0/2.4094)'s neighbors
     Router ID: 128.1.138.140        Address: 128.1.138.140    
       State: Full           Mode:Nbr is Master     Priority: 1
       DR: None              BDR: None              MTU: 0
       Dead timer due in  38  sec
       Retrans timer interval: 5
       Neighbor is up for 00h00m24s
       Neighbor Up Time : 2019-12-28 09:46:39
       Authentication Sequence: [ 0 ]
     Area 0.0.0.0 interface 128.1.138.138 (DCN-Serial1/0/0:0)'s neighbors
     Router ID: 128.1.138.137        Address: 128.1.138.137    
       State: Full           Mode:Nbr is Slave      Priority: 1
       DR: None              BDR: None              MTU: 0
       Dead timer due in  36  sec
       Retrans timer interval: 5
       Neighbor is up for 00h53m22s
       Neighbor Up Time : 2019-12-28 08:53:41
       Authentication Sequence: [ 0 ]
     Area 0.0.0.0 interface 128.1.138.138 (DCN-Serial1/0/1:0)'s neighbors
     Router ID: 128.1.138.139        Address: 128.1.138.139    
       State: Full           Mode:Nbr is Master     Priority: 1
       DR: None              BDR: None              MTU: 0
       Dead timer due in  30  sec
       Retrans timer interval: 5
       Neighbor is up for 00h53m22s
       Neighbor Up Time : 2019-12-28 08:53:42
       Authentication Sequence: [ 0 ]
    [~ABR]  
    

    在ABR上执行display ospf lsdb命令查看OSPF的链路状态数据库信息。Area 1的数据库中Sum-Net LSA的信息没有进行聚合。因此发布到Area 0的路由没有经过聚合。

    [~ABR]dis ospf lsdb
              OSPF Process 1 with Router ID 2.2.2.2
                      Link State Database
                              Area: 0.0.0.0
     Type      LinkState ID    AdvRouter        Age  Len   Sequence       Metric
     Router    1.1.1.1         1.1.1.1           78  36    80000002            1
     Router    2.2.2.2         2.2.2.2           77  36    80000004            1
     Router    10.2.2.2        10.2.2.2         228  36    80000007            1
     Network   10.1.24.2       2.2.2.2           77  32    80000001            0
     Sum-Net   10.0.12.0       2.2.2.2           82  28    80000002            1
     Sum-Net   10.0.34.0       2.2.2.2           82  28    80000002            1
                              Area: 0.0.0.1
     Type      LinkState ID    AdvRouter        Age  Len   Sequence       Metric
     Router    2.2.2.2         2.2.2.2          221  48    80000003            1
     Router    3.3.3.3         3.3.3.3          222  36    80000002            1
     Router    4.4.4.4         4.4.4.4          228  36    80000002            1
     Network   10.0.12.1       3.3.3.3          222  32    80000001            0
     Network   10.0.34.1       4.4.4.4          228  32    80000001            0
     Sum-Net   10.1.24.0       2.2.2.2          224  28    80000001            1
              OSPF Process 65534 with Router ID 128.1.138.138
                      Link State Database
                              Area: 0.0.0.0
     Type      LinkState ID    AdvRouter        Age  Len   Sequence       Metric
     Router    128.1.138.137   128.1.138.137   1453  60    80000004          100
     Router    128.1.138.138   128.1.138.138     74  96    80000009          100
     Router    128.1.138.139   128.1.138.139   1452  60    80000004          100
     Router    128.1.138.140   128.1.138.140     75  48    80000005          100
                      Type 10 Opaque (Area-Local Scope) Database
     Type      LinkState ID    AdvRouter        Age  Len   Sequence   Area           
     Opq-Area  4.0.0.0         128.1.138.137    975  32    80000003   0.0.0.0        
     Opq-Area  4.0.0.0         128.1.138.138    931  28    80000003   0.0.0.0        
     Opq-Area  4.0.0.0         128.1.138.139    994  32    80000003   0.0.0.0        
     Opq-Area  4.0.0.0         128.1.138.140     75  32    80000004   0.0.0.0        
     Opq-Area  200.1.204.0     128.1.138.137   1512  84    80000002   0.0.0.0        
     Opq-Area  200.1.204.0     128.1.138.138   1513  84    80000002   0.0.0.0        
     Opq-Area  200.1.204.0     128.1.138.139   1510  84    80000002   0.0.0.0        
     Opq-Area  200.1.204.0     128.1.138.140     75  84    80000003   0.0.0.0        
     Opq-Area  200.255.204.0   128.1.138.137   1453  36    80000003   0.0.0.0        
     Opq-Area  200.255.204.0   128.1.138.138   1456  36    80000005   0.0.0.0        
     Opq-Area  200.255.204.0   128.1.138.139   1457  36    80000004   0.0.0.0        
     Opq-Area  200.255.204.0   128.1.138.140     70  36    80000006   0.0.0.0        
     Opq-Area  202.255.238.0   128.1.138.137   1512  68    80000002   0.0.0.0        
     Opq-Area  202.255.238.0   128.1.138.138   1513  68    80000002   0.0.0.0        
     Opq-Area  202.255.238.0   128.1.138.139   1510  68    80000002   0.0.0.0        
     Opq-Area  202.255.238.0   128.1.138.140     75  68    80000003   0.0.0.0        
    [~ABR]
    [~ABR]dis ospf lsdb summary 
              OSPF Process 1 with Router ID 2.2.2.2
                              Area: 0.0.0.0
                      Link State Database
      Type      : Sum-Net
      Ls id     : 10.0.12.0
      Adv rtr   : 2.2.2.2
      Ls age    : 195
      Len       : 28
      Options   :  E
      seq#      : 80000002
      chksum    : 0x300d
      Net mask  : 255.255.255.0
      Tos 0  metric: 1
      Type      : Sum-Net
      Ls id     : 10.0.34.0
      Adv rtr   : 2.2.2.2
      Ls age    : 195
      Len       : 28
      Options   :  E
      seq#      : 80000002
      chksum    : 0x3de9
      Net mask  : 255.255.255.0
      Tos 0  metric: 1
                              Area: 0.0.0.1
                      Link State Database
      Type      : Sum-Net
      Ls id     : 10.1.24.0
      Adv rtr   : 2.2.2.2
      Ls age    : 337
      Len       : 28
      Options   :  E
      seq#      : 80000001
      chksum    : 0xa18f
      Net mask  : 255.255.255.0
      Tos 0  metric: 1
    [~ABR] 
    
    1. 在ABR上配置路由聚合,将Area 1区域内具有相同前缀的路由聚合为一条路由10.0.0.0/16
    ABR:
    ospf 1
     area 0.0.0.1
      abr-summary 10.0.0.0 255.255.0.0
    
    1. 验证配置结果

    配置完路由聚合后,在ABR上执行display ospf lsdb命令,可以看到Area 1区域内具有相同前缀的路由聚合成了一条路由10.0.0.0/16,这条路由发布到了Area 0区域中。

    [~ABR-ospf-1]dis ospf lsdb
              OSPF Process 1 with Router ID 2.2.2.2
                      Link State Database
                              Area: 0.0.0.0
     Type      LinkState ID    AdvRouter        Age  Len   Sequence       Metric
     Router    1.1.1.1         1.1.1.1          364  36    80000002            1
     Router    2.2.2.2         2.2.2.2          363  36    80000004            1
     Router    10.2.2.2        10.2.2.2         514  36    80000007            1
     Network   10.1.24.2       2.2.2.2          363  32    80000001            0
     Sum-Net   10.0.0.0        2.2.2.2           86  28    80000001            1
                              Area: 0.0.0.1
     Type      LinkState ID    AdvRouter        Age  Len   Sequence       Metric
     Router    2.2.2.2         2.2.2.2          507  48    80000003            1
     Router    3.3.3.3         3.3.3.3          508  36    80000002            1
     Router    4.4.4.4         4.4.4.4          514  36    80000002            1
     Network   10.0.12.1       3.3.3.3          508  32    80000001            0
     Network   10.0.34.1       4.4.4.4          514  32    80000001            0
     Sum-Net   10.1.24.0       2.2.2.2          510  28    80000001            1
              OSPF Process 65534 with Router ID 128.1.138.138
                      Link State Database
                    
                              Area: 0.0.0.0
     Type      LinkState ID    AdvRouter        Age  Len   Sequence       Metric
     Router    128.1.138.137   128.1.138.137   1739  60    80000004          100
     Router    128.1.138.138   128.1.138.138    360  96    80000009          100
     Router    128.1.138.139   128.1.138.139   1738  60    80000004          100
     Router    128.1.138.140   128.1.138.140    361  48    80000005          100
                      Type 10 Opaque (Area-Local Scope) Database
     Type      LinkState ID    AdvRouter        Age  Len   Sequence   Area           
     Opq-Area  4.0.0.0         128.1.138.137   1261  32    80000003   0.0.0.0        
     Opq-Area  4.0.0.0         128.1.138.138   1217  28    80000003   0.0.0.0        
     Opq-Area  4.0.0.0         128.1.138.139   1280  32    80000003   0.0.0.0        
     Opq-Area  4.0.0.0         128.1.138.140    361  32    80000004   0.0.0.0        
     Opq-Area  200.1.204.0     128.1.138.137   1798  84    80000002   0.0.0.0        
     Opq-Area  200.1.204.0     128.1.138.138   1799  84    80000002   0.0.0.0        
     Opq-Area  200.1.204.0     128.1.138.139   1796  84    80000002   0.0.0.0        
     Opq-Area  200.1.204.0     128.1.138.140    361  84    80000003   0.0.0.0        
     Opq-Area  200.255.204.0   128.1.138.137   1739  36    80000003   0.0.0.0        
     Opq-Area  200.255.204.0   128.1.138.138   1742  36    80000005   0.0.0.0        
     Opq-Area  200.255.204.0   128.1.138.139   1743  36    80000004   0.0.0.0        
     Opq-Area  200.255.204.0   128.1.138.140    356  36    80000006   0.0.0.0        
     Opq-Area  202.255.238.0   128.1.138.137   1798  68    80000002   0.0.0.0        
     Opq-Area  202.255.238.0   128.1.138.138   1799  68    80000002   0.0.0.0        
     Opq-Area  202.255.238.0   128.1.138.139   1796  68    80000002   0.0.0.0        
     Opq-Area  202.255.238.0   128.1.138.140    361  68    80000003   0.0.0.0        
    [~ABR-ospf-1] 
    [~ABR-ospf-1]dis ospf lsdb summary 
              OSPF Process 1 with Router ID 2.2.2.2
                              Area: 0.0.0.0
                      Link State Database
      Type      : Sum-Net
      Ls id     : 10.0.0.0
      Adv rtr   : 2.2.2.2
      Ls age    : 101
      Len       : 28
      Options   :  E
      seq#      : 80000001
      chksum    : 0xb693
      Net mask  : 255.255.0.0
      Tos 0  metric: 1
                              Area: 0.0.0.1
                      Link State Database
      Type      : Sum-Net
      Ls id     : 10.1.24.0
      Adv rtr   : 2.2.2.2
      Ls age    : 525
      Len       : 28
      Options   :  E
      seq#      : 80000001
      chksum    : 0xa18f
      Net mask  : 255.255.255.0
      Tos 0  metric: 1
    [~ABR-ospf-1]  

     

    展开全文
  • r2(config)#access-list 1 per 192.168.1.0 0.0.0.255 r2(config)#route-map aaa per 10 r2(config-route-map)#match ip add 1 ...只从1.1.1.1接受192.168.1.0的路由 ip prefix-list aaa seq 1..

    目录

    一、路由聚合:

    二、路由过滤 :

    (1)ACL过滤

    (2)Prefix-list过滤(常用):

     (3)distribute路由过滤:

    三、路由聚合+路由过滤:

    四、把本地抑制路由传给邻居:

     五、路由聚合过程中修改属性: 

    六、路由过滤中修改属性  :

    七、过滤优先级


    注:所有案列拓扑图一致

    一、路由聚合:

    aggregate-address 192.168.0.0 255.255.248.0 suppress-map aaa summary-only as-set

    聚合过程中过滤,ACL的permit做聚合,deny不做聚合,放行明细,即使加上summary-only也会放行192.168.1.0

    案列:

     

     

     

     

     

    ———————————————————————————————————————————————————————— 

    二、路由过滤 :

    (1)ACL过滤

    r2(config)#access-list 1 per 192.168.1.0 0.0.0.255
    r2(config)#route-map aaa per 10
    r2(config-route-map)#match ip add 1
    r2(config)#router bgp 100
    r2(config-router)#nei 1.1.1.1 route-map aaa in //从1.1.1.1只接收192.168.1.0的路由

    (2)Prefix-list过滤(常用):

    ip prefix-list aaa seq 1 deny 192.168.1.0/24  匹配192.168.1.0/24的BGP路由,执行拒绝
    ip prefix-list aaa seq 2 permit 0.0.0.0/0 le 32  匹配剩余的0大于等于32掩码的BGP路由执行放行
    定义策略路由,名字为bbb,在策略路由bbb里面调用上面的前缀列表aaa    
    route-map bbb permit 10
     match ip address prefix-list aaa
    router bgp 200
     neighbor 23.1.1.2 route-map bbb in  // 从23.1.1.2接收BGP路由的时候执行过滤,怎么过滤,通过route-map BBB里面的策略过滤
    
     

    案列: 

              

     

     

     (3)distribute路由过滤:

    access-list 1 permit 192.168.1.0 0.0.0.255
    router bgp 200
    distribute-list 1 in

    实现功能:只允许192.168.1.0的路由进来,进程里面使用

     ———————————————————————————————————————————————————————

    access-list 1 permit 192.168.1.0 0.0.0.255
    router bgp 200
    nei 4.4.4.4 distribute-list 1 in//neighbor

    实现功能:只允许从4.4.4.4收满足ACLpermit流量路由,后面使用

     

    ——————————————————————————————————————————————————————

    三、路由聚合+路由过滤:

    access-list 1 deny   192.168.1.0 0.0.0.255
    access-list 1 permit any
    route-map aaa permit 10
     match ip address 1
    router bgp 200
    aggregate-address 192.168.0.0 255.255.248.0 suppress-map aaa summary-only as-set
    聚合过程中过滤,ACL的permit做聚合,deny不做聚合,放行明细,即使加上summary-only也会放行192.168.1.0
    ip prefix-list aaa seq 1 deny 192.168.1.0/24
    ip prefix-list aaa seq 2 permit 0.0.0.0/0 le 32
    router bgp 200
     aggregate-address 192.168.0.0 255.255.248.0 as-set summary-only suppress-map aaa

    ———————————————————————————————————————————————————————— 

    四、把本地抑制路由传给邻居:

    access-list 1 permit 192.168.1.0 0.0.0.255
     route-map aaa permit 10
     match ip address 1
     router bgp 200
     aggregate-address 192.168.0.0 255.255.248.0 summary-only
     neighbor 4.4.4.4 unsuppress-map aaa
     把我本地抑制的路由传给4.4.4.4邻居,且是active

    —————————————————————————————————————————————————————————— 

     五、路由聚合过程中修改属性: 

    route-map aaa permit 10
     set local-preference 120//修改本地优先级
    router bgp 200
    aggregate-address 192.168.0.0 255.255.248.0 summary-only as-set  attribute-map aaa

    注意:

    聚合中修改汇总路由属性,注意尽量不和ACL连用

    ***不支持修改AS-PATH!!

    聚合时候route-map 和att…map是同一个意思

    —————————————————————————————————————————————————————————— 

    六、路由过滤中修改属性  :

    ip prefix-list aaa seq 1 deny 100.1.1.0/24
    ip prefix-list aaa seq 5 permit 0.0.0.0/0 le 32
    route-map bbb permit 10
     match ip address prefix-list aaa
     set metric 8
    exit
    router bgp 300
    neighbor 67.1.1.6 route-map bbb in
    exit

    实现功能: 不给67.1.1.6发送100.1.1.0,其他路由修改MED为8

     ——————————————————————————————————————————————————

    七、过滤优先级

    出方向:route-map过滤-----filter-list----------prefix-list

    进方向:prefix-list  -------filte-list -------route-map

    展开全文
  • 路由聚合与地址聚合

    千次阅读 2021-11-09 15:50:27
    路由聚合与地址聚合 CIDR 无分类域间路由选择CIDR (Classless Inter-Domain Routing) 无分类的两级编址的记法是: CIDR 使用“斜线记法”(slash notation),它又称为CIDR 记法,即在 IP 地址面加上一个斜线“/”,...
  • BGP自动路由聚合

    千次阅读 2021-05-04 22:13:15
    BGP自动路由聚合 一. 原理概述     在大型网络中,路由条目通常多达成千上万条,所以如何存储并有效管理如此多的路由信息就显得十分重要了。     BGP是一种无类路由协议,支持CIDR,VLSM和路由聚合路由...
  • 路由聚合

    千次阅读 2020-03-12 17:27:43
    假设下面有4个网络: 172.18.129.0/24 后面的24...如果这四个进行路由汇聚,能覆盖这四个网络的汇总地址是:172.18.128.0/21 算法思路是,首先从左到右开始,把不同的那个ip数字换算成二进制,即 129 二进制 1000 000...
  • OSPF路由聚合(学习笔记+实验验证)

    千次阅读 多人点赞 2020-04-30 18:50:44
    路由聚合原理概述注:路由聚合算法实验目的实验内容实验拓扑编址表实验步骤1,基本配置1)各个接口IP配置2)S1的vlan和IP的配置3)配置access接口4)开启OSPF5)配置area2为NSSA区域2,路由引入1)在R4上配置去往外部...
  • 路由聚合是指将多条具有相同IPv6前缀的路由聚合成一条路由。当大规模部署OSPFv3网络时,可能会出现由于OSPFv3路由表规模过大而降低路由查找速度的现象,为了解决这个问题,可以配置路由聚合,减小路由表的规模,降低...
  • NP、OSPF路由聚合

    2020-12-09 21:33:18
    与RIP不同,OSPF不支持自动路由聚合,仅支持手动路由聚合。OSPF路由聚合有两种机制:区域间路由聚合和外部路由聚合。区域间路由聚合必须配置在ABR路由器上,指的是ABR在把与自己直接相连区域(Area)中的Type-1和...
  • BGP的属性、路由聚合

    2021-10-16 21:10:08
    Origin属性定义路径信息的来源,标记一条路由是怎么成为BGP路由的。 AS_Path 如图所示: AS 1内的RTA能够从RTB与RTC收到100.0.0.0/24的路由,RTA如何进行自动优选? RTA->RTB->RTC之间在拓扑上存在环路,...
  • 路由聚合原理和举例

    万次阅读 多人点赞 2020-05-30 19:16:11
    **前言:**最近在学习网络子网划分,学到路由聚合发现有点小问题,顺便把各大博主的题目整合学习一下。 路由汇聚: 是把一组路由汇聚为一个单个的路由广播。路由汇聚的最终结果和最明显的好处是缩小网络上的路由表的...
  • CIDR与路由聚合系列文章目录CIDR与路由聚合CIDR路由聚合 CIDR与路由聚合 在有类地址的分配和使用过程中存在问题,分配效率低,造成地址浪费,路由过程效率低。所以提出新的技术CIDR CIDR Prefix前缀 超网:将两个...
  • BGP手动路由聚合原理概述实验目的实验内容实验拓扑实验步骤1,基本配置2,配置BGP路由协议3,配置BGP路由聚合4,属于No-Advertise关键字控制路由聚合5,使用Detail-Suppressed关键字控制路由聚合6,使用Suppress-Policy...
  • BGP 自动路由聚合

    2021-01-25 10:09:11
    BGP 是一种无类路由协议,支持CIDR、VLSM(无类别域间路由,可变长子网掩码)和路由聚合路由聚合技术的使用,可以在一定程度上缩减路由条目的数量,同时还可以减轻路由震荡导致的网络不稳定的问题。BGP的路由聚合...
  • 路由汇总与路由聚合的区别

    千次阅读 2021-03-03 08:55:23
    什么是路由汇总,什么是路由聚合 其实汇总跟聚合的概念差不多,都是把多条路由合并为一条,但是什么情况下叫汇总,什么情况下叫聚合呢?这里就引发一个“超网路由”的概念。 多条路由合并成一条时,如果这个合并的...
  • BGP 路由聚合(Huawei设备)

    千次阅读 2020-10-31 19:20:16
    文章目录BGP 路由的聚合所产生的问题参考阅读说明一、实验搭建1.1 配置EBGP1.2 宣告路由1.3 路由聚合1.3.1 network方式1.3.2 aggregate方式1.4 团体属性1.5 AS-Path属性二、附加思考 BGP 路由的聚合所产生的问题 ...
  • 今天给大家介绍一种常见的潜在路由环路风险的网络——路由聚合引发的潜在路由环路风险网络,如果您对此还不甚了解,一定要赶紧看完本篇文章。路由聚合是我们在配置动态路由协议时常见的一种配置方式,但是如果我们...
  • 基于ISIS路由协议的路由聚合

    千次阅读 2020-06-19 18:57:10
    1.配置基于ISIS路由协议的路由聚合 2.配置基于ISIS路由协议的路由引入 二、注意事项 1.全局使能ISIS功能之后,还必须在接口上使能ISIS功能 三、ISIS路由聚合和引入 1.路由器只对本地生成,并向ISIS邻居路由器发布的...
  • 计算机网络网络层之IP协议(6)——CIDR与路由聚合 CIDR 无类域间路由(CIDR:classless interdomain routing) 消除传统的A类、B类和C类地址界限 NetID+SubID→Network Prefix(Prefix)可以任意长度 融合...
  • 华三 h3c ospf路由聚合

    千次阅读 2020-12-21 17:59:03
    ASE2 150 1 20.0.0.1 GE0/1 192.168.3.0/24 O_ASE2 150 1 20.0.0.1 GE0/1 在R1上配置路由聚合 [R1-ospf-1]asbr-summary 192.168.0.0 22---注意了,在ASBR上配置聚合路由时是在ospf进程视图下面配置,并非像在ABR配置...
  • 将物理位置连续的网络分配地址连续的网段,就可以在边界路由器上将远程的网络合并成一条路由,这就是路由汇总。 路由表里面的条目越多,给数据包寻址,选择转发出口的时候,查找的时间就越长。如果路由表里面就两条...
  • 华为设备配置IS-IS的路由聚合
  • 路由聚合(构造超网) 如果有多个网段连接在一个路由器上,可以通过路由聚合将五条路由信息聚合成一个路由信息 几个网段中共同的网络前缀组成聚合地址块,聚合地址块是路由聚合之后存储的路由信息 例题 最长前缀...
  • 综合运用路由备份和路由聚合,深入理解这两个东东的作用 实验拓扑 实验配置的限制条件 1、按照图示配置 IP 地址,R3 上连接 192.168.X.X/24 4个业务网段 2、配置 RIPv2 协议使全网互通,R1 和 R3 的直连链路不运行 ...
  • 详细介绍了Cisco Packet Tracer中路由的运作机制,说明了路由聚合的原理并且通过实例验证计算的准确性
  • IPV4支持自动聚合、手工聚合,IPV6只支持手工聚合,以下主要研究IPV4路由聚合。 如图所示拓扑,R5上存在三条外部路由,分别为1.1.1.0/24、1.1.2.0/24、1.1.3.0/24,R4存在一条外部路由为1.1.0.0/24。R5、R4、R8...
  • bgp的路由聚合

    万次阅读 2018-03-16 17:05:54
    bgp路由聚合分为自动聚合和手动聚合。自动聚合:对BGP引入的IGP子网路由进行自然掩码也就是主类路由聚合,配置自动聚合后,生成聚合后的自然网络路由,而原先引入的子网路由被抑制,不会被优先和发布给BGP邻居。自动...
  • 详解超网技术(路由聚合技术)

    万次阅读 多人点赞 2018-03-05 21:58:38
    超网(路由聚合)技术是为了解决路由表的内容冗余问题,使用路由聚合能够缩小路由表的规模,减少路由表的内存。 超网与子网的异同 子网划分是为了让我们拥有更小的网络,每个网络的主机数可以放得少一些。超...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 49,544
精华内容 19,817
关键字:

路由聚合