精华内容
下载资源
问答
  • eNSP交换机配置VLAN

    万次阅读 多人点赞 2019-05-13 22:42:35
    eNSP交换机配置VLAN 一、VLAN配置过程。 1. 搭建拓扑结构。 运行eNSP>新建拓扑>搭建如下图的拓扑结构>启动设备 2. 测试主机间连通性。 2.1 四台主机基础配置如下: PC1: IP地址:192.168.2.2 子网...

    eNSP交换机配置VLAN

    一、VLAN配置过程。
    1. 搭建拓扑结构。
    运行eNSP>新建拓扑>搭建如下图的拓扑结构>启动设备
    图1
    2. 测试主机间连通性。
    2.1 四台主机基础配置如下:

    PC1:   IP地址:192.168.2.2   子网掩码:255.255.255.0   网关:192.168.2.0
    PC2:   IP地址:192.168.2.3   子网掩码:255.255.255.0   网关:192.168.2.0
    PC3:   IP地址:192.168.2.4   子网掩码:255.255.255.0   网关:192.168.2.0
    PC4:   IP地址:192.168.2.5   子网掩码:255.255.255.0   网关:192.168.2.0
    

    2.2 测试主机间连通性:
    运用ping命令测试各主机间连通性。
    PC1:

    PC>ping 192.168.2.3
    
    Ping 192.168.2.3: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.3: bytes=32 seq=1 ttl=128 time=47 ms
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: bytes=32 seq=1 ttl=128 time=63 ms
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: bytes=32 seq=1 ttl=128 time=62 ms
    

    如上,PC1与其他三台主机间都能连通。
    PC2:

    PC>ping 192.168.2.2
    
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: bytes=32 seq=1 ttl=128 time=47 ms
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: bytes=32 seq=1 ttl=128 time=79 ms
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: bytes=32 seq=1 ttl=128 time=32 ms
    

    如上,PC2与其他三台主机间都能连通。
    PC3与PC4经测试都能与其他三台主机连通,篇幅原因命令语句在此不进行展示。
    3. 配置交换机。
    3.1 配置交换机LSW1:
    3.1.1 进入管理员系统,构建VLAN2,VLAN3,查看VLAN。

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]vlan 2
    [Huawei-vlan2]quit
    [Huawei]vlan 3
    [Huawei-vlan3]quit
    [Huawei]display vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(D)     
                    Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    
    2    common  
    3    common  
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003      
    

    3.1.2 将0/0/1和0/0/2端口设置为access类型:

    [Huawei]interface Ethernet 0/0/1    
    [Huawei-Ethernet0/0/1]port link-type access
    [Huawei-Ethernet0/0/1]port default vlan 2  
    [Huawei-Ethernet0/0/1]quit 
    [Huawei]interface Ethernet 0/0/2
    [Huawei-Ethernet0/0/2]port link-type access
    [Huawei-Ethernet0/0/2]port default vlan 3
    [Huawei-Ethernet0/0/2]quit             
    [Huawei]
    

    3.1.3 将0/0/3端口设置为trunk类型:

    [Huawei]interface Ethernet 0/0/3
    [Huawei-Ethernet0/0/3]port link-type trunk
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 2
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 3
    [Huawei-Ethernet0/0/3]quit
    

    3.1.4 查看VLAN:

    [Huawei]display vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/3(U)     Eth0/0/4(D)     Eth0/0/5(D)     Eth0/0/6(D)     
                    Eth0/0/7(D)     Eth0/0/8(D)     Eth0/0/9(D)     Eth0/0/10(D)    
                    Eth0/0/11(D)    Eth0/0/12(D)    Eth0/0/13(D)    Eth0/0/14(D)    
                    Eth0/0/15(D)    Eth0/0/16(D)    Eth0/0/17(D)    Eth0/0/18(D)    
                    Eth0/0/19(D)    Eth0/0/20(D)    Eth0/0/21(D)    Eth0/0/22(D)    
                    GE0/0/1(D)      GE0/0/2(D)                                      
    
    2    common  UT:Eth0/0/1(U)                                                     
    
                 TG:Eth0/0/3(U)                                                     
    
    3    common  UT:Eth0/0/2(U)                                                     
    
                 TG:Eth0/0/3(U)                                                     
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    [Huawei]
    

    3.2 配置交换机LSW2:
    步骤同上,配置LSW2,在此不描述详细步骤,只展示交换机命令。

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]vlan 2
    [Huawei-vlan2]quit 
    [Huawei]vlan 3
    [Huawei-vlan3]quit
    [Huawei]interface Ethernet 0/0/1
    [Huawei-Ethernet0/0/1]port link-type access 
    [Huawei-Ethernet0/0/1]port default vlan 3
    [Huawei-Ethernet0/0/1]quit
    [Huawei]interface Ethernet 0/0/2
    [Huawei-Ethernet0/0/2]port link-type access 
    [Huawei-Ethernet0/0/2]port default vlan 2
    [Huawei-Ethernet0/0/2]quit 
    [Huawei]interface Ethernet 0/0/3
    [Huawei-Ethernet0/0/3]port link-type trunk
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 2
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 3
    [Huawei-Ethernet0/0/3]quit 
    [Huawei]display vlan 
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/3(U)     Eth0/0/4(D)     Eth0/0/5(D)     Eth0/0/6(D)     
                    Eth0/0/7(D)     Eth0/0/8(D)     Eth0/0/9(D)     Eth0/0/10(D)    
                    Eth0/0/11(D)    Eth0/0/12(D)    Eth0/0/13(D)    Eth0/0/14(D)    
                    Eth0/0/15(D)    Eth0/0/16(D)    Eth0/0/17(D)    Eth0/0/18(D)    
                    Eth0/0/19(D)    Eth0/0/20(D)    Eth0/0/21(D)    Eth0/0/22(D)    
                    GE0/0/1(D)      GE0/0/2(D)                                      
    
    2    common  UT:Eth0/0/2(U)                                                     
    
                 TG:Eth0/0/3(U)                                                     
    
    3    common  UT:Eth0/0/1(U)                                                     
    
                 TG:Eth0/0/3(U)                                                     
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    [Huawei]	
    

    至此,两台交换机配置完成。
    4.实验验证。
    4.1 测试VLAN中各主机间连通性:
    ping命令测试:
    PC1:

    PC>ping 192.168.2.3
    
    Ping 192.168.2.3: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    
    --- 192.168.2.3 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    
    --- 192.168.2.4 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: bytes=32 seq=1 ttl=128 time=62 ms
    From 192.168.2.5: bytes=32 seq=2 ttl=128 time=78 ms
    From 192.168.2.5: bytes=32 seq=3 ttl=128 time=78 ms
    From 192.168.2.5: bytes=32 seq=4 ttl=128 time=47 ms
    From 192.168.2.5: bytes=32 seq=5 ttl=128 time=63 ms
    
    --- 192.168.2.5 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 47/65/78 ms
    

    PC2:

    PC>ping 192.168.2.2
    
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    
    --- 192.168.2.2 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: bytes=32 seq=1 ttl=128 time=63 ms
    From 192.168.2.4: bytes=32 seq=2 ttl=128 time=62 ms
    From 192.168.2.4: bytes=32 seq=3 ttl=128 time=63 ms
    From 192.168.2.4: bytes=32 seq=4 ttl=128 time=62 ms
    From 192.168.2.4: bytes=32 seq=5 ttl=128 time=63 ms
    
    --- 192.168.2.4 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 62/62/63 ms
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    
    --- 192.168.2.5 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    PC3:

    PC>ping 192.168.2.2
    
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    
    --- 192.168.2.2 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.3
    
    Ping 192.168.2.3: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.3: bytes=32 seq=1 ttl=128 time=63 ms
    From 192.168.2.3: bytes=32 seq=2 ttl=128 time=62 ms
    From 192.168.2.3: bytes=32 seq=3 ttl=128 time=63 ms
    From 192.168.2.3: bytes=32 seq=4 ttl=128 time=63 ms
    From 192.168.2.3: bytes=32 seq=5 ttl=128 time=62 ms
    
    --- 192.168.2.3 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 62/62/63 ms
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    
    --- 192.168.2.5 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    PC4:

    PC>ping 192.168.2.2
    
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: bytes=32 seq=1 ttl=128 time=94 ms
    From 192.168.2.2: bytes=32 seq=2 ttl=128 time=31 ms
    From 192.168.2.2: bytes=32 seq=3 ttl=128 time=62 ms
    From 192.168.2.2: bytes=32 seq=4 ttl=128 time=63 ms
    From 192.168.2.2: bytes=32 seq=5 ttl=128 time=62 ms
    
    --- 192.168.2.2 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 31/62/94 ms
    
    PC>ping 192.168.2.3
    
    Ping 192.168.2.3: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    
    --- 192.168.2.3 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    
    --- 192.168.2.4 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    4.2 测试结果:
    通过ping命令测试,可得结果为:

    PC1与PC4之间相互连通,与PC2、PC3不通。
    PC2与PC3之间相互连通,与PC1、PC4不通。
    PC3与PC2之间相互连通,与PC1、PC4不通。
    PC4与PC1之间相互连通,与PC2、PC3不通。
    

    4.3 实验结论:

    PC1与PC4属于VLAN2;
    PC2与PC3属于VLAN3.
    VLAN构建成功。
    

    二、相关知识点。

    1.什么是VLAN?
    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。

    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。

    2.VLAN的作用。
    通过划分不同的VLAN,VLAN内的主机间可以直接通信,而VLAN间不能直接互通,从而将广播报文限制在一个VLAN内。
    作用:限制广播域、增强局域网的安全性(不同VLAN用户不能直接通信)、提高网络的健壮性(限制故障)、灵活构建虚拟工作组(同一VLAN用户不局限于固定的物理范围)。

    3. VLAN的优点。
    3.1 端口的分隔。
    即便在同一个交换机上,处于不同VLAN的端口也是不能通信的。这样一个物理的交换机可以当作多个逻辑的交换机使用。
    3.2 网络的安全。
    不同VLAN不能直接通信,杜绝了广播信息的不安全性。
    3.3 灵活的管理。
    更改用户所属的网络不必换端口和连线,只需更改软件配置。
    VLAN技术的出现,使得管理员根据实际应用需求,把同一物理局域网内的不同用户逻辑地划分成不同的广播域,每一个VLAN都包含一组有着相同需求的计算机工作站,与物理上形成的LAN有着相同的属性。由于它是从逻辑上划分,而不是从物理上划分,所以同一个VLAN内的各个工作站没有限制在同一个物理范围中,即这些工作站可以在不同物理LAN网段 。由VLAN的特点可知,一个VLAN内部的广播和单播流量都不会转发到其他VLAN中,从而有 助于控制流量、减少设备投资、简化网络管理、提高网络的安全性。 VLAN除了能将网络划 分为多个广播域,从而有效地控制广播风暴的发生,以及使网络的拓扑结构变得非常灵活 的优点外,还可以用于控制网络中不同部门、不同站点之间的互相访问。

    4.交换机端口类型。
    4.1 Access
    Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    4.2 Trunk
    Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;
    4.3 Hybrid
    Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

    Hybrid端口和Trunk端口在接收数据时,处理方法一样,唯一不同之处在于发送数据时:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    展开全文
  • 交换机VLAN配置 1)交换机配置——Access/Trunk 如图,交换机LSW4和LSW5分别连接两台PC机 现在想要将PC6和PC8在VLAN2下,可相互连接 将PC7和PC9在VLAN3下,可相互连接 交换机各个接口配置如图 【系统视图下save保存...

    交换机VLAN配置

    1)交换机配置——Access/Trunk

    如图,交换机LSW4和LSW5分别连接两台PC机
    现在想要将PC6和PC8在VLAN2下,可相互连接
    将PC7和PC9在VLAN3下,可相互连接
    交换机各个接口配置如图
    【系统视图下save保存,否则掉电丢失配置】

    vlan batch 2 to 3
    
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
     quit
    
    interface Ethernet0/0/1
     port link-type access
     port default vlan 2
     quit
     
    interface Ethernet0/0/2
     port link-type access
     port default vlan 3
     quit
    
    #退出 到系统视图
    quit
    #保存
    save
    Y
    

    在这里插入图片描述

    2)hybrid

    如图2,PC6-1,PC7-1和PC8-1分别属于不同的VLAN
    实现PC6-1和PC7-1都能访问PC8-1(邮件服务器)
    但是PC6-1和PC7-1之间不能相互访问
    在这里插入图片描述

    展开全文
  • eNSP交换机VLAN及Trunk基本配置

    千次阅读 2020-04-02 00:20:15
       以下的配置为主要熟悉了解各项命令的作用,如果有不对的地方请告知更改,以免影响他人。                   也希望多多评论交流 ============================================...

    在这里插入图片描述

    =================================================================================
       以下的配置为主要熟悉了解各项命令的作用,如果有不对的地方请告知更改,以免影响他人。
                      也希望多多评论交流

    =================================================================================

    一个VLAN内部的广播和单播流量都不会转发到其他VLAN中,即使是处在同一网段的两台计算机。
    如果不在同一VLAN中,它们各自的广播也不会相互转发
    划分VLAN有助于控制流量、减少设备投资、简化网络管理、提高网络的安全性
    VLAN能够隔离广播风暴
    也能隔离不同VLAN之间的通讯,因此不同VLAN之间的通讯必须依靠路由器或者三层交换机来实现

    =================================================================================
    SW1:
    system-view                 /进入系统视图(默认为用户视图)
    [Huawei]sysn SW1              /更名为SW1
    [SW1]vlan batch 10 20            /创建多个VLAN
    [SW1]int e0/0/1                /进入0/0/1接口
    [SW1-Ethernet0/0/1]port link-type access    /创建端口类型
    [SW1-Ethernet0/0/1]port default vlan 10     /端口默认为VLAN10
    [SW1]int e0/0/2                /进入0/0/2接口
    [SW1-Ethernet0/0/2]port link-type access     /创建端口类型
    [SW1-Ethernet0/0/2]port default vlan 20      /端口默认为VLAN20
    [SW1]int e0/0/3                /进入0/0/3接口
    [SW1-Ethernet0/0/3]port link-type trunk      /设置端口性质
    [SW1-Ethernet0/0/3]port trunk allow-pass vlan all /显示设置端口类型及所有VLAN通行

    =================================================================================
    SW2:
    system-view                  /进入系统视图(默认为用户视图)
    [Huawei]sysname SW2             /更名为SW2
    [SW2]vlan batch 30 40              /创建多个VLAN
    [SW2]int e0/0/1                   /进入0/0/1接口
    [SW2-Ethernet0/0/1]port link-type access       /创建端口类型
    [SW2-Ethernet0/0/1]port default vlan 30         /端口默认为VLAN30
    [SW2]int e0/0/2                         /进入0/0/2接口
    [SW2-Ethernet0/0/2]port link-type access       /创建端口类型
    [SW2-Ethernet0/0/2]port default vlan 40         /端口默认为VLAN40
    [SW2]int e0/0/3                         /进入0/0/3接口
    [SW2-Ethernet0/0/3]port link-type trunk         /输出输入端口均为
    [SW2-Ethernet0/0/3]port trunk allow-pass vlan all   /显示设置端口类型及所有VLAN通行

    =================================================================================

    SW3:
    system-view                           /进入系统视图(默认为用户视图)
    [Huawei]sysname SW3                       /更名为SW3
    [SW3]vlan batch 50 60                       /创建多个VLAN
    [SW3]int e0/0/1                         /进入0/0/1接口
    [SW3-Ethernet0/0/1]port link-type access       /创建端口类型
    [SW3-Ethernet0/0/1]port default vlan 50        /端口默认为VLAN50
    [SW3]int e0/0/2                         /进入0/0/2接口
    [SW3-Ethernet0/0/2]port link-type access        /创建端口类型
    [SW3-Ethernet0/0/2]port default vlan 60         /端口默认为VLAN60
    [SW3]int e0/0/3 /进入0/0/3接口
    [SW3-Ethernet0/0/3]port link-type trunk         /输出输入端口均为
    [SW3-Ethernet0/0/3]port trunk allow-pass vlan all   /显示设置端口类型及所有VLAN通行

    =================================================================================

    SW4:
    system-view                             /进入系统视图(默认为用户视图)
    [Huawei]sysname SW4                      /更名为SW4
    [SW4]vlan batch 10 20 30 40 50 60             /创建多个VLAN
    [SW4]port-group                          /端口组
    [SW4-port-group-1]group-member g0/0/1 to g0/0/3  /1接口到3接口组成端口组
    [SW4-port-group-1]port link-type trunk           /创建端口类型
    [SW4-GigabitEthernet0/0/1]port link-type trunk
    [SW4-GigabitEthernet0/0/2]port link-type trunk
    [SW4-GigabitEthernet0/0/3]port link-type trunk
    [SW4-port-group-1]port trunk allow-pass vlan all     /显示设置端口类型及所有VLAN通行
    [SW4-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [SW4-GigabitEthernet0/0/2]port trunk allow-pass vlan all
    [SW4-GigabitEthernet0/0/3]port trunk allow-pass vlan all
    [SW4]int Vlanif 10                                /起到三层交换的作用
    [SW4-Vlanif10]ip address 192.168.1.1 24
    [SW4]int Vlanif 20
    [SW4-Vlanif20]ip address 192.168.2.1 24
    [SW4]int Vlanif 30
    [SW4-Vlanif30]ip address 192.168.3.1 24
    [SW4]int Vlanif 40
    [SW4-Vlanif40]ip address 192.168.4.1 24
    [SW4]int Vlanif 50
    [SW4-Vlanif50]ip address 192.168.5.1 24
    [SW4]int Vlanif 60
    [SW4-Vlanif60]ip address 192.168.6.1 24

    展开全文
  • 华为模拟器(ensp交换机配置vlan

    万次阅读 多人点赞 2016-07-27 20:26:52
    华为模拟器(ensp交换机配置vlan 一、软件信息: 华为ensp v1.2.00.B380 二、配置步骤: 1、打开ensp,按照如图画出拓扑结构 2、pc设置: c1: c2: C3: C4: 3、交换机配置端口类型: 进入sw1写: ...

    华为模拟器(ensp)交换机中配置vlan

    一、软件信息:

    华为ensp v1.2.00.B380

    二、配置步骤:

    1、打开ensp,按照如图画出拓扑结构


    2、pc设置:

    c1:

    c2:

    C3:

    C4:



    3、交换机配置端口类型:

    进入sw1写:

    <Huawei>system-view (回车)

    (新建vlan)

    valn 3 (回车)

    vlan4(回车)

    [Huawei]int g0/0/1(回车)

    [Huawei-GigabitEthernet0/0/1]port link-type access(回车)

    port default vlan 3(端口放到VLAN3)

    接着写:

    [Huawei]int g0/0/2(回车)

    [Huawei-GigabitEthernet0/0/2]port link-type access(回车)

    把0/0/2配置成access端口

    port default vlan 4


    配置交换机之间的线:0/0/3)

    int g0/0/3

    port link-type trunk (把线设置成trunk)

    port trunk allow-pass vlan 3 准许vlan通过trunk

    port trunk allow-pass vlan 4 准许vlan通过trunk



    配置另一个交换机:

    <Huawei>system-view (回车)(进入管理员系统)
    [Huawei]int g0/0/1(回车)

    [Huawei-GigabitEthernet0/0/1]port link-type access(回车)

    port default vlan 3(端口放到VLAN3)

    [Huawei]int g0/0/2(回车)

    [Huawei-GigabitEthernet0/0/2]port link-type access(回车)

    port default vlan 4

    int g0/0/3

    port link-type trunk (把线设置成trunk)

    port trunk allow-pass vlan 3 准许vlan通过trunk

    port trunk allow-pass vlan 4 准许vlan通过trunk

    配置完了

    测试:

    vlan3 的pc有1和3

    vlan4的pc有2和4

    点开pc1 输入

    ping pc3的IP(回车)

    出现这样的就连通了。

    ====================================

    拓展:不同vlan之间通信

    vlan是二层中不能互相通信的,所以我们要经过三层才能相互通信。

    具体设置:

    在任意一个交换机中配置vlan的网关

     int Vlanif 3

    ip add 192.168.3.1 24

    int Vlanif 2

    ip add 192.168.2.1 24

    这样就能不同vlan之间通信了。


    vlan设置IP就像是虚拟端口设置IP











    展开全文
  • 使用eNSP搭建交换机VLAN三层通信

    千次阅读 2019-10-09 14:31:21
    背景:工作需要,自己本身对数通了解有限,遂通过模拟软件进行学习与提升,新人学习,难免有错误,如发现,请指正...第五步:进入交换机,完成交换机配置 注:怎么进去交换机配置界面呢,在工作区交换机右键点击CLI...
  • 如图: 1.首先进入系统视图:system-view 进入后<>变成[ ],当然我这是在华为的ensp模拟器下,实操是需要输入账户和...3.配置vlanif接口的ip地址 int vlan * 进入vlanif接口视图 vlan10网段10,vlan20网段20,...
  • 华为模拟器eNSP防火墙配置vlan实验

    千次阅读 2020-06-07 15:18:09
    首先配置号R1和R2的2接口地址,然后创建vlan,接着把防火墙的接口地址设置成透明交换机接口并加入vlan Trust1-R1: sys un in en sysname Trust1-R1 int e0/0/0 ip address 192.168.7.17 24 dis this quit Trust2-...
  • 1、LSW1交换机配置:创建vlan10和vlan20——连接PC的端口设置为access类型,10网段的PC并入vlan10,20网段的PC并入vlan20——GE0/0/2端口设置为trunk型,允许vlan10 20通过。 2、R1路由器配置: 创建子接口0/0/0.1...
  • ##实验一:三层交换机VLANIF配置# 实验环境 实验思路 1.规划并配置IP 创建VLAN 配置VLANIF接口 向VLAN中加入对应终端 动态配置 检查连通性 具体实施 规划并配置IP PC1: PC2: PC3: PC4: ...
  • 掌握交换机Tag VLAN的配置 掌握三层交换机基本配置方法; 掌握三层交换机VLAN路由的配置方法; 通过三层交换机实现VLAN间相互通信;
  • **eNSP三层交换机不同vlan间通信**一、实验题目二、实验拓扑图三、实验内容四、实验总结 一、实验题目 三台交换机(其中一台交换机为三层交换机),四台PC,实现不同vlan之间的通信。 二、实验拓扑图 实验中使用的...
  • PC1的IP地址192.168.10.1,vlan 10 网关192.168.10.254 PC2的IP地址192.168.20.1,vlan 20 网关192.168.20.254 PC3的IP地址192.168.30.1,vlan 30 网关192.168.30.254 PC4的IP地址192.168.40.1,vlan 40 网关192.168...
  • ensp交换机实验

    2020-12-24 11:27:10
    ensp交换机实验拓扑图DHCP自动配分IP地址 拓扑图 先进行配置两台PC的IP。 然后在打开LSW2进行配置 这里我给交换机和PC1这条线上赋予了一个access接口,然后把vlan 100分配在这个接口。 PC2和上图步骤一致。略… ...
  • eNSP练习:跨交换机vlan划分

    千次阅读 2019-06-20 16:13:28
    交换机划分vlan就是用两台或者多台交换机连接起来进行vlan划分 这次的模拟实验用了 2个服务器+2台交换机+4个PC机 PC1和PC3属于vlan10 PC2和PC4属于vlan20 两台服务器属于vlan30 PC1: 192.168.1.1 PC2: 192....
  • 交换机VLAN配置

    2018-09-09 21:48:45
    交换机VLAN配置,包含具体的超级终端登录教学和配置代码
  • eNSP练习:单交换机划分vlan

    千次阅读 2019-06-20 11:50:22
    ensp上进行的单交换机划分vlan的练习 先把设备接起来,如下图 我给PC1和PC2划分在vlan1中,PC3和PC4划分在vlan2中 PC1:192.168.1.1 PC2:192.168.1.2 PC3:192.168.1.3 PC3:192.168.1.4.子网掩码都是:255....
  • 一、PC机配置 如拓扑图 PC1的IP地址192.168.10.1,vlan 10 网关192.168.10.254 PC2的IP地址192.168.10.2,vlan 10 网关192.168.10.254 PC3的IP地址192.168.20.1,vlan 20 网关192.168.20.254 PC4的IP地址192.168....

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,017
精华内容 806
关键字:

ensp交换机配置vlan