精华内容
下载资源
问答
  • 华为 OSPF

    千次阅读 2019-04-02 15:33:19
    OSPF工作过程 -邻居列表 -链路状态数据库 -路由表 路由分类 内部网关路由协议:RIP OSPF ISIS 外部网关路由协议:BGP 区域ID -十进制数表示 -地址格式表示 骨干区域:area 0 非骨干区域 非骨干区域相互...

    OSPF工作过程
        -邻居列表
        -链路状态数据库
        -路由表
    路由分类
        内部网关路由协议:RIP OSPF ISIS
        外部网关路由协议:BGP
        
    区域ID
        -十进制数表示
        -地址格式表示
        
    骨干区域:area 0
    非骨干区域
    非骨干区域相互通信必须通过骨干区域
    ------
    RID 路由器的身份标识
        --手工指定
        --lopback接口
        --物理接口IP地址最高的
        
    OSPF度量值 cost(开销)

    指定路由器(DR)
        减少设备间链接
    BDR备份指定路由器
        
    DR/BDR选举方法
            自动选择:RID大的选为DR,第二大的选为BDR
            手工选择:默认优先级1;0-255,优先级大的
                      优先级为0,不参与DR和BDR的选举
                      优先级相同,则需要比较Router ID
                      
    组播地址:
        224.0.0.5    所有路由器。
        224.0.0.6    主要路由器、备份主要路由器。

    IPV4 分为5类
        A:1-126        0  127 特殊
        B:128-191
        C:192-223
        D:224-239        组播地址
        E:240-254        255特殊--保留

    OSPF 适应环境
        ---大规模网络
        ---无环网络
        ---支持组播网络
        ---收敛速度快
        ---支持分区域

    OSPF协议号89

    5种数据包类型
        Hello包:维护邻居关系
        数据库描述包DD:向邻居发送摘要信息
        链路状态请求包LSR:请求更详细的信息
        链路状态更新包LSU:
        链路状态确认包:确认收到LSU
    7种邻居状态
        Down
        Init
        2-Way
        ExStart
        Exchange
        Loading
        Full
        
    OSPF 通信量
        内部区域通信
        区域之间通信
        外部通信
        
    OSPF 区域类型
        骨干区域 area 05
            --内部路由器
            --骨干路由器
        非骨干区域
            --内部路由器
            --标准区域
            --stub
            --total stub
            --nssa
            --total nssa
            
            --区域之间路由器 :ABR
            --自制系统边界路由器:ASBR

    链路状态数据库
        由多个LSA()        
        
    路由优先级(管理距离)
        --静态69
        --内部OSPF 10
        
    度量值
        --RIP 跳数
        --OSPF 开销COST

    ospf 1  (ospf 1 router-id 2.2.2.2)
     area 0
      network 192.168.1.0 0.0.0.255
      network 192.168.12.0 0.0.0.255

    display ospf peer brief  查看OSPF邻居表  #显示出来状态必须是:Full


    #骨干
    ospf 1 router-id 1.1.1.1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.3
      network 192.168.2.0 0.0.0.3
    #边界路由
    ospf 1 router-id 2.2.2.2
     area 0.0.0.0
      network 192.168.2.0 0.0.0.3
     area 0.0.0.1
      network 192.168.3.0 0.0.0.3
    #
    ospf 1 router-id 3.3.3.3
     area 0.0.0.1
      network 192.168.3.0 0.0.0.3
      network 192.168.4.0 0.0.0.3
      stub  (1,2,3)
      stub no-summary  (1,2,只存在3类默认路由)
     
    display ospf rou
    display ospf lsdb

    ------------------------------------------------------------------------------------------
    不使用stub和no-summary:

         OSPF Process 1 with Router ID 192.168.2.2
             Link State Database

                     Area: 0.0.0.0
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    192.168.2.2     192.168.2.2        567  36    80000005       1
     Router    192.168.2.1     192.168.2.1        571  36    80000003       1
     Network   192.168.2.2     192.168.2.2        568  32    80000002       0
     Sum-Net   192.168.3.0     192.168.2.2         49  28    80000004       1
     
                     Area: 0.0.0.1
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    192.168.3.2     192.168.3.2          3  36    80000004       1
     Router    192.168.2.2     192.168.2.2          2  36    80000005       1
     Network   192.168.3.2     192.168.3.2          4  32    80000001       0
     Sum-Net   192.168.2.0     192.168.2.2         49  28    80000001       1

    ------------------------------------------------------------------------------------------
    使用stub:

         OSPF Process 1 with Router ID 192.168.2.2
             Link State Database

                     Area: 0.0.0.0
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    192.168.2.2     192.168.2.2        160  36    80000005       1
     Router    192.168.2.1     192.168.2.1        164  36    80000003       1
     Network   192.168.2.2     192.168.2.2        161  32    80000002       0
     Sum-Net   192.168.3.0     192.168.2.2         93  28    80000002       1
     
                     Area: 0.0.0.1
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    192.168.3.2     192.168.3.2         21  36    80000005       1
     Router    192.168.2.2     192.168.2.2         29  36    80000005       1
     Network   192.168.3.2     192.168.3.2         21  32    80000002       0
     Sum-Net   0.0.0.0         192.168.2.2         93  28    80000001       1
     Sum-Net   192.168.2.0     192.168.2.2         93  28    80000001       1

    -------------------------------------------------------------------------------------------
    使用stub no-summary

         OSPF Process 1 with Router ID 192.168.2.2
             Link State Database

                     Area: 0.0.0.0
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    192.168.2.2     192.168.2.2        360  36    80000005       1
     Router    192.168.2.1     192.168.2.1        364  36    80000003       1
     Network   192.168.2.2     192.168.2.2        361  32    80000002       0
     Sum-Net   192.168.3.0     192.168.2.2        129  28    80000003       1
     
                     Area: 0.0.0.1
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    192.168.3.2     192.168.3.2        108  36    8000000A       1
     Router    192.168.2.2     192.168.2.2        104  36    8000000B       1
     Network   192.168.3.1     192.168.2.2        104  32    80000002       0
     Sum-Net   0.0.0.0         192.168.2.2        129  28    80000001       1

     

     

     


    地址汇总:
    ---------------------------------------------------------
    R1
    #
    ospf 1 router-id 1.1.1.1
     area 0.0.0.1
      network 172.16.0.0 0.0.0.255
      network 172.16.1.0 0.0.0.255
      network 172.16.2.0 0.0.0.255
      network 172.16.3.0 0.0.0.255
      network 172.16.4.0 0.0.0.255
      network 172.16.5.0 0.0.0.255
      network 172.16.6.0 0.0.0.255
      network 172.16.7.0 0.0.0.255
      network 172.16.8.0 0.0.0.255
      network 172.16.9.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    ---------------------------------------------------------
    R2
    #
    ospf 1 router-id 2.2.2.2
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
     area 0.0.0.1
      abr-summary 172.16.0.0 255.255.240.0
      network 192.168.1.0 0.0.0.255
    ---------------------------------------------------------
    R3
    #
    ospf 1 router-id 3.3.3.3
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    ---------------------------------------------------------
    R4
    #
    ospf 1 router-id 4.4.4.4
     asbr-summary 10.0.0.0 255.255.224.0
     import-route rip 1
     area 0.0.0.0
      network 192.168.3.0 0.0.0.255
    #
    rip 1
     version 2
     network 192.168.4.0
     import-route ospf 1
    ---------------------------------------------------------
    R5
    #
    rip 1
     version 2
     network 10.0.0.0
     network 192.168.4.0
    ---------------------------------------------------------


     
    reset ospf 1 process 重启OSPF
    display ospf brief
    display ospf vlink


    虚链路:
    vlink-peer 6.6.6.6

     

    展开全文
  • 华为OSPF基本内容。。。
  • 华为OSPF配置

    2012-10-26 22:53:49
    华为OSPFO基本配置。简洁,实用,喜望大家喜欢。
  • 华为ospf链路状态数据库,LSA TYPE 1、LSA TYPE 2、LSA TYPE、3 LSA TYPE、4 LSA TYPE 5;的一些总结。
  • 华为ospf路由配置实例操作
  • 华为OSPF排除命令大全

    2021-02-20 19:18:03
    华为OSPF排除命令大全 display ospf peer //查看 OSPF 邻居的相关信息 display ip routing-table protocol ospf //查看 OSPF 协议路由表 display ospf interface //查看运行 OSPF 协议的接口信息 display ospfv3 ...

    华为OSPF排错命令大全

    display ospf peer //查看 OSPF 邻居的相关信息

    display ip routing-table protocol ospf //查看 OSPF 协议路由表

    display ospf interface //查看运行 OSPF 协议的接口信息

    display ospfv3 peer //查看 OSPFv3 邻居的相关信息

    display ospf vlink //查看虚拟链路信息

    display ospf routing //查看本设备通过 OSPF 协议写到的动态路由

    display ospf peer brief //查看本设备 OSPF 邻居的简略信息(2-way为邻居状态,Full状态为邻接状态)

    display ospf interface GigabitEthernet 0/0/0 //查看接口 GigabitEthernet 0/0/0 的详细信息

    display current-configuration section ospf //查看本设备的 OSPF 配置

    display ospf lsdb //查看本设备的 OSPF 链路状态数据库表

    [AR-1]dis ospf lsdb ?
    lsdb router //查看1类 LSA 的详细信息;路由器 LSA,路由器自身的拓扑信息
    lsdb network //查看2类 LSA;网络 LSA,仅存在 MA-广播网络,MA 网段及成员
    lsdb summary //查看3类 LSA;网络汇总 LSA,域见路由信息
    lsdb asbr //查看4类 LSA;描述域外网关路由信息
    lsdb ase //查看5类 LSA;常规区域传来的域外路由信息
    lsdb nssa //查看7类

    展开全文
  • 华为OSPF配置练习

    千次阅读 2021-03-12 19:07:45
    华为OSPF配置练习一、拓扑以及需求二、所需技术以及简单配置(1)OSPF(2)RIP(3)虚链路(4)重发布三、配置思路(1)打通0域(2)打通RIP域外(3)连接各域1、使用虚链路2、使用双向重发布四、验证(1)连通性...

    一、拓扑以及需求

      某公司核心网络采用OSPF协议来打通,其中R1、2、3、4构成ospf的0域;R9、10采用rip来充当ospf域外路由。具体的区域划分如拓扑所示:
    在这里插入图片描述
    我在各个区域选择一个环回地址充当此区域的用户

    地址规划说明:
    	接口ip:10.200.x.y
    	为验证需要,我在各个区域选择一个环回充当此区域的用户:
    		0域:2.2.2.2
    		1域:5.5.5.5
    		2域:6.6.6.6
    		rip(域外)9.9.9.9
    

    二、所需技术以及简单配置

    (1)OSPF

      开放的最短路径优先协议,首先工作在AS内(内部网关协议,即IGP),流量使用的ip协议号是89,它采用触发更新(增量更新)。部署的时候需要0域(骨干区域),其余所有分支必须与0域直接相连。

    配置:
    [r1]ospf 1 router-id 1.1.1.1   //启动协议,需要配置进程号,具有本地意义,可以选择配置RID,若不配置,则路由器自己选择
    [r1-ospf-1]area 0   //进入区域
    [r1-ospf-1-area-0.0.0.0]network 172.16.1.0 0.0.0.255  //宣告路由或接口
    

    (2)RIP

      RIP是距离矢量协议,它以跳数作为衡量标准(16即为不可达),共有v1和v2两个版本,端口号520、521。同样是内部网关协议工作在AS内,定时更新(30s),且传路由所以不适用于大型网络。

    配置:
    [r1]rip 1    //启动协议时必须配置进程号,仅具有本地意义
    [r1-rip-1]version 1   //选择版本,以版本1为例,版本2同版本1
    [r1-rip-1]network 192.168.1.0    //宣告路由,基于主类范围宣告
    [r1-rip-1]undo summary   //关闭自动汇总
    

    (3)虚链路

      故名思议,虚拟的链路。由于OSPF的其他区域必须与0域相连,由拓扑我们可知2域与0域并不能直接相连,所以在此我们需要虚链路来缝合领域,使它在逻辑上是相连的。

    配置:
    	需要配置在0域和本域的ABR设备上,且虚连接在所跨域中。
    	以本文拓扑为例:需配置在R4和R5设备上,且虚连接存在于1域中。
    R4配置:
    [r4]ospf
    [r4-ospf-1]area 1
    [r4-ospf-1-area-0.0.0.1]vlink-peer 5.5.5.5
    
    R5配置:
    [r5]ospf
    [r5-ospf-1]area 1
    [r5-ospf-1-area-0.0.0.1]vlink-peer 4.4.4.4
    

    (4)重发布

      当两个协议边界相遇时,为了使双方均可学习得对方路由,此时可采取双向重发布来实现。

    配置:
    	配置在ASBR设备中。
    	以本文拓扑为例:需配置R1设备上
    [r1]ospf
    [r1-ospf-1]import-route rip 1 
    [r1]rip
    [r1-rip-1]import-route ospf 1
    
    

    三、配置思路

    (1)打通0域

      在R1、2、3、4设备上起OSPF并宣告接口。

    以R2、R4为例
    	R2配置如下:
    [r2]ospf 1 router-id 1.1.1.1 
    [r2-ospf-1]area 0
    [r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0 //此环回充当此区域的用户
    [r2-ospf-1-area-0.0.0.0]network 10.0.21.0 0.0.0.255 
    [r2-ospf-1-area-0.0.0.0]network 10.0.23.0 0.0.0.255 
    [r2-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255 
    
    	R4配置如下:
    [r4]ospf 1 router-id 4.4.4.4 
    [r4-ospf-1]area 0
    [r4-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255 
    [r4-ospf-1-area-0.0.0.0]area 1 
    [r4-ospf-1-area-0.0.0.1]network 10.200.0.0 0.0.0.255 
    

      其他OSPF域配置均与之相同。
      结果展示:
    在这里插入图片描述

    (2)打通RIP域外

      在R1、9、10三台设备中起RIP协议。

    以R1、R10为例:
    	R1配置如下:
    [r1]rip 1
    [r1-rip-1]undo summary
    [r1-rip-1]version 1
    [r1-rip-1]network 10.0.0.0
    
    	R9配置如下:
    [r1]rip 1
    [r1-rip-1]undo summary
    [r1-rip-1]version 1
    [r1-rip-1]network 10.0.0.0
    [r1-rip-1]network 9.0.0.0  此环回(9.9.9.9)充当此区域的用户
    

    结果展示:
    在这里插入图片描述

    (3)连接各域

    1、使用虚链路

      首先是2域和0域并未直接相连,此时我们需要虚链路来缝合0域。
      配置如下:

    R4配置:
    [r4]ospf
    [r4-ospf-1]area 1
    [r4-ospf-1-area-0.0.0.1]vlink-peer 5.5.5.5
    
    R5配置:
    [r5]ospf
    [r5-ospf-1]area 1
    [r5-ospf-1-area-0.0.0.1]vlink-peer 4.4.4.4
    

    2、使用双向重发布

      为了使RIP和OSPF相互学习得到路由,且全网可达,我们在ASBR设备R1上对此进行双向重发布。
      配置如下:

    R1配置:
    [r1]ospf
    [r1-ospf-1]import-route rip 1 
    [r1]rip
    [r1-rip-1]import-route ospf 1
    
    

      到此即打通了所有域,实现全网可达。我们在0域的R2设备;2域的R6设备;RIP域的R10设备中分别查看它们是否学得我们充当用户的环回路由即可验证。
    R2:
    在这里插入图片描述
    R6:
    在这里插入图片描述
    R10:
    在这里插入图片描述

    四、验证

    (1)连通性验证

      我们验证用户R9-R6;R2-R6;R2-R9:
      R9-R6结果展示:
    在这里插入图片描述

      R2-R6结果展示:
    在这里插入图片描述

      R2-R9结果展示:
    在这里插入图片描述

    五、完整配置

      在这里我们只给出核心的一些设备的全部配置。

    R1

      R1的完整配置如下:

    [r1]display current-configuration 
    [V200R003C00]
    #
     sysname r1
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.21.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.200.19.1 255.255.255.0 
    #
    ospf 1 router-id 2.2.2.2 
     import-route rip 1
     area 0.0.0.0 
      network 10.0.21.0 0.0.0.255 
    #
    rip 1
     undo summary
     version 1
     network 10.0.0.0
     import-route ospf 1
    
    

    R2

      R2的完整配置如下:

    [r2]display current-configuration 
    [V200R003C00]
    #
     sysname r2
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.21.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.0.23.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/2
     ip address 10.0.24.2 255.255.255.0 
    #
    ospf 1 router-id 1.1.1.1 
     area 0.0.0.0 
      network 2.2.2.2 0.0.0.0 
      network 10.0.21.0 0.0.0.255 
      network 10.0.23.0 0.0.0.255 
      network 10.0.24.0 0.0.0.255 
    

    R4

      R1的完整配置如下:

    [r4]display current-configuration
    [V200R003C00]
    #
     sysname r4
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.24.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.200.0.2 255.255.255.0 
    #
    ospf 1 router-id 4.4.4.4 
     area 0.0.0.0 
      network 10.0.24.0 0.0.0.255 
     area 0.0.0.1 
      network 10.200.0.0 0.0.0.255 
      vlink-peer 5.5.5.5
    

    R5

      R1的完整配置如下:

    [r5]display current-configuration 
    [V200R003C00]
    #
     sysname r5
    #
    interface GigabitEthernet0/0/0
     ip address 10.200.0.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.200.1.1 255.255.255.0 
    #
    interface LoopBack0
     ip address 5.5.5.5 255.255.255.255 
    #
    ospf 1 router-id 5.5.5.5 
     area 0.0.0.1 
      network 5.5.5.5 0.0.0.0 
      network 10.200.0.0 0.0.0.255 
      vlink-peer 4.4.4.4
     area 0.0.0.2 
      network 10.200.1.0 0.0.0.255 
    

    R6

      R1的完整配置如下:

    [r6]display current-configuration 
    [V200R003C00]
    #
     sysname r6
    #
    interface GigabitEthernet0/0/0
     ip address 10.200.1.2 255.255.255.0 
    #
    interface LoopBack0
     ip address 6.6.6.6 255.255.255.0 
    #
    ospf 1 router-id 6.6.6.6 
     area 0.0.0.2 
      network 6.6.6.6 0.0.0.0 
      network 10.200.1.0 0.0.0.255 
    

    R9

      R1的完整配置如下:

    [r9]display current-configuration 
    [V200R003C00]
    #
     sysname r9
    #
    interface GigabitEthernet0/0/0
     ip address 10.200.109.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.200.19.2 255.255.255.0 
    #
    interface LoopBack0
     ip address 9.9.9.9 255.255.255.255 
    #
    rip 1
     undo summary
     version 1
     network 10.0.0.0
     network 9.0.0.0
    

      到这里简单的全网可达已经实现了,但是网络中依然存在一些问题,例如:双重发布时学习的子网掩码为8的路由会存在问题,拓扑够大时可能出现环路或者路由黑洞等问题,所以这些问题还需要解决。
      但本文中不再对此进行赘述。

    展开全文
  • 华为OSPF学习实验

    2021-03-15 16:29:01
    华为OSPF学习实验概述网络拓扑图配置和验证验证和连通性测试抓包分析 概述 网络拓扑图 配置和验证 路由器R1配置: ospf 1 router-id 1.1.1.1 area 0.0.0.0 network 192.168.1.0 0.0.0.255 network 200.1.1.0 0.0.0....

    概述

    网络拓扑图

    在这里插入图片描述

    配置和验证

    路由器R1配置:
    ospf 1 router-id 1.1.1.1
    area 0.0.0.0
    network 192.168.1.0 0.0.0.255
    network 200.1.1.0 0.0.0.255

    路由器R2配置:
    ospf 1 router-id 2.2.2.2
    area 0.0.0.0
    network 192.168.2.0 0.0.0.255
    network 200.1.1.0 0.0.0.255
    network 201.1.1.0 0.0.0.255

    路由器R3配置:
    ospf 1 router-id 3.3.3.3
    area 0.0.0.0
    network 10.0.0.0 0.0.0.255
    network 201.1.1.0 0.0.0.255

    更改COST值和密码认证:
    路由器R2上的配置:
    interface GigabitEthernet0/0/1
    ip address 201.1.1.1 255.255.255.252
    ospf cost 10
    ospf authentication-mode md5 1 lgb

    更改密码认证:
    路由器R3上的配置:
    interface GigabitEthernet0/0/0
    ip address 201.1.1.2 255.255.255.252
    traffic-filter inbound acl 2000
    ospf authentication-mode md5 1 lgb

    验证和连通性测试

    cost值:10.0.0.0/24这条路由cost值是12
    在这里插入图片描述

    抓包分析

    在这里插入图片描述

    在这里插入图片描述

    展开全文
  • 华为OSPF小实验

    2020-11-19 14:26:15
    华为OSPF小实验 什么是OSPF 不知道什么是OSPF的,可以看我的另一篇博文(MikroTik ROS软路由OSPF命令配置实例) 先来拓扑 AR1-----AR2 12.1.1.0 24 AR1-----AR3 13.1.1.0 24 AR2-----AR3 23.1.1.0 24 AR1环回口: ...
  • 华为ospf实验配置

    2020-09-25 13:12:05
    华为ospf实验配置 拓扑: 实验要求: 配置ip 配置ospf 配置路由汇总 配置路由重分发 实验步骤: 配置ip: R1: interface GigabitEthernet 0/0/1 ip add 192.168.1.1 255.255.255.0 undo sh interface ...
  • 华为 OSPF链路状态数据库

    千次阅读 2020-02-18 19:39:46
    华为 OSPF链路状态数据库 拓扑 基本配置 描述Type1 2 3LSA的内容及作用 OSPF-LSA总结 以按图所示配置好接口地址,路由协议,R-id,实现全网互通。 AR-3设备 ping 56.1.1.2 89.1.1.2 通 描述Type1 LSA(Router LSA),...
  • 华为 OSPF协议

    千次阅读 多人点赞 2020-02-13 19:37:40
    成功,就是比放弃多坚持了一次。 文章目录 一、拓扑 二、基础配置与状态机测试 三、ospf建立邻居“4+1”条件总结 四、邻居状态和数据包
  • 华为 OSPF特殊区域

    千次阅读 多人点赞 2020-06-01 10:46:02
    (静 稳 忙 忍)!我个人理解为以下意思: 静:静的一半需要“争”;稳:稳的一半需要“急”,这里的急是指行动上;忙:忙的一半是不能急躁,做事要脚踏...一、概括 二、拓扑 三、配置与分析 四、总结 五、OSPF特殊区域
  • 华为 OSPF与RIP重分布

    千次阅读 多人点赞 2020-02-18 23:05:44
    华为 OSPF与RIP重分布 拓扑 设备AR-1基本配置: sys [Huawei]sysname AR-1 [AR-1]int g0/0/0 [AR-1-GigabitEthernet0/0/0]ip add 12.1.1.1 24 [AR-1-GigabitEthernet0/0/0]quit [AR-1]rip 1 [AR-1-rip-1]undo ...
  • 华为OSPF总结

    2018-07-16 10:24:35
    OSPF把自治系统划分成逻辑意义上的一个或多个区域,所有其他区域必须与区域0相连。 OSPF把自治系统划分成逻辑意义上的一个或多个区域,所有其他区域必须与区域0相连。
  • 华为 OSPF基本概念与基础配置

    万次阅读 多人点赞 2020-05-19 17:48:37
    在战胜敌人之前,先战胜自己。 文章目录 一、拓扑 ...OSPF 是一种应用非常广泛发基于链路状态的动态路由协议,它具有区域(Area)化的层次结构,扩展性好,收敛速度快,适合部署在各种规模的网络上。
  • 华为OSPF多区域简单配置

    千次阅读 2019-09-08 15:21:19
    华为OSPF多区域简单配置 在ospf中固定了所有非area 0区域必须与area 0区域直连,否则无法工作。所以当有非area0区域没有与area0区域直连时,就需要使用虚链路让区域与area0区域在逻辑上直连。 骨干区域与非骨干区域...
  • 华为 OSPF邻居建立的过程

    千次阅读 多人点赞 2021-01-14 11:38:51
    OSPF状态机的详解。接口使能之后,发出第一份 hello 报文的时候就开始计时,40S之内不会认为自己是DR。如果40S超时之后,还是没有收到携带DR、BDR参数字段的Hello报文,就认为自己是DR。
  • 华为ospf与思科ospf对比

    千次阅读 2019-06-08 16:42:55
    1.ospf对比:1)华为ospf基本配置:系统试图:设置router-id:router id 路由器id系统试图:进入ospf配置试图:ospf进入区域配置试图:area 区域编号将接口网段加入ospf:network 网段 反码返回用户试图:return2...
  • 华为OSPF 多区域配置

    2018-01-17 13:08:46
    实验名称:华为OSPF 多区域配置 实验拓扑: 所需设备:4台路由器 AR1 AR2 AR3 AR4 地址规划:AR1 G0/0/1 IP 192.168.1.1/24 AR1 LoopBack 1 IP 10.10.10.1/24 (回环口地址) AR2 G0/0/0 IP 192.168.1.2/24 AR2 ...
  • 华为 OSPF 简介

    2015-06-03 12:04:06
    OSPF是一个基于链路状态的内部网关协议,目前针对IPv4协议使用的是OSPFv2。 OSPF是IETF组织开发的一个基于链路状态的内部网关协议。
  • 华为ospf知识点整理(HCIA): 1.ospf出现的原因: RIP协议有着最大条数(max=15跳)的限制,无法适应适应网络的扩展和丰富性。 2.ospf的优势: (1)无环路(利用SPF算法保证ospf协议无环) (2)收敛快,触发更新...
  • 华为OSPF详解及配置

    万次阅读 多人点赞 2020-04-15 02:13:23
    OSPF:开放式最短路径优先协议 目录 OSPF:开放式最短路径优先协议 一、数据包—5种基本数据包 二、OSPF的状态机 三、OSPF的工作过程 四、区域划分规则: 五、数据包 六、各类LSA: 七.OSPF 邻居状态机制 ...
  • 华为ospf综合实验(认证+缺省路由)个人笔记 ————————————————————————————— 第一步:把R1、2、3、6,主机名、IP、ospf这些基础配好 R1: sys sys R1 int g0/0/0 ip add 192.168.0.1 ...
  • 华为OSPF总结.docx

    2020-02-08 06:44:35
    OSPF整体拓扑 OSPF把自治系统划分成逻辑意义上的一个或多个区域,所有其他区域必须与区域0相连。 路由器类型 区域内路由器(Internal Router):该类设备的所有接口都属于同一个OSPF区域。 区域边界路由器...
  • 华为ospf配置

    2019-11-28 21:52:16
    NBMA网络配置OSPF 1.NBMA网络 2.ospf进程下配置 (peer 对端接口地址) [R5]int g0/0/0 [R5-GigabitEthernet0/0/0]ip address 56.0.0.5 24 [R5-GigabitEthernet0/0/0]ospf network-type nbma //设置网络类型nbma [R5-...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,317
精华内容 526
关键字:

华为ospf