精华内容
下载资源
问答
  • 华为VLAN隔离配置

    2021-01-07 08:11:43
    华为VLAN隔离配置 方法1:通过vlan ACL 包过滤 (这个最简单) [Huawei]acl 3000 [Huawei-acl-adv-3000]rule 5 deny ip source 192.168.10.0 0.0.0.255 destination 192.168.20.0 0.0.0.255 [Huawei-acl-adv-3000]...
  • 华为VLAN配置.rar

    2009-05-31 19:28:54
    华为VLAN配置 华为VLAN配置 华为VLAN配置 华为VLAN配置 通用路由平台 VRP 操作手册
  • 华为vlan技术白皮书

    2010-09-15 09:07:24
    华为vlan技术白皮书,基本VLAN介绍
  • 华为Vlan技术原理

    2011-03-04 11:02:40
    华为Vlan技术原理,很通俗的讲解了vlan的原理,内附演示文稿版本
  • 计算机网络 华为 vlan-mapping

    创作不易,记得点赞哦 

    目录

    1.什么是vlan-mapping? 

    1.2 vlan-mapping中所运用到的技术

    2.eNSP实验

    2.1 vlan一层转换实验

    2.2  隔离组实验

    3.镜像技术的应用

    3.1 镜像技术的由来

    3.2 镜像概述

     3.3 eNSP镜像配置实验

    3.3.1 简单的镜像配置实验

    3.3.2 配置远程观察端口实验

     3.3.3 配置基于MQC的本地镜像

    3.3.4配置基于acl的本地镜像流 

    4.端口安全

    4.1端口安全类型: 

    4.2端口安全配置实现实验


    1.什么是vlan-mapping? 

    VLAN Mapping也叫做VLAN translation,可以实现在用户VLAN ID(私有VLAN)和运营商VLAN ID(业务VLAN,也被叫做公有VLAN)之间相互转换的一个功能。 

    例子:

    比如当在交换机端口上配置了VLAN 100和VLAN10的映射后,端口在向外发送VLAN100的帧时,将帧中的VLAN Tag替换成VLAN10的VLAN Tag;在接收VLAN 10 的帧时,将帧中的VLAN Tag替换成VLAN100的VLAN Tag,这样VLAN100和VLAN10就实现了互相通信。

    1.2 vlan-mapping中所运用到的技术

    端口隔离: 

    端口隔离是交换机端口之间的一种访问安全控制机制。 

    实现不同端口接入的PC之间不能互访(PC属于相同的VLAN),而所有的PC都能够通过上行的交换机访问网络。 可以配置VLAN内的用户间的相互隔离或者互通。

    命令行:

    配置隔离组

    port-isolate mode all-----全局使能隔离模式

    interface GigabitEthernet0/0/1   //在端口下配置相应的VLAN

    port link-type access

    port default vlan 3

    port-isolate enable group 1-----属于相同组不能互通,未被隔离和隔离的端口可以互通,不同组可以互通  

    配置观察端口

    observe-port interface Ethernet0/0/1 //配置为被观察的端口

    interface Ethernet0/0/2 

    mirror to observe-port inbound  //将被观察端口的入方向的操作作为镜像输出到该端口

    interface Ethernet0/0/3

    mirror to observe-port outbound  //将被观察端口的出方向的操作作为镜像输出到该端口

    配置ACL来匹配镜像观察端口

    observe-port interface Ethernet0/0/1

    acl  number 2000  //一个ACL的固定模式

    rule 5 permit source 192.168,3,10  0 //允许IP地址为192.168.3.10 的IP地址通过,IP地址后的配置为反掩码

    traffic classifier c1 operator or if-match acl 2000   //配置流类型为c1或者匹配acl 2000的规则

    traffic behavior b1 mirror to  observe-port //配置行为类型为b1,并且作为被观察端口的镜像

    traffic policy d1 classifier c1 behavior b1 //配置策略类型为d1,并且绑定流行为c1和行为类型b1

    配置观察端口

    interface Ethernet1/0/1

    traffic-policy d1 inbound  //将该端口配置为Ethernet0/0/1端口的观察端口,并且配置的策略为d1

    2.eNSP实验

    2.1 vlan一层转换实验

    拓扑图:下面各交换机端口参照下一个拓扑图

    实验目的:PC1与PC3处于vlan10,PC2与PC4处于vlan20,终端通过Internet来进行通信,Internet内部有自己的内部VLAN进行通信,本实验就是实现进入Internet之前实现vlan转换。 vlan内部可以通信,同一vlan内的终端可以共享同一网段 

    PC1配置

    PC2配置

     

    PC3配置

    PC4配置

     

     SW1配置

    sysname SW1
    #
    vlan batch 10 20
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
     

    SW2配置

    #
    sysname SW2
    #
    vlan batch 10 20
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 20
     

    SW3配置

    #
    sysname SW3
    #
    vlan batch 100

    vlan batch 200
    #

    interface GigabitEthernet0/0/1
     qinq vlan-translation enable
     port link-type trunk
     port trunk allow-pass vlan 100

     port trunk allow-pass vlan 200
     port vlan-mapping vlan 10 map-vlan 100
     port vlan-mapping vlan 20 map-vlan 200
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100

     port trunk allow-pass vlan 200
    #

    SW4配置

    #
    sysname SW4
    #
    vlan batch 100

    vlan batch 200
    #
    interface GigabitEthernet0/0/1
     qinq vlan-translation enable
     port link-type trunk
     port trunk allow-pass vlan 100

     port trunk allow-pass vlan 200

     port vlan-mapping vlan 10 map-vlan 100
     port vlan-mapping vlan 20 map-vlan 200
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100

     port trunk allow-pass vlan 200
    #

    效果图:

    port-isolate的模式:三层

    ALL:在同一个组中的端口之间不能进行2、3层互通

    L2:在同一个组中的端口之间不能进行2层互通,但是可以进行3层互通

    注:在同一个隔离组中的端口之间不能互通,但是可以和其它组的端口或者没加组的端口间互通

    2.2  隔离组实验

    拓扑图:

    实验目的:PC1与PC5处于同一个VLAN,同一个隔离组,但是相互不能通信

    port-isolate mode l2
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 10
     port-isolate enable group 1
    #
     

    3.镜像技术的应用

    3.1 镜像技术的由来

    在网络维护的过程中会遇到需要对报文进行获取和分析的情况,比如怀疑有攻击报文,此时需要在不影响报文转发的情况下,对报文进行获取和分析。

    镜像技术可以在不影响报文正常处理流程的情况下,将镜像端口的报文复制一份到观察端口,用户利用数据监控设备来分析复制到观察端口的报文,进行网络监控和故障排除。 

    镜像技术是为了进行数据采集,从而分析数据来达到科学合理的管控网络中的内容的效果。

    3.2 镜像概述

    镜像定义:将镜像端口(源端口)的报文复制一份到观察端口(目的端口)

    镜像作用 :获取完整报文用于分析网络状况

    镜像优点:①不影响原有网络,快捷方便 ②采集的是实时数据流,真实可靠

     3.3 eNSP镜像配置实验

    3.3.1 简单的镜像配置实验

    拓扑图:

    实验目的:配置一个镜像端口和多个观察端口,利用观察端口来监视镜像端口的流量数据

    实验一:配置一对一,即一个镜像端口对一个观察端口 

    第一步:配置观察端口

    #
    observe-port 1 interface GigabitEthernet0/0/1
    #
    第二步:配置镜像端口

    #
    interface GigabitEthernet0/0/4
     port-mirroring to observe-port 1 inbound
    #
    第三步:验证配置结果

    [SWITCH]dis observe-port
      ----------------------------------------------------------------------
      Index    : 1
      Interface: GigabitEthernet0/0/1
      Used     : 1
      ----------------------------------------------------------------------

    实验二:配置多对一,即多个镜像端口对一个观察端口

    第一步:配置观察端口

    #
    observe-port 1 interface GigabitEthernet0/0/1
    #

    第二步:配置镜像端口

    #
    interface GigabitEthernet0/0/4
     port-mirroring to observe-port 1 inbound
    #

    #
    interface GigabitEthernet0/0/3
     port-mirroring to observe-port 1 inbound
    #
    return

    3.3.2 配置远程观察端口实验

    拓扑图:

    实验目的:SW1的g/0/0/1口为镜像口,g/0/0/3为观察口,将观察口接收到的报文转发给远程在vlan10 的终端,即PC8

    SW1配置:
     

     #
    observe-port 1 interface GigabitEthernet0/0/3 vlan 10  //配置观察端口接收到的镜像报文像vlan10转发,不需要在观察端口下进行接口加入vlan的操作
    #

    #
    interface GigabitEthernet0/0/1
     port-mirroring to observe-port 1 inbound  //配置该镜像端口发送该端口入方向的报文复制一份到观察端口
    #
     

    SW2配置

    #
    vlan batch 10   //创建vlan10
    #
    #
    interface GigabitEthernet0/0/1   //将接口接入vlan10
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
     

     3.3.3 配置基于MQC的本地镜像

     拓扑图:

    SW1配置

    #
    observe-port 1 interface GigabitEthernet0/0/3
    #
    #
    acl number 3000
     rule 5 permit tcp source 192.168.1.0 0.0.0.255 destination-port eq www
    acl number 3001
     rule 5 permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255
    #
    traffic classifier b1 operator or
     if-match acl 3000
     if-match acl 3001
    #
    #
    traffic behavior c1
     mirroring to observe-port 1
    #
    #
    traffic policy p1
     classifier b1 behavior c1
    #

    #
    interface GigabitEthernet0/0/1
     traffic-policy p1 inbound
     port-mirroring to observe-port 1 inbound
    #
     

    3.3.4配置基于acl的本地镜像流 

    4.端口安全

    在对接入用户的安全性要求较高的网络中,可以配置端口安全功能,将接口学习到的MAC地址转换我诶安全MAC地址,接口学习的最大MAC数量达到上限后不再学习新的MAC地址,只允许学习到MAC地址的设备通信,这样可以阻止其他非信任用户通过本接口和交换机通信,提高设备与网络的安全性。

    4.1端口安全类型: 

    端口安全(Port Security)通过将接口学习到的动态MAC地址转换为安全MAC地址(包括安全动态MAC、安全静态MAC和Sticky MAC )阻止非法用户通过本接口和交换机通信,从而增强设备的安全性。

    类型定义特点
    安全动态MAC地址使能端口安全而未能使Sticky MAC功能时转换的MAC地址设备重启后表项会丢失,需要重新学习。缺省情况下不会被老化,只有在配置安全MAC的老化时间后才可以被老化
    安全静态MAC地址使能端口安全时手工配置的静态MAC地址不会被老化,手动保存配置后重启设备不会丢失
    Sticky MAC地址使能端口安全后又同时使能Sticky MAC功能后转换得到的MAC地址不会被老化,手动保存配置后重启设备不会丢失

    端口安全:

    说明:接口使能端口安全功能时,接口上之前学习到的动态MAC地址表项将被删除,之后学习到的MAC地址将变为安全动态MAC地址。 

    接口使能Sticky MAC功能时,接口上的安全动态MAC地址表项将转化为Sticky MAC地址,之后学习到的MAC地址也变为Sticky MAC地址

    接口去使能端口安全功能时,接口上的安全动态MAC地址将被删除,重新学习动态MAC地址

    接口去使能Sticky MAC功能时,接口上的Sticky MAC地址会转换为安全动态MAC地址

    端口安全限制动作 

    超过安全MAC地址限制数后的动作

    动作实现说明

    Restrict

    (限制)

    丢弃源MAC地址不存在的报文并上。推荐使用restrict动作报告警

    Protect

    (保护 )

    只丢弃源MAC地址不存在的报文,不上报告警
    shutdown(关闭)接口状态被置为error-down,并上报告警。默认情况下,接口关闭后不会自动恢复,只能由网络管理人员在接口视图下使用restart命令重启接口进行恢复

    接口上安全MAC地址数达到限制后,如果收到源MAC地址不存在的报文,端口安全则认为有非法用户攻击,就会根据配置的动作对接口做保护处理。缺省情况下,保护动作是restrict。 

    4.2端口安全配置实现实验

     网络端口安全,比如封闭的园区网络要求保障接入用户的安全性。财务部人员流动性较低,可以使用端口安全技术静态的绑定接入用户的MAC与VLAN信息;市场部的人员流动性较高,使用端口安全技术的动态MAC地址学习保证接入用户的合法性。

    [SW2-GigabitEthernet0/0/1]dis this
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
     port-security enable   //开启端口安全
     port-security protect-action shutdown   //配置违规后的动作为shutdown
     port-security max-mac-num 5  //接口下可以学习的MAC地址数量为5条
     port-security mac-address sticky  //MAC地址学习的方式为粘贴
    #
    return
     

     

    [SW2-GigabitEthernet0/0/1]port-security aging-time 15 type ?
      absolute    Absolute time  //绝对时间,MAC地址绑定时间到期后会被清除
      inactivity  Inactivity time  //不活动时间,绑定的MAC地址在规定时间内没有发送数据帧,绑定关系会被清除
     

    展开全文
  • 华为vlan配置

    万次阅读 多人点赞 2018-06-11 21:50:15
    一、实现同个vlan,不同网段的主机互通1、拓扑图2、案例LSW1交换机配置1)任意创建vlan,这里演示vlan100[Huawei]vlan 1002)进入vlan100配置IP,注意第二个IP后面加sub[Huawei]interface Vlanif 100 [Huawei-Vlanif...

    介绍

    本实验全部使用华为模拟器eNSP进行完成。

    一、实现同个vlan,不同网段的主机互通

    1、拓扑图


    2、案例LSW1交换机配置
    1)任意创建vlan,这里演示vlan100
    [Huawei]vlan  100
    2)进入vlan100配置IP,注意第二个IP后面加sub
    [Huawei]interface  Vlanif  100
    [Huawei-Vlanif100]ip address  192.168.1.254 24	
    [Huawei-Vlanif100]ip address  192.168.2.254 24 sub 
    3)配置PC所连的交换机接口为vlan100,实现通信
    [Huawei]interface  GigabitEthernet  0/0/2
    [Huawei-GigabitEthernet0/0/2]port link-type access 	
    [Huawei-GigabitEthernet0/0/2]port default vlan 100
    [Huawei]interface  GigabitEthernet  0/0/3
    [Huawei-GigabitEthernet0/0/3]port link-type access 
    [Huawei-GigabitEthernet0/0/3]port default vlan  100
    3、测试192.168.1.1 ping 192.168.2.1通信正常


    二、不同vlan的主机二层互通(hybrid端口应用)

    1、拓扑图


    2、hybrid端口配置介绍


    3、案例配置
    1)LSW1划分vlan,加入端口。
    [LSW1]vlan  10
    [LSW1]interface  GigabitEthernet  0/0/2
    [LSW1-GigabitEthernet0/0/2]port link-type access	
    [LSW1-GigabitEthernet0/0/2]port default vlan 10
    2)LSW2同理
    [LSW2]vlan  100
    [LSW2]interface  GigabitEthernet  0/0/2
    [LSW2-GigabitEthernet0/0/2]port link-type access
    [LSW2-GigabitEthernet0/0/2]port default  vlan  100
    3)LSW1配置hybrid接口,数据包出交换机的时候移除标签后再转发,当接收对端发送过来的数据包就打上默认PVID号。
    [LSW1]interface  GigabitEthernet  0/0/1
    [LSW1-GigabitEthernet0/0/1]port link-type hybrid
    [LSW1-GigabitEthernet0/0/1]port hybrid  pvid vlan 10
    [LSW1-GigabitEthernet0/0/1]port hybrid untagged vlan 10
    4)LSW2同理
    [LSW2]interface  GigabitEthernet  0/0/1
    [LSW2-GigabitEthernet0/0/1]port link-type  hybrid
    [LSW2-GigabitEthernet0/0/1]port hybrid pvid vlan  100
    [LSW2-GigabitEthernet0/0/1]port hybrid untagged vlan 100
    4、测试192.168.1.2 ping  192.168.1.1,通信正常。




    展开全文
  • 华为VLAN培训

    2014-08-30 18:51:30
    华为内部vlan技术培训,轻松易懂,助你一臂之力,知识重要的是分享
  • 华为vlan的多种划分方式

    千次阅读 2019-09-06 02:19:34
    华为vlan的多种划分方式VLAN概念VLAN划分的方法实验拓扑:实验的目的初始化交换机配置【VLAN,以及VLAN接口跟DHCP】插入链接与图片如何插入一段漂亮的代码片生成一个适合你的列表创建一个表格设定内容居中、居左、居...

    一、VLAN概念

    VLAN(Virtual Local Area Network)的中文名为“虚拟局域网”。虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点:网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。

    二、VLAN划分的方法

    • 基于接口的划分方式:就是根据以太网交换机的交换端口来划分的,将VLAN交换机上的物理端口划分到对应的VLAN内,固定在这个VLAN下了。
    • 基于MAC地址划分VLAN:是根据每个主机的MAC地址来划分,当该接口收到一个源MAC为匹配的,就动态划分到对应的VLAN内。
    • 基于IP组播形式划分VLAN:它只看用户的IP子网形式,认为一个IP组播网就是一个vlan,比如规定一个192.168.1.0/24的网段划分到VLAN 20,那么配置了该网段的PC连接的接口就会动态划分到VLAN 20。
    • 基于网络层协议划分:这种比较特殊,可分为IP、IPX、DECnet、AppleTalk、Banyan等VLAN网络。这种按网络层协议来组成的VLAN,用的比较少。
    • 基于策略的方式划分VLAN:这种类似IP与MAC绑定,它匹配IP跟MAC或者是IP MAC跟端口都匹配才划分到对应的VLAN。

    三、 实验拓扑:

    在这里插入图片描述
    这里5台PC,分别对应5个VLAN,每一个VLAN用一种划分的方式来演示,VLAN 10用基于接口的方式,VLAN 20用基于MAC、VLAN 30用基于IP组播、VLAN 40用基于网络层协议、VLAN 50基于策略。

    四、实验的目的

    • 交换机初始化【配置VLAN,以及VLAN接口跟DHCP】
    • 基于接口的方式划分 【最常用】
    • 基于MAC的方式划分 【有些环境比较常用】
    • 基于IP组播的方式划分
    • 基于网络层协议的方式划分
    • 基于策略的方式划分【IP+MAC绑定】

    五、初始化交换机配置【VLAN,以及VLAN接口跟DHCP】

    创建相应的vlan:在这里插入图片描述

    开启DHCP服务:
    在这里插入图片描述

    创建VLNA接口,并且在对应的VLAN开启DHCP功能:

    在这里插入图片描述
    【说明:这里只在VLAN 10与20下启用了DHCP功能,因为这2种方式可以用DHCP,也推荐用,而剩下的3种比较适合静态IP的方式,VLAN接口是用来给下面PC作为网关的,在这里测试用。】

    六、基于接口方式划分:

    拓扑:
    在这里插入图片描述
    VLAN 10采用基于接口的方式来划分,这里用E0/0/1,注意华为的默认为hybrid端口,这种端口比较特殊,跟trunk一样支持对多VLAN 打标记,也可以去掉标记,默认也属于VLAN 1,这里我们改为常见的Access接口
    在这里插入图片描述
    说明:把接口改为Access类型,然后划分到Vlan10里面。

    测试:

    在这里插入图片描述
    在这里插入图片描述
    可以看到通过DHCP获取到了对应VLAN 10的分配地址,而且能与VLAN 10的网关通信。

    七、基于MAC的方式划分:

    在这里插入图片描述
    说明:基于MAC的方式划分VLAN,它主要根据主机的源MAC来划分对应的VLAN,比如当主机请求DHCP的时候,交换机会通过接口学习到对应的主机源MAC,然后根据接口配置的划分方式,然后对应的划入指定的VLAN,然后获取对应的IP。

    在这里插入图片描述
    可以看到该主机的对应MAC是红色部分。
    在这里插入图片描述
    【在VLAN 20里面添加对应的MAC地址】
    在这里插入图片描述
    【这里给VLAN 20不打Tag,而且开启mac-vlan 功能,注意这里PVID还是VLAN1,也就是说属于VLAN 1,只是对应VLAN 20的去掉标记。】

    测试:

    在这里插入图片描述
    可以看到获取到了对应的VLAN 20的地址,而且能访问网关。
    在这里插入图片描述
    在这里插入图片描述
    说明下,这里把MAC地址修改了下,在测试。
    在这里插入图片描述
    可以看到这里找不到对应的DHCP服务器,因为它不匹配任VLAN内的MAC地址,所以这里只能按接口默认的来划分,也就是VLAN 1,但是VLAN 1并没有配置VLAN接口,更没DHCP启用,所以获取不到地址。
    在这里插入图片描述
    在这里插入图片描述

    八、基于IP组播方式划分:

    在这里插入图片描述
    基于子网的方式比较简单,就是配置了对应的子网的主机划入到对应的VLAN。
    在这里插入图片描述
    【在对应VLAN下定义要划入这个VLAN的IP地址,然后在定义的接口下启用该子网功能。】
    为PC3设置静态IP:
    在这里插入图片描述
    测试:
    在这里插入图片描述
    可以看到访问没任何问题。

    九、基于网络层协议划分【最不常用】:

    在这里插入图片描述
    基于协议的方式,它主要通过协议来区分,比如某个PC用IPV4,而另外的就是IPV6,然后通过这样来区分划分到不同的VLAN。
    在这里插入图片描述
    说明下:基于协议的,模拟器测试没效果,所以这里也没办法演示,只能给出配置命名了。

    十、基于策略的方式划分:

    在这里插入图片描述
    基于策略的划分,它非常类似IP跟MAC或者IP MAC跟端口绑定
    在这里插入图片描述
    可以看到该PC对应的IP与MAC是红色部分标记的。
    在这里插入图片描述
    【说明,这里配置顺序必须先把接口对于收到VLAN 50的去掉标记,然后在VLAN 50下,可以绑定MAC,IP以及端口号,端口号为可选。】

    测试:
    在这里插入图片描述
    可以看到可以直接Ping通了。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    可以看到,把IP或者MAC任何改变一下就不能通信了,这种方式比较适合要做IP与MAC绑定的。

    总结:

    华为 的VLAN划分方式比思科的要多很多,也灵活很多,平时肯定用基于接口的最多,但是遇到特殊情况,比如希望通过MAC动态的来划分到对应VLAN,或者最后一种策略VLAN可以实现IP+MAC的绑定都是非常不错的,至于基于协议跟子网的类型方式,这个一般很少见。

    在这里插入图片描述

    展开全文
  • 华为vlan实验

    千次阅读 2020-05-16 21:43:24
    untagged VLAN 4 5 , tagged vlan 2 3。相当于把vlan 45 在这儿换成 vlan3。 1、交换机和pc间的vlan接口模式 SW1 [sw1]vlan batch 2 to 5 [sw1]int GigabitEthernet 0/0/3 [sw1-GigabitEthernet0/0/3]port link-type...

    在这里插入图片描述在SW1的g0/0/1 和 SW2的g0/0/2 接口上配置混杂模式,pvid为3,
    untagged VLAN 4 5 , tagged vlan 2 3。相当于把vlan 45 在这儿换成 vlan3。

    1、交换机和pc间的vlan接口模式
    SW1
    [sw1]vlan batch 2 to 5
    [sw1]int GigabitEthernet 0/0/3
    [sw1-GigabitEthernet0/0/3]port link-type access
    [sw1-GigabitEthernet0/0/3]port default vlan 2
    [sw1]int GigabitEthernet 0/0/4
    [sw1-GigabitEthernet0/0/4]port hybrid pvid vlan 3
    [sw1-GigabitEthernet0/0/4]port hybrid untagged vlan 2 to 5
    SW2
    [sw2]vlan batch 2 to 5
    [sw2]int GigabitEthernet 0/0/3
    [sw2-GigabitEthernet0/0/3]port link-type access
    [sw2-GigabitEthernet0/0/3]port default vlan 2
    [sw2]int g
    [sw2]int GigabitEthernet 0/0/4
    [sw2-GigabitEthernet0/0/4]port hybrid pvid vlan 4
    [sw2-GigabitEthernet0/0/4]port hybrid untagged vlan 2 to 4
    SW3
    [sw3]vlan batch 2 to 5
    [sw3]int GigabitEthernet 0/0/3
    [sw3-GigabitEthernet0/0/3]port hybrid pvid vlan 4
    [sw3-GigabitEthernet0/0/3]port hybrid untagged vlan 2 to 5
    [sw3]int g
    [sw3]int GigabitEthernet 0/0/4
    [sw3-GigabitEthernet0/0/4]port hybrid pvid vlan 5
    [sw3-GigabitEthernet0/0/4]port hybrid untagged vlan 2 3 5
    2、交换机之间的vlan接口模式
    SW1
    [sw1]int GigabitEthernet 0/0/1
    [sw1-GigabitEthernet0/0/1]port hy
    [sw1-GigabitEthernet0/0/1]port hybrid pvid vlan 3
    [sw1-GigabitEthernet0/0/1]port hybrid untagged vlan 4 5
    [sw1-GigabitEthernet0/0/1]port hybrid tagged vlan 2 3
    SW2
    [sw2]int GigabitEthernet 0/0/2
    [sw2-GigabitEthernet0/0/2]port hybrid pvid vlan 3
    [sw2-GigabitEthernet0/0/2]port hybrid untagged vlan 4 5
    [sw2-GigabitEthernet0/0/2]port hybrid tagged vlan 2 3
    [sw2]int GigabitEthernet 0/0/1
    [sw2-GigabitEthernet0/0/1]port link-type trunk
    [sw2-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 5
    SW3
    [sw3]int GigabitEthernet 0/0/2
    [sw3-GigabitEthernet0/0/2]port link-type trunk
    [sw3-GigabitEthernet0/0/2]port trunk allow-pass vlan 2 to 5
    3、sw1和R1
    SW1
    [sw1]int GigabitEthernet 0/0/2
    [sw1-GigabitEthernet0/0/2]port link-type trunk
    [sw1-GigabitEthernet0/0/2]port trunk allow-pass vlan 2 3
    R1
    单臂路由
    [r1]int GigabitEthernet 0/0/1.1
    [r1-GigabitEthernet0/0/1.1]dot1q termination vid 2
    [r1-GigabitEthernet0/0/1.1]ip address 192.168.2.10 24
    [r1-GigabitEthernet0/0/1.1]arp broadcast enable
    [r1]int GigabitEthernet 0/0/1.2
    [r1-GigabitEthernet0/0/1.2]dot1q termination vid 3
    [r1-GigabitEthernet0/0/1.2]ip address 192.168.3.10 24
    [r1-GigabitEthernet0/0/1.2]arp broadcast enable
    DHCP
    [r1]int GigabitEthernet 0/0/1.1
    [r1-GigabitEthernet0/0/1.1]dhcp select global
    [r1]ip pool v2
    Info: It’s successful to create an IP address pool.
    [r1-ip-pool-v2]gateway-list 192.168.2.10
    [r1-ip-pool-v2]network 192.168.2.0 mask 255.255.255.0
    [r1-ip-pool-v2]dns-list 114.114.114.114
    [r1-ip-pool-v2]lease day 10
    [r1-ip-pool-v2]q
    [r1]int g
    [r1]int GigabitEthernet 0/0/1.2
    [r1-GigabitEthernet0/0/1.2]dhcp select global
    [r1]ip pool v3
    Info: It’s successful to create an IP address pool.
    [r1-ip-pool-v3]gateway-list 192.168.3.10
    [r1-ip-pool-v3]network 192.168.3.0 mask 255.255.255.0
    [r1-ip-pool-v3]dns-list 114.114.114.114
    [r1-ip-pool-v3]lease day 10
    4、测试
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    pc2可以访问pc4/5/6
    在这里插入图片描述
    在这里插入图片描述
    pc4可以访问pc5
    在这里插入图片描述
    pc4、pc5不能访问pc6
    在这里插入图片描述
    在这里插入图片描述
    pc1/3可以正常访问pc2/4/5/6
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 华为VLAN实现防火墙

    2012-12-02 23:09:28
    配置说明:使用4台PC,华为路由器(R2621)、交换机(S3026e)各一台,组建一VLAN,实现虚拟网和物理网之间的连接。实现防火墙策略,和访问控制(ACL)。
  • 了解华为VLAN配置

    2021-01-15 21:06:19
    文章目录前言VLAN配置思路1 交换机上创建vlan2 交换机上的各个接口划分到对应的vlan中3 trunk干道—中继干道4 VLAN间路由例例:关于华为设备vlan接口的类型问题access:只能允许一个vlan进或出;trunk :可以允许多...
  • 华为vlan技术基础

    千次阅读 2017-10-10 09:49:49
    vlan有动态vlan和静态vlan之分,具体划分如下 静态vlan:基于端口 动态vlan:基于MAC地址、基于子网、基于协议、基于策略。 通过静态vlan划分和动态vlan划分出来的vlan都属于静态vlan,通过GVRP协议动态注册的vlan...
  • 华为hcie认证体系里500字描述华为VLAN聚合工作原理 你看懂了吗? 工作原理如下: 和普通VLAN都有一个三层逻辑接口和若干物理接口,VLAN聚合定义的Super-VLAN和Sub-VLAN比较特殊: Sub-VLAN:只包含物理接口,...
  • 华为VLAN的应用

    2020-11-02 15:17:08
    VLAN分割广播域 1.物理分割(通过路由器来分割,相当于跨网段分割) 2.逻辑分割(通过软件来分割,使用最为广泛,也被称为VLANVLAN的优势 1.控制广播(防止交换机接口同时广播造成网络风波) 2.增强网络安全性...
  • 华为vlan简单配置

    2021-01-29 12:45:56
    相同vlan可实现通信,不同vlan不可通信 sw1 interface GigabitEthernet0/0/1 port link-type access port default vlan 10 # interface GigabitEthernet0/0/2 port link-type access port default vlan 20 # ...
  • 华为VLAN技术原理

    2011-01-10 16:44:17
    关于学习VLAN的材料,对于学习VALN,特别是华为的,应该有很大的帮助!!!
  • 一招让你懂华为VLAN

    2021-07-19 13:10:39
    华为思科在vlan思路上的差别 vlan的配置思路 总结 实验 混杂的产生 世界只有一个,万物皆有其价值,我们的互联网也如此。众所周知,在思科设备二层设备中只有access和trunk,而华为多出一个混杂模式(hybrid...
  • 华为VLAN划分配置

    2018-07-10 22:21:32
    system-view ----进入系统试图[Huawei]vlan 10 ----创建vlan10[Huawei]vlan batch 11 to 20 -----创建vlan11至20 连续的19个vlan[Huawei]vlan batch 25 30 35 ------创建不连续的vlan25 30 3...
  • VLAN Aggregation作为普通vlan的拓展技术,肯定是为了弥补普通vlan的一些不足,这个不足就是浪费IP地址,如果每一个vlan都在不同的网段,为了完成三层通信,每个vlan都将有一个vlanif的接口座位网关,并且每一个网段...
  • 华为VLAN规则: 1、所有数据帧在一个交换机内部转发时,必须存在标签 2、在每一个交换机的接口上均存在转发允许列表,只有被允许的流量才能通过该接口进或出 3、流量从一个接口出去时,看允许列表上,决定可以继续...
  • 华为VLAN间通信技术

    2020-07-24 11:31:50
    VLAN之间在二层是分隔开的,如果要实现VLAN之间的通信,必须要借助到三层路由功能。 ·支持VLAN间路由的设备:  1.任意的3层交换机  2.支持以太口起子接口的路由器   单臂路由(Router on a Stick)> 通过使用...
  • 华为Vlan浏览器 使用该软件可以很方便的浏览华为交换机Vlan信息,Vlan所属port信息,可以方便的修改port的vlan信息,再也不用命令行登录方式修改了。该版本支持华为lanswitch系列设备。本软件是纯绿色软件,下载...
  • 华为VLAN配置及使用

    2018-08-31 08:50:42
    二、不同交换机、同VLAN下的PC连接实验步骤:一、搭建拓扑:在交换机中添加vlan:[Huawei]vlan 10[Huawei]vlan 20[Huawei]vlan 30[Huawei]vlan batch 11 12 13 14 15[Huawei]vlan batch 21 to 25查看vlan信息:二、1...
  • 华为交换机配置TRUNK类型 port link-type trunk port trunk allow-pass vlan { { vlan-id1 [ to vlan-id2 ] } & | all 华为交换机配置ACCESS类型 port link-type access port default vlan vlan-id ...
  • 华为VLAN间互访配置

    2018-07-10 23:45:17
    SW2配置[SW2]vlan batch 10 20 30 ----创建VLAN 20 30[SW2]interface Vlanif 20 ---进入vlanif20逻辑接口[SW2-Vlanif20]ip address 192.168.20.254 24 ----配置VLAN20网关IP 子网掩码24位[SW2]interface Vlanif 30 -...
  • 华为vlan划分,单臂路由以及静态路由使所有成员都能上网 华为拓扑图:   IP地址规划如图! 给三台电脑配IP地址    VLAN 划分:   <Huawei>sy 进入视图模式 [Huawei]un in en 关闭...
  • 拓扑图: W1配置: <Huawei>system-view [Huawei]vlan batch 10 20 ...[Huawei-Vlanif10]interface vlanif 20 [Huawei-Vlanif20]ip address 192.168.2.1 24 [Huawei-Vlanif20]quit [Huawei]interface g
  • 华为vlan聚合(超级vlan)配置实例

    千次阅读 2015-05-30 22:55:45
    是指在一个主vlan下包括多个处于同一个IP网段的从vlan,但只需为主VLANif配置IP地址,各从vlan使用主vlanVLANif地址作为网关实现三层互通(ARP proxy)。目的是解决IP地址浪费,提高编址的灵活性。配置聚合vlan...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 12,441
精华内容 4,976
关键字:

华为vlan