精华内容
下载资源
问答
  • 华为交换机常见命令总结 ,内包含交换命令 学习阶段可以使用到路由交换的hcie阶段。更新时间2020年2月8日。pdf文件可以自己可以修改。
  • 交换机命令大全,经典,要的要的赶快下。^_^
  • 华为交换机命令大全

    2013-04-25 08:55:14
    这个还是很好用的
  • 华为交换机常用命令大全

    千次阅读 2021-05-15 18:12:49
    01 — 基础配置命令 ...3、交换机改名 这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 02 — 创建vl...

     

    01

    基础配置命令

     

    1、用户模式

    登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令;

    图片

     

    2、视图模式

    用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可执行设备全局配置的命令;

    图片

     

    3、交换机改名

    图片

    图片

    这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉

    图片

     

    4、进入接口

    图片

     

    5、退出此端口

    图片

     

     

    02

    创建vlan并将端口加入vlan

     

    1、创建vlan

    创建单个vlan

    图片

    批量创建vlan

    图片

     

    2、更改端口的链接类型

    由于华为交换机的端口出厂时默认都是hybrid类型或auto类型的,所以无法立即加入vlan,需要更改端口的link-type后,才可以加入vlan。单个端口更改方式如下:

    图片

    为何要选择access类型??

    因为我们是终端PC与交换机相连,要求PC只能只能和上级交换机通信,所以必须只属于1个vlan

    以太网端口的链路类型有三种:

    Access 类型:端口只能属于1 个VLAN,一般用于交换机与终端用户之间的连接;

    Trunk 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,一般用于交换机 之间的连接;

    Hybrid 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,可以用于交换 机之间连接,也可以用于连接用户的计算机。Hybrid 端口可以允许多个VLAN 的报文发送时不携带标签,而Trunk 端口只允许缺省VLAN 的报文,发送时不携带标签。

    • trunk端口用于交换机相连,pvid必须一致。

    • access 类型只能属于1 个vlan

    • 规模较大的企业局域网,不建议使用vlan1,所以trunk端口不允许vlan1通过

     

    3、端口加入vlan

    图片

    以上的操作是单个操作,如果配置端口比较多就很麻烦,下面我们来批量操作。

     

    4、端口的批量操作——端口组

    原理就是创建一个端口组,把要更改的端口加入到端口组中,然后统一更改类型加入vlan。也可以理解为群组端口,统一配置类型加入vlan.

     

    批量更改,先更改端口类型,再统一加入某个vlan,如下:

    图片

     

    5、vlan的查看

    全局查看vlan信息

    图片

    查看端口与vlan对应关系

    图片

     

    6、允许所有vlan通过

    图片

     

     

    03

    首次登入交换机或路由器

     

    第一次上电和恢复出厂是一样的,我们先说一下恢复出厂设置。

     

    1、恢复出厂设置

    注意Y和N的选项,不要输错。

    图片

     

    2、设置新密码

    新交换机第一次上电,或恢复出厂设置后,要求设置新密码

    出厂自带的用户名是admin,密码是admin@huawei.com

    图片

     

    3、首次保存配置

    第一次保存设置时,需输入文件名,只需按回车

    图片

     

    4、设置日期和时间

    图片

    设置console口的连接方式,可设置为无,仅密码,用户名密码等方式

    图片

     

    5、开启必要的服务和功能

    开启telnet服务,stp功能,http服务

    图片

     

    6、设置vty,telnet登录

    图片

     

    7、设置一个用户用于网页登录

    图片

    由于第一次登录时,console口要求用户名密码登录,所以无法删除本地用户admin,此时可退到<>视图,保存设置,退出交换机,再重新登录。由于我们已经将console口的认证方式改为仅需密码,所以可以再次进入aaa,删除用户admin。删除后,再建立admin,权限,服务类型等,均可由我们自己控制。

    图片

    如遇更新版本的交换机软件,telnet服务要求必须是aaa认证(用户名密码认证),可按上面所述再建立一个用户,service-type设置为telnet。

     

    8、关闭交换机自动弹出配置改变告警

    输入配置命令后设备会提示如下类似信息:

    图片

    这个是配置改变的告警提示信息,不是错误信息,可以配置如下命令屏蔽此信息:

    图片

     

    04

    设置链路聚合

     

    图片

    以上命令建立一个聚合端口,并设置了端口的属性

    图片

    以上命令将G 0/0/25端口加入聚合端口eth-trunk 1,无需更多设置。可将更多的端口加入聚合端口。

     

    05

    交换机DHCP

     

    开启DHCP功能,设置地址池,并应用

    图片

     

    06

    开启流控制功能,限制某些网段互链

     

    主要是限制访客网与办公网、财务网互访

    图片

    注意源地址和目的地址的反向掩码

    图片

     

     

    1

     

     

    end

    展开全文
  • 华为交换机命令配置的中文解释和说明,非常详细
  • 小白也能看懂的华为交换机常用命令大全

    千次阅读 多人点赞 2021-04-16 14:41:05
    01 — ...3、交换机改名 这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 02 — 创建vlan并...

    01

    基础配置命令

     

    1、用户模式

    登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令;

    图片

     

    2、视图模式

    用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可执行设备全局配置的命令;

    图片

     

    3、交换机改名

    图片

    图片

    这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉

    图片

     

    4、进入接口

    图片

     

    5、退出此端口

    图片

     

     

    02

    创建vlan并将端口加入vlan

     

    1、创建vlan

    创建单个vlan

    图片

    批量创建vlan

    图片

     

    2、更改端口的链接类型

    由于华为交换机的端口出厂时默认都是hybrid类型或auto类型的,所以无法立即加入vlan,需要更改端口的link-type后,才可以加入vlan。单个端口更改方式如下:

    图片

    为何要选择access类型??

    因为我们是终端PC与交换机相连,要求PC只能只能和上级交换机通信,所以必须只属于1个vlan

    以太网端口的链路类型有三种:

    Access 类型:端口只能属于1 个VLAN,一般用于交换机与终端用户之间的连接;

    Trunk 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,一般用于交换机 之间的连接;

    Hybrid 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,可以用于交换 机之间连接,也可以用于连接用户的计算机。Hybrid 端口可以允许多个VLAN 的报文发送时不携带标签,而Trunk 端口只允许缺省VLAN 的报文,发送时不携带标签。

    • trunk端口用于交换机相连,pvid必须一致。

    • access 类型只能属于1 个vlan

    • 规模较大的企业局域网,不建议使用vlan1,所以trunk端口不允许vlan1通过

     

    3、端口加入vlan

    图片

    以上的操作是单个操作,如果配置端口比较多就很麻烦,下面我们来批量操作。

     

    4、端口的批量操作——端口组

    原理就是创建一个端口组,把要更改的端口加入到端口组中,然后统一更改类型加入vlan。也可以理解为群组端口,统一配置类型加入vlan.

     

    批量更改,先更改端口类型,再统一加入某个vlan,如下:

    图片

     

    5、vlan的查看

    全局查看vlan信息

    图片

    查看端口与vlan对应关系

    图片

     

    6、允许所有vlan通过

    图片

     

     

    03

    首次登入交换机或路由器

     

    第一次上电和恢复出厂是一样的,我们先说一下恢复出厂设置。

     

    1、恢复出厂设置

    注意Y和N的选项,不要输错。

    图片

     

    2、设置新密码

    新交换机第一次上电,或恢复出厂设置后,要求设置新密码

    出厂自带的用户名是admin,密码是admin@huawei.com

    图片

     

    3、首次保存配置

    第一次保存设置时,需输入文件名,只需按回车

    图片

     

    4、设置日期和时间

    图片

    设置console口的连接方式,可设置为无,仅密码,用户名密码等方式

    图片

     

    5、开启必要的服务和功能

    开启telnet服务,stp功能,http服务

    图片

     

    6、设置vty,telnet登录

    图片

     

    7、设置一个用户用于网页登录

    图片

    由于第一次登录时,console口要求用户名密码登录,所以无法删除本地用户admin,此时可退到<>视图,保存设置,退出交换机,再重新登录。由于我们已经将console口的认证方式改为仅需密码,所以可以再次进入aaa,删除用户admin。删除后,再建立admin,权限,服务类型等,均可由我们自己控制。

    图片

    如遇更新版本的交换机软件,telnet服务要求必须是aaa认证(用户名密码认证),可按上面所述再建立一个用户,service-type设置为telnet。

     

    8、关闭交换机自动弹出配置改变告警

    输入配置命令后设备会提示如下类似信息:

    图片

    这个是配置改变的告警提示信息,不是错误信息,可以配置如下命令屏蔽此信息:

    图片

     

    04

    设置链路聚合

     

    图片

    以上命令建立一个聚合端口,并设置了端口的属性

    图片

    以上命令将G 0/0/25端口加入聚合端口eth-trunk 1,无需更多设置。可将更多的端口加入聚合端口。

     

    05

    交换机DHCP

     

    开启DHCP功能,设置地址池,并应用

    图片

     

    06

    开启流控制功能,限制某些网段互链

     

    主要是限制访客网与办公网、财务网互访

    图片

    注意源地址和目的地址的反向掩码

    图片

     

     

    end            关注微信公众号:厦门微思网络

    展开全文
  • 本文档介绍了S9300中各特性的配置命令,包括每条命令的功能、格式、参数、视图、缺省级别、使用指南、举例和相关命令。 向下兼容 包含中低端交换机命令解释
  • 华为交换机故障诊断命令display怎么用?华为交换机如果出现问题会使用display命令进行故障诊断,该怎么使用display命令呢?下面我们就来看看详细的教程,需要的朋友可以参考下
  • 华为交换机 display命令 . 
  • cisco交换机命令和华为交换机命令的对比,其实有很多共同之处,cisco交换机命令和华为交换机命令都很常用,华为交换机命令还可在H3C上使用
  • 无线通信技术,ensp配置命令代码,史上最全华为路由器交换机配置命令大全
  • 华为交换机配置命令超详解,华为交换机配置命令超详解
  • 史上最全华为路由器交换机配置命令大合集(辛苦整理),史上最全华为路由器交换机配置命令大合集(辛苦整理)
  • 华为常用命令锦集.chm

    2020-08-22 20:08:37
    史上最全华为路由器交换机配置命令大合集,熟练掌握下面的华为路由器交换机配置知识点,你只需花几分钟的时间就能明白华为路由器交换机配置。交换机的配置命令等等
  • 主要介绍了华为交换机常用命令以s5700-SI为例,需要的朋友可以参考下
  • 熟练掌握华为路由器交换机配置知识点,你只需花几分钟的时间就能明白华为路由器交换机配置、交换机的配置命令等等。下面就为大家介绍了华为交换机监控口配置命令大全,大家参考下
  • 华为交换机基本命令

    万次阅读 多人点赞 2018-11-10 21:10:55
    命令不区分大小写,支持“Tab”键补全,支持命令简写。 一、常用命令 用户视图 &lt;Huawei&gt;   进入系统视图 &lt;Huawei&gt; system-view 或者 sys 或者 system [Huawei]   更改设备...

    命令不区分大小写,支持“Tab”键补全,支持命令简写。


    一、常用命令

    用户视图

    <Huawei>

     

    进入系统视图

    <Huawei>  system-view   或者  sys  或者 system

    [Huawei]  

     

    更改设备的名字

    [Huawei] sysname  HW  

    [HW]

     

    进入接口视图

    [Huawei]interface Ethernet0/0/1  或者int         interface 接口类型+接口编号 

    [Huawei-Ethernet0/0/1]

     

    关闭接口

    [Huawei-Ethernet0/0/1] shutdown

    开启接口

    [Huawei-Ethernet0/0/1] undo shutdown

     

    查看vlan

    display vlan 或者 dis vlan

     

    查看当前配置:display  current-configuration 或者 display cu

    查看已保存配置:display saved-configuration  或者  display sa

    查看版本: display version

     

    保存配置:save

    清除已保存的配置:reset saved-configuration

     

    返回上级视图:quit

    返回用户视图:return

     

    重启设备:reboot

     

     

    二、配置和管理Vlan

    #1.基于接口划分VLAN -- 静态

    创建vlan  

    [Switch] vlan 10

    [Switch] vlan batch 10  20  同时创建两个vlan

    [Switch] vlan batch 10 to 20  创建10-20的vlan

     

    进入接口模式

    [Switch]  interface Ethernet0/0/1

    [Switch-Ethernet0/0/1]

     

    配置接口类型为Acces接口

    [Switch-Ethernet0/0/1]  port  link-type  access

    [Switch-Ethernet0/0/1]  port default vlan 10           配置接口所属的VLAN

     

    配置接口类型为Trunk口

    [Switch]  interface Ethernet0/0/3

    [Switch-Ethernet0/0/3]  port link-type trunk    

    [Switch-Ethernet0/0/3]  port trunk allow-pass vlan 10  20   配置接口所属的VLAN

                          port trunk allow-pass vlan all  运行所有vlan通过

     

    简写:int e0/0/1   int g0/0/1

     

     

    设置vlan描述

    [SW] vlan 10

    [SW-vlan10]  description  xxxxx  设置该vlan描述

     

    设置接口组(批量设置)

    [SW]  port-group vlan 10

    [SW-port-group-vlan10]  group-member Ethernet0/0/1  to Ethernet0/0/8

     

    # 2.基于MAC地址划分VLAN  -- 静态

    华为交换机上所有二层以太网端口缺省都是Hybrid类型并且发送数据帧时都是不带VLAN标签的

    如果该交换机的缺省配置有改变,需要重新恢复其缺省配置

    <HUAWEI>  system-view  

    [HUAWEI]  vlan 10       管理vlan10

    PC的MAC地址与VLAN 10关联

    [HUAWEI-Vlan10]  mac-vlan mac-address 22-22-22  

    [HUAWEI-Vlan10]  mac-vlan mac-address 33-33-33  

    [HUAWEI-Vlan10]  mac-vlan mac-address 44-44-44  

    [HUAWEI-Vlan10]  quit

    配置接口加入的VLAN10

    [HUAWEI] interface ethernet 0/0/1  

    [HUAWEI-Ethernet0/0/1] port hybrid Untagged vlan 10   允许VLAN 10的数据帧通过,且发送时不带VLAN标签[HUAWEI-Ethernet0/0/1] quit  

    [HUAWEI] interface ethernet 0/0/2

    [HUAWEI-Ethernet0/0/2] port hybrid Tagged vlan 10    允许VLAN 10的数据帧通过,且发送时带有VLAN标签 [HUAWEI-Ethernet0/0/2] quit  

     

    启用基于MAC地址的VLAN划分功能

    [HUAWEI] interface ethernet 0/0/1  

    [HUAWEI-Ethernet0/0/1] mac-vlan enable    

    [HUAWEI-Ethernet0/0/1] quit  

     

    三、链路和接口类型

    两种链路: 接入链路(Access Link) 、干道链路(Trunk Link)

     

    四种接口:  Access接口、   Trunk接口、  Hybird接口、  QinQ接口

    分别连接:   终端            交换机                         公网

     

     

    概述:

    Access类型:端口只能属于一个vlan,一般用于连接计算机。

     

    Trunk类型:端口可以属于多个vlan,可以接收和发送多个vlan报文,多用于交换机之间。

     

    Hybrid类型:端口可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于交换机之间,也可以用于连接用户主机。  

     

    Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为Hybrid端口。

     

     

     

     

     

     

     

    配置交换机的管理

    [SW] interface vlanif10                创建vlan的vlanif接口

    [SW-vlanif10] ip address 1.1.1.1       创建vlanif的接口ip

     

    [SW]telnet server enable      开启telnet

    [SW]user-interface vty 0 4     开启vtf线路模式,开启0-4的5个用户终端

    [SW-ui-vty0-4]

    [SW-ui-vty0-4]  protocol inbound telnet   配置telnet协议

    [SW-ui-vty0-4] authentication-mod aaa     配置认证方式

    [SW-ui-vty0-4] quit

    [SW]  aaa

    [SW-aaa] quit

    <SW> save    用户视图下保存配置

     

    aaa服务器是验证、授权和记账(Authentication、Authorization、Accounting )

     

     

     

     

     

     

    其他概念:

    交换机Console口连接计算机串口。

    vlan(虚拟局域网)工作在第二层和第三层。

    每个vlan都形成一个广播域。

    vlan间通信需要通过路由器(第三层)组成的主干网段。

     

    静态vlan配置:基于端口 (管理员手动分配)

    动态vlan配置:基于MAC 或 IP

     

     

    STP生成树Spanning Tree Protocol

    网络中,存在二层环路的主要原因是对设备或链路存在冗余备份,以保障网络的可靠性。

    如果二层交换网络中存在环路,则会导致广播风暴、帧的重复复制、MAC地址表动荡

    生成树协议能发现并自动消除荣誉网络扩扑中的环路

     

    STP生成树协议作用:

    1. 消除环路:通过阻断冗余链路来消除环路()
    2. 链路备份:当活动路径发生故障是,激活备份链路,恢复网络连通性。

     

    生成树算法:进行环路分解

     

     

     

     

     

    展开全文
  • 华为交换机基础配置命令参考

    万次阅读 多人点赞 2019-03-24 10:06:03
    华为交换机基础配置命令参考 基础配置 用户模式 登陆设备后,直接进入用户模式,只能执行少量查看配置的命令; 视图模式 用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令; 局部配置...

    华为交换机基础配置命令参考

    基础配置

    用户模式

    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令;

     

    视图模式

    用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令;

     

    局部配置模式

    视图模式下,输入局部配置命令,如interface GE 1/0/0,进入GE1/0/0端口配置模式,

     

    此外局部配置模式有很多种,可根据不同需求进入vlan配置模式、端口聚合配置模式等,可输入?,查看当前模式下,能执行哪些命令;

     

    输入quit返回上一层配置模式,输入commit提交已有配置,用户模式下输入save保存配置;

     

     

    查看设备信息

    <HUAWEI>display version

     

    其中关键信息有:

    软件版本:Version 8.130 (S6800 V800R013C00SPC560B560)

    设备型号:HUAWEI S6800

    运行时间:0 day, 0 hour, 15 minutes

     

    查看和修改系统时间

    <HUAWEI>display clock

    <HUAWEI>clock datetime 12:00:00 2018-01-01

     

     

    修改设备名称

    <HUAWEI>system-view

    [~HUAWEI]sysname CE6800

    如果没有commit,需退出一次系统视图模式后保存;

     

     

     配置设备说明信息

    添加登录设备说明内容,举例:Only the administrator can configure the equipment

    [*CE6800]header shell information "Only the administrator can configure the equipment!"

     

    退出视图模式后可见

     

     

    配置console登录认证方式及超时时间

    Console登录:默认console登录无密码,任何人通过串口线直连设备console接口,可直接修改配置,管理员可配置console密码,登录不需要用户名,初次配置时使用console;

     

    超时时间:指连接设备后,一段时间内无操作,系统自动退出,需重新登录,默认超时时间为10min;

     

    进入console配置模式

    [*CE6800]user-interface console 0

     

    Console认证方式为password

    [*CE6800-ui-console0]authentication-mode password

     

    设置console密码为密文形式huawei@123

    [*CE6800-ui-console0]set authentication password cipher huawei@123

     

    设置超时时间为20min

    [*CE6800-ui-console0]idle-timeout 20 0

     

    使用quit返回视图模式,保存后使用display this检查配置结果,乱码是加密后的密码;

     

     

    Telnet 配置

    配置密文登录验证

    进入vty配置模式,0 4表示允许5个并发telnet连接

    [~CE6800]user-interface vty 0 4

     

    指定认证方式为password,出现要求使用aaa认证提示信息,暂时忽略

    [~CE6800-ui-vty0-4]authentication-mode password

     

     

    配置telnet使用密文认证,密码Gauss_234

    [*CE6800-ui-vty0-4]set authentication password cipher Gauss_234

     

    配置用户等级3,缺省为级别1

    [*CE6800-ui-vty0-4]user privilege level 3

     

    退出保存后,使用display this查看配置

     

     

    用户等级说明

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。
    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

     

    注:某些型号设备用户等级有0-15级,区分更细,其中15级与LEVEL 3权限一致,配置时需依据具体情况而定。

     

    配置aaa登录认证

    aaa认证

    authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处radius(远程拨号认证系统)服务或hwtacacs(华为终端访问控制系统)服务器完成认证/授权;

     

    进入vty配置模式

    [~CE6800]user-interface vty 0 4

     

    退出vty配置模式后,进入aaa配置模式

    [*CE6800]aaa

     

    配置本地用户huawei密码为密文Gauss_234

    [*CE6800-aaa]local-user huawei password cipher Gauss_234

     

    配置huawei用户服务类型为telnet

    [*CE6800-aaa]local-user huawei service-type telnet

     

    配置huawei用户特权等级15(模拟器不支持此配置,只有用户等级0-3)

    [*CE6800-aaa]local-user huawei privilege level 15

     

    配置完成后查看结果,其中aaa认证模式无特殊要求,均采用默认模式

     

     

    telnet登录时会要求输入username和password

    配置设备超级密码

    超级密码

    在用户权限较低时(例如Telnet登陆时,可以定义权限级别为0戒1),此时

    可以使用super命令迚行权限提升。为避免非法权限提升带来的危害,应该配置

    超级密码迚行防护。

     

    为CE6800设置超级密码,密码以simple(明文)方式存储(模拟器不支持)

    [*CE6800]super password simple huawei

     

    保存及查看配置

    保存所有配置信息,先提交后保存

    [~CE6800]commit

    <CE6800>save

     

     

    查看已保存的所有配置

    [*CE6800]display saved-configuration

     

    查看当前所有配置

    [*CE6800]display current-configuration

     

     

    IP及路由配置

    配置接口IP

    拓扑图如下:

     

    CE6800配置

    [*CE6800]undo portswitch batch GE 1/0/0                                                  GE 1/0/0开启三层转发

    [*CE6800]interface GE 1/0/0                                                                       进入接口配置模式

    [*CE6800-GE1/0/0]ip address 10.0.12.1 24                                                配置IP及netmask

    [*CE6800-GE1/0/0]description this port connect to CE12800 GE 1/0/0      添加端口说明(可选)

    [*CE6800-GE1/0/0]undo shutdown                                                             激活接口

    [*CE6800-GE1/0/0]quit                                                                               退出接口配置模式

    [*CE6800]commit                                                                                        提交配置

     

    保存后查看配置:

     

     

    CE12800配置

    配置GE 1/0/0地址为10.0.12.1 24

    其余配置与CE6800相同,查看配置结果如下

     

     

    从CE6800 ping 对端CE12800,测试连通性

     

     

    配置静态路由

    接上一个案例,拓扑图如下:

     

    目标:让CE6800能ping通CE6850上的8.0.10.2

     

    在CE12800上,配置GE 1/0/1接口IP为8.0.10.1/24

     

     

    在CE6850上,配置GE 1/0/0 接口IP为8.0.10.2/24

     

     

    网络连通后,尝试从CE6800 ping CE6850上的8.0.10.2,结果ping不通;

    查看CE6800路由表,没有去往8.0.10.0/24的路由

     

     

    在CE6800上添加去往8.0.10.0/24的静态路由,下一跳地址应为CE12800上的10.0.12.2

    [*CE6800]ip route-static 8.0.10.0 24 10.0.12.2

     

    再尝试从CE6800 ping CE6850上的8.0.10.2,结果仍然ping不通,

    原因是CE6850没有去往10.0.12.0/24网段的路由,导致ping数据包“有去无回”;

    在CE6850上添加去往10.0.12.0/24的静态路由,下一跳地址应为CE12800上的8.0.10.1

    [~CE6850]ip route-static 10.0.12.0 24 8.0.10.1

     

    提交保存后,CE6800可以ping通CE6850上的8.0.10.2;

     

    查看CE6800、CE12800及CE6850路由表,分别如下图

     

     

    注意到Proto字段,有两种类型:Direct直连和Static静态,

    其中CE12800路由均为直连,Pre字段为0,

    而CE6800和CE6850有两条静态路由,Pre字段为60,

    Pre表示路由优先级,越小越优,路由会优先匹配;

     

    华为路由器默认协议优先级如下表

     

    其余协议均为动态路由协议,包括:

    OSPF(开放式最短路径优先协议)

    RIP(路由信息协议)

    IS-IS(中间系统到中间系统协议)

    BGP(边界网关协议)

     

    配置默认路由

     

    该拓扑图中,在CE6800和CE6850上配置默认路由,也可以互相ping通,配置示例如下:

     

    CE6800配置:

    [~CE6800]ip route-static 0.0.0.0 0.0.0.0 10.0.12.2

     

    CE6850配置:

    [~HUAWEI]ip route-static 0.0.0.0 0.0.0.0 8.0.10.1

     

    分别查看路由表:

     

     

    利用默认路由,拓扑图中两端设备也可以互相ping通;

     

    配置端口聚合

    LACP协议

    LACP,基于IEEE802.3ax标准的LACP(Link Aggregation Control Protocol,链路汇聚控制协议)是一种实现链路动态汇聚的协议。LACP协议通过LACPDU(Link Aggregation Control Protocol Data Unit,链路汇聚控制协议数据单元)与对端交互信息

     

    静态LACP汇聚由用户手工配置,不允许系统自动添加或删除汇聚组中的端口。汇聚组中必须至少包含一个端口。当汇聚组只有一个端口时,只能通过删除汇聚组的方式将该端口从汇聚组中删除。静态汇聚端口的LACP 协议为使能状态,当一个静态汇聚组被删除时,其成员端口将形成一个或多个动态LACP 汇聚,并保持LACP 使能。禁止用户关闭静态汇聚端口的LACP 协议。

    动态LACP汇聚是一种系统自动创建或删除的汇聚,动态汇聚组内端口的添加和删除是协议自动完成的。只有速率和双工属性相同、连接到同一个设备、有相同基本配置的端口才能被动态汇聚在一起。即使只有一个端口也可以创建动态汇聚,此时为单端口汇聚。动态汇聚中,端口的LACP 协议处于使能状态。

     

    端口聚合配置示例

    拓扑图如下:

     

    CE6850的GE1/0/1~GE1/0/3分别直连对端CE12808的GE1/0/1~GE1/0/3,将三条链路做链路聚合(channel);

     

    CE6850配置如下:

    [~CE6850]interface Eth-Trunk 1                                                进入Eth-Trunk子配置模式,

    [*CE6850-Eth-Trunk1]mode lacp-dynamic                                 选择lacp动态模式

    [*CE6850-Eth-Trunk1]lacp max active-linknumber 1                                          

    [*CE6850-Eth-Trunk1]least active-linknumber 1                                              

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/0

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/1

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/2                                 将三个端口加入Eth-Trunk 1

    [*CE6850-Eth-Trunk1]commit                                                   提交配置

     

    CE12808配置与CE6850相同;

     

    查看Eth-Trunk 1配置

     

     

     

    两端设备的三根连线形成链路聚合,逻辑接口为Eth-Trunk 1

     

    展开全文
  • 华为交换机,路由器命令集合,手边最方便、好用的的工具书
  • 华为交换机命令手册,包含两个主文件,一个为chm形式的手册,另一个是从官网下载的文档
  • 华为交换机display命令大全 很好很实用
  • 介绍了一些华为3COM交换机命令,用好他可以大大方便我们日常工作。
  • 华为路由器交换机命令大全超级手册
  • 华为入门级三层交换机S系列配置操作详解,用于控制台登陆或tel登陆配置交换机
  • 华为交换机基本配置命令大全

    千次阅读 2019-12-02 13:42:16
    查看万兆端口模块收发光:display transceiver ...命令 命令解释 system 进入系统视图 system-view 进入系统视图 quit 退到系统视图 undo vlan 20 删除vlan 20 sysname 交换机命名 disp vlan 显示vlan...
  • 华为交换机命令大全,免费下载给大家。
  • 主要介绍了华为交换机基本配置命令详解,需要的朋友可以参考下
  • eNSP - 华为交换机常用命令

    万次阅读 多人点赞 2019-08-30 21:14:55
    eNSP是一款由华为提供的免费的、可扩展的、图形化操作的网络仿真工具平台,主要对企业网络路由器、交换机进行软件仿真,完美呈现真实设备实景,支持大型网络模拟,让广大用户有机会在没有真实设备的情况下能够模拟...
  • 使用IPOP 4.1软件的FTP功能,剩下所有的调试命令这里面都有提示 可以查看到 华为交换机版本升级指导.docx
  • H3C华为交换机配置命令大全

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 10,259
精华内容 4,103
关键字:

华为交换机命令大全