华为单臂路由

     单臂路由,即在路由器上设置多个逻辑子接口,每个子接口对应一个vlan。在每个子接口的数据在物理链路上传递都要标记封装。Cisco设备支持ISL和802.1q(dot1Q)协议。华为只支持802.1q。

        DOT1Q和ISL的区别:DOT1Q是各类产品的VLAN通用协议模式,Dot1q是一种普遍使用的标准,适用所有交换机与路由设备。支持超过1024vlan,而ISL最多支持1024个vlan。ISL是CISCO设备的专用协议,适用于Cisco设备。 ISL(Interior Switching Link)交换机间协议用于实现CISCO交换机间的VLAN中继。它是一个信息包标记协议,在支持ISL接口上发送的帧由一个标准以太网帧及相关的VLAN信息组成。

需求:在局域网中,通过交换机上配置vlan可以减少主机通信广播域的范围,当vlan之间有部分主机需要通信,单交换机不支持三层交换时,可以采用一台支持802.1Q的路由器实现vlan的互通,这需要在以太网口上建立子接口,分配IP地址作为该vlan的网关,同时启动802.1Q。

组网:路由器E0/0/0端口与交换机的上行trunk端口(E0/0/1)相连,交换机下行口划分2个vlan,带若干主机。

实验拓扑:

clip_image002

1、路由器配置:

#

interface Ethernet0/0/0

#

interface Ethernet0/0/0.1 //定义子接口E0/0/0.1

vlan-type dot1q 10 //指定以太网子接口属于vlan 10,此命令应用在以太网子接口上。只有配置了该命令之后,以太网子接口才会根据配置的Vlan ID号在以太网帧头中嵌入vlan标签,与该网口相连的交换机接口才能正确处理接收到的帧。

ip address 192.168.10.254 255.255.255.0

#

interface Ethernet0/0/0.2 //定义子接口E0/0/0.2

vlan-type dot1q 20 //指定以太网子接口属于vlan 20

ip address 192.168.20.254 255.255.255.0

#

2、交换机配置:

#

vlan 10

description to-market

vlan 20

description to-caiwubu

#

#

interface Ethernet0/0/1 //将E0/0/1设为trunk口

port link-type trunk

port trunk allow-pass vlan 2 to 4094 //允许所有vlan流量通过

#

interface Ethernet0/0/2 //将E0/0/2加入到vlan 10

port link-type access

port default vlan 10

#

interface Ethernet0/0/3 //将E0/0/3加入到vlan 20

port link-type access

port default vlan 20

#

3、在工作站上检查网络是否连通

clip_image004

Vlan 10可以ping通vlan 20

clip_image006

Vlan 20可以ping通vlan 10

4、在路由器上查看路由表。可以发现,由于192.168各网段都是直连路由,故不需启用路由协议或静态路由即能实现vlan之间的通讯。

[zydx]dis ip routing-table

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Tables: Public

Destinations : 6 Routes : 6

Destination/Mask Proto Pre Cost Flags NextHop Interface

127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0

127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

192.168.10.0/24 Direct 0 0 D 192.168.10.254 Ethernet0/0/0.1

192.168.10.254/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/0.1

192.168.20.0/24 Direct 0 0 D 192.168.20.254 Ethernet0/0/0.2

192.168.20.254/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/0.2

[zydx]